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INTRODUCTION

The purpose of this project was to develop a graphical utility interface (GUI) with the air pollution
dispersion models: CALINE3' and CAL3QHC? for use at the Florida Department of Transportation
(FDOT). The scope of the project was expanded to include various requirements to allow the GUI to be
easier to implement and more user friendly. Graphical input, in the form of a spreadsheet format, is made
easy with on-line help, error checking, and color identification. This permits a quick and easy review of
the input files. Ease of input, along with plotting capabilities of the modeled highway or intersection,
greatly help the air quality analyst to avoid common mistakes during input and permit a quick and easy
way to view the geometry of the input. Problems avoided include dealing with fixed field input formats
required for FORTRAN input files, incorrect specification of input variables, and incorrect coordinate

input data.

PROJECT DESCRIPTION

The FDOT authorized this project in September of 1993. Since that time, software was selected,
program needs were defined, a prototype was written and submitted to FDOT for review, extensive
testing was accomplished, and a final program was written. The GUI programs developed have been
named CALVIEW and CALQVIEW, corresponding to the U.S. Environmental Protection Agency
(EPA) promulgated models: CALINE3 and CAL3QHC. This report describes that work, conducted by
the University of Central Florida (UCF) and presents a user manual for the programs.

1 Benson, P. , Ccaline-3: A Vesatile Dispersion Model for Predicting
Air Pollutant lLevels Near Highways and Arterial Streets, Report No.

FHWA/CA/TL-84/15, California Department of Transportation, Office of
Transportation Laboratory, Sacramento, CA, 1984.

2 Schattanek, G. and T. Stranton, CAL3QHC, A Modeling Methodology

for Predicting Pollutant Concentrations Near Roadway Intersections

User Guide, Parsons, Brinckerhoff, Quade & Douglas, Inc., New York,
1990.



A. Software Selection.

The first task completed was to select an appropriate software package for implementing the GUL It
was originally thought that the language C++ would be the best choice. This was because other software
packages had been developed for FDOT using this software. Unfortunately, during initial programming,
many problem areas were found using this software for the intended purposes. First, printer drivers had
to be included for every type of printer that would be used. Not only would this have been time
consuming, but would have been quite costly. Defining only a few printer types could lead to
incompatibilities during program use. Second, programming the desirable options was clumsy and
inefficient. Third, the program would not have allowed future enhancements to be done very easily.

To overcome these difficulties, other software was reviewed. The selected software was Visual Basic, a
Microsoft Corporation product. Visual basic, running in a Windows® environment, eliminated all of the
problems previously described, and added increased flexibility during project development. Not only
could all printers be supported, programming was extremely efficient, and future enhancements will be
much easier. In addition, Visual Basic was selected because of its compatibility with current systems and
its future compatibility as digital operating systems (DOS) change. A major concern during the software
selection process was the requirment that the FDOT user have Windows. To this end, software
projections were strongly considered. The standard operating systems now is use (Microsoft DOS,
Digital Research DOS, or IBM DOS) will soon be obsolete. This is because of a tendency of the IBM
compatible computer users to “migrate” toward a Windows environment. Windows now runs as a
program in DOS, but will be released in the Fall of 1994 or Spring of 1995 as a complete operating
system. IBM has previously released another operating system called OS-2. As such, programs written
for the existing DOS would require continued support by FDOT of software being phased out by
suppliers. In addition, the new software currently being developed by the Federal Highway
Administration (FHWA) for noise analysis will also be Window based. This will require FDOT to
support Windows for environmental analysis. Because of all of these considerations, Microsoft Visual
Basic, Version 3.0, running in a Windows environment was finally selected.

B. Defining Program Requirements.

The intent of this software was to increase productivity of the FDOT air quality analyst by simplifying
the input process, allowing a quick review of input, and eliminate common errors by allowing the analyst
to plot the highway or intersection being analyzed. To accomplish these tasks, Dr. Ron Eaglin, under the
direction of the principal investigator Dr. Roger L. Wayson, developed the software for the specific
requirements. The programmer/engineer tandem permitted the software requirements to be compared to
the practical aspects of implementing the program. Compromises were allowed by Dr. Wayson if
suitable alternatives to the original plan were possible. In cases where exact program details were

3 Windows is a brandname of the Microsoft Corporation.



needed, no compromising of the programming effort was allowed and the programmer was directed
accordingly.

Minimum requirements were required as initially proposed. These requirements included:

e easy entry of data without regard to column, line, or other format details;
e allowing a quick review and edit of input data,

e plan view plotting of the highway or intersection being modeled,

e zoom in/out capabilities at intersections;

¢ panning to allow screen adjustment to proper location during zoom functions; and,

print capabilities for both the plot and input.

During the development of the software, other requirements were defined beyond these minimal
requirements. This occurred during testing at UCF and a review by FDOT. These additional

requirements included:

e setting input parameters to defined default values where repetition occurred;
e use of a spreadsheet type input format rather than the typical box screen edit;
¢ alisting of units for each variable visible-on the input screen;

¢ color identification for input screens and plotting;

¢ anorth arrow on plots so wind direction could easily be verified;

e color coded numbering of links, and receptors on the plot for easy identification;

e displaying link widths for verification of input;



¢ error checking for completeness and correct character type;

e color backgrounds for easy reading;

¢ plotting of the axis (X, Y) to allow detailed viewing;

¢ outline of modeled area to allow easy definition of project limits;

¢ on-line help on using CALVIEW or CALQVIEW,

¢ running of the CALINE3 or CAL3QHC programs without exiting CALVIEW or CALQVIEW; and,

e areview of the output without exiting CALVIEW or CALQVIEW.

All of these requirements were included in the final program.

C. Development of a Prototype.

Concurrently with defining program requirements, programming was accomplished. As the requirements
were derived and programmed, a working prototype was developed in June, 1994. This prototype was
tested extensively and then passed on to the project administrator at FDOT (Ms. Amy Datz) for review
and comment. The testing at UCF and the detailed comments received from FDOT allowed the final

software package to be developed.
D. Testing.

As with all software, “bugs” are inevitable. To test for these problems in CALVIEW and CALQVIEW,
over 400 tests were performed by Dr. Wayson, Dr. Eaglin, and Ms. Stephanie Polesnak-Gimer. These
tests were on a variety of geometric designs ranging from simple highways to very complex, multiple
intersection files. During the tests, efforts to cause the program to “bomb” were included. Also,
program options were tested during the evaluation of the various geometric designs. These tests further
identified some desirable enhancements that were included in the final software. The results of these

tests were then used to produce the final requirements and software.



E. Final Program.

The final program is a self-contained package, capable of being used in conjunction with either CALINE
3 or CAL3QHC. 1t is very user friendly, requiring very little training. On-line help is available to help
the inexperienced user. In addition, all Window commands, such as copy and paste, are available to the
user. This means that input may be copied directly between CALINE3 or CAL3QHC input files. In
essence, large portions of input files can be “dropped” into new files being built. Existing files may be
read and easily edited using a spreadsheet format, rather than dealing with columns and line format.
Separate spreadsheet formats allow input of link, receptor, and meteorological inputs very easily.

A detailed user manual has been included as an Appendix to this report.

CONCLUSIONS AND RECOMMENDATIONS FOR IMPLEMENTATION

The program is ready for immediate implementation. Since the software used by EPA and FHWA are
unchanged, no formal approval process is needed. It is suggested that implementation be accomplished
by FDOT sending copies of the software and the user manual to each district office or other state
agencies. No formal training should be required as the program is extremely user friendly.

In addition, other users such as consultants or users outside of the state may be provided access to the
software. The software is appropriate for most states. Several entities have already requested copies. It
is suggested that FDOT also supply copies to these prospective users upon request, charging as
necessary for the software and copying costs. It may also be desirable for FDOT to submit copies to
EPA and FHWA for their own use. Another possible method of implementation would be distribution

through suppliers such as McTrans.
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1. About CALVIEW

CALVIEW is a preprocessing program for CALINE3'. The program allows you to
graphically view CALINE3 input files, create new input files, edit existing files in a
spreadsheet format, save these files in CALINE3 input format, run CALINE3 using the
current input file, and view the output of the CALINE3 run. The program was written at
the University of Central Florida by Dr. Ronald D. Eaglin under the direction of the
principal investigator, Dr. Roger Wayson, for the Florida Department of Transportation.
Ms Amy Datz was the project coordinator for the Florida Department of Transportation.

2. About CALQVIEW

CALQVIEW is a preprocessing program for CAL3QHC?. The program allows you to
graphically view CAL3QHC input files, create new input files, edit existing files in a
spreadsheet format, save these files in CAL3QHC input format, run CAL3QHC using the
current input file, and view the output of the CAL3QHC run. The program was written at
the University of Central Florida by Dr. Ronald D. Eaglin under the direction of the
principal investigator, Dr. Roger Wayson for the Florida Department of Transportation.
Ms Amy Datz was the project coordinator for the Florida Department of Transportation.

3. Getting Started

The user of the preprocessing program should be familiar with the dispersion model being
used; either the CALINE3 or the CAL3QHC computer program. All input is specific to
these programs and completely defined in the appropriate users manual. All variables are
shown by the exact name used in the respective user manual.

All input follows the normal card layout of CALINE3 or CAL3QHC. The purpose of the
CALVIEW and CALQVIEW preprocessors are not to teach the use of CALINE3 or
CAL3QHC, but as an aid for the air quality analyst when using these programs.

CALVIEW and CALQVIEW should not be used until the preliminary work of setting up
the study area is performed. All inputs should be determined. Once you are ready to input
the information, start the program by double clicking on the CALVIEW Icon or the
CALQVIEW Icon in the Traffic Programs group. Typical default values have already
been included for several variables. These may be changed as required. If you are

! Benson, P., CALINE3 - A Versatile Dispersion Model for Predicting Air Pollutant Levels Near

Highways and Arterial Streets, Report No. FHWA/CA/TL-79/23, California Department of
Transportation, Office of Transportation Laboratory, Sacramento, CA, 1979.

2 Schattanek, G. and T. Stranton, CAL3QHC, A Modeling Methodology for Predicting Pollutant
Concentrations Near Roadway Intersections - Users Guide, Parsons, Brinckerhoff, Quade & Douglas, New

York, 1990.



beginning a new file you will select either Receptor Information, Links Information, and
Meteorology Information from the Edit menu. Click Done in each of these forms after the
required information has been entered to save that information. Exiting an input form
without clicking Done will result in lost input! When you exit a form, the entered
information will be plotted graphically on the main screen. Input for all receptors, links
and meteorological variables is required for a successful run of CALINE3 or CAL3QHC.
Error checking has been included to help insure these forms have been completed, but the

analyst should also check for completeness.

After all information is entered through these input forms the file should be saved using
the Save option in the File menu. You may also wish to save at times while using the
program. This is also done using the Save option in the File menu.

4. Opening and Saving Files

In addition to creating new files, existing input files for CALINE3 and CAL3QHC can be
opened, reviewed, edited and/or saved using CALVIEW or CALQVIEW.

To Open an existing file select Open from the File menu. CALVIEW will look for
programs in the specified directory with a .D* extension. CALQHC will look for files
with a .IN extension. If this is not correct, simply use the pull down menu under the file
name listing to change the extension. All files will be selected if *.* format is selected.

To save a file select Save from the File pull-down menu. If you wish to save the file with
a different name select Save As from the File menu. If a new file is desired, simply select
New for the File pull-down menu. All files are saved in CALINE3 or CAL3QHC ready
format. CAL3QHC files are automatically saved with a .IN extension. CALINE3 files are
saved with a .DAT extension. These extensions may be changed to suit user preference by

typing in the preferred file name.

S. Editing Files

CALVIEW and CALQVIEW use a spreadsheet format for entering information. The user
doesn’t have to worry about file format, number of decimal places, or position in the input

file. All of these details are handled by the program.

Receptor, Link, and Meteorology information are all input into spreadsheet as fields.
These fields are divided by vertical lines shown on the spreadsheet format input form.
Each field is labeled by the exact name shown in the respective user manual. Units are
shown on the input form. If an input is required then the spreadsheet field will be yellow
and will allow input to be typed into the field. Spreadsheets which contain multiple input
options will present fields that are not required for that option as gray fields. When you
are done entering information, click the Done button. If you wish to exit the spreadsheet



without saving changes double click the box in the upper left corner of the form. At any
time information from a spreadsheet can be sent to the Windows clipboard. Hold down

the left button on the mouse and drag it over the information you wish to select. Next hit
the Control-Insert keys and the information will be sent to the clipboard. To retrieve this
information for pasting into a document or new input form, position the cursor at the
proper location and hit Shift-Insert. The highlighted information will be pasted starting at

the location of the cursor.

Moving around the spreadsheet input format is accomplished by using the arrow keys or
mouse. The tab key will move between the “button” options shown on the input forms.

A. Receptor Editor (CALVIEW)

The receptor editor allows for direct input of CALINE3 cards 1 and the array of card(s) 2
as shown in Figure 1. Click the done button when done inputting information to keep all

information. Information will not be saved to disk until the File, Save option is used.
Receptor information
ATIM ZO VS VD NR SCAL

[eo 175 0. 0.8 030485

Ctri-Hins - Copy
Receptor Name XR YR ZR Shift-Ins - Paste

;fg ATIM-Averaging Time (min)
et Z0-Surface Roughness (cm)
VS-Settling Velocity (cm/s)
VD-Deposition Velocity (cm/s)
NR-Numbers of Receptors
SCAL-Scale Factor

Figure 1 - CALVIEW Receptor Editor

B. Receptor Editor (CALQVIEW)

The receptor editor allows for the direct modification of CAL3QHC Card 1 and
the array of Card(s) 2. Information can be entered directly into the spreadsheet forms as
shown in Figure 2. Cards can also be inserted and deleted from this spreadsheet as in

CALVIEW.



Job ATIM Z0 VS VD NR  SCAL

l [eo: 0 o0 0 12 0.3048F]
Ctil-ins - Copy
Receptor Na XR YR ZR Shiftns - Paste

L2} ATIM-Averaging Time (min)
Z20-Surface Roughness (cm)
VS-Settling Velocity (cm/s)
VD-Deposition Velocity (cm/s)
NR-Number of Receptors
SCAL-Scale Factor

Figure 2 - CALQVIEW Receptor Editor

C. Link Editor (CALVIEW)

Link information is entered in much the same way as receptor information (see Figure 3).
The Done button should be clicked when you are completed. Cards can be deleted and

inserted in this editing screen.

Edit Link l.llfbf‘;llaliﬁl]- .

Ctrl-ins - Copy
Shift-ins - Paste

YL2 VPHL EFL HL WL

NL-Number of Links EFL-Emission Factor (g/mile)
NM-Number of Met. Conditions HL-Source Height (length)
TYP-SectionType; AGFLBR.DP  WL-Mixing Zone Width (length)
VPHL-Vehicles per Hour ;(Ll .YL]I XL2,YL2-Link Coordinates

Figure 3 - CALVIEW Link Editor



D. Link Editor (CALQVIEW)

Link information is a little more complex in CALQVIEW (see Figure 4). Since there are
two types of links; queue and flow-flow, there is more than one type of link card. The
free-flow link card requires the VPHL and EFL field but not the NLANES field. The
queue card requires NLANES, but not VPHL and EFL. Required inputs are shown in
each field during input by a yellow background. If an input is not needed, then the
background of that field will be gray. The user can modify the type of card (free-flow or
queue) at any time by double clicking the row of the spreadsheet corresponding to the link
card. Queue link cards also require the input of intersection information as shown in
Figure 5. When entering this information, card types which do NOT require input will be
grayed out. Clicking Done will exit you from these editing windows and will keep your

changes.

Edit Lir‘|k illtinrllnaliilll

NL NM Ctrl-ins - Copy  Double-Click - Toggle
e 8 Shiftdns - Paste Free Flow<->Queue

YL1 X2 YL2 VPHL EFL HL WL NLANES

NL-Number of Links EFL-Emission Factor (g/mile)
NM-Number of Geometries HL-Sousce Height (length)
TYP-SectionType; AG.FL.BR.DP WL-Mixing Zone Width (length)
VPHL-Vehicles per Hour XL1 .Y'l‘.]l XL2,YL2-Link Coordinates

Figure 4 - CALQVIEW Link Information



it Signal and Intersection Information

Ctsl-ins - Copy Double-Click - Toggle
Shift-Ins - Paste Free flow <-> Queue

CAVG RAVG YFAC v

IDLFAC SFR ST AT

CAVG-Total Cycle Lenth (sec) IDLFAC-die Emission Factor (g/veh-min)
RAVG-Red Cycle Length [sec) SFR-S aturation Flow Rate (vph)
YFAC-Clearance Lost Time (sec) ST-Signal Type (1.2.3)

IV-Approach Volume {(vph) AT-Arrival Rate (1-5)

Figure 5 - CALQVIEW Queue Link Information

E. Meteorology Editor (CALVIEW)

CALVIEW allows interactive editing of all meteorology cards as shown in Figure 6.

Edn Metémomgy Infoﬁnétion

Ctrl-ins - Copy

U BRG CLAS MIXH AMB Shift-ins - Paste

NM-Number of Met. Conditions
U-Wind Speed (m/s)

BRG-Wind Angle (degrees)
CLAS-Atmospheric Stability Class
Mixing Height (meters)
AMB-Ambient poliutant C [ppm]

Figure 6 - CALVIEW Meterology Editor



F. Meteorology Editor (CALQVIEW)

CALQVIEW allows interactive editing of all meteorology cards as shown in Figure 7. It
should be noted that if a wind angle search (worst case) is to be done, the user should
specify a “Y” under the column marked “VAR” and the upper and lower limits of the
search should be placed in the columns marked VAI(1) and VAI(2).

kdit Metcéwlogy Information
NL NM

NM-Number of Meteorological
Cases

U-Wind Speed (m/s) ' AMB-Ambient pollutant C {ppm) DEGR - Increment angle degiees
BRG-Wind Angle (degrees) CLAS-Atmospheric Stability Class  VAI(1) - Lower variation boundary
MIXH - Mixing Height (meters] VAR - Y for angle variations VAI(2) - Upper variation boundary

U BRG CLAS MIXH AMB VAR DEGR VAI(1) VAI(2)

%gﬁ Ctrk-ins - Copy
H&{ Shiftns - Paste

Figure 7 - CALQVIEW Meterology Editor

6. Graphical Display
A. Graphical Display (CALVIEW)

The program will automatically plot the highway modeled in the main screen after
data entry. CALVIEW has no zoom or pan features. The user should use CALQVIEW if
these options are needed. To print the information select Print Graphic from the File
menu. To print the input file select Print Input File from the File menu.



i ~ Caline 3.0 Fite Editor
File Edit Run Help

’]; \i\ ° ° °

D:\VB\PRDGHAMS\WAYSON\CALVIEW\M‘ISBM‘I 4A.DAT
Figure 8 - CALVIEW Main Screen

The graphical display has a number of options which the user can specify. Select
Display Defaults from the Edit menu. The only option which does not affect the graphical
display is the “Use Commas in Numbers” option. This option will include commas in
large numbers included in the spreadsheet editing screens to allow easy review of such
numbers. (Note: This option may not work on some computers due to data handling
features.) Figure 9 lists the CALVIEW display options.

Dﬁspia‘y Dcfé&ité |
Default Roadway Width for Display 12.192

" Display Defaults
U Show Links with Width

O Display Link Numbers

O Display Receptor Numbers
O Display Axes

O Display Boundaries of File
X Show North Arrow

[0 Use Commas in Numbers

: ie CV]Ei]a] .
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B. Graphical Display (CALQVIEW)

In addition to the selection menu bar at the top of the page, CALQVIEW’s graphical
display has eight pan buttons (2 up ,2 down, 2 left and 2 right) and a zoom in and zoom
out button as shown in Figure 10. This allows the user to detail on exactly what they wish
to see. The large “UP”, large “DN”, left double arrow (<<), and right double arrow (>>)
are faster pan buttons. The small “up”, “down”, and single arrows allow for a finer degree

of panning.

{D:\VB\PROGRAMS\WAYSON\CALVIEW\ALLETEX.CQ3

Figure 10 - CALQVIEW Main Screen

The number of display options is also expanded with CALQVIEW as shown in Figure 11.
The additional options allow a more detailed view of key inputs near an intersections such

as which links are queue or approach (free-flow).
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{)igma»y ngauks

O Show Links with Width O Display Axes

O Display Link Numbers O Display Project Boundaries
O Display Receptor Numbers X Display North Arrow
XiDisplay Queue Links] 0 Use Commas on Numbers

X Display Approach Links

Figure 11 - Display Defaults for CALQVIEW

7. Running Dispersion Models

A. Running CALINE3

The CALINE3 program can be run from within CALVIEW. Select Run CALINE3 from
the Run menu. If you haven’t saved your file you will be prompted to save it at this time
to avoid lost input. You will also be prompted for an output file name. The CALVIEW
program will shell out to DOS and run CALINE3 using your file as the input file and will
place the output of CALINES3 in the specified file. This output file can also be viewed.
When you select “View Output File” from the Run menu, the windows notepad will be

opened and the output file displayed.

B. Running CAL3QHC

The CAL3QHC program can be run from within CALQVIEW. Select Run CAL3QHC
from the Run menu. Your current file will be saved and you will be prompted for an
output file name. Be careful in the selection of this name as program will overwrite old
files without prompting you. You must be able to run cal3ghc successfully from the DOS
prompt to run it from within the program. If the program run is unsuccessful this will be
reflected in View Output File. Consult your CAL3QHC manual about the successful

running of CAL3QHC.

Note: If the program was unsuccessful in running CALINE3 or CAL3QHC, this will be
reflected in the viewed output. In some cases the output file will not be found. This
happens when the CALINE3 or CAL3QHC run was unsuccessful in beginning execution

and so no output was generated.



Also, due to incompatibilities in software compilers, CAL3QHC may not run on many
computers when you shell out to DOS from Windows. CAL3QHC is being recompiled
with a Microsoft Corporation FORTRAN compiler which will resolve this problem. The
recompiled software should be available in October of 1994. If the user does not
recompile or have the newly compiled CAL3QHC, the problem can easily be avoided by
first quiting CALQVIEW (after successful file creation for CAL3QHC) and exit Windows.
The CAL3QHC program can then be run as before.
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