
1 INTRODUCTION 

OBJECTIVE 

This chapter divides into three sections: 

• Computer Aided Drafting and Design (CADD) Standards & File Creation: 

o FDOTSS4 Desktop Folder  

o File Creation 

o Base Project File Creation 

• FDOT Traffic Plans Menu Configuration 

• MicroStation V8i Features/Concepts: 

o Levels 

o Civil Features 

o Text Styles 

o Annotation Scale 

o Models 

GENERAL INFORMATION 

This chapter reviews the FDOTSS4 working environment including how to create design files properly that meet 

Florida Department of Transportation (FDOT) CADD standards and introduces concepts and tools used to make 

producing plans much more efficient. 

EXPLORING THE FDOTSS4 DESKTOP FOLDER 

The FDOT CADD software installation installs a folder named FDOTSS4 on the desktop. This folder contains 

shortcuts to applications used when working on the FDOT projects.  



The figure below shows the contents of the FDOTSS4 folder. 

  

Using these shortcuts to start MicroStation will start the FDOT Workspace environment properly with the FDOT 

CADD standards.  The FDOT delivers shortcuts for starting PowerGEOPAK, MicroStation or MicroStation with 

GEOPAK Suite depending on the registry configuration. 

Note When systems have MicroStation with GEOPAK Suite installed, there are two icons created to open 

the MicroStation session.  One will open with GEOPAK activated and the other will not.  To access 

some of the tools used with this course the icon to open with GEOPAK will be required. 

Using this shortcut to start MicroStation opens MicroStation Manager and sets the workspace, but does not set the 

Project. Set the Project by selecting the drop down arrow and selecting the correct project configuration file or .pcf 

file. The workspace remembers the last project worked in and will use the .pcf file the next time MicroStation opens 

with that workspace. This is important to watch as most designers probably work on more than one project at a time. 

FDOT recommends always to use the .pcf file.  If a .pcf file does not exist for the project or the project does not exist, 

use the Project drop down and select New Project to create the project and/or .pcf file.  This does not overwrite any 

existing files that may already be in the project directory.  

  



CADD STANDARDS & FILE CREATION 

Traffic Plan projects are normally a component of a Roadway plans package. Therefore, the project directory structure 

usually exists prior to beginning work on a Traffic Plans component. If this is not the case, the same directory structure 

and file standards that apply to Roadway apply to any other lead component. The FDOT CADD Manual defines the 

naming convention used to create the different types of design files required in a project. 

CREATING THE PROJECT BASE FILES 

The FDOT recommends using the Create File/Project application to create MicroStation design files and other 

files in accordance with the FDOT standard file naming conventions.  Create File/Project uses an ASCII text 

file, called a Control File (*.ctl) to perform these task(s).  This application can also create projects, although there 

are other recommended methods for creating new projects.  Create File/Project can be accessed from both inside 

and outside of MicroStation.  

  

Note The designer has the option to open the file after creation or create all the design files and open them 

later.  Some files have an associated action such as setting the plot scale or creating models.  Using the 

Open File option at the time of creation initiates these actions to occur.  The Create File/Project dialog 

will remain open in the newly opened file. 

 



Exercise 1.1 Creating the Base Files for a Project 

� In this exercise, you will create Signing and Pavement Marking design files.  

Note This process is the same for any Traffic Plans discipline. 

1. Open the FDOTSS4 folder  on the desktop.  

2. Double click on the Create Files icon . This will open the Create File/Project tool. 

Note When training in the FDOT offices, the user must click the Project Navigator button to allow the Create 

File/Project tool to work locally. 

3. On the top right hand side of the Create File/Project tool, select the Project 

Settings button. This will open Project Settings. 

 

  

4. Click Select Active Project. This will open the Select Active Project dialog. 

   

5. Browse to the Projects folder and select 22049555201. Stop at the root folder. 

  

6. Click the Select button. This selects the project, dismisses the Choose Folder dialog and returns to the 

Select Active Project dialog. 

7. Click OK on the Select Active Project dialog. 

8. Click OK on the Project Settings dialog. This sets the active project. 



� Load Appropriate Control File 

The control file sets, for lack of a better term, the discipline to work in. Traffic Plan files are part of the Roadway 

control file. It is important to know how to do this in case it is required to use a different control file in the future 

or if the standards ever change. 

1. Click the down arrow on the Control File combo box. 

Note  

2. Click on Roadway.ctl. This loads the control file and the Create File/Project application now has 

enough information to begin creating design files in the specified Output folder. 

3. In the File Group category, use the drop down arrow to select Signing & Pavement Marking Files 

(DGN). This sets the file types to Signing & Pavement Marking files and sets the output folder to 

Signing.  

 

4. In the File Type category select the file Proposed Design. This selection populates the Output File and 

Seed File with the correct information. 

Note Create File/Project allows the designer to browse to a different Output Folder if needed. In addition, the 

Workspace field is set to FDOTSS4 by default. 

 

5. Click the Create button at the bottom of the dialog. 



6. Click the OK button to acknowledge the file creation.  Notice below the Create and Open File buttons 

that the file name now display. If the file Dsgnsp01 already exists in this project, the application will 

automatically increment the file name to Dsgnsp02 and will not overwrite the file. 

  

Note Clicking the Open File button next to the Create button at the bottom of the dialog can be used to open 

the file with this tool, which also registers and checks the file out in Project Navigator when the Create 

Edit Application is in TIMS mode.  Also, notice below the Create and Open File buttons that the file name 

is shown. If the file Dsgnsp01 already exists in this project, the application will increment the file name 

to Dsgnsp02 and will not overwrite the existing file. 

  

7. (OPTIONAL) From Create File/Project, click the Open File button next to the Create button at the 

bottom of the dialog.  MicroStation will open the newly created file.  Review file and then Close 

MicroStation 

<OR> Click OK to close Create File/Project, close MicroStation and go on to the (Optional) 

Exercise. 

Exercise 1.2  (Optional) Create Additional Files 

Use the Same File Group to Create Additional Design Files 

1. Using the Create File/Project tool select the Tabulation of Quantity Sheets file. 

2. Select the Create button. 

3. Click OK to acknowledge the file creation. 

4. Repeat steps 1 thru 4 to create the Border for Plan Sheets When Sheet is Referenced file. 

5. Repeat steps 1 thru 4 to create the Summary of Pay Item Sheets file. 

6. Click OK on the Create File/Project tool. This will close the tool. 

  



Exercise 1.3 Starting MicroStation through the FDOTSS4 Desktop Folder 

In this exercise, use the FDOTSS4 folder located on the desktop similar to the previous exercise. This folder contains 

several shortcut icons. It is important to review and understand the use of each icon. 

1. From the FDOTSS4 folder  double click on the icon labeled FDOTSS4. This opens the 

MicroStation Manager dialog and sets the Workspace environment. 

 

2. In MicroStation File Open, select the Project 22049555201. This selection opens the project in the 

correct root directory. 

 

3. Navigate to the Signing folder. 

4. Select the Dsgnsp01.dgn file and click Open or double click on the file to open it. 

5. Once in MicroStation notice that the FDOT Menu appears. Take a moment to become familiar with 

this workspace configuration. 

 



TRAFFIC PLANS MENU 

As seen in the last exercise, FDOT Menu loads when MicroStation is loaded through the FDOT delivered workspace. 

The FDOT Menu, by default, opens in the Standard menu; the FDOT provides the option to configure FDOT Menu 

to load additional discipline menus as needed.  

 

The figure below shows the possible FDOT Menu configurations. 

   

The top portion of the FDOT Menu Configuration dialog provides the option to load one or all of the Standard 

(Roadway) Menu options. For example, one can load Traffic Plans along with Roadway or by itself.  

The bottom portion of the dialog provides options to load the Structures, Right of Way, or Photogrammetry menus. 

The discipline options are available with the Standard (Roadway) and Standard plus Structures Menu, but only loading 

Right of Way or Photogrammetry menus as separate workspaces. Once the options have been selected click the 

Update (wrench icon) button to load/unload menu options or Exit (slashed circle icon) closes this dialog without 

making any changes. 

Note The options selected on the FDOT Menu Configuration dialog control the resources attached to the 

MicroStation session.  If there are resources needed (levels, cells, features, etc.) that are not 

available, check the FDOT Menu options and reset as needed to access the resources. 

 

  



Exercise 1.4 Setting up FDOT Menu to Load the Traffic Plans Menu 

1. Continuing in Dsgnsp01.dgn, select the FDOT Menu option Standard > FDOT Menu Configuration to 

open the FDOT Menu Configuration dialog. 

 

2. Change Configuration options to load the Traffic Plans menu.  

  

3. Click the Update (Wrench icon) button. This will close down MicroStation and reopen the File Open 

dialog.  Select Open to re-open the same file. 

4. Select and hold the solid bar on the left of the FDOT Menu to drag it to a convenient location. 

5. Right click anywhere on the FDOT Menu to access the Context Menu. 

6. From the Context Menu, select Save Settings to set the FDOT Menu 

settings. 

 

 

7. When the FDOT Menu reloads, the Traffic Plans Menu is the only 

discipline menu displayed. Take a moment to become familiar with this 

workspace configuration and the FDOT Menu. 

    



TASK NAVIGATION WORKFLOW 

FDOT PLANS DEVELOPMENT > TRAFFIC PLANS 

The FDOT CADD software includes a customized Task menu, FDOT Plans Development. This menu is 

comprised of smaller discipline/task specific menus containing tools and links organized in step-by-step 

workflows. 

 

 

 

 

 



ATTRIBUTES, TEXT AND MODELS 

LEVELS 

The FDOT has created six Standard Level libraries:  Common, Survey, Right of Way, Roadway, 

Photogrammetry and Structures. There are approximately 1400 levels. The appropriate level library loads upon 

the creation or opening of a MicroStation file using the FDOT workspaces. The level name is a maximum of 18 

characters and has three components:  Level Name, State and View with the format: object_sv  

Where:  (object = Level) _(s = State) (v = View) 

(S)tate Designations (V)iew Designations 

p (proposed) p (plan) 

d (drafting element) r (profile) 

e (existing) x (cross section) 

 m (model) 

An example of a plan view level is: PavtMessage_ep, where: Level = PavtMessage, State = e  and View = p 

Note Some levels do not show a State or View in their name. These levels are by default set to be a proposed 

plan view element. An example is the level (RPM1), created for proposed RPM’s in the plan view. 

The levels symbology (color, weight and style) are set to ByLevel. What this means is that each level already has 

a color, weight and style associated to it. Designers cannot create additional levels. 

RULES & FILTERS 

FDOT has also created a set of Standard Rules that group the Standard Levels together for the purpose of 

Quality Control (QC) checking of the FDOT Standard design files ensuring compliance with the FDOT 

CADD Standards.  FDOT delivers MicroStation Filters to reflect each of these Standard Rules to assist in 

users searching through the level menu.  Discussion on these filters continues later in this section. The 

Standard Level Filters do not turn levels on or off, but they reduce the number of levels visible in the dialog 

box. 

There are several location to very easily active a Standard Level Filter. Level filters can be loaded from the 

MicroStation Attributes Tool Palette, Level Manager, Level Display dialog, etc. There is a drop down 

menu as seen in the figure below to load level filters, but is option is only available when selecting “Active 

Level Filter”. 

Note FDOT presets Standard Level Filters to each Standard File Name. The 

filters automatically set by default to those specific file names upon 

opening of the design file. 

  



Exercise 1.5 Levels and Filters 

This exercise will cover investigating Levels and Level Filters delivered by FDOT. The elements placed in this 

exercise are not part of the final design; they are for experimenting and practicing only. 

1. Continuing with DSGNSP01.dgn in the Class Work model, select the STANDARDS:DSGNSP option 

from MicroStation Attributes tool palette. This sets the active level filter.  

Note As a refresher, a level filter isolates the levels seen in the level dialog so it is easier to navigate. FDOT 

groups the level filters by discipline and sets them by the filename. 

2. In the Attributes tool palette, select the drop down arrow next to the level names. 

 

3. Scroll down and select the level SignSupport that sets the active level and sets the Color, Weight and 

Style to ByLevel. 

4. In the Attributes tool palette, select the drop down arrow next to the level name. 

  



5. Scroll all the way to the top and select Filter: STANDARDS:DSGNSP. This opens the Recall Filter 

dialog. 

  

    

Note This is another way to load level filters. 

6. Scroll down and select Text (fdot_v8_levels). 

7. Click OK. This loads Text Levels filter. 

8. Take a moment to review the levels in this filter. Notice that all levels visible are associated to text.  

9. Now that the Filter is loaded, navigate the level drop down menu and select the level appropriate to place 

the item. Level filters can save time when going from Line work to Text and so on. 

  



CIVIL FEATURES 

Civil Features define the symbology of elements much like using Place Influence with D&C Manager.  The 

difference is, only the civil tools use the Feature definitions.  Each design Feature has only one definition.  Within 

this definition, symbology is set up for each design View.  The tools use the correct symbology for the elements 

drawn based on the type of model or design View (Plan, Cross Section, Profile, or 3D).  FDOT has set up the 

Feature tables using Native Style for quantity calculations.  Native Style looks in the GEOPAK DDB file for the 

symbology settings, including the GEOPAK attribute tag and any Adhocs defined in the DDB file. 

FEATURE DEFINITIONS 

Feature Definitions control symbology, annotation, and various other properties applied to the geometric 

elements. 

FDOT built the Feature Definitions by using an existing feature table from the GEOPAK (DDB). One utilizes 

these existing feature tables by way of a link to the file, plus the addition of more settings to enhance 

capabilities.  One uses these feature definitions to: 

o Define what the geometric elements actually are; what is being modeled such as curb, centerline, edge 

of pavement, etcetera. 

o Control symbology in various views, including capability to define differing symbology in plan, 

profile, and 3D spaces. 

o Define terrain model attributes (spot, break line, void, etcetera). 

o Define surface display characteristics. 

TEXT STYLES 

A text style is comprised of a group of text attributes, such as font, width, height, spacing and so on. Text styles 

take away the burden of having to set all of the individual text parameters. FDOT delivers predefined text styles 

for use whenever possible. The text styles delivered by FDOT are at a scale of 1 to 1. This is important to 

remember placing text using Annotation Scale. A more detailed discussion of Annotation Scale comes later in 

this section. 

TEXT STYLES DIALOG 

The Text Styles dialog can be accessed by selecting Element > Text Styles from the MicroStation menu. 

 



The Text Styles dialog shows all of the text styles that exist in the design file, and all of the parameter settings for 

each style. When a new file is created or opened an existing file based on the fdot_levels_v8.dgnlib all of the 

appropriate text styles are loaded. FDOT expects no changes made to the delivered text styles. 

 

TRUE TYPE FONTS 

FDOT has integrated the use of True Type Fonts and restructured the Text Styles.  The following implements 

the True Type Fonts: 

o Cell Libraries 

o DDB  

o VBAs 

o MDLs 

o Spreadsheets 

True Type Fonts will ignore MicroStation weights.  The best method to show thicker text is to use the Bold 

font.  The FDOT CADD Software delivers and installs the True Type Fonts in the 

FDOTSS4\RESOURCES\Fonts\ folder on the server and in the Windows\Fonts folder on the client. 

Note FDOT CADD Software also delivers old fonts, but do not configure the menus and tools to use them. 

  



STYLE ORGANIZATION 

Fonts at Common Sizes  40 Scale  50 Scale 

Large = .15 x Scale 5.0 6.25 

Medium = .1 x Scale 4 5 

Small  = .07 x Scale 2.8 3.5 

ANNOTATION SCALE 

Annotation Scale associates text and linestyles placed in a model to a specific scale so if the scale changes in that 

model the text dynamically changes with it. The Annotation Scale lock must be check on before placing the first 

piece of text and continue to use Annotation Scale on all of the remaining text for this to function properly. 

  

Using Annotation Scale also removes the burden calculating text height used at particular scales when placing 

text. Annotation Scale is model specific.  

FDOT recommends to set this at the time the model creation and to select the Annotation Scale lock.  This can 

also be set in the Model Properties as seen in the figure above. 

Important items to remember regarding Annotation Scale: 

o Model Specific 

o Annotation Lock must be on from the start 

o Can be synced to the plot scale using FDOT Menu 

o Can be set in the Model properties 

o Can be changed using the Drawing Scale 

o Do Not switch Annotation Scale ON and OFF 



Exercise 1.6 Annotation Scale and Text Styles 

This is a brief introduction to placing text using FDOT delivered Text Styles. This discussion is in more detail later 

in this course. 

1. Continuing with DSGNSP01.dgn in the Class Work model, set the active level to TextLabel. 

 

2. From the MicroStation Task Navigator’s Main Classic Task, select the Place Text tool. This opens 

the Place Text dialog.  

 

Note Notice that the Annotation Scale option is active. This was part of our Model Properties set in a previous 

exercise. Remember with Annotation Scale set there is no need to calculate what text height and width 

to use; this tool automates the calculation. 



3. From the Text Styles drop down menu, select the FDOT (Medium) style.  

  

4. In the Text Editor dialog, enter a sample text string and place it in the design file. 

 

5. From the MicroStation Task Navigator select the Main Classic Menu > Display Text Attributes tool

. 

6. Select the text just placed and notice the text attributes, the Height and Width are set to the correct size 

based on the Annotation Scale. No manual calculation required. 

 



7. Open the Drawing Scale dialog by selecting the MicroStation menu Settings > Drawing Scale. 

 

8. Change the Annotation scale from 1:50 to 1:40.  Note the change in size of the previously placed text. 

 

9. Take time to familiarize yourself with the Place Text dialog and other delivered Text Styles. 

10. Change the Model back to Default and select File > Save Settings. 

  



MODELS 

Models are independent sets of design data within the same file. Every MicroStation design file has at least one 

model named Default. Models consolidate files containing data used collectively.  

An example is the cross section file, this one file (Rdxsrd*.dgn) has four models in it: 

• Pattrd – Pattern lines for cross sections 

• Rdxsrd – Cross Sections 

• Xsshrd – Cross Section Shapes 

• Rdxsrd_shg – Cross Section Sheets 

Another example of how to use a model is with the alignment file or (Algnrd*.dgn). This file is for displaying the 

alignment Stationing, tick marks, PC, PT, PI, and curve data information. Typically, there could be multiple 

alignment files to cover all of the different scales. Using the model concept only one MicroStation (Algnrd*.dgn) 

file with several models in it (i.e. a model for each scale) has to be created. 

When creating a new model there are several options to define in the model properties, these properties are unique 

to the model. The figure below shows the Create Model dialog. 

 

There are two types of models, Design and Sheet. The Design model is the actual geometry or line work and the Sheet 

model is the sheet file or border. Models are either 2D or 3D. A 3D model can reference to a 2D design file. 

Note If DGN files use multiple models, it is important to document their names and uses in the project Journals. 

This will give downstream users an idea as to what is in the file and whether it is important or not. The 

same goes for CADD managers who review QC reports. If creating temporary models to work in and the 

model fails compliancy, the project Journal documentation should provide an explanation, as long as 

this Model IS NOT referenced to any other design file. 

  



Exercise 1.7 Using the Tools  

� Models (Part 1) 

This exercise will cover setting the Annotation Scale for the default model and create a new model in this exercise. 

This model is a place where to experiment with some tools without adding junk to the default model. 

1. Continuing in DSGNSP01.dgn open the Model Properties dialog. You can also open this from the 

Primary Tools bar. 

 

2. In the Model dialog, highlight the Default model. 

3. Right mouse click on the Default model and select Properties. This opens the Model Properties 

dialog. 

 

4. Set Annotation Scale to 1”=50’. 

5. Click OK. This closes the Model Properties dialog. 

 

6. Click Yes on the Alert dialog (if one appears.). Up to this point, nothing is in the design file to change. 

 

 



� Create New Model (Part 2) 

1. In the Models dialog, select Create a new model . This opens the Create Model dialog. 

 

2. Set the Type to Design 2D. These are the default settings. 

3. In the Name, enter Class Work. This is the Model name. 

4. You can leave Description blank. 

5. For Ref Logical enter Practice Work. This field, if populated, fills in the logical name in the reference 

palette if this file is attached. This is very helpful. 

6. For Annotation Scale set this to 1”=50’.  

7. Click OK. This creates the new model and makes it the active model. 

8. Notice now that the new Model shows up in the Model dialog. To switch between models, double click 

on the model name. The active model name will be next to the View 1 name. 

  

Note In MicroStation, should already have the Annotation Scale Lock toggled on. 



� Reference Files, Models and Print Scale (Part 3) 

This exercise will cover attaching reference files that have multiple models in them. This reinforces the earlier 

discussion regarding models inside of a MicroStation file. There is more than one way to load the References 

dialog. Use the method most familiar. 

1. Continuing with DSGNSP01.dgn open the References dialog. This dialog is loaded by clicking on the 

References icon on the Primary Tool Bar. 

 

2. In the References dialog, select Tools > Attach. This opens the Attach Reference dialog. 

3. Navigate to the Roadway folder. 

4. Attach the reference file dsgnrd01.dgn in the roadway folder. 

5. Click on Open. This opens the Reference Attachment Settings dialog.  

6. Select the default model from the Model drop down list. 

 

7. Click the OK button. This attaches the reference file. 

8. In MicroStation do a Fit View. This fits the reference file to the active view window.  Take a moment 

and zoom in close to the baseline, notice that there are no tick marks or stations. 

Note The Roadway Design File have the project alignments drawn on the CLConst_dp level, utilizing the 

Centerline (CL) Feature Definition.  Stationing and tick marks are drawn in the Alignment file 

(algnrd*.dgn) at different scales in separate models.  

9. In the References dialog, select Tools > Attach. This opens the Attach Reference dialog. 

10. Navigate to the Roadway folder and select the reference file: Algnrd01.dgn. 



11. Click on Open. This opens the Reference Attachment Settings dialog. This is the alignment file 

containing the Stationing and tick marks. 

 

Note The attachment method should be set to Interactive. Notice the Model name defaults to the Default 

model. Every MicroStation file has at least one model named Default, except Rdxsrd*.dgn where the 

default model has been renamed to Rdxsrd. This reference file has additional models to accommodate 

multiple scales.  

12. In the Reference Attachment Settings dialog set the Model to Algnrd_50. 

13. Click the OK button. This attaches the reference file. 

14. In MicroStation do a Fit View. This fits the reference file to the active view window. 

Note The reason for doing it this way is that on Signing and Marking Plans sometimes it is more advantageous 

to display only the stations and ticks and not the baseline. This avoids confusion when they are close to 

another pavement marking line or when displaying them at different scales. This set up makes it easier 

to turn off the display of the reference file.  

15. Zoom in close to the baseline again; notice now that there are tick marks and stations. 

 

Note It may be necessary to attach the Topord*.dgn, Utexrd*.dgn and Drexrd*.dgn files depending on the type 

of project being worked. Conflicts with any of the existing features requires the display of that reference 

file. Refer to the Plans Preparation Manual Volume II - Chapter 23 for further guidance. 

  


