
5 DESIGN TOOLS 

OBJECTIVE 

The objective of this chapter is to introduce common design tools used by all the Traffic Plans disciplines.  These 

include the Design & Computation (D&C) Manager, Draw Cell by Feature, and Draw Cell Group by Feature. 

INTRODUCTION 

This chapter introduces several applications that are very useful to the designer to create Traffic Plans features:  

• D&C Manager  A GEOPAK tool used to help designers draw elements, set symbology, 

and compute quantities.  The FDOT CADD office provides a database set up with the correct symbology, 

cells, formulas and pay items needed to meet the FDOT standards. 

• Draw Cell by Feature A GEOPAK tool used to place a single cell in the file along an alignment 

or MicroStation element.  It uses the D&C Manager to insure the placement of cells with the correct 

symbology and pay information for calculations. 

• Draw Cell Group by Feature A tool to place multiple cells along elements or alignments.  It uses the 

D&C Manager to insure the placement of cells with the correct symbology and pay item information for 

calculations. 

 

EXPLORING D&C MANAGER 

The D&C Manager uses a proprietary DDB provided by FDOT. The installation of the FDOT CADD software places 

the latest D&C Manager DDB either on the server or on the local hard drive. For new projects, FDOT recommends 

to copy the latest DDB file from the FDOT installation folder into the project SYMB folder and rename it to the 

eleven-digit Financial Identification Number (FIN) number.  For the 22049555201 project used as the example in this 

manual, the FDOTSS4.ddb is renamed to 22049555201.ddb. This 

allows the designer to modify the DDB for specific parameters, and 

protects it from any future maintenance updates overwriting the file. 

The latest FDOT DDB file is located in the 

\FDOTSS4\GEOPAK\databases\ folder.  The naming format is 

fdot####.ddb where #### is the year or version of the FDOT CADD 

Software.  

It is highly recommended that every user that works on projects 

becomes very familiar with D&C Manager. D&C Manager sets 

symbology and automates quantity calculations for linear, each, and 

area quantities. 

FDOT specifically set the DDB to create elements with the correct 

level symbology according to the FDOT CADD Standards. The DDB 
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file is set up with discipline folders called categories. Inside of each category are items.  

• Categories - The basic component of the hierarchical tree is the Category, represented by a folder icon. 

The categories in the FDOTSS4.ddb are divided by discipline. The figure above shows the Categories with 

a description relative to their discipline  

• Items - The other DDB component is the item. An item could be a drafting item, a compute item or a 

default item. Items contain specific functions related to defined element symbology or quantity 

calculations. Items are represented by one of three icons: 

•  Default Icon -These items are used to set drafting standards for MicroStation commands or to 

draw COGO elements without annotation.  

•  Drafting Standards Icon - These items are used to set drafting standards for MicroStation 

commands or to draw COGO elements with annotation. 

•   Calculator Icon - These items are used to set drafting standards for MicroStation commands, to 

draw COGO elements and/or compute quantities. FDOT tags graphics with a pay item attribute for 

additional stratification of features when running computations and defines computation for these items. 

D&C MANAGER MENU BUTTONS 

D&C Manager has a toolbar for easy access of different modes. Summarized below are the functions of each 

button. A later section in this chapter covers in more detail the tools used to create Pavement Marking plans. 

 

 - Switch To Toolbox Mode. D&C Manager is set up to work in two different modes, as a dialog or a 

toolbox. This button activates the resizable and dockable toolbox.  To change the display back to the whole dialog, 

click the Switch to Dialog Mode button. The Place Influence check box is at the left end of the toolbox.  

 - Identify Item. The Identify Item button sets the D&C Manager item to match a selected MicroStation 

element previously drawn by the D&C Manager or elements drawn with Graphical COGO and the SMD file. If 

the item you ID does not match an item in the active DDB, a message appears in the status bar saying: No 

matching database item.  



 - Display. The Display button filters the display of MicroStation elements in the design file so only the 

selected features display, highlighted or hidden. This button expands D&C Manager to show a collection bin. 

This collection bin is for controlling the display of multiple items at one time. To add items to the collection bin, 

double-click the item. This tool also opens a second toolbox with four buttons as seen in the figure below.  

Buttons from left to right: Normal Display, Highlight Selection, Hide Selection and Display Only Selection. 

  

 - Design. The Design button plots COGO and MicroStation elements into MicroStation with the defined 

symbology when selecting Place Influence. Draw Plan and Profile dialog or MicroStation commands place 

elements.  

 

 - Set. The Set button sets the symbology of previously drawn MicroStation graphic elements in accordance 

with the parameters of a selected item in the DDB. This tool fixes elements to meet CADD standards or 

attach/modify Adhoc Attributes. 

 

 - Compute. The Compute button tabulates quantities of items placed as a Pay Item by use of the Design or 

Set mode or have been drawn in MicroStation and they match the search criteria of the ddb file. This tool also 

expands D&C Manager to show the collection bin; this allows you to process multiple pay items or categories 

at one time. A second toolbox opens with the computation results.  

  

 - Shapes. The Shapes button uses plan view MicroStation graphics that defines an enclosed area to create 

a filled shape for computing area quantities.  



Note FDOT does not recommend this tool is for use when the Civil Tools have been used for the design.  Use 

the Create Region tool instead with the Associative Region Boundary option toggled OFF. 

 - Pavement Marking. This mode provides additional options for placing pavement striping and markings. 

This tool adds four additional tools to D&C Manager as shown in the figure below.  

The four tools from left to right:  Striping, Separation, Chevron Diverge, and Chevron Merge: 

 

 - Preference. This expands the toolbar to include four additional buttons to configure D&C Manager. 

These tools are also accessible from the Edit menu. 

DESIGN SETTINGS 

Before using D&C Manager to draw or compute items, address settings. These are the Design Settings loaded 

from the Settings > Design menu in D&C Manager. 

 

• Maximum GAP Tolerance – If the distance between two specified elements in a MicroStation file is 

smaller than the Max Gap Tolerance, the software assumes the two elements intersect and act accordingly. 

If the distance is larger than the Max Gap Tolerance, GEOPAK assumes the two elements do not connect. 

• Deduction Tolerance – The Compute mode utilizes the Deduction Tolerance. For example, if the pay 

item is specified for a curb line, and for each manhole (drawn in as a cell), there is a deduction of six feet. 

The origin of the cell does not have to be on the curb line, but must be within the deduction tolerance in 

order to recognize cells and make the deduction. 

• Custom Line Style Creation – The Custom Line Style Scale Factor sets a specific scale for custom line 

styles. Note this scale is only for custom line styles.  



• Cell Creation – Plot Scale is a ratio with the Creation Scale within the setup of D&C Manager. If the 

Cell Creation Scale is 10 and the designer wants the cell twice as large as a cell placed with D&C Manager, 

utilize 20 as the Drawing Scale. 

Note When entering a drawing scale, all subsequent cells placed from the D&C Manager are scaled 

accordingly if the item is set to use creation scale. When placing a cell with place influence on, 

GEOPAK utilizes the drawing scale setting to compute an X & Y scale for use in the MicroStation 

Place Cell dialog.  

• Influence Graphic Cell Level Symbology – When active, GEOPAK utilizes the symbology within the 

D&C Manager, ignoring the element symbology defined in the cell. 

DESIGN MODE 

Design Mode is the default mode when the D&C Manager opens. The following functions use the Design Mode:  

• Set Drafting Standards by use of the Place Influence command for the placement of MicroStation elements 

using MicroStation commands. 

• Print COGO elements into the design file according to the drafting standards set by the item’s defined 

parameters. 

• Place Adhoc Attributes on an element. 

Whether placed in the file by generic MicroStation commands or plotted from COGO, Draw Plan & Profile, the 

items can be placed as pay items for future tabulation.  

By selecting Place Influence, the designer can use MicroStation commands to place elements utilizing the 

element attributes established for the currently selected item in the GEOPAK D&C Manager DDB. With most 

items, a GEOPAK attribute is placed with the element.  This attribute provides another identifier to make the 

element unique and used to sort features for calculating quantities.  

 

When selecting Place influence, the MicroStation level symbology is set. Any MicroStation command to draw 

a line, copy a line or place a cell is set to this symbology. 

 

Note When finished placing the elements for a selected item it is important to remember to turn off Place 

Influence. 

ADHOC ATTRIBUTES  

An Adhoc Attribute is additional information about a particular element. Look at it as another property for the 

MicroStation element, i.e.  Level, Color, Weight, and Style. 



By placing an Adhoc on the line, the designer is giving that line additional information. That information could 

be a chain name, cross slope, profile name, thickness, etc. It is almost limitless as to what can be associated to an 

element with Adhocs. Other down-stream applications use these Adhocs. 

Some Adhocs are placed in the background and the designer does not interact with them. For example, when a 

proposed & remove sign post is placed with the Draw Sign Program, a 3pc file is utilized to access the D&C 

Manager DDB to place Adhocs on the post symbol for computing quantities.  

The figure below shows the Adhocs that are associated with an item from D&C Manager. These Adhocs are part 

of the item and are set by default. Nothing indicated this information was set since all of the adhocs are locked 

for modification when placing elements.  

 

Other Adhocs are interactive meaning the designer must fill in the parameters. An example is placing guardrails. 

There are adhocs added to the line that must be defined by the designer.  

 

Note Adhocs with values displayed in red are locked for modification. 

Adhoc Attributes are comprised of three types of information that must be defined:  

• Name - The Name is an identifying term used when GEOPAK is searching for a specific Adhoc Attribute. 

• Type - The Type identifies the nature of the information, and has various options: Numeric, String, Unit, 

Quantity, and Remarks. 

• Value - The Value is the actual information used by GEOPAK, and is determined by the Type. For 

example, if the Type setting is Numeric then the Value must be a number and GEOPAK will use it as a 

number. 

For more information on the D&C Manager, see the GEOPAK Help files. 
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DEFINING ADHOCS FOR QUANTITIES  

Adhoc Attributes are tags that apply to graphic elements to provide more information. Adhoc Attributes are comprised 

of three types of information that require mandatory definitions: Name, Type, and Value. 

Name An identifying term used when GEOPAK is searching for a specific Adhoc Attribute. 

Type Identifies the nature of the information, and has a number of different setting options. The options are Numeric, String, 
Unit, Quantity, and Remarks. 

Value The actual information to be used by GEOPAK, and is determined by the Type. For example, if the Type is Numeric 
then the Value must be a number.  

FDOT has set up Adhoc Attributes for many of the Items in the D&C Manager.  The functionality of these Adhocs 

range from setting variables used in the calculation of quantities to adding notes for later retrieval.  It is important to 

note that in many cases specific projects may require modifying these Adhoc values.  The creation process of design 

elements using the Civil Tools and Features will assign the default.  FDOT recommends the review of these elements 

to ensure the correct values are set on the elements. 

To calculate a quantity using adhocs, the Compute Parameters must be set to Adhoc Attributes and adhocs must consist 

of 1 to 3 adhocs set on an element.  As a minimum, an adhoc using the pay item as the name, type set to Unit, and the 

value set to either the Standard Unit or an equation.  If this is the only adhoc set, then D&C will use the item 

description.  If this should be different, a second string adhoc, using the same name as the unit adhoc, can be set with 

the desired description.  A third adhoc type, Quantity, may be used to override the calculated quantity from the design 

file. 

Note Place these adhocs on the elements BEFORE exporting the quantities to Quantity Manager. 

Review chapter 5 of this training manual for more information on Adhocs and the D&C Manager. 

There are 3 tools that can be used to review, set, and/or modify adhocs on the MicroStation elements.  These are the 

3pc Adhoc Attribute Manager, FDOT Adhoc Manager, and the D&C Manager using either the Design mode or the 

Set mode. 

ADHOC ATTRIBUTE MANAGER 

Adhoc Attribute Manager is the tool used for tagging, reviewing, and manipulating Adhoc Attributes. It can be 

opened from the Road tools palette  or from the MicroStation menu option GEOPAK > ROAD > 3PC 

Adhoc Attribute Manager, or from the Task menu FDOT Plans Development > Quantities. 

 



The File menu contains the option for Preferences.   

 

• Set Mode – Defines the actions to take with adhocs when the Set Attribute option is used.  Append adds 

any new adhocs from the list to the selected elements.  It does not modify any of the adhoc values.  Replace 

deletes all adhocs from the selected element and then adds the list of adhocs. 

The Adhoc Attribute Manager has four icons on the tool bar for viewing and tagging elements with Adhoc 

Attributes. From left to right these icons are:  Attribute Display Filter, Identify Element, Set Attribute, and Adhoc 

Scooper. The two icons on the right side are Create New Row and Delete Row. 

•  Identify Element - Click on the icon to select a MicroStation element. All adhocs on the element will 

be displayed in the window. 

•  Set Attributes - Select the icon to set the defined adhocs on the selected element(s). 

Click F1 with the toolbox active to see the GEOPAK Help files for more detailed information. 

FDOT ADHOC MANAGER 

FDOT has developed a comparable tool, FDOT Adhoc Manager, that can place GEOPAK Adhocs without having 

a full GEOPAK license active.  

The FDOT Adhoc Manager can be loaded from the FDOT Menu option:  Actions > Adhoc Manager. 

 

This opens the FDOT Adhoc Manager. 



 

The FDOT Adhoc Manager tool is used to Add New Adhocs, Edit New or Existing Adhocs, Copy Adhocs for 1 

element to another element or group of elements in a selection set and/or Delete Adhocs on elements within a 

DGN file. 

• Select Elements(s) to Modify - In order to review Adhocs on an element, first the designer must create a 

selection set of 1 or more elements in MicroStation and then click the Select Elements(s) to Modify button. 

When a selection set is used, a dialog will pop up asking to “Use selection set?” 

 

o Clicking the NO or Cancel button will stop the selection process.  

o Clicking the Yes button will populate the FDOT Adhoc Manager dialog, if all Adhocs of the selected 

elements match or a single element is selected containing Adhocs and the elements are in the active 

design file.  

• The following dialog will display indicating the number of elements in the selection set and if the 

element(s) selected have Adhocs. 

 

Note If elements are selected that do not have Adhocs, the dialog will state: “You have selected (number of 

elements) elements without Adhoc attributes.” 

• Copy - To copy the Adhocs from 1 element to another element or to a group of elements in a selection set, a 

selection set will have to be selected first and then the Copy button clicked. In the FDOT Adhoc Manager 

status bar (lower left corner) the message will read: “Copy Adhocs from Element with Adhocs > Identify 

Element” when the Copy button is initialized. 



 

• Select the element with the Adhocs and the selected element’s Adhocs will populate the FDOT Adhoc 

Manager dialog. To set the Adhocs to the selection set elements, click the Set button. 

• When the Set button is initialized the FDOT Adhoc Manager writes the Adhocs to the selected 

element(s) and gives the designer the dialog below when this function is complete. Click the OK button 

to continue. 

 

• Add New - Initializing this button creates a new row for adding the additional Adhocs and loads the Edit 

Adhoc dialog for the designer to complete the creation of the new Adhoc. 

 

This dialog gives the designer the ability to name the Adhoc, select the type of Adhoc (String, Numeric, 

Quantity, Remarks, Unit or None) and to give the Adhoc a value.   

Note The Name Field has a 23-character limitation and the Value field has a 45-character limitation. 

• Clear - This button will clear the listed Adhocs from the FDOT Adhoc Managers. This function does not 

clear Adhocs from the selected elements.  

• Name (Column) - This field lists the names of the Adhocs. The Name Field has a 23 character limitation. 

• Type (Column) - This field lists the Type of Adhoc whether it's a String, Numeric, Quantity, Remarks, Unit 

or None (if no type is specified). 

• Value (Column) - This field lists the Value of the Adhocs. The Value Field has a 45-character limitation. 

• Edit (Button) - This dialog gives the user the ability to name the Adhoc, select the type of Adhoc (String, 

Numeric, Quantity, Remarks, Unit or None) and give the Adhoc a value. To complete the Edit of an 

Adhoc, set the Set Mode to Replace and the click Set button save changes to the element.  

• Delete (Button) - This function is to delete the Adhoc on the row initialized. When the Delete button is clicked 

the row will be removed for the Adhoc list. However, the operation is not complete until the Set Mode is set 

to Replace and the Set button is clicked. 

• Set Mode - This gives the user a way to select either to Append to the elements Adhocs or to Replace them. 

 



o Append - This radio button is to append new or copied Adhocs to an existing element (with or without 

existing Adhocs) without overwriting or removing any of the existing Adhocs. Click the Set button to 

complete the function of writing Adhocs to the selected element or group of elements in a selection set. 

o Replace - This radio button is to replace new or copied elements to any element whether or not the 

element has Adhocs or not. Replace means that any existing Adhocs will be removed and replaced with 

the new Adhoc(s). Use this Set Mode for deleting Adhocs. Click the Set button to complete the function 

of writing Adhocs to the selected element or group of elements in a selection set.  

o Set Button - Once any additional Adhocs are added, copied or deleted, set the Set Mode to either 

Append or Replace. Click the Set button to complete the function of writing Adhocs to the selected 

element or group of elements in a selection set. 

• Cancel (Button) - Stops the current operation but will not return the FDOT Adhoc Manager to a clean slate. 

It may be necessary to click the Clear button to clear the dialog. 

• Exit (Button) - Closes the FDOT Adhoc Manager application. 

  



Exercise 5.1 Add an Adhoc to D&C Manager Item  

In this exercise an item in the D&C Manager will be modified to calculate the quantity using adhocs. 

� Modify Item 0710 11290 - Add an Adhoc 

20. Open Dsgnsp01.dgn in the Signing folder. 

21. Start D&C Manager. Make sure the correct ddb file is loaded. (Project Specific DDB.) 

22. Use the Edit > Find option in D&C Manager to search for item 0710 11290. This is for Reflective Island 

Nose Paint (Yellow). 

 

23. Right click on Item 0710 11290 and select Modify Item from the menu. This opens Item Modify dialog. 

  

24. On Item Modify, make sure that the Adhoc Attribute option is toggled on. 



  

25. Click the Adhoc Attributes button. This opens Adhoc Attributes. 

26. Click the Add New Row icon.  

 

27. For the Name click on New1 and Key-in 0710 11290. (This is the pay item number and must match the 

D&C Manager Item name if used by itself.) 

28. For the Type, select Unit. 

29. For the Default Value, key-in SY.  

30. Toggle the Lock to Yes. (This locks the item from modification when an element is drawn or set.) 



� Add New Row for Quantity 

31. Click Add New Row again.  

32. For the Name click on New1 and Key-in 0710 11290. 

(You can copy and paste from the first entry. This must 

match the Name of the unit adhoc.) 

33. For the Name click on New1 and Key-in 0710 11290. 

34. For Type, select Quantity. 

35. For the Default Value leave at 0.0. (This will edit this 

as the elements are drawn.)  

36. Toggle the Lock to No. (This will be filled in with a 

manually calculated area.)  

37. Click OK. This takes you back to the Item Modify dialog. 

� Set Compute Parameters 

38. On Item Modify, click Compute Parameters. This opens Parameters for Target Item. 

39. Under Computation Method, select Adhoc Attribute. If this is already set, then ignore this step. 

 

40. Click OK to close and save changes in the Parameters for Target Item dialog. 

41. Click OK on the Item Modify dialog. 

42. In D&C Manager, select File > Save. This will save this change to the DDB file. 

  



� Place A Line with an Adhoc 

43. Continuing in Dsgnsp01.dgn zoom to the Traffic Separator Nose near Sta 701+00.  

44. Confirm selection of item 0710 11290. This is the item modified. 

45. In D&C Manager, select Design mode  .  

46. In Design mode toggle On Place Influence and Adhoc Attributes.  

 

47. Notice when Adhoc is selected that Adhoc Editor opens. Also, notice that two of the rows values are red; 

this is due to the options being locked when the Adhoc was created earlier. 

 

48. Set the Quantity Adhoc Value to 25.0. 

49. Select the MicroStation Place Line tool.  The DDB item is set to place an arc, however, this can be 

changed on the Place SmartLine dialog. 

50. Draw a line from one end of the radius of the median to the other end. 

 

Note The length of the line makes no difference, it could be one inch and the item will quantify. The Adhoc is 

only additional information about an item. 

51. Check Off Place Influence. 

52. Take this opportunity to place the rest of the Island Nose Paint on the Traffic Separators along the SR61 

alignment by repeating steps 1-7 of this exercise. 



� Use FDOT Adhoc Manager to Check Element  

53. From the FDOT Menu, select Actions > Adhoc Manager to open the FDOT Adhoc Manager. 

 

54. Select the line drawn in the previous exercise. 

55. In FDOT Adhoc Manager, click Select Element(s) to Modify. 

56. Click Yes on the Use selection set? dialog to accept the select collection set. The Adhoc information 

will populate the dialog; this is what will show up when automated quantities are run. 

 

57. Click OK on the FDOT.Adhocs dialog. 

 

58. Review the Adhocs of the Island Nose Element. 

59. Close FDOT Adhoc Manager. 

DRAW CELL BY FEATURE 

One of the options the designer has to draw the signal elements is the Draw Cell by Feature tool in GEOPAK. This 

tool is best suited for placing one cell at a time like a Mast Arm foundation or Loop Assembly.  



The Draw Cell by Feature tool can be loaded from the MicroStation pull down menu GEOPAK > Road > Plans 

Preparation > Draw Cell by Feature.  

This tool can also be loaded from the Road Tools palette. 

 

The Draw Cell by Feature tool can be used to draw single cells in the design file.  It uses Features which are defined 

in the D&C Manager.  It will tag the cells with the attribute, symbology, and adhocs defined in the D&C Manager. 

 

o Feature – Defines the item in the D&C Manager. 



o  Button used to open the Select Design & Computation Payitem dialog which is used to set the 

D&C Manager category to populate the drop down list. 

o Drop down list is used to select the item/cell to be drawn by the tool. 

o Placement – Defines how the cell will be placed in the design.  There are two options: 

o By Point – This option is used to manually select the location in the file with a data point. 

o On Element – This option is used to define the location using an element in the file or a chain from 

the GPK file. 

o Angle – Sets the angle of cell.  There are to options available: 

o Absolute – sets the angle based on 0 degrees as horizontal. 

o Relative – sets the angle relative to the element selected. 

o Element – Defines the type of element used for the location.  There are two options available: 

o DGN – a MicroStation element drawn in the file 

o Complex Chain – toggle to allow the selection of a complex chain as the DGN element. 

o   - Identify Element - Button used to select an element from the file.  The Station field will 

be populated with the begin length (0) of the element selected. 

o Chain – a chain stored in a GPK file.  The Station field will be populated with the begin station of 

the chain selected. 

o   Identify Chain – Button used to select the chain from the graphic elements in the design 

file. 

Note When selecting the Chain option, the GEOPAK User Preferences may need to be set to point to the 

GPK file location if it is in another directory.  Most commonly it is found in the Roadway directory. 

o Station – The station or distance along the element for the placement location. 

o Offset – the distance from the chain or element for the placement location. 

o Dynamic Rotation – Toggle to allow for manually rotating the cell once the location has been 

established. 

DRAW CELL GROUP BY FEATURE 

The Draw Cell Group by Feature tool can be used for placing Pavement Messages and Arrows, RPM’s or any 

other cell you want to group together. It is not required to use this tool when placing cells, however, this tool will 

make the task of drawing Arrows and RPMs much easier. This tool can be opened on the Road tools pallet or on 

the menu GEOPAK > ROAD > Plans Preparation > Draw Cell Group by Feature. 

Note When using the Draw Cell Group by Feature and/or Draw Cell by Feature tools, always ensure to load 

the correct GEOPAK DDB as the tool will 'reset' to the DDB specified in the resource file every time 

the tool is closed and reopened.  This GEOPAK DDB may not be the DDB intended for use with your 

active project. 

The dialog consists of two tabs: 

FEATURE GROUP TAB 

Feature Group defines the D&C Manager item(s) to use, which in turn selects the cell(s) to be placed, and 

the Offset from the selected element to place the item. 



 

Based on the items that are checked the tool allows the designer to place up to three different cells. The 

Magnifying glass next to each item allows the designer to browse to D&C Manager and select the appropriate 

item, which will attach the cell to be drawn. The Offset is the distance from the selected DGN Element or 

Chain when drawing the cell. 

LOCATION TAB 

Location defines whether to use a DGN element or Chain, Begin and End stations, Spacing, Angle, and 

Justification. 

  

o Element – This is either a GEOPAK Chain or DGN element. This function is similar to the Draw 
Striping tool. The Begin and End fields will be populated with the appropriate data based on the element 

selected. They can be modified using the buttons or by keying in the value. 

Note When selecting the Chain option, the GEOPAK User Preferences may need to be set to point to the 

GPK file location if it is in another directory.  Most commonly it is found in the Roadway directory. 

o Buffer Distance – This is for setting where to start the first cell and end the last cell. Example, when 

placing RPM’s on a 10/30 skip line, if snapping to the beginning of the first painted stripe, set the Begin 

Buffer Distance to 25.0. This accounts for the 10’ (ft) stripe and the 15’ (ft) spacing between the first 

and second stripe. 

 

o Spacing – There are several options available to set the spacing between the cells, they are: 



� Increment – This is a set value between cells. 

� Even – Evenly spaces the cells at a user-specified spacing, the buffer distances are ignored. 

� Max Spacing – The location of the beginning and ending cell are determined, then a sufficient 

number of cells are placed in between, so that the distance between them is no more than the 

specified Max Spacing and equidistant apart. 

� Once – Only one set or cell is placed. The ending buffer distance is ghosted. 

� Each Vertex – The origin of the cell is placed at each vertex of the selected element. The Begin 

and End and buffer distances are ghosted. 

� End Points – The origin of the cell is placed at each end point of the selected element. The Begin 

and End and buffer distances are ghosted. 

Hint When placing RPMs along a curved roadway this tool does not account for the 

curve geometry at an offset. You will have to copy parallel one of the edge lines on 

top of the 10/30 skip line and use that line as the DGN element then delete the copied 

line. Optionally, the Chain option can be used if the cells can be placed parallel to the 

selected alignment. 

o Angle – If set to Absolute the angle is based on 0 degrees as horizontal. If set to Relative the cell is 

placed relative to the element selected. 

o Justification - The justification can be based on the center cell (only option if only one row is placed), 

the upstream or downstream cell.  Only those selected in the Feature Group are available for setting 

Justification. 

 


