FDOT GEOPAK Drainage

FDOT GEOPAK Drainage for Plans Preparation
(Chapters 1, 3-6, 8, 12-14)

FDOT GEOPAK Drainage for Design
(Chapters 1-11, 15-19)

Course Guide

November 2016

PRODUCTION SUPPORT CADD OFFICE
TALLAHASSEE, FLORIDA
http://www.fdot.gov/cadd/
FDOT GEOPAK Drainage for Design

Description
Students will be able to review the hydraulic design capabilities of the GEOPAK software applied in a FDOT roadway project. Students will learn how to place drainage structures, connect them with a pipe system and compute the hydraulics of a storm drain network. The Storm Tabulation and Spread Tabulation report will also be generated.

Objectives
NOTE: This manual is used for three courses; FDOT GEOPAK Drainage for Design (Chapters 1-11, 15-19), FDOT GEOPAK Drainage for Plans Preparation (Chapters 1, 3-6, 8, 12-14).

- Getting Started
- Drainage Library
- Project Preferences
- Drainage Areas and Nodes
- Conveyance Systems
- Networks
- Profiles and Utility Conflicts
- Navigator and Global Editor
- Querying
- Reports
- Design Revisions
- Culverts
- Terrain Models for Drainage Design and Analysis
- Special Ditch Profiles
- Pond Design with FDOT SS4
- Importing Stream Geometric Data to HEC-RAS

Audience
Drainage Designers and Drainage Engineers.

Prerequisites
The following courses and some manual drafting or related CADD product experience is recommended:
- FDOT GEOPAK for Roadway Designers - Basic (CE-11-0099)

Duration: 24 Hours
Professional Credit Hours: 18 PDHs
FDOT GEOPAK Drainage for Plans Preparation

Description
This course will review the plans preparation capabilities of the GEOPAK software applied in a FDOT roadway project. The material will cover the generation of the storm and spread tabulation reports, calculation of plan quantities, summary of drainage structures, and plan view labeling.

Objectives
NOTE: This manual is used for three courses; FDOT GEOPAK Drainage for Design (Chapters 1-11, 15-19), FDOT GEOPAK Drainage for Plans Preparation (Chapters 1, 3-6, 8, 12-14).

- Getting Started
- Project Preferences
- Drainage Areas and Nodes
- Conveyance Systems
- Networks
- Navigator and Global Editor
- Plans Preparation
- Automatic Quantities
- Drainage Structure Cross Sections

Audience
Drainage Designers and Drainage Engineers.

Prerequisites
The following courses and some manual drafting or related CADD product experience is recommended:
- FDOT GEOPAK for Roadway Designers - Basic (CE-11-0099)

Duration: 24 Hours

Professional Credit Hours: 12 PDHs
Table of Contents

1 GETTING STARTED .................................................................................................................. 1-1

   OBJECTIVES .......................................................................................................................... 1-1
   INTRODUCTION ....................................................................................................................... 1-1
   PROJECT COMPONENTS ......................................................................................................... 1-2
   DRAINAGE COMPONENTS ..................................................................................................... 1-3
   GENERAL DESIGN PROCESS FOR STORM DRAINS ............................................................ 1-4
   ACCESSING GEOPAK DRAINAGE: MAIN MENU BAR ......................................................... 1-4
   VBA APPLICATIONS ............................................................................................................... 1-6
       Exercise 1.1 Creating a GEOPAK Drainage Project ............................................................. 1-6

2 DRAINAGE LIBRARY .............................................................................................................. 2-1

   OBJECTIVES .......................................................................................................................... 2-1
   INTRODUCTION ....................................................................................................................... 2-1
   RAINFALL ITEMS .................................................................................................................... 2-2
   LAND USE ITEMS .................................................................................................................. 2-3
   NODE ITEMS .......................................................................................................................... 2-4
   LINK ITEMS ............................................................................................................................ 2-5
   SPREAD SECTION ITEMS ..................................................................................................... 2-6
       Exercise 2.1 Understanding Rainfall Data in the Drainage Library ................................... 2-7
       Exercise 2.2 Reviewing Land Use (Runoff Coefficients) in the Drainage Library .......... 2-8
       Exercise 2.3 Reviewing the Spread Section in the Drainage Library ............................... 2-9

3 PROJECT PREFERENCES ........................................................................................................ 3-1

   OBJECTIVES .......................................................................................................................... 3-1
   INTRODUCTION ....................................................................................................................... 3-1
   UNITS ...................................................................................................................................... 3-1
   PROJECT COMPONENTS ......................................................................................................... 3-2
   RAINFALL PARAMETERS ........................................................................................................ 3-3
   LAND USE OPTIONS ............................................................................................................... 3-4
   FREQUENCY OPTIONS .......................................................................................................... 3-6
   INTENSITY OPTIONS ............................................................................................................. 3-7
   JUNCTION LOSSES ................................................................................................................. 3-8
   INLET OPTIONS ....................................................................................................................... 3-10
   NODE OPTIONS ...................................................................................................................... 3-11
   LINK OPTIONS ......................................................................................................................... 3-12
   PROFILE OPTIONS ................................................................................................................ 3-14
   PLAN SYMBOLOGY ............................................................................................................... 3-15
   UPDATES .................................................................................................................................. 3-15
   SAVE OPTIONS ....................................................................................................................... 3-16
   PRINTING THE PROJECT PREFERENCES ............................................................................. 3-17
       Exercise 3.1 Project Preferences ......................................................................................... 3-17

4 DRAINAGE AREAS & NODES ................................................................................................. 4-1

   OBJECTIVES .......................................................................................................................... 4-1
   DRAINAGE AREAS ................................................................................................................. 4-1
       Introduction ........................................................................................................................... 4-1
       Definition ............................................................................................................................... 4-2
       Subareas ................................................................................................................................ 4-4
       Computations ....................................................................................................................... 4-5
   DRAINAGE NODES .................................................................................................................. 4-5
       Introduction ........................................................................................................................... 4-5
       Properties .............................................................................................................................. 4-6
       Location ................................................................................................................................ 4-8
       Spread Criteria for On Grade ............................................................................................. 4-9
5 CONVEYANCE SYSTEM ........................................................................................................ 5-1

OBJECTIVES .......................................................................................................................... 5-1
INTRODUCTION ........................................................................................................................ 5-1
LINK CONFIGURATION ............................................................................................................ 5-2
Definition .................................................................................................................................. 5-2
Conditions ................................................................................................................................. 5-4
Constraints ................................................................................................................................. 5-5
Computation ............................................................................................................................. 5-7
Exercise 5.1 Links ...................................................................................................................... 5-7
Exercise 5.2 Entering Pipes for Plans Preparation Purposes Only ............................................ 5-7

6 NETWORKS .......................................................................................................................... 6-1

OBJECTIVES .......................................................................................................................... 6-1
INTRODUCTION ........................................................................................................................ 6-1
NETWORK CONFIGURATION DIALOG ..................................................................................... 6-2
Exercise 6.1 Adding Networks .................................................................................................. 6-3
Exercise 6.2 Select Active Network ......................................................................................... 6-7

7 DRAINAGE PROFILES ....................................................................................................... 7-1

OBJECTIVES .......................................................................................................................... 7-1
INTRODUCTION ........................................................................................................................ 7-1
EDIT DRAINAGE PROFILE ....................................................................................................... 7-2
Registration ............................................................................................................................... 7-2
Display ...................................................................................................................................... 7-2
Drainage Information ............................................................................................................... 7-3
Grid & Labels ............................................................................................................................. 7-4
Link Profile ............................................................................................................................... 7-4
PREFERENCES .......................................................................................................................... 7-5
MICROSOFT UTILITIES ......................................................................................................... 7-5
Exercise 7.1 Profile Design ....................................................................................................... 7-5

8 NAVIGATOR / GLOBAL EDITOR ...................................................................................... 8-1

OBJECTIVES .......................................................................................................................... 8-1
INTRODUCTION ........................................................................................................................ 8-1
USING THE NAVIGATOR ........................................................................................................... 8-1
GLOBAL EDITOR ...................................................................................................................... 8-2
Exercise 8.1 Navigator/Global Editor ....................................................................................... 8-2

9 QUERYING ............................................................................................................................ 9-1

OBJECTIVES .......................................................................................................................... 9-1
QUERYING FROM THE NAVIGATOR .......................................................................................... 9-1
Exercise 9.1 Query Mode ......................................................................................................... 9-2
Method 1.................................................................................................................................................. 20-18
Method 2.................................................................................................................................................. 20-18
GEOPAK DRAINAGE WARNING MESSAGES .................................................................................. 20-19
Preferences .............................................................................................................................................. 20-19
Areas ....................................................................................................................................................... 20-19
Node ......................................................................................................................................................... 20-19
Link ........................................................................................................................................................ 20-19
Network ................................................................................................................................................... 20-20
Profiles ...................................................................................................................................................... 20-21
Navigator .................................................................................................................................................. 20-21
Renumbering Nodes ............................................................................................................................. 20-21
Reports ...................................................................................................................................................... 20-21
GEOPAK REPORT BUILDER VARIABLES ....................................................................................... 20-22
Area ........................................................................................................................................................... 20-22
Node .......................................................................................................................................................... 20-22
Inlet ........................................................................................................................................................... 20-24
Links .......................................................................................................................................................... 20-25
21 GENERAL INFORMATION ..................................................................................................................... 21-1
Objectives .................................................................................................................................................. 21-1
Frequently Asked Questions .................................................................................................................. 21-1
Correcting for Inlet Offset ...................................................................................................................... 21-3
Using GEOPAK Drainage for Spread and Inlet Elevations ................................................................. 21-4
Inlet Locations/Project Conditions ....................................................................................................... 21-5
   On Grade, No Transitions of Superelevation, Turn Lane or Thru Lanes: ............................................ 21-5
   On Grade, Superelevation Transitions, Turn Lane transitions, Thru Lane Transitions: ................. 21-5
1 GETTING STARTED

OBJECTIVES

In this chapter, you will learn about:

- Various File Types Used within Subsurface Utility Design and Analysis (SUDA).
- Creating a New GEOPAK Drainage Project File.
- General Process Using GEOPAK Drainage to Design Storm Drain System.

INTRODUCTION

This manual serves three primary functions. It is a training manual for instructor lead training, a user's manual for designers and technicians, and it is a technical reference. Lab exercises are provided at the end of the chapters, although the instructor based classes may not use all the exercises or cover all the chapters.

The Florida Department of Transportation (FDOT) standards for drainage design are provided in the Drainage Manual. Guidelines for drainage design are provided in the various drainage handbooks (Storm Drain, Hydrology, etc.). The Department’s Plans Preparation Manual and CADD Manual provide the standards for preparing the construction plan sets. Discussions about how to best use GEOAPK Drainage to comply with the Department’s CADD standards and guidelines are included in this document where appropriate.

GEOPAK Drainage is a comprehensive application for designing and analyzing storm drain systems, which can leverage many roadway design features to create a seamless information exchange to the drainage design process. A GEOPAK Drainage project may contain multiple drainage networks; each comprised of any number of topologically connected drainage areas, inlets, pipes and ditches. The GEOPAK Drainage workflow closely mirrors conventional design processes allowing for the design of the surface collection system (i.e. drainage areas, inlets) and then the design of the subsequent conveyance system (i.e. pipes, ditches).

GEOPAK Drainage is extremely flexible, in that the hydraulics designer can create and manipulate elements of the system, while simultaneously seeing the effects. Interactive dialogs and design visualization make the process easy to learn and efficiently produce results. Manipulations and redesign are accomplished quickly and easily, whether it's moving a single inlet or developing an entire network. At any time during the process, customized reports can be generated to provide hard copy outputs.

Roadway alignments, vertical profile grade lines, and digital terrain models created as part of the design process may be used throughout SUDA to provide pertinent information to the drainage design. All drainage components feature interactive graphical placement tools for easy spatial definition of the drainage system. Visualization tools in GEOPAK Drainage for networks, drainage components, and computations all but eliminate the tedium of thumbing through pages of computer output to evaluate whether the system is functioning adequately. The visualization allows for immediate evaluation of the drainage system.

GEOPAK Drainage hydrologic and hydraulic capabilities include runoff computations, inlet design and analysis, and pipe and ditch design and analysis. All computations follow recommended methodologies in the Federal Highway Administration (FHWA) publication "Drainage of Highway Pavements" as well as the procedures in the American Association of State Highway and Transportation Officials (AASHTO) Model Drainage Manual.
Runoff computations are performed using either the Rational or SCS method where rainfall parameters may be specified with common intensity equations, hydrographs, or by tabular intensity-duration data. The Department’s Intensity-Duration-Frequency curves are included in the Department’s Drainage Library discussed later in this manual. Drainage area delineation tools allow easy creation of contributing areas and the graphical assignment of these to drainage features. The extremely tedious task of compiling different subareas and runoff coefficients is practically eliminated by GEOPAK Drainage’s graphical shape tool, allowing easy creation of drainage areas and land use boundaries. Once the boundaries are defined, the runoff coefficient and associated hydrologic parameters are computed automatically by delineating the land use zones inside of the drainage area. Any subsequent modifications to the boundaries will update the runoff coefficient via a single mouse click.

Inlet design and analysis capabilities include Curb, Slotted Drain, and Grate inlets both on grade and in a sump. The Department’s common inlets are included in the Department’s Drainage Library discussed later in this manual. Inlets may also be designed or analyzed with bypass flows from one inlet to another, including by pass flows between inlets of different networks.

Most standard pipe configurations may be designed and analyzed including arch, box, circular, elliptical and pipe arches. The Department’s most common pipe and box culvert shapes and materials are included in Drainage Library discussed later in this manual. Pipe design selections may be optimized for either minimize size or minimize depth of cover. Trapezoidal ditches may also be designed or analyzed anywhere within a storm drain network. The pipe and ditch hydraulics include backwater curve computations and junction loss options.

**PROJECT COMPONENTS**

GEOPAK Drainage has four major components within each project: GEOPAK Drainage File (*.gdf), MicroStation 2D Design file (*.dgn), Drainage Library (*.dlb), and the MicroStation Cell Library (*.cel). In contrast to the GEOPAK Drainage File and MicroStation Design file, the Drainage Library and Cell Library are utilized for numerous projects, as they contain the Department’s CADD standards. The designer only has to select the desired items for each specific project.

- **GEOPAK Drainage File (*.gdf)** - This file contains all the hydraulic information about the drainage system. Each GEOPAK Drainage Project contains Preferences, which include hydrologic and hydraulic computation options, visualization symbologies, and project file references to the Drainage Library and GEOPAK GPK files as well as spatial data, connectivity and hydraulic properties for each drainage feature. Sufficient data is maintained to rebuild the graphical representation of the Drainage Project with the exception of certain features, which are defined by MicroStation elements. The user will specify the directory in which the file is created. The GDF database only allows single user access for read and write.

- **MicroStation Design File (*.dgn)** - This graphics file is utilized for the visualization of the drainage project and definition of certain drainage features using MicroStation graphic elements. The only data stored within this file are attributes attached to the graphics for reference to the GEOPAK Drainage file (*.gdf).

- **Drainage Library (*.dlb)** - The Drainage Library is utilized for numerous projects, as it contains the standards for an entire organization. The Drainage Library contains the Rainfall Parameters, standard inlet types, standard pipes configurations, spread sections, and land use symbology tables. All of these items are merely referenced by each project to accommodate standardization and information sharing among projects. The Department provides a Drainage Library with the CADD deliverables. If the designer needs to modify any of the standard provided files, he needs to include these updated files as part of his project deliverable.

- **Drainage Cell Library (*.cel)** - Drainage cells are the plan views of the Department’s drainage structures such as inlets and manholes. The Cell Library contains the commonly used structures. The Nodes used in the Drainage Library refer to appropriate cells in the Cell Library. The Department provides a Cell Library with the CADD deliverables.

- **Design and Computation (D&C) Manager Database (*.ddb)** - The D&C Manager database is used for the Department as a tool to expedite the drafting of plans using the Department’s CADD Standards. The D&C Manager also allows the designer to compute plan view quantities based on MicroStation level symbology.
• **Geometry Database (*.gpk)** - The (*.gpk) file is a database that stores all the geometric information of the project. All alignments (chains), profiles, points, curves, spirals, parcels are saved into a single file per project. Then, GEOPAK Drainage can refer to the nodes location by station and offset from a particular chain and get or calculate elevations from a profile. The (*.gpk) database allows multiple users access for read and write.

• **Criteria files** – The Department has developed criteria files for each drainage structure that can be placed with GEOPAK Drainage. The criteria files are used by GEOPAK to draw the drainage structure cross sections. These files are delivered as part of the Department’s CADD software.

**DRAINAGE COMPONENTS**

GEOPAK Drainage organizes the components of a drainage system according to their spatial characteristics. Spatial information is stored as **Nodes, Links and Networks**.

- **Nodes**: A node (inlets, manholes, etc.) is a point with a user-defined location. The location may be in Cartesian coordinates (x,y) or in curvilinear coordinates (station, offset).
- **Links**: A Link represents a linear feature depicting a path connecting two nodes, traversing upstream to downstream. The path may be straight line or curvilinear (along a graphic element).
- **Networks**: A network is a system of interconnected nodes and links that form a system through which water can flow to a single outlet node. A drainage project accommodates any number of Networks.

Other associated components in GEOPAK Drainage include:

- **Areas**: A drainage area can be represented by a closed boundary or simply keyed-in (acres or hectares). All flows from a single drainage area are tributary to a single Node. There is a **one to one** correspondence between a node and an area. Therefore areas and nodes share the same name (ID). A drainage area may contain multiple subareas representing homogeneous features such as soil types and land uses (“C” values), thereby allowing composite “C” value calculations.
- **Profiles**: A profile represents a path connecting any two nodes in a Network. Profiles provide the visualization of profiles between any two nodes in a drainage network.
GENERAL DESIGN PROCESS FOR STORM DRAINS

The design of a storm drain system is usually an iterative process. Inlets locations and pipe sizes are selected. The designer then checks if the system meets the Department’s criteria and changes pipe sizes and other items as needed. The need to check if the system meets criteria is not avoided by using GEOPAK Drainage. One particular area that can be confusing is that the “Design Mode” of GEOPAK Drainage does not design pipes to meet Hydraulic Grade Line (HGL) requirements. Pipes are sized based on capacity only. This document describes several ways that designers can use GEOPAK to check and identify where the system need to be changed. The following is a general outline for creating storm drain systems in GEOPAK, detailed in other chapters.

1. Start New Project file (.gdf) by Setting Project Preferences.
2. Select Inlet Locations and Types by Adding Nodes.
3. Define Area to each Node.
4. Link Inlets Together with Pipe Segments.
5. Identify Network of Pipes and Inlets.
6. Use GEOPAK to Design System.
7. Check Design to meet Criteria.
8. Edit System, Re-compute Hydraulics and Check if Criteria are met.
9. Add J-structure Bottoms (if appropriate) for Large or Skewed Pipes.
10. Print Storm Drain Tabulation Form.

Note: It is recommended that the designer create or use an already existing GEOPAK Road Project Manager file (*.prj). This will help locate other project files that GEOPAK Drainage may use (D&C Manager (.ddb) file, Coordinate Geometry (.gpk) file, etc).

ACCESSING GEOPAK DRAINAGE: MAIN MENU BAR

GEOPAK Drainage can be accessed from within a two dimensional MicroStation graphics file. From MicroStation Menu select Applications > GEOPAK Drainage, which accesses the software and displays the main GEOPAK Drainage menu bar as depicted below.

Each menu selection accesses GEOPAK Drainage project information, feature placement and tools necessary to complete a GEOPAK Drainage project. Tool frames and toolboxes are also supported for all functions and are accessed via the Tool Boxes pull down menu.

- **Project Menu** - The Project Menu selections are utilized for creating new GEOPAK Drainage projects, opening existing projects, saving projects, establishing the project Preferences, editing the Drainage Library, importing and exporting between GEOPAK Drainage Files (.gdf).
• **Component Menu** - The Component menu selections provide the mechanism to add, edit and delete the various elements, which comprise a drainage system including Areas, Nodes, Links, Profiles, and Land Uses. Each of these selections displays a dialog wherein the specific component information can be added or edited.

• **Network Menu** - The Network menu selections provide the availability to add, edit and delete networks in a drainage file. It can also be identified as an Active Network, which dictates which features are contained in the calculations and provides quick access to the components of a specific Network. Once a Network is added to the project and set as the Active Network, the Design and Analyze options perform their respective hydraulic procedures on the Network.

• **Reports Menu** - The Reports menu selections provide access to the predefined hydrologic and hydraulic reports available and to the Custom Report Builder and Generator.

• **Utilities Menu** - The Utilities menu selections provide access to the Navigator, Conflict Finder, Labeler and DTM Drainage tools.

• **Tool Boxes Menu** - The Tool Boxes menu selections provide access to all of the Drainage Tool Boxes.
VBA APPLICATIONS

The Department has provided Visual Basics Applications (VBA) (.mvba) for specific tasks during the design and plans production process of the drainage system. These VBA applications can be accessed thru the FDOT Menu or Plans Development Workflow. They are:

- **Draw Drainage Profile and Nodes**: draws and annotates the inlet boxes and pipes inside a roadway profile cell.
- **Draw Drainage Pattern Lines**: draws patterns lines across each drainage node present in the (.dgn) file. User can assign the (.dgn) file and model where these lines are going to be printed.
- **Drainage Stub-Out Report for Cross Sections**: creates an ASCII file showing the connectivity and orientation of the pipes in the network. This is later used when executing the proposed cross section run to draw the drainage structures.
- **Drain Tabulation**: creates an Excel spreadsheet for the Department's Storm Tabulation form, Spread Tabulation form and Area Tabulation form with information extracted from the GEOPAK Drainage (.gdf) file.
- **Inlet Balloons**: used manually place Inlet Balloons and can read adhoc values from elements to use in the balloons.
- **Summary of Drainage Structures**: creates an Excel spreadsheet with a summary of drainage structures and pipes following the Department’s guidelines.
- **Sketch of GEOPAK Drainage Network**: creates a jpg image with a sketch (not to scale) of the selected drainage network.

**Exercise 1.1  Creating a New GEOPAK Drainage Project**

➢ **Create the Proposed Drainage File**

Using the Create Files icon, in the FDOTSS4 folder create the DRPRRD01.dgn file in the project folder: C:\\eprojects\22049555201\drainage\.

1. Double click on the Create Files icon. The Create File/Project dialog displays.
   a. Click on the Project Settings button.
   b. The Project Settings dialog displays. Click on the Select Active Project button.
   c. The Select Active Project dialog displays. Click the Browse button, navigate to C:\\eprojects\\22049555201, click Select and then click OK.
   d. Click OK on the Project Settings dialog.
e. The Project is populated with the selected Project path and the Workspace is set to FDOTSS4. Complete the rest of the dialog as shown below:

f. Click Create to create the file, DRPRRD01.dgn.

g. Click Open File to open DRPRRD01.dgn. Set/Update Plot Scale displays. Use the Default settings and click OK.

h. Click OK to close the Create File/Project dialog.
Open GEOPAK Drainage and Create a New Project

1. Open GEOPAK Drainage. From the MicroStation menu select Applications > GEOPAK > DRAINAGE > Drainage. All items in Drainage can be accessed through this main GEOPAK Drainage menu. GEOPAK Drainage displays in an untitled project file.

2. From the GEOPAK Drainage menu, select Project > New… Create a new drainage project: SR61.gdf in c:\e\projects\22049555201\drainage.  

   Note The (.gdf) file was designed as a single-user access database.

3. Open the Main GEOPAK Drainage tool box from the GEOPAK Drainage menu, select Tool Boxes > Main. During the course you will become familiar with the various tools on this tool frame.

   Note The GEOPAK Drainage tool frame is similar to the MicroStation main tool frame, it is resizable and dockable.

4. Save the new drainage project: SR61.gdf. From the GEOPAK Drainage menu, select Project > Save.
2 DRAINAGE LIBRARY

OBJECTIVES

The main focus in this chapter will be on: Reviewing the Drainage Library.

INTRODUCTION

The Drainage Library is used to store data and standards which may be shared by different projects and designers. Each GEOPAK Drainage project simply accesses items within the library for use on the specific project. The library contains five major categories:

- Rainfall Data
- Land Use Runoff Coefficients
- Nodes (Inlets, Junctions, etc.)
- Links (Pipes)
- Spread Sections

The Department has created a drainage library (FDOTSS4.dlb) that will apply to most projects. It is part of the CADD deliverables and is located in the FDOTSS4\GEOPAK\databases\ directory.

The provided drainage library could be modified in order to address the designer’s specific needs. Caution should be used since these changes may affect existing and new projects.

The Drainage Library is invoked by selecting Project > Drainage Library from the Drainage pull down menu or the Drainage Library tool located on the Main Drainage tools tool frame.
RAINFALL ITEMS

Within the Drainage Library, under the Rainfall tab are the Rainfall Zones, which store all the rainfall data to be used on subsequent GEOPAK Drainage Projects. GEOPAK Drainage supports rainfall sources in the form of intensity duration frequency (IDF) tables, two SCS methods, or as coefficients for three different preset intensity duration equation formats. The Department's 11 Intensity-Duration-Frequency (IDF) curves are included in the library through regression equation constants and coefficients. Each curve is associated with a certain zone of the state. Refer to the Department’s Hydrology Handbook for more information.

When an Item is modified or added, the dialog displays the Rainfall Data Source information.

The IDF curves were developed from a statistical evaluation of rainfall data. The third degree polynomial equation provides the best curve fit of the actual data. Caution: The equations should not be used for durations longer than 3 hours.

User should not edit the rainfall source for typical rational method calculations on the Department’s projects. There are, for special occasions, three other Rainfall Data types supported; Table, SCS Unit Hydrograph, and SCS Cumulative Hydrograph. Selecting each of these dynamically changes the dialog to reflect the selection.
**LAND USE ITEMS**

Land Use Items take advantage of the drainage area delineation tools in GEOPAK Drainage and are used to store runoff coefficients and corresponding graphic symbology for various land uses contained in Drainage projects. Under the Land Uses tab, the Department has included a basic land use item. This item is shown below and has its Item ID Land Use. The designer may use this item or create others. Land use items can have as few as one land use description.

The designer must draw MicroStation shapes matching the symbology below so GEOPAK Drainage can recognize and compute the different types of land use areas inside the drainage basins. These MicroStation shapes could be drawn preferably in the active drainage design file or in a referenced (.dgn) file.

- **Item ID:** Land Use Item Identification to recall the item from within a GEOPAK Drainage project. (Maximum of 32 alphanumeric characters).
- **Description:** Description of the Land Use Item. (Maximum of 32 alphanumeric characters).
- **Land Use Description:** Description of each Land Use. (Maximum 32 alphanumeric characters).
- **Runoff C:** Runoff coefficient for the Rational Method (C Value).
- **Symbology** - Specified element parameters which uniquely identify the various land use descriptions.
- **Edit Buttons:** Add – key in the required values in the edit fields directly below the list box, then click Add.
- **OK / Cancel** - Action buttons which also close the dialog.
NODE ITEMS

Node Library Items define the type of Node structures used on subsequent GEOPAK Drainage projects. The Nodes contain the Department’s standard inlet configurations for Ditch Bottom Inlets (grated), Curb Inlets as well as Junctions (i.e., manholes), Outlets, and Other generic Nodes (i.e., grade breaks) as may be required for various Drainage projects. The description, plan view representation, and dimension information for each Node item are included in the library and referenced by each project.

Under each Node Type are various stored Node configurations. A typical listing may appear as follows:

All Node items have certain data that describe them. The typical Node item dialog and common data requirements are shown below. For further explanation of the dialog contents, please refer to the standard GEOPAK Drainage On-line Help.

Note
The bottom part of the dialog contains parameters used in the hydraulic computations of the inlet. These parameters are needed for typical FHWA HEC-12 or HEC-22 calculations. The values provided were determined by the Department’s staff and are felt to be conservative. Nevertheless, if you are using GEOPAK Drainage to perform inlet and spread calculations, you should verify these values.
LINK ITEMS

The Link Items are used to store all the pipe configurations that may be used on a GEOPAK Drainage project.

The Links tab is the source of shapes, materials, dimensions, and hydraulic properties of these features. When designing these components, the items serve as the means to specify design candidates. If pipe items are deleted, these items will no longer be available for use on a project using the specific library.

The Links are categorized by three types of properties for each pipe:

- Shape
- Material
- Type or corrugations

The Department's library contains shapes for box, circular, and elliptical only. Manning's n of 0.012 is applied to all of these and concrete is the only applicable material.

Each pipe contains the specific pipe sizes and default roughness coefficients for each shape, and material combination. GEOPAK Drainage offers both English and Metric libraries, which contain virtually every standard pipe configuration, but the Department only supports the English libraries.
SPREAD SECTION ITEMS

The Spread Section tab is utilized to store roadway pavement spread information.

When double clicking on an entry in the list box, the Spread Section dialog displays.

Input is available for the Spread Width, Slope, and Manning’s N value. The Department's library contains several common spread sections. Note that some or all may not include the gutter. Users can create additional spread sections as needed. Read the Chapter about drainage nodes, particularly the spread criteria for additional information.
Exercise 2.1 Understanding Rainfall Data in the Drainage Library

1. Open the Drainage Library dialog. From the Drainage Menu select Project > Drainage Library.

   Note At this point you may be looking at a default drainage library. We will now open our standard drainage library and review the various items stored in our library.

2. Select File > Open.
3. Open the Drainage Library c:\FDOTSS4\GEOPAK\databases\FDOTSS4.dlb.
4. Select the Rainfall tab.
5. Double click Zone1.

![Drainage Library - Rainfall Data Source Item](image)

6. Review the data source item. The coefficients shown in the table are from the FDOT Hydrology Handbook.

7. Click Cancel. Do NOT close the Library.

   Note If the designer needs to modify any of the standard provided files, he needs to include these updated files as part of his project deliverable.
Exercise 2.2  Reviewing Land Use (Runoff Coefficients) in the Drainage Library

1. Continuing in the Drainage Library, select the Land Use tab.

2. Double click the Land Use item.

3. Review the different Runoff Coefficients for the land uses and associated MicroStation symbology.

4. Click Cancel.
Exercise 2.3  Reviewing the Spread Section in the Drainage Library

1. Select the Spread Section tab. Double click on the std lane + aux (+2, +3 slope) section to modify it.

2. Review the Spread Cross Section Characteristics for each spread item.

3. Exit MicroStation.
3 PROJECT PREFERENCES

OBJECTIVES

The objective of this chapter is to review the Project Preferences.

INTRODUCTION

GEOPAK Drainage supports a wide array of user defined preferences which enables the designer to set project specific options, or a large organization to set parameters to maintain standards. Each GEOPAK Drainage project contains a set of preferences and they remain with the project. Computation options in the preferences may be changed easily and the systems completely redesigned utilizing the new options. The preferences dialog is opened from the Drainage Menu select Project > Preferences. The Drainage Preferences can also be opened by selecting Tool Boxes > Main, then selecting the Drainage Preferences tool icon.

The general Options are displayed in a list box in the left side of the dialog, while the right side displays parameters for the highlighted Option. As different Options are selected in the list box, the right side of the dialog will change dynamically to reflect the parameters for highlighted Option.

UNITS

The first Preference is Units, which establishes the input and output units for the current project. There are two options: English and Metric, but the Department supports only English units.

Within each group box is a listing of the units utilized for GEOPAK Drainage. These are display only and cannot be changed. Projects with mixed units are not supported within GEOPAK. There are no other unit specifications within the project. The data input is expected to be in the proper units (English). As fields are entered in the dialogs the units required will be displayed in the MicroStation Command Prompt.
Coordinate geometry databases (*.gpk) files must also be in the specified units when created within GEOPAK ROAD. For additional information on this topic, refer to the GEOPAK Online help > Coordinate Geometry.

**PROJECT COMPONENTS**

The Project Components define the location of all files utilized by the project.

- **Drainage Library File (.dlb)** - Reference to the Drainage Library file containing the Rainfall Parameters, Land Use Options, Node Library items, Link Library items and spread sections. This file can be located within the working directory, in which case, no path need be specified. However, a more prudent option is placing the Drainage Library File on a central server or directory, so that all hydraulics designers can access the same database. This ensures standardization and minimal maintenance. The file name (and optionally, the path) may be supplied. Clicking Files displays the MicroStation File Manager, wherein the path and database file may be selected.

  The drainage library is FDOTSS4.dlb. The file is provided by the CADD office and located in the directory: \FDOTSS4\GEOPAK\databases.

- **GPK Job Number (Optional)** - GEOPAK coordinate geometry database which contains all alignment and profile information for the project. Creation and manipulation of this binary file must be accomplished from within GEOPAK Road. The file name of the database is job*.gpk, where * is a one to three alphanumeric name unique to each project. It is this name that should be typed into the (.gpk) Job Number field. In lieu of typing, it may be selected by clicking the Select icon.

- **Road Preferences** - The working directory, wherein the GEOPAK coordinate geometry database is located, is specified within this dialog. The directory may also contain other project files, which is desirable; however, this is not required by GEOPAK Drainage.

  The designer should adjust the Output Accuracy group settings as desired, since they will not affect the precision and accuracy of the drainage calculation. They are just output values.
• **Drainage Cell Library** - Cell library containing cells utilized for Nodes contained in the Drainage Library. The cell library is `drplan.cel`. The file is provided by the Department and located in the directory: `\FDOTSS4\RESOURCES\cell`.

• **Criteria Directory** - Directory wherein the criteria to draw nodes, links and other drainage data onto cross sections is stored. The criteria have been developed by the Department and are located in the directory: `\FDOTSS4\GEOPAK\criteria\drainage`.

• **GEOPAK DDB** – This defines the D&C Manager file which is utilized for matching pay items to the Drainage Library in order to draw nodes and links at the desired symbology upon completion of the design process. The file is currently `FDOTSS4.ddb`, but the year will change as updates are made. The file is located in the directory `\FDOTSS4\GEOPAK\databases`.

• **Water and Sewer Project** - Optional, to leverage data from a Water and Sewer project, activate the toggle, then select the directory and *.GWS file. This is not required for the drainage design.

• **Shape File** - Optional, GEOPAK superelevation shapes created with GEOPAK Road can be utilized in drainage design. Specify the path and file name by using the browse icon to locate the appropriate file. In order to utilize and extract superelevation shapes data from the superelevation shape file, the file must be referenced into the active design file. For the Department projects the superelevation shapes are in the XSSHRD model of the Cross Section Design file.

• **Site Project** - Optional, to leverage data from a Site project, activate the toggle, and then select the directory and (*.gsf) file. A site project model or object may be used. This is not required for the drainage design.

• **Original Ground** - The Model, Object or (*.tin) file to be used as existing ground. The Original Ground profile along the drainage pipes is drafted when drawing the profile of the drainage system.

• **Design Surface** - The Model, Object or (*.tin) file to be used as another reference surface, in this case as a “proposed” surface. The Design Surface profile along the drainage pipes is drafted when drawing the profile of the drainage system.

---

**RAINFALL PARAMETERS**

The Rainfall Parameters dialog establishes the rainfall parameters for computing intensities and discharges for the current project.
• **Rational Method Rainfall Source** – The Rainfall Data Source for computing intensities and discharges is stored in the Drainage Library. Refer to the Department Hydrology Handbook for the boundaries of the zones to select the correct zone.

• **SCS Method: Rainfall Source** – The SCS approach is not standard for the Department’s storm drains, but it can be used for preliminary routing calculations. The Rainfall Data Source for computing discharges is stored in the Drainage Library File. Antecedent Moisture Condition I is the lowest runoff potential (dry soil), Antecedent Moisture Condition II is the average condition, and Antecedent Moisture Condition III is the highest runoff potential (saturated soil).

• **Hydrograph Time Interval** - The hydrograph display interval specified in minutes.

**LAND USE OPTIONS**

The Land Use dialog establishes the land use options used to delineate subareas and runoff coefficients for the current project.
Different Single and Multiple Land Use Items can be defined for the Rational and SCS Method.

Since the Rational Method is the standard methodology used for the Department’s Storm Drain projects, the designer should disregard the settings for the SCS Method.

- **Single Land Use Item** - The land use source from the Drainage Library containing the runoff coefficients and symbology for land use delineation may be selected from the list box.
- **Multiple Land Use Item** - The land use sources from the Drainage Library containing the runoff coefficients and symbology for land use delineation. To select, utilize the down arrow in the list box and select the desired option. The item selected must be associated with a symbology that matches the symbology of each of the main land use shapes in the design file. The Department has only defined a Single Land Use Item in their Drainage Library. Therefore, this option would not be used by the designers.
FREQUENCY OPTIONS

The Frequency Options dialog establishes the computation frequency and runoff peaking factors for discharge computations for the current project.

- **Drainage Library File (*.dlb)** - The current Drainage Library as specified in the Project Component option is displayed. It cannot be changed from this dialog, only in Project Components.

- **Computation Frequency (Rational Method)** - The displayed frequencies are selected from the available entries in the Rainfall Parameters chosen from the library. Select the appropriate frequency for the project. Most urban projects use a 3-year frequency and Interstates use a 10 year frequency. Refer to the FDOT Drainage Manual for further details. These fields can only be modified through the Drainage Library dialog.

- **Cumulative Frequency (SCS Method)** - The SCS approach is not standard for the Department’s storm drains, but it can be used for preliminary routing calculations. The displayed depths are selected from the available entries in the Rainfall Parameters from the Drainage Library. These fields can only be modified through the Drainage Library dialog.

- **Peaking Factors** - Runoff coefficient peaking factors to be applied in the runoff computations. These factors are used to adjust runoff coefficients for differing frequency rather than entering multiple set of coefficients for each frequency. GEOPAK applies this factor to all the runoff coefficients whether pervious or impervious. This is not consistent with the FDOT Hydrology Handbook which recommends applying peaking factors to only pervious areas. Regardless, the handbook recommends a factor of 1.0 for 2-year thru 10 year frequencies.
INTENSITY OPTIONS

The Intensity Options dialog establishes the intensity computation options for the current project.

- **Drainage Library File (*.dlb)** - The current Drainage Library as specified in the Project Component option is displayed. It cannot be changed from this dialog, only in Project Components.

- **Minimum Time of Concentration** - Minimum Time of Concentration to use in discharge computations. This is used throughout the computations as the minimum. In pipe hydraulic computations this value will be used until the actual time of concentration within the systems exceeds this value. Specified in terms of minutes.
  
  The FDOT Drainage Manual specifies a minimum of 10 minutes.

- **Accumulate Pipe Flow Time by:** Uniform Flow Velocity Full Flow Velocity Iterative Velocity - This option controls how travel times through the pipes are determined. Refer to the Technical Reference in the Appendices for details. The Department recommends the Iterative Velocity method. When Iterative Velocity is selected, GEOPAK makes three passes up and down the network performing runoff and hydraulic calculations. By making several passes, the velocity used to compute the travel time closely matches the actual flow conditions.
  
  For pipes flowing full, the full flow velocity (V= Q/A) establishes the travel time. For pipes flowing partially full, the average velocity through the pipe establishes the travel time. GEOPAK performs backwater curve (water surface profile) calculations so the average velocity is often different than normal depth (uniform flow) velocity.

  **Note** This approach will result in velocities that are different than would be obtained by using the approach in the Department’s Storm Drain Handbook. Nevertheless, it is acceptable.

  If Full Flow Velocity is selected, the velocity associated with full flow velocity (V= Q/A) establishes the travel time.

  If Uniform Flow Velocity is selected, the velocity associated with normal depth (uniform flow) establishes the travel time.

- **Intensity Options Group** - Intensity options allow for specification of an absolute (constant) intensity or computed intensities to use throughout the network discharge computation procedures.

  For most of the Department’s projects, select Compute Intensity from Library Rainfall Data Source.

- **Compute Intensity from Library Rainfall Data Source** - Utilizes the values established and computed from the Rainfall Parameters (either default equation or table) from within the Drainage Library.
- **Absolute Intensity** - A constant intensity that overrides the Drainage Library and utilizes the specified value for all discharge computations. It is specified in terms of in/hr or mm/hr depending on the project units.

- **Weight Time of Concentration** - *Ignore this for most of the Department’s projects*. When combining different types and times of concentration, activating this toggle weights the times of concentration such that the discharge will not decrease.

- **Inlet Computation Only: Absolute Intensity** - A constant intensity that overrides the Drainage Library File and utilizes the specified value for discharge computations required for inlet and spread calculations only. Network hydrologic discharges will be computed as specified in the Intensity Options. However, for the value to be utilized the toggle on the left of Absolute Intensity within the Inlet Computation Only group box must be activated or the value will be ignored. Specified in terms of in/hr or mm/hr depending on the project units.

  The Department performs most inlet and spread calculations on 4 in/hr. Shoulder gutter inlets may be an exception. Refer to the *Drainage Manual*.

**JUNCTION LOSSES**

The Junction Losses dialog establishes the junction loss equations and coefficients utilized in Link hydraulic calculations for the current project. When selected from the Options list, the dialog depicted below is displayed.

Unique Loss Coefficients (K) can be specified in the fields to the right of each Description, and apply to the whole project. On the other hand, designers can specify a particular Loss Coefficients for each junction in the "Node Configuration - Junction Loss" Dialog box discussed in the Nodes Chapter. However, if the Disable All Junction Loss Computations is activated, no losses will be computed for the entire project.
To compute junction losses, the Storm Drain Handbook encourages using the formula $\text{Headloss} = K \frac{V^2}{2g}$, where $V =$ outlet velocity. Using this approach with GEOPAK Drainage, requires that Disable All Junction Loss Computations be inactive and the remaining portions of the Preferences – Junction Losses dialog be ignored. The K value will be entered in the "Node Configuration - Junction Loss" dialog.

- **Disable All Junction Loss Computations** - If the toggle is active, no Junction Loss computations are calculated, regardless of the option selected in the Nodes - Junction dialog. Note if a single or small number of Junction Losses are not desired, an option is provided in the Nodes - Junction dialog to accomplish this. The toggle here applies to the entire project.
- **Loss Velocity** - Losses can be computed on Actual or Full Flow.
- **Pressure Expansion** - Loss coefficient to be used in pressure (full flow) expansions within the system.
- **Free Surface Expansion** - Loss coefficient to be used in free surface (partial flow) expansions within the system.
- **Pressure Contraction** - Loss coefficient to be used in pressure (full flow) contractions within the system.
- **Free Surface Contraction** - Loss coefficient to be used in free surface (partial flow) contractions within the system.
- **Bend Loss** - Specify the methodology and source of bend loss computations. Method 1 utilizes Modern Sewer Design, while Method 2 utilizes AASHTO methods.
- **Terminal Inlet / Junction** - Loss coefficient to be used at terminal inlets or junctions (no upstream pipes) within the system.
- **Simple Junction** - Specify the methodology for computing junction losses at simple junction (one pipe into junction node and one pipe out). For the Junction losses computations there are two methods available. Method 1: One or more incoming laterals connect directly to the main pipe, without a junction box. Method 2: One or more incoming laterals connect to the main pipe using a junction box.
- **Complex Junction** - Specify the methodology for computing junction losses at complex junctions (more than one pipe in and only one pipe out).

**Note** For a detailed discussion of the specific hydraulic algorithms, see the Technical Reference chapter of this manual.
INLET OPTIONS

The Inlet Options dialog establishes the default inlet variables to use in the Node Configuration Properties dialog.

- **Inlet By Pass Options** - This option indicates the method by which Inlet by pass flows are accounted for in the system. By Pass as Total Discharge will account for by pass flows as the difference between the total discharge to the inlet and the inlet capacity. This difference, expressed in flow units, will be the total by pass from the inlet and can be added at a subsequent downstream inlet. The Department’s spread calculations have typically been performed using this approach, thus this method is recommended for The Department’s projects. By Pass as C x Area Product, on the other hand, is determined from the total bypass at the inlet as a product of runoff coefficient and drainage area that is contributing to the total bypass at the inlets computed intensity. This product of area and runoff coefficient will then be added to the composite runoff coefficient and area at the downstream inlet.

- **Link By Pass Options** - This option indicates the method by which Inlet Bypass flows are accounted in the Link discharge computations. Do Not Allow Inlet By Pass in Link Discharges will prevent the system from bypassing discharges from one inlet to the next when Link discharges are computed. The total discharge that reaches the inlet will be considered entering the Link at that point. This option in no way impacts the inlet computations, bypass flows will be reflected in these computations. The Department’s storm drain calculations have typically been performed using this approach, therefore this method is recommended for the Department’s projects. Allow Inlet Bypass in Link Discharges will account for the discharge that bypasses the inlets when the Link discharges are computed. Only the discharge entering the inlet will be considered entering the Link at that location. Bypass flows will be directed to the appropriate inlet and the Link accordingly.

- **Default Spread N Value** - The default Manning’s roughness coefficient for the spread hydraulic computations. Table 3-2 of the Department’s Storm Drain Handbook provides typical values. A Manning’s n-value of 0.016 accounts for the friction course of the pavement and the broom finish of the concrete curb.

- **Extend Superelevation Shapes to Inlet at Shape Slope** - This option extends the slope of the last superelevation shape to the drainage location point of the drainage node. Sometimes roadway superelevation shapes are not created to the extent of the whole pavement width.
The Node Options establish the default naming prefix for Node entries and option for automatic link updates.

- **Default Node ID Prefix** - This prefix will be added to the beginning of each defined Node element automatically and then numerically sequenced by one. For example, the first Node stored would obtain default ID in this case of S–1 followed by “S–2”, “S–3”, etc. for subsequent Nodes.

- **Scale Node Cells / Scale Factor** - When active, the node cells are scaled based on the specified scale factor. In this way, the node cell can utilize standard node dimensions, but the cells are scaled in the Plan View. The Department's cells should be placed at 1.0, inactivate the Scale Node Cells or set them to 1.0.

- **Minimum Freeboard** - This value does not affect the hydraulic computation in any way. It is used solely to trigger a warning message (HGL Blowout) if the hydraulic gradient causes less free board. GEOPAK measures freeboard from the hydraulic gradient to the inlet elevation. The Department requires 1.0 feet of freeboard from the hydraulic gradient to the theoretical gutter, if junction losses are not computed. For curb inlets this equates to 1.13 feet to the edge of pavement, which is reference elevation for curb inlets.
LINK OPTIONS

The Link Options dialog establishes the default Link design constraints.

- **Default Link ID Prefix** - This prefix, similar to the one found in the Node Options, is added to the beginning of each defined Link element automatically and then numerically sequenced by one. For example, the first Link stored would obtain default ID in this case of “pipe – 1” followed by “pipe – 2”, “pipe – 3”, etc. for subsequent Links. For the Department’s projects, pipe or culvert sections are not labeled in the plans, so this is important only for the designer while designing the system.

- **Link Profile Options group box** - A pipe profile envelope is developed which represents the minimum soffit elevation and maximum invert elevations for each network. This envelope is derived from an evaluation of all the constraints of the system; minimum and maximum depth, minimum and maximum pipe rise, minimum and maximum slope, and any elevations held through the system. These constraints are established later in the Link and Node dialogs. Refer to the Link and Node Chapters for additional information. The Minimize Pipe Size option will use the entire envelope to size pipes. If a smaller pipe will fit within the envelope at a steeper slope then it will be selected as the candidate of choice. If using the entire envelope does not result in smaller pipes then the top of the envelope will be used and the appropriate pipe fitting this slope configuration will be selected. For most of the Department’s projects, the pipe slope and depths are constrained so minimizing the pipe size is the design intent. Select Minimize Pipe Size for most of the Department’s projects. The Minimize Depth of Cover will size pipes based on the top of the envelope, minimum soffit elevation and the pipe fitting this slope configuration will be selected. One Design Optimization method per project may be selected, however, the option may be changed anytime during the design process, the results quantified, and the effects of the Design Optimization reviewed.

- **Minimize Pipe Size** - Drainage bases the design on minimizing pipe size, even though this may encourage deeper excavation.

- **Minimize Depth of Cover** - Drainage designs the system with minimal excavation, but uses larger pipe sizes.

- **Elevation Option** - This refers to the elevation reported for the ends of the links. Two options are supported: at Hydraulic Center and at Actual Link End. Hydraulic Center reports the elevation at the center of the node structure. Actual Link End reports the elevation at the inside of the structure wall. Use Actual Link End for the Department’s projects. The option selected is reflected in the Link dialog in the condition option.
- **Link Design Options** - Only one option may be selected for a project, however, this may be changed during the design process. It is not critical what is selected here, because the pipes will likely be adjusted to meet standards after GEOPAK initially designs the system. To be consistent statewide, it is suggested that Design for Full Capacity be selected.

- **Design for Maximum Capacity** - This option sizes pipe using maximum capacity. This typically occurs at some percentage less than full.

- **Design for Full Capacity** - This option sizes pipe using full flow (100%) by depth. If a pipe is designed, the smallest size corresponding to a capacity greater than the discharge will be selected.

- **Design Partial Capacity \((d/D)\) Ratio** - The ratio of the diameter of the pipe capacity versus the diameter of the total pipe to be used as the maximum capacity in pipe sizing as depicted in the graphic below. Note the value is a ratio (in decimal format) which must be equal to or smaller than one. If the value is equal to one, the pipe is designed for full capacity.

- **Design Partial Capacity \((q/Q)\) Ratio** - The ratio of the pipe capacity versus discharge to be used in computing maximum capacity in pipe sizing algorithms. For example if the value is set to 0.5 then all pipes designed will have a capacity of twice the discharge and if set to 2.0 the pipes would have half the capacity of the discharge.

- **Link Slope Decimal** - Options range from none to four. This limits the number of decimal places reported for most link slopes.

- **Link Criteria File** - Name of criteria file which draws links onto cross sections. `Pipe.x` is the file provided by the Department. This is typically located in the directory `\FDOTSS\GEOPAK\criteria\Drainage`.

- **Hydraulic Grade Line Options** –

  - **Equal Hydraulic Grade Line** - This option for computing HGLs assumes that the starting downstream HGL of one Link is equal to the upstream HGL (plus junction losses if applicable) of the downstream Link. Use this for all of the Department’s projects.

  - **Equal Energy Grade Line** - This option for computing HGLs assumes that the starting downstream energy grade line of one Link is equal to the upstream energy grade line (plus junction losses if applicable) of the downstream Link. The HGL will then proceed from the energy grade line less the velocity head in the pipe. If the energy value in the downstream Link does not exist (too low) in the upstream pipe, the minimum specific energy and critical depth are used at the downstream end of the Link.
PROFILE OPTIONS

The Profile Options establishes the default naming convention for profiles along the links designed.

- **Default Profile ID Prefix** - This prefix is added to the beginning of each defined profile automatically and then numerically sequenced by one. For example, the first Profile stored would obtain default ID in this case of “PRO-1” followed by “PRO-2”, “PRO-3”, etc. for subsequent Profiles. If the links are to be used for COGO chains or profiles, the length of this prefix should be within the parameters for chain and profile character limitations.

- **Create COGO Chains and Profiles** - When toggled on, the links are stored in the coordinate geometry database (GPK) specified in the Preferences - Project Components. The link name is used as both the chain and profile name. Stationing starts at 0+00.

  This is not applicable to the Department’s projects.
PLAN SYMBOLOGY

The Plan Symbology dialog establishes the element symbology for drawing the drainage features during the design process.

These are “design process” symbology, therefore it does not need to match the FDOT CADD standards. When the design is completed, GEOPAK Drainage will update automatically all the CADD elements to be complied with the Department’s standards using the Design and Computation Manager.

- **Linear** - Any valid MicroStation symbology may be specified for drawing the component. To set the symbology, double click on the graphic, which displays the Set Feature dialog.
- **Text** - Any valid MicroStation text parameters may be specified. To set the symbology, double click on the graphic, which displays the Set Feature dialog.

UPDATES

The Updates dialog enables you to determine whether various data is updated during the design process. You may toggle on as many options as desired. When toggled on, the automatic updating is activated. If the option is not toggled on, no automatic updating occurs.
SAVE OPTIONS

- **Automatically Save Drainage Updates** - When activated, the Drainage project file (.gdf) is saved every time an Apply command is issued from any Drainage dialog.
- **Automatic Backup** - When activated, a backup file is always created (in the project directory with a (*.bak) extension) when the project is opened.
- **Automatic Save** - To automatically save, activate the toggle to the left of the option, then select the desired time interval.
PRINTING THE PROJECT PREFERENCES

Users may print all of the preferences by going to the GEOPAK Drainage menu and selecting Project > Export > Preferences to ASCII.

Exercise 3.1 Project Preferences

The Project Preferences control the graphic and computational options of the drainage system. The Project Preferences may be changed at any time and the system can then be redesigned or analyzed utilizing the new preferences.

➢ Setup the Project Preferences

1. Using the FDOTSS4 icon, open the MicroStation file: c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager from the MicroStation menu option Applications > GEOPAK Road > Project Manager.
3. Select project: SR61Drainage.prj located in c:\e\projects\22049555201\ and click OK.
5. Click OK. The Road Project dialog displays. This will setup the proper directories for the location of the (*.gpk) file.

6. Minimize the Road Project dialog.

7. Open GEOPAK Drainage from the Plans Development Workflow Task, select Drainage Plans > Open Geopak Drainage.
8. Open the Drainage project, c:\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.

9. Open the project Preferences. From GEOPAK Drainage select Project > Preferences.

10. Establish the preferences by selecting each option in the columns and defining the various Options.

11. Select the Units as shown below.
12. Select the **Project Components** option. The location of the GEOPAK databases will be filled in according to the installation of the Department’s CADD software.

   **GPK Job Number**  
   job00.gpk.

   **Original ground**  
   c:\\projects\22049555201\survey\GDTMRD01.tin

   **Design Surface**  
   c:\\projects\22049555201\roadway\SR61_FINAL.tin

13. Select the **Rainfall Parameters** option. We will use the **Rational Method** for the Storm Sewer design.

   **Rational Method**  
   Zone 2
14. Select the **Land Use Options** and set the **Rational Method Single Land Use** to **Land Use**.

15. Select **Frequency Options** and set the **Rational Frequency Options** as shown below. This will be your “frequency design storm” for the drainage project.

   - **Computation Frequency**: 3 Year
   - **Runoff Coefficient Peaking Factor**: 1.0
16. Select the **Intensity Options** and set the values as shown below.

- **Minimum Time of Concentration**: 10 minutes
- **Accumulate Pipe Flow Time by**: Uniform Flow Velocity
- **Intensity Options**: Use Compute Intensity from Library Rainfall Data Source
- **Inlet Computation Only**: Toggle OFF
17. Select the **Junction Losses** and toggle **ON** the *Disable All Junction Losses Computations*.

![Image of Junction Losses preferences]

18. Select the **Inlet Options** and set the values as shown below.

- **Inlet By Pass Options**: By Pass as Total Discharge
- **Link By Pass Flow Options**: Do Not Allow Inlet By Pass in Link Discharge
- **Default Spread n Value**: 0.016
- **Extend Superelevation Shapes to Inlet at Shape Slope**: Toggle ON

![Image of Inlet Options preferences]
19. Select the **Node Options** and set the values as shown below.

- **Default Node ID Prefix**: S-
- **Scale Node Cells**: Toggle OFF
- **Minimum Freeboard**: 1.125

**Note**
For this example we have numerous curb inlets. Since the edge of pavement elevation is the reference elevation for curb inlets, we will use 1.125 feet for the minimum freeboard (to trigger the warning). The Department requires 1.0 feet of freeboard from the hydraulic gradient to the theoretical gutter, if junction losses are not computed. Adding the 1.5’ gutter depression gives 1.125’ of freeboard to edge of pavement.

20. Select the **Link Options** and set the values as shown below.

- **Default Link ID Prefix**: pipe-
- **Design Optimization**: Minimize Depth of Cover
- **Elevation Option**: at Actual Link End
- **Link Design Options**: Design for Maximum Capacity
- **Link Slope Decimal**: 2
- **Link Criteria File**: C:\FDOTSS4\GEOPAK\criteria\drainage\pipe.
- **Hydraulic GradeLine Options**: Equal Hydraulic Gradeline
21. Select the **Profile Options** and set the values as shown below.

- **Default Profile ID Prefix**: Pro-
- **Create COGO Chains and Profiles**: Toggle OFF
22. Select the **Plan Symbology** and establish the symbology of the different project elements. The Preferences may be changed at any time during the course of the project.

![Plan Symbology Preferences](image)

**Note** These are “design process” symbology, therefore it does not need to match the FDOT CADD standards. When the design is completed, GEOPAK Drainage will update automatically all the CADD elements to be complied with the Department’s standards using the Design and Computation Manager.

23. Select the **Updates** and toggle **ON all the options**, so all the individual project elements will be updated every time we recalculate our project.

![Updates Preferences](image)
24. Select the **Save Options** and toggle **ON Automatically Save Drainage Updates**.

25. Click **OK** when done.

➢ **Saving the Preferences File**

1. Save the drainage preferences for the project. From the Drainage Menu, select **Project > Export > Preferences to ASCII**.
2. **Exit MicroStation**
OBJECTIVES

The objective of this chapter is to review drainage design procedures on how to place Drainage Nodes and associate them with their corresponding Drainage Areas.

DRAINAGE AREAS

INTRODUCTION

Drainage Areas in GEOPAK Drainage may be used to simply compute peak discharges or to attach computed discharge values to Nodes within a GEOPAK Drainage Project. The physical drainage area boundaries may be delineated using a digital terrain model, simply drawn with MicroStation, or keyed in as a total area value.

The Drainage Library is an integral part of defining and computing discharges for Drainage Areas. With graphical definition of the area boundary, runoff coefficients may be automatically computed with the use of Land Use Items from a Drainage Library.

Intensity values for the peak discharge computations are computed using the Department’s Intensity-Duration-Frequency curves that are part of the Department’s Drainage Library.

Graphical definition of Drainage Areas through the DTM Drainage Tools or MicroStation is accomplished through the creation of MicroStation closed shapes and subsequent selection of the shape during the Drainage Area creation process.

In order to assign Drainage Areas and the resulting peak discharges to Nodes of a storm drain network, the Drainage Area ID must match that of the Node. The best option to match the Node and the Area is thru Components >Node, then selecting the Edit Area button.
The Drainage Areas tool box is opened by selecting **Tool Boxes > Area**, from the GEOPAK Drainage toolbar.

![Drainage Areas Tool Box](image)

Tools from left to right are:
- Add Drainage Area
- Edit Area
- ID Edit Drainage Area
- Delete Drainage Area
- Rename Drainage Area
- Update All Areas
- Drainage Area Report

**DEFINITION**

The Drainage Area Definition dialog is used for adding or editing Areas. The general properties of the drainage area are displayed in a list box on the left side of the dialog under the Options group, while the right side displays parameters for the highlighted Option. As different Options are selected in the list box, the right side of the dialog will change dynamically to reflect the parameters for the highlighted Option. When all the options have been reviewed and appropriate information supplied, pressing the **Apply** button will update the Drainage database.

![Drainage Area Definition Dialog](image)
The Drainage Area Definition dialog is divided into six different group boxes.

- **Description** - This may be used to better describe the drainage area.
- **Hydrologic Method** - Rational and SCS are supported. The FDOT Drainage Manual requires that the Rational Method be used for storm drain design.
- **Drainage Area** - Total drainage area can be entered here or the designer can select a valid MicroStation shape and the software will automatically compute the area of the shape. The area units are either Acres or Hectares, depending on the project units.
- **Base C Value** - If no subareas are delineated, the Base C value applies to the whole drainage area. If subareas are delineated within the drainage area, this Base C value will be applied to all “remaining” subareas that do not have their own C Value. If the Land Use Library items address all the possible land uses on the project, there would be no “remaining” subareas for the Base C-value to apply to. See discussion of Subareas below.
- **Time of Concentration** - The overland Time of Concentration for the Drainage Area expressed in minutes. The minimum time of concentration entered under Preferences >Intensity Options will override smaller values if entered here. The Department recommends a minimum of 10 minutes for Storm Sewer Design. For most of the Department’s projects, the Time of Concentration entered here will not affect the inlet computations, because a constant intensity of 4 inches per hour is used for inlet computations. The Time of Concentration entered here will not always affect the pipe hydraulic calculations. The time of concentration to compute flows in pipes accounts for travel time in upstream pipes.
- **Compute TC** - Displays the Time of Concentration dialog. This is a time of concentration calculator that separates the flow into Sheet, Shallow and Concentrated flow. Different formulas and methods are applied for each type of flow. The flow path could be keyed in by the designer or could be extracted from DTM data.
- **Area Selection / Creation** - Three methods of defining the area are supported: Select Shape, Pick Boundary Element or Create a DTM Shape.
  - **Select Shape**: Select a previously drawn MicroStation shape, click Select Shape, then identify and accept the existing shape. These MicroStation shapes could be drawn in the active design file or be in a visualized reference dgn at the time of selecting the shape.
  - **Pick Boundary Elements**: Click Pick Boundary Elements, then select all required MicroStation elements which comprise the boundary of the area. Note the vertices need not be trimmed but the elements must bound an enclosed region. Once the elements are selected for the bounding area, click DP Create Shape, and indicate a Data Point within the enclosed area. Upon successful creation of the shape, a Data Point will accept the shape and reset will undo the shape. If a solution cannot be found and numerous trials through the bounding elements are occurring, hitting any key will cancel the process.
  - **Create DTM Shape**: Create a Drainage Area shape via the Delineate Watershed-Drainage Area Tool. Drainage > Utilities > Drainage Area Tools.
**SUBAREAS**

In order to delineate and add subareas for a particular Area, select the Subareas item within the Drainage Area Subareas dialog. Subareas are defined as smaller components within a drainage area that exhibit different land uses or runoff coefficients (C values).

The Subareas and C-Values may be entered in the table manually or Subareas may be delineated from the land use boundaries automatically.

The Automatic Delineation button is used to define the subareas within the current Drainage Area. In order for the software to delineate the land use areas automatically, MicroStation shapes need to be drawn into the active or reference (.dgn) file following the symbology specified in the Department’s Drainage Library under the tab Land Uses. The designer can also assign this MicroStation symbology by using the land use definition tool located in Drainage > Components > Land Uses. Upon calculation of the subareas, GEOPAK will write the subarea values in the (.dgn) file unless the Display Only check box is activated.
COMPUTATIONS

The Computation option will calculate the discharge for the selected drainage area, using the computed weighted average or composite C value and the rainfall intensity associated to the entered or calculated time of concentration. The computed discharge shown does not reflect the absolute intensity, if the designer selected an absolute intensity for inlet computations in Preferences > Intensity Options.

DRAINAGE NODES

INTRODUCTION

Nodes in GEOPAK Drainage are used to define structure points within a drainage Network. Nodes create all the Inlets, Junctions, and Outlets in the Network and provide for the connectivity of the Link system. Nodes are also used to indicate physical changes in Link sizes or slopes. Links cannot change size or slope, other than at Nodes. Although GEOPAK supports more, the Department provides library items for the Node types below:

- **Curb** - Used for Curb opening Inlets. The Library items include Curb Inlets Type 1 thru 10, Curb and Gutter Barrier Wall Inlets (Index 219), and Median Barrier Inlets (Index 217).
  
  **Note** GEOPAK Drainage will not analyze the pavement hydraulics (inlet calculations) for Median Barrier Inlets Type 3, 4, and 5. These inlets have two independent drainage areas and multiple spread calculations which the program cannot address. If used, the Department recommends the total drainage area be entered. This allows for accurate pipe hydraulics. The inlet and spread calculations will have to be done separately outside the program.

- **Grate** - Used for Grate opening Inlets. The Library items include all the Ditch Bottom Inlets, the Barrier Wall Inlet (Index 218), Gutter Inlet Type S (Shoulder Gutter), and Gutter Inlet Type V.

- **Slotted Drain** - Used for Slotted Drain Inlets. The Department has no library items at this time.

- **Junction** - Used for any confluence of pipes, structure location (not an Inlet), pipe size or slope change, or flow addition that does not require an Inlet. The library items include junction boxes and manholes.

- **Other** - The Department intends these to be hydraulic openings that accept flow into the system. The library items include Mitered End Sections (MES), Straight Concrete Endwalls, Flared End Sections, U-Endwalls, and 45 Degree Winged Endwalls. These node types can also be used for any miscellaneous points in a system such as a confluence of pipes, structure location (that is not an Inlet), pipe size or slope change, or flow addition that does not require an Inlet. They are also used between links that are ditches.

- **Outlet** - Used for the Outlet, or outfall, of a storm drain Network. The library items include Mitered End Sections (MES), Straight Concrete Endwalls, Flared End Sections, U-Endwalls, and 45 Degree Winged Endwalls.

- **Bottom** - Used for bottom portion of an inlet or node structure. The Department’s setup assumes that all bottoms are type P, no need to store in the database unless another type of bottom (J boxes) are needed.

- **Headwall** - Used by the culvert tool and just for graphical representation purposes.

The Drainage Library is an integral part of defining Node properties. The Node types, names, descriptions, physical dimensions, hydraulic properties, and plan view representation are all defined within the Drainage Library and merely referenced and selected out of the library.
Several options are supported to define, edit and delete Nodes. One option is invoked by the Drainage menu option Components > Node and another option is by selecting Drainage > Tool Boxes > Node, then identifying the desired tool from the tool box as depicted below.

Tools from left to right are:

- Add Drainage Node
- Edit Node
- ID Edit Drainage Node
- Delete Drainage Node
- Rename Drainage Node
- Renumber Node
- Update All Nodes
- Update Nodes With Pay Items
- Drainage Node Report – Sump
- Drainage Node Report – On Grade

**Properties**

To define a node as a part of the drainage network, the Node Configuration dialog needs to be setup with the appropriate node data. The general Options are displayed in a list box on the left side of the dialog, while the right side displays parameters for the highlighted Option. As different Options are selected in the list box, the right side of the dialog will change dynamically to reflect the parameters for highlighted Option. When all the options have been reviewed and appropriate information supplied, pressing the Apply button will update the Drainage database.
- **Node ID** - GEOPAK will automatically number the nodes based on the order in which the nodes are entered. The nodes can be renumbered later in the design process. This is discussed in the Chapter about Design Revisions.

- **Description (optional)** - This may be used to better describe the node.

- **Node Type** - This will show the different node types defined in the drainage library. At present, the Department’s library has items for Curb, Grate, Junction, Other, Outlet, and Headwall.

- **Profile** - The designer needs to specify the profile condition of the particular node to be placed. On Grade or in Sag condition. This affects the input and calculations for spread.

- **Library Item** - Depending of the Node Type selected above, the list box will only show the available nodes that match the type condition.

- **By Pass to Node** - The designer can specify or ID the node that will take the by passed discharge from the active node. During initial input, this option may be left blank since the designer does not know yet which node is going to take the bypass flow.

- **Max By Pass** - Defines the maximum allowable by pass flow from the inlet. No specific computations are adjusted by this value; it is used to merely query the system for by pass flows which exceed this value. Used for On Grade Inlets only. Typically not applicable for the Department’s Projects. This value could be left at zero (default) if no By Pass to Node is specified.

- **Node Bottom** - This refers to J-Bottom structures and is applicable for Curb, Grate, Junction node types. The designer can select a specific J-Bottom structure to be applied to the node and rotate it to fit the pipe arrangement. J-Bottoms are rotated using the Align button. Adding J-bottoms is discussed further in the Design Revision chapter. Typically you will not know if J-Bottoms are needed until after the pipe sizes are determined, so do not add J-bottoms initially. After the pipes are sized, J-Bottoms can be added.

  There is a noticeable difference in the graphical representation where J-Bottoms are added with this toggle. In plan view, the bottom can be shown with the pipes connected to it. This may help to avoid conflicts or it may clutter the plans too much, leaving that to the discretion of the designer.

  The Department has created different J-bottom cells depending on the orientation needed by the designer. E.g Jbottom35x40, Jbottom40x35.

  Concerning the drainage structure cross sections, the Department's criteria files will attempt to draw a J-Bottom where required by pipe size, even if the J-Bottom is not added in plan view; but the orientation of the bottom may not match the pipe configuration. Instead the designer can add a J-Bottom with the proper orientation in the plan view file and include it in the drainage database. J-Bottoms may be more accurately drawn in the cross sections if they are added and aligned using this option.

  The Plans Preparation Manual Section 10.2.6 states the outline of structure bottoms may be shown at the designer’s discretion. The Department is considering changing this to require showing the structure bottoms. Check the latest version of the PPM.

  Adding J-Bottoms has no effect on the hydraulic computations because the calculations are based on the hydraulic length, which is from center to center of structures.

- **Override Library Item** - Each node in the drainage library is associated to a pay item or Item ID in the D&C Manager database. This option will override this linkage, allowing the user to select their Item ID. The Department uses that option to make the placed node an “existing” node for quantity computations. At this time, The Department has defined the following items in the D&C Manager (*.ddb):

  - **Existing Nodes**: /Drainage/Existing Features/ExistStructure
  - **Existing Pipes**: /Drainage/Existing Features/ExistPipe
LOCATION

The designer will place the drainage node into the (.dgn) file using different locating options. If a geometric database (.gpk) is used in the Project Components, the Chain and Profile options will be activated, therefore the nodes could be referenced to a station and offset from the selected alignment or chain, and the node elevation could also be computed from the profile selected. If no (.gpk) file is available, the node will be placed using the coordinate information from the MicroStation file.

• **Chain** - A previously defined horizontal alignment stored in the (.gpk) file. Activate the toggle to the left of the field and select the chain from the list.

• **Profile** - A previously defined vertical profile stored in the (.gpk) file. Activate the toggle to the left of the field and select the desired profile from the list.

• **Align: At Point** - When this option is utilized, the node is placed at the active angle in the MicroStation file at the current or dynamic Node coordinates.

• **Align: Tangent to Chain** - When this option is utilized, the node is dynamically moved along the Chain, and is rotated maintaining tangency to the chain. The designer can enter the station location or place the node dynamically.

• **Align: Tangent on Element** - When this option is utilized, the ID button to the right of the option is activated and the designer is prompted to identify and accept a MicroStation element. The Node is placed tangent to and on the identified element projected from the current or dynamic Node coordinates. The designer can enter the station location or place the node dynamically.

• **Align: Tangent to Element** - When this option is utilized, the ID button to the right of the option is activated and the designer is prompted to identify and accept a MicroStation element. The Node is placed tangent to the identified element at the current or dynamic Node coordinates.

• **Angle** - An optional angle rotation could be applied to the node. A 180-degree angle is often needed to properly align the throat of curb inlets and is sometimes used in conjunction with the Mirror Node toggle.

• **Station and Offset** - Nodes may be located by entering the station and offset in reference to the selected chain. GEOPAK Drainage supports the existence of “station equations”. If station equations are present in the chain, the designer must enter R 2, R 3, R 4, etc. depending on the segment of the alignment this station is found. If "Tangent on Element" is used, the offset is computed.

• **Mirror Node** - When activated, the node cell is mirrored, in order that the same cell can be utilized to accommodate flow coming from either direction.

• **Offset from Gutter to Inlet** - Inlet hydraulic equations assume the Inlet is at the edge of the computed spread (i.e. the Curb). If the Inlet is offset from the Curb, the discharge in the spread section will bypass the Inlet. This value, expressed in terms of feet or meters, is used to compute this bypass and adjust the actual flow to the Inlet. This may be used, for example, when a Grate Inlet is actually set some distance away from the curb of the road. Therefore any flow calculated in that segment will not be added to the inlet and it will bypass to the next assigned one. This value should remain zero for standard the Department’s inlet applications.
SPREAD CRITERIA FOR ON GRADE

Inlets utilize this option to compute the node elevation and spread calculations and for other nodes, it is used for elevations only. The dialog changes slightly depending on whether the Inlet is On Grade or in a Sag. The following are the common components of the Spread Criteria for sections in Sag or On Grade.

The Spread Cross Section table in the box above is used to define the spread cross section including the gutter section and/or pavement section which may encompass the spread of flow approaching the Inlet. The top entry is at the outermost point of flow. In most situations, this entry is the section abutting the curb. GEOPAK Drainage refers to this part of the cross section as Slope 1, Width 1, and Roughness 1.

Adjacent parts of the cross section are identified as Slope 2, Slope 3 etc. as shown below. The cross section defined here may also be used to compute the inlet elevation from the PGL, so the sections should continue to the location of the PGL, if inlet elevations will be computed this way.

A spread section needs to be defined for every node, including junctions or outlets for the software to design or analyze the system, since the spread section could also be used to compute the structure elevation.

Note: The slopes entered are positive in value if “going up” from the inlet's point of view towards the centerline. Negative slopes are supported but not for the bottom (or last) one in the list since it does not convey flow to the node.

The Spread Cross Section table could leverage information from the drainage library, the proposed .tin file or user supplied. Shapes can also be used, but they must be created with GEOPAK and not the new Civil Tools.
• **User Supplied** - The designer will enter the width and slopes across the spread section starting from the Inlet and continuing towards the edge of the section farthest away from the inlet.

• **Reference TIN** - A spread cross section will be extracted at the inlet location from the (.tin) file defined in the Project Components item under the Drainage Project Preferences. The designer needs to be careful on what DTM is using since for most the Department’s projects the only (.tin) file generated is the existing ground (.dtm).

• **Library Item** - A spread cross section will be assigned to the inlet using a Spread Section item defined in the Drainage Library. Once a Library Item has been selected, the spread source can be changed to User Supplied and the spread section defined by the Library Item modified to accommodate non-typical situations such as pavement width transitions.

• **Shape** - A spread cross section will be extracted at the inlet location from the Superelevation Shapes (.dgn) file defined in the Project Components item under the Drainage Project Preferences and shown in the Spread Criteria table.

  For curb inlets in superelevation or superelevation transition, the designer can use this option or enter the spread source (cross section) as User Supplied.

  If the superelevation shapes are not defined to the edge of pavement, the designer can take advantage of the toggle: “Extend Superelevation Shapes to Inlet at Shape Slope”, located in Drainage > Project > Preferences under the Inlet Options item. This will extend the last slope of the shape to the node location point defined in the structure. Within the current (2009) cell library, the node location point is the edge of pavement for curbs and gutter inlets.

  Therefore, if the shape file is used to define the spread, be aware that the cross section starts at the edge of pavement creating a theoretical section that is shifted from the actual spread section by the width of the gutter. This is acceptable if the spread does not extend across a change in cross slope because the calculated spread width is the same regardless of the shift. The gutter depression cannot be modeled with this approach. To account for the gutter depression while using the shape option, the "Shape and Library Item" would need to be used.

• **Shape and Library Item** - A spread cross section will be assigned to the inlet combining the section extracted from the Superelevation Shapes (.dgn) file and Library item from the Drainage Library. If the gutter section is made a library item, this option can be used to account for the gutter capacity.

  To properly use this option, the superelevation shapes need to be defined to the edge of pavement line, and the “Extend Superelevation Shapes to Inlet at Shape Slope” toggle must be off.

  **Note** Some options could be gray out if no active elements are present. E.g. roadway superelevation shapes files or TIN file not specified in the Project>Preferences.

To accurately depict the spread section for inlets along a special gutter grade, the designer can provide the cross section as User Supplied, or use the Superelevation Shapes, if needed to account for a special gutter grade.

The designer can specify threshold values for the spread at each node. When either of the following values is exceeded, GEOPAK Drainage will issue a Warning Message while designing the Network. After a networks is initially designed, it can be Queried for inlets that violate these values.

• **Maximum Ponded Depth** - The maximum depth allowed for ponding in the cross section (expressed in terms of feet or meters). This does not affect any computations, but will produce a warning if the computed depth is greater. For sag inlets, this value is used to compute the capacity of the node.

• **Maximum Ponded Width** - The maximum width allowed for ponding in the cross section (expressed in terms of feet or meters). This does not affect any computations, but will produce a warning if the computed depth is greater.
The Longitudinal Slope for Inlets On Grade can be identified several ways as shown below.

- **Reference PGL** - Slope will be extracted from the profile defined in the Location item of the Node dialog at the inlet location. The slope will update as the (.gpk) file is updated.
- **User Supplied** - Slope will be entered by the designer in percentage format while omitting the % sign.
- **Shape** - Slope will be extracted from the superelevation shapes (.dgn) file defined in the Project Components item in the Drainage Project Preferences. For inlets in superelevation, superelevation transition, or other transitions, the designer can use this option or enter the longitudinal slope as User Supplied.

For an inlet in sag conditions, the approaching longitudinal slopes have no effect on the calculation of the inlet capacity or spread at the inlet. The spread approaching a sag inlet needs to be calculated and the approaching longitudinal slopes affect those calculations. The fields unique to Spread Criteria for Sags relate to the spread along the approaching longitudinal slopes and are discussed below. The designer must specify a value for Maximum Ponded depth for sag inlets. Although this value is not needed to compute spread, it is used by GEOPAK to compute the capacity of sag inlets.

- **% Slope Left and Right** - For defining the longitudinal slope to use in spread (ponded width) computations for the flow approaching from the right and left side of the inlets. The terminology (right and left) is somewhat arbitrary as long as the designer recalls which side is intended as left and right. To be consistent around the State, the Department recommends that Left = Back Station and Right = Ahead Station
- **% Discharge Left and Right** - Defines the percentage of the total discharge to the inlet to allocate to the left and right approach spread computations. The terminology right and left are somewhat arbitrary as long as the designer recalls which side is intended as left and right and is consistent with the definition of % Slope Left and Right. To be consistent around the state, the Department recommends that Left = Back Station and Right = Ahead Station.
For most inlets in sag condition, the % Discharge will be directly related to the ratio of the CA product. For example:

\[
\text{\% Discharge Left} = \frac{\text{CA Left}}{\text{CA Total}}
\]

\[
\text{\% Discharge Right} = \frac{\text{CA Right}}{\text{CA Total}}
\]

The CA Left and CA Right will need to be calculated and documented separately from the program, because GEOPAK Drainage uses only one area for each inlet. For sag inlets that receive bypass from upstream inlets, computing the % Discharge is more complicated. GEOPAK adds the bypass flow to the sag, but the program does not track if the bypass is from the left or right; therefore, the total bypass flow is split based on the percentage values the designer inputs. To accurately account for bypass flows to sags, the inlet calculations must be done twice. The first calculation determines the bypass flow. Then the % Discharge Left and Right are adjusted to account for the bypass flow. The following approach can be used to adjust the % Discharge.

1) Determine Q Bypass Left and Q Bypass Right. These values are shown in the Node Configurations - Computations dialogue for the inlets immediately upstream of the sag inlet.

2) Determine the direct runoff to sump inlet. This can be done two ways.
   a) \( Q \text{ Direct} = \text{CA Total} \times 4 \text{ iph} \) <OR>
   b) \( Q \text{ Direct} = Q \text{ Discharge} - (Q \text{ Bypass Left} + Q \text{ Bypass Right}), \)

   Where Q Discharge is the discharge shown in the Node Configurations - Computations dialogue for the sump inlet.

3) Determine the actual discharge Left and Right.

   \[
   Q \text{ Left Actual} = \left(\frac{\text{CA Left}}{\text{CA Total}}\right) \times Q \text{ Direct} + Q \text{ Bypass Left}
   \]

   \[
   Q \text{ Right Actual} = \left(\frac{\text{CA Right}}{\text{CA Total}}\right) \times Q \text{ Direct} + Q \text{ Bypass Right}
   \]

4) Determine the Adjusted % Discharge.

   Adjusted % Discharge Lt = \( \frac{Q \text{ Left Actual}}{Q \text{ Discharge}} \)

   Adjusted % Discharge Rt = \( \frac{Q \text{ Right Actual}}{Q \text{ Discharge}} \)

   Where Q Discharge is the discharge shown in the Node Configurations - Computations dialogue for the sump inlet.

**ELEVATIONS**

The Node Configuration-Elevation dialog will assign the elevation of the drainage nodes from different sources, dictate the vertical matching point of the pipes entering and exiting the structure, and the minimum and maximum depth of the node.
• **Reference Surface**  Define the desired TIN File or a Model or Object within the site project specified in the Drainage Preferences – Project Components.

• **Elevation Source**  Defines the source of the Node elevation. With the source specified as something other than User Supplied, the Node elevation will automatically update as the Node is moved. The options are:
  
  o **Reference Surface**: Computes the actual elevation from the X and Y coordinates of the structure from the Location dialog and the Reference TIN File or Site Model. This option may be useful for placing Ditch Bottom Inlets at the existing ground elevation depicted in a TIN file.
  
  o **Reference PGL**: Utilizes the Station from the Location dialog to ascertain the profile elevation on the Reference PGL. Note: This option will report the elevation directly at the station on the PGL.
  
  o **PGL+Spread Section**: Utilizes the PGL and information from the Spread Criteria cross section to compute the elevation. The elevation is ascertained along the PGL at the specified Station and then adjusted along the spread cross section width and slope segments to the end of the cross section. Although it says PGL "plus" spread section, the programs subtracts positive values from the PGL.

• **Node Elevation Options**: - The designer may adjust the inlet elevations up or down from the Elevation Source item. These options are:
  
  o **Same as Source**: matches the node elevation with elevation source.
  
  o **Constant Offset**: enables a plus or minus value to the elevation source selected. For example, if the reference profile is PGL+ Spread Section to the flow line of the gutter, a Constant Offset can be specified to have the node elevation be the edge of pavement (EOP) elevation. This is useful because the EOP is used for curb inlet elevations. A plus offset will add to the elevation value.
  
  o **User Supplied**: The user may specify an elevation.

  For the Outlet node elevation, the elevation is not a physical point on the structure. The elevation should be at least 1 foot above the tailwater to avoid a warning. In general, using the berm or ground elevation that covers the outlet structure is acceptable for the outlet node elevation.

• **Vertical Alignment**  Alignment preferences for incoming and outgoing pipes from the Node. As pipes are designed the elevations will be set according to the selected preference. Options available are:
  
  o **Match Soffit**: aligns all the pipes in the system by matching the top of each pipe or crown elevation.
  
  o **Match Invert**: aligns all the pipes in the systems by matching the bottom of each pipe or invert elevation.
  
  o **Match Surface**: aligns the pipes following the elevation of the water surface inside the pipes.
  
  o **Allow Drop Manhole**: allows for “drops” inside the node for the pipes arriving or existing pipes in the node. No matching inverts or soffits will be performed. This option allows for greater flexibility while designing the Department’s projects. Since the design preference is to minimize excavation, the first pass during the design will align all the pipes at the soffit. As the designer needs to move the inverts of certain pipes due to various factors, e.g. utility conflicts, the change will only affect the selected pipe and others will remain at the previously set elevation.
  
  o **Min. Fix Drop**: sets a minimum drop in elevation between the pipes arriving and exiting the node.

• **Minimum Depth** - Minimum depth expressed in master units (i.e., feet or meters) for the pipe to be placed (minimum cover) measured from the Node Elevation to the soffit (top inside) of the highest pipe. This value is used to establish the minimum cover elevation noted in the Link Configuration Conditions dialog. See the discussion below.

• **Maximum Depth** - Maximum depth expressed in master units (i.e., feet or meters), for the pipe to be placed measured from the Node Elevation to the invert of the lowest pipe. This value is used to establish the Maximum Depth elevation noted in the Link Configuration Conditions dialog. See the discussion below.

• **Add Sump Depth** - Extra depth to be allowed in the manhole structure after the maximum depth of the structure has been computed. This has no effect in the hydraulic calculations, but some designers add this extra depth for pollution control measures.
**MINIMUM AND MAXIMUM DEPTH AT NODES**

The values entered for Minimum and Maximum Depth define the vertical limits that the program uses to place the pipe. The Minimum Depth establishes the upper limit that pipes are designed in. The Maximum Depth establishes the lower limit.

The minimum depth of a pipe is often established by cover requirements of Design Standard 205 or by structure clearances discussed in the Storm Drain Handbook. For example, these clearances dictate a Minimum Depth of about 2.7’ for an 18” pipe in a curb inlet. Note that the Storm Drain Handbook refers to the pipe flow line, while this discussion and GEOPAK refer to the soffit. Reasonable results should be obtained by setting all the nodes to have a Minimum Depth equal to that of the nodes at the upstream end of the system. This will not be deep enough for pipes requiring J-Bottoms, but it is a good starting point.

Consider the following for the Maximum Depth: The approximate elevation of the outlet node should be known while designing the storm drain. The outlet elevation may be controlled by the minimum pipe slope or by the depth of the pond at the outlet. The designer will be able to lock the elevation of the outlet pipe in the Link Configurations-Conditions dialog. Locking the elevation of the outlet will control the total drop through the system. This will limit the allowable pipe envelope that the pipes are designed within. Reasonable results should be obtained by setting the Maximum Depth for all nodes to be deeper than the outlet pipe (maybe use a tentative 20’ depth). Again, GEOPAK will not fully use this depth to design the pipes if the outlet elevation is locked.

Regardless of what depths are used, the designer will still need to check for adequate depth, pipe slope, and hydraulic gradient clearance later in the design process.
JUNCTION LOSS

Within this dialog the designer has the option to enter specific values for the junction losses in the particular structure being analyzed. These settings will override the coefficients selected under the Drainage Project Preferences, but the toggle Disable All Junction Loss Computation must be off.

DISCHARGE OPTIONS

The Node Configuration-Discharge option is used to select type and possible amount of flow entering the drainage structure directly from its drainage area or from “offsite” locations.

- **Use Computed Discharge** - Indicates using the computed discharge from a stored Drainage Area as the discharge to the Node.
- **Supplied Discharge** - This option allows for a user supplied discharge, with disregard to any calculated value from a drainage area.
- **Disable Inlet Calculations Capacity** - When toggled on, the designer may provide the desired inlet capacity overriding any GEOPAK Drainage calculated value. This approach can be used if the designer wants to apply the inlet efficiency curves of the appendices in the Storm Drain Handbook. The Department does not require that these curves be used. The HEC-22 equations used by GEOPAK or the Department's efficiency curves are acceptable.
- **Link Base Flow Area / Link Base Flow Discharge** - When toggled on, an additional drainage area may be defined. The area can be identified graphically by clicking ID and selecting the MicroStation shape previously defined as a GEOPAK Drainage Area. For the Link Base Flow Discharge the designer can also enter a value for the extra discharge in the proper units defined in the Project Preferences (cubic feet per second or cubic meters per second). This “extra” area or discharge is included in the pipe, but is not included in the inlet spread calculations.
COMPUTATIONS

Once all the information regarding a specific Node has been defined, clicking the Compute Option computes and displays all pertinent information in the list box. If sufficient information has not been provided, warning or error messages are displayed in the list field.

![Node Configuration - Computations](image)

**Note** The designer should be aware that the computations shown are the spread calculations. Therefore, the value of discharge may be different from the discharge calculated in the drainage area, since the Department’s uses an absolute intensity of 4 inches/hour intensity for inlet computations. This discharge value also includes any bypass discharge added to the current node.

**Exercise 4.1 Drainage Design**

➢ *Opening the Drainage Project*

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. In MicroStation go to Applications > GEOPAK Road > Project Manager.
3. Select project: SR61Drainage.prj located in c:\e\projects\22049555201\, and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. This will setup the directory location of the (*.gpk) file.

6. Minimize the Road Project dialog.

7. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

8. Open the drainage project,
c:\\projects\22049555201\drainage\SR61.gdf.

9. From the Drainage Menu, select Project > Open.

10. Reference in the following files:
   - C:\Projects\22049555201\drainage\DRMPRD00.dgn file
   - C:\Projects\22049555201\drainage\DRREXR01.dgn file
   - C:\Projects\22049555201\roadway\DSGNRD01.dgn file
   - C:\Projects\22049555201\roadway\ALGNRD01.dgn file; model ALGNRD_50
   - C:\Projects\22049555201\survey\GDTMRD02.dgn file
   - C:\Projects\22049555201\survey\TOPORD01.dgn file
Define Properties and Locate Inlet S-200

1. Zoom in around Station 702+00.00 on SR61.
2. Select the Add Drainage Node icon or from GEOPAK Drainage, select Component > Node > Add.
3. Type in S-200 for the Node ID and click OK to Add the Node S-200.

4. Select the Properties Option and assign the Node properties as shown below.

   | Node Type  | Curb        |
   | Profile    | On Grade    |
   | Library Item | InltCurb   |
   | Node Bottom | PBottom35DIA |

5. Select the Location Option and define the inlet’s location in the design plane.

   | Chain | SR61 |
   | Profile | SR61_PR |
   | Align   | Select Tangent to Element. Activate the Select MS Alignment Element button and select and accept the "edge of pavement" line. Activate the Station DP button and the node will dynamically move along the selected element. Using the left mouse button, place the node close to where it is desired. The station can be revised by entering a different station value. |
   | Station | 701+90.00 |
   | Offset  | -44.500   |

6. Click Apply.

   Note This automatically places the inlet at the specified location.
➢ Define Additional Inlet Information

1. Select the Spread Criteria option and define the roadway cross sectional characteristics directly in front of the inlet.

   \[
   \begin{align*}
   \text{Longitudinal Slope Source} & : \text{Reference PGL} \\
   \text{Spread Source} & : \text{Reference TIN} \\
   \text{Max Ponded Depth} & : 0.00 \\
   \text{Max Ponded Width} & : 7.50
   \end{align*}
   \]

   These values will be utilized to calculate inlet capacity and resulting by-pass flow.

2. Select the Elevation option and assign the inlet's vertical elevation and vertical pipe alignment.

   \[
   \begin{align*}
   \text{Reference Surface} & : \text{TIN File, c:\projects\22049555201\survey\SR61_FINAL.tin} \\
   \text{Elevation Source} & : \text{Reference Model} \\
   \text{Node Elevation Option} & : \text{Same as Source} \\
   \text{Vertical Alignment Preference} & : \text{Match Soffit} \\
   \text{Minimum Depth} & : 3.0 \\
   \text{Maximum Depth} & : 20.0
   \end{align*}
   \]
3. Select the **Junction Losses** option and use **Defined Equations** (defaults to **Preferences > Junction Loss Settings**).

![Node Configuration - Junction Loss](image)

4. Select the **Discharge Options** and toggle ON **Use Computed Discharge**.

![Node Configuration - Discharge Options](image)

**Note** This specifies the source of the discharge contributing to this inlet.

- **Complete Hydraulic Computations and Add Node to the Project**
  
  1. Select the **Computations** option to verify the inlet’s hydraulic computations.

  **Note** The Drainage Area for this node won’t be added until the next step. Therefore, the Computations for the node can’t be completed until a discharge is known (next step).

  2. Click **Apply** to add this Node to the project. Do NOT close this dialog yet.
Exercise 4.2  Delineating Drainage Areas for S-200

The physical drainage area boundary may be delineated using a digital terrain model, simply drawn with MicroStation, or keyed in as a total area value (in units of acres or hectares). After the drainage area is delineated using the MicroStation drawing tools, runoff coefficients can be automatically computed with the use of Land Use Items from the Drainage Library.

The basin limits were predefined and were drawn on the MicroStation Level: DrainDividesXX. A closed shape will be created in the next steps in order to become the drainage area for each structure.

1. Turn Off all Reference Files except DRMPRD00.dgn
2. Turn Off all Levels in the DRMPRD00.dgn file except DrainDividesXX.
3. Set the Level to ScratchEle2_dp.

4. Still in the Node Configuration dialog, select the Properties option and click Edit Area.

5. An Alert displays. Click YES to create a new drainage area.
6. Type in **S-200** for the *Area ID* and Click **OK** to add the new drainage area.

7. The Drainage Area Definition displays. Under the *Definition Option*, enter information shown below.

   - **Base C**: 0.95
   - **Time of Concentration**: 10.0

8. From the FDOT Plans Development Workflow, select **Drainage Plans > Flood Element**.
9. Set to **Flood**, **Fill Type** to **None**, toggle **ON Keep Original**, and set the **Max Gap** to **0.01**.

![Create Region dialog](image)

10. **Data Point** inside the area to create the shape.

![Data Point](image)

11. On the **Drainage Area** dialog, select **Definition** option. Under **Area Selection/Creation**, click on the **Select Shape** button and select the **shape** just created.

![Drainage Area Definition](image)

12. The **shape symbology** will be set to **DrainageDivide00**
13. Select the **Computation** option and click **Compute Discharge**. Verify the computations.

14. Click **Apply** to add the *Area* to the Project.

15. Close the *Drainage Area Computations* dialog.

16. Return to the *Node Configuration* dialog, and select **Computations**.

17. Click **Apply** to update the node information.
Exercise 4.3  Complete the Inlet Locations for the Project

We need to complete the remaining inlets for the project with the correspondent drainage areas. Most of the preferences are carried over from the previous node placement.

1. From the Node Configuration dialog, select the Add Node icon.
2. Layout the inlets for the project using the same methodology as described above, and create the correspondent drainage areas.

<table>
<thead>
<tr>
<th>Node ID</th>
<th>Type</th>
<th>Library Item</th>
<th>Node Bottom</th>
<th>Station</th>
<th>Offset</th>
<th>Reference Surface</th>
<th>Elevation Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>S-201</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>703+00.00</td>
<td>-44.50</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-202</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>704+00.00</td>
<td>-44.50</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-203</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>704+00.00</td>
<td>-44.50</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-204</td>
<td>Junction</td>
<td>MHType7JBtm2Cov</td>
<td>PBottom40Dia</td>
<td>704+19.00</td>
<td>53.50</td>
<td>SR61_FINAL.tin</td>
<td>User Supplied Elev. 33.250</td>
</tr>
<tr>
<td>S-205</td>
<td>Curb, On Grade</td>
<td>InltCurb2</td>
<td>PBottom35Dia</td>
<td>704+35.00</td>
<td>-39.00</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-206</td>
<td>Grate</td>
<td>DBIDNoPvt</td>
<td></td>
<td>704+46.00</td>
<td>80.30</td>
<td>SWMF2.tin</td>
<td>User Supplied Elev. 32.500</td>
</tr>
<tr>
<td>S-207</td>
<td>Curb, On Grade</td>
<td>InltCurb2</td>
<td>PBottom35Dia</td>
<td>705+00.00</td>
<td>39.00</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-208</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>705+00.00</td>
<td>-44.50</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-209</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>705+38.00</td>
<td>-44.50</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-210</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>705+80.00</td>
<td>-5.50, 330°</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-211</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>JBottom50Dia</td>
<td>706+15.00</td>
<td>-44.50, 327°</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-211Ot</td>
<td>Outlet</td>
<td>MESC30RCP2S</td>
<td></td>
<td>706+15.00</td>
<td>78.20, 150°</td>
<td>SWMF2.tin</td>
<td>User Supplied Elev. 26.000</td>
</tr>
<tr>
<td>S-212</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>706+15.00</td>
<td>-5.50, 327°</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-213</td>
<td>Curb, On Grade</td>
<td>InltCurb1</td>
<td>PBottom35Dia</td>
<td>707+20.00</td>
<td>-5.50, 320.5°</td>
<td>SR61_FINAL.tin</td>
<td>Reference TIN</td>
</tr>
<tr>
<td>S-214</td>
<td>Grate</td>
<td>DBIDNoPvt</td>
<td></td>
<td>707+20.00</td>
<td>-61.75, 320.5°</td>
<td>SR61_FINAL.tin</td>
<td>User Supplied Elev. 32.8</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Drainage Area ID</th>
<th>Drainage Area</th>
<th>Base C Value</th>
<th>Time of Conc</th>
</tr>
</thead>
<tbody>
<tr>
<td>S-201</td>
<td>0.130</td>
<td>0.95</td>
<td>10.00</td>
</tr>
<tr>
<td>S-202</td>
<td>0.270</td>
<td>0.94</td>
<td>10.00</td>
</tr>
<tr>
<td>S-203</td>
<td>0.124</td>
<td>0.94</td>
<td>10.00</td>
</tr>
<tr>
<td>S-205</td>
<td>0.106</td>
<td>0.80</td>
<td>10.00</td>
</tr>
<tr>
<td>S-207</td>
<td>0.247</td>
<td>0.77</td>
<td>10.00</td>
</tr>
<tr>
<td>S-208</td>
<td>0.091</td>
<td>0.85</td>
<td>10.00</td>
</tr>
<tr>
<td>S-209</td>
<td>0.010</td>
<td>0.95</td>
<td>10.00</td>
</tr>
<tr>
<td>S-210</td>
<td>0.030</td>
<td>0.83</td>
<td>10.00</td>
</tr>
<tr>
<td>S-211</td>
<td>0.339</td>
<td>0.72</td>
<td>10.00</td>
</tr>
<tr>
<td>S-212</td>
<td>0.099</td>
<td>0.87</td>
<td>10.00</td>
</tr>
<tr>
<td>S-213</td>
<td>0.183</td>
<td>0.92</td>
<td>10.00</td>
</tr>
<tr>
<td>S-214</td>
<td>2.758</td>
<td>0.17</td>
<td>23.00</td>
</tr>
</tbody>
</table>

3. Exit MicroStation.
Exercise 4.4  Entering Nodes for Plans Preparation Purposes Only

Even though GEOPAK Drainage is a powerful tool for designing a storm sewer system, it can be very useful for plans preparation purposes only. A drainage engineer may hard-code his particular solution for a drainage system. At the same time they may make use of the graphical interface of GEOPAK Drainage for printing the drainage structures, pipes, profiles and drainage structure cross sections.

Entering data for this purpose is done following the steps in previous exercises, but with the option of key-in the obtained values from design. We will outline the process needed to enter the same S-1 node of a previous exercise but from a plans preparation only approach.

➢ Define Properties and Locate Inlet S-200

1. Zoom in around Station 702+00.00.
2. Select the Add Drainage Node icon or from GEOPAK Drainage, select Component > Node > Add. Click OK to Add the Node S-200.

3. Select the Properties Option and assign the Node properties as shown below.

<table>
<thead>
<tr>
<th>Node Type</th>
<th>Curb</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profile</td>
<td>On Grade</td>
</tr>
<tr>
<td>Library Item</td>
<td>InltCurb1</td>
</tr>
<tr>
<td>Node Bottom</td>
<td>Toggle ON, PBottom35DIA</td>
</tr>
</tbody>
</table>
4. Select the **Location** Option and define the inlet’s location in the design plane.
   
   **Chain** SR61  
   **Profile** SR61_PR  
   **Align** Select **Tangent to Element**. Activate the Select MS Alignment Element button and select and accept the edge of pavement line. Activate the Station DP button and the node will dynamically move along the selected element. Using the left mouse button, place the node close to where it is desired. The station can be revised by entering a different station value.

   **Station** 701+90.00  
   **Offset** -44.500

   ![Node Configuration - Location](image)

   **Note**  The angle and mirror node options should be used to rotate the node correctly. This varies on a case by case basis depending on the type of structure and its location in the project.

5. Click **Apply**. This automatically places the inlet at the specified location.

6. Select the **Spread Criteria** option. Even though this information will not be used for design purposes, the software does not accept “zero” or invalid values. We will use some standard information.

   **Longitudinal Slope Source** Reference PGL  
   **Spread Source** Library Item: std lane(+2 slope)  
   **Max Ponded Depth** 0.00  
   **Max Ponded Width** 7.50

   ![Node Configuration - Spread Criteria for On Grade](image)
7. Select the **Elevations** option. Elevation values will be user supplied.

<table>
<thead>
<tr>
<th>Reference Surface</th>
<th>Not needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elevation Source</td>
<td>User Supplied, Inlet or structure elevation</td>
</tr>
<tr>
<td>Node Elevation Option</td>
<td>Same as Source</td>
</tr>
<tr>
<td>Vertical Alignment</td>
<td>Match Soffit</td>
</tr>
<tr>
<td>Minimum Depth</td>
<td>0.0</td>
</tr>
<tr>
<td>Maximum Depth</td>
<td>0.0</td>
</tr>
</tbody>
</table>

![Node Configuration - Elevations](image)

**Note** Even though we are hard-coding certain parameters, the minimum and maximum depth for the structure must have realistic values.

8. Select the **Junction Losses** option and select **None**.

![Node Configuration - Junction Loss](image)

9. Select the **Discharge Options** option and toggle **On Supplied Discharge**. This eliminates the need to enter a Drainage Area. Enter 0.1 so that GEOPAK Drainage can “run” the system.

![Node Configuration - Discharge Options](image)

10. Click **Apply** when done. We can highlight the **Computations** option just to verify the validity of the data entry but disregarding the calculated values.

11. Click the **Add Node** icon to lay out the remaining structures for the project using the same methodology.
12. Enter the outlet node for the project:

- **Node ID:** S-211 out
- **Type:** Outlet
- **Library Item:** MES30RCP4S
- **Station:** 706+15.00
- **Offset:** 78.20
- **Elevation:** El. 10

13. Exit MicroStation.
CONVEYANCE SYSTEM

OBJECTIVES

The objective of this chapter is to review the placement of drainage links.

INTRODUCTION

In GEOPAK Drainage, Links connect and convey runoff from the various Nodes within a Network to the Outlet, and may consist of pipes, boxes, or ditches. A multitude of options for sizing, and profiling Links are supported.

A Link represents a linear feature depicting a path connecting two Nodes. The path (upstream to downstream) need not be indicated because GEOPAK Drainage will determine the direction of flow purely based on connectivity. The path may be a straight line, line string, curvilinear, or a combination and series of linear MicroStation elements.

The Drainage Library is an integral part of designing and analyzing Links. The library contains all the standard pipe configurations based on shape, material, and, if applicable, corrugations which may be used in a Drainage project. Link library items selected to specify pipe sizes or the shape and material properties within the library may be used to establish the suitable candidates for design.

Several options are supported to add, edit, and delete Links:

One option is invoked by the Drainage menu Component > Link.

A second option is the tool box obtained by selecting Tools > Tool Boxes > Link, then identifying the desired tool from the tool box as depicted below.

![Drainage Links](image)

Tools from left to right are:

- **Add Drainage Link** - Utilized to add a Link to the current GEOPAK Drainage project.
- **Edit Link** - Utilized to select and edit any previously defined and stored Link within the current project. The Link Edit dialog is identical to the Link Add dialog, however, when the Link is identified, all associated data is displayed.
- **ID Edit Drainage Link** - Utilized to ID the link in the design file.
- **Delete Drainage Link** - Utilized to select and delete the specified Link and associated data.
- **Rename Drainage Link** - Rename the link name in the GEOPAK database.
- **Update All Links** - Updates all link graphics in the design file.
- **Update All Links with Pay Items** - Updates all link graphics with the designated pay items (specified in the Drainage Library) from the D&C Manager database.
- **Drainage Link Report - Configuration** - Displays in table report the links configuration (size, inverts, and slopes) after the design is performed.
- **Drainage Link Report - Computation** - Displays in table report the links hydraulic computation (discharge, capacity, HGL) after the design is performed.
A third option is to access the Links from the Navigator (Drainage: Utilities > Navigator).

**LINK CONFIGURATION**

The Link Configuration dialog is the one used to properly place a link (pipe or ditch) into the database. The Link options are displayed in a list box in the left side of the dialog, while the right side displays parameters for the highlighted Option. The options are: Definition; Conditions; Constraints and Computation.

As different Options are selected in the list box, the right side of the dialog will change dynamically to reflect the parameters for highlighted Option. When all the options have been reviewed and appropriate information supplied, pressing the Apply button will update the Drainage database.

**DEFINITION**

This option will define the Link’s path, connectivity, shape, material, roughness coefficient, size, and design options.

- **Description (optional)** - Description of the Link. (Maximum of 32 alphanumeric characters.)
- **From Node** - Identification of the Node from which the Link originates. The flow direction, upstream or downstream, need not be established. The direction is determined by the connectivity of the Network in which the Link resides. If the designer identifies a downstream node as a From Node, GEOPAK will reverse the From Node and To Node based on actual flow direction of the Network. GEOPAK does this when the network is built (See the Network Chapter).

  It is recommended to use the ID button to select the node since it will connect the link to the proper pipe connection points defined in the Department’s Drainage Library.

- **To Node** - Identification of the Node from which the Link originates. The flow direction, upstream or downstream, need not be established. The direction is determined by the connectivity of the Network in which the Link resides.

  It is recommended to use the ID button to select the node since it will connect the link to the proper pipe connection points defined in the Department’s Drainage Library.
• **ID** - Identification of the Node from which the Link originates or ends. The flow direction, upstream or downstream, need not be established. The direction is determined by the connectivity of the Network in which the Link resides.

• **Length** - Once the From Node and To Node are identified, GEOPAK computes the length of the Link based on distance between Nodes or the MicroStation element selected as the Link path. GEOPAK Drainage considers two lengths for a link: actual length and hydraulic length.
  - **Actual Length**: This is the distance from the pipe connection point of one node to the pipe connection point of the next node. This is often called the construction length of the pipe.
  - **Hydraulic Length**: This is the distance from the hydraulic point of one node to the hydraulic point of the next node. This length is used to perform the drainage calculations (travel time, HGL slopes, etc).
    The Department has defined the hydraulic point of every node at the center of the structure.

• **Use MS Element** - To define and select the Link path with previously drawn MicroStation elements. Activate the toggle, press the Select button, then identify the element. This is only used when the designer needs to model a link with a bend without a node.

• **Type Group**: **Pipe or Ditch** - Selection of this option dynamically changes the Configuration group box to reflect the selection. Links in GEOPAK Drainage could be a pipe or a ditch.

• **Configuration** - The Configuration group box will change depending upon designer’s choice to use a pipe or ditch as a link between nodes.

  **Pipe Type** - the Configuration Group box will allow the following:

  ![Configuration](image)

  - **Shape** - Option button for pipe shapes. The Department’s Drainage Library contains only box, circular, and elliptical shapes.
  - **Material** - Option button for Pipe materials. The Department’s Drainage Library has all the links stored as concrete material, so the designer must select concrete. This does not control the pipe material for construction. The pipe material constructed is controlled by the Department’s Optional Pipe process.
  - **Design Size** - Toggle on to indicate pipe size to be determined by the software based on given design Configuration and Constraints. If the pipe is an existing one or the designer wants to select a specific pipe, then toggle off this option. Pressing the Select button invokes the Select Size dialog, wherein the desired size may be selected. Pipes listed in the dialog are based on the sizes in the Drainage Library for the specified Shape and Material configuration.
  - **Design Barrels** - Toggle on to indicate the number of barrels (multiple pipes) GEOPAK is to design based on given configuration and constraints. If the toggle is not activated, GEOPAK designs for one barrel. The designer can select from 2 to 10 barrels from node to node.
  - **Manning’s** - Manning’s roughness coefficient. The default value is based on shape and material found in the Drainage Library. All of the current Library items have Manning’s n = 0.012. This is consistent with the Drainage Manual standards for acceptable Storm Drain and Cross Drain materials.
    The designer can also override this value for each individual pipe.
  - **Override Library Pay Item** - Each pipe in the drainage library is associated to a pay item or Item ID in the D&C Manager database. This option will override this linkage, allowing the user to select their own Item ID. The Department uses that option to make the placed pipe an “existing” pipe for quantity computations.

  **Ditch Type** - the Configuration Group box will allow the following:
✓ *Ditch Type* - A ditch with fixed geometry or cross section based could be placed.
✓ *Ditch Width* - Ditch bottom width in master units (i.e., feet or meters).
✓ *Ditch Depth* - Ditch depth in master units (i.e., feet or meters).
✓ *Side Slope Ratio Left* - Left side slope of the ditch.
✓ *Side Slope Ratio Right* - Right side slope of the ditch
✓ *Manning’s* - Manning’s roughness coefficient.
✓ *Number of Cross Sections* - If the ditch type selected is cross section based:

Number of cross sections to create along the path of the Link. A minimum of four sections is suggested to balance energy.

The TIN file or Site Model to extract the cross sections is specified in the Reference Surface option of the Node Definition dialog.

✓ *Width of Cross Sections* - Width of the cross sections created along the path of the Link. Cross sections will be centered along the Link.

**CONDITIONS**

Defines or reviews the elevation condition for the Link including minimum cover, soffit, invert, and slope data. It also includes the profiling options for holding certain values constant.

The Minimum Cover and Maximum Depth values on this dialog represent calculated elevations based on the values for the nodes connected to the link. The Minimum Cover elevation = Node Elevation - the Minimum Depth of the node. The Maximum Depth Elevation = Node Elevation – Maximum Depth of the node.
The soffit, invert and slope of the pipes are the calculated elevations after the Network is designed. The designer has the option to “lock” these elevations, therefore GEOPAK Drainage will not adjust them. To lock one of these items, activate the toggle and type the desired value in the window. Another option to lock the pipes elevations is through the Edit Profile dialog.

Note GEOPAK Drainage cannot accommodate adverse pipe. If locked or held flow lines result in one of these conditions, GEOPAK will adjust the flow lines to fix the problem, thus giving the appearance that the Lock or Hold Invert option does not work. A Warning message will inform the designer of the changes made to the pipe elevations after the design is performed.

CONSTRAINTS

The Constraints establish further design criteria for Links. GEOPAK Drainage utilizes the physical constraints of minimum and maximum size and slope to determine a suitable pipe size.

GEOPAK Drainage will perform the following steps to determine the “allotted pipe envelope”

Starting upstream, GEOPAK computes each link slope by connecting the nodes at the elevation set by the node elevation minus the minimum depth.

If this slope is less than the minimum slope, GEOPAK Drainage sets the slope equal to the minimum slope. This will provide the upper limit of the envelope. Then, it continues downstream.

To setup the bottom part of the “envelope”, it starts from the outlet elevation, move upstream and setup the minimum invert of the pipes by using node elevation minus the maximum depth values on each node.

If the invert falls within the minimum and maximum slopes the link is placed at the calculated elevation. If not, the link is once again placed at the minimum specified slope from that node to the upstream end of the system.
If during the construction of the envelope, any elevations that the user has held will be accommodated if physically possible and the envelope constrained to that elevation. However, if a held elevation of a pipe violates the minimum or maximum depth line, the elevation will not be held. With the minimum and maximum depth profiles computed, GEOPAK Drainage can then design a suitable pipe within this envelope that satisfies all the constraints possible.

The other constraints, minimum and maximum velocities are for querying purposes and evaluating the adequacy of the design.

- **Minimum Rise Constraint** - Minimum rise (diameter, height) for pipe or ditch in master units (i.e. feet or meters). The Department’s minimum round pipe size is 1.5' (18”).
- **Maximum Rise Constraint** - Maximum rise (diameter, height) for pipe or ditch in master units (i.e. feet or meters). Unless the designer knows a constraint, it is recommended that this be set for a large pipe such as a 6' (72”).
- **Minimum Slope** - Constraint - Minimum physical slope for pipe or ditch expressed in percentage. The minimum pipe slope varies with the pipe size (0.15% for 18”, 0.102% for 24” etc.) See the discussion in the Storm Drain Handbook. During the initial design, the pipe sizes are not known, so this constraint may need to be changed as the design progresses. In moderately sloped terrain, using 0.15% may be acceptable for all pipes, because the terrain will force the pipes to be steeper than that. In flat terrain, using 0.15% for all pipes may cause the downstream pipes to be too deep.
- **Maximum Slope** - Constraint - Maximum physical slope for pipe or ditch expressed in percentage. The Department does not have a maximum slope constraint, so it is recommended that this be set high for all pipes.
- **Minimum Velocity** - Query - Minimum velocity for pipe or ditch expressed in feet per second or meters per second. This value must be something greater than zero for the program to do the hydraulic calculations. This value refers to the actual velocity in the link and not to the minimum velocity concept defined in the FDOT Drainage Manual (Velocity of 2.5 fps defined by the pipe flowing full using the flattest slope possible).
- **Maximum Velocity** - Query - Maximum velocity for pipe or ditch expressed in feet per second or meters per second.
COMPUTATION

The Computations option allows for evaluating the computed hydraulic properties of the Link. Link hydraulics are not available for review until a Network has been established containing the Link and the Network hydraulic computations have been successfully performed.

Exercise 5.1  Links

➢ Opening the Drainage Project

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. From MicroStation menu select Applications > GEOPAK Road > Project Manager.
3. Select project: SR61Drainage.prj located in c:\e\projects\22049555201, and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the drainage project, c:\e\projects\22409555201\drainage\SR61.gdf.
   From the GEOPAK Drainage, select Project > Open.
Link Placement

1. From the GEOPAK Drainage menu, select Component > Link > Add...
2. Type in the Pipe-200 and click OK.

1. Select the Definition option. This sets the pipe's spatial characteristics including From and To Nodes, pipe shape, material, library items, etc.
2. Select the From Node from the pull down menu. For Pipe-200 the From Node should be set to S-200.
3. Graphically identify the From Node pipe connection by selecting the ID icon and clicking on the proper pipe connection point of the structure within MicroStation.
4. Accept the highlighted point by clicking the Apply button on the Link Configuration Definition dialog.
5. Select the To Node from the pull down menu. For Pipe-200 the To Node should be set to S-201.
6. Graphically identify the To Node pipe connection by selecting the ID icon and clicking on the proper pipe connection point of the structure within MicroStation.
7. Accept the highlighted point by clicking the Apply button on the Link Configuration Definition dialog.
8. The pipe length is automatically set.
9. Set the other pipes properties under the Definitions option:
   
   - **Shape**: Circular
   - **Material**: Concrete
   - **Design Size**: Toggle OFF. The designer has the option to select a specific pipe size. If a specific design size does not want to be set toggle ON.
   - **Size**: Click on the Select… button. The Select Size dialog displays. Choose a pipe size from the list and click OK.
   - **Design Barrels**: Toggle OFF and select 1 for the Number of Barrels
   - **Roughness**: 0.012
10. Select the **Conditions** option. The elevations shown are based on the *From-Node* and *To-Node* elevation minus the min/max depth, as specified in the Node Definition dialog for Nodes S-200 and S-201 respectively.

11. In this case, no entries are necessary; Drainage will design all the pipe inverts for this project.

![Link Configuration Conditions](image)

**Note** The designer has the option to key in the value and lock any of the pipe’s invert elevation.

12. Select the **Constraints** option and establish the Minimum/Maximum Design Constraints for the link:

- **Rise** min/max: 1.5 / 5.0 (feet)
- **% Slope** min/max: 0.15 / 10.00 (%)
- **Velocity** min/max: 2.50 / 10.00 (fps)

![Link Configuration Constraints](image)

13. Select the **Computation** option. This displays the computed hydraulic properties of the Link.

![Link Configuration Computation](image)
14. Click the Apply button. This incorporates the link to the project.

15. Add the remainder of the link conveyance system by clicking the Add Link icon.

**Note** As Links are added, most dialog values default from the previous Link with the exception of the node and elevation information.

<table>
<thead>
<tr>
<th>Link</th>
<th>Traverses From Node To Node</th>
<th>Pipe Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIPE-201</td>
<td>S-201 To S-203</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-202</td>
<td>S-202 To S-207</td>
<td>24”</td>
</tr>
<tr>
<td>PIPE-203</td>
<td>S-203 To S-202</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-206</td>
<td>S-205 To S-208</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-207</td>
<td>S-207 To S-211</td>
<td>24”</td>
</tr>
<tr>
<td>PIPE-208</td>
<td>S-208 To S-207</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-209</td>
<td>S-209 To S-208</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-210</td>
<td>S-210 To S-212</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-211</td>
<td>S-211 To S-211 out</td>
<td>30”</td>
</tr>
<tr>
<td>PIPE-212</td>
<td>S-212 To S-211</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-213</td>
<td>S-213 To S-212</td>
<td>18”</td>
</tr>
<tr>
<td>PIPE-214</td>
<td>S-214 To S-213</td>
<td>18”</td>
</tr>
</tbody>
</table>

16. Set S-211 to S-211 out and set the invert elevation of S-211 out to elevation 26.0 using the Conditions option in the Link Configuration dialog.

17. Exit MicroStation.
Exercise 5.2  Entering Pipes for Plans Preparation Purposes Only

Even though GEOPAK Drainage is a powerful tool for designing a storm sewer system, it can be very useful for plans preparation purposes only. A drainage engineer may hard-code his particular solution for a drainage system. At the same time they can make use of the graphical interface of GEOPAK Drainage for printing the drainage structures, pipes, profiles and drainage structure cross sections.

Entering data for this purpose is done following the steps in previous exercises, but with the option of keying the obtained values from design. We will outline the process needed to enter the same pipe-1 link of a previous exercise but from a plans preparation only approach.

1. Select the Add Drainage Link tool. From the GEOPAK Drainage menu select Component > Link > Add.

2. Click OK.

3. Select the Definition option. This sets the pipe's spatial characteristics including From and To Nodes ID's, pipe shape, material, library items, etc.

4. Graphically identify the From Node (S-1) by selecting the ID button and left clicking in the proper pipe connection point of the structure.

5. Accept the highlighted point by left clicking one more time.

6. Graphically identify the To Node (S-2) by selecting the ID button and left clicking in the proper pipe connection point of the structure.

7. Accept highlighted point by left clicking one more time.

8. Set the other pipes properties under the Definitions option:

   Shape       Circular
   Material    Concrete
9. Toggle OFF the Design Size option and click the Select button to pick the already designed pipe size.

10. Click OK when done.

11. Toggle ON the Design Barrels option and select 1 for the Number of Barrels, then toggle OFF.

12. Select the Conditions. Lock (toggle ON) the invert elevations of the pipe and enter the designed values as shown below.

13. Select the Constraints. Enter the standard values as shown below.

**Note** The rise, slope and velocity parameters must have realistic values.

14. Select the Computations. Just verify the validity of the data entry but disregard the calculated values.

15. Click Apply. This incorporates the link to the project.
### FLORIDA DEPARTMENT OF TRANSPORTATION

**STORM SEWER TABULATION FORM**

#### HYDRAULIC GRADIENT
- **CROWN FLOWLINE ELEVATION**:
  - **Rise**:
    - **SLOPE (V)**: 6.13%
    - **ACTUAL VELOCITY (FPS)**: 1.55
    - **FULL CONVEYANCE VELOCITY (FPS)**: 1.55

#### PIPE SIZE (IN.)
- **SPAN**
  - **MBL PHYSICAL**: 1.25in
  - **MBL PHYSICAL**: 1.25in
  - **MBL PHYSICAL**: 1.25in

#### NOTES AND REMARKS

**Chapter 5 Link Configuration**

1. Add the remainder of the link conveyance system by clicking the Add Link icon.

Note: The designer still needs to build a Network and design it in order to create the storm sewer system for plans preparation purposes. Please refer to chapter Networks for the procedure.
6 NETWORKS

OBJECTIVES

The objective of this chapter is to review the creation and computation of a GEOPAK Drainage Network.

INTRODUCTION

A GEOPAK Drainage Network is defined as a series of interconnected Nodes and Links draining to a single outlet. GEOPAK Drainage can maintain multiple Networks in a single project.

The Network computations serve as the final calculation process in the design or analysis of a storm drain system. Drainage Areas and Inlets may be computed individually and are not dependent on any type of Network topology. Pipes and Ditches, however, are dependent on the connectivity and Network characteristic and therefore, require a Network be defined and successfully built, in order to complete the hydraulic computations on these features.

Several options are supported to add, edit, and delete Networks and can be accessed via the Network pull down on the drainage main menu. Alternately, the Network toolbox can be opened by selecting Tool Boxes > Network.

Seven tools are supported in the Network tool box (from left to right):

- **Add Drainage Network** - Initially utilized to define the Network and associated data. When invoked, the Network Configuration dialog is blank.
- **Edit Drainage Network** - Utilized to edit any previously defined Network. When selected, the Select Network dialog is invoked, wherein the desired Network is highlighted. Note the Network Edit dialog is identical to the Network Add dialog, however all associated data is displayed.
- **Delete Drainage Network** - Utilized to delete the specified Network and associated data.
- **Rename Drainage Network** - Utilized to rename any previously defined Network.
- **Design Network** - This mode enables when an Active Network is defined. It's a shortcut to the Design procedure without having to invoke the Network dialog.
- **Analyze Network** - This mode enables when an active network is defined. It's a shortcut to the Analyze procedure without having to invoke the Network dialog.
- **Set Active Network** - GEOPAK Drainage uses an Active Network as a shortcut and organization tool. Many of the reporting, query, and navigation tools support the use of the Active Network to limit the information viewed to the system currently under design (the Active Network). When selected, the Active Network dialog is invoked, wherein a previously defined Network may be specified as active. The current Active Network is displayed on the main menu bar for quick reference.

**NETWORK CONFIGURATION DIALOG**

It is within this dialog where a network is built and computed. The dialog is divided into two major groups: Validation and Computations.

![Network Configuration Dialog](image)

- **Validation**: Build Network. Highlight Network -
  - **Build Network**: Builds the storm drain network starting from the Outlet Node. The purpose of building a Network is to check the topology and connectivity and determine whether this storm drain system is ready to be analyzed or designed. It is at this time that all the flow directions through the Links are established.

  The Network is established by traversing from the Outlet Node upstream, splitting off into multiple paths at a fork, until terminating nodes are reached on all paths. For a gravity system, the topology must be a tree structure.

  This process validates all the interconnected components for errors and/or unexpected conditions like: no or multiple outlets identified, indeterminate flow path due to loops, duplicate links, or multiple downstream links from a single node.

  - **Highlight Network**: Highlights all elements (Areas, Nodes, and Links) contained in the current Network for visual inspection of the system.
- **Computations**: Design Network. Analyze –

  - **Design**: Performs the hydraulic design of all the components contained in the Network. It evaluates the current Network, and designs any features that were indicated as such.

  - **Analyze**: Performs the hydraulic analysis of all components contained in the Network. It evaluates the current network, ignoring all design toggles and maintaining current feature sizes. This can be helpful when evaluating a system that has already been designed to see how it accommodates a different design storm. This is also helpful when the designer is changing the size of certain pipes to meet the hydraulic gradient clearance requirements. In this case the designer may want to change only one pipe while holding the size of the others.

- **Lock/Unlock Sizes** - Lock or Unlock the sizes prior to computing. Be careful with this option since it will lock/unlock all pipes sizes, even the ones manually defined by the designer in the link configuration dialog.

- **Lock/Unlock Elevations** - Lock or Unlock the pipe invert elevations prior to computing. Be careful with this option since it will lock/unlock all pipe inverts, even the ones manually defined by the designer (e.g. existing pipe sizes and invert elevations) in the link configuration dialog.

### Exercise 6.1 Adding Networks

- **Opening the Drainage Project**

  1. Using the **FDOTSS4** icon, open the MicroStation file, `c:\projects\22049555201\drainage\drprd01.dgn`.
  2. Open Project Manager. From the MicroStation menu, select **Applications > GEOPAK Road > Project Manager**.
  3. Select **Project: SR61Drainage.prj** located in `c:\projects\22049555201\roadway`, and click **OK**.
  4. Access **User: Student**
  5. Click **OK**. The Road Project dialog displays. Minimize the Road Project dialog.
  6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select **Drainage Plans > Open Geopak Drainage**.
  7. Open the Drainage Project, `c:\projects\22409555201\drainage\SR61.gdf`. From the GEOPAK Drainage menu, select **Project > Open**.
network design

1. to add a drainage network, from the geopak drainage menu, select the network > add…

2. the add a new network dialog displays. enter the network information as shown below:
   
   network id: sr61-1
   outlet node: s-211 out

3. click ok.

4. the network configuration dialog displays. in the validation section, click build network. the network sr61-1 has now been added to the project. this creates and saves the network and all associated nodes and links.

   note: clicking on this icon isn’t necessary, as geopak drainage can build the network when it performs calculations. however, building a network prior to performing calculations allows the designer to locate potential problems before performing calculations.

5. if geopak drainage is able to build the network, the following information box displays. (total nodes in network and total links in network will vary depending on the project/network).

   note: geopak drainage may still build a network even if it has errors. in such cases, a dialog will display notifying the designer the network has been built and listing the potential errors. if geopak drainage is unable to build the network, an alert message will display stating that geopak drainage was ‘unable to build topology for network [xx].’ common errors include a missing component such as a node or link, a network that has more than one outlet or has duplicated links, or a node that has multiple downstream links.
6. The Highlight Network feature highlights all components (areas, inlets, pipes, etc.) connected to the Active Network. The Outlet Node will not be highlighted.

7. Two options exist under Computations: Design Network and Analyze Network. Using the Design Network option optimizes the design and adjust values as needed, as long as the velocity and capacity are within limits. Click on the Unlock Sizes and Unlock Elevations buttons and then click Design Network.

8. GEOPAK Drainage designs the network and issues the Pertinent Warning messages, if necessary. Warnings are common during the design process. They typically do not affect calculations; instead, they warn the designer that certain criteria has been exceeded or not achieved. When Warnings do occur, an Information box as shown below will display. These Warning messages are saved in a text file named: drgmsg.txt located in the same directory as the (.gdf) file. Click OK to close.

9. Click Apply on the Network Configuration dialog, once the Warnings have been reviewed.

10. Using the Analyze Network option keeps the input values the same, unless a problem occurs with velocity or capacity and an adjustment is made. Click on the Lock Sizes and Lock Elevations buttons in the Network Configuration dialog and then click Analyze Network.
11. This option is common when analyzing systems for different storm. After performing calculations, click Apply.

12. Occasionally, errors occur during the design process. If GEOPAK Drainage is unable to perform calculations, an Information box will display as shown below.

Note: Clicking OK will bring up a window explaining the error (in this case Link Pipe-201 has a reverse slope).
Exercise 6.2  Select Active Network

Selecting a network to be active allows the designer to limit the information viewed to that of the active network. Many of the reporting, query, and navigation tools support the use of Active Networks. Only one network at a time can be active.

1. To set an active network, from the Network Configuration dialog, left of Apply button, click the Set Active Network icon.

2. The Select Active Network dialog displays. Click on the desired network and click OK. The chosen network will become active.

3. Some of the provided reports of this network can now be reviewed. Open the Drainage Reports toolbox. From the GEOPAK Drainage menu select Tool Boxes > Reports.

4. Click on the various Drainage Report icons and review some of the available reports. This will be further discussed in the Reports chapter.

5. Exit MicroStation.
7 DRAINAGE PROFILES

OBJECTIVES

The objective of this chapter is to review the creation of drainage profiles along the conveyance system and check for utility conflicts.

INTRODUCTION

A Profile is a path between two nodes, spanning one or more links. Profiles allow you to define a path running in any direction (upstream or downstream) in a drainage Network and visualize profiles (ground, pipes, depth of cover...) along that path. All that is needed to define a profile is the identification of the From Node and To Node, and GEOPAK Drainage automatically traverses the Network and finds the Links connecting the two Nodes.

Several options are supported to add, edit, and delete Profiles and are invoked via the Component pull down on the Drainage menu. Alternately, the Profile tools are invoked by selecting Tool Boxes > Profile, then identifying the desired tool from the tool box as depicted below.

The Drainage Profiles tool box contains seven tools (from left to right). In addition, the tools can be invoked via the Navigator.

- **Add Drainage Profile** - Utilized to add a Profile to the current GEOPAK Drainage project.
- **Drainage Profile List** - List of profiles in the current drainage project.
- **ID Drainage Link in Profile** - Allows selecting a previously printed profile from the screen and making it the active one.
- **Modify Drainage Profile** - Utilized to select and edit any previously defined and stored Profile within the current project.
- **Delete Drainage Profile** - Utilized to select and delete the specified Profile and associated data.
- **Update All Drainage Profiles** - Recalculates and redraws all the profiles in the active gdf file.
- **Automatic Create Profile** - The Auto Create Profile tool draws a series of profiles based on the specified network.
**EDIT DRAINAGE PROFILE**

When the *Add*, *Edit*, or *Delete* options are selected, the *Edit Drainage Profile* dialog displays.

![Edit Drainage Profile Dialog](image)

The dialog is comprised of the *Description* area and five tabs: *Registration*, *Display*, *Drainage Information*, *Grid & Labels*, and *Link Profile*. The fields detailed below are independent of which tab is selected.

- **Profile ID** - Identification of the Profile is displayed in the Dialog Title bar. (Maximum of 16 alphanumeric characters.)
- **View Number** - Select the view in which the profile is to be drawn.
- **Center Profile** - When clicked, the profile is centered in the specified view.
- **Description** - Description of the Profile. (maximum of 32 alphanumeric characters.) This field is always at the top of the dialog, above the tabs.
- **Apply** - Applies the current Profile information in the project.

**REGISTRATION**

The *Edit Drainage Profile* dialog under the *Registration* tab controls the display of the profile. The setup is reviewed below:

- **Registration Point** - Sets the X and Y coordinates that will be used to print the profile information. These can be keyed in, or the designer can use the DP button and choose a place within the file or model.
- **Scale** - Horizontal and vertical scales. All profiles are drawn to true dimensions in the horizontal, so the scales are used to determine the distortion factor of the vertical. Example: 10 Horizontal: 1 Vertical means that the vertical elements are distorted 10 times larger than the horizontal.
- **Node Information** - The starting and ending points of the profile. These can be changed by selecting the node in the From and To drop down menus, or selecting a node in the design file using the select node icon.

Reset Profile will reset the profile display to the current setting of the dialog after the Project to Chain option is deactivated.

- **Projection Project to Chain** - If the Profile is to be projected onto a chain in order to utilize its stationing, the toggle is activated and chain parameters specified by selecting a profile cell previously printed in the (.dgn) file.
Grid Stationing and Elevations - If Chain Projection is not used, the Stationing at the From Node is set to 0+00 and is assigned to the Registration Point. If Chain Projection is used, the Station matches the Begin Station in the Projection group box. The ending station is automatically computed based on the length of the profile and the Beginning Station.

Reference Surface - Surface utilized to draw the ground profile above the Profile. A site model/object may also be specified. If blank, individual Node elevations are utilized.

DISPLAY

The Display tab determines what information is drawn for each profile. Activate the toggles for the desired components of the profile drawing and set the desired element symbology. For the Water, Drainage, Sewer Line and Misc. Utilities Crossings, labels may be placed by activating the toggle to the left of label. A separate set of symbology is used for the textual label from the crossing elements.

DRAINAGE INFORMATION

The Drainage Information tab allows for other information from the Drainage (.gdf) file to be optionally drawn. This information is generated after the design or analysis of the network. Simply activate the toggle to the left of the desired drainage information, and set the symbology.
GRID & LABELS

The Grid & Labels tab allows for a variety of grid and label options to be supported enabling the user to customize the profile drawings. Six Grid & Labels options are listed on the left side of the dialog. To activate an option, double click to fill the option box. Double click again to turn the option off, which ghosts the right side of the dialog.

![Edit Drainage Profile](image)

LINK PROFILE

In the Link Profile tab, each node of the link profile can be reviewed and modified. Clicking on any Link ID in the list box populates the fields below. To modify, change the desired field(s), then click Modify (to the right of the list box.) To Hold an Invert, toggle on the button to the left of Hold Invert. The Slope can also be held by toggling on in the lower right corner. A pipe size could also be change selecting the Drainage Library Item Option. The user can also click ID then graphically identify one link of the profile. The associated line is highlighted in the list box. After performing the changes, click Apply to accept all modifications. Depending on your Update options under Project > Preferences, GEOPAK Drainage will redesign your network using the same design parameters and constraints specified under the Nodes and Links menus.

![Edit Drainage Profile](image)

**Note**

GEOPAK Drainage cannot accommodate adverse pipes. If locked or held flow lines result in this condition, GEOPAK will adjust the flow lines to fix the problem, thus giving the appearance that the Lock or Hold Invert option does not work. A Warning message will inform the designer of the changes made to the pipe elevations after the design is performed.
PREFERENCES

The Edit Drainage Profile setup can be saved into a Preferences file (.ppf). This file will include all previously defined preferences for the Display, Drainage Information, Grid & Labels and Link Profile tabs. This allows greater flexibility to the users since properties and display information of most profiles in the same project are very similar.

MISCELLANEOUS UTILITIES

Miscellaneous Utilities can be stored within a drainage project and utilized within the utility conflict tool. Each group of utilities is stored as a group, then the group is referenced for conflicts. Therefore, it is prudent to group by location for subsequent location of conflicts, rather than grouping by utility type.

For example, all utilities in an intersection, (i.e., gas, power, cable TV) can be placed within a single group, rather than all gas for an entire subdivision as a group.

This tool checks for conflicts in elevation but it does not address conflicts in the horizontal plane. Miscellaneous Utilities for a drainage project are defined thru the GEOPAK Drainage menu Components > Miscellaneous Utilities > Add.

To properly define a utility location, the user needs to specify the horizontal and vertical location of the buried utilities in the Details section of the dialog. The options available are:

- **Alignment** - Element: specify the MicroStation symbology of the drawn utility.
- **Chain**: Select the desired chain from the list of chain available in the gpk database
- **Elevation Source**
  - **Model**: it can be selected from the list of all models in the current site project or GSF file.
  - **Object**: it can be selected from the list of all models in the current site project or GSF file.
  - **Tin file**: select the DTM or tin file of project.
  - **GPK Profile**: select the desired profile from the list of profiles available in the gpk database. This is only available if chain is selected in the alignment options. The GPK profile is defined at the crown elevation of the utility line.
- **Offset** - Vertical distance (in master units) from the top of the utility to the specified model, TIN file, object or profile. Negative offsets indicate below the terrain, while positive offsets are above it.
- **Size** - Defines the diameter of the utility in terms of master units, feet or meters.

Exercise 7.1 Profile Design
Opening the Drainage Project

1. Using the FDOTSS icon, open the MicroStation file, c:\projects\22049555201\drainage\drprrd01.dgn.

2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.

3. Select Project: SR61Drainage.prj located in c:\projects\22049555201\, and click OK.

4. Access User: Student

5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.

6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the drainage project, c:\projects\22409555201\drainage\SR61.gdf. From the GEOAPK Drainage menu, select Project > Open.

Creating a Drainage Profile

1. From the GEOAPK Drainage menu, select Component > Profile > Add.

2. The Add Profile dialog displays. Enter the Profile ID, From Node, and To Node as shown below:

- Profile ID: Pro-200
- From Node: Select S-201
- To Node: Select S-211 out

3. Click Apply. The Edit Drainage Profile dialog displays. The Registration information will be automatically populated.
4. There are 2 methods of placing the Drainage Profile:

✓ The first is to click on the DP button and Data Point in the MicroStation design file. This will draw the profile at this location with the generic stationing shown in the Grid Stationing area of the Edit Drainage Profile dialog.

✓ The second option is to project the profile onto a previously created profile/chain. Toggle On the Project to Chain option and click on the Identify Profile Cell button. Select the desired Profile Cell in the design file. The Location, Scale, and Stationing will all be set to match the profile cell.

5. Set up all of the other tabs to display the profile as desired.

6. Click Apply. GEOPAK Drainage draws the profile.
Dynamically Editing Profiles

1. Select the Link Profile tab and click the ID Segment/Link icon.

2. Select and accept the link to modify from the profile view. (Pipe-207). This will makePipe-207 the active link.

3. In the Details section, click Edit Invert in the left Node group.

4. Move your cursor into the Profile View. There is a circle around the downstream invert at node S-207.

5. Move the cursor into the circle and drag the Invert. Link: Pipe-207 will dynamically follow your cursor.

6. Data Point to define a new invert location in the profile.
7. Click on the **Modify Segment** icon to accept the changes.

![Modify Segment Icon](image)

8. Click **Apply**. For this example, the **Automatic Update Network** dialog was activated in the **Preferences**, so the network is automatically redesigned.

9. Click **NO** on the **Alert** box, if you do not want to display any **Warning** or **Error** message generated by the design process.

**Note**

GEOPAK Drainage redesigns your system aligning the pipes following the vertical alignment options (Match Soffit, Match Inverts, Allow Drop Manhole, etc.) of your node configuration. The inverts of the modified pipe get automatically locked but if there are other pipe sizes or inverts that you do not want to change, you must lock them in the Link Configuration Conditions dialog before changing an invert as shown above.

➢ **Checking for Utility Conflicts**

1. Select the **Miscellaneous Utilities** tool. From the GEOPAK Drainage menu select **Component > Miscellaneous Utilities > Add**.

![Add Miscellaneous Utility Dialog](image)

2. Enter **ID: Existing_Utility**. Click **OK**.

3. Enter the existing **Sanitary Force Main Utility** in the project.

   - **Alignment Element. Level=SanitaryB ep , Co=ByLevel, Style=ByLevel, Weight=ByLevel**
   - **Elevation Source TIN File. C:\\projects\\22049555201\\survey\\GDTMRD01.tin**
   - **Size 1.0**
   - **Offset -4.0**
4. Click the **Add List Item** icon.

5. Click **Apply** when done.

6. In the **Miscellaneous Utility** dialog, select **File > Save As** to save the file: **Utility Conflicts.utl** under c:\4942062\drainage\eng_data.

7. Close the **Miscellaneous Utility** dialog.

8. In the **Edit Drainage Profile** dialog, select the **Display** tab.

9. Activate the option for **Misc. Utility Crossing** and select **Id: Existing Utilities**.

10. Select a line symbology that easily identifies the **Misc. Utility Crossings**.

11. Click **Apply** to update the profile showing the utility crossings.

12. Dynamically edit the **Profile** where needed, as shown in previous steps.

13. Close the **Edit Drainage Profile** dialog.

14. **Exit MicroStation**
OBJECTIVES

The objective of this chapter is to review the Navigator and its global editing options.

INTRODUCTION

The Navigator tool is an easy method of maneuvering through the components of a GEOPAK Drainage Project. It provides a means to identify, add, edit, delete, and query the components of the current project. The Navigator also provides graphical maneuvering tools to move through the design file and view the components with highlighting and window centering functions.

In addition, the Navigator provides a Global Editor to edit parameters of the project components on a system wide basis. A tool is also provided to update the graphic display of any or all of the components in the Navigator List.

USING THE NAVIGATOR

The Navigator is accessed via Utilities > Navigator from the GEOPAK Drainage menu or from the Drainage tool frame.
The Global Editor is used to edit the input and parameters of the project system on a system wide basis. When View > Global Editor is selected from the Navigator tool bar, the dialog expands as depicted below.

Exercise 8.1 Navigator/Global Editor

- **Opening the Drainage Project**

1. Using the FDOTSS4 icon, open the MicroStation file, 
   c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\e\projects\22049555201\ and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the drainage project, c:\e\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.
➢ **Opening the Drainage Navigator**

1. Open the Navigator dialog. From the GEOPAK Drainage menu, select **Utilities > Navigator**. The Navigator displays defaulted to *All Networks*.

![Navigator](image)

2. Click on the **Nodes** icon.
3. Toggle **ON** Highlight and **Window Center**.
4. Click on the **Nodes** in succession for easy navigation of any Drainage component.
5. Select **View > Global Editor**.

![Global Editor](image)

6. Select all the **Node Components**.
7. In the **Variable to Edit** list box, select **Node – Minimum Depth**.
8. Enter a **New Value** of 3.0.
9. Click **Apply Edit No Confirm**. This changes all values.

*Note* Be careful with this option since it will apply all changes with no warnings. Apply Edit with Confirm will ask the user to click OK before any change in the data.

10. Make **SR61-1** the **Active Network**. From the GEOPAK Drainage menu, select **Network > Active Network**.
11. Redesign the **Network** with these changes in effect. From the GEOPAK Drainage menu, select **Network > Design**.
12. **Exit MicroStation**.
OBJECTIVES

The objective of this chapter is to review the Navigator’s Query mode.

QUERYING FROM THE NAVIGATOR

The Navigator provides a Query tool to specify a subset of the current components based on a query of values or constraints. The Query Tool is only enabled for Areas, Inlets, and Pipes for which numerous computed values and design constraints are available for the query. When the Query toggle is activated, GEOPAK Drainage compiles a list for the selected component based on a designer’s specified condition(s). The dialog depicted below illustrates the invocation of the query feature.

A query can be one of two types; Values or Constraints. A Value query will perform a search for components whose input or computed value for a specified variable meets the specified Condition and Value. A Constraint query will perform a search for components whose computed value for a design constraint meets the Condition.

Note: A complete definition of all the variables used by the Query option could be found in the Technical Chapter of this manual.
Exercise 9.1  Query Mode

➢ Opening the Drainage Project

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\e\projects\22049555201\, and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the drainage project, c:\e\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.
➢ **Query the Drainage Network**

1. Open the Navigator tool. From the GEOPAK Drainage menu select **Utilities > Navigator**.
2. Set the **Active Component Type** to **Inlet** and toggle **On** the Query option.
3. Use the **Query** tool to determine which inlets have exceeded a **Ponded Width** of 8 ft. Set the Query Options as shown below and click **Apply Query**.

   ![Query Options](image)

   - **Query Type**: Values
   - **Condition**: >
   - **Variable**: Ponded Width
   - **Value**: 8.00

   *Note* The components remaining in the navigator meet the conditions of the query.

4. The **Nodes** that have a **Ponded Width** greater 8.0 will be listed in the Navigator dialog.

5. Follow the same procedures to determine the following:
   a. Which **pipes** have a **velocity greater than 3 fps**?
   b. Which **pipes** have **exceeded** their **maximum rise** (diameter)?
   c. Which **inlets** have a **pond width greater than 6 feet**?

6. **Exit** MicroStation.
10 REPORTS

OBJECTIVES

The objective of this chapter is to review GEOPAK standard report features and the Visual Basic Drainage applications for preparing the Storm Tabulation Sheet, Spread Report, Area Report and Network Sketch.

INTRODUCTION

GEOPAK Drainage provides a number of tools to create and generate both custom reports and quick, standardized reports. The standardized reports for Drainage Areas and Inlets are updated dynamically as any of the components contained in the report are updated, so the impact of the changes can be reviewed on the entire system. The Storm Drains/Links report dynamically tracks the condition of the data and provides notification whether the data is current in the report. These summaries are dependent on the Network computations being performed successfully and whenever the Network is designed or analyzed, these report summaries are updated automatically.

All report functions are accessed via the Reports pull down on the main GEOPAK Drainage menu. Alternately, the Reports tools are invoked by selecting Drainage > Tool Boxes > Reports, then identifying the desired tool from the tool box.

Tools from left to right are:

- Drainage Area Report
- Drainage Node Report – Sump
- Drainage Node Report – On Grade
- Drainage Link Report – Configuration
- Drainage Link Report – Computations
- Drainage Report Builder
- Drainage Generate Report

Of these reports, Drainage Areas, Inlets, and Storm Drains / Links are standardized reports, while the Builder and Generate menu selections are utilized for the customized reporting capabilities. Both standardized reports and customized reports can be viewed and subsequently, hard copy output can be produced.
The Report Builder provides a means to build and generate reports on any feature in the drainage project which may include any of the input or computed values for the components. Once the content of a report is designed, the report format can be saved for subsequent use at a later time and/or on other GEOPAK Drainage projects. A custom report will simply consist of row and column data as prescribed by the designer and may be easily imported into other applications that are designed for processing row and column data.

The Report Builder is selected from the main menu or from the Reports tool.

- **Report File menu** - Standard file options include New, Open, Save and Save As and are used to open and save Report File formats for subsequent processing. The default extension is (*.drf). The (*.drf) file saves the format of the reporting, not project specific data. Multiple projects can utilize the same (*.drf) file to generate information, providing standardization to an organization. Files saved within this menu may be accessed in the Report > Generate tool.

- **Component Report Basis** - All custom reports must specify the component that will serve as the basis for the report. A report may only specify one Component Report Basis and the candidate drainage elements for the report are selected based on this selection.

- **Include Active Network Only** - When activated, only the Active Network is incorporated into the reports, rather than All Networks.

- **Component Data** - Once a Report Basis Component is selected, the available Component Data is displayed in this option. Available Data Based on the selected Component Data, all available data is listed for placement into a report.

- **Report Data** - List of items selected from the Available Data list to be included in the report. Note the order of the list is important as it dictates the column layout of the final report. The sample below has three items currently comprising the report, which can be removed or reordered by the Action buttons (< Exclude, Move Up, Move Down) in the center of the main dialog.
• **Include >** - To place data into the report, highlight the desired item in the Available Data list box, then press the Include > button. The item ghosts in the Available Data list box and is added to the Report Data list box. Note multiple selections utilizing the Control and Shift keys are supported. In the sample below, the highlighted item in the Available Data list box, Inlet – Profile Type will be added after Inlet - Type in the Report Data list box when the Include > button is clicked.

• **< Exclude** - If an item in the Report Data needs to be removed, highlight the line, then press the < Exclude button. The line is deleted from the Report Data and un-ghost in the Available Data list box. The < Exclude button is only available when an item in the Report Data is highlighted.

• **Move Up** - After highlighting one line of data in the Report Data list box, pressing this button moves the item up one position in the list.

• **Move Down** - After highlighting one line of data in the Report Data list box, pressing this button moves the item down one position in the list.

• **Output** - Contains output parameters such as file names, decimal places, delimiters, etc.
  - **Default Output File Name** - The default name for the output file.
  - **Files** - Clicking this button invokes the File Manager with the Default Output File Extension as a filter.
  - **Default Output File Extension** - Extension utilized for file naming in addition to filtering in the File Manager dialog. Using the extensions of associated files makes the output reports automatically available to other programs for formatting etc. For example, using an extension of CSV (comma separated values), enables spreadsheet programs that understand the comma separated file to automatically open the report in the proper row and column format.
  - **Decimal Places** - Number of decimal places.
  - **Delimiter** - Specifies the delimiter utilized between items within the output report.
  - **Generate** - Commences the report building process. An informational message is displayed when complete.
  - **View** - Displays the text editor to view, edit, and print if desired. The Windows based editor is depicted below with a sample report. Standard file options and editing capabilities are supported within the editor.
Exercise 10.1 Drainage Tabulation Reports

- Opening the Drainage Project

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.

2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.

3. Select Project: SR61Drainage.prj located in c:\e\projects\22049555201, and click OK.

4. Access User: Student

5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.

6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the drainage project, c:\e\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.

8. Make SR61-1 your Active Network.
Creating Storm Tabulation, Spread Tabulation and Area Tabulation Reports

1. From the FDOT Plans Development Workflow, select Drainage Plans > Drainage Tabulation.

Note: You need to be in the drainage plan file with the drainage project open and all calculations updated to the current state of the project and have a valid network active.

2. The Drainage Tabulations dialog displays. Browse to the Drainage Database file for the current project and fill in all the remaining information needed as shown below. This configuration can be saved at any time during the reports process for use at a later time.

3. Click the appropriate button for the report to generate (i.e. Generate Storm Sewer Tabulation for Storm Tabs and so on).
4. Provide the name **SR61_StormTabs.xls** for the new Drainage Tabulation Excel spreadsheet.

5. Open the spreadsheet in Microsoft Excel to review the results.

Exercise 10.2 Customized Reports

Creating a Custom Report

1. Open the Report Builder dialog. From the GEOPAK Drainage menu, select Reports > Builder.
2. Set the Component Report Basis to Link.
3. Set the Component Data to From Node:
4. Select FN Node-ID, FN Node Description, and FN Node-Type from the Available Data column and click the Include button to add them in the Report Data column.
5. Type in the Default Output File Name and Extension.
6. Select the number of Decimal Places: 3
7. Set the Delimiter to Comma. This sets the Output Format to a comma separated values file or csv.
8. To save this report format as a Template for future use, go to Report File > Save As.
9. Click Generate to create the report.
10. Click the View button to display the data to the screen.
Exercise 10.3 Creating a Sketch of the GEOPAK Drainage Network

1. Open the Sketch of the GEOPAK Drainage Network application. From the FDOT Plans Development Workflow, select Drainage Plans > Sketch the GEOPAK Drainage Network.

2. Click on the magnifying glass and select SR61.gdf as the Drainage Project File.

3. Select SR61-1 as the Network in the Drainage Network Sketch dialog.

4. Click the Scale and Move buttons to adjust the size of the node labels, node cells and link labels.

5. Click the Save icon to store the network sketch as a (.jpg) image file.

6. Exit MicroStation.
OBJECTIVES

The objectives of this chapter are:

- Review System Modification Options
- Add a J-Bottom Structure.
- Analyze for Different Storm Frequencies
- Change Pipe Sizes to Meet Hydraulic Gradient Clearance Requirements

GLOBAL EDITOR

The Global Editor is used to edit the input and parameters of the project system on a system wide basis. The Global Editor is part of the Navigator dialog. To open the Navigator dialog from the GEOPAK Drainage menu go to Utilities > Navigator. For the Global Editor option select View > Global Editor from the Navigator dialog. The designer can change the parameters for drainage areas, nodes, inlets and links from this dialog.

The network system needs to be recalculate after any change is performed in the design.
EDIT NODE AND LINK CONFIGURATIONS

The Node Configurations and Link Configurations dialogs can also be used to edit individual information for nodes or links. From the GEOPAK Drainage menu, select Component > Node > Edit or Component > Link > Edit. The information changed is carried over to the profile view. The network system needs to be recalculated after any change in the design database.
EDIT DRAINAGE PROFILE

The Edit Drainage Profile dialog, Component > Profile > Edit List… allows the designer to make changes in the piping system regarding invert elevations, slopes and pipes sizes. These changes are carried over automatically to the plan view elements.

After pressing the Apply button, the Network system needs to be recalculated unless specified to be done automatically in the Drainage Project Preferences.

Exercise 11.1 System Modification

➢ Opening the Drainage Project

1. Using the FDOTSS 4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\e\projects\22049555201\, and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the Drainage project, c:\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.

8. Set SR61-1 as your Active Network. From the GEOPAK Drainage menu, select Network > Active Network.

➢ Adding a New Structure

1. To add a new Node select Component > Node > Add.
2. Type in S-215 for the Node ID.
3. Set the Node Properties:

<table>
<thead>
<tr>
<th>Node ID</th>
<th>S-215</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node Type</td>
<td>Junction</td>
</tr>
<tr>
<td>Library Item</td>
<td>MHType8PBtm3Cov</td>
</tr>
<tr>
<td>Node Bottom</td>
<td>Toggled ON PBottm35DIA</td>
</tr>
</tbody>
</table>

![Node Configuration - Properties](image-url)
4. Use the **Location** option to define the *Manhole location* in the design plane:

   - **Reference Chain**: SR61
   - **Reference PGL**: SR61_PR
   - **Align**: Tangent to Chain
   - **Station**: 707+20.00
   - **Offset**: -39.00

5. Click **Station DP** to automatically place the *Manhole* at the specified location.

6. Use the **Elevations** option to set the *top elevation* of the manhole:

   - **Elevation Source**: User Supplied. El. 32.50
   - **Node Elevation Option**: Same as Source
   - **Vertical Alignment**: Allow Drop Manhole
   - **Minimum Depth**: 3.0
   - **Maximum Depth**: 10.0

7. Click **Apply** to add the *Manhole* to the project.

8. Close the Node Configuration dialog.
Modifying the Connecting Links

2. Select Pipe-214 and reconnect it from S-215 to S-213.
3. Click Apply to update the Link.
4. Add a new pipe connecting S-214 to S-215. Select Component > Link > Add. The new pipe will use the same conditions and constraints of the previously stored pipes.
5. Close the Link Configuration dialog when done.
➢ Adding a J-Bottom Structure to a Node

2. Under Properties, change the Node Bottom option to JBottom35x50.

![Node Configuration dialog]

**Note** GEOPAK Criteria files were created to default to the standard inlet bottoms when printing cross sections. Criteria files were written to draw J-bottom boxes if the pipes connecting to the nodes require that. The criteria will not always automatically account for the actual location of the largest pipe, thus the structure bottom orientation may not be correct. There is a noticeable difference in the graphical representation where J-Bottoms are added with this toggle. In Plan View, the bottom can be shown with the pipes connected to it. This may help to avoid conflicts. J-Bottoms are more accurately drawn in the cross sections if they are added using this toggle.

3. Select the Align button in the Node Configuration dialog. The Align Top and Bottom Node Cells dialog displays.

![Align Top and Bottom Node Cells dialog]

4. Click the Adjust button under the bottom cell to position the J-bottom. The orientation for standard bottom is limited to the arrangement in the Design Standards. Please refer to Index 200.

**Note** There is no rotation option to place node bottoms. Depending on the orientation needed, the designer needs to select the correspondent box for the project. Meaning Jbottom35x50 or Jbottom50x35. The designer must also check the constructability of the structure setup.

5. Click OK when finished.
6. Click Apply in the Node Configuration dialog to accept the changes.
➢ **Redesigning the Network**

1. Edit the *Network* to add the updated changes. Select *Network > Edit*.
2. Edit *Network: SR61-1*.
3. Click *Build Network* in the *Validation* group.

4. Unlock *Sizes* and *Elevations*.
5. Select the *Design Network* icon and click *Apply*. This will redesign the network with the new structure and new pipe.
**Exercise 11.2 Analyzing Different Storm Frequencies**

Once the system has been designed, pipes sizes and invert elevations are set. If the system needs to run thru a different storm for checking or analysis purposes without modifying the design, simply “Analyze” the system.

1. Open the Project Preferences. From the GEOPAK Drainage menu, select **Project > Preferences**.
2. In the Project Preferences, change the design frequency of the drainage project. Select the **Frequency Option** item in the Preferences dialog and set to a **25 year Computation Frequency**.

![Preferences dialog](image)

3. Click **OK**.
4. Open the **Network Configuration** dialog. From the GEOPAK Drainage menu, select **Network > Edit**. Under **Computations** click the **Analyze** icon. GEOPAK Drainage runs the storm to the preset pipe sizes and elevations.

![Network Configuration dialog](image)

5. Examine the updated **HGL** on the previously printed **Profile Pro-200**. See the lab exercise in the **Drainage Profiles** chapter of this manual.

   **Note**  
   GEOPAK Drainage will automatically update the Hydraulic information on all the system profiles printed in the MicroStation file.

6. Change your **Computation Frequency** back to the **3 Year storm** and update the calculations.
Exercise 11.3 Meeting Hydraulic Gradient Clearance Requirements

➢ Updating the Tailwater Conditions

1. Update the Tailwater Elevation for the Outlet Node S-211 out as shown below.

   ![Node Configuration - Properties](image)

   2. Click Apply when done.

3. Perform a Network Design in order to compute the new Hydraulic Grade Line.

   ![Network Configuration - [SR61-1]](image)

4. Review the Warning Messages in the drgmsg.txt file.

5. The HGL clearance requirement is not being met for Pipe-210. This is the Minimum Freeboard option defined in the Drainage Project Preferences under the Node Option item.

6. Close the Editor box.
Dynamically Editing the Profile

1. From the GEOPAK Drainage menu, select Component > Profile > Edit List...
2. Select Pro-200 and click OK.
3. Click the Center Profile icon to visualize Profile Pro-200 in View 1. This is the icon to the left of the Apply button.
4. Select the Link Profile tab and click the ID icon.
5. Select from the Profile View in the MicroStation file the Link to be modified (Pipe-211). The Link becomes highlighted, accept your selection. This will make Pipe-211 the Active Link.
6. In the Drainage Library Item group, change the Pipe Size to a 30" pipe.
7. Click Modify to accept the changes.
8. Click Apply to recalculate the network.
9. Review the Warning Messages in the drmsg.txt

Note: Any changes performed in the Edit Drainage Profile dialog automatically updates the link information that could be accessed thru Drainage: Component > Link>Edit.

Drainage redesigns your system aligning the pipes following the Vertical Alignment options (Match Soffit, Match Inverts, Allow Drop Manhole, etc) of your Node configuration.

11. Exit MicroStation.
12 PLANS PREPARATION

OBJECTIVES

- Review Plans Preparation Procedures under GEOPAK Drainage
- Renumber Nodes Along Network System
- Plan View Labeling
- Printing Network System Along Roadway Profile

RENUMBER NODES

GEOPAK Drainage provides an automatic tool to renumber all the nodes in the gdf file. From the Drainage menu select Component > Nodes > Renumber.

The renumbering tool will update not only the selected nodes, but all the pipes connected to them, drainage areas and profiles. Conflict resolution procedures are also available to the user prior the renumbering process.

The Renumber Node dialog is divided in four groups:

- **Alignment** - Possible nodes for renumbering will be scanned along a specified chain and station range. The scan range is also limited by a search distance along the left and right side of the alignment. The Find button will initiate the scanning process.
- **Numbering** - The new nodes will be renumbered or renamed according to the new prefix, number and suffix specified
- **Nodes Inside the Scan Range** - The list box will show the encountered nodes along the alignment after the scanning process is finished.
- **Node Name Conflicts outside the scan range** - This list box will be populated only if the new numbering of the nodes has a name conflict with an existing node in the system that was not selected by the FIND process. Designers resolve this on an individual basis, renaming the conflict node and place it into the Nodes inside the Scan Range list box.
PLAN VIEW LABELING

The Plan View Labeling automates the composition and placement of plan labels onto drawings. This interactive tool permits the creation of very simple to complex labels using many of the following features:

- Numerous Computed Text Inserts permit standardized computed values to be easily incorporated into labels. These standardized computed values are based on the type of element to be labeled and change as you select different elements. Types of elements available for computed inserts include points, lines, arcs, complex graphic elements, COGO features, and drainage features.
- User Text Inserts facilitate the simple inclusion of user defined text strings into the label. These User Inserts can be customized to include frequently used labeling terms and be saved for continual use.
- Standard shapes can be placed around labels and to accommodate different plan label formats.
- Standard leader lines and leader line terminators can also be utilized to create the desired label formats.
- Frequently utilized labels can be stored as Label Styles for subsequent recall. The complete label, including computed text inserts, user inserts, shapes, and leaders, are all stored within the Style.
- Tools to edit, move, and extract labels are also provided to make manipulation and plan changes easier.
- Enhanced ASCII is supported by use of the (\) symbol.
- Styles are supported, whereby often used labels and associated settings can be saved off and recalled in subsequent sessions.
- Updating options provide for efficient changing as the project dictates changes in the design.

While the labeler can be used for generic purposes, several of the fields are set up for specific applications. The specialty modes include:

- Plan View
- Profile
- Cross Section
- Drainage
- Site
- Water and Sewer

Under each mode, the types of elements available to label and the associated text inserts change. Other than this change, the remaining functionality operates exactly the same under each mode.
Exercise 12.1 Renumbering Nodes

➢ Opening the Drainage Project

1. Using the FDOTSS4 icon, open the MicroStation file, c:\\projects\22049555201\drainage\drpr01.dgn.

2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.

3. Select Project: SR61Drainage.prj located in c:\\projects\22049555201, and click OK.

4. Access User: Student

5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.

6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the Drainage project, c:\\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.
Renumbering the Nodes

Warning  It is recommended that before renumbering, the designer should create a copy of the (.dgn) and (.gdf) file for the drainage project as a backup.

1. Open the Renumber Nodes tool. From the GEOPAK Drainage menu, select Component > Node > Renumber.

2. Fill out the Renumber Nodes dialog as shown below. We will renumber all the structures following the direction of the Alignment SR61, starting with Structure S-200.

3. Once the correct parameters have been set, click Find. All of the nodes found inside the set parameters will be listed in the box below.

4. Select all of the Nodes in the list and click Renumber Nodes. GEOPAK Drainage will renumber all the drainage structures, update the links connections, and drainage areas, and according to our previously setup project preferences it will update the calculations and profiles.

5. Close the Renumber Nodes dialog when done.
Exercise 12.2 Plan View Labeling

- **Labeling Drainage Structures**

1. Open the Drainage Labeler. From the GEOPAK Drainage menu, select **Utilities > Labeler**.
2. Select the **Text** tab and set the **Component** to **Node**.

3. Select the first **Element ID**: S-200.
4. Double-click the **Computed Text**: **Node-ID** to add it to the **Editor** box.
5. Click on the **Parameters** tab and set the **Text Preferences/Symbology** as shown below. You will need to double-click on the text ‘Sample’ box to bring up the **Set Feature** dialog.
6. Select the **Shape** tab, and set the **Shape Preferences** and **Symbology** as shown below:

![Shape tab settings]

7. Select the **Leader** tab and set the **Leader Type** and **Terminator** as shown below.

![Leader tab settings]

8. Select the **Rotate** tab and select the **Current Angle** option as shown below:

![Rotate tab settings]

9. Place the **Label** in the design file by clicking **Place Label**.

10. Create a new **Style** by selecting the **Styles** tab and clicking on **New Style**. Provide a **style name** for the label, and click **OK**.

11. Save the **Style** by selecting **Style Files > Save**.

12. Select the **Text** tab, and select the second **Structure**: **S-201**. By activating the **Highlight** and **Window Center** toggles, the **Drainage Labeler** will navigate to the correspondent drainage structure location in the (.dgn) file. Label the remaining **Drainage Structures**.
Labeling Pipes

1. After labeling the Drainage Structures, click the Clear button in order to empty the Labeler box.
2. Select the Text tab and set the Component to Links.
4. Compose the label by double-clicking the Computed Text: Link-Actual Length and Link-Library Item. Type remaining text in the Editor Box to complete label text as shown below.

5. Click on the Parameters tab and set the Text Preferences/Symbology as shown below.

6. Select the Shape tab, and set the Shape Preferences and Symbology as shown below:
7. Select the **Leader** tab and set the **Leader Type**, **Terminator** and **Symbology** as shown below:

![Leader Tab Screenshot]

8. Select the **Rotate** tab and select the **Current Angle** option as shown below. Be sure to be rotated to the correct angle for placing the label on the sheet.

![Rotate Tab Screenshot]

9. Place the **Label** in the design file by clicking **Place Label**.

10. Select the **Text** tab, and select the **second pipe: pipe-201**. By activating the **Highlight** and **Window Center** toggles, the **Drainage Labeler** will navigate to the correspondent drainage pipe location in the (.dgn) file.

![Text Tab Screenshot]

11. **Label** the remaining pipes and **close** the **Drainage Labeler** when finished.
Exercise 12.3 Drawing Drainage Structures into a Roadway Profile

1. Open the MicroStation file: c:\projects\22049555201\roadway\dspfrd01.dgn where a Roadway Profile along the centerline has been printed.

2. Open the Draw Drainage Profiles and Nodes application. From the FDOT Plans Development Workflow, select Drainage Plans > Draw Drainage Profiles.

3. The Drainage Profile dialog displays.

4. Click on the magnifying glass and select the Drainage Project: SR61.gdf

5. Click on Identify Profile Cell button and select the Profile cell printed in the (.dgn) file.
6. Select the **Drainage Structures** to be drawn from the populated list box.

![Drainage Profile](image)

**Note** The Department's Plans Preparation Manual (10.3.5) states that the structures along the mainline shall be shown (printed) in the profile view.

7. Click on the **Preferences** button to setup the *printing parameters* per the Department’s CADD Standards.

8. Click on the **Draw Drainage Profile** button to print the structures and pipes along the Roadway Profile. Some manual manipulation will be needed to accommodate for possible overlapping text along the Profile View.

9. **Exit MicroStation.**
13 AUTOMATED QUANTITIES

OBJECTIVES

The objective of this chapter is to understand the computational modes of the D&C Manager for calculating Automated Quantities in a Drainage project.

INTRODUCTION

The D&C Manager is a tool that enables you to standardize graphics elements for drafting and pay item quantities. A D&C Manager Pay Item can be used for Node and Link items within the Drainage Library for use in performing quantity takeoffs and applying D&C Manager symbology. Pressing the Select Payitem button within the specific Drainage Library Node or Link item invokes the D&C Manager, in order to select the desired Pay Item.

OPERATIONAL MODES: COMPUTE

One of several operational modes within the D&C Manager is the Compute mode. Through the Compute mode of the D&C Manager, GEOPAK offers tools that make the completion of this task much quicker and easier. In addition, since the software utilizes the plan view construction drawings to compile quantities, discrepancies between the drawings and the tabulated quantities are non-existent.

Once the MicroStation plan view design file is accessed, the first step is to invoke the D&C Manager and click the shortcut button at the top of the dialog to Compute. The dialog changes dynamically to reflect the compute operation.
The D&C Manager dialog is resizable. Within the dialog, the sash (long, thin horizontal bar between list boxes) enables you to adjust the partition between the list and collection boxes while the overall dialog size remains constant. Simply place the cursor over the sash and dynamically move.

In addition to dynamically adjusting the main dialog to reflect the compute operation, the auxiliary dialog is invoked as depicted below. Note if the auxiliary dialog was already invoked from another operation, it dynamically changes to reflect the Compute operation.

The next step is the selection of the correct item from the hierarchy. GEOPAK computes quantities only for those hierarchical items that are configured for the computation of quantities.

Two selection methods can be employed. The first method is to select an entire category. GEOPAK computes quantities for every item found in the selected category as well as any child categories. This is accomplished by double clicking through the groups until the desired category is contained in the List box. Single click onto the desired category and click Add to Collection at the top of the dialog.

The second method involves the selection of individual features. This is accomplished by double clicking through the categories until the desired item appears in the List box. When seen in the List box, a single click onto the desired item and subsequent click of Add to Collection places the item in the Collection box.

Several Output Formats are supported.

- **Comp Book** - A more detailed report that lists not only quantity summaries, but also geometric properties such as plan view coordinates and station/offsets for located elements. File is in ASCII format.
- **Item Report** - Quantities Summary listing pay items, descriptions, units and total quantities for located elements. File is in ASCII format.
- **Item Tables** - Contains the same information as the Item Report, but formatted in tabular form.
- **DBMS** - Very detailed information including calculated and rounded quantities, geometric properties, pay item numbers, descriptions, station/offset values, etc. The format is the selected database (i.e., Microsoft Access, Oracle, SQL Server, and dbase.
- **CVS by Item** - Quantities Summary listing pay items, descriptions, units and total quantities for located elements. Format is in comma delimited data.
- **CVS by Element** - A more detailed report that lists not only quantity summaries, but also geometric properties such as plan view coordinates and station/offsets for located elements. Format is in in comma delimited data.
- **Tables** - Creates an interactive quantity table that can be placed in the (.dgn) file.
Exercise 13.1 Automated Quantities

GEOPAK Drainage can track the component quantities within the Drainage Project. This exercise will utilize the D&C Manager to automatically calculate and report the pipe quantities used in this project. The D&C Manager computes quantities by matching the level symbology stored in its database with the level symbology of the elements in the design file.

➢ Updating Pay Item Symbology to Comply with CADD Standards

We have drawn our Drainage items using our own predefined symbology setup in the Drainage Preferences. The level symbology can now be updated in the drainage designed elements with the symbology stored in the D&C Manager.

1. Using the FDOTSS icon, open the MicroStation file, c:\projects\22049555201\drainage\drprrd01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\projects\22049555201\ and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the Drainage Project, c:\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open.
8. Set the Active Network to SR61-1.
9. Open the Project Preferences from the GEOPAK Drainage menu and click Plan Symbology.
10. Clear all the **Label** check boxes and make sure the *Areas symbology* complies with the Department’s CADD standards.

11. Toggle **OFF** the *Set Node Cell Symbology* check box.

**Note** In previous labs, we chose to Set Node Cell Symbology ON. This setting was overriding the original MicroStation symbology of the drainage cells. In the next steps, GEOPAK Drainage will resymbolize the Nodes and Links according to the Department’s CADD Standards.

12. Click **OK**.

13. Update the *Drainage Areas*. From the **GEOPAK Drainage** menu, select **Component > Area > Update All**.

14. Update the *Nodes*. From the **GEOPAK Drainage** menu, select **Component > Nodes > Update With Pay Items**.

15. Update the *Links*. From the **GEOPAK Drainage** menu, select **Component > Link > Update With Pay Items**.

**Note** GEOPAK uses the D&C Manager (*.ddb*) file (*FDOTSS4.ddb*) to update the symbology of the drainage nodes and pipes as defined by the Department’s CADD software installation.
Calculating Quantities in Plan View

1. Access the D&C Manager. From the MicroStation menu select Applications > GEOPAK > ROAD > Design & Computation Manager.

2. In the D&C Manager dialog, click the calculator icon to set the Mode to Compute.

3. Navigate to the Drainage\Proposed Structures Features category and double-click the folder to expand the category.

4. Select the Inlets folder, then right click and select Add to Collection from the popup menu.

5. From Plan Quantity Computation dialog, set Extents to Active Design File.

6. Set the Baseline Reference to None.

7. Click Compute Quantities for initiation of the calculation. GEOPAK Drainage will calculate the payitems found within the extents of the MicroStation design file.

8. Select the Item Report as the Export Format and type SR61Dr_Qtys.txt as the File Name to export.

9. Click Export. The new ASCII File: SR61Dr_Qtys.txt will be created in the GEOPAK project working directory.

Exercise 13.2 Summary of Drainage Structures

Creating the Summary of Drainage Structures Spreadsheet

1. From the FDOT Plans Development Workflow, select Drainage Plans > Create and Place Summary of Drainage Structures.

2. On the Summary of Drainage Structures dialog click on the magnifying glass icon and select the SR61.gdf file for the Drainage Database.

3. Click Create Spreadsheet and provide a Name: DrainageSummary.xls for the new Summary of Drainage Structures Sheet.

4. Review the spreadsheet in Microsoft Excel. Additions or remarks may be placed as needed. Save and Close when done.
Placing Summary of Drainage Structures Spreadsheet in MicroStation

1. From the FDOT Plans Development Workflow, select Roadway Plans > Create New File.

2. The Create File/Project dialog displays. Set the dialog as shown below.

3. Click Create to create the file, SUMDRD01.dgn

4. Click Open File to open SUMDRD01.dgn. Set/Update Plot Scale displays. Use the Default settings and click OK.

5. Click OK to close the Create File/Project dialog.
6. Make sure that Annotation Scale is turned OFF.

7. Open the Summary of Drainage Structures application. From the FDOT Menu, select Drainage > Drainage VBAs > Summary of Drainage Structures.

8. Fill in the Sheet Prefix and Starting Sheet Number fields, if needed.

Note: The prefix and number placed by this application is compatible with the Department’s Sheet Navigator application. This compatibility makes it simple to re-number the sheets generated.

9. Click Draw Spreadsheet and choose the Summary of Drainage Structures spreadsheet to be placed into the drawing. Any properly formatted spreadsheet can be placed with this new application.

10. Review and verify the information on the sheet(s) now within the file.

11. Exit MicroStation.
14 DRAINAGE STRUCTURES CROSS SECTIONS

OBJECTIVES

The objective of this chapter is to review the process to generate drainage structures cross sections.

INTRODUCTION

The generation of Drainage Structures cross sections is done thru the Process Cross Section engine in GEOPAK Road. GEOPAK Road Project Manager is the tool to use in order to manage the creation of cross sections where the Drainage (.gdf) project is attached.

The generation of drainage structures cross sections starts as any cross section run, in which the designer has to previously have generated pattern lines, existing ground cross sections and developed also the roadway typical section. The workflow is as follows:

1. Generate the Stub report so the GEOPAK cross section routine can establish the proper connectivity of the pipes within the cross section. This is a Department (.vba) application.
2. Generate pattern lines perpendicular to the drainage structures drawn in the (.dgn) file. To facilitate the printing of the pattern lines, the Department has included a special (.vba) application.
3. Cut existing ground cross sections along the pattern lines.
4. Collect the information from roadway design regarding: typical section configuration and superelevation shapes (if used).
5. Assembly the proposed cross section run in **Project Manager**: Select the **Typical Section** of the project and edit/modify the included variables for the cross section run. A recommended practice is that the Drainage designer should take advantage of the **Proposed Cross Section Run** created by the roadway engineers and make it his own. The “copy” of the Roadway run will not modify or affect any of roadway work previously done. This process is done in the dialog shown below.

6. In the **Proposed Cross Section** run, activate the option to generate Drainage Structure cross sections.

7. Upon execution, the **Roadway Features** will be drawn using the criteria files from the **Typical Section** generator, and the **Drainage Structures** cross sections will also be drawn reading the criteria files defined for each type of structure within the **GEOPAK Drainage Library**.

8. The Drainage designer has the option to generate ITS cross sections using a “bare bone” typical section (only existing ground and basic road template), since all the information regarding drainage is extracted only from the Drainage Library and the (.gdf) file. This is usually done during the design process since some of the roadway features have not been completely defined yet.
Exercise 14.1 Drainage Structures Cross Section

➢ Opening the Drainage Project

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\drprrd01.dgn.

2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.

3. Select Project: SR61Drainage.prj located in c:\e\projects\22049555201, and click OK.

4. Access User: Student

5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.

6. Open GEOPAK Drainage. From the FDOT Plans Development Workflow, select Drainage Plans > Open Geopak Drainage.

7. Open the Drainage Project, c:\e\projects\22409555201\drainage\SR61.gdf. From the GEOPAK Drainage menu, select Project > Open. From the GEOPAK Drainage menu, select Component > Node > Update All.

8. From the GEOPAK Drainage menu, select Component > Links > Update All.
9. To Generate the *Stub-Out Report*, from the FDOT Plans Development Workflow, select **Drainage Plans > Create Drainage Stub-Out Rport for Cross Sections**.

10. Select the *Project Name*: `SR61.gdf` and create the *Output Filename*: `SR61_stubs.txt`.

11. Click **Apply** to generate the report. The designer can click the **View** button to verify the creation of the report.

12. **Close** the dialog.
➢ Draw Pattern Lines for the Drainage Structures

1. From the FDOT Plans Development Workflow, select Roadway Plans > Create New File.

2. The Create File/Project dialog displays. Set the dialog as shown below.

3. Click Create to create the file, DRXSRD01.dgn

4. Click Open File to open DRXSRD01.dgn. Set/Update Plot Scale displays. Use the Default settings and click OK.

5. Click OK to close the Create File/Project dialog.
6. With $DRXSRD01.dgn$ open, go to the **Pattrd Model** and **reference** in the following files:
   - C:\E\Projects\22049555201\drainage\DRPPRD01.dgn file
   - C:\E\Projects\22049555201\roadway\DSGNRD01.dgn file
   - C:\E\Projects\22049555201\roadway\ALGNRD01.dgn file; model ALGNRD_50
   - C:\E\Projects\22049555201\roadway\GKLNNRD01.dgn file
   - C:\E\Projects\22049555201\survey\GDTMRD02.dgn file

7. *Fit the View and Save Settings.* From the MicroStation menu, select **File > Save Settings.**

8. From FDOT Plans Development Workflow, select **Drainage Plans > Draw Drainage Pattern Lines.**

9. The **Drainage Pattern Lines** dialog displays. Populate the dialog as shown below.

10. Set the **symbology** of the pattern lines by clicking the **Set Symbology** icon.

11. Click the **Draw Pattern Lines** button. Pattern lines will be drawn for each station with a Drainage Structure(s).
Generate Existing Ground Cross Sections

1. Continuing in `DRXSRD01.dgn`, From FDOT Plans Development Workflow, select Cross Sections > Create Cross Sections.

2. Following the cursor prompt, locate the **SR 61 Alignment**. The Create Cross Section dialog displays.

3. Click on the Preferences button.
   a. The Preferences dialog displays.
   b. Select the Preference Name **XS_20_10** from the list and click Load. Once loaded the dialog will display Preference ‘XS_20_10’ loaded.
   c. Click Close. All of those preset preferences will be loaded for 20’ Scale Cross Sections Sheets.

4. From the Create Cross Section dialog change the Display in View to 3.
5. Change the Model Name to SR61_DR.

6. On the Create Cross Section dialog, go to the Custom folder.

7. Using the Element Selection tool, select all of the pattern lines previously created for SR61.
8. Set the *Type* to *Linestring*. Click on the *Graphics* button that has now become available.

![Create Cross Section](image)

9. The list box will then populate with all of the Stations of the Pattern Lines.

10. Click *Apply*. *View 3* is opened and the Roadway Cross Sections are generated with the cross section cell, existing ground, existing features, and proposed features.

11. Click *Close* to exit the Create Cross Sections dialog.

12. Because the existing features were created using the existing surface templates, there will be existing line work that is either duplicate or overlapping, once the cross sections are created. To remove the duplicate or overlapping lines, open the *SR61_DR* Model.

13. From the FDOT Plans Development Workflow, select *Cross Sections > Delete Duplicate Lines*.

![Cross Sections](image)

14. This tool will run through each cross section and remove the duplicate and overlapping elements.

15. Review the generated cross sections using the Cross Section Navigator. From the FDOT Plans Development Workflow, select *Cross Sections > Navigate Cross Sections*.

![Cross Section Navigator - SR61 - Scale 2 H : 1 V](image)

16. Exit the Cross Section Navigator when done.

17. Upon reviewing the sections, it is desirable to “lock” the elements to prevent accidental deletion or modification in later steps. From the *MicroStation* menu, select *Edit > Select All*, then select *Edit > Lock* to lock the elements.
Drainage Structures Cross Section

1. From the Project Manager dialog, select Proposed Cross Sections. Create the Run: Drain_XS.
2. Select the XS DGN category, set the dialog as shown below.

3. Select the Pattern category.
   a. Select SR61 as the Chain.
   b. Set the Scale to 2:1.
   c. Select DRXSRD01.dgn as the DGN File.
   d. Set Search Criteria to the correct Pattern Line level.

4. Select the Existing Ground category.
   a. Select DRXSRD01.dgn as the DGN File.
   b. Toggle On the Lv Names under Search Criteria and set the Level to XSGrdLine_ex.
5. Select the **Shapes** category. Set this option to **Shapeless**.

6. Select the **Shapes Clusters** category.
   a. Select **SR61** as the Chain.
   b. Select **SR61_PR** as the Profile and click the **Add** button.

7. Select the **Plot Parameters** category. Be sure that all options are toggled OFF.
8. Select the **Drainage** category.
   a. Toggle **On** the *Draw Drainage Components* option.
   b. Select **SR61.gdf** for the *Project Database*.
   c. Select **DRPRRD01.dgn** for the *Drainage DGN File*.

9. From the *Proposed Cross Sections* dialog, select **File > Run** to process the cross sections.

10. Setup the *Proposed Cross Section* dialog as shown below and click **Apply**.

11. Select the **Stub-out Report** previously created.

12. Choose what should be printed on the **right side** of the cross section.

13. Choose the **offset** from the centerline of the structure label.
14. Determine how long the stub pipes should be in each cross section and enter the corresponding number (the default is 3).

![Prompt](image)

15. Review the newly generated drainage cross sections using the Cross Section Navigator.

16. Close the Proposed Cross Section dialog.

➢ **Drainage Structures Cross Sections on Sheets**

1. Change the Model to **Rdxsrd_shg**.

2. From the FDOT Plans Development Workflow, select Cross Sections > Layout Cross Section Sheets.

![Cross Section Navigator](image)

3. The following Information box will display. Click OK to dismiss the message.

![Information](image)
4. The Cross Section Sheet Composition dialog displays. Set the Active Cross Section Sheet to XSSHEET20_10.

5. Select the XS DGN File category. Click the magnifying glass and browse to C:\e\projects\roadway\DRXSRD01.dgn. The XS Baseline and Begin/End Stations will automatically populate.
6. Select the **Sheet DGN File** category. Click the *magnifying glass* and browse to C:\e\projects\roadway\DRXSRD01.dgn.

7. Click the **Layout Sheets** button. The Cross Sections will attach as reference files and laid out onto sheets.

8. **Fit View** to review the Cross Section sheets.

9. Turn **Off** the following **Levels**: **XSCell** and **DTM_px** for all of the Cross Sections:

10. From **MicroStation** turn **Off** the **Data Fields** under **View Attributes** and select **File > Save Settings**.

11. Close the Cross Section Sheet Composition dialog. When prompted to **Save Settings**, click **No**.

12. Exit **MicroStation**.
CULVERTS

OBJECTIVE

- Review Culverts
- Review Necessary Data Input Required for Design of Culverts.

INTRODUCTION

GEOPAK Drainage Culvert is a powerful tool for the design and analysis of culvert structures. Located within GEOPAK Drainage, the Drainage Culvert tool can leverage data from a coordinate geometry database (GPK), a site database file (.gsf), the drainage database file (.gdf) or a binary (.tin) file. This allows for the utilization of roadway and/or storm sewer data, both existing and proposed.

A prerequisite to storing culverts is a headwall must be stored within the Node options in the specified Drainage Library.

DRAINAGE CULVERT TOOL BOX

The Drainage Culvert tool box can be accessed by selecting Tool Boxes > Culvert from the main GEOPAK Drainage menu.

Previously stored culverts are displayed in the list box for easy selection and modification.

- **Add Culvert** - Invokes the add culvert dialog.
- **Modify Culvert** - Invokes the culvert dialog populated with data for the specified culvert in the list box.
- **Identify Culvert** - When pressed and a previously stored culvert is selected on the screen, the culvert is displayed in the list box.
- **Delete Culvert** - Deletes the culvert in the list box.

ADD NEW CULVERT

When the Add Culvert button is selected, the Add New Culvert dialog displays. A prerequisite to storing culverts is a headwall must be stored within the Node options in the specified Drainage Library.
The Culvert dialog is used for adding, editing, or deleting Culverts.

The dialog consists of three fields at the top, and six tabs. The fields at the top remain regardless of which tab is selected. As each tab is selected, the dialog changes dynamically to reflect the selected tab. Only the culvert ID and description are constant while manipulating tabs. The minimum requirements for storing a culvert are completion of the front three tabs: Parameters, Headwall Locations, and Configurations.

**PARAMETERS TAB**

Defines the Design Discharge and Tailwater as well as the Analysis Discharges and Tailwater.

Under this tab multiple Discharges and Tailwaters are user supplied for both analysis and design purposes. For each discharge that is input, there must be a corresponding Tailwater.

Currently, only one option for Discharge is supported, User Supplied. Up to six discharges may be entered for analysis, but only one user-defined discharge is used for design (indicated by the X).

The Tailwater conditions could be entered as a single list of elevations as shown below, or it can be computed from a provided DTM. The designer can also compute the Tailwater conditions using a variation of the Parameters tab dialog.
The Tailwater Compute option utilizes a cross section of the channel downstream of the culvert along with a user supplied slope of the channel and its "N Value" to calculate the Tailwater.

- **Extract Cross Section** - Displays the Define Culvert Tailwater Cross Section dialog (see GEOPAK Drainage Help) which can be utilized to populate the Distance / Elevation list box.
- **Slope** - Hydraulic slope (in percentage format) of the channel at the downstream end of the culvert.
- **N value** - Roughness coefficient (Manning's value) for the channel bed used to calculate the Tailwater.
- **Adjust Tailwater Depth** - Adds a value to the Tailwater depth. For example, if the Tailwater cross section is 100 feet from the end of the culvert and the channel slope is 1%, the user may want to add 1 foot so the elevation is more reflective of what is at the actual culvert end.
- **Distance/Elevation** - The information can be manually entered in the fields at the bottom of the dialog, and utilizing the Edit buttons to the right side of the list box. However, if a TIN file or site model is specified, the list box can be automatically populated within the Profile dialog by clicking Extract Cross Section.

**CONFIGURATION TAB**

Defines the properties of the culvert including the culvert shape, material, size, number of barrels, roughness coefficients, and entrance type.
The following items need to be defined:

- **Shape** - The shapes are a listing of available shapes within the current Drainage Library.
- **Material** - The materials are a listing of available materials within the current Drainage Library.
- **Corrugations** - Dependent on the Shape and Material selection, this is only an option with Arch, Ellipse, and Pipe-Arch. This affords the user choices in size and direction of corrugations.
- **Entrance Type** - Graphics of various entrance types are displayed. Pressing the Select Entrance button at the bottom of the dialog displays the dialog depicted below. Type selection changes based on the current Shape and Material specified in the Configuration tab.

![Select Entrance Type Dialog](image)

- **Culvert Size** - Two options are supported within culvert size: Library Item and Design Size. This enables the user to either input the culvert size or let the size be designed by the program.
  - **Library Item** Click Select displays the Select Size dialog, wherein the desired size may be selected. Pipes listed in the dialog are based on the sizes in the Drainage Library for the specified Shape and Material configuration.

![Select Size Dialog](image)

- **Design Size** In order for Drainage to design the size, three input values are required: Minimum Rise (diameter, height) for culvert in master units (i.e. feet or meters), Maximum Rise (diameter, height) for culvert in master units (i.e. feet or meters) and Allowable Headwater (depth in master units above the invert elevation) or Headwater Elevation (the maximum elevation the water can reach at the upstream end of the culvert.)

![Design Size Dialog](image)

- **Design Barrels** - Toggle to indicate that the number of barrels required (multiple pipes) is to be determined by the software based on the user supplied Configuration and Constraints.
- **Number Barrels** - Option button for number of barrels (pipes or boxes) for the Link ranging from 1,2,3...10
- **Manning’s n Roughness coefficient** - The default value is based on shape and material found in the Drainage Library.
- **Entrance Ke** - Entrance loss coefficient.
HEADWALL LOCATION TAB

Defines the location and reference information for the culvert. The designer can place the culvert headwalls in plan or profile view. The Plan utilizes station/offset data to define headwalls. The Profile option uses Invert Stations/Invert Elevations to define headwalls.

- **Reference Chain** - Previously defined chain used to compute station/offsets.
- **Node ID** - Identification of the Node from which the culvert originates (Upstream Node) or terminates (Downstream Node). Note these are display fields only, as GEOPAK assigns the name by using the culvert name plus UP for upstream and DN for downstream.
- **Library Item** - The Library Item field, directly below the Node ID, displays "None" until an Item is selected. This is accomplished by pressing the Select button to the right of the Library Item. Select the desired Node from the library, which will highlight, then click OK.
- **Chain Sta** - Based on the Reference Chain, the station is relative to the origin or a predefined location point for the headwall cell being placed. If no Reference Chain is input, this feature is disabled.
- **Offset** - Based on the Reference Chain and the master units from the Preferences dialog, the offset is to the origin or a predefined location point for the headwall cell being placed. If the headwall is to the left of the Reference chain, (looking toward increasing stationing), the offset is negative. If the headwall is to the right of the Reference chain, (looking toward increasing stationing), the offset is positive. If no sign is given, GEOPAK assumes positive offsets. If no Reference Chain is input, this feature is disabled.
- **Mirror Cell** - When activated, the headwall cell is mirrored so that the same cell can be utilized on both ends of the culvert.
- **Lock** - If the designer wants to force the headwall to a specific offset, for example the toe of the incline, then the offset can be entered and the Lock toggle activated. If no Reference Chain is input, this feature is disabled.
- **Invert Elevation** - The elevation of the Culvert Invert. Two options are supported: User Supplied (input field where user types the elevation) and (.tin)/Model (display only field where GEOPAK computes and displays the elevation). When the (.tin)/Model option is utilized, the Headwall Cross Section dialog is displayed.

Fields are supported for the Offset from the toe of the slope, and Link Angle, which is the angle at which the culvert lies, or User Angle, which is the mathematical angle from zero.

- **Dynamic Place** - Used to initiate the headwall placement options. Begins the dynamic headwall placement based on the current location settings.
- **Keyin Place** - Used to issue the new location for the headwall should the Station and Offset be supplied or modified by the designer.
Chapter 15

CULVERTS - Drainage Culvert Tool Box

Options - Several options for aligning and rotating the headwall are supported. Based on the selection, various key-in fields and buttons within the group box are ghosted. Options include: Tangent to Ref. Chain, Tangent to MS Element, Tangent on MS Element, and User Angle.

User Angle - The headwall is placed at the active angle in the MicroStation file at the current or dynamic headwall coordinates.

Angle (+ / -) - In addition to selecting an Align Option, an optional Angle may be specified in the upper right corner of the group box. For example, an angle of 90 degrees will rotate the headwall perpendicular, rather than tangent to the Element.

Create Profile - Displays the Create Culvert Profile dialog to store a profile along the culvert.

OVERTOPPING TAB

Defines parameters used in the calculation of overtopping flow. The user inputs the roadway information to be used when calculating the discharge of the water flowing over the road.

Three Overtopping Sources are supported within this dialog: PGL, DTM and User Supplied. As each source is selected, the dialog dynamically changes based on the selection. However, several fields are found in all options and are detailed below.

- **Width** - Length (in master units) of the roadway crest.
- **Pavement** - When toggled on a Manning's coefficient for pavement is used. When toggled off, a coefficient for gravel is used.
- **Adjust Constant Delta Elevation** - An additive factor that raises the elevation above the PGL which the water must flow over.
- **View Overtopping Profile** - This button provides a graphic display of the profile once it has been created. It can be used for all three overtopping sources.

The PGL Overtopping option uses the following:

  - **Reference Chain** - Reference chain (or alignment).
  - **Ref. PGL** - Reference Profile Grade Line (previously stored as a profile).
  - **Begin Station/End Station** - Station at which the overtopping profile begins and ends. It can be typed in the field or defined graphically.
  - **X Increment** - The incremental distance along the line where the overtopping occurs. A maximum number of 50 distance / elevation points may be specified. If more than 50 points are specified, an Information message is displayed, and the X Increment is increased. The first distance point is the beginning station point, while the last distance point is the ending station point.

The DTM overtopping option uses the following:
- **DTM** - A tin specified at the moment of extracting the overtopping profile.

- **Extract Overtopping Profile** - This dialog is will be used to extract a profile elevations along a specified or selected MS element.

- **Adjust Constant Delta Elevation** - The extracted elevations from the DTM could be adjusted using a constant value along the profile.

**Note**  
With the User Supplied option, the designer has to manually enter the overtopping elevations for the culvert in analysis.

**COMPUTATION TAB**

Provides for any combination of Culvert, Tailwater, and/or Overtopping Calculations and allows for output to an ASCII file. The Compute Tab will display the culvert computations. The results are displayed in the list box in the middle of the dialog with an option to send the results to an ASCII file.

- **Culvert, Tailwater, Overtopping** - When selected, additional computations are added to the report. Note that more than one option may be selected for each report.

- **Output to ASCII** - When activated, the report is written into the specified output file in addition to being displayed in the dialog.

- **Create/Append** - If the file is to be created, set to Create. Note if the file already exists, it is overwritten with no warning. To add the computations to an already existing ASCII file, select Append.

- **View** - Invokes the GEOPAK editor displaying the current report.

- **Files (button) and Keyin Field** - To select the ASCII file, type the desired name, or pressing the Files button, select a previously existing file.

**Exercise 15.1 Culverts**
1. Open the MicroStation file c:\projects\21984315201\drainage\dprrd01.dgn.
2. Open Project Manager from the MicroStation menu: Applications > Road > Project Manager
3. Select Project: 2198431520.prj located in c:\projects\21984315201\roadway\eng_data, and click OK.
5. Click OK. The Road Project dialog displays. This will setup the proper directories for the location of the (.gpk) file. Minimize the Road Project dialog.
6. Access GEOPAK Drainage from the MicroStation menu: Applications > Drainage > Drainage.
7. Open the Drainage Project: culverts.gdf located in c:\projects\2198\drainage\eng_data. Select Drainage > Project > Open.
8. Select Drainage > Tool Boxes > Main. Drag the Culvert icon from the Drainage Tool Box.
9. The Drainage Culvert toolbar displays. Click the Add Culvert button.
10. Enter the Culvert Name as: Culvert 1 and Click OK to add the new culvert to the (.gdf) file. Click OK to the Information message.
11. The Culvert dialog displays as shown below:

12. Enter Culvert Discharges
Discharge: Keyin 75 cfs and click the Add List Item button. Keyin 120 cfs and click the Add List Item button.

Design Discharge: Double click next to the 75 cfs within the design column.

13. Define the Tailwater:
   
   Slope: 4.0%
   
   N Value: 0.010
14. Click the **Extract Cross Section** button. Set to the **Drape Element on Model/TIN** and set to **TIN File**. Then select `c:\\e\projects\21984315201\roadway\us90dtm.tin`.

15. Click the **Place Element** button to locate the position of the tailwater profile to extract. Place a line in a location similar to that shown below:

16. The **Define Culvert Tailwater Cross Section** dialog now contains the profile along the element placed representing the channel cross section at this location.

17. Click the **OK** button and the main **Culvert** dialog displays again. The coordinates of the profile are populated.
18. Select the **Configuration** tab to define the type of **Culvert**:

- **Shape**: Circular
- **Material**: Concrete
- **Library Item**: 24”
- **Manning’s**: 0.012
- **Entrance Type**: Headwall Square Edge

19. Select the **Headwall Location** tab to define the location of the **Upstream** and **Downstream Headwalls** (nodes).

- **Type**: Plan View
- **Reference Chain**: CLCON
- **TIN File**: c:\e\projects\21984315201\roadway\us90dtm.tin
20. Locate the *Upstream Node* by clicking the **Dynamic Place** button and setting the *Upstream Node* at a location similar to that shown below. The *station* and *offset value* will change as the designer is dynamically placing the endwalls.

21. Locate the *Downstream Node* by clicking **Dynamic Place** under the *Downstream Node* group.

22. Set the *Elevations* for both the *Upstream* and *Downstream Nodes* by toggling the *Elevation Source* to **TIN/Model**. This extracts the elevations at the headwall locations with information from the (.tin) file.

23. Once the Nodes have been located and the elevations set, the Culvert can be added to the project. Click the **Apply** button and the culvert is drawn to the symbology set in the **Preferences** and then labeled.

24. Select the **Overtopping** tab and setup the dialog as shown below.
25. Click on the **Extract PGL Profile** to populate the elevations along the roadway.

26. Select the **Computations** tab. Toggle **ON** the **Output** options to view the **Culvert1 computations**.

27. Click the **Compute Culvert** button to perform the calculations.

28. Click the **View** button to review the calculations.

29. **Exit MicroStation.**
16 TERRAIN MODELS FOR DRAINAGE DESIGN ANALYSIS

OBJECTIVES

Learn how to display and analyze Terrain Models for use in Drainage design.

INTRODUCTION

A Terrain Model is a set of three-dimensional triangles mathematically computed from point data collected on the surface being modeled. Models are used to define highly irregular surfaces, particularly the surface of the earth, but can be generated for proposed surfaces, subsurface geotechnical layers, etc. Terrain models are also referred to as digital terrain models (DTMs), triangulated irregular networks (TINs), or triangulated surfaces.

With the release of MicroStation V8i SELECTseries 3 we now have the ability to import a surface file into a DGN file. A Civil Application such as InRoads or GEOPAK is not required. This new Terrain Model element type resides inside the DGN file and allows users to view the data a number ways.

The Terrain Model represents the topography of a project in the form of a triangulated network. The Terrain Model can be imported from several different file types:

- GEOPAK TIN
- InRoads DTM
- GEOPAK DAT
- MX. Fil
- Point Clouds
- LandXML
- Photogrammetry Data
- Graphical Elements
- ASCII file
- Lidar

The Department’s Survey Department generally provides a *.TIN file with 3d triangles depicting the ground information.
TERRAIN MODEL TOOLS

The Terrain Model tools can be accessed in MicroStation under Civil Tools > Terrain Model.

CREATE TOOLS

The Terrain Model Create tool group contains tools to create a terrain model from graphical elements, ASCII files, point clouds, LandXML, and importing from various Bentley Civil products. Tools are also supported to merge together two or more models, and to clip models.

Terrain Models can be created from a variety of source data. Each data type has different input requirements, but many options are the same throughout the create tools.

- Create From File - Creates a Terrain Model by importing from an external file type. The following formats are supported:

- Create From ASCII File - Creates a Terrain Model by importing from an ASCII file.
- Create By Graphical Filter - Data may be provided for consumption into the terrain model in a variety of formats including raw graphical elements both 2D and 3D. For the Create Terrain by Graphical Filter, the elements must be 3D. This tool is useful when the source data has consistent element symbology. Rather than defining the element symbology for each terrain feature each time a terrain model is created, the information can be stored in a filter group. Numerous groups can be stored in a dgnlib, so the user merely selects the appropriate group, based on the type of features and associated symbology. If none of the groups are applicable, a new filter group can easily be created.
• **Create From Point Cloud** - The Create from Point Cloud tool utilizes one or more point clouds to create a Terrain Model.

A point cloud is a data file which can include a large number of points on the surface of an object. A point cloud is a set of vertices in a 3D coordinate system and these vertices are defined by X, Y and Z coordinates. Point clouds are usually created by 3D scanners. These devices measure a large number of points on the surface of an object and output a point cloud as a data file. The point cloud represents the visible surface of the object that has been scanned or digitized.

• **Create From Elements** - The Create From Elements tool creates a terrain model from 3D graphical elements that are ruled. Ruled Terrains update dynamically if the source elements are changed. Each element or group of elements of a terrain feature type can be selected individually or via selection set.

• **Create Complex Terrain Model** - The Create Complex Terrain Model tool is used to merge or append multiple terrain models into one. Order is important as the models are processed in the order listed. It is also crucial to specify append or merge as appropriate for the project, as the results may be dramatically different.

Any two terrain models can be merged together as long as one terrain model overlaps the other model in at least one point. A warning message is displayed if there is no overlap, and no processing occurs.

• **Create Clipped Terrain Model** - Creates a new terrain by clipping a portion of a previously created terrain model.

• **Create Delta Terrain Model** - The Delta Surface tool creates a delta terrain model between a surface and plane or between two surfaces, which can then be used for Isopach contouring. The Z value in the delta TM is the difference between the two specified models or model and surface, rather than actual elevations. Any voids in any of the terrain models produces a corresponding void in the delta model (as the software cannot compute the difference in these areas).

• **Create Terrain By Text Interpolation** - The Create Terrain Model by Text Level Interpolation tool utilizes 2D files. The XYZ data is derived by locating spot elevations on longitudinal MicroStation elements and interpolating. Contours must be "tagged" with the elevation, while break lines and voids use text at each vertex to determine elevation. Therefore, two sets of filters must be defined; one for the Linear Features and a second filter for the Spot Elevations.

• **Create Corridor Alternate Surfaces** - Creates a terrain model from a corridor model.

**EDIT TOOLS**

The *Edit* tools allow the designer to change and manipulate the terrain model utilizing numerous tools.

• **Set Active Terrain Model** - Sets the default terrain model. The default terrain model is the model which is displayed by default in profile models and is the default target for the corridor.

• **Add Features** - Adds more 3D graphical elements (as terrain model features) into a previously created terrain model.

• **Remove Features** - Removes 3D elements from a terrain which were added by Add Features or Create from Elements.

• **Edit Complex Terrain Model** - The Edit Complex Terrain Model tool is similar in functionality to the Create Complex Terrain Models, but utilizes previously defined complex models. When the tool is selected, the dialog list box is populated with the complex terrain models in or referenced to the current *.dgn file.

• **Change Feature Type** - Changes the feature of the terrain model.

• **Edit Terrain Model** - These editing commands are for a terrain model that has no graphic elements with rules. For example, importing terrain models from other formats without creating features. The commands allow limited editing without returning to the source and importing features. If you need additional editing capabilities then import the original source and use the other editing methods. The following editing methods are available:

  ✓ Delete Vertex
  ✓ Delete Edge Triangle
  ✓ Swap Line
analyse tools

the analyse tools allow you to visually inspect the terrain model utilizing numerous tools such as volume analysis, point analysis, slope and pond analysis.

- analyse volumes - computes volumes between two models or a model and plane and generates an optional ASCII report. the volume is computed for the union of the two terrain models (model to model option) or between the entire terrain model and elevation (elevation option). an optional boundary may be specified to compute volumes for part of the terrain model. in this case, the volumes are calculated by drawing vertically from the boundary element to intersect the terrain models.
- analyse points - dynamically reviews information about a selected 2D or 3D element, terrain model, or mesh. the results are based on the type of element selected.
- analyse between points - analyzes the elevation, slope, distance, and delta information between two selected points of a terrain model or mesh.
- analyse trace slope - the analyse trace slope command dynamically traces a path on a terrain model or mesh surface. for example, consider the path of a drop of water down a selected terrain model or up the surface to the water source. inputs include a data point for the origin of the path. two trace methods are supported: maximum slope trace and constant slope trace.
  - when the maximum slope trace method is used with the down option, the indicated path follows the steepest descent from the point through the terrain model or mesh terminating at a low point or the edge of the terrain model or mesh. when used with the up option, the indicated path follows the steepest ascent from the point through the terrain model or mesh terminating at a high point or the edge of the terrain model or mesh.
  - when the constant slope trace method is used, more input information is required: slope (in terms of percent) and distance (in terms of master units). let’s use a slope of 5% and distance of 500 master units. the initial data point is placed on the screen and as the cursor is moved, various solutions are displayed. each possible solution is comprised of a line string 500 mast units long and whose slope is based on actual slope of the terrain model. therefore, the line string meanders along a path of the specified slope until it is 500 master units long (or less if there is no solution).

When DP2 is placed on the screen, the first line string which was dynamically displayed at the time of the data point is now fixed. using DP 2 as the initial endpoint, new solutions are dynamically displayed. note the solution between DP 3 and DP 4 has almost a 90 degree turn in it, based on the terrain of the model apartment. there is also a small turn at the end of this segment near DP 4. note that you only data point to define the origin point, while the software determines the rest of the path.
One option in the (down) trace slope is the consideration of Minimum Depth. Terrain models have numerous low points, however, many of these areas are simply small indentations or dips in the model, where water would flow through to a nearby lower point. To utilize this option, set the value to a depth, in master units (feet or meters). Bentley Civil determines each low point, then determines if water placed at the specified depth overflows the indentation and flows into adjacent triangles. If it does not flow into adjacent triangles, it is utilized as a low point in the tracing procedure. If it does flow into adjacent triangles, points on the adjacent triangles are given the depth test until a point is found where the depth test does not overflow. This point is then utilized as a low point. When set to zero, the Minimum Depth is not utilized.

- **Analyze Pond** - Pond Analysis tool traces a point downstream to a low point and fills it giving the volume, maximum depth, and maximum elevation. In addition, the pond delineation is graphically displayed.
- **Create Cut & Fill Volumes** - Computes the Cut and Fill Volumes between two terrain models.

### Reporting Tools

The *Reporting* tools are for the generation of various data about the imported terrain. These also include some labeling tools.

- **Report Crossing Features** - Locates intersecting line features, such as break lines or contours. At the intersection, the elevations of the two elements is computed and compared. If the elevation difference at the intersection of the two elements is less than the specified tolerance, they are not listed in the report.
- **Report Conflicting Points** - Any location in a terrain model (as defined by an X, Y coordinate) can have one and only one elevation. However, the source data used to create the terrain model may have duplicate points (as defined by an X, Y location with the same or differing elevations). During triangulation, if two or more points with the same X,Y coordinates are encountered, the first point (with its elevation) is utilized, while the second or subsequent points which may have different elevations are ignored. The Report Conflicting Points tool utilizes the underlying source data for this report.
- **Graphical Filter Manager** - The general workflow for setting up filter groups is to create the individual filters for individual terrain features, then combine them into a filter group. For example, perhaps a common dataset might consist of points and break lines using the levels points and breaks respectively. Create a feature for points and a feature for break lines, then combine into a filter group and assign a meaningful name so it’s easy to tell its contents. Perhaps another group might have all the features. Keep in mind you can use a filter group that has more filters than you have in your data. If no data is found for a particular filter, the filter is just ignored.
Chapter 16

TERRAIN MODELS FOR DRAINAGE DESIGN ANALYSIS - Terrain Model Tools

- **Export to File** - Exports the terrain model from the DGN file to a select file type. The TM can be exported to:
  - GEOPAK (TIN)
  - InRoads (DTM)
  - MX (FIL)
  - LandXML version 1.2

- **Label Terrain Contours** - Used to place additional labels for elevation on selected contours. Contours label automatically as a property of the terrain model element. You can place additional labels with this tool.

- **Label Terrain Spots** - Used to label elevations at specific locations on the terrain model.

**Exercise 16.1 Terrain Modeling**

The purpose of this exercise is to review the triangles of a tin file and to create contours from the tin file.

➢ **Importing the Terrain**

1. Open the MicroStation file, c:\projects\22049555201\drainage\drprrd01.dgn.
2. The Terrain Model tools can be accessed under the Civil Tools > Terrain Model.
3. From the Terrain Model tools, select the Create From File icon.
4. Select the TIN file located in c:\\projects\22049555201\survey\GDTMRD01.tin.
5. The Import Terrain Model(s) dialog displays.
6. Under the Feature Definition section set the Feature Definition to **DtmExisting**.

7. Leave the Import Options at **Import Terrain Only** and click on the **Import** button.

8. The terrain is imported into the (.dgn) file as a terrain model. Close the Import Terrain Model dialog and fit the view in MicroStation to see the terrain.
➢ **Set Terrain Model Active**

Setting a terrain model as active allows GEOPAK to know what to cut a profile from as well as what to target corridor end conditions.

1. Select the **Terrain Boundary** and hover. The context menu displays. Select the second icon to **Set the Active Terrain Model**.

2. A *Default-3d model* is created. Select **F2** to see both the 2D and 3D models. When the *Default-3d model* was created, it was referenced to the Default model.

➢ **Display Triangles and Drainage Flow Arrows, Locate High and Low Points**

1. Select the **Terrain Boundary** and hover. The context menu displays. Select the first icon to view the display options.
2. Double click on Triangles or select On from the pull down menu, to display the triangles in the MicroStation view.

3. Repeat the same steps for viewing the Contours, Flow Arrows, Low Points, and High Points.

4. Turn Off any that should not remain on the view.

➢ Read Elevations and Slopes

1. From Civil Tools, select Terrain Model > Analyze Point.
2. Follow the cursor prompt and **Select Element To Analyze Point**. The Analyze Point dialog displays. Move the cursor around to view the X and Y coordinates, the elevation, and the slope.

3. Right-click to exit out of the command.

➢ **Dynamic Profiles**

A **Profile** can be drawn for any area of the Terrain Model.

1. Select the **element** (this can be a drawn line, a pipe, the centerline, etc.) to view a **Profile** for and hover. The context menu displays .

2. Select the second icon, **Open Profile Model**.

3. Following the cursor prompt, **Select a View** to open the **Profile Model**.

4. **Data Point** inside the opened view.
5. The Profile displays for the element selected.

➢ **Delineating Drainage Areas**

1. From the FDOT Plans Development Workflow, select Drainage Plans > Drainage Terrain Analysis.

2. The Delineate All Watersheds dialog displays.

3. Click on the magnifying glass and navigate to the c:\Projects\22049555201\Survey\GDTMRD01.tin.
4. Select the **Delineate All Watersheds** icon and populate the dialog as shown below.

5. Click **Apply** and review the tentative **Watersheds** for the pavement drainage.

6. The **Refine Watershed** option processes the entire TIN, evaluating ridges, sumps, and low points and determines more precise flow boundaries within the triangles. This process will define all the *mathematically possible* **Drainage Watersheds**. The designer will need to define the final drainage areas for the project.
**OBJECTIVE**

Review the concept of how to create a *Special Ditch Profile* for proper drainage in GEOPAK and review the tools to automate this process.

**INTRODUCTION**

The standard roadside ditch is usually a fixed depth below the roadway shoulder point. In super-elevation the shoulder point and the ditch flow line can raise relative to the profile grade. In this situation, the ditch could hold water depending on the slope of the profile grade and the degree of super-elevation.

To correct this, a special ditch profile is usually created to drain the ditch through the super elevation transition. The creation of a special ditch profiles requires the usage of different tools within the Civil Tools open roads technology. The designer should be able to update the template, extract an existing ditch profile and then adjust it to create a proposed ditch profile, export the profile to the GPK file, and draw the profile in 2D plan view.
The Template Library can be accessed from the Corridor Modeling Workflow: Civil Tools > Corridor Modeling > Create Template

The Create Template dialog is used to create, edit, manage, and preview roadway templates.
The Template Library shows the tree view that lists all available templates in the active Template Library (*.itl). This view also includes additional template-level commands such as: set active, cut, copy, paste, rename. To access these commands, right click on a template in the view. The view also displays the default point name list, which allows you to add or modify names and styles of points in the template. To edit the point name list, right click or double click on the Point Name List item in the tree view.

The Template Library tabs at the bottom right of the dialog allows for selection between the standard Template Library tree view and the Active Template tree view.

- **Template Library** - displays the standard Template Library tree view.
- **Active Template** - displays the tree view for the active template. This view also lists the properties of a selected (active/highlighted) component, point, or display rule in the template. You can access (double click) and edit the properties of objects, or delete objects from the list view.

When you select the Points folder, a list of all points is displayed below the folder/tree view. Multiple points can be selected using shift and control key functions. A right-click menu is available to edit or delete the points, change style and display status, and set the Feature Name Override.

Drag a component on top of another component to make it a child of that component, or drag it on to the Component folder to remove its parent.

More information about templates and the Template Library can be found in the *FDOT Roadway Design and 3D Modeling Training Manual*.

**VERTICAL GEOMETRY TOOLS**

Below are some of the most common Vertical Geometry tools and their uses.

- **Open Profile Model** - Generates a view that presents a desired profile feature. Also allows the Vertical Geometry tools to interact once the view is opened.
- **Set Active Profile** - Designates which profile is associated with which alignment. Designates which profile elements will drive the 3D model.
- **Profile from Surface** - Generates a profile whose elevations are determined by draping onto a surface. The surface may be a terrain model, a mesh, or a mesh solid.
- **Project Profile to Element** - Shows one element’s profile in the profile view of another element.
- **Project Profile Range to Element** - Performs the same function as the Project Profile command except a station range can be used instead of the entire element.
- **Profile Intersection Point** - Indicates in a Profile View where one element crosses another.
- **Profile Line Between Points** - Constructs a profile line between two designated points.
• **Profile Line Between Elements** - Constructs a profile line between two previously placed profile curves.

• **Profile Curve Between Points** - Constructs a vertical curve between designated points.

• **Profile Complex by Elements** - Constructs a complex profile element from previously placed elements.

• **Profile Complex by VPI** - Constructs a complex profile defined by vertical points of intersection (VPI).

• **Design Profiles by Best Fit** - Constructs a profile defined by best fitting through a selected profile. For example, pick an existing ground profile and best fit a profile to match the ground.

• **Profile Insert Curve** - Inserts a vertical curve into a profile element.

• **Append Profile Element** - Appends additional elements to a previously established complex element.

• **Profile Offset Transition** - Constructs profile elements at an offset from a base element. The base element may be a line, arc, spiral, or complex.

• **Quick Profile Transition** - Defines the profile of an element by matching the slope and elevation of adjoining elements. Depending on the configuration of adjacent elements, either a single crest/sag curve is created or a reverse transition.

• **Profile By Constant Elevation** - Defines a flat profile at a given elevation for the entire element.

• **Profile By Slope from Point** - Defines a profile of an element by computing a slope from a 3D point.

• **Profile By Slope from Element** - Defines an element’s profile by projecting a fixed slope from another element with a design profile.

• **Profile By Vertical Offset from Element** - Defines the profile of an element based on a vertical offset. The results are similar to Profile by Variable Slope command, except that, instead of transitioning two slopes, two vertical offsets are used.

• **Profile By 3D Element** - Produces a profile (in profile space) from a 3D element in the drawing.
Exercise 17.1 Special Ditch Profiles

➢ Add the Ditch to the Template

1. Open the MicroStation file c:\projects\22049555201\roadway\DSGNRD01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\projects\22049555201, and click OK.
4. Access User: Student
5. Click OK. The Road Project dialog displays. Minimize the Road Project dialog.
6. Open the Template Library. From the Civil Tools Workflow, select Corridor Modeling > Create Template.
7. The Create Template dialog displays with the project Template Library attached, c:\e\projects\roadway\22049555201.itl. Navigate to the Corridor Templates folder and activate the SR61_1 template. This is the template that will be modified to include a special ditch.

8. From the Create Template dialog, select Tools > Options. The Template Options dialog displays.

9. On the Template Options dialog, click on the Preferences button. The Preferences dialog displays.
10. Select the Preference and click Load. The Template preferences have been loaded. Click OK on the Template Options dialog.

![Preferences dialog]

11. Right-click on the SR61_1 template and Copy.

12. Right-click on the Corridor Templates folder and Paste. A copy of the SR61_1 template is created and named SR61_11.

13. Right-click and rename the SR61_11 template to SR61_2.

14. Navigate to Components > Ditches > Common Ditch Right Template. A preview of the ditch is in the window on the lower left hand side of the dialog.

15. With the Common Ditch Right Template highlighted, drag the ditch components and snap them to the RT_SHLDR_UNPAV_OUT point. This will be the right most point on the SR61_2 Template.

![Ditch Components]

16. From the Create Template dialog select File > Save to save the changes. Click the Close button when finished.

17. Continuing in the DSGNRD01.dgn file, press the F2 key to open and view the 2D and 3D Views.
18. From the Civil Tools Workflow, select **Corridor Modeling** > **Corridor Objects**.

![Corridor Modeling Interface](image1)

19. Following the cursor prompt, locate the **SR 61 Corridor Boundary**.

![Corridor Objects Dialog](image2)

20. The Corridor Objects dialog displays. On the left side of the dialog, make sure that the **Template Drop** option is selected.

![Template Drop List](image3)

21. Select the second **Template Drop** in the list. Click on the **Browse** button and navigate to the **SR61_2 Template** that was just created. Allow the corridor to process and **Close** the Corridor Objects dialog.
Extract a Ditch Profile from 3D Elements

1. Continuing in the DSGNRD01.dgn file, from the Civil Tools Workflow, select Vertical Geometry > Profile By 3d Elements.

2. On the Profile By 3D Element dialog, confirm the Profile Name and Element Template.

3. Following the cursor prompt, locate the Element to Profile. Select the SR61 Centerline in the 2D View.

4. Following the prompt again, locate the 3D element defining the Profile. Select the Ditch Tie Point in the 3D View.
5. The Profile is created and can be viewed in the Profile Model. From the Civil Tools Workflow, select Vertical Geometry > Open Profile Model.

6. Following the cursor prompt, locate the Plan Element. Select the SR61 Centerline in the 2D View.

7. Following the prompt again, select or Open a View. Open View 3 and Data Point in the view. The Profile created displays in the Profile View along with the SR61 Profile.

8. The Special Ditch Profile can be created or edited using the tools under the Vertical Geometry tools. For this exercise we are going to leave the Profile as is.
Control the Profile

A Point Control needs to be set so that the ditch control point in the template will follow the profile vertically.

1. From the Civil Tools Workflow, select Corridor Modeling > Create Point Control.

![Corridor Modeling](image)

2. Following the cursor prompt, locate the corridor. Select the SR 61 Corridor Boundary.
3. Give a Start Station of 715+75.00.
4. Select Alt to lock the end station to the end of corridor.
5. Give the Control a Name or Description, i.e. Special Ditch.
6. Select the Point RT_DITCH_CP.
7. Set the Mode to Vertical.
8. Set the Control Type to Linear Geometry.
9. Following the cursor prompt, select the Special Ditch Profile in the profile model. This will automatically set the plan to the SR 61 Centerline.
10. Set the Priority to 1.
11. Set the *Start* and *Stop Vertical Offsets* to 0.0 and *Data Point* to place the point control.

12. Allow the corridor to process.

13. The ditch can be viewed in the cross section view. From the Civil Tools Workflow, select **Corridor Modeling > Open Cross Section View**.
14. Following the cursor prompt, locate the *Alignment* or *Corridor*. Select the **SR 61 Centerline**.

15. Set the *Left Offset* to **-80.00**.

16. Set the *Right Offset* to **80.00**.

17. Set the *Station* to **719+50.00**.

18. Set the *Interval* to **10.00**.

19. Following the cursor prompt, *Select* or *Open a View*. Select *View 4* and *Data Point* in the view.

20. Use the navigation arrows at the top of the dialog to view the cross sections.
Export the Profile to the GPK File.

2. Following the cursor prompts, select the Special Ditch Profile in the profile model and right-click to Reset and Complete.
3. The Job Number dialog displays. Select the correct (.gpk) file, job00.gpk and click OK.
4. The Profile is stored in the selected (.gpk) file.

Exercise 17.2 Draw the Ditch Profile

1. Continuing in the MicroStation design file:
   C:\E\Projects\22049555201\roadway\DSGNRDO1.dgn.
3. The Create File/Project dialog displays. Click on the **Project Settings** button.
   
a. The Project Settings dialog displays. Click on the **Select Active Project** button.
   
b. The Select Active Project dialog displays. Click the **Browse** button, navigate to the Project C:\\Projects\22049555201, click **Select** and then click **OK**.
   
c. From the Project Settings dialog, click **OK**.
   
d. The Project is populated with the selected Project path and the **Workspace** is set to **FDOTSS4**. Complete the Create File/Project dialog as shown below:

   ![Create File/Project dialog](image)

   e. Click **Create** to create the file, **DSPFRD02.dgn**.
   
f. Click **Open File** to open the newly created **DSPFRD02.dgn**. **Set/Update Plot Scale** displays. Use the **Default** settings and click **OK**.
   
g. Click **OK** to close the Create File/Project dialog.
4. Reference in the DSGNRD01.dgn file and **Fit View**.

5. From the GEOPAK Road toolbox, select the Project Manager tool.

   **Note** To open this toolbox go to GEOPAK > ROAD > Road Tools.

6. The Project Manager dialog displays. Select the SR61Drainage.prj file and click **OK**.

7. The **Project Users** dialog displays. Select the **User: Student** and click **OK**. The Road Project dialog displays. Minimize the Road Project dialog.
8. From the GEOPAK Road toolbox, select the **Draw Profiles** tool.

9. The **Draw Profiles** dialog displays. Select **00** for the **Job Number** and set the **Chain** to **SR61**.
10. Click the Profile Cell Control button.

   a. The Profile Cell Control dialog displays. Select **SR61** as the *Active Chain*.

   b. Click the Place Profile Cell button on the right side of the dialog.

   c. The Place Profile Cell dialog displays. Complete the information as shown below.

   d. **Data Point** near the Plan View to place the **Profile Cell** in the design file. The Place Profile Cell dialog closes.

   e. Close Profile Cell Control dialog.

11. From MicroStation, click the **Fit View** button.
12. From the Draw Profile dialog, select the **Surfaces** tab.

![Draw Profile Dialog](image)

a. Under **Details**: click the *spy glass* icon and browse to the TIN file: C:\\e\projects\22049555201\survey\GDTMRD01.tin.

![Details Dialog](image)

b. Select **Triangles** as the **Method** for extraction.

c. Under **Display Settings**: Set to **By Feature**.

d. Use the **Paintbrush** icon to browse to the **Feature**.

![Display Settings Dialog](image)

e. The Select Design & Computation Pay Item dialog displays. Navigate to:

- **Profiles > Roadway > Roadway Design Profiles > Profile Grade Line (Existing)**

and select **EPGL_50_5 50 Scale Horiz., 5 Scale Vert.** Click **OK**.

![Select Design & Computation Pay Item](image)

f. **Feature** is set to the selected item’s symbology and the Select Design & Computation Pay Item dialog closes.
13. From the Draw Profile dialog, toggle On the Begin and End Station Limits check boxes.

![Draw Profile dialog](image)

a. Type in **719+00.00** for the Begin Station Limit.
b. Leave the End Station Limit as is.

14. From the Draw Profile dialog, toggle On the Void check box.

a. Right-click on the symbology box under Display Settings and select **Copy**.
b. Right-click on the symbology box next to Void and select **Paste** to set the Void symbology.

15. From the Draw Profile dialog, click the Add Surface Settings button to add the Profile to the list and to the design file.
16. From the Draw Profile dialog, select the COGO tab.
   a. Set the Label Scale to **50.0**.
   b. Under the Details section, select **SPDTRT** as the Profile.
   c. Under the Display Settings section set to By Feature.
   d. Click the Paintbrush icon to select the right of Feature.

   ![Draw Profile dialog with COGO tab selected]

   e. The Select Design & Computation Pay Item dialog displays. Navigate to: Profiles > Roadway > Roadway Design Profiles > Profile Grade Line Right (Proposed) and select PPGL_50_5R 50 Scale Horiz., 5 Scale Vert. Click OK.

   ![Select Design & Computation Pay Item dialog]

   f. Feature is set to the selected item’s symbology and the Select Design & Computation Pay Item dialog closes.

   g. Click the Add COGO Profile Settings button on the right side of the list box to draw the Profile into the MicroStation design file.

   h. Close the Draw Profile dialog.

17. Adjust the Labels as needed.

18. Close MicroStation.
OBJECTIVES

The objective of this chapter is to provide the user with a general understanding of SS4 Open Roads Technology functionality.

INTRODUCTION

OpenRoads is the common technology for Bentley Systems civil products that has been developed in partnership with users.

OpenRoads combines data acquisition/survey, geometry corridor, terrain modeling, dynamic sections, and much more to create an immersive interaction of features within a common footprint.

Exercise 18.1 Pond Design

To create a pond and determine the location, size, shape, volume, and treatment method follow the guidelines set in the Drainage Handbook. For the purpose of demonstration and training those parameters have already been set.

➢ Create Pond Boundary

1. Using the FDOTSS4 icon, open the MicroStation file, c:\e\projects\22049555201\drainage\DRPRRD01.dgn
3. The Create File/Project dialog displays. Set the dialog as shown below.

4. Click Create to create the file, PDPLRD01.dgn

5. Click Open File to open PDPLRD01.dgn. Set/Update Plot Scale displays. Use the Default settings and click OK.

6. Click OK to close the Create File/Project dialog.

7. Reference in the following design files:
   ✓ C:\projects\220495555201\roadway\DSGNRD01.dgn
   ✓ C:\projects\220495555201\drainage\DRPRRD01.dgn
   ✓ C:\projects\220495555201\rwmap\RWDTDRD01.dgn
   ✓ C:\projects\220495555201\survey\TOPTRD01.dgn

8. Fit the View. Confirm the proposed R/W Level, RWLine is turned On and select File > Save Settings.
9. The pond will be constructed in the area of the proposed R/W to the right of SR61.

➢ Use the New Roadway and R/W Lines to Create a Pond Boundary.

1. Continuing in the PDPLRD01.dgn file, on the Civil Tools Workflow, select Horizontal Geometry > Single Offset Entire Element tool.
2. Create Pond Boundary Line 1:
   a. Set the Feature to ConstLinesGreenDash.
   b. Type PondBnd1 for the Name.
   c. Select the Unpaved Shoulder Level: line to the right of SR 61.
   d. Set the Offset to 20.00.
   e. Data Point to accept the Offset.
   f. Set Mirror to No and Data Point to place the line.

3. Using the same tool, create the Pond Boundary Line 2:
   a. Set the Feature to ConstLinesGreenDash.
   b. Type PondBnd2 for the Name.
   c. Select the R/W line at approximate Sta. 704+00.00.
   d. Set the Offset to 20.00.
   e. Data Point to accept the offset.
   f. Set Mirror to No and Data Point to place the line.

4. Using the same tool, create the Pond Boundary Line 3:
   a. Set the Feature to ConstLinesGreenDash.
   b. Type PondBnd3 for the Name.
   c. Select the R/W line at approximate Sta. 709+20.00.
   d. Set the Offset to 20.00.
   e. Data Point to accept the offset.
   f. Set Mirror to No and Data Point to place the line.

5. There should be 3 green dashed lines placed inside the proposed R/W.

7. On the dialog, set the *Feature* to **ConstLinesGreenDash** and type **PondBndArc_1** for the *Name*.

8. Follow the prompts on the cursor:
   a. Select the *first element* (**Boundary Line 1**).
   b. Select the *second element* (**Boundary Line 2**).
   c. Set the *Radius* to **35.00**.
   d. Set the *Trim Option* to **Both**.
   e. *Data Point* to trim the line work and place the arc.

9. Follow the same steps for the other 2 corners of the pond.
10. On the Civil Tools Workflow, select **Horizontal Geometry > Complex By Elements** tool.

11. Set the dialog as shown below:
   a. **Method**: Automatic.
   b. **Maximum Gap**: 0.01
   c. **Feature Definition**: Retention Area
   d. **Name**: POND1

12. Select Pond Boundary 1 and **Data Point** to create the shape.
➢ **Place the Pond Civil Cell**

1. Continuing in the *PDPLRD01.dgn* file, use the *Element Selector* to select the Pond Boundary.
2. Hover over the boundary. The context menu will pop up.

3. Select the *second icon, Open Profile Model*.
4. Following the cursor prompt, open a MicroStation *View* and *Data Point* to view the existing profile.
5. Select the **Existing Profile** and hover over it until the context menu pops up.

![Select the Existing Profile](image1)

6. Select the *second icon, Set As Active Profile.*

7. Select the **F2** key to see the 3D line.

   **Note**
   - Turn off the default level in the 3D View

8. On the Civil Tools Workflow, select the **Civil Cells > Place Civil Cell** tool.

![Civil Tools Workflow](image2)

9. The **Place Civil Cell** dialog displays.

![Place Civil Cell](image3)

10. Click on the **Browse** button, the **Pick Civil Cell** dialog displays.

![Pick Civil Cell](image4)
11. Select the **Pond Civil Cell** under **FDOT_Ponds > Pond** and click **OK**.

![Pond Civil Cell](image)

12. Following the cursor prompts, **Locate the Pond Shape**.

13. Right-click to **Reset** and skip **Alternate Views**.

14. **Data Point** to accept the Civil Cell Placement.

15. The pond is placed in the **2D** and **3D View**. Select the **F2** key to see both views.

**Note** This civil cell places a linear template and creates a terrain model of the pond.
16. To view the contours, select F11 key. The Project Explorer dialog displays. Select the Civil Model tab.

17. Select Civil Cells > Dependent Elements > Terrain Model: DTMPond.

18. Right-click and select Properties. The Element Information dialog displays. Double-click on Contours under the Calculated Features Display section. This will turn them on and off.
➢ **Change the Pond Dimensions and Elevations**

1. If the pond is extended outside of the R/W limits or onto the roadway the dimensions can be changed and all of the other variables will adjust as well.

2. Click on the **Retention Area Shape** in the 2D View.

3. The original Dimension from the line that created the shape displays. Click on the **Dimension** and enter a *different value* to make it move in or out.

4. Repeat for each side of the pond to confirm it within the R/W Limits.

5. To change the elevation, from the **Civil Tools Workflow**, select the **Vertical Geometry > Profile By Constant Elevation** tool.

6. The **Create Profile By Constant Elevation** dialog displays.

7. Following the prompts, locate the **Element to Profile**. Select the **Pond Boundary**.

8. Right-click to **Reset**.

9. Set the **Elevation** to **30.00** and **Data Point** to create the **Profile**.
10. The *Profile line* will be placed in the *Profile View*.

![Profile View](image)

11. Select the **Profile** and hover over it until the context menu pops up.

![Set As Active Profile](image)

12. Select the second icon, **Set As Active Profile**.

13. The *Elevation* can now be changed directly in the *Profile View*; the *Pond Model* and 2D Elements will adjust accordingly.

![Elevation Change](image)

14. Change the *Elevation* to **31.50**. View both the *Plan* and *Model View* to see the changes occur.

**Note** If the pond is not the shape needed for the project it can be easily changed to reflect the desired slopes or other information. First, drop the civil cell that was placed and edit the linear template in the Template Library.
➢ **Compute and Analyze Volumes**

There are a few Civil Tools available for computing the pond volumes and analyzing the ponds in a project.

1. Continuing in the `PDPLRD01.dgn` file, from the Civil Tools Workflow, select the **Terrain Model > Analyze Volumes** tool.

2. The Analyze Volume Terrain Model displays.

3. Set the **Volume Method** to **Terrain Model To Terrain Model** and **Data Point** to accept the method.

4. Following the cursor prompts, locate the **From Terrain Model**. Select the **Project Terrain Model**.

5. Locate the **To Terrain Model**, select the **Project Terrain Model**.

6. Leave the **Cut Factor** at 1.0 and **Data Point** to accept.

7. Leave the **Fill Factor** at 1.0 and **Data Point** to accept.

8. Right-click to **Reset** for the **Boundary**.

9. Set the **Save Results** option to **Yes** and **Data Point** to accept.

10. The **results** displays on the active level attached to the cursor. **Data Point** to place the information in the file.
➢ Use Alternate Method, Analyze Pond Tool, to Evaluate a Pond.

1. On the Civil Tools Workflow, select the Terrain Model > Analyze Ponds tool.

   ![Civil Tools Workflow](image1)

   **Note** This tool will allow you to view all existing pond areas within the terrain model.

2. Following the cursor prompt, Locate the Terrain Model. Select the Project Terrain Model.

3. The Analyze Pond dialog displays.

   ![Analyze Pond Dialog](image2)
4. The Ponded Areas will also display in the design file.

5. Hover over each pond to view the Volume, Depth, Elevation, and Area.

6. Data Point in the pond to save the boundary.
Export the Terrain Model

Once the pond is created, the terrain model of the pond can be exported if needed. The pond terrain model can be exported to an MX (.fil), LandXML file, an InRoads DTM file, or a GEOPAK TIN file.

1. On the Civil Tools Workflow, select the **Terrain Model > Export to file** tool.

2. Following the cursor prompt, select the **Terrain to Export**. Select the **Pond Model**.
3. Select the **File Format**, **GEOPAK (.tin)** and **Data Point** to accept.
4. Navigate to the correct directory and **Name** the file, if needed.
5. Click **Save**. The file will be saved in the selected directory.
6. Close **MicroStation**.
19 IMPORTING STREAM GEOMETRIC DATA TO HEC-RAS

OBJECTIVES

The objective of this chapter is to provide a general understanding of GEOPAK Cross Section Reports and their capability to generate geometric information for the HecRas program.

INTRODUCTION

The creation of a stream or river cross sections requires the usage of different tools within the Civil Tools. The GEOPAK Cross Section Report tool enables us to extract information from the stream cross sections in a format acceptable by the HecRas software.

The designer should be able to place a basic alignment along the stream and generate existing ground cross sections. These cross sections will be used in the GEOPAK Cross Section Report to format the data accordingly to HecRas Gis format.

Exercise 19.1 Importing Stream Geometric Data to HEC-RAS

➢ Creating a River Baseline

1. Using the FDOTSS4 icon, open the MicroStation file, c:\\projects\22049555201\drainage\DRPRRD01.dgn.
2. Open Project Manager. From the MicroStation menu, select Applications > GEOPAK Road > Project Manager.
3. Select Project: SR61Drainage.prj located in c:\\\projects\\22049555201\, and click OK.
4. Access User: Student
5. Turn On the TOPO reference file and locate the stream on the left side of BL98.
6. Copy the stream line into the DRPRRD01.dgn file and turn Off the TOPO reference file.
7. From the quick tools, select the Drop Element tool. The Drop Element dialog displays.
8. On the Drop Element dialog confirm the Line Strings/Shapes option is toggled ON. Drop the line string.

9. From the Civil Tools Workflow, select the Horizontal Geometry > Complex By Elements tool.

10. The Create Complex Element dialog displays.
   b. Set the Feature Definition to Centerline(CL).
   c. Type in the Name STREAM.

11. Create the new Alignment by connecting the elements.
12. From the Civil Tools Workflow, select the **Horizontal Geometry > Start Station** tool.

13. The Define Starting Station dialog displays. Set the *Start Station* to **100+00.00**.

14. Following the cursor prompt, **Locate Element**.

15. Set the **start position** at the beginning of the line and **Data Point**.

16. **Data Point** to accept the *Start Station*. The station information is added to the centerline.

17. Select the **STREAM Centerline** and hover over the highlighted line until the **Context Menu** displays.

18. Select the **View Profile** icon and select **View 3** at the bottom of the MicroStation window to open the **Profile View**, then **Data Point** in **View 3**.
19. In the Profile View, select the Existing Ground Profile to display the Context menu and then select the Set Active Profile icon. Close the Profile View window.

20. On the Civil Tools Workflow, select the General Geometry > Export to Native tool.

21. Following the cursor prompt, select the STREAM Centerline and Reset.
22. The Job Number dialog displays. Select the job00.gpk file and click OK.
23. Open the ALGNRD01.dgn file, open the 50 Scale Model.
24. From the MicroStation menu, select GEOPAK > ROAD > Design & Computation Manager.

a. Navigate to the Roadway Design > Plan Features folder and select CL Centerline of Construction (with stationing).

25. On the CL Centerline of Construction dialog, check the Place Influence box and click the Draw Plan & Profile button.

a. On the Open Job dialog, browse to the job00.gpk Job file and click OK.
   a. Change the Element Type to Stationing.
   b. Enter 50 for the Label Scale.
   c. In the Select Chain to Draw List box, select on STREAM.

27. Close each of the Design & Computation Manager dialogs (3) and click Fit View to see the results.

28. From the MicroStation menu, select File > Save Settings <OR> press Ctrl F.
➢ Existing Ground Cross Sections

1. From the FDOT Plans Development Workflow, select Roadway Plans > Create New File.

![Roadway Plans screenshot]

2. The Create File/Project dialog displays. Complete the Create File/Project dialog as shown below.

![Create File/Project dialog]

- Click Create to create the file, RDXSRD02.dgn.
- Click Open File to open the newly created RDXSRD02.dgn. Set/Update Plot Scale displays. Set the Scale to 20.0 and click OK.
- Click OK to close the Create File/Project dialog.
3. Open the MicroStation design file:
   C:\E\Projects\22049555201\roadway\RDXSRD02.dgn.

4. With RDXSRD02.dgn open, go to the Patrrd Model and Reference in the following files:
   - C:\E\Projects\22049555201\roadway\DRPRRD01.dgn file
   - C:\E\Projects\22049555201\roadway\GKLNRD01.dgn file
   - C:\E\Projects\22049555201\survey\GDTMRD02.dgn file

5. Use the MicroStation Fit View and then select File > Save Settings.

6. From the FDOT Plans Development Workflow, select Cross Sections > Create Cross Sections.

7. Following the cursor prompt, locate the STREAM Alignment.

8. The Create Cross Section dialog displays. Populate the dialog as shown below:

9. Click Apply. View 3 is opened and the Cross Sections are generated with the cross section cell and existing ground.

10. Click Close to exit the Create Cross Sections dialog.
➢ **Review the Cross Sections**

1. From the FDOT Plans Development Workflow, select **Cross Sections > Navigate Cross Sections**.

2. Use the Cross Section Navigator to browse and check the *Existing Cross Sections*.
3. Close the Cross Section Navigator dialog

➢ **Exporting to HEC-RAS**

1. Open the Cross Section Reports dialog. From the MicroStation menu select **GEOPAK > ROAD > Cross Sections > Reports**.
2. Click on the **HEC-RAS** button. The HEC-RAS Report dialog displays.
3. Populate the dialog as shown below.
4. Click **Apply** to generate the **Hec-Ras Cross Section Geometry** file.
Import Cross Section Data into HEC-RAS

1. Install HEC-RAS from c:\e\projects\22049555201\roadway\HEC-RAS\HEC-RAS_410_Setup.exe.
2. Open HEC-RAS. The main dialog displays.

3. From the HEC-RAS menu select Edit > Geometric Data.

4. The Geometric Data dialog displays. Import the Cross Section Data generated by GEOPAK. From the HEC-RAS menu select File > Import Geometry Data > GIS Format.
5. Select the file created from the **GEOPAK Cross Sections** and click **OK**.

6. Review the Import Geometry Data dialog and click **Finished – Import Data**. The **Geometric Data** is now shown in the dialog.

7. Click on the **Cross Section** button in the Geometric Data dialog. The **Cross Section Data** dialog displays. Review the **Cross Sections**.
8. From the Cross Section Data dialog select **Plot > Plot Cross Section (in separate window)** to view a graphical representation of the *Cross Section Data*.

9. Save your project data and **exit HEC-RAS**.
OBJECTIVES

The objective of this chapter is to review the computation methods utilized by GEOPAK Drainage.

THE RATIONAL METHOD

The Rational Method is the most widely used formula to calculate storm water runoff. The Department recommends the use of that for pipe sizing, inlet capacity and spread computations. This method uses certain assumptions that make their use only suitable for areas of less than 200 acres. These assumptions are:

- The entire Drainage Area contributes to the Discharge.
- Rainfall Intensity, measured in inches per hour, is distributed evenly in the whole drainage area.
- Rainfall intensity is at a constant rate along the entire duration of the storm. The storm duration is at least equal to the Time of Concentration.
- Frequency of the computed flow is of the same frequency as that of the rainfall intensity. Five (5) year rainfall intensity is set to produce a 5 year peak flow or discharge.
- Coefficient of Runoff is the same for all storms and probabilities of recurrence.

The Rational Formula is given as:

\[ Q = CIA \]

- \( Q \) = Computed Peak Discharge in cubic feet per second (cfs)
- \( C \) = Runoff Coefficient (non-dimensional value)
- \( I \) = Intensity of Storm in inches/hr.
- \( A \) = Drainage Area in acres

The formula is not dimensionally correct as it is a result of empirical studies. Let’s analyze in detail each component of the formula.
ÇÁÇÁÎÉÍÁÎÉÍ (C)

The Runoff Coefficient is a function of the ground cover and other hydrological abstractions. This is a dimensionless number that represents the fraction of rainfall that remains on the surface of the ground. The runoff coefficient relates the estimated peak discharge to a theoretical maximum of 100 percent of runoff.

The Department provides a table of runoff coefficients that depends on the slope of the terrain being analyzed and the use of it. In more practical terms we can summarize that for storm drain projects, we can divide our drainage area into pervious and impervious areas.

We can conclude that a pervious area is the one with a c value equal or less than 0.5. A typical pervious area could be woodlands, grassy terrain or residential areas. Then we can also say that an impervious area is the one with a c value greater than 0.5. Pavement areas or heavy commercial and industrial lots are a good representation of this type of drainage area.

Therefore, we can say that for storm drain projects the following assumption is valid:

\[
C = \begin{cases} 
0.95 & \text{for pavement areas} \\
0.50 & \text{for grassy areas} 
\end{cases}
\]

In a drainage area, multiple types of surfaces could be present with different runoff coefficients. Then, a weighted runoff coefficient should be determined. The weighting is based on the area of each land and is found by the following formula:

\[
C = \frac{\sum CA}{\sum A}
\]

INTENSITY (I)

Intensity is usually represented at the rate of rainfall in inches over an hour period. Intensity computations in GEOPAK Drainage are based on one of several options for defining the Intensity-Duration-Frequency (IDF) relationship. The selection of the intensity over a drainage area depends on the frequency of the storm to be analyzed and their duration, than in general we equal to the time of concentration of the area.

The intensity over a drainage area is calculated or extracted from widely develop I-D-F (intensity-duration-frequency) curves. The Department also provides mathematical functions for each of the curves so they can be implemented in computer programs. GEOPAK Drainage uses a four parameter intensity curve with the time of concentration in logarithmic format to represent the intensity rainfall in Florida.

\[
I = a + b \ln(tc) + c \ln(tc)^2 + d \ln(tc)^3
\]

I = rainfall intensity for frequency (inch/hr)

n = time of concentration (min)

a,b,c,d = empirical factors which are input for each frequency.
The Department has also published I-D-F curves covering the State of Florida for different frequencies under different rainfall zones. In order to find the Intensity for Drainage area, we have to do the following:

- Localize the project inside one of the 11 zones into which the Department has divided the State.
- Select the proper I-D-F curve according to the selected zone.
- Enter the chart using the time of concentration as the storm duration and intersect the proper frequency curve.
- At the point of intersection, read the rainfall intensity in inches per hour.

**TIME OF CONCENTRATION (TC)**

*Time of Concentration* is defined as the time required for a drop of rainfall to travel from the most remote point of a watershed to the point of analysis. GEOPAK Drainage time of concentration calculations are derived from FHWA HEC-22. The Department recommends a minimum Time of Concentration equal to 10 minutes despite a lower calculated time.

To calculate Time of Concentration, we have to recognize the different types of flow that occur inside the drainage basin and along the flow path. These are sheet flow, shallow concentrated flow and open channel or pipe flow. For each type of flow a myriad of formulas could be used; each one of them using their own assumptions. FHWA in their *Urban Drainage Design Manual* cites the following formula for each types of flow.

**Sheet Flow Travel Time**

The starting type of flow in a drainage basin, in which, runoff has a uniform depth along a sloping surface. We can say that the limit is the first 400 ft. The formula is a version of the kinematic wave equation.

\[
T_{\text{sheet}} = \frac{K_u}{I^{0.4}} \left( \frac{nL}{\sqrt{S}} \right)^{0.6}
\]

- \(T\) = sheet flow travel time (minutes)
- \(N\) = Manning’s roughness coefficient of the watershed.
- \(L\) = flow length (ft)
- \(I\) = rainfall intensity (inches/hr)
- \(S\) = surface slope (ft/ft)
- \(K_u\) = empirical coefficient equal to 0.933
✓ Manning’s Roughness Coefficient (n) for Overland Sheet Flow

<table>
<thead>
<tr>
<th>Surface Description</th>
<th>n</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smooth Asphalt</td>
<td>0.011</td>
</tr>
<tr>
<td>Smooth Concrete</td>
<td>0.012</td>
</tr>
<tr>
<td>Ordinary concrete lining</td>
<td>0.013</td>
</tr>
<tr>
<td>Good wood</td>
<td>0.014</td>
</tr>
<tr>
<td>Brick with cement mortar</td>
<td>0.014</td>
</tr>
<tr>
<td>Vitrified clay</td>
<td>0.015</td>
</tr>
<tr>
<td>Cast iron</td>
<td>0.015</td>
</tr>
<tr>
<td>Corrugated metal pipe</td>
<td>0.024</td>
</tr>
<tr>
<td>Cement rubble surface</td>
<td>0.024</td>
</tr>
<tr>
<td>Fallow (no residue)</td>
<td>0.05</td>
</tr>
</tbody>
</table>

**Cultivated soils:**

- Residue cover < 20%: 0.06
- Residue cover > 20%: 0.17
- Range (natural): 0.13
- Short grass prairie: 0.15
- Dense grasses: 0.24
- Bermuda grass: 0.41
- Woods
  
  *(When selecting n, consider cover to a height of about 30 mm. This is the only part of the plant cover that will obstruct sheet flow.)*

- Light underbrush: 0.4
- Dense underbrush: 0.8

This is an iterative process since the intensity depends on the time of concentration. Therefore, the assumed time of concentration must be the same as the calculated one in order to stop the iterative process.

**Shallow Concentrated Flow Travel Time**

Up to a distance of 400 ft, sheet flow tends to concentrated in rills and then gullies of increasing proportions. First, we need to calculate the velocity in order to estimate the travel time.

\[
V = K_u k S^{0.5}
\]

- \(V\) = velocity (ft/s)
- \(K_u\) = coefficient of 3.28
- \(k\) = intercept coefficient.
- \(S\) = slope in percentage
✓ Intercept Coefficients for Velocity vs. Slope Relationship

<table>
<thead>
<tr>
<th>Land cover / Flow regime</th>
<th>k</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forest with heavy ground litter; hay meadow (overland flow)</td>
<td>0.076</td>
</tr>
<tr>
<td>Trash fallow or minimum tillage cultivation; contour or strip cropped; woodland (overland flow).</td>
<td>0.152</td>
</tr>
<tr>
<td>Short grass pasture (overland flow)</td>
<td>0.213</td>
</tr>
<tr>
<td>Cultivated straight row (overland flow).</td>
<td>0.274</td>
</tr>
<tr>
<td>Nearly bare and untilled (overland flow) alluvial fans in western mountain regions</td>
<td>0.305</td>
</tr>
<tr>
<td>Grassed waterway (shallow concentrated flow).</td>
<td>0.457</td>
</tr>
<tr>
<td>Unpaved (shallow concentrated flow.)</td>
<td>0.491</td>
</tr>
<tr>
<td>Paved area (shallow concentrated flow); small upland gullies</td>
<td>0.619</td>
</tr>
</tbody>
</table>

**Open Channel and Pipe Flow Travel Time**

It is the flow collected in channel and pipes. The Manning’s equation can be used to estimate the average flow velocities in pipes and open channels.

\[
V = \frac{1.49}{n} R^{2/3} S^{6.5}
\]

- \( V \) = velocity (ft/s)
- \( n \) = Manning’s runoff coefficient
- \( R \) = hydraulic radius (flow area divided by the wetted perimeter)
- \( S \) = slope (ft/ft)

Then the travel time could be calculated as:

\[
T_{\text{channel}} = \frac{L}{60V}
\]
Values of Manning Coefficient (n) for Channels and Pipes:

<table>
<thead>
<tr>
<th>Conduit Material</th>
<th>Manning n</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Closed Conduits:</strong></td>
<td></td>
</tr>
<tr>
<td>Asbestos – cement pipe</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td>Brick</td>
<td>0.013-0.017</td>
</tr>
<tr>
<td>Cast Iron pipe</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td>Cement-lined &amp; seal coat</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td>Concrete (monolithic)</td>
<td>0.012-0.014</td>
</tr>
<tr>
<td>Corrugated-metal pipe (1/2 in x 2 ½ in corrugations)</td>
<td></td>
</tr>
<tr>
<td>Plain</td>
<td>0.022-0.026</td>
</tr>
<tr>
<td>Paved Invert</td>
<td>0.018-0.022</td>
</tr>
<tr>
<td>Spun Asphalt Lined</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td>Plastic pipe (smooth)</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td><strong>Vitrified Clay:</strong></td>
<td></td>
</tr>
<tr>
<td>Pipes</td>
<td>0.011-0.015</td>
</tr>
<tr>
<td>Liner Plates</td>
<td>0.013-</td>
</tr>
<tr>
<td><strong>Open Channels:</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Lined Channels:</strong></td>
<td></td>
</tr>
<tr>
<td>A. Asphalt</td>
<td>0.013-0.017</td>
</tr>
<tr>
<td>B. Brick</td>
<td>0.012-0.018</td>
</tr>
<tr>
<td>C. Concrete</td>
<td>0.011-0.020</td>
</tr>
<tr>
<td>D. Rubble or riprap</td>
<td>0.020-0.035</td>
</tr>
<tr>
<td>E. Vegetal</td>
<td>0.030-0.40</td>
</tr>
<tr>
<td>Excavated or dredged</td>
<td></td>
</tr>
<tr>
<td>Earth, straight, and uniform</td>
<td>0.02-0.030</td>
</tr>
<tr>
<td>Earth, winding, fairly uniform</td>
<td>0.025-0.040</td>
</tr>
<tr>
<td>Rock</td>
<td>0.030-0.045</td>
</tr>
<tr>
<td>Not maintained</td>
<td>0.050-0.14</td>
</tr>
<tr>
<td>Natural channels (minor streams, top width at flood stage &lt; 100 ft.)</td>
<td></td>
</tr>
<tr>
<td>Fairly regular section</td>
<td>0.03-0.07</td>
</tr>
<tr>
<td>Irregular section with pools</td>
<td>0.04-0.10</td>
</tr>
</tbody>
</table>

Then, the total time of concentration for a watershed will be:

\[ T_{concentration} = T_{sheet} + T_{shallow} + T_{channel} \]
STORM FREQUENCY

Storm Frequency can be defined as the return period of a specific storm or their Exceedance Probability. Exceedance probability is the probability that an event having a specific volume and duration will be exceeded in a specified time period. Return period is the average length of time between events having the same volume and duration.

Be careful, saying that a storm has a 50 year frequency does not mean that it happens every 50 years. The probability of a storm happening is inversely proportional of the return period. This means that a 50 year storm has a 2% probability of recurrence.

The Department recommends the following design frequencies depending of the type of project:

<table>
<thead>
<tr>
<th>Type of Project</th>
<th>Design Frequency</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Design</td>
<td>3 year</td>
</tr>
<tr>
<td>General design with ditch replacement and adding of side pipes.</td>
<td>10 year</td>
</tr>
<tr>
<td>General design work on interstates</td>
<td>10 year</td>
</tr>
<tr>
<td>Interstate facilities which only outlet is a storm drain system and for the outlet of systems requiring pumping stations.</td>
<td>50 year</td>
</tr>
</tbody>
</table>

INLET SPREAD COMPUTATIONS

The spread or ponded width of runoff at an inlet location is a geometric function of the cross sectional geometry, longitudinal pavement/gutter slope and discharge. A direct solution is not possible for complex cross sections with multiple breaks in the transverse slope so an iterative procedure derived from HEC-22 is employed.

CURB INLETS ON-GRADE

The computation of on-grade curb opening inlets involves a determination spread or ponded width characteristics, computation of length required for total interception, and consideration of inlet efficiency.

The hydraulics of Curb Inlets On Grade is derived from HEC-22. The applicable equations are as follows:
The length of curb inlet required for total interception using Equation:

\[
L_r = 0.60 Q^{0.42} S^{0.3} \left( \frac{1}{n S_e} \right)^{0.46}
\]

- \(L_r\) = length of curb inlet required (ft)
- \(Q\) = flow rate in gutter (cfs)
- \(S\) = longitudinal slope (ft/ft)
- \(n\) = Manning's roughness coefficient
- \(S_e\) = equivalent cross slope (ft/ft) for non-depressed inlets

The equivalent cross slope \((S_e)\) for a depressed curb-opening inlet using Equation:

\[
S_e = S_x + \frac{a}{W} E_o
\]

- \(S_e\) = equivalent cross slope (ft/ft)
- \(S_x\) = cross slope of the road (ft/ft)
- \(a\) = gutter depression depth (ft)
- \(W\) = gutter depression width (ft)
- \(E_o\) = ratio of depression flow to total flow

The Ratio of depression flow to total flow is determined using the following equation:

\[
E_o = 1 - \left(1 - \frac{W}{L} \right)^{0.36}
\]

- \(E_o\) = ratio of depression flow to total flow

Inlet interception capacity is then defined by:

\[
Q_{\text{intercepted}} = Q_{\text{total}} \times \text{Efficiency}
\]

- \(Q_i\) = intercepted discharge (cfs)
- \(Q_t\) = total inlet discharge (cfs)

Efficiency = inlet efficiency defined below

\[
\text{Efficiency} = 1 - \left(1 - \frac{L}{L_r} \right)^{1.8}
\]

- \(L_r\) = length of curb inlet required for 100% interception (ft)
- \(L\) = length of curb inlet provided (ft)
Curb Inlets in Sag

The capacity of a curb inlet in a sag depends on the water depth at the curb opening, and the height of the curb opening. The inlet operates as a weir to depths equal to the curb opening height and transition to orifice flow on higher depths. In the transition the capacity is based on the lesser of the computed weir and orifice capacity.

The head on the inlet is computed by adding the ponded depth (y) and the inlet depression (a) using the following Equation:

\[ h = y + a \]

- \( h \) = head at inlet opening (ft)
- \( y \) = ponded depth in gutter (ft)
- \( a \) = inlet depression depth (ft)

The capacity of the inlet when operating under weir conditions is calculated with the equation:

\[ Q = C_w (L + 1.8*W) h^{1.5} \]

- \( Q \) = total flow reaching inlet (cfs)
- \( C_w \) = weir coefficient = 2.3
- \( h \) = head at inlet opening (ft)
- \( L \) = length of curb inlet opening (ft)
- \( W \) = lateral width of inlet depression (ft)

The equation for interception capacity of a curb opening operating as an orifice follows:

\[ Q = C_o hL\sqrt{2gd_o} \]

- \( Q \) = total flow reaching inlet (ft³/s)
- \( C_o \) = orifice coefficient = 0.67
- \( h \) = depth of opening (ft)
- \( L \) = length of curb opening inlet (ft)
- \( g \) = acceleration due to gravity = 32.2 ft/s²
- \( d_o \) = effective head at the centroid of the orifice (ft)

Grate Inlets on-Grade

The capacity of a grate inlet on-grade depends on its geometry and the cross slope, longitudinal slope, total gutter flow, depth of flow, and pavement roughness. The design of a grate inlet on-grade involves an analysis of given grate dimensions to estimate the interception rate. The difference between the estimated interception rate and the total approach discharge equals the bypass rate. The following procedure is applicable to grate inlets on-grade:

The Ratio of discharge over the grate (Frontal Flow) to flow to total flow is determined using the following equation:

\[ E_o = 1 - \left(1 - \frac{W}{T}\right)^{8/3} \]

- \( E_o \) = ratio of flow over the grate to total flow
The ratio of frontal flow intercepted to total frontal flow:

\[ R_f = 1 - 0.3(\frac{V}{V_o}), \text{ if } V > V_o \]

\[ R_f = 1.0, \text{ if } V < V_o \]

\( R_f \) = ratio of frontal flow intercepted to total frontal flow
\( V \) = approach velocity of flow in gutter (ft/s)
\( V_o \) = minimum velocity that will cause splash over grate (ft/s)

The splash over velocity is of the form of

\[ V_o = AL^N factor^{1-N} \]

\( V_o \) = is splash over velocity
\( A \) = constant for different grate type
\( N \) = a power coefficient for different grate type
\( L \) = grate length

factor = 1 for English and .3048 for metric

<table>
<thead>
<tr>
<th>Grate Type</th>
<th>Coefficient A</th>
<th>Coefficient N</th>
</tr>
</thead>
<tbody>
<tr>
<td>P-1-7/8</td>
<td>5.74872</td>
<td>0.5038679</td>
</tr>
<tr>
<td>P-1-1/8</td>
<td>4.54822</td>
<td>0.5058875</td>
</tr>
<tr>
<td>Curved Vane</td>
<td>3.92812</td>
<td>0.5954068</td>
</tr>
<tr>
<td>45 Tilt Bar</td>
<td>3.35159</td>
<td>0.5926234</td>
</tr>
<tr>
<td>30 Tilt Bar</td>
<td>2.67291</td>
<td>0.7567052</td>
</tr>
<tr>
<td>P-1-7/8-4</td>
<td>3.01181</td>
<td>0.6454720</td>
</tr>
<tr>
<td>Reticuline</td>
<td>2.48235</td>
<td>0.7659749</td>
</tr>
</tbody>
</table>

The ratio of side flow intercepted to total side flow:

\[ R_s = \left[1 + \left(\frac{0.083 ZV^{1.8}}{L^2}\right)^{-1}\right]^{-1} \]

\( R_s \) = ratio of side flow intercepted to total flow
\( Z \) = inverse of transverse slope
\( V \) = approach velocity of flow in gutter (ft/s)
\( L \) = length of grate (ft)

The efficiency of grate, \( E_f \), using equation:

\[ E_f = \left[R_f E_o + R_s (1 - E_o)\right] \]

The interception capacity of the grate, \( Q_i \), using equation:

\[ Q_i = E_f Q = Q\left[R_f E_o + R_s (1 - E_o)\right] \]

The bypass flow rate:

\[ CO = Q - Q_i \]
GRATE INLETS IN SAG

A grate inlet in sag configuration operates in weir flow at low ponding depths. The transition to orifice flow begins as the ponded depth increases. The procedure for calculating the inlet capacity is as follows:

The capacity of a grate inlet operating as a weir is determined with the following equation:

\[ Q_w = (1 - P_R) C_w P h^{1.5} \]

- \( Q_w \) = weir capacity of grate (cfs)
- \( C_w \) = weir coefficient = 3.087
- \( P \) = perimeter of the grate (ft)
- \( h \) = allowable head on grate (ft)
- \( P_R \) = perimeter reduction factor to account for clogging

Under orifice conditions, the grate area controls the capacity. The capacity of a grate inlet operating under orifice flow is computed equation:

\[ Q_o = A \times (1 - A_R) C_o \sqrt{2gh} \]

- \( Q_o \) = orifice capacity of grate (cfs)
- \( C_o \) = orifice flow coefficient = 0.67
- \( A \) = clear opening area (ft²) of the grate (the total area available for flow)
- \( g \) = acceleration due to gravity (32.2 ft/s²)
- \( h \) = allowable head on grate (ft)
- \( A_R \) = area reduction factor to account for clogging

The capacity of a grated inlet in a sag is based on the minimum flow calculated from weir and orifice conditions. The figure below demonstrates the relationship between weir and orifice flow. If \( Q_o \) is greater than \( Q_w \) (to the left of the intersection in the figure), then the capacity would be that calculated with the weir equation. However, if \( Q_o \) is less than \( Q_w \) (to the right of the intersection), then the capacity, as determined with the orifice equation, would be used.
**LINK HYDRAULIC COMPUTATIONS**

Numerous algorithms are employed to perform the pipe and ditch hydraulic computations. The fundamental equations and terminology are presented here for reference purposes. The most widely used formula for determining the hydraulic characteristics of storm drain networks is the Manning Formula, expressed by the following equation:

\[
V = \frac{1}{n} R^{2/3} S^{1/2}
\]

- \( V \) = mean rate of flow (ft/s)
- \( R \) = the hydraulic radius (ft)
- \( S \) = the slope of hydraulic grade line (ft/ft)
- \( n \) = Manning’s roughness coefficient

The hydraulic radius (\( R \)) is defined as follows:

\[
R = \frac{A}{W_p}
\]

- \( W_p \) = wetted perimeter (ft)
- \( A \) = cross sectional area of flow (\( A^2 \))

To satisfy continuity:

\[
Q = A V
\]

- \( Q \) = discharge (m\(^3\)/s)

Combining these equations gives the following equation:

\[
Q = \frac{1}{n} A R^{2/3} S^{1/2}
\]

Conveyance describes the geometric carrying capacity of a hydraulic conduit and is described by the following equation:

\[
K = \frac{Q}{S^2} = \frac{1}{n} A R^2
\]

Friction Slope is the slope (\( S \)) in Manning’s formula required to convey a specified discharge under uniform flow conditions given a depth, roughness, and shape. Under uniform flow, depth and flow area are constant and the friction slope, the actual slope, and the energy slope are all equal.

\[
S_f = \left( \frac{Q}{K} \right)^2
\]
LINK DESIGN CONSTRAINTS

The Constraints establish further design criteria for Links. GEOPAK Drainage utilizes the physical constraints of minimum and maximum size and slope to determine a suitable pipe size.

GEOPAK Drainage will perform the following steps to determine the “allocated pipe envelope”

Starting upstream, GEOPAK computes each link slope by connecting the nodes at the elevation set by the node elevation minus the minimum depth.

If this slope is less than the minimum slope, GEOPAK Drainage sets the slope equal to the minimum slope. This will provide the upper limit of the envelope. Then, it continues downstream.

To setup the bottom part of the “envelope”, it starts from the outlet elevation, move upstream and setup the minimum invert of the pipes by using node elevation minus the maximum depth values on each node.

If the invert falls within the minimum and maximum slopes the link is placed at the calculated elevation. If not, the link is once again placed at the minimum specified slope from that node to the upstream end of the system.

If during the construction of the envelope, any elevations that the user has held will be accommodated if physically possible and the envelope constrained to that elevation. However, if a held elevation of a pipe violates the minimum or maximum depth line, the elevation will not be held. With the minimum and maximum depth profiles computed, GEOPAK Drainage can then design a suitable pipe within this envelope that satisfies all the constraints possible.

The other constraints, minimum and maximum velocity, are for querying purposes and evaluating the adequacy of the design.
• **Minimum Rise** - Constraint - Minimum rise (diameter, height) for pipe or ditch in master units (i.e. feet or meters). The Department’s minimum round pipe size is 1.5' (18”).

• **Maximum Rise** - Constraint - Maximum rise (diameter, height) for pipe or ditch in master units (i.e. feet or meters). Unless the designer knows a constraint, it is recommended that this be set for a large pipe such as a 6' (72”).

• **Minimum Slope** - Constraint - Minimum physical slope for pipe or ditch expressed in percentage. The minimum pipe slope varies with the pipe size (0.15% for 18”, 0.102% for 24” etc.) See the discussion in the Storm Drain Handbook. During the initial design, the pipe sizes are not known, so this constraint may need to be changed as the design progresses. In moderately sloped terrain, using 0.15% may be acceptable for all pipes, because the terrain will force the pipes to be steeper than that. In flat terrain, using 0.15% for all pipes may cause the downstream pipes to be too deep.

• **Maximum Slope** - Constraint - Maximum physical slope for pipe or ditch expressed in percentage. The Department does not have a maximum slope constraint, so it is recommended that this be set high for all pipes.

• **Minimum Velocity** - Query - Minimum velocity for pipe or ditch expressed in feet per second or meters per second. This value must be something greater than zero for the program to do the hydraulic calculations.

• **Maximum Velocity** - Query - Maximum velocity for pipe or ditch expressed in feet per second or meters per second.

**HGL COMPUTATIONS**

The methodology employed by GEOPAK Drainage to compute the water surface profiles through a storm drain network is typical of any open channel water surface procedure. A backwater analysis is performed through the system beginning at the most downstream point (outlet) and progressing upstream to the most remote nodes. GEOPAK Drainage will compute the Hydraulic Grade Line (HGL) using gradually varied flow analysis in free surface flow conditions and pressure flow computations under full flow conditions.

The resulting HGL represents the set of elevations to which the water would rise if open to atmospheric pressure (e.g., piezometer tubes) along a pipe run and can be used to evaluate the adequacy of the design and identify areas where flooding occurs.

**HYDRAULIC GRADE LINE**

The HGL procedure begins at the most downstream node (outlet) and proceeds upstream through each link in the same fashion. A starting HGL at this downstream point elevation must be defined. The procedure for developing the HGL through a link of the network from Downstream Node to Upstream Node is as follows:
1. Beginning with the HGL at the Downstream Node (HGL₁), the Energy Grade Line (EGL₁) is computed from:

\[ EGL = HGL + \frac{v^2}{2g} \]

\( v \) = velocity at flow depth HGL (ft/s)

\( g \) = gravity (32.2)

\( HGL \) = elevation of HGL

2. Assuming a very small change in the energy and depth (\( y \)) compute the HGL₂ from:

\[ HGL₂ = HGL₁ + y \]

3. Determine the distance along the pipe (\( x \)) to create the (\( y \)) loss due to friction = \( x = S_fy \)

where \( S_f = 0.5(S₁+S₂) \)

4. This procedure of computing HGL₂ and the distance along the pipe proceeds until the end of the pipe has been reached yielding the HGL at the upstream end of the pipe.

5. The resulting upstream HGL is subsequently used on the next upstream pipe as its starting downstream HGL. **GEOPAK Drainage** can alternatively use the computed energy grade line upstream as the starting downstream EGL on the next pipe upstream. This alternative method differs in that the EGL’s upstream and downstream at a node are equal rather than the conventional assumption that the HGL’s are equal.

6. If junction losses are desired they computed prior to progressing upstream and added to the HGL.

➢ **Special Considerations**

- If the starting HGL is less than critical depth then critical depth will be assumed.
- If the HGL converges to equal the uniform depth the computations proceed to the upstream end at uniform depth.
- Once the HGL reaches the soffit of the pipe full flow conditions begin.
- Hydraulically steep pipes where uniform depth is less than the critical depth are checked with a backwater profile to verify if the resulting upstream HGL drowns out critical depth at the upstream end. If it does than the backwater profile is accepted. If the backwater curve does not exceed the critical depth, then a Forewater Profile is generated for this supercritical condition. A Forewater Profile uses the same procedure as above but progresses from the upstream end towards the downstream end. It begins at critical depth at the upstream end and converges towards uniform depth as the calculations proceed downstream.
- Hydraulic jumps may occur when mixing supercritical and subcritical water surface profiles. **GEOPAK Drainage** does not compute the exact location of a jump but will check if downstream subcritical depths have sufficient energy to force a supercritical profile to its conjugate depth thereby satisfying the conditions required for a jump to occur. Message will be appear indicating the existence of a jump.

**JUNCTION LOSSES METHODOLOGIES**

Six junction loss methodologies are discussed:

- Free Surface Transition Losses
- Pressure Flow Transition Losses
- Bend Losses
- Curve Losses
- Terminal Inlet / Junction Losses
- Complex Junction Losses
FREE SURFACE TRANSITION LOSSES

The energy losses may be expressed in terms of the kinetic energy at the between the incoming and outgoing pipes:

\[ H_t = K_t \Delta \left( \frac{V^2}{2g} \right) \]

Where \( K_t \) is the transition Loss Coefficient.

For \( V_2 > V_1 \)

\[ H_t = K_t \left( \frac{V_2^2 - V_1^2}{2g} \right) \]

For \( V_1 > V_2 \)

\[ V_1 = \text{upstream velocity} \]
\[ V_2 = \text{downstream velocity} \]
\[ K_t = \text{Loss Coefficient for expansion of contraction} \]

PRESSURE FLOW TRANSITION LOSSES

The energy losses may be expressed in terms of the kinetic energy at the between the incoming and outgoing pipes:

\[ H_t = K_t \left( \frac{\Delta V^2}{2g} \right) \]

Where \( K_t \) is the transition Loss Coefficient.

For \( V_2 > V_1 \)

\[ H_t = K_t \left( \frac{V_2^2 - V_1^2}{2g} \right) \]

For \( V_1 > V_2 \)

\[ V_1 = \text{upstream velocity} \]
\[ V_2 = \text{downstream velocity} \]
\[ K_t = \text{Loss Coefficient for expansion of contraction} \]
**BEND LOSSES**

**METHOD 1 (FROM MODERN SEWER DESIGN)**

Bend losses may be estimated from the equation:

\[ H_b = K_b \frac{V^2}{2g} \]

Where \( K_b \) can be estimated from the following table:

<table>
<thead>
<tr>
<th>K - Bend Loss Coefficient</th>
<th>Degree of Turn at Bend</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.10</td>
<td>20</td>
</tr>
<tr>
<td>0.32</td>
<td>40</td>
</tr>
<tr>
<td>0.64</td>
<td>60</td>
</tr>
<tr>
<td>1.06</td>
<td>80</td>
</tr>
<tr>
<td>1.32</td>
<td>90</td>
</tr>
</tbody>
</table>

**METHOD 2 (FROM AASHTO)**

Bend losses may be estimated from the equation:

\[ H_b = K_b \frac{V^2}{2g} \]

Where \( K_b \) can be estimated from the following table:

<table>
<thead>
<tr>
<th>K - Bend Loss Coefficient</th>
<th>Degree of Turn at Bend</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.19</td>
<td>15</td>
</tr>
<tr>
<td>0.35</td>
<td>30</td>
</tr>
<tr>
<td>0.47</td>
<td>45</td>
</tr>
<tr>
<td>0.56</td>
<td>60</td>
</tr>
<tr>
<td>0.64</td>
<td>75</td>
</tr>
<tr>
<td>0.70</td>
<td>90</td>
</tr>
</tbody>
</table>

**CURVE LOSSES**

Losses for curved pipe segments may be estimated from the equation:

\[ K_b = 25 \sqrt{\frac{\phi}{90}} \]

\( \phi \) = central angle of bend in degrees

**TERMINAL INLET/JUNCTION LOSSES**

\[ H_t = K_t \left( \frac{V^2}{2g} \right) \]

\( V \) = Velocity at terminal end of junction
\( K_t \) = Loss Coefficient for terminal junction
**COMPLEX JUNCTION LOSSES**

Manhole losses in many cases comprise a significant percentage of the overall losses within a sewer system. Losses at junctions are dependent upon flow characteristics, junction geometry and relative sewer diameters.

**METHOD 1**

Losses at junctions where one or more incoming laterals occur may be estimated by combining the laws of pressure plus momentum where $H_j$ is equal to the junction losses.

\[
H_j = K_j \frac{V^2}{2g}
\]

Using the laws of pressure plus momentum, the loss $H_j$ can be estimated as follows:

\[
(H_j + D_1 - D_2) \frac{(A_1 + A_2)}{2} = \frac{Q_2^2}{A_2g} - \frac{Q_1^2}{A_1g} - \frac{Q_3^2}{A_3g} \cos \delta
\]

**METHOD 2**

Losses at junctions where one or more incoming laterals occur utilize the principle of conservation of energy, involving position energy and momentum energy. The energy content of the inflows is equal to the energy content of the outflow plus any losses due to the collision and turbulence.

\[
Q = \text{discharges} \\
V = \text{horizontal velocities} \\
K = \text{bend loss factor}
\]
GEOPAK DRAINAGE WARNING MESSAGES

PREFERENCES

**Error Opening GPK file:** The directory path for the location of the project’s geometric database (.gpk) file is not properly defined in the Drainage project preferences.

**Error Opening Drainage Library:** The directory path for the location of the project’s drainage library (.dlb) file is not properly defined in the Drainage project preferences.

**Close All Open Library Item Dialogs Before Exiting Librarian:** All edit dialogs must be saved or cancelled before exiting the drainage library dialog.

**Unable to load path data:** The directory paths for any of the project components are invalid or do not exist as defined in the Project preferences dialog.

**Unable to find shape file in preferences:** The roadway superelevation shapes (.dgn) file is not at the location specified in the Project preferences dialog.

AREAS

**No element meets the boundary level/symbology criteria:** The (.dgn) element symbology, specified as search criteria for the area definition, does not match any of the elements in the (.dgn) file.

**Area Creation Failed or Aborted - Area Must be Enclosed:** A drainage area must be closed shape element in MicroStation.

**No Boundary Elements Selected:** A boundary or borderline MicroStation elements to define a drainage area were not selected.

**Sum of Subareas = ## Exceeds Total Drainage Area = ## Do You wish to Reset Total:** The sum of the subareas entered in the Area>Subareas option exceeds the total area defined in the Area>Definition dialog. GEOPAK will adjust the total area as the total sum of the subareas.

NODE

**Error Retrieving Cell:** The MicroStation cell library containing the drainage node cells is not attached to the (.dgn) file, it is not found or it is not specified in MS_Celllist variable.

**NO element identified:** User has not selected/identified the MicroStation element where the drainage node is going to take as a reference for placement while using the Tangent to Element or Tangent on Element option in the Node>location dialog.

**Unable to determine PGL Elevation:** The station where the node is placed does not exist along the profile specified as a reference.

**Unable to compute TIN Elevation:** The node is placed outside the boundary of the TIN file specified or the TIN file does not exist.

**Error Finding D&C Manager:** The D&C Manager ddb file is not found at the location specified in the Project Preferences.

**Error Computing Inlets Calculations for Network:** GEOPAK Drainage was not able to compute any hydraulics for the specified inlet. No flow is getting to the inlet. This could be caused by a wrong spread criteria definition in which the first slope of the spread criteria cross section is diverting the flow out of the inlet (negative slope) or the user has not defined a drainage area or discharge into the node.

**Error Opening ACBOOK:** The D&C Manager ddb file is not found at the location specified in the Project Preferences.
Error Accessing TIN or Model: The TIN file or Site Model (.gsf) file do not exist at the directory path specified in the Project Preferences.

Error in Inlet By Pass Designations - Loop Detected: User is bypassing flow into the same node.

Error using shapes: GEOPAK was unable to extract information from the roadway super-elevation shapes defined in the Project preferences. This could be caused by wrong definitions inside the shapes (chain and profile), the shape (.dgn) file does not exist in the path specified in the Project preferences or there are not shapes defined at the node location.

LINK

Link placement ERROR: Link was not placed and stored in the drainage database (.gdf) file. This could be caused by a wrong definition (from and to node are the same) or a MicroStation element to define the link is not selected.

Cannot Hold the Slope and From and To Node Elevations: User can not specify hold values for the inverts and slope of the link/pipes at the same time. User should specify the inverts and let the slope to be calculated by the software.

Cannot Hold From Node Soffit and Invert Elevations: User can not specify values for the soffit and invert elevations in the same FROM node. User should specify either one of them and let the software calculate the remaining elevation with the link rise or pipe diameter.

Cannot Hold To Node Soffit and Invert Elevations: User can not specify values for the soffit and invert elevations in the same TO node. User should specify either one of them and let the software calculate the remaining elevation with the link rise or pipe diameter.

Cannot Hold More than Two Conditions: User can not specify hold values for the inverts and slope of the link/pipes at the same time.

Rise Exceeds Maximum allowed by Profile Envelope: The selected or designed link for the segment is encroaching in the profile envelope defined by the elevations and minimum depths of the connected nodes.

Downstream HGL sufficient for Hydraulic Jump: GEOPAK Drainage does not calculate the exact location of a hydraulic jump but it can warn the user of its possible occurrence.

Minimum Slope used for Positive Drainage: Link slopes were adjusted to the minimum specified slope in order to assure gravity/positive flow. Adverse slope pipes are not allowed.

Min Depth Exceeded at Upstream or Downstream of Link: Link rise is encroaching the limits defined by the node elevation minus the minimum depth.

NETWORK

Error Building Network: An invalid network has been defined. Multiple outlet nodes or “loop” connections are not allowed.

Network Calculations Containing Profile are not up to date, Please Perform Network Calculations: Shown results may not be up to date since possible edit operations have occurred in the network.

An Active Network must be selected: The Drainage > Network > Active Network has not been selected in the project. Some reporting options required this definition at the user request.

Network Computations are not up to date show results anyway?: Shown results may not be up to date since possible edit operations have occurred in the network.

Network Calculations involving link are not up to date, Please perform Network Computations: Shown results may not be up to date since possible edit operations have occurred in the network.

Errors Preclude Computations: GEOPAK Drainage was unable to calculate the network system. This could be caused by some zero values in the node or link definitions (no flow into the nodes, minimum velocities equal to zero) or no drainage areas defined for inlets.
HGL Blowout at upstream end: The HGL is encroaching the limits defined by the node elevation minus the minimum freeboard value (defined in the Project Preferences).

Commingling Runoff Methods not supported: GEOPAK Drainage can compute a network either using the Rational or SCS method for the drainage areas definitions.

Error Building Network - More than One Outlet found: An invalid network has been defined. Multiple outlet nodes are not supported.

Error Building Network - Loop or Multiple Downstream Links: An invalid network has been defined. Loop or closed circuits connections are not supported.

Error Building Network - More than five Incoming Links for Node: GEOPAK Drainage does not allow more than five link/pipes connections in a node.

PROFILES

Unsuccessfully projecting to chain __ from link __: The chain extends/limits does not include the link location.

Error Accessing TIN or Model: The TIN does not exist at the directory path specified in the Project Preferences.

Drainage Profile __ contains Node __: The Drainage Profile dialog must be closed to edit this node. The Drainage Profile dialog must be closed before editing a node that is part of the active profile.

Drainage Profile __ contains Link __: The Drainage Profile dialog must be closed to edit this link. The Drainage Profile dialog must be closed before editing a link that is part of the active profile.

NAVIGATOR

No Queries Available for Selected Type: There are no query options for the drainage element type selected.

No Elements Meeting Query were found: A specific query has returned no results.

RENUMBERING NODES

Some Nodes get labeled as “Scratch-##”: A wrong renumbering definition has caused some nodes to be assigned an ID as “Scratch” nodes. Refer to your backup version of the project and correct the renumbering setup.

REPORTS

Runtime errors while running Macro…: The (.vba) version accessed does not work with the installed MicroStation and GEOPAK version. Security restrictions in your operating system or network prevent you for running a macro function.
GEOPAK REPORT BUILDER VARIABLES

AREA

Area - ID: Drainage area name/identification stored in the drainage database (.gdf) file
Area - Description: Drainage area user provided description.
Area - Time of Concentration: User provided or calculated time of concentration.
Area - Tc Used: Time of concentration used in the calculation for the drainage area discharge.
Area - Discharge: Computed discharge for the drainage area.
Area - Intensity: Intensity rainfall used as computed from the time of concentration and rainfall library.
Area - Composite C Value: Calculated composite C coefficient for the Rational Method.
Area - Composite Area: Calculated composite area value for the Rational Method.
Area - Total Subarea C Value: Calculated composite C value for only the delineated subareas.
Area - Total Subarea: Sum of the delineated subareas only.
Area - Remainder C Value: C coefficient of the area not included into the delineated subareas.
Area - Remainder Area: Calculated value equal to Total Drainage Area minus the Total Subareas.
Area - Subarea 1…20 Area: Area value of the 1..20 delineated subarea.
Area - Subarea 1…20 C Value: C coefficient of the 1..20 delineated subarea.
Area - Subarea 1…20 Description: Description of the 1..20 delineated subarea.

NODE

Node - ID: Drainage node name/identification stored in the drainage database (.gdf) file
Node - Description: Drainage node user provided description.
Node - Type: Node type as defined in the drainage library. E.g. curb, grate, junction, other, curb-grate, headwall.
Node - Library Item Name: Node name as it is stored in the drainage library.
Node - Library Item Description: Node description as it is stored in the drainage library.
Node - Reference Chain: GEOPAK chain used to locate the node by station.
Node - Reference PGL: GEOPAK profile used to compute the elevation and longitudinal slope for the node.
Node - Reference TIN: GEOPAK DTM file used to compute the elevation of the node.
Node - Station: Station value computed at the node location using the Node - Reference Chain.
Node - Offset: Offset or distance value computed from the Node - Reference Chain to the node location.
A negative value will indicate the left side of the chain.
Node - Location X Node/ Node - Location Y Node: Coordinate location of the drainage node.
Node – Rotation Node: Angle value in which the node is rotated.
Node - Cumulative Tc: Accumulated time of concentration at the node location.
Node - Supplied Discharge: Applied flow into the node. A discharge is entered directly without a drainage area definition.
Node - Cumulative Supplied Q: Accumulated directly-entered discharge in the node.
Node – Freeboard: Distance computed as node elevation minus HGL elevation.
Node - **Cumulative Discharge**: Accumulated discharge/flow in the node.

Node - **Cumulative Area**: Accumulated drainage area in the node.

Node - **Cumulative C Value**: Accumulated C coefficient in the node.

Node - **Cumulative Intensity**: Accumulated intensity in the node.

Node - **Hyd Center X** / **Node - Hyd Center Y**: Coordinate location of the node hydraulic center.

Node - **Elev Point X** / **Node - Elev Point Y**: Coordinate location of the node elevation point.

Node - **Origin X** / **Node - Origin Y**: Coordinate location of the node cell origin.

Node - **Minimum Depth** / **Node - Maximum Depth**: Distance measured from the node elevation point. These distances paired with the next connected node creates an envelope in which the links can be placed.

Node - **Depth**: Distance computed from the node elevation point minus the node bottom elevation.

Node - **Minimum Invert Elevation**: Minimum invert elevation computed from the links arriving or leaving the node.

Node - **Maximum Rise In**: Maximum link size arriving into the node.

Node - **Maximum Rise Out**: Maximum link size leaving the node.

Node - **Minimum Invert In** / **Node - Minimum Invert Out**: Minimum invert elevation of the links arriving or leaving the node.

Node - **Bottom Name**: Name as stored in the drainage library of the bottom structure attached to the node.

Node - **Bottom Description**: Description as stored in the drainage library of the bottom structure attached to the node.

Node - **Pay Item**: D&C Manager item ID attached to the node.

Node - **Bottom X** / **Node - Bottom Y**: Coordinate location of the bottom structure attached to the node.

Node - **Bottom Station**: Station value computed at the bottom of the structure attached to the node using the **Node - Reference Chain**.

Node - **Bottom Offset**: Offset or distance value computed from the **Node - Reference Chain** to the bottom of the structure attached to the node. A negative value will indicate the left side of the chain.

Node - **Bottom Elevation**: Elevation of the bottom of the structure attached to the node.

Node - **Sump Depth**: Extra depth specified by the user added after computing the node bottom elevation.

Node - **Is Link Base Flow**: Returns a value of -1 if a Base Flow (offsite drainage discharge) option is added to the node.

Node - **Link Base Flow Type**: Returns a value of 1 if the Base flow (offsite drainage discharge) is entered as a numeric value. Returns 0 if the Base Flow discharge is entered as a predefined drainage area.

Node - **Link Base Flow Area**: Returns the name or ID of the drainage area entered as Base Flow. Returns N/A if not.

Node - **Link Base Flow Discharge**: Returns the numeric value entered as Base Flow discharge. Returns N/A if not.
Inlet - ID: Drainage inlet name/identification stored in the drainage database (gdf file).

Inlet – Description: Drainage inlet user provided description.

Inlet - By Pass Node ID: Node name in which by pass flow is directed from the present inlet.

Inlet – Type: Inlet type as defined in the drainage library. E.g. curb, grate, curb-grate.

Inlet - Profile Type: Inlet placement profile condition. Either On Grade or Sag.

Inlet – Discharge: Inlet computed discharge from the drainage area or supplied discharge.

Inlet – Capacity: Capacity of the inlet based on their physical properties and placement conditions.

Inlet - Max ByPass: Maximum by pass flow/discharge assigned to the inlet as a query value. It is not used for design purposes.

Inlet - By Pass Flow: Computed flow that the present inlet will bypass due to lack of capacity.

Inlet - By Pass Flow Into: Inlet name in which by pass flow is directed from the present inlet.

Inlet - Curb Length: Curb length as defined in the drainage library.

Inlet - Curb Depression: Curb Depression as defined in the drainage library.

Inlet - Curb Height: Curb Height as defined in the drainage library.

Inlet - Curb Depression Width: Curb Depression Width as defined in the drainage library.

Inlet - Slot Length: Slot Length as defined in the drainage library.

Inlet - Slot Width: Slot Width as defined in the drainage library.

Inlet - Grate Type: Grate Type as defined in the drainage library.

Inlet - Grate Length: Grate Length as defined in the drainage library.

Inlet - Grate Width: Grate Width as defined in the drainage library.

Inlet - Grate Area: Grate Area as defined in the drainage library.

Inlet Grate Perimeter: Grate Perimeter as defined in the drainage library.

Inlet - Grate Clog Area: Grate Clog Area as defined in the drainage library.

Inlet - Grate Clog Per Inlet: Grate Clog Per Inlet as defined in the drainage library.

Inlet - Max Ponded Depth: Maximum allowed spread depth. This is used a query value and not for design purposes.

Inlet - Max Ponded Width: Maximum allowed spread width. This is used a query value and not for design purposes.

Inlet - Longitudinal Slope: Slope along the direction of stationing defined by the user or a GEOPAK profile.

Inlet - Computed Ponded Width: Computed spread width.

Inlet - Computed Ponded Depth: Computed spread depth.

Inlet - Right Spread Intercept: Computed spread width at the right side of the inlet.

Inlet - Left Spread Intercept: Computed spread width at the left side of the inlet.

Inlet - Length Required: Computed inlet required in order to handle all the discharge.

Inlet - Spread N: Manning’s coefficient for the spread section.

Inlet - Composite Spread Slope: Composite slope across the inlet.

Inlet - Inlet to Gutter Offset: Distance applied when the inlet is set at a certain offset of the section considered for computing spread width and depth.
Inlet - Spread Slope 1…5: Slope of the different segments of the Spread Criteria cross section. Section 1 is the closest to the inlet.

Inlet - Spread Width 1…5: Width of the different segments of the Spread Criteria cross section. Section 1 is the closest to the inlet.

**LINKS**

**Link - ID**: Drainage link name/identification stored in the drainage database (gdf file).

**Link - Description**: Drainage link user provided description.

**Link - Type**: Link type. Either pipe or ditch.

**Link - Upstream Node**: Upstream node ID of the connecting link.

**Link - Downstream Node**: Downstream node ID of the connecting link.

**Link - Shape**: Link shape as defined in the drainage library. E.g. Arch, box, circular, ellipse or pipe arch.

**Link - Material**: Link material as defined in the drainage library. E.g. aluminum, concrete, plastic, or steel.

**Link - Corr – Type**: Link corrugation or type as defined in the drainage library. E.g. Standards, low profile, high profile, horizontal, or vertical.

**Link - Library Item**: Link name as it is stored in the drainage library.

**Link - Number of Barrels**: Number of parallel pipes going from one node to another.

**Link - Actual Length**: Link length measured from the graphical ends of the element.

**Link - Hydraulic Length**: Link length measured from hydraulic center to hydraulic center of each node.

**Link - Manning's N Value**: Manning’s coefficient of the link.

**Link – Slope**: Link slope in percentage.

**Link – Rise**: Link rise in feet or meters.

**Link – Span**: Link span in feet or meters.

**Link – Discharge**: Link discharge/flow.

**Link - Uniform Depth**: Flow uniform depth at the link.

**Link - Uniform Velocity**: Uniform velocity computed at the link.

**Link - Critical Depth**: Critical depth computed at the link.

**Link - Critical Velocity**: Critical Velocity computed at the link.

**Link - Friction Slope**: Friction slope computed at the link.

**Link - Critical Slope**: Computed slope caused by critical flow at the link.

**Link - Actual Depth Downstream**: Downstream runoff depth at the link.

**Link - Actual Depth Upstream**: Upstream runoff depth at the link.

**Link – Capacity**: Link capacity under the present physical conditions.

**Link - HGL Downstream/ Link - HGL Upstream**: Hydraulic grade elevation at the link ends.

**Link - EGL Downstream/ Link - EGL Upstream**: Energy grade line elevation at the link ends.

**Link - Upstream Junction Loss**: Junction loss value at the upper portion of the link.

**Link - Soffit Upstream /Link - Soffit Downstream**: Soffit or crown elevation at the link ends.

**Link - Invert Upstream/Link - Invert Downstream**: Invert elevation at the link ends.

**Link - Minimum Rise**: Minimum link rise used for design purposes.
**Link - Maximum Rise:** Maximum link rise used for design purposes.

**Link - Minimum Slope/Link - Maximum Slope:** Minimum/maximum slope at which links would be placed.

**Link - Minimum Velocity/Link - Maximum Velocity:** Minimum/maximum velocity at which links are placed.

**Link - Design Size:** Return a Yes/No value if GEOPAK Drainage will design the size of the links.

**Link - Design Barrels:** Return a Yes/No value if GEOPAK Drainage will consider parallel links from node to node.

**Link - Actual Velocity Downstream/Link - Actual Velocity Upstream:** Velocities computed at the link ends.

**Link - Pay Item:** ID of the D&C Manager item associated with the link as defined in the drainage library.

**Link - Library Description:** Link description as it is stored in the drainage library.

**Link - Iterative Velocity:** Computed velocity at the link after 10 iterations.

**Link - Full Velocity:** Computed velocity assuming that the links are flowing full. This is the velocity if the given discharge were flowing full in the pipe. GEOPAK uses the formula \( V = \frac{Q}{A} \) with \( Q \) = total flow and \( A \) is the area of the pipe full.

**Link - Upstream Freeboard:** Computed elevation from the upstream node minus the assigned freeboard to the node.
21 GENERAL INFORMATION

OBJECTIVES

The objective of this chapter is to provide general information in certain areas in GEOPAK Drainage that require special consideration while designing the Department projects.

This chapter addresses the following:

- Frequently Asked Questions
- Correcting for Inlet Offset
- Using GEOPAK Drainage to Compute Spread and Determine Inlet Elevations in Curb and Gutter Sections

FREQUENTLY ASKED QUESTIONS

➢ I received a warning “Link Discharge Capacity is exceeded”. What should I do?

Nothing. It is perfectly acceptable for the actual flow rate through the pipe to be greater than the full flow capacity of the pipe, which is what this warning indicates. The Department requires the HGL to be one foot below the inlet elevation if minor losses are not considered or no greater than the inlet elevation if minor losses are considered. This is what should be evaluated to determine if the storm drain design is acceptable.

➢ When defining the spread section, should I start from the gutter or the PGL?

The spread section is defined by starting at the inlet location (typically the gutter) and then working away from the gutter. Slopes are positive if flow towards the inlet.

➢ Do I have to define the spread section out to the PGL?

The spread section can be used for two purposes – 1) to provide the cross slopes and widths necessary to perform spread computations and 2) to compute the inlet elevation based on the PGL. If you are using it for the second purpose, then yes, the spread section needs to be defined from the inlet location to exactly the PGL. If another method besides “PGL + Spread Section” is used to input the inlet elevation, then the spread section can be defined to anywhere past the calculated spread width.

➢ My inlet is located on the PGL how do I define the spread section? My inlet is located only 1.5 feet away from the PGL?

For this situation in which the inlet is located on the PGL, which is common in super elevated sections, use “Reference PGL” as the inlet elevation and define the spread section from the inlet out to a point past the calculated spread width. For a situation where the distance to the PGL is less than the calculated spread width, it is recommended to use “User Supplied” for the inlet elevation and define the spread section from the inlet out to a point past the calculated spread width.
What should I input into “Offset from Gutter to Inlet”?

Most likely, there is nothing to input. This option should not be used for standard the Department’s applications. It could be used, if an inlet is not located adjacent to the gutter and, therefore, flow could bypass the inlet between the gutter and the inlet.

The inlet bypass in GEOPAK Drainage does not match the charts in the FDOT Storm Drain Handbook. Can I use the GEOPAK Drainage values?

Yes, GEOPAK Drainage uses equations from Hydraulic Engineering Circular 12 (HEC-12). Either HEC-12 methodology or the charts in the Storm Drain Handbook are acceptable means of determining inlet capacity for the Department’s projects.

What should I input for allowable spread depth?

The Department’s spread requirements are based on width. The allowable spread depth could be input as the depth that corresponds to the allowable width or any higher value. Please note that both the allowable spread depth and width are for informational purposes only and do not affect the spread computations.

What should I input for the Node Elevation for an outlet node?

It is recommended to input the Node Elevation for an outlet node at least one foot higher than the Tailwater elevation. This elevation is not used in the hydraulic calculations and does not represent a physical point on the outlet node. But setting it at least a foot higher than the Tailwater will prevent a “HGL Blowout” warning message.

Should I ignore the gutter slope for spread computations?

Based on the FDOT Storm Drain Handbook, it is the designer’s option to include the gutter slope or ignore it. If the gutter slope is included in the spread section, a Constant Offset of 0.125’ (the depth of the gutter) should be input for Node Elevation Option so that the inlet elevation will be at the edge of pavement.

If there is bypass to a sag inlet, how do I define which side of the sag inlet the bypass should be assigned to?

Currently, there is no direct way to assign the bypass to a side. The bypass flow will be split based on the % Discharge Left and % Discharge Right. The % discharges can be adjusted to account for the bypass flow using the method described in the FDOT GEOPAK Drainage Class materials.

Is Minimum Depth measured to the invert or the crown?

Minimum Depth is measured to the crown (or soffit). Maximum depth is measured to the invert (or flow line). Please note that the recommended depths in the Tables 4-4 and 4-5 in the FDOT Storm Drain Handbook are measured to the invert; therefore, these values should be adjusted accordingly before using as the Minimum Depth in the software.

How do I know if the Constant Offset value should + or -?

If the desired Node Elevation is higher than the elevation determined by the Elevation Source, then the Constant Offset should be a positive value and vice versa. For example, if the Elevation Source provides the elevation of the gutter and the edge of pavement is the desired Node Elevation, then the constant offset should be entered as a positive value equal to the depth of the gutter.
➢ *I allowed GEOPAK Drainage to “design” the pipe sizes, but the warnings show “HGL blowouts”?*

The software chooses pipe sizes based on the full flow capacity of the pipe. It does not evaluate the HGL elevations and upsize or downsize the pipe accordingly. If the network has a high Tailwater, some pipes might be undersized by the software. If the network has a low Tailwater, some of the pipes might be oversized by the software. Therefore, the “designed” pipe sizes should only be considered a good first pass at designing the system. Optimizing pipe sizes is the responsibility of the designer, not the software.

➢ *I locked all the flow lines, but they still changed when GEOPAK Drainage designed the network?*

GEOPAK Drainage cannot accommodate adverse slopes (the lower end flow line higher than the upper end flow line) or a jump up in elevation from the upstream side of a structure to the downstream side. If the locked flow lines result in one of these conditions, the software will adjust flow lines to “fix” the problem. These conditions can be caused unintentionally by user input error. It is recommended that you reset the elevations as desired and run the network again. If you are certain that the input is correct and the problem persists, report the problem to GEOPAK and the Production Support Office | CADD.

➢ *What inlet elevation should I use for a median barrier inlet which has a different elevation on each side?*

It is recommended to input the lower elevation since it will be the most critical for comparing to the HGL elevation. The criteria files for drawing the structure in cross section currently do not account for two inlet elevations; therefore, the structure section will need to be modified.

➢ *When I try to design the network, I get an error about the node definition. It looks like the definition is complete. What is causing this?*

One possible cause is the spread section is not defined. For the software to design the network, a spread section must be defined for every node, even if it is not used to compute spread or determine the node elevation.

**CORRECTING FOR INLET OFFSET**

GEOPAK Drainage uses the Node Location Point as the reference point for station and offset location. For curb and gutter inlets, this point is the edge of pavement. Unfortunately, the Department’s standard indexes refer to other places on the inlet as the location reference.

Until the software is revised, the user will need to correct the offsets of curb and gutter inlets in the storm drain tabulations and in the drainage structure cross sections.

The correction distance for several inlets is noted below.

- Type 1-4 inlets: 5.5’ out from EOP
- Type 5-6 inlets: 1.3’ out from EOP
USING GEOPAK DRAINAGE FOR SPREAD AND INLET ELEVATIONS

One would like to have GEOPAK compute Spread and determine Inlet Elevations in curb and gutter sections to the fullest extent possible, regardless of the project conditions. Some of the project conditions that affect inlet elevations and spread are superelevation, turn lanes, and through lane transitions. GEOPAK has different ways to handle different project conditions.

The options within GEOPAK that may affect calculations of inlet elevations and spread are listed below:

**Shape Files:** These are created by the roadway designer.
- ✓ Created to Edge of Pavement (EOP)
- ✓ Created to Less than EOP

**Extend Shapes to Inlet:** This option is in Preferences> Inlet Options. This affects the entire project because it is in Preferences.
- ✓ Yes (activate toggle) if shapes are not created to the EOP.
- ✓ No

**Longitudinal Slope Source:** This option is in Node Configuration> Spread Criteria.
- ✓ User Supplied
- ✓ Reference PGL
- ✓ Shape

**Spread Source:** This option is in Node Configuration> Spread Criteria. This refers to the cross section of the spread area.
- ✓ User Supplied
- ✓ Library Item
- ✓ Shape
- ✓ Shape + Library Item (this option is not applicable if the shapes are extended to the Inlet

**Elevation Source:** This option is in Node Configuration> Elevations.
- ✓ Reference PGL
- ✓ PGL+Spread

**Node Elevation Option:** This option is in Node Configuration> Elevations.
- ✓ Source
- ✓ Constant Offset
- ✓ User Supplied

Of the six items, the drainage designer has little control over how the shape files are created. Roadway designers typically do not create shapes to the EOP, so the following discussion is based on the assumption that Shape Files represent only a portion of the pavement cross slope, i.e. they are not created to the EOP. The drainage designer should coordinate with the Roadway designer to determine how the shape file is created.

An issue in spread calculations is the gutter depression. For Type E and F Curb and Gutter this is 1.5” deep over 1.5’ wide gutter. This could be ignored by assuming that the pavement cross slope extends across the gutter or it could be modeled with a little extra effort.

The other five items in the listed above are somewhat interrelated, in that the elevation calculation is affected by the option selected for the spread source. Rather than address all the permutations of five items with two to four options each, it is better to suggest possible options based on typical inlet locations or project conditions.

The following are not meant to be the only possibilities.
INLET LOCATIONS/PROJECT CONDITIONS

ON GRADE, NO TRANSITIONS OF SUPERELEVATION, TURN LANE OR THRU LANES:

- **Arrangement A**

<table>
<thead>
<tr>
<th>Item</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend Shapes to Inlet</td>
<td>No</td>
</tr>
<tr>
<td>Longitudinal Slope Source</td>
<td>Reference PGL</td>
</tr>
<tr>
<td>Spread Source</td>
<td>User Supplied: Create a cross section from the face of the curb to the location of the PGL. This cross section could account for the gutter depression or the depression could be ignored.</td>
</tr>
<tr>
<td>Elevation Source</td>
<td>PGL+Spread</td>
</tr>
<tr>
<td>Node Elevation Option</td>
<td>Constant Offset: The offset is the difference between the spread source elevation at the face of the curb and the EOP elevation.</td>
</tr>
</tbody>
</table>

- **Arrangement B**

<table>
<thead>
<tr>
<th>Item</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend Shapes to Inlet</td>
<td>Yes</td>
</tr>
<tr>
<td>Longitudinal Slope Source</td>
<td>Reference PGL</td>
</tr>
<tr>
<td>Spread Source</td>
<td>Shape: This may be reasonable if the shapes start at the PGL. Realize that Extending Shapes to Inlet extends the shape only to the edge of pavement. Using the approach of extending the shapes and using the shapes for the spread cross section, creates a theoretical section that is shifted from the actual spread section by the width of the gutter. This is acceptable because the calculated spread width is the same regardless of the shift. Gutter depression cannot be modeled with this approach.</td>
</tr>
<tr>
<td>Elevation Source</td>
<td>PGL+Spread</td>
</tr>
<tr>
<td>Node Elevation Option</td>
<td>Source</td>
</tr>
</tbody>
</table>

ON GRADE, SUPERELEVATION TRANSITIONS, TURN LANE TRANSITIONS, THRU LANE TRANSITIONS:

Arrangements A and B will work except for the longitudinal slope source item. For most of these situations, the longitudinal slope source will need to be User Supplied. If the shape files are created to the EOP, using Shape as the longitudinal slope source will track the slope along the gutter.