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CONNECT Edition (10.01.00.xx)
 This PDF file includes bookmarks providing an overview of the document. Click on the bookmark to quickly 

jump to any section in the file.

 The dataset uses Imperial units.

 This training uses an Example workspace delivered with the software. It is important that you select the 
appropriate workspace and workset when working the exercises in this course.

 The terms Left-click, Click, Select and Data Point are used interchangeably to represent pressing the left 
mouse button. The terms Right-click and Reset are also used interchangeably. If your mouse buttons are 
assigned differently, such as for left-handed use, you will need to adjust accordingly.

Have a Question? Need Help?

If you have questions while taking this course, submit them to the Civil Design Forum on Bentley 
Communities where peers and Bentley subject matter experts are available to help.

http://learn.bentley.com
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Exercise 1: Overview and Settings

Description
gINT Civil tools is a power product (standalone application based on the MicroStation platform) that will be delivered with gINT. It allows gINT 
users to load gINT data in 2d models (mapping workflow for drilling plan creation and preliminary studies) as well as in 3d for subsurface 
interpretation and BIM workflows.

The data files for this course are included in a zip file that can be downloaded from the Bentley LEARNserver. We recommend you unzip the 
files to the c:\Bentley Training\ folder but it can be stored to a different location if you choose.

In this module you will review the gINT Civil Tools interface and settings.

Skills Taught
 Become familiar with user interface

 Become familiar with backstage settings



Start gINT Civil Tools and Select Workspace

1. Start the gINT Civil Tools or OpenRoads Designer software.

Note: The Startup Screen appears where example videos, learning courses, news, and announcements appear.

2. Click the Start a Work Session arrow on the right side of the screen.
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3. Set the Workspace and Workset.

This workshop requires the Example WorkSpace and Geotechnical WorkSet installed with the gINT Civil Tools or OpenRoads Designer 
software. The workspace and workset define standards that are used by the gINT tools.

It is very important that a proper WorkSpace and WorkSet are selected for the software to operate properly. 

Setting up WorkSpaces and WorkSets are beyond the scope of this course but there are other courses that cover this topic.

a. Select Example (if using the gINT Civil Tools software) or Training and Examples (if using the OpenRoads Designer software) from 
the WorkSpace menu.

b. Select Geotechnical from the WorkSet menu.
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4. Open a 3D dgn file that will be used to display the geotechnical data.

a. Select Browse.

b. Browse to c:\Bentley Training\QuickStart using gINT Civil Tools or other folder where you unzipped the dataset files. This is the folder 
where the new dgn file will be stored.

c. Select the file named QuickStart using gINT Civil Tools and select Open.
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Review the Interface

The user interface has multiple workflows (ribbons), the Drawing workflow hosts the CAD drawing (MicroStation) tools, and the Geotechnical 
workflow hosts the gINT tools.

1. Activate the Geotechnical workflow from the pick list in 
the upper left corner if it is not already active.

The ribbon menu changes to Geotechnical tools organized into familiar categories called ribbon tabs.

 Home - Common tools such as attributes, Explorer, references, models, element selection, and fences.

 gINT Projects - Tools to connect to gINT projects and load data.

 Site Map - Tools for the 2d mapping workflows (preliminary study, drilling plan creation) 

 3D Modeling - Tools for creating 3d modeling (subsurface, section views.)

 Mesh - Tools for creating mesh surfaces
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2. Searching the ribbon.

When you are not sure where to find a tool on the ribbon interface the Search Ribbon field in the upper right corner is your best friend.

a. Type Database in the search field.

The matches found in the ribbon menus appear. The search is across all ribbon 
menus, not just the currently active ribbon.

b. Hover over Database Connectivity.

The search results expand showing where this tool is located on the ribbon.

c. Select Database Connectivity to start that tool.

Notice that the Database Connectivity and Mapping tool started but the ribbon 
menu did not change.

d. Close the Database Connectivity and Mapping window.

e. Type Database in the search field again.

f. Hover over Database Connectivity to expand the search options.

g. Select Geotechnical → gINT Projects → Connectivity.

The ribbon changes to the selected menu which contains the Database Connectivity tool.

3. Introduction to the Backstage.

a. Activate the Back Stage View by clicking File in the ribbon menu.

b. Select Settings.

Design File settings, preferences, customizations, etc. are found in the Backstage, keeping the ribbon menus focused on the tools.

c. Select User > AccuDraw Settings.

d. Disable the Auto Load option.

e. Click the Arrow in the upper left corner to return to the design canvas.

4. Close AccuDraw if it is currently open.
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Exercise 2: Database Connectivity and Mapping

Description
In this exercise you will learn to connect to a gINT database and define how those fields and properties are mapped to the borehole graphic 
elements.

Skills Taught
 Connect to gINT database

 Define how borehole cells will appear in 2D view

 Define which properties from the gINT database are stored on the borehole graphics
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Database Connectivity and Mapping window

The Database Connectivity and Mapping window is the starting point of the product. It is used to connect to a gINT project and to define the 
mapping between the gINT Civil Tools data model and gINT project data. This is necessary because the gINT project data is flexible and it can 
be different for each organization. 

There are two tabs in this window.

The Project tab defines the type, either 
a Microsoft Access based (.gpj) file, 
Microsoft Excel, or a SQL Server 
database, and path to a gINT project. 
Once a connection is made, it is stored 
in the design file and can be reused 
next time the DGN file is opened. 
Once saved, it can also be loaded in 
other files.

The Borehole tab defines the point 
table name and the different columns 
for the points. Optionally definitions 
such as the following can also be 
defined.

 an orientation and a plunge 
(even with curved boreholes) 

 a set of additional properties 
that will be loaded with each 
point

 a custom cell (symbol) for the 
2d symbolization, or property 
based symbolization (cell 
based on point's properties)
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Loading a gINT Project

1. Load the project database.

a. Activate the Geotechnical workflow from the pick list in the upper left corner if it is not already active.

b. Select gINT Projects > Connectivity > Database 
Connectivity.

c. Select the Project tab.

d. Set the Database Type to gINT .gpj Project.

e. Set the Source > File to gINT 
SampleDataset_Update1.gpj file from the c:\Bentley 
Training\QuickStart Using gINT Civil Tools\ folder or other 
location where the workshop files are installed.

f. Select the Borehole tab.

g. Review the mappings defined in the Location section. 

The software automatically maps these fields to fields in 
the loaded project as best it can. In this situation the 
mappings are correct and no adjustments are needed. 
However, if the project used different field names it might 
be necessary to define proper mappings.
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2. Define how point tables and columns are named.

a. Select the Project tab.

b. Disable the Show gINT table/column Captions option.

c. Select the Borehole tab

d. Notice that the names in the Location section changed.

gINT tables and columns can be captioned to display 
recognizable, user-friendly names instead of the actual 
table names. For example, in gINT Workshop.gpj, the 
actual table name is POINT, but the caption name for the Location Table is Borehole. When the Show gINT table/column Captions 
option is enabled, the caption names will appear. When disabled, the database names will appear.
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3. Define how boreholes are displayed.

a. Select the Borehole Representation field in the Data Type Representation section.

b. Set the Cell Name to PointType03.

Hint: Typing a letter in a list often advances the list to that letter. Here, you could type P rather than scroll.

A cell is a graphic or dgn drawing that is frequently reused such as a borehole symbol.

c. Set the Cell Width to 50.

d. Click OK to close the cell properties window.

NOTE: The actual size of the borehole cell in the graphics is equal to the cell width multiplied by the Annotation Scale Factor. For 
example, if the Annotation Scale Factor is set to 1:1, the cells will be 50 feet or meters wide. However, if the Annotation Scale Factor is 
set to 1”:100’, the cells will be 60,000 feet wide (50’ wide * 100 (scale factor) * 12 (inch to foot adjustment of scale factor). The 
Annotation Scale factor is not used in this QuickStart course but can be found by activating the Drawing workflow and selecting the 
Utilities tab.

4. Click OK to close the Database Connectivity and Mapping window.
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Display the Points in the DGN file

1. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the projects.

2. Click Retrieve to display the points in the DGN file.

3. Select Fit View.

The points are loaded and displayed as 2d cells.

4. Review the level where the borehole cells are displayed.

a. Select Home > Primary > Level Display.

The level named Boreholes was created when the points were loaded.

b. Close the Level Display window.

5. Review the borehole properties.

a. Select Home > Selection > Element Selection.

b. Data point (left click) on any borehole graphic (cell) to select it.

c. Reset (right click) and pause until the popup menu appears and select Properties 

NOTE: A “quick” right-click will clear the selection. A “long” right-click will open the popup menu. 

Holding the cursor over a selected graphic (“clicking-and-hovering”) will show a Context Menu. 

d. OR select Home > Primary > Properties from the ribbon menu.

e. Review the properties in the Borehole section.

f. Close the Properties dialog.

NOTE: The Context Menu (by clicking-and-hovering) provides a quick view of  
the properties at the cursor.
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6. Annotate the Boreholes

a. Select gINT Projects > Connectivity > Annotate Boreholes.

b. Select PointID for the Property.

c. Enable the Use all Boreholes check box.

d. Enable the View Independent check box.

e. Enable the Display Property Name as Labels check box.

f. Data point to annotate the points.

The according Point IDs will now be displayed with each 
borehole. The View Independent option insures the 
annotation stays upright even when the view is rotated.

HINT: A shaded box may appear behind the annotation text. This box is a visual indicator of a text field. The display of this box can be 
turned off by selecting File > Settings > User > Preferences. In the Preferences dialog select the Text category and then enable the Hide 
Field Background option.
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7. Editing the text style

Once the annotations are created, you can edit how they display using the Text Style tools.

a. Type Text Styles in the Search Ribbon field and press Enter.

b. Select the BoreholeTextStyle from the list on the left.

c. Set the Height and Width to 10.

d. Save to apply the changes.
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Adding Additional Borehole Properties

Additional properties can be added to the bore hole cells.

1. Add additional properties to the borehole.

a. Select gINT Projects > Connectivity > Database 
Connectivity.

b. Select the Borehole tab.

c. Scroll to the Other Properties section.

d. Click the Down Arrow in the Properties field.

e. Set the Table to POINT (or Borehole if captions are 
enabled).

f. Click Add all properties from selected table to add 
all the properties from the selected table (POINT).

g. Click OK to accept the property selections.

h. Click OK to close the Database Connectivity and 
Mapping window.



Copyright © 2018 Bentley Systems, Incorporated 17DO NOT DISTRIBUTE - Printing for student use is permitted

2. Update the borehole cells.

a. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the projects.

b. Click Retrieve to display the points in the DGN file.
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3. Add a symbolization rule to display borehole based on a property.

a. Select gINT Projects > Connectivity > Database Connectivity.

b. Select the Borehole tab.

c. Click Add a Rule by clicking the Blue + icon in the Symbology section near the bottom of the dialog.

Note: There are two Blue + icons on this dialog. The + icon at the top of the dialog is for adding a new table mapping. We will learn to 
use this later in the course.

d. Set the following settings for the new rule that will display the borehole different if the PointID property starts with “A”.

 Property =PointID

 Comparator = Starts_With

 Value = A

 Symbology = PointType01 

e. Click OK to save and close the Database Connectivity and Mapping window.

4. Update the borehole cells.

a. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the 
projects.

b. Click Retrieve to display the points in the DGN file.

Notice that the boreholes that have PointIDs that begin with A are now shown 
as solid circles.
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Connecting and Disconnecting the Database

The gINT database does not need to be connected at all times. In order to run Queries and perform other functions, the 
gINT database must be connected. You can be disconnected and and connect as needed.

1. Exit the gINT Civil Tools or OpenRoads Designer software.

2. Start the gINT Civil Tools or OpenRoads Designer software 
and open the QuickStart using gINT Civil Tools.dgn file.

3. Select gINT Projects > Connectivity > Database 
Connectivity.

4. Notice in the lower right corner that the database is currently 
Disconnected.

5. Click Cancel to close the Database Connectivity and Mapping 
dialog.

6. Select gINT Projects > Connectivity > Open to reconnect the 
database.

7. Select gINT Projects > Connectivity > Database Connectivity 
and verify in the lower right corner that the database is 
connected.

8. Click Cancel to close the Database Connectivity and Mapping 
dialog.
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Exercise 3: Attaching Imagery

Description
The gINT Civil Tools CAD environment can load many data types like raster imagery, vector data like ESRI shape files or DWG files, as well 
as on line mapping service. Adding layers of different data type will allow users to perform preliminary study, and build drilling plans. In the 
following exercise, we will add some local and remote data types.

Skills Taught
 Attach aerial imagery

 Attach terrain model
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Attach Aerial Imagery

1. Attach aerial imagery.

a. Select Site Map > Reference > Attach Reference.

Multiple raster images have already been attached to another dgn file named Imagery.dgn. We can easily attached all of those images 
in one step by referencing that dgn file. The images could also be attached directly using the Attach Raster tool.

b. Select the file Imagery.dgn as reference and click 
Open.

HINT: The Imagery.dgn file is located in c:\Bentley 
Training\QuickStart using gINT Civil Tools\ or other 
folder where you unzipped the dataset files.

c. Select the Orientation named Coincident - World.

The orientation determines how the reference is 
adjusted to line up with the gINT data.

d. Click OK.
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Attaching Terrain Model

1. Attach terrain model.

a. Select Site Map > Reference > Attach Reference.

b. Attach Terrain.dgn as reference using a Coincident - World 
attachment method.

HINT: The Terrain.dgn file is located in c:\Bentley 
Training\QuickStart using gINT Civil Tools or other folder 
where you unzipped the dataset files.

The terrain model would typically be created by the survey 
or civil team using OpenRoads Designer or one of the 
other Bentley civil applications.
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Exercise 4: Adding a New Borehole Location

Description
Borehole Locations can be added manually. In this exercise, we will add one.

Skills Taught
 Add a new borehole location
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Adding a New Borehole Location

1. Select Site Map > Borehole > New Borehole

2. Set the following values.

 Name = A-30

 Depth = 20

 Existing Ground = OG

The existing ground parameter specifies a terrain model that will be used to calculate the elevation of the borehole. In this exercise we 
are using the terrain model that was referenced in the previous exercise. That terrain model had a name of OG for Original Ground 
which is why OG appears in the Existing Ground pick list.

3. Data point (left click) on the drawing at the location of the new borehole. You can identify any location.

4. Data point a second time to accept the new borehole and add it to the database.
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Exercise 5: Loading Data in 3D

Description
gINT Civil Tools can also model boreholes, create surfaces, and create meshes in 3D. 

In gINT there are different ways to have a distance between two points: a Depth - Bottom Depth combination as found most often in the 
Lithology Table in the Standard gINT US files (as well as others). One can also have a Depth - Length configuration which is often used in the 
Sample table (and also found in the Standard gINT US files).

In this section, as mentioned, we will be adding lithology tables to the 3D model. We will also show how you can change the symbolization of 
a level, add additional properties from a table, rename item types, dynamically symbolize data, and use the Project Explorer to navigate to 
specific boreholes.

Skills Taught
 Add Lithology data to the boreholes

 Display boreholes and lithology data in 3D

 Define how boreholes and lithology data are displayed
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Open a 3D Model

The dgn file contains one or more models. Each model is an independent 2D or 3D drawing space. The current model you have been working 
with during this course is a 2D. A 3D model is needed to view 3D models of the boreholes.

1. Open a 3D Model.

a. Select Home > Primary > Models.

b. Double click on the model named 3D Model to make it active.

c. Close the Models dialog.
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Display the Points in the 3D Model 

1. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the projects.

2. Click Retrieve to display the points in the DGN file.

3. Select Fit View.

The points are loaded and displayed in the 3d model.

4. Select View Rotation and use the mouse to rotate the view such that the depth of the boreholes are visible.

5. Add hyperlink to boreholes

a. Select gINT Projects > Connectivity > Database Connectivity.

b. Select the Borehole tab.

c. Expand the Hyperlink section.

d. Set the Prefix to the c:\Bentley Training\QuickStart using gINT Civil Tools 
folder or other folder where you unzipped the dataset files.

e. Set the Variable Field to PointID.

f. Set the Suffix value to .pdf

g. Click OK.

h. Select gINT Projects > Connectivity > Query All.

i. Click Retrieve to display the points in the DGN file.

Each borehole should now have their pdf hyperlink.
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6. Annotate the Boreholes

a. Select gINT Projects > Connectivity > Annotate Boreholes.

b. Select PointID for the Property.

c. Enable the Use all Boreholes check box.

d. Enable the View Independent check box.

e. Enable the Display Property Name as Labels check box.

f. Data point to annotate the points.
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Adding Lithology Data (Depth - Bottom)

So far only the Project and Point tables have been mapped in the Connectivity and Mapping window. For 3D, additional depth information is 
also needed. In this exercise the lithology table and applicable fields will be added. 

This exercise uses the Depth - Bottom Depth data types. Specifically, we will be importing data from the Lithology table from our example gINT 
project. 

1. Select gINT Projects > Connectivity > Database Connectivity.

The Source should still be set to gINTSampleDataset_Update1.gpj. A 
prompt in the lower right shows if the database is Connected or 
Disconnected.

2. If the database is Disconnected, click the Connect to the Database 
button to connect to the database, otherwise skip to the next step.

3. Define a new Lithology table

a. Click the Plus icon next to the Borehole tab to add a table.

b. Set the Name to Lithology.

c. Set the Type to Depth - Bottom.

d. Click OK.

e. Use the drop down lists for each field to enter the following values 

 Top Depth = Depth

 Bottom Depth = Bottom

 Identifier = Graphic

f. Set Level Creation to Identifier.

g. Set Graphic Type as Cylinder and Fixed Size at 7.

4. Click OK to close the Database Connectivity and Mapping window.
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5. Display the Lithology Data.

a. Select gINT Projects > Connectivity > Query All.

b. Click Retrieve to display the points in the DGN file. 

6. View the 3D Lithology Data.

a. Zoom and Rotate the view such that the depth of the borehole cylinders are visible.

b. Select View Attributes.

c. Set the Display Style to Illustration: Ignore Lighting.

Each borehole has a center pin to represent the borehole (top, bottom), and there are cylinders around each pin. The cylinders are the 
lithology information imported in to the database. If you hover your cursor over any of the elements, a small flag with information 
appears.

7. Annotate the Lithology Data

a. Select gINT Projects > Connectivity > 
Annotate Item Types.

b. Select Lithology for the Item Type.

c. Select Graphic for the Property.

d. Enable the Use All Item Types check box.

e. Enable the View Independent check box.

f. Data point to accept.
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8. Editing the text style

Once the annotations are created, you can edit how they display using the Text Style tools.

a. Type Text Styles in the Search Ribbon field and press Enter.

b. Select the LithologyTextStyle from the list on the left.

c. Set the Justification to Left Center.

d. Adjust the Height and the Width as necessary.

e. Save to apply the changes.
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Review and Control Display of Boreholes

1. Select Home > Primary > Explorer.

2. Expand the Items section. 

You should see condensed lists for the Borehole and the Lithology tables.

3. Data point on the arrow to the left of Borehole to expand the list

4. Right click on B-1 and select Zoom to center B-1 on the screen. 

5. Right click on B-1 and select Isolate.

The display is updated to only show borehole B-1. Notice that the lithology data is no longer 
visible, just the borehole pin.

6. Right click again on B-1 and select Clear Isolate.

7. Right click on Borehole and select Details.

A table with the properties of the borehole appears. This table includes the Point table 
information that was imported into gINT Civil Tools.

8. Close the Details window.
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Exercise 6: Using Levels to Control Borehole Data Display

Description
In this exercise you will explore how levels are created when data is imported into gINT Civil Tools, and work flows you can use to gather 
information from the 3D model.

The borehole pins are created on the Borehole_Decoration level in gINT Civil Tools. Other data imported in to gINT Civil Tools is created on a 
level specific to the Identifier. This means that each item in the identifier will have its own level. For example, when the lithology graphics are 
imported there is a level for each material type. Having a unique level for each identifier creates a simple workflow for reviewing and 
evaluating data. Levels can be used to visualize spatially where materials are located or create tables with data summaries and export to 
excel.

Skills Taught
 Control display using levels

 Define colors displayed by adjusting level definitions
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Changing What Data is Displayed

1. Zoom in to a view so that 3-5 boreholes are visible.

2. Select Home > Primary > Level Display.

3. In the Level Display window right click on the level named CL.

A pop up menu appears.

4. Select Set Active. 

The level CL is now highlighted in a different color, indicating that it is active. Elements drawn will be placed on the active level.

5. Right click on any level in the Level Display window and select All Off from the pop up window. 

All levels except the active level (CL in this example) are now off meaning the elements on those levels are not displayed.

6. Right click again and select All On. 

All levels are now back on and the elements on those levels are displayed.

7. Right click again in the Level Display window and select Off By Element.

Notice the prompt in the lower left says Identify Element.

8. Click on a graphic borehole pin.

The level named Boreholes_Decoration is turned off and the borehole pins are no longer displayed.

9. Try selecting a few other items and notice the changes after each click. 

10. Right click in the Level Display window and select All On. 

All levels and elements are once again displayed. 
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Changing How Data is Displayed and Symbolized

1. Select Home > Primary > Level Manager.

The Level Manager window appears.

There are several icons and menu options. This class does not cover all of these functions. For more information on the Level Manager 
please refer to other Bentley training courses or the Bentley MicroStation Communities group.

2. Review the level definitions and notice that CL and SW levels use colors that appear very similar to each other. You can change these 
colors so differences are more apparent.

Note: Users can create a custom library so that the material settings by level are established before data import. This is a standard 
MicroStation operation and many organizations using MicroStation may have such libraries already established. For more information 
please check with your CADD manager or refer to Bentley's MicroStation Communities group. 

3. Set the CL level to a Light Yellow color.

a. Right click on CL in the Level Manager and select Properties.

b. In the Symbology ByLevel section, select Color.

c. Select the third tab and select gINT Standard Colors from the pick list.

d. Set the Color to Light Yellow.

e. Click OK to accept the color.

f. Click OK on the Level Properties window to apply and save the change.

4. Close the Level Manager.

5. Review the changes in the model.
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Exercise 7: Loading Additional Data

Description
With gINT Civil Tools, additional tables and properties can be added to the Connectivity and Mapping window at any time and saved for use 
on future projects. When properties are queried again, the original query is overwritten, and additional data added. Information already 
queried is not doubled or repeated. 

In this exercise you will change the Data Connection and Mapping query to import samples. You will also add properties after the initial sample 
query. 

Skills Taught
 Add sample data

 Add water table data

 Adjust display colors and sizes
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Adding Sample Data (Depth - Length)

1. Select gINT Projects > Connectivity > Database Connectivity.

2. Select the Lithology tab.

3. Disable the Include In Query option.

The Include in Query option, when not checked, means the item remains mapped, but the results are not included in the query. It is a 
simple way to limit a query result to specifics. For example, you can import several tables at one time. However, the lithology cylinders 
and sample cylinders will overlap so for simplicity we are querying one item at a time in this lesson

4. Define a new Sample table

a. Click the Plus button to add a table.

The Table Mapping window appears. 

b. Set the Name to Sample.

c. Set the Type to Depth - Length.

d. Click OK.

A new tab named Sample appears in the Database 
Connectivity and Mapping window.

e. Use the drop down lists for each field to enter the 
following values.

 Top Depth = Depth

 Length = Length

 Identifier = SampleType

f. Set Level Creation to Identifier.

g. Click OK to close the Database Connectivity and Mapping window.
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5. Display the Sample Data.

a. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the projects.

b. Click Retrieve to display the points in the DGN file.

6. View the Sample Data.

a. Select Home > Primary > Explorer if it is not already open.

b. Expand the Items section. 

c. Data point on the arrow to the left of Borehole to expand the list

d. Right click on A-3 and select Zoom.

e. Zoom out to expand the view so that several boreholes are visible. 

7. Review Sample Details.

a. In the Explorer window, right click on Sample and select Details.

The details window doesn't have much information about the samples, only sample type, borehole name, and depth. To get a more detail 
of what is present, we want to return to the Connectivity and Mapping window and add additional details. 

8. Close the Details window.
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Adding Additional Sample Properties

1. Select gINT Projects > Connectivity > Database 
Connectivity.

2. Select the Sample tab.

3. Add additional properties to the borehole

b. Click the Down Arrow in the Properties field.

Selecting Add all properties from selected table as we did 
in an earlier exercises adds all fields in the gINT 
database to the gINT Civil Tools query. We want to be 
more specific than that. 

c. Set the Table to SAMPLE.

d. Set the Column to Number.

e. Click the Plus icon below the Column field to add the new 
property to the query.

4. Repeat step 3 to add the following properties to the query.

 Recovery Length

 Blows 1st

 Blows 2nd

 Blows 3rd

 Blows 4th 

5. Click OK to accept the property selections.

6. Click OK to close the Database Connectivity and Mapping window.
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7. Update the borehole graphics and sample data stored on the graphic elements.

a. Select gINT Projects > Connectivity > Query All.

b. Click Retrieve to display the points in the DGN file.

8. Review the updated Sample properties.

a. Select Home > Primary > Explorer if it is not already open.

b. Right click on Sample and select Details. 

Notice the table now has the additional fields and any data in those fields for the items queried. 
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Adding Water Level Event Data (Depth only)

The last standard type of import in gINT Civil Tools is depth only elements. This can be lab results, or water, or environmental test results.

Depth only element can be displayed as spheres or discs.

1. Select gINT Projects > Connectivity > Database Connectivity.

2. Define a new Water Level table

a. Click the Plus icon next to the Sample tab to add a table.

The Table Mapping window appears. 

b. Set the Name to WaterLevelEvent.

c. Set the Type to Depth Only.

d. Click OK.

e. Use the drop down lists for each field to enter the 
following values.

 Depth = Depth

 Identifier = ItemKey (this is the name of the Reading 
Event)

f. Set Level Creation to Table Name.

g. Set Graphic as Disk and Fixed Size at 10.

h. Click OK to save and close the Database Connectivity and Mapping window.

3. Display the Sample Data.

a. Select gINT Projects > Connectivity > Query All.

The Project Boreholes window appears showing all of the points in the projects.

b. Click Retrieve to display the points in the DGN file.
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Exercise 8: 3D Modeling

Description
In this exercise you will create terrain models, meshes, cross sections, and fence diagrams.

Skills Taught
 Create water surface terrain models

 Control display of terrain models

 Create Top and Bottom Meshes from Lithology data

 Create Cross Sections

 Create a Fence Diagram
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Creating Terrain Model at Water Level

This lesson is an introduction in to the 3D modeling possible with gINT Civil Tools. In this exercise you will create a terrain model at the water 
level.

1. Create a terrain model for the Water Level data.

a. Select 3D Modeling > 3D > Create Terrain.

The Create Terrain window appears.

b. Enter the following values:

 Terrain Name = Water Level

 Type = WaterLevelEvent

 Identifier = EOD

 Existing Ground = None

 Enable the Use all Boreholes option

 Disable the Create Bottom Terrain option

The prompt in the lower left hand corner provides instructions for the next actions to create the terrain. Since the Use all Boreholes 
option is enabled, the prompt is stating “Data point to accept selection, reset to cancel command”.

c. Data point on the active model to create the terrain.

A terrain model for the water surface is created and displayed.
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Reviewing Terrain and Displaying Contours

1. Change the display of th Water Level terrain to show contours.

a. Open the Properties of the Water Level terrain model.

This can be done by selecting and a “long right-click” to get to the context menu; or by selecting with the Properties dialog open.

b. Expand the Calculated Features Display classification in the Properties window. 

c. Set the Major Contours option to On.

d. Set the Minor Contours to On.

e. Set the Triangles to Off.

Notice that the surface changes to show major and minor contours. Take some time to explore what the other drop down options do to 
the image, and the information you can obtain from them. 
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Create Mesh from Vertical Boreholes

In this exercise we will create mesh surfaces from the lithology data.

Currently the display does not include lithology because it was not included in the query when we added samples. We need to bring the 
lithology data back into the drawing before creating the surface.

1. Define what data to include in the query.

a. Select gINT Projects > Connectivity > Database Connectivity.

b. Select the Lithology tab.

c. Enable the Include In Query option.

d. Select the Sample tab.

e. Disable the Include In Query option.

f. Select the WaterLevelEvent tab.

g. Disable the Include In Query option.

h. Click OK to close the Database Connectivity window.

2. Display the Lithology Data.

a. Select gINT Projects > Connectivity > Query All.

b. Click Retrieve to display the data in the DGN file.
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3. Create a Mesh.

a. Select 3D Modeling > 3D > Create Mesh.

The Create Mesh window appears.

b. Enter the following values:

 Type = Lithology

 Identifier = All

 Enable the Use all Boreholes option

c. Data point on the active model to create the meshes.
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Create Cross Section

In this exercise we will create a cross section through the lithology data.

1. Display paths where cross sections will created.

a. Select Home > Primary > Level Display.

b. In the Level Display window right click on the level named XSection Lines and select Set Active.

c. Right click on any level in the Level Display window and select All Off from the pop up window. 

2. Create a Cross Section.

a. Select 3D Modeling > Cross Section > Create 
Cross Section.

b. Enter the following values:

 Boreholes Selection Mode = by Offset

 Offset to Cross Section Line = 4

 Model Name = East-West

 Columns Width = 2

 Annotation = Borehole ID or PointID

 Enable the Open Model on Creation option

c. Data point on the cross section line running 
roughly east to west.
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d. Data point again to accept and create the cross section.
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Create Fence Diagram

A Fence Diagram is a cross section model attached in 3D space to the constituent boreholes. Cross Section Models 
must exist.

1. Return to the 3D Drawing model.

a. Click Go to Previous View Group in the lower left corner to return to the 3D Model. 

HINT: The 3D Model View can also be selected from the pick list next to the Go to Preview View Group icon.

2. Create a Fence Diagram.

a. Select 3D Modeling > Cross Section > Create Fence 
Diagram.

b. Set Cross Section Selection Mode to List.

c. Select East-West from Cross Section List.

d. Data point to accept and create the fence diagram.
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