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FDOT Roadway Design and 3D Modeling 

Basic 2D Rule Based Design Training 
 

Description 

This is a 2-day training course to include the Introduction and Chapters 2, 3, and 4 of the course guide. Participants 

will be introduced to Bentley GEOPAK V8i SELECT Series4 (SS4) OpenRoads Technology tools for design 

and modeling; specifically for Florida Department of Transportation (FDOT) projects using the FDOTSS4 

Workspace.  Several new technologies will be introduced including: 

• Civil Elements, Civil Features, and  Civil Geometry 

• Design Intent  and Design Standards 

• Civil AccuDraw and Civil Cells 

• Project Explorer: Civil Model 

• Task Menus and Cursor Context Menus 

 

Objectives 

• Use Civil Geometry Elements in the design file to calculate and define a proposed centerline of 

construction. 

• Use Civil Geometry Elements in the design file to define the roadway features of the proposed 

design.  

• Apply Civil Cells delivered within the FDOTSS4 Civil Cell DGN library. 

• Use Civil Geometry Elements in the design file to define the vertical profiles of a proposed 

centerline. 

Audience 

• FDOT Roadway Designers and Engineers 

 

Prerequisites 

Participants need to have a basic understanding of Computer Aided Drafting and Design (CADD) using 

MicroStation, a basic understanding of GEOPAK concepts and a solid understanding of the engineering 

necessary to design a Roadway. 

 

Duration: 16 Hours    

 

Professional Credit Hours:  16 PDHs 
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FDOT Roadway Design and 3D Modeling  

Advanced 3D Modeling Training 
 

Description 

This is a 2-day training course to include the Introduction and Chapters 1, 5, 6, 7, 8, 9, and 10 of the course guide. 

Participants will continue to learn the Bentley GEOPAK V8i SELECT Series4 (SS4) OpenRoads Technology 

tools for design and modeling within the FDOTSS4 workspace.  Several advanced concepts and technologies 

will be introduced including:  

• Rule Based Superelevation Design Parameters 

• Associating Template Points to Superelevation Lanes  

• Constructing 3D Elements 

• Building Intersection Terrains from 3D Elements 

• Appling a Surface Depth to Terrain Elements 

• Placing  3D Civil Cells 

• Configuring Advanced 2D and 3D Civil Cells 

• Corridor and Terrain Model Clipping  

•  Applying Linear Templates to 3D Elements 

• Building DTM, XML  Files for Construction Deliverables 

Objectives 

• Create a Superelevation Shape Model. 

• Create Superelevation Sections and Lanes. 

• Calculate and Assign Superelevation to a Corridor. 

• Create an Intersection Terrain Model from 3D Elements. 

• Create a Traffic Separator Nose Model on the Corridor Model. 

• Create an Island Model on an Intersection. 

• Apply Linear Corridors along 3D Elements. 

• Create 3D Driveway on a Corridor Model. 

• Create 3D Sidewalk Ramps on Intersection Model. 

• Prepare the Files Necessary for Construction Deliverables. 

Audience 

• FDOT Roadway Designers and Engineers 

Prerequisites 

Participants need to have a basic understanding of Computer Aided Drafting and Design (CADD) using 

MicroStation, a basic understanding of GEOPAK concepts and a solid understanding of the engineering 

necessary to design a Roadway. 

In addition to the above, the participant is required to complete:   

FDOT Roadway Design and 3D Modeling - Basic Training.  

Duration: 16 Hours    

Professional Credit Hours:  16 PDHs 
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INTRODUCTION  

This course was developed to introduce Roadway Designers to the V8i SELECTSeries4 (SS4) OpenRoads 
Technology tools for design and modeling on Florida Department of Transportation (FDOT) projects.  The 

curriculum was developed within the FDOTSS4 Workspace to provide sample exercises for most of the new 

Civil Tools on a sample project data set.  

COURSE OBJECTIVES 

Participants of this course will be introduced to the newest OpenRoads Technology and a Workflow for 

designing two dimensional (2D) Plans, Profiles, Cross Sections and three dimensional (3D) Models for 

Construction Deliverables.  At successful completion they will have learned how to: 

• Create a Terrain Element from the existing surface to be used as a reference for the project. 

• Develop Existing Feature Terrain Surfaces to be shown on cross sections and used in earthwork calculations. 

• Use Civil Geometry Elements in the design file to calculate and define a proposed centerline of construction 

and while using the built in Design Standards Criteria checking. 

• Use Civil Geometry Elements in the design file to define the roadway features of the proposed design.  

• Apply Civil Cells delivered within the FDOTSS4 Civil Cell DGN library. 

• Use Civil Geometry Elements in the design file to define the vertical profiles of a proposed centerline. 

• Use the Standard Components and Templates within the FDOTSS4 Template library. 

• Create a 3D Model of the existing and proposed Roadways. 

• Reference 2D Civil Geometry Elements to a Corridor Model by adding the elements for use as design model 

control lines. 

• Apply varying Typical Section conditions along the project, including: variable medians, special ditches, 

handrail checks, gravity wall placement, slope conditions, left and right turns, etc. 

• Define the Superelevation Standards along a corridor. 

• View Dynamic Cross Sections for review, updates, and design checks along the project before cross sections 

are created for printing. 

• Create and display 3D Models for better designing and visualization. 

• Use the Milling Overbuild and Overlay Components on a project corridor. 

• Apply Corridor Modeling Techniques used for developing driveways and intersection, etc. 
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EXPECTATIONS – WHAT THIS COURSE PROVIDES 

This course provides a standard workflow for designing a project with Bentley Systems GEOPAK OpenRoads 
Technology within the FDOTSS4 Workspace. Although the majority of tools are used throughout, this course 

does not provide a description of every Bentley Systems GEOPAK OpenRoads Technology Civil Tool.  

Integrated help for each of the tools can be found by selecting from the Main Menu in MicroStation: GEOPAK 

> ROAD > Help. 
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DOCUMENT STYLE  

Style conventions used throughout the course guide are shown in the following table. 

Item Convention Example 

Menu names 

and 

commands 

Bold N 

(Names separated 

with > symbol) 

• File > Open 

• File > ComSelect > Design 

Dialog box 

Actions 
Bold 

 

• Click the Apply button. 

• Click the Graphic Select button to the right 
of the Horizontal Alignment Include box. 

• In the Segment Type list, click Lines. 

Dialog box 

Field Names 
Italic • Key in Hemfield Road in the Alignment 

Name field. 

• Click the Graphic Select button to the right 
of the Horizontal Alignment Include field. 

• In the Segment Type list, click Lines. 

Key-ins Bold • Key in Hemfield Road in the Alignment 
Name field. 

File Names Italic • Open the file Working Graphics.dgn in the 
C:\Bentley Training\GEOPAK 101\Project 
Setup\Practice\ folder. 

File Paths Non italic 

 

• Open the file Working Graphics.dgn in the 
C:\Bentley Training\GEOPAK 101\Project 
Setup\Practice\ folder. 

New Terms 

or Emphasis 
Italic 

 

• The Template Library contains templates, 
which represent typical sections of the 
proposed roadway. 
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FILE TYPES 

The Bentley Systems GEOPAK OpenRoads Technology road design process now uses a single source file 

type, the DGN file.  All pertinent design data is stored in the design file. This information can be viewed through 

the Project Explorer and reported on in the Civil Report Browser. 

Below is a brief description of the legacy file types used in GEOPAK which can be imported or exported (i/o) 

with OpenRoads Technology. 

File Type Description: 

• Surface.tin  (i/o) - A binary file, also known as a GEOPAK digital terrain model (DTM),that stores features 

made up of random points, break lines, and boundary data along with triangulated surface model. The features 

and the triangles together represent an existing ground surface. 

• Surface.dat (i) - A binary (or ASCII) file containing string and point information that is used for digital terrain 

model construction. 

• Surface.dtm (i/o) – A binary file, also known as a Roadway Designer digital terrain model that stores features 

made up of components, break lines, and boundary data along with triangulated surface model. The features 

and the triangles together represent either existing ground surface or the proposed roadway corridor model. 

• Geometry Project.gpk (i/o) - A binary file (job###.gpk) created when starting a coordinate geometry (COGO) 

session for the first time or created through Project Manager, that stores geometric data including points, 

lines, curves, spirals, parcels, chains, and profiles. The file may be appended to during the design process. 

Multiple users can access this file at the same time. Only one file should be created for each project. The 

"###" is the only variable in this filename. It represents a job number (1 to 3 alphanumeric characters) unique 

to a project and is user defined upon creation. 

• CMJobxx.alg (i) – A binary file containing the imported Chain, Profiles, and MicroStation Plan Elements 

necessary on a project in the Select Series 2 Version of GEOPAK Corridor Modeling. 

• Template Library.itl (i) - Stores templates and template components. Different components can be assembled 

to build templates, which define the typical sections of a roadway. Only one Template Library file may be 

open for editing at a given time. 

• Project.rdp – Stores the corridor modeling preferences imported geometry, DTM, and plan graphics in the 

Select Series 2 Version of GEOPAK Corridor Modeling. This file is not used or imported in the Select Series 

3 release.  

• Project.ird (i)  – Stores Corridor Definitions including; Limits, Template Drops, Parametric Constraints, 

Superelevation, Point Controls, Key Stations, Etc. in the Select Series 2 Version of   GEOPAK Corridor 

Modeling. This file can be imported in the Select Series 3 release. 
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LEARNING RESOURCES 

There are several resources available for learning about the various Bentley Systems GEOPAK OpenRoads 
Technology tools. Among them are: 

• Bentley Communities:   

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-

technotes-faqs.aspx 

• Bentley Learn:  

Bentley Institute site is for registered user and may require a Select Server site license to participate:  

https://learn.bentley.com 

• Bentley Product OpenRoads: 

Videos are available on a variety of topics: https://www.Bentley.com  

• YouTube: 

Bentley OpenRoads Videos are available on a variety of topics: 

http://www.youtube.com/user/BentleyCivil  

• YouTube Search - Google:   

Bentley OpenRoads returns several sites with videos for learning how to apply the technology on 

project specific situations. 

• Production Support Office | CADD (CADD) Website:  http://www.fdot.gov/cadd/ 

Webinar training recordings are available on many of the subjects covered in this manual:   

http://www.fdot.gov/cadd/main/FDOTCaddTraining.shtm 

http://www.fdot.gov/cadd/downloads/webinars/Posted.shtm#loadSection 

https://www.youtube.com/channel/UCqbY8kqZuXp1pyYV6lIQw_A 

 

COURSE SUPPORTING FILES 

The exercises for each chapter are independent of one another and can be used without having to complete the 

exercises in previous modules. The exercise files are organized into separate comSelected zip files for each 

chapter.  All files used in this course are located also at this link:   

http://www.fdot.gov/cadd/downloads/documentation/FDOTRDAnd3DM/FDOTRDAnd3DM.shtm 

  

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-technotes-faqs.aspx
http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-technotes-faqs.aspx
https://learn.bentley.com/
http://www.bentley.com/
http://www.youtube.com/user/BentleyCivil
http://www.fdot.gov/cadd/
http://www.fdot.gov/cadd/main/FDOTCaddTraining.shtm
http://www.fdot.gov/cadd/downloads/webinars/Posted.shtm#loadSection
https://www.youtube.com/channel/UCqbY8kqZuXp1pyYV6lIQw_A
http://www.fdot.gov/cadd/downloads/documentation/FDOTRDAnd3DM/FDOTRDAnd3DM.shtm


Introduction ______________________________________ EXISTING TERRAIN AND FEATURES - Introducing a New Workspace 

6 ©2018 FDOT  FDOT Roadway Design and 3D Modeling 

INTRODUCING A NEW WORKSPACE  

FDOTSS4 PREDEFINED SETTINGS 

 

DESIGN FILE SETTINGS: 
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FDOTSS4 WORKSPACE PREFERENCES: 

  

FDOTSS4 KEYBOARD SHORTCUTS 

These will open the Civil Tasks on your cursor as shown below. 
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FDOTSS4 FUNCTION KEYS  

FDOTSS4 Function Key Assignments 

F1 Opens the Civil Help. Ctrl+F1 Closes all Views except View 1 

F2 Open View 1 (2D Plan) and View 2 (3D Isometric) and fits both views. 

F3 Opens View 3 (2D Plan), closes all View 4, and arranges all Views. 

F4 Open View 1 (2D Plan) , View 2 (3D Isometric), View 1 (2D Plan), View 1 (2D Plan) & 

Fits All views 

F5 Toggles Dim References ON/OFF 

F6 Resets out of any ongoing commands. 

F7 Toggles the Construction view attribute off and on. 

F8 Toggles between MicroStation AccuDraw and Civil AccuDraw. 

F9 With 3D Model view active, Toggles Off 3D proposed model shapes and bottom lines. 

F10 With 3D Model view active, Toggles On 3D proposed model shapes. 

F11 Toggles (opens or closes) the Project Explorer dialog. 

F12 Opens the Create Template dialog. 
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• Function Key F1 – Civil Help 

 

• Function Key F2 – Open and Fits Two Views Setup; View 1- 2D Plan, View 2-Isometric 
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• Function Key F3 – Opens View 3; Closes View 4 and Arranges Views 

 

• Function Key F4 – Opens and fits Four View Setup; View 1- 2D Plan, View 2-Isometric, View 3,4 - custom 
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• Function Key F5 – Toggle Dim References 

 

• Function Key F6 – Resets Out of Any Ongoing Commands. 

 

• Function Key F7 – Toggles On/Off Construction View Attributes 
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• Function Key F8 – Toggles Between MicroStation AccuDraw and Civil AccuDraw 

  

• Function Key F9 – With 3D Model View Active, Toggles Off 3D Shapes and Bottom Lines 

 

• Function Key F10 – With 3D Model View Active, Toggles On 3D Shapes. 
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• Function Key F11 Toggles Project Explorer Dialog Open/Close. 

 

• Function Key F12 Corridor Modeling, Opens Create Template Dialog. 
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FDOTSS4 USER CONFIGURATION VARIABLES 

 

FDOT SS4 DESIGN AND 3D MODELING OVERVIEW 
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GENERAL WORKFLOW AND CHAPTER OUTLINE 

1. Existing Terrain and Existing Features 

2. Design Centerlines Alignments and Prepare Station Annotations 

3. Prepare 2D Plan Layout  

4. Design Profiles 

5. Define Project Templates 

6. Create 3D Design Model and add 2D References 

7. Create Cross Section View 

8. Define Superelevation and Assign to the Corridor Model 

9. Detail Modeling for Intersections, Median Traffic Separator Nose, Side Roads, 

Driveways, Curbs Ramps, etc. 

10. Prepare Construction Deliverables. 

RECOMMENDED MICROSTATION SETTINGS  

Various tools and settings will be used throughout the workshop. Therefore for quick accessibility, several of the 

dialogs are better docked on the sides the MicroStation view.  

GETTING STARTED 

1. (Optional) Extract the 22049555201(1).zip file in the Data Set folder to the c:\e\projects folder. 

If this is a class environment, then this step has already been completed. 

2. (Optional) Copy the 22049555201.pcf file in the Data Set folder to the c:\e\projects folder. If 

this is a class environment, then this step has already been completed. 

3. Click on the FDOTSS4 icon   on the windows task bar <OR> double click on the 

FDOTSS4 icon in the FDOTSS4 folder on the desktop to open the Workspace.  

4. In the lower right corner of the File Open dialog, set the User to FDOTSS4, Project to 

224049555201, and Interface to FDOTSS4. 

 

5. Navigate to the Roadway folder, select TYPSRD01.dgn and click Open. 
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MENU DOCKING 

 

1. Verify that the Civil Message Center tool is already docked on the bottom; if not, select it from 

the General Geometry Task group, dock and unpin.  

  

2. Verify that the Project Explorer is docked on the left side; if not, from the main menu bar, 

select File > Project Explorer, dock and unpin…Or use the F11 function key to toggle 

ON/OFF the dialog. 
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3. Verify that the Level Display is docked on the right side; if not, from the main menu bar, select 

Settings > Levels > Display, dock and unpin.  

 

4. Verify that the Task Bar is docked on the left side; if not, from the main menu bar, select Tools 

> Tasks, dock and unpin.  

  

5. Verify that the Element Information is docked on the right side; if not, from the main menu 

bar, select Settings > Element Information, dock and unpin. 

  

 Many of the dialog settings are stored in user preferences defined in xml data files located in the users 
data folders i.e. C:\Users\rd964vd\AppData\Local\Bentley. 
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1 EXISTING TERRAIN AND FEATURES 

INTRODUCTION 

 This chapter will introduce the OpenRoads Technology tools to use for viewing the existing terrain and 

creating 3D existing features in design models in FDOTSS4.   

CIVIL TERRAIN MODELING 

As defined in the Bentley Civil Tools help files: 

“A terrain model is a set of three-dimensional triangles mathematically computed from point 

data collected on the surface being modeled. Models are used to define highly irregular surfaces, 

particularly the surface of the earth, but can be generated for proposed surfaces, subsurface 

geotechnical layers, and etcetera. Terrain models are also referred to as digital terrain models 

(DTMs), triangulated irregular networks (TINs), or triangulated surfaces. 

The MicroStation Terrain Model tools support importing and labeling terrain contours and 

spots on terrain models. You can import a terrain model into a DGN to use its data. Terrain 

models imported from the LandXML file format are supported within MicroStation. However, 

any manipulation or importing from Civil products must be done within Bentley Civil. 

Bentley Civil provides a robust set of tools to create, edit, analyze, and work with terrain models. 

A terrain model is recognized as a MicroStation element type as of MicroStation V8i 

(SELECTseries 4). When you select a terrain model, the Element Selection tool Element Type 

tab indicates that it is a Terrain element type.” 

Several terrain model civil features have been developed for the FDOTSS4 Workspace to be used on FDOT 

projects. Terrain elements created in the design file can be selected from these features in the various Terrain 

Model Tasks. 

WORKFLOW INFORMATION 

The workflow process for getting existing features to appear on cross sections has changed significantly in 

FDOTSS4.  No longer will the legacy existing features criteria be used.  Instead the existing features will be 

created in a 3D model following the steps outlined in the exercises to follow.  

• Levels containing the existing features will be identified from the SURVRD01 OR TOPORD01 file and 

copied into a GKLNRD file. 

• Closed shapes will be created to contain areas representing the existing features. These are the features which 

are typically required to be the on cross sections.   
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The table below is a list of the Levels that contain these features.  

  Level Existing Feature 

CGBack_ep Curb Back Line 

CGep_ep Curb Edge of Pavement 

ConcSlabs_ep Concrete Slabs 

Driveway_ep Driveway Pavement 

PavtAsphalt_ep  Pavement (Roadway) 

PavtMisc_ep Pavement (Miscellaneous) 

ShldrPaved_ep Shoulder Pavement 

SidewalkFront_ep Sidewalk Front Line * 

SidewalkBack_ep Sidewalk Back Line 

TrafSeparator_ep Traffic Separator 

* A sidewalk front line may not be present when 

the sidewalk is adjacent to curb. 

 

• The existing Terrain will then be clipped by each shape individually to create separate existing feature 

Terrains 

• A surface template is then applied to the terrain features to define the sub-surface depth to the terrain. 

• For the non-uniform depth curb and gutter a linear template is applied.  

• A profile is added to the R/W Existing lines in order to display the R/W line symbol in a cross section view 

When finished, the file will contain 3D existing features developed from the original existing DTM terrain and 

TOPORD01 files. As a result of creating this file, any cross section created while the terrain elements are 

displayed in the 3D model will show existing features below the surface.  

 EXERCISE OVERVIEW 

 1.1  Create and Set Up the GKLNRD file  

 1.2  Create Shapes Using FDOT Create Existing Features   

 1.3  Create Existing Feature Terrains (External)  

 1.4  Clip Terrains within Terrain, i.e. Medians/Traffic Separators   

1.5  Create Existing Traffic Separator Terrains  

 1.6  Apply Surface Templates  

 1.7   Edit Existing Feature Depth  

 1.8  Add Curbs to the Existing Features  

 1.9  View Existing Cross Sections  

1.10  Add Existing R/W Lines for Cross Section Viewing  

1.11  Add Existing Utility Lines for Cross Section Viewing 
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Exercise 1.1 Create and Set Up the GKLNRD file  

In this exercise, the GKLNRD01.dgn file will be created and the FDOT Create Existing Features tool will 

be used to reference the SURVRD01 file which contains the existing survey.  The RWDTRD01 file will 

also be referenced.  

 

1. From the main Tasks bars, select the FDOT Plans Development task.   

  

2. From the FDOT Plans Development, Roadway Plans Task, select the Create New File icon. 

The Create File dialog displays.  

  

3. Create a GKLNRD01.dgn file with the Create File/Project dialog as shown below.  
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4. Click Create – Open File to create the file, GKLNRD01.dgn. Click Open File, 

GKLNRD01.dgn displays. Set/Update Plot Scale displays. Use the default settings and click 

OK.  

5. Click Close to close the Create File dialog.  

6. From the FDOT Plans Development, Existing Features Task, select the Create Existing 

Features icon.  

  

7. At the Open dialog, navigate to the project survey directory and select the SURVRD01.dgn 

file.  

  

8. Click Open.  FDOT Features 1.00.00 opens.  (The tool has attached the reference file, copied 

in the elements, and then turn off the display to the reference file.)  
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9. Select MicroStation Fit View to see the elements copied into the file.  

  

10. Delete the DTM element from the file.  

11. Turn on the display for the referenced SURVRD01 file.  

12. Turn off all the levels in the reference SURVRD01 file except the DTM_ep and DTM_ex.  

➢ To Add Lines from R/W  

1. From the MicroStation menu select File > References and attach the following files: 

C:/e/projects/rwmap/RWDTRD01.dgn 

2. From the FDOT Plans Development, Existing Features Tasks, select the Copy Reference File 

Levels icon.  
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<OR> From the FDOTSS4 Menu select Design Apps > Reference File > Copy Reference File 

Levels.  

  

3. Select the level RWLine_ep and click the Add button. When finished select Process.   

  

4. Click the X button to close the application.  

5. From the Reference file manager, turn the display off for the RWDTRD01.dgn file.  

  

  



EXISTING TERRAIN AND FEATURES - Create Shapes Using FDOT Create Existing Features _____________________ Chapter 1 

FDOT Roadway Design and 3D Modeling  ©2018 FDOT  1-7 

Exercise 1.2 Create Shapes Using FDOT Create Existing Features    

  

The FDOT Features tool will be used to assist in closing areas and creating the necessary shapes for 

the existing features to be modeled. The tool contains a drop-down menu and 3 tool icons.  The drop-

down menu allows for the selection of the active existing feature.  Levels are turned on/off to help 

isolate the areas where shapes are needed.  In order to create a continuous shape around the existing 

features, miscellaneous lines are drawn in the file at various locations.  The first icon, Place Feature 

Line, activates the Place Feature Line tool.  The second and third icons are used to create the shapes 

either by the flood method or by selecting the elements to trace.  

1. On the FDOT Features dialog, select Pavement from the dropdown list.  

  

2. Select Place Feature Line and place lines to separate the 2 existing roadways and close off the 

pavement areas as shown.  
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Note The lines drawn to close the turnouts (purple) beyond the RW line can be used to create shapes for either 
Turn Out or Pavement depending on preference 

3. Select the icon Create Feature Shape by Flood.   

    

4. Data point inside each area defined with step 2 to create the required shapes.  The tool will 

highlight and zoom the area to fit the view before accepting each shape. Click again in the 

screen to accept.  Zooming out to see the entire shape before selecting inside an area is not 

necessary. 

5. Repeat the steps to create closed shapes for each of the following types of features.  

Note Place lines to close line work differentiating existing features. It may be necessary to modify the Tolerance 
value when creating the shapes.  The Flood Feature Tolerance dialog box will pop up when the Create 
Feature Shape by Flood tool is activated. 

Existing Features Types:  

Shoulders  

Driveways,  

Existing Traffic Separator  

Turnouts  

Side Streets  

Medians  

(CGFace_ep and CGBack_ep elements will be used in later exercises.)  

Note This exercise is meant to demonstrate the procedures for adding existing features into a 3D model. There 
may be more features on a typical project and the steps outlined here can be used to achieve the desired 
results. 

6. Close the FDOT Features tool and then close MicroStation.  
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Exercise 1.3 Create Existing Feature Terrains (External) 

Once the shapes are created, those shapes can be used to create individual terrains from the existing 

DTM.  This is referred to as External Clipping.  In this exercise, the Open Roads Civil tool, Clip 

Terrains will be used to create the terrains for the pavement, shoulders, driveways, and turnouts.  

1. Open up the MicroStation file C:\e\projects\22049555201\Roadway\GKLNRD01.dgn.  

a. Set the Active Level to PavtAsphalt_ep and turn Off all the other Used Levels.   

b. Make sure the Reference file display for the Terrain is turned On.  

2. Use the Existing Features, Clip Terrain tool to create a Terrain for Existing Features.  

    

Note If you did not close the file when completing Exercise 1.2 and the file crashes when activating this tool, use 
Clear Crash to close the MicroStation session.  Reopen the file and start this exercise from step 1. 

3. On the Create Clipped Terrain Models dialog, under the Feature section set the Feature 

Definition to DtmExistingFeature and enter ExFeature_SR61_Pavement for the Name.  

Note DtmExistingFeature is a terrain feature used for Surface Templates. It is a construction class terrain 
element and can be turned OFF with the F7 function key. 

   

a. Following the prompts on the end of the cursor, locate the Reference Terrain Model 

element. This will be the terrain you are clipping from; which in most cases will be the 

Existing Terrain Model. Select the GDTMRD boundary as the Reference Terrain.  

b. Locate the Clipping Element; the shape for which you want to create a terrain. Select 

the shape created for the left existing pavement for SR 61 and data point to accept it as 

the Clipping Element.  

 Some of the shapes may overlap each other. Right-click or Tab through the shapes and 

select the correct one. Select F6 to exit the command and then restart the command if 

needed.  
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c. Right click to Reset when finished to stop selecting Clipping Elements.   

d. Set the Horizontal Offset to 0.0 and left-click to accept.  

e. Set the Vertical Offset to 0.0 and left-click to accept.   

f. Set the Clipping Method to External and data point to accept.  

Note When selecting multiple shapes, the dialog will flip and lock to the internal method. External boundaries 
can only be selected one boundary at a time.  

Internal clipping elements will be added in another exercise. 

4. Repeat step 3 to create the terrain for the right side of SR61.  The tool will automatically 

rename the terrain by adding a 1 to the end.  (Notice that the triangle for the right side of SR61 

are triangulating outside of the boundary.)  

  

5. A clipped terrain is created and placed in the 3D Model of the GKLNRD01. The 3D Model is 

then referenced to the 2D Model.  To Edit a terrain, it must be done in the 3D model.  Select 

the Function Key F2 to open both the 2D and the 3D Model.  

6. Change the View Rotation to Top and zoom in to the area of triangles that are incorrect.  

7. Select the Function Key F11 to open Project Explorer.  

8. Under the Civil Model tab, go to GKLNRD01.dgn, Default > Terrain Models > Terrain 

Model: ExFeature_SR61_Pavement1 (the right side existing terrain for SR 61).  

9. Right Click on the Terrain Model and select Rules > Remove Rules.  
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10. With the 3D view active, go to Tasks > Civil Tools > Terrain Model > Edit Terrain Model.   

  

11. The Edit Terrain toolbox opens.  Select the option to Delete Triangle By Line.  

  

12. In the 3D view, select the terrain boundary and then draw a line across the unwanted triangles.  

  

13. Continue deleting triangles until removed from all 3 areas.  When done, close the 3D view.  

14. Repeat the Step 3 Clip Terrain command for each of the following existing shapes. Use the 

table below to record the Status.   

 Existing Feature Terrain Name  Status 

 ExFeature_SR61_Pavement   completed  

 ExFeature_SR61_Shoulder    

 ExFeature_US98_Pavement    

 ExFeature_US98_Shoulder    

 ExFeature_US98_Driveway    

 ExFeature_US98_Turnout    
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Exercise 1.4 Clip Terrains within Terrain, i.e. Medians/Traffic Separators  

In some cases, the terrain created may include areas that they should not.  Examples include Traffic 

Separator, Medians, or Curbed Islands within a terrain created for a pavement area.  These smaller 

sections need to be clipped out of the larger terrain.  This is referred to as Internal Clipping.  The tool 

creates a new terrain with the area(s) clipped out.  It does not modify the existing terrain.  

In this exercise, a terrain will be created using the internal method for the pavement terrain created in 

the previous exercise on the right side of SR 61.  

1. Select the Terrain and hover over the boundary to display the Context Menu. Select the 

Properties dialog.  

   

2. From the Properties dialog, set the Triangles option to Off.  
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3. Use the Existing Features, Clip Terrain tool to create a clip boundary within a terrain for 

Existing Features.  

   

a. On the Create Clipped Terrain Models dialog, select the Reference Terrain Model 

ExFeature_SR61_Pavement1.  

b. Enter the Name ExFeature_SR61_Pavment2.  

c. Then locate the shape inside the ExFeature_SR61_Pavement1 boundary.   

d. Reset when finished.  

   

 Multiple internal clipping elements can be added one time.  

e. Change the Clipping Method to Internal.  

f. Data point to create the clipped Terrain.    
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4. To delete the first ExFeature_SR61_Pavement1 Terrain.  

a. Select F11 to launch Project Explorer.  

b. Select the Civil Model tab.  

c. Navigate to the Civil Data > GKLNRD01.DGN, Default > Terrain Models folder.   

d. Right-click on the Terrain Model: ExFeature_SR61_Pavement1 and select Delete.   
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Exercise 1.5 Create Existing Traffic Separator Terrains  

So far the Existing Pavement Terrain area has been created for ExFeature_US98_Pavement, now the 

Existing Traffic Separator Terrain can be created.  

1. On the reference dialog, turn off the Display for the Default 3D model.  (This will make it 

easier to select the traffic separator shape.)  

2. Use the Existing Features, Clip Terrain tool to create a terrain for Existing Traffic Separator 

island shape.  

   

3. On the Create Clipped Terrain Models dialog, select the Reference Terrain Model 

GDTMRD01.  

4. Set the Clipping Method to External.  

5. Set the Feature Definition to DtmExistingFeature.   

6. Enter ExFeature_US98_TrafficSeparator for the Name.  

  

7. Select the Traffic Separator Island Shape.  

  

Note The curb islands will be created in exercises to follow using linear templates. 

8. Turn back on the display for the Default 3D model to see the terrain triangles.  
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Exercise 1.6  Apply Surface Templates  

In this exercise the Surface Template will be applied to each of the existing terrains created from the 

previous exercises.   

1. Use the Existing Features, Open Existing Features Template to view Surface Templates to 

apply to each Clipped Terrain.  

  

a. The Create Template dialog displays the FDOTSS4.itl file.    

b. Navigate the left folders to the Existing Feature Templates folder.  
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c. Double click on PavementAsphaltExisting. (This is an example of the template to be 

used for the existing pavement.)  

  

d. Click Close to exit the dialog.  

2. Use the Existing Features, Apply Surface Template to apply Surface Templates to each 

Clipped Terrain.  
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a. Following the prompts on the end of the cursor, locate the Terrain Model and select 

the ExFeature_SR61_Pavement Terrain.  

  

b. Set the Apply External Clip Boundary to No. (The arrow keys on the keyboard can be 

used to toggle through the options.)  

  

c. Data point to accept.  

d. Set the General Template to PavementAsphaltExisting.   

  

 The Template library can be opened by Selecting Alt+↓ on the keyboard. 

e. Data point to accept that template.  A surface will be applied to that terrain with the 

correct feature.  

3. Repeat this procedure for each of the Existing Feature Terrains shown in the table below.  

Existing Feature Terrain Name  Existing Feature Template  

ExFeature_SR61_Pavement2   PavementAsphaltExisting  

ExFeature_SR61_Shoulder(s)  PavedShldrExisting  

ExFeature_US98_Pavement(s)  PavementAsphaltExisting  

ExFeature_US98_Driveway(s)  DrivewayExisting  

ExFeature_US98_Shoulder(s)  PavedShldrExisting  

ExFeature_US98_TrafficSeparator  TrafficSepExisting  

ExFeature_US98_Turnout(s)  PavedAsphaltExisting  
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4. To view those Existing Features created in the 3D Model without the Existing Feature Terrain 

triangles, click F11 to open Project Explorer, then navigate to Civil Standards > 

GKLNRD01.dgn, Default > Feature Definitions > Terrain Display and toggle OFF either 

the Terrain Display or DtmExistingFeature option.  
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Exercise 1.7 Edit Existing Feature Depth   

The surface templates that have been applied are set with a default depth.  In many cases, these depths 

may be acceptable.  If not, they will need to be edited.    

1. Click F2 to open the views showing both the 2D and 3D models.  

2. Select the 3D view to make it active.  (A dialog will pop up asking to accept settings.  This is 

due to the Survey attached to the file.  Click on the X to close the dialog.)  

3. Click on the Existing Features > Edit An Applied Surface Template icon.  

  

4. In the 3D view, select one of the surface templates. The Editing Roadway Design Template 

Drop dialog (the interface is identical to the Template Library dialog) opens with the current 

template shown with the Library tab active.   
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5. Click on the Active Template tab.  

  

6. On the left hand menu, navigate to the Parametric Constraints folder and double click on the 

EOP_PvtThick item.  

  

7. Set the Default Value to -.5 and click OK.  

   

8. Click OK to close the Editing Roadway Designer Template Drop dialog. You do not have 

to select File > Save to save your edits.  

Note Another Option is to open Project Explorer and navigate to the Terrain’s surface template and right click to 
choose Edit and Applied Surface Template. 
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Exercise 1.8 Add Curbs to the Existing Features  

In this exercise a model of the existing curbs will be developed. In order to use the Civil Tools to create 

the Existing Curb Model, MicroStation elements will need to be changed to Civil Features.  Linear 

templates will then be applied to the feature elements to generate the depth needed for curbs.  

1. Select Ctrl + F1 to return to a One View only of the project.  

2. Select the Existing Terrain Boundary, and when the Context Menu displays, click on the Set 

As Active Terrain Model. (This will allow for profiles to be displayed on elements.)   

  

3. In the Level Display dialog, right click on the Ref, GKLNRD01.DGN, default-3D file and 

Uncheck the display.  

4. In the Level Display dialog, click on GKLNRD01.DGN, default file, set the Active Level to 

CG_ep, and turn OFF all other Levels except for CGBack_ep and PavtAsphalt_ep.  

5. Create a Selection of the median shapes made from the Back of Curb (level CGBack_ep) 

elements.  
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a. Use the Existing Features, Set Feature Definition to set the Back of Curb shapes to 

the Civil Roadway Feature, CurbExisting.   

  

b. On the Set Feature Definition dialog, set the Feature Type to Linear and navigate 

the Feature Definition to Plans (2D) > CurbGutter > CurbExisting. The Name will 

automatically populate.  

  

c. Data Point to apply Feature to the selected elements.   

6. Right click and hold to access the context menu and select Select All On Level By Element.  

Click on one of the edge of pavement shapes to create a Selection of the median shapes made 

from the Existing Pavement (PavtAsphalt_ep) elements.  

a. Use the Existing Features, Set Feature Definition to set the Existing Pavement 

(PavtAsphalt_ep) shapes to the Civil Roadway Feature, PavementExisting.   

  

b. On the Set Feature Definition dialog, navigate to the Feature Definition to Plans 

(2D) > PavementExisting. The Name will automatically populate.  

  

c. Data point to apply Feature to the selected elements.  ➢ Open Profile Model for 

Back of Curb. 
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7. Turn ON the CGFace_ep level.  

8. Select the Back of Curb shape and hover over the highlighted line until the Popup Menu 

displays.  

  

9. Select the Open Profile Model icon and select View 3 at the bottom of the MicroStation 

window to open the Profile view, then data poin inside View 3.  

  
10. In the Profile view, select the Existing Ground Profile to display the Popup Menu and then 

select the Set Active Profile icon. Close the Profile view window.   
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➢ Appling an Existing Curb Template   

1. Use the Existing Features, Apply Linear Templates to create a 3D Existing Curb Feature.  

  

  

a. At the prompt locate element and select the CurbExisting Feature (i.e. back of curb 

line).  

b. Hold Alt down arrow key to pick the CurbExisting Template.  

  

c. Click Ok and then data point to accept.  

d. Press the Alt key to lock the Start and then data point. Press the Alt key to lock the 

End, and then data point again.  

e. Select the side to place the curb and data point outward from the back of curb.   

f. Enter (<OR> accept) 1 degree for the Exterior Corner Sweep Angle.  

g. Enter Existing Curb for the Description.  Data point to accept.  
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2. Select the F2 Function Key to open the 3D model View. The 3D Curb bottom shape will appear 

in the model.   

   

3. Use Existing Feature, Add Corridor Reference tool to add the Template Target Feature, 

PavementExisting, to the CurbExisting Template.    

  

a. At the prompt, select the CurbExisting corridor boundary element handle on level 

CorrHndlStg3_dp.  

b. Select the PavementExisting line in front of the CurbExisting Feature.  

c. Click F6 to end the command.  

Note The Existing curb in the 3D model should stretch from the back to the edge of pavement as shown in the 
image below. 

.   
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Exercise 1.9 View Existing Cross Sections  

Once the Existing Feature Terrains have been created a cross section view can be created to verify the 

model data.  In this exercise a base line in the TOPO reference file will be used to create a cross section 

view.   

1. Use Reference Display to display the attached SURVRD01.DGN file. This file has the Survey 

Baseline elements displayed to use for cross sections.  

2. Use Existing Features, Open Cross Sections in a View tool.   

   

3. At the prompt, select the Alignment shown below.  

  

4. Enter information in the dialog as shown:   

Note  Be sure to check the Station box or the Program may crash!  
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5. Data point in the view to accept EACH of the settings from above.  

6. Open View 4 and data point in the view to display the Cross Section.  

  

7. For the Cross Section View 4:  

a. Notice many of the MicroStation Zoom, Pan, etc. commands will operate as normal.   

b. Use the Cross Section View Navigation tools to examine the Existing Features.  

   

c. Select View Properties and set the Vertical Exaggeration to 10 and then select the 

View to see the changes.  
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d. Select the Station pull down menu and change to Station 2+20, (i.e. key in 220 and 

Enter).  

  

8. Navigate the cross section stations and notice the blue line in the plan view designating the 

current cross section view station. 

Note This line will also appear in the Profile Model if open. 
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Exercise 1.10 Add Existing R/W Lines for Cross Section Viewing   

1. Select CTRL + F1 to return to a single plan view of the GKLNRD01.DGN file.   

2. From MicroStation, select the menu Tools > Groups Menu > Create Complex Chain.  

  

3. Set the Active Level to RWLine_ep. 

 Optional: Turn off all other levels. 

4. Set the Create Complex Chain Method to Automatic and chain together the RWLines in 

the active file within the project Existing Terrain Limits. 
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➢ Create a Selection Set of RWLine_ep.  

1. Use Existing Feature > Set Feature tool to create Civil Features of the RW lines in the 

selection set.  

  

a. In the Feature Definition, navigate and select the RightofWayItems > 

RightofWayLine(Existing) Feature.  

   

b. The Name will be set to Exist. R/W.  

c. Data point in the view to Apply Feature Definitions to elements.   

d. Hover over an element to verify the new Feature Definition.   
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2. Select the line to display the Context Menu and select Open Profile Model.  

  

3. At the cursor prompt, select View 3 to open and draw the profile.   

  

4. Select the line and select Set as Active Profile. 

 To create an offset  profile line, 2 feet below the surface, use the Vertical Geometry, Profile Offset Transition 
Command in the Civil Tools Task Menu. 
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5. Repeat these steps for each of the R/W lines in the file. 

a. Use Existing Features, Open Cross Sections in a View tool.   

  

b. Select the Baseline Survey line in the SURVRD file as the Alignment.  

  

c. Enter -100 feet for the Left Offset, data point in the view  

d. Enter 100 feet for the Right Offset, data point in the view  

e. Enter  the Start Station value 0+00, data point in the view  

f. Enter or lock the interval to 50 feet, data point in the view  

g. Open View 4 and data point to display the Cross Section.  

6. The existing R/W lines appear on the cross sections.  
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Exercise 1.11 Add Existing Utility Lines for Cross Section Viewing   

1. Select Ctrl + F1 to return to a single plan view of the GKLNRD01.DGN file.   

2. Turn On the EXFEAT_SURVRD01.dgn, SURVRD01.dgn reference attachment.  

3. On the FDOTSS4 Menu, select the Design Apps > Reference Files> Copy Reference File 

Levels.  

  

a. On the Copy Reference File Levels dialog, from the Available Levels To Process 

column, select the WaterB_ep item.  

b. Click the “plus” sign to add it to the levels to process.  

c. Click the Process button, close the dialog.   

 

4. Turn OFF the Reference file display for the utilities.  
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5. Delete any WaterB_ep elements in the active file outside of the terrain boundary limits. They 

are not necessary for the project limits.  

6. Set the Active Level to WaterB_ep.  

7. Use Create Complex Chain, set Method to Manual and chain together the WaterB_ep lines 

in the active file within the project Existing Terrain Limits.   

8. Create a Selection Set of Water_ep.  

   

9. Use Existing Feature, Set Feature tool to create Civil Features of the Water Lines in the 

Selection Set. 

Note Existing and Proposed Utility features are located the Utilities folder in the Feature List. 
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Note This folder will be shown when the Include Utilities Features box is checked on the FDOT Menu 
Configuration  dialog. 

 

 

 

10. Data point in the view to Apply Feature Definitions to elements.   
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11. Use the Selector tool to identify the new Feature and hover over an element to verify the new 

Feature Definition.   

   

12. Select the line to display the Context Menu and select Open Profile Model.  
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13. At the cursor prompt, select View 3 to open and draw the profile.   

  

  

14. Set the sidebar tasks to Civil Tools.  

    

15. To offset the Utility Profile line 3 feet below the existing Terrain surface, on the Civil Tools 

Task Menu, select the Vertical Geometry > Profile Offset Transition tool.  
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a. Set the Placement Method to Single Offset.  

  

b. Following the prompt on the cursor select the water profile line in View 3.  

c. Enter -3.0 for the Offset value.   

d. Press the  key and press Alt to lock the profile to the start point. Data point to accept 

the offset and start point.  

e. Press Alt to lock the profile to the end point and data point to accept the end point. f. 

 Set Mirror to No.  

g. Data point to place the profile line the view.  

16. Select the water profile line in View 3 and hover over it to display the Context Menu. Select 

Set As Active Profile.  
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17. Press the F2 key to open the 3D view and view the 3D water line.   

  

18. Repeat these steps for each of the Utility Lines in the file.   

19. Use Existing Features, Open Cross Sections in a View tool.   
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a. Select the Baseline Survey line in the TOPO reference file as the Alignment.  

  

b. Enter -100 feet for the Left Offset, then data point in the view.  

c. Enter 100 feet for the Right Offset, then data point in the view.  

d. Enter the Start Station value 0+00, then data point in the view.  

e. Enter or lock the Interval to 50 feet, then data point in the view.  

f. Open View 4 and data point to display the Cross Section.  

20. The existing Water Utility displays on the cross section.  
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2 CENTERLINE ALIGNMENTS 

INTRODUCTION 

This chapter will introduce three (3) important OpenRoads Technologies for creating geometry/line work 

while designing in FDOTSS4.  They are: 

• Feature Definitions 

• Civil Geometry Design Intent  

• Design Standards 

FEATURE DEFINITIONS 

As defined in the Bentley Civil Tools help files: 

“Feature Definitions are used to control symbology, annotation, and various other properties 

that are applied to the geometric elements. The feature definitions are built by using your 

existing feature table from GEOPAK (DDB), InRoads (XIN), or MX (PSS). These existing 

feature tables are utilized by way of a link to the file, plus the addition of more settings to enhance 

capabilities.  The feature definitions are used to: 

• Define what the geometric elements actually are. What is being modeled such as curb, 

centerline, edge of pavement, etcetera. 

• Control symbology in various views, including capability to define differing symbology 

in plan, profile, and 3D spaces 

• Define terrain modeling attributes (spot, break line, void, etcetera) 

• Define surface display characteristics 

An extensive FDOTCivilFeatures.dgnlib has been developed for the FDOTSS4 Workspace to be used for all 

FDOT projects. All elements placed in the design file should have a defined Feature definition. The Civil 

Geometry tools can be set with and Active FDOT Civil Features for element creation and assignment. They can 

be viewed in the Project Explorer and in the Feature Toggle Bar. 

  



Chapter 2 CENTERLINE ALIGNMENTS - Civil Geometry - Design Intent 

2-2 ©2018 FDOT  FDOT Roadway Design and 3D Modeling 

CIVIL GEOMETRY - DESIGN INTENT 

As defined in the Bentley Civil Tools help file: 

“Design intent builds associations and relationships between civil elements. Object information 

(how, where, and by what method it was created) is stored with the object to insure the original 

intent is retained and honored in the design. If an element is modified, any related elements will 

recreate themselves based on these stored relationships. 

Civil Geometry or rule-base elements are created intelligently as the tools are used and elements are constructed. 

The FDOTSS4 Workspace and design development workflow is highly dependent on using Civil Geometry for 

the 2D plan layout rather than traditional MicroStation place elements tools. 

CIVIL GEOMETRY DESIGN STANDARDS  

Also known as Design Geometrics and Criteria and as defined in the Bentley Civil Tools help files: 

“Design standards can be used to maintain required curvature and other alignment checks when 

performing geometric layouts. They work at two levels: 

• Provide values for the element creation tools (for example, minimum radius and 

transition lengths) 

• Check the suitability of complex elements (for example, check for kinks in the 

alignment) 

Design standards are very alignment oriented. You may find limited value for using design 

standards for non-alignment computations. 

When a design standard is violated, feedback is provided in two ways: 

• An icon in the graphics on the element that has the problem. Hover over the icon to 

reveal a tool tip report of the error. 

• In the Civil Message Center 

An extensive FDOTDesignGeometricsCriteria.dgnlib has been developed for the FDOTSS4 Workspace to be 

used for all FDOT projects. Alignments created in the design file either with Civil Geometry Tools or Imported 

should have a set Design Geometrics Criteria. FDOT Design Geometrics Criteria can be viewed in the Project 

Explorer and in the Design Standard Toggle Bar.   
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EXERCISE OVERVIEW  

In this chapter exercise, the existing roadway Baselines for SR61 and US98 will be imported from a provided 

(.gpk) file. A new Centerline of Construction for the SR61 roadway is required to improve the intersection with 

US98. The new intersection will be located across from the School entrance on US98. It will be a 90 degree 

angled intersection from US98.  The centerline will require a new horizontal curve following the PPM design 

guidelines as follows. In order to provide minimal property impacts to a local business on SR61 the alignment 

will be offset from existing baseline to the west 30 feet and will re-join SR61 at a small skew that does not require 

a horizontal curve. 

 

Design Geometrics and Criteria Plans Preparation Manual, Volume 1 

Design Speed 50 MPH 

Facility Urban Arterial with Curb  

Maximum Tangent Deflection w/out curve 1 degree  Table 2.8.1a 

Minimum Horizontal Radius 881 feet  Table 2.83 

Minimum Length of Curve 750 feet  Table 2.8.2a 

 

2.1 Design New SR61 Centerline  

2.2 Import Side Roads 

2.3 Import Baseline 

2.4 Create ALGNRD01 Stationing Annotation Models 
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Exercise 2.1 Import Baseline  

Import Baseline In this exercise, the user will create a new design file and import chains from the job00.gpk file 

provided from the survey.  

1. (Optional) Extract the 22049555201(2).zip file in the Data Set folder to the c:\e\projects folder. 

2. From the desktop FDOTSS4 folder, double-click on the Create Files icon.  

  

3. Create a DSGNRD01.dgn file with the dialog as shown below. 

  

a. Click Create to create the file, DSGNRD01.dgn.  

b. Click Open File, DSGNRD01.dgn displays.  

c. Set/Update Plot Scale displays. Use the default settings and click OK. 

d. Click OK to close the Create File/Project dialog. 
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4. If the SURVRD file exists, Use the Attach Survey Reference Files tool from the FDOT 

Menu. Otherwise skip to step 7. 

 

5. Select the SURVRD01.dgn file. 

 

6. From the MicroStation menu select File > References to view the attached files: 

 

7. From the MicroStation menu select File > References and attach the following files: 

• C://e/projects/survey/TOPORD01.dgn (disregard if SURVRD exists) 

• C://e/projects/rwmap/RWDTRD01.dgn 

• C://e/projects/roadway/AERIALS.dgn 

8. Fit View and Save Settings, select Ctrl F. 

  



Chapter 2 __________________________________________________________ CENTERLINE ALIGNMENTS - Import Baseline 

2-6 ©2018 FDOT  FDOT Roadway Design and 3D Modeling 

9. Change the Task Menu to Civil Tools. 

 

10. Use General Geometry, Import Geometry tool and select the job00.gpk file in the Roadway 

folder.  

 

a. Navigate to the Alignment > No Features folder.  

b. Click in each box to select BL98 and EX-61. 

 

c. Click Import.  
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11. Zoom to the intersection of EX-SR61 and US98, hover over the baseline to verify the 

alignment imported in the previous step. 

 

12. Use Horizontal Geometry, Set Feature Definition tool.  

 

a. Set the Feature Definition to Baseline(BL). 

 

b. Select both EX-SR61 and US98 line, then click Reset to set the Baseline(BL) feature 

on the lines.  

13. Select the Element Selection to exit the command. 
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Exercise 2.2 Design New SR61 Centerline  

This exercise will use several Construction lines to create the final Centerline as shown below. 

 

➢ ConstLines1 

1. Locate the Driveway into the school off US98 between the baseball field and the parking lot. 

 

2. Now that the new intersection is located, turn the display OFF for the Aerial Reference file. 
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3. Use the Horizontal Geometry, Line Between Points tool.  

 

a. Use Feature Definition ConstLinesBlueDash and Name ConstLines1.  

b. Start a line perpendicular to BL98 and ending at in the middle of the Driveway. Be 

careful not to snap to anything on the second point. 
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➢ ConstrLines2 

1. Use Horizontal Geometry, Simple Line From Element tool. 

 

2. Use Feature Definition ConstLinesBlueDash and Name ConstLines2 

3. First select ConstLines1, then use the AccuSnap to locate the beginning of the line at BL98. 

 

4. Enter a Distance of -2000 feet. Data point in the View to accept the Distance. 

5. Data point to accept Trim None. 
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➢ ConstrLines3 

1. Use the Horizontal Geometry, Single Offset Entire Element tool.  

 

2. Use Feature Definition ConstLinesBlueDash and Name ConstLines3.  

3. Data point in the View to create a line -30 feet Offset to EX-61.  

4. Uncheck the mirror option to No, and click in the View.  

 

5. Once the new line is created, turn the Display OFF for the TOPORD Reference file.  
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➢ ConstrLines4 

Next step, create a line from the Offset line to intersect the EX-SR61 line at a 1 degree deflection angle. 

1. Find the Azimuth angle of EX-61, select the element and click the Context Menu Description. 

Copy the bearing value into the buffer space selecting Ctrl C <OR> right-click Copy. 

 

2. Use the Horizontal Geometry, Line Between Points tool.  

 

3. Use Feature Definition ConstLinesBlueDash and Name ConstLines4. 

4. Start a line at the intersection of ConstLine2 and ConstLine3 enter a value of 2000 feet for 

the Length and use the Bearing in the buffer as the Line Direction minus 1 degree. 

 



CENTERLINE ALIGNMENTS - Design New SR61 Centerline ________________________________________________ Chapter 2 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  2-13 

5. Use MicroStation Trim to Element and extend the ConstLines4 line to intersect EX-61. This 

step will create an interval element ConstLines5. 

 

➢ Verify the Construction Lines Maintain Design Intent 

1. Change the Active Level to Scratch1_dp. Use MicrosStion Drawing to Place Circlee with 

MicroStation with a center at the end of ConstrLines5 

  

2. Open View 4 and use Copy View from View 1. Zoom into the School Entrance in View 4 
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3. Move the location of the ConstLines1 and check the end of ConstLines5 to see if the location 

has been corrected.  

 1: Select the first line and Use the manipulator tool  handle in the middle to move parallel location. 

 

 2: Select ConstLines5, Use MicroStation Undo/ Redo to see the end change location. 

  

4. Select Ctrl Z to undo change. 

5. (Extra Exercise) Change the Offset Distance of ConstrLines3 from -30 to -40 to verify that 

the end of ConstrLines4 will change.  

6. Select Ctrl Z to undo change. 
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➢ Construct a Horizontal Curve between ConstLines2 and ConstLines5 to Meet 

Geometric Standards.  

1. Use the General Geometry, Design Standards Toolbar.  

   

2. Set Active the Design Facility Standard to: Arterial, Flat, Urban, with Curbs, 50 MPH. 

 

3. Activate the Toggle Active Design Standard icon.   
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4. Use the Horizontal Geometry, Simple Arc tool.  

   

5. Use Feature Definition ConstLinesBlueDash and Name ConstLines6. 

6. Create a Radius between ConstLine2 and ConstLine5 using the default value 881.4738, Set 

Trim/Extend to Both. 
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➢ Make a Longer Driveway into the School. 

1. Use Horizontal Geometry, Line Between Elements tool;  

 

2. Turn ON the TOPORD file. 

3. Use Feature Definition ConstLinesBlueDash and Name ConstLines6. 

4. First, snap to the end of the first Construction line placed, ConstLines1. 

5. Then snap to the end of the Existing Centerline in the TOPORD file. 

 

Note After the line is constructed a Warning icon may appear on the line because the Active Design Standard 
icon is being toggled ON and the tangent length may be less than the minimum 100 feet.  
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➢ Next, Create a Centerline of All the ConstrLines.  

1. Use the Horizontal Geometry, Complex by Element tool.  

 

2. Create the new Alignment by connecting the elements. Use Feature Definition Centerline(CL) 

and Name SR61, with no spaces. Use the Manual Method. 

 

3. Be careful to select at the school side first and near the start of the line.  
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4. Continue until New Centerline is constructed as shown below.  

 

➢ Set a Begin Station Value at the Intersection of BL98 

1. Use the Horizontal Geometry, Start Station tool. 

2. Set a Begin Station value of 700+00 at the 

intersection of SR61 and BL98. 

3. Select the new SR61 Centerline(CL). 

4. Use AccuSnap to locate the Intersection with 

BL98 and data point to accept. 

 

 

5. Enter 70000 and select Enter <OR> data point to accept.  
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➢ Describe the New Centerline Geometry 

1. Use Horizontal Geometry, Horizontal Geometry Report tool.  

 

2. Select the SR61 Centerline (CL). Use the settings below at the prompt to generate the report 

shown. 
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 If the Stationing format is not displayed correctly, In the Bentley Civil Report Browser, select Tools Format 
Options 

 

 

➢ Save the SR61 Centerline to the job00.gpk 

1. Use the General Geometry, Export to Native tool and save the SR61 Centerline to the 

job00.gpk file. 
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Exercise 2.3 Import Side Roads  

1. Use General Geometry, Import Geometry tool. 

2. Navigate to the Alignment > NoFeature folder. 

 

3. Select the following GEOPAK chains from the job61.gpk file: Friendship, Friendship2.  Be 

certain to Uncheck the Profile before clicking the Import button..  

Note This file may be named job61.org in the dataset, copy and rename it job61.gpk 

 

4. Use Horizontal Geometry, Set Feature Definition tool.  

   

a. Set the Feature Definition to Centerline(CL). 

b. Select both FREINDSHIP and FREINDSHIP2 line, then click Reset to set the 

CenterLine(CL feature on the lines.  

c. Select the Element Selection to exit the command. 
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Exercise 2.4 Create ALGNRD01 Stationing Annotation Models  

1. From the FDOTSS4 menu, select Actions > Create/Edit File. 

 

2. Create an ALGNRD01.dgn file with the dialog as shown below. 

  

3. Click Create to create the file, ALGNRD01.dgn. Click Open File, ALGNRD01.dgn displays. 

Click OK. 

Note This tool now creates multiple models to display Stationing at different scale once the Open File button is 
clicked.  
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4. Verify the Active Model in the design file is ALGNRD_50. 

 

5. In MicroStation, select GEOPAK > ROAD > Design & Computation Manager.  

 

a. Navigate to the Roadway Design > Plan Features folder and select CL Centerline of 

Construction (with stationing). 
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b. On the CL Centerline of Construction dialog, check the Place Influence box and 

click the Draw Plan & Profile button.  

 

c. On the Open Job dialog, browse to the job00.gpk Job file and click OK. 

 

6. On the Draw Plan & Profile dialog,  

a. Change the Element Type to Stationing.  

b. Enter 50 for the Label Scale.  
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c. In the Select Chain to Draw List box, select on SR61.  

 

7. Close each of the Design & Computation Manager dialogs (3) and click Fit View to see the 

results. 

 

8. In MicroStation, select File > Save Settings <OR> select Ctrl F. 

9. (Optional) Continue to add the Stationing Annotations by repeating these steps for the different 

scale models.  

10. Return / Open to the DSGNRD01 file and attach the Reference in the ALGNRD01_50 Model 

file.  
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3 2D PLANS  

INTRODUCTION  

This chapter will continue to use the OpenRoads Technology for Horizontal Geometry. Rather than use 

traditional MicroStation element creation tools, these exercises will provide participants with practice using the 

Civil Tools.  Using Civil rule-based Feature Definitions assures design intent is incorporated into the two 

dimensional (2D) plan layout. This will, in turn, prove valuable when design changes or “what if scenarios are 

needed or tested.   

This chapter also introduces two (2) important new OpenRoads Technologies for creating geometry / line 

work while designing in FDOTSS4.  They are: 

• Civil AccuDraw  

• Civil Cells 

CIVIL ACCUDRAW 

As defined in the Bentley Civil Tools help files: 

“Use Civil AccuDraw to allow precise input of points, whether the points are physical points or 

end points of linear geometry. The Civil AccuDraw values can be persisted as rules on the points 

by locking both values in the Civil AccuDraw input. Several methods can be used, among them 

are: 

• Distance and Direction, to set the order of ordinate entry to distance then direction, 

with both sharing a common point of origin. 

• Dist-Dir, to set the order of entry to distance for the first ordinate then direction for the 

second ordinate, without a common point of origin. 

• Dist-Dist, to set the order of entry to distance for the first ordinate then distance for the 

second ordinate, without a common point of origin. 

• XY, to set the order of ordinate entry to X-axis then Y-axis, with the two sharing a 

common point of origin. 

• DX DY, to set the order of ordinate entry to the difference in X coordinate then the 

difference in the Y coordinate, with the two sharing a common point of origin. 

• Station-Offset, to set the order of ordinate entry to station identification then offset 

value, with both sharing a common point of origin 

 The delivered methods are those configured by default. These defaults can be edited, removed, 

or additional methods may be added. 
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CIVIL CELLS 

As defined in the Bentley Civil Tools help files: 

“A civil cell is a collection of civil elements - geometry, templates, and terrain models - which 

can be placed repeatedly in a design. The collection of civil elements will have been created 

relative to one or more reference elements. When you place the civil cell, you choose the new 

reference elements, and a new collection of civil elements is then created relative to them. A civil 

cell can therefore be thought of as a copy of the original collection of civil elements, relative to 

the geometry of the new reference elements. Civil cells can be 2D or 3D. They can consist of 2D 

(plan) elements only, or 3D elements (2D elements with profiles), and can include terrains, 

linear templates, area templates, and simple corridors. 

When the new civil elements are created, all of the rules associated to them are also created. 

This means that the new civil elements retain their relationships, both with each other and with 

the reference elements, and therefore know how to react when these relationships change. In 

addition, the Civil and MicroStation toolsets can still be used on the new civil elements, to adjust 

and further refine the design as required, because there is no difference between a civil element 

created by a civil tool, and one created by placing a civil cell. 

Civil cells can save a lot of time and effort, because they replicate the complete series of steps 

needed to create the civil elements. They also help to ensure compliance with design standards, 

by making a civil cell available to the design team.  

EXERCISE OVERVIEW 

3.1 Preparation for 2D Plans 

3.2 BL98 Milling Limits 

3.3 BL98 Side Street 

3.4 BL98 Widening 

3.5 BL98 Widening Taper Line 

3.6 For SR61 New Construction Template Lines 

3.7 Add Right Turn lane on BL98 

3.8 Add the School Entrance right Turn Lane off BL98 Intersection 

3.9 Create/Edit the Intersection Curve Radii 

3.10 Trim Back Sidewalk and Curb Lines to the Curve Radii 

3.11 Use Civil Cell Technology to Place Curb and Sidewalk Around the Radii 

3.12 Create a Custom Civil Cell for Other Radii 

3.13 Place Left Turn with Traffic Separator 

3.14 Place Right Turn Island 

3.15 For BL98 Intersection Crosswalks Lines 

3.16 Create BL98 Turnouts 

3.17 For BL98 Intersection Shoulders 

3.18 For Friendship Intersection 
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Exercise 3.1 Preparation for 2D Plans 

1. (Optional) Extract the 22049555201(3).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22049555201\roadway\ folder in the 

FDOTSS4 Workspace in MicroStation. 

Exercise 3.2 BL98 Milling Limits 

In this exercise the exiting pavement edge lines from the TOPORD file are copied to be used as the Milling Lines 

for the proposed improvements. 

1. Use MicroStation References to attach and display the TOPORD01 and RWDTRD01 

Reference files. 

 

2.  Use MicroStation Level Display to turn OFF all the TOPORD01 Levels except the 

PavtAsphalt_ep.  
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3. Use MicroStation References, Merge into Master tool to copy existing edge PavtAsphalt_ep 

lines into the active DSGNRD01 file. 

  

4. Use the Horizontal Geometry, Line Between Points tool.  

  

5. Create a PavementMilling(ML) line across the existing intersection of SR61 and BL98. 

  



2D PLANS - BL98 Milling Limits _______________________________________________________________________ Chapter 3 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  3-5 

6. Use MicroStation Break Element on the PavtAsphalt_ep line string elements where the new 

PavementMilling(ML) line intersects. 

 

7. Repeat these steps for the other side roads along BL98. 

8. Create a Selection Set of the PavtAsphalt_ep by level.  
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a. Subtract out of the Selection Set the Intersection lines at SR61; these will not be 

PavementMilling(ML) lines. 

 

b. And also subtract out of the Selection Set the Intersection lines at Friendship Road. 
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9. Use the Horizontal Geometry, Set Feature Definition tool.  

 

10. Data point to change the elements to the Feature Definition, PavementMilling(ML). 

 

11. Change the Selector tool back to New and verify the New Feature Definition by hovering over 

a line until the Context Menu displays. 
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Exercise 3.3 BL98 Side Street 

In this exercise Civil AccuDraw is used to help construct a side road centerline on BL98. 

1. MicroStation AccuDraw and Civil AccuDraw should never be toggled ON at the same time 

because both use some of the same Shortcut Key ins. Toggle OFF the MicroStation 

AccuDraw. 

 

2. Use General Geometry, Civil AccuDraw tool to activate the Civil AccuDraw toolbar. 

 

3. Click on the Mode Station-Offset to toggle ON. 

 

4. Use the Horizontal Geometry, Line Between Points tool to create a ConstLineBlueDash line 

perpendicular to the BL98 at Station 39+00 for a Length of 80 feet used as a side road 

centerline. Here are the steps to use Civil AccuDraw with the Station Offset option: 
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 On the cursor prompt, tab to the offset field and use the Shortcut Key-in o, and select 
the reference line BL98. The cursor will now track the station and offset.  

 

 

a. For the first data point, set the Snap Locator button to Perpendicular, and select on 

the BL98. 
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b. For the second point tab to the Station field in the AccuDraw Cursor Prompt dialog, 

enter Station value 39+00, select Enter to lock in on the station. 

 

c. Tab to the Offset field in the AccuDraw Cursor Prompt dialog, Enter Offset value 80, 

select Enter to lock.  

 

d. Data point in View to place the point. 
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Exercise 3.4 BL98 Widening 

 In this exercise, the proposed Pavement Lines used for widening on BL98 are created at the following locations: 

 

 

1. Toggle OFF Civil AccuDraw tool. 

 

2. Use the Horizontal Geometry, Single Offset Partial tool.  

 

a. Select the BL98 line at the prompt to Locate Element. 

  

 
START 

STATION 
OFFSET LENGTH 

1 28+00 16 feet 500 feet 

2 33+00 32 feet 600 feet 

3 30+00 -24 feet 300 feet 

4 33+00 -24 feet 1000 feet 
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b. Fill in the Single Offset Partial dialog as shown below. 

  

c. Data point in the View to accept the Offset. 

d. Data point in the View to accept Length. 

 

e. Data Point in the View to accept No at the Mirror option prompt. 

3. Repeat this procedure for each of the PavementAsphalt(EOPA) widening lines diagram and 

table above.  
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Exercise 3.5 BL98 Widening Taper Line 

In This exercise a tapered Pavement Asphalt (EOPA) line off BL98 is created at the following location. Select 

Alt to enter the End Station. 

 

 Toggle On the Civil AccuDraw. 

1. Use the Horizontal Geometry, Variable Offset Taper tool. 

 

2. Select the BL98 element to offset from. 

3. Enter the Station at 39+00 and select Enter to lock the value. 

4. Tab to the Offset, enter 20 and select Enter to lock the value. 

  

START 

STATION 

START 

OFFSET 
END STATION END OFFSET 

39+00 20 feet Alt to end Station Lock Snap Nearest 
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5. Data Point in the View to set the first point. 

 

6. Select Alt key to lock the End Station value. 

7. Set the AccuSnap tool to Nearest, hover over the right PavmentMilling(ML) until the Snap 

Mode displays. 

 

8. Data Point to place the second point and complete the command.   
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Exercise 3.6 For SR61 New Construction Template Lines 

First, it is necessary to create a Template Limits line for the Project Typical PPM Civil Cell. This is a Construction 

type element which is used to define the Begin and End Station limits.  

1.   Use the Horizontal Geometry, Single Offset Partial tool. 

 

2. Create a Feature line, ConstLinesGreen. 

a. Select the SR61 Centerline(CL). 

b. Set the Offset to 0.00. 

c. For the first point, set AccuSnap to Intersection and select the intersection of SR61 and 

BL98. 
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d. For the second point, zoom out to the first intersection after the end of the SR61 curve 

and snap to the right PavementMilling(ML) of existing SR61 <OR> Key in Station 

716+50. 

 

 Use Intersect Snap and to place first point and Key Point snap for the second point.   

3. Use Civil Cells task, Place Civil Cell tool. 

   

a. Navigate to the FDOT_Templates.dgnlib, 4 Lane Divided Arterial(45 MPH or Less) 

and select PPMEXHIBIT TYP5. 

 

b. Click OK and follow the prompts to complete the Place Civil Cell command. 



2D PLANS - For SR61 New Construction Template Lines ___________________________________________________ Chapter 3 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  3-17 

c. Locate Reference Element, select the GreenConstLine. 

 Use the tab key to after clicking on an element to get to the last place GreenConstLine. 

d. Reset to Skip View Alternates. 

e. Data point to accept Civil Cell Placement. 
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4. Change the Front Sidewalk Utility Strip Width to 0ft and the Sidewalk Width to 6ft,  

a. Select the SidewalkFront Feature and zoom to find the Context Menu near the 

middle of the element. 

 

b. Change the SidewalkFront Dimension from 3 to 0. 

c. Change the SidewalkBack from 5 to 6.  

d. Repeat this for both sides of the roadway.  
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Exercise 3.7 Add Right Turn Lane on BL98  

This exercise uses Civil Cells to add a right turn lane to the BL98. 

1. Use Civil Cells, Place Civil Cell tool. 

   

2. From the Place Civil Cell dialog, navigate to the FDOT _Intersections.dgnlib and select Right 

Turn Lane. 

 

3. At the prompt, for the first Reference, select the widening PavementAshaplt(EOP) line. 

4. For the second Reference, select the SR61 Right EOP Out PavementAshaplt(EOP). 

5. Reset to Skip Elements to View Alternatives. 
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6. Data point to accept Civil Cell Placement. The right turn lane is added. 

 

7. Edit the storage length for first Right Turn Lane placed, select the tangent line and change the 

Length from 135 to 500 feet. 

 

8. Use MicroStation Trim to Intersection to correct the PavementAsphalt(EOPA) lines. 
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Exercise 3.8 Add the School Entrance Right Turn Lane off BL98 Intersection 

1. Use the Horizontal Geometry, Single Offset Partial tool.  

 

2. Create the side road PavementAsphalt(EOPA) opposite SR61 left offset -23 feet.  

a. For the beginning, snap to beginning of SR61.  

b. For the end, snap to the BL98 widening line end point at SR61.  

c. Uncheck Mirror to set to No. 
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3. For the opposite side, use the Horizontal Geometry, Single Offset Partial tool.  

 

4. Create the side road PavementAsphalt(EOPA) opposite SR61 Left Offset 39 feet.  

a. For the beginning, snap to beginning of SR61. 

b. For the end, snap to the BL98 widening line end point at SR61.  

c. Uncheck Mirror to set to No. 

 If necessary, Let the tool place the line on the opposite side and edit it after it is placed  

 

5. Add another Right Turn Lane Civil Cell on the opposite side of the intersection. 
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a. At the prompt, for the first Reference, select the widening PavementAshaplt(EOPA) 

line. 

b. For the second Reference, select the intersection PavementAshaplt(EOPA) line. 

 

c. Data point to accept Civil Cell Placement. The Right Turn Lane is added. 

6. Click on the Select Tool Set icon to exit the Place Civil Cell command <OR> F6 Function 

Key. 

 

7. Edit the storage length for the second Right Turn Lane placed, select the tangent line and 

change the Length from 135 to 365 feet. Change the lane width to -16 feet. 
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Exercise 3.9 Create/Edit the Intersection Curve Radii 

1. Use the Horizontal Geometry, Simple Arc tool.  

 

2. Create/Edit the Curve returns. 

3. Select Feature Definition, PavementAsphalt(EOPA) to place remaining curve radii.  

4. Follow the cursor prompt to select the two Roadway PavementAsphalt(EOPA) reference 

lines.  

 Select the two PavementAsphalt(EOPA) in each quadrant. Use the value shown and trim both for each of 
the following quadrants:  Southwest 110 feet, 

Southeast 60 feet,  
Northeast 60 feet,  
Northwest 60 feet 
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Chapter 3 ______________________________________________________ 2D PLANS - Create/Edit the Intersection Curve Radii 

3-26 ©2018 FDOT  FDOT Roadway Design and 3D Modeling 

 

5. Select F11 to open the Project Explorer menu options; change the tab to Civil Model. 

 

6. Navigate to the Civil Cells listed in the active design file, right click on each and select Drop 

Civil Cell. This allows for editing the Civil Geometry elements individually in future 

exercises.  
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Exercise 3.10 Trim Back Sidewalk and Curb Lines to the Curve Radii 

This exercise takes advantage of design intent to modify the curb and sidewalk lines off SR61 to the new curve 

radius end point. 

1. Select the LT_CURB_FACE_OUT line. 

 

2. When the Context Manipulators display, zoom into the beginning point and select the Start 

Station handle OR the Station value to move the end. 
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3. Drag the handle while zooming out and select the End Radius point to move the point.  

 

4. Notice the results. The curb and sidewalk move as one because of the built in design intent 

relationship. 

 

5. Repeat these steps to move the RT_CURB_FACE_OUT line back to the curve radius on the 

right Roadway. 
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Exercise 3.11 Use Civil Cell Technology to Place Curb and Sidewalk Around the Radii 

1. Select Civil Cells, Place Civil Cell tool. 

  

2. Navigate to the FDOT _Intersections.dgnlib and select the CurbSidewalkLines civil cell. 

 

3. At the prompt, select the SW EOPA radius line, reset to View Alternates and then data point 

to accept the Civil Cell Placement. 
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4.  Edit the SidewalkFront to be 0 feet from the CurbBack line at the middle of the element. 

 

5. Edit the SidewalkBack line to be 6 feet from the SidewalkFront line of the element. 
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Exercise 3.12 Create a Custom Civil Cell for Other Radii 

1. Select Civil Cells, Drop Civil Cell tool. 

   

2. Select the CurbSidewalkLines Civil Cell in the View and data point to drop the Civil Cell. 

 Move the cursor over the curb or sidewalk lines to see it highlight 

 

3. Use Civil Cells, Create Civil Cell tool. 

  

a. Enter the Civil Cell Name: Custom CurbandSidewalkLines. 

 

b. Data point to accept the new Name. 
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c. At the prompt, locate Reference Element and select the SW EOPA line. 

 

d. Reset to Locate Reference Element. 

e. Reset to Optional Reference. 

f. Data Point to accept Civil Cell. 

4. Use the new Civil Cell to place for the other Radii; use Civil Cell, Place Civil Cell tool. 

   

a. If the Custom CurbandSidewalkLines is not active, navigate to the Active DGN and 

select it from the list. Click OK. 
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b. At the prompt, select the NW EOPA Radius line. 

 

c. At the prompt, select Element to View Alternatives, move the cursor over the EOP 

line and click on the Arrow to reflect the Civil Cell to the correct side. 

 

d. Reset to View alternates.  
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e. Data Point to accept the Civil Cell Placement. 

 

5. Repeat these steps to place the Custom CurbandSidewalkLines Civil Cell on the NE EOPA 

Radius. 

 

6. Leave the SE Radius without curb and sidewalk. 
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Exercise 3.13 Place Left Turn with Traffic Separator 

1. Use Civil Cells, Place Civil Cell tool. 

  

a. Navigate to the FDOT _Intersections.dgnlib and select Left Turn with TS civil cell. 

 

b. At the Locate Reference Element Centerline, select the BL98 line in the View. 

 

c. At the Locate Reference Element PavementAsphalt(EOPA), select the 

RT_PVT_EOP_IN line in the View. 
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 For the direction of travel l, this is always the left median EOP line 

 

d. Click on the Arrow of both Reference Elements to View Alternates, when the Green 

Turning Radius and Traffic Separator are both in the correct place, Reset to skip. 
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e. Data point to accept the Civil Cell Placement and view the left turn lane on SR61 at 

BL98 Intersection. 

 

2. Use MicroStation Trim to Intersection tool. 
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3. Trim the curb median elements at the begin taper as shown. 

 

4. Use MicroStation Trim to Element tool. 

 

5. Trim the elements at the Curb Median lines at the Traffic Separator as shown, leave the green 

line. 
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6. View the placed left turn, change the Turning Radius from 100 feet to 75 feet.  

 

7. View the placed left turn, change the Storage Length from 200 feet to 300 feet.  

 Select the green line, then select the length text.  
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8. Zoom to the Turning Radius Offset Dimension, change the value from -1 feet to -4 feet.  
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Exercise 3.14 Place Right Turn Island 

1. Use Civil Cells task, Place Civil Cell tool. 

  

2. Navigate to the FDOT Intersections.dgnlib, select Right Turn Island. Click OK. 

 

3. Select the first PavementAsphalt(EOPA) lines.  
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4. Select the second PavementAsphalt(EOPA) line. 

 

5. Reset to Skip Alternates. 

6. Data Point to accept the Civil Cell. 
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➢ Change the Right Turn Island Parameters 

1. Change ConstLinesBlueDashed Arc Radius from 110 feet to 126 feet. 

 

2. Check ConstLinesBlueDashed Begin Arc Offset is -18 feet. 
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3. Check ConstLinesBlueDashed End Arc Offset is -16 feet. 

  

4. Change the straight ConstLinesBlueDashed SR61 EOP Offset from 1 foot to -16 feet. 
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5. Check ConstLinesBlueDashed BL98 EOP Offset is -16 feet. 

 

6. Change Island EOP Offset from the ConstLinesBlueDashed BL98 from -5 feet to -2 feet. 
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7. Change Island EOP Offset from the ConstLinesBlueDashed SR61 from 1 foot to 6 feet. 

 

8. Change Island Radii to 4 feet. 
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9. Change the Island ingress Offset -6 feet and Island Egress Offset -3 feet. 

 

10. Move the Offset handles to the Radius Point. 
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11. Change the Active Level to Miscellaneous0. 

 

12. Use the MicroStation Crate Region Flood tool, select the center of the island, and then data 

point to accept the closed element. 
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13. Use the MicroStation Select tool to view the properties of the new island. Record the Area 

_____. 

 

14. View the modified Right Turn Island. 
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Exercise 3.15 For BL98 Intersection Crosswalks Lines 

1. Use the Horizontal Geometry, Single Offset Partial tool. 

 

2. Create a Partial Offset line from BL98 -52 feet across the intersection. Use Feature Definition 

ConstLinesBlueDash and Name ConstLineA. 

 

3. Use Horizontal Geometry, Line Between Points tool. 
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4. Create a line from the curve center to the midpoint of the Island Radius EOP.  Use Feature 

Definition ConstLinesBlueDash and Name Line B. 

 

5. Use the Horizontal Geometry, Single Offset Partial tool. 
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6. Create a Partial Offset line from SR61 across the intersection.  Use Feature Definition 

ConstLinesBlueDash and Name ConstLineC.  

 Snap to the mid-point of the radii. 

 

Note Use these lines in later exercises to place 3D Sidewalk Ramp Civil Cells.  
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Exercise 3.16 Create BL98 Turnouts 

In this exercise the additional rural turnouts can be added to BL98. 

1. Use Horizontal Geometry, Single Offset Entire Element tool. 

 

a. Select the ContLineBlueDash Turnout line. 
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b. Accept the -20 feet Offset and Mirror. 

 

2. Use Horizontal Geometry, Simple Arc tool. 

 

a. Place the Radius on both side and set Trim/Extend to Both. 
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b. Change the Geometry to fit the existing driveway. 

 Use the centerline snap and dimensions to modify the location, length and angle. Use the Offset 
PavementAsphalt(EOPA) Dimensions to change the width. 

 

3. (EXTRA Exercise) Repeat the steps above to create an addition Turnout as shown below  

<OR> use the Civil Cell, FDOT Intersection.dgnlib, and Side Road Turnout.  

However, first place the Side Road Centerline.  

 

 When using the Side Road Turnout Civil Cell; there was an issue delivered. Drop the placed civil cell, fit 
the view and delete the extraneous element placed. 
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Exercise 3.17 For BL98 Intersection Shoulders 

This exercise uses the PavementAsphalt(EOPA) to create the 5 feet ShoulderPaved(PSHLD) Offset lines.   

1. Turn ON the ShldrPaved level.  

2. Use Horizontal Geometry, Single Offset Entire Element tool. 

 

3. Set the Offset to 5 feet and the Feature Definition to ShoulderPaved(PSHLD). 

 

4. Select the PavementAsphalt(EOPA) lines from the previous steps. 

5. Repeat these steps to add the remaining Shoulder lines for the widening along BL98. 

6. View the intersection below for complete details. 
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Exercise 3.18 For Friendship Intersection 

1. Use Civil Cells, select Place Civil Cell tool. 

  

a. From the Place Civil Cell dialog, navigate to the FDOT _Intersections.dgnlib and 

select Side Road Turnout. 

 

b. Add Side Road Turn Out civil cell to both sides of the Intersection with Friendship 

and Friendship 2 Centerlines.  

 When using the Side Road Turnout Civil Cell; there was an issue delivered. Drop the placed civil cell, fit 
the view and delete the extraneous element placed. 

c. Use Modify Element to clean the extra curb line and sidewalk lines across the 

intersection. 

d. Change all Radii to 35 feet. 

e. Change Friendship2 Side Road Offsets to 20 feet. 

f. Change Centerline Length to 100 feet. 
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2. Use Civil Cells, Place Civil Cell tool. 

  

a. From the Place Civil Cell dialog, navigate to the FDOT _Intersections.dgnlib and 

select Left Turn with TS. 

 

b. Use FDOT _Intersections.dgnlib, Left Turn with TS Civil Cell to a place left turn lane 

on SR61 at Friendship Intersection. 



2D PLANS - For Friendship Intersection _________________________________________________________________ Chapter 3 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  3-59 

c. For the first Reference element, select the Friendship Rd Centerline. 

 

d. For the second Reference element, select the left median PavementAsphalt(EOPA) 

line. 
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e. Reset to Skip Alternates and data point to accept Civil Cell Placement. 

f. Change the turning Radius to 50 feet. 

g. Change the turning lane storage length to 300 feet. 

 

3. Use MicroStation Trim to Element tool. 
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4. Move the LT_PVT_EOP_IN to the beginning of the Traffic Separator. 

 Use the ConstLinesGreen as the cut element 

 

5. Use MicroStation Trim to Intersection tool. 
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6. Trim the Curb and EOP lines to the beginning of the median Taper line. 

 

7. (EXTRA Exercises) Complete the Intersection with Civil Geometry tools as follows below: 

a. Add Curb lines for each of the Radius.  

b. Trim Sidewalk lines into the Radius Curb lines. There is no sidewalk along SR61 north 

of Friendship Road. 

c. Add Asphalt Pavement(EOP) Taper lines from the Intersection Radii at Friendship 

to the End Station of SR61 11 left. 

d. Add ShoulderPaved(PSHLDR) lines to both sides along the Taper. 

 

 



 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  4-1 

4 PROFILES 

INTRODUCTION 

This chapter will continue to use the OpenRoads Technology Civil Tools, Vertical Geometry. Rather than use 

traditional GEOPAK Profile creation tools, these exercises will provide participants with practice using the Civil 

Tools.  Using Civil rule-based Feature Definitions assures design intent is incorporated into the vertical geometry 

layout. This will be beneficial for design when changes need to be reflected and considered through-out the 

development process. 

This chapter introduces important new OpenRoads Technologies for creating vertical geometry line work 

while designing in FDOTSS4.   

OPEN PROFILE MODEL  

The Open Profile Model generates a MicroStation View that presents the desired feature in profile thus enabling 

the Vertical Geometry tools to interact with the chosen feature. 

Open the Civil Tools Task pane to the Vertical Geometry section then click the Open Profile Model icon. Move 

the cursor into the Workspace and note that it is accompanied by a command prompt requesting that you, "Locate 

Plan Element". Select the element with which you wish to work in profile. The cursor is now equipped with a 

prompt that says, "Select or Open View". Data point or left-click in it a view to present a profile of the selected 

element.  If no other view is open, click one of the view icons on the View Groups toolbar then click again in the 

new View. Vertical Geometry tools can then be used to edit/create vertical profile data in the design. 

EXERCISE OVERVIEW 

4.1  Preparation for SR61 Profile 

4.2 Create SR61 Profile 

4.3 Edit SR61 Profile 

4.4 BL98 Profile 

4.5 Friendship Profile 
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Exercise 4.1 Preparation for SR61 Profile 

1. (Optional) Extract the 22049555201(4).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22049555201\roadway\ folder in the 

FDOTSS4 Workspace in MicroStation. 

3. Use MicroStation, References tool to attach the Existing Terrain file,  

c:\e\projects\22049555201\survey\ GDTMRD02 

Note If the SURVRD file exist the SURVRD01 -GTMRD logical can be used 

 

4. Select the Tasks list and set the Menu Tasks to Civil Tools. 
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5. Use the Terrain Model, Set Active Terrain Model tool. 

 

6. At the cursor prompt, select the Terrain Boundary green line from the attached GDTMRD02 

Reference file <OR> pick it from the list on the dialog.  
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Exercise 4.2 Create SR61 Profile 

In this exercise, several Vertical Geometry tools are used to create a proposed profile for SR61. 

1. Use the Vertical Geometry, Open Profile Model tool. 

 

a. At the cursor prompt, select on the mainline SR61 Centerline. 
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b. At the prompt select to open View 3, then data point in the View. 

 

2. Use the Vertical Geometry, Define Profiles by Best Fit tool. 
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a. At the cursor prompt, data point to Make Complex Element option.  Enter the Profile 

Name , SR61-PR, and then data point on the green line in the profile. 

 

b. Follow the prompts to enter the Best Fit Parameters as shown. 

    

3. Use the General Geometry, Design Standards Toolbar tool. 
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4. On the Design Standards Toolbar, navigate to Arterials, Flat Terrain, Urban, With Curb 

and Gutter and select 55MPH.  Toggle On the Active Design Standard. 

 Be sure to set left and right fields to 55 MPH 

 

5. Use the General Geometry, Set Design Standard tool. 

 

a. At the prompt, select the Best Fit Profile created in the previous steps.  The profile 

now has a Vertical Design Standard rule placed on it. 

b. Using the Select Tool,  select the profile element and view its properties 

in the Element Information dialog. 
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6. Use the General Geometry, Civil Message Center tool. 

 

a. The Civil Message Center dialog displays to view the results.  

Note It may be docked at the bottom of the screen, click on the Tab 

  

b. In the Civil Message Center dialog, select on the MicroStation tab. This will toggle 

Off all the general messages for MicroStation and leave only Errors and Warnings in 

the list. 
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c. In the Civil Message Center, review the Errors and Warnings. 

d. Select the first error, then right click over the error and select Zoom To from the 

popup box. 

  

e. Notice the Error is now centered in the profile view.  Hover the cursor over the Error 

icon to display the Error Message description. 

  

Note The values are given in whole stations, i.e. 3.5 station equals 350 feet 
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7. On the Design Standards Toolbar, navigate to Arterials, Flat Terrain, Urban, With Curb 

and Gutter and select 50MPH. 

 

8. Use the General Geometry, Set Design Standard tool. 

 

9. At the prompt, select the Best Fit Profile created in the previous steps.  Notice the Error icons 

are no longer displayed. 
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Exercise 4.3 Edit SR61 Profile  

This exercise changes the profile using Civil AccuDraw and MicroStation Modify Element. 

➢ Edit the Best Fit Profile  

In order to edit this profile, because it was created from the “Profile by BestFit” the rule must first be removed. 

1. Select the Profile Element and hover over the element to display the Context Menu.  

 

2. Select the Convert to Profile Rule tool.  

➢ Delete PIs 

1. Use MicroStation Modify, Delete Vertex tool. 
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2. Zoom to the beginning of the Profile and delete the first two Vertical Elements. 
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➢ Create Profile with Place Vertical Line 

New vertical civil profile elements are added to match the existing profile across US98. 

1. Use Vertical Geometry, Profile Line Between Points tool. 

-2  

2. Place Line Elements on the Existing Ground points to trace the Profile across BL98. 

Note This is not exact, simply trace a few lines.  
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3. Continue using the Profile Line Between Points tool 

a. Begin at the edge of the existing pavement or connect to the proposed profile line from 

the step above.  

 

b. In the Profile Line Between Points dialog, check the length and slope, length of 16 

feet and slope of -2%. Click a data point in the view to create the line as defined in 

the dialog.  
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c. Using Line Between Points to join the two profiles, place another Profile line between 

the “16’ at 2%” line and the Best Fit Profile. 

 

➢ Profile by VPI’s 

1. Zoom to the Beginning of the profile, Use Vertical Geometry, Profile Complex By VPI tool. 

 

2. Toggle OFF the Active Design Standard, set the Curve length to 50 feet. 

 Check that the Vertical Curve Type is set to Parabola 
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3. Start by snapping to the Beginning Point on the ground and complete the Profile Segment as 

shown below. 

 This is not exact, snap to 3 points 

 

4. Zoom to the End of the Profile, select the Line and move the last End Point to snap to the 

Existing Ground. 

 

 Click on the solid ball manipulator at the end of the line to move it in both directions 
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➢ Complex Profile Elements 

1. Use Vertical Geometry, Profile Complex by Elements tool. 

 

2. Keyin the name SR61_PR on the dialog and Start at the Beginning Profile line and create a 

new Connected Profile. 

 On the Profile Complex by Element tool setting, enter the Feature Name. This is the Profile Name assigned 
to the Profile. 
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➢ Profile Report 

1. Use Vertical Geometry, Profile Report tool. 

  

<OR> With the Profile selected, hover over the element to display the Context Menu and 

select the Profile Report. 
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2. The Bentley Civil Report browser displays the Vertical Alignment Review Report for the 

Profile. Close the Civil Report browser. 

 

3. Use Vertical Geometry, Set Active Profile tool. 

 

<OR> With the Profile selected, hover over the element to display the Context Menu and 

select Set Active Profile.   

➢ Export Profile 

1. Use the General Geometry, Export to Native tool. 

 

 Always check that the profile has a Feature Name before saving to the GPK file 

2. Select the SR61 Profile and save it to the job00.gpk file.  
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Exercise 4.4 BL98 Profile 

1. With the BL98 selected in the Plan View, hover over the element to display the Context Menu 

and select the Open Profile Model.  

2. Select View 3 to view the Existing Ground Profile for the mainline BL98 Centerline. 

 

3. With the Profile selected, hover over the element to display the Context Menu and select the 

first icon Properties 

4. In the name field enter BL98_EX 

 

5. With the Profile selected, hover over the element to display the Context Menu and select Set 

As Active Profile.  

 

6. Use the General Geometry, Export to Native tool, select the BL98_EX Profile and save it to 

the job00.gpk file.  
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Exercise 4.5 Friendship Profile 

1. With the Friendship selected in the Plan View, hover over the element to display the Context 

Menu and select the Open Profile Model. 

 

2. Select View 3 to view the Existing Ground Profile for the mainline Friendship Centerline. 
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3. With the Profile selected, hover over the element to display the Context Menu and select Set 

As Active Profile.  

  

4. Repeat the steps for Friendship2 Rd. 

5. Open View 2 using the F2 Function Key to see the 3D alignment cernterlines for the project 

6. Notice the 3D lines displays in View 2. 
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5 TEMPLATE DESIGN 

OVERVIEW 

The Create Template command generates the transverse geometry that is central to roadway design. A template 

comprises a series of points and components that represent break line features that are processed using Corridor 

Modeling commands. Roadway features that have been processed are saved to the design surface. Templates are 

stored in a template library (*.itl). 

TEMPLATE BASICS 

• The FDOTSS4 Workspace provides an extensive Template Library. 

• FDOTSS4 Templates closely follow CADD Manual, PPM and FDOT Design Standards and should be used 

to start a project.  

• FDOTSS4 Templates are designed from the PPM typical sections of the proposed roadway. 

• FDOTSS4 Templates are stored in the FDOTSS4.itl. 

• The FDOTSS4.itl Templates have Features, Point Names, Component Names, Parametric Constraints and 

Display Rules which follow a standard naming convention. 

• A project specific Template Library is created and FDOTSS4.itl file templates are copied to that library and 

are modified to meet the specific needs of the project. 

• New and modified templates should adhere to the template standards of the FDOTSS4.itl file. 

• When applied to a Corridor, templates are written to the design file and can be edited within the file.  

• Once templates are in a design file, they can be copied to another Project Template Library or design file.  

APPLYING TEMPLATES 

• Templates create a model of the proposed roadway. 

• Template points generate longitudinal break line features in the model. 

• Templates are used to create a proposed model of the roadway.  

• Templates are assigned to specific stations along an alignment at a specific interval, which are called template 

drops. 

• When a corridor is processed, the points of the template drops are connected to form a model of the roadway. 

• The connected template points also form longitudinal break line of the surface model. 

• The model can be exported into a traditional surface Terrain model.  
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CREATE TEMPLATE DIALOG 

The Create Template dialog is accessed from the Corridor Modeling, Create Template tool. To create or edit a 

Template Library, click the Open Create Template icon on the Corridor Modeling dialog. This displays the 

Create Template dialog. 

The Create Template dialog is the primary place where templates are created and edited. This is also where 

templates are copied from a standard Template Library to a project Template Library using Tools > Template 

Library Organizer. 

• User Definable Folder Structure 

• Create Templates, Components and End Conditions 

• Right-click Functions 

• Copy and Paste, and Drag and Drop 

• Red-colored Box Indicates Current Template 

• Drag and Drop Components to Current Template Window 

On the left side of the dialog, you will find the Template Library area, which contains a Windows-like folder 

structure. The root folder is the name and location of the Template Library that is currently open. Only one 

Template Library may be open at a time. 

To navigate the folder structure, double-click the folders you want to open or close. Inside any folder you can 

create and organize your templates and subfolders. The organization of the folder structure is user definable. The 

folder structure also supports common Windows functions, such as drag and drop, cut and paste, etc. 

Most commonly used commands can be accessed by right clicking on the folders and templates. If you double 

click a template, it becomes the Current Template and is signified by a red box around the Template icon. The 

Current Template is also identified in the Current Template area next to the Template Library area. To assemble 

or edit a template, it must be the Current Template. 

CURRENT TEMPLATE WINDOW 

• Templates Assembled and Edited 

• Right-click To Create Components 

• Double-click To Edit Points and Components 

• View Commands Bottom of Window 

In the center of the Create Template dialog is the main graph for creating templates. The graph is called the 

Current Template window. The Current Template window uses its own graphics engine and is not a MicroStation 

View. The scale of the graph is dynamic and changes as you zoom in and out. 

The center point of the Current Template window is marked by the dynamic origin, which is a magenta-colored 

box. The dynamic origin is used as a reference point and can be moved to any location in the graph. 

At the bottom of the graph there are numerous view commands, which are similar to MicroStation View 

commands. There are two buttons that look like the MicroStation View Previous and View Next commands, 

however, they are used to undo and redo template creation operations.  

If your mouse has a scroll wheel, it can be used to pan and zoom. The CTRL-Z keyboard hot key will undo your 

last edit or creation.  In the graph area you can right-click to access commands and you can double-click elements 

in the graph for editing purposes. 
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TEMPLATE PREVIEW WINDOW 

• Previews Templates and Components 

• Works on Non-current Templates 

• Placement Point Location Denoted by a Cyan-colored Box 

• Click Point to Move Placement Point Location 

• Drag and Drop from Preview Area to Current Template Window 

Under the Template Library area is the Preview area.  When you highlight (single click) a template, the template 

is displayed in the Preview area. 

You can use the Preview to assemble templates from their parts or components. This is accomplished using drag 

and drop functions. The cyan-colored box in the Preview represents the insertion point for any drag and drop 

operation. You can change the insertion point location by clicking the desired insertion point on the preview. 

DYNAMIC SETTINGS 

• Tools > Dynamic Settings Command 

• Precision Input Template Points 

• XY = Absolute Coordinates 

• HS = Horizontal Delta Distance and Slope from Last Point Placed 

• DL = Enter Delta Coordinates from Last Point Placed 

The Dynamic Settings dialog is used for precision input of the template components and to assign point names 

and styles when creating components. It also serves as a compass for the location of your cursor with respect to 

the dynamic origin. The dynamic origin can be moved using Set Dynamic Origin, located at the bottom of the 

Dynamic Settings dialog. 

The Dynamic Settings dialog is accessed by selecting the menu option Tools > Dynamic Settings or using the 

View Control icons located below the Current Template window. 

The Key-in pull-down specifies the type of key-in to be performed: 

XY = key-in absolute coordinates 

DL = key-in delta coordinates from last point placed (defaults to the dynamic origin if it is the first point 

of a component) 

HS = key-in horizontal delta distance and slope from last point placed 

VS = key-in vertical delta distance and slope from last point placed 

OL = key-in delta coordinates from dynamic origin 

OS = key-in horizontal delta distance and slope from dynamic origin 
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COMPONENTS 

• Components are Parts of the Template 

• Curb and Gutter, Median Barrier, Pavement Layers, Cut and Fill, etc. 

• Simply Drag and Drop Components Together to Create a Complete Template 

• When Two Points Coincide, Heavy White Plus Sign Appears 

• Existing Connection Point Name Override Dropped Point Name 

Components are logical parts of a template. Portions of the template that are separated into components are 

normally based on tabulation considerations. Examples of components include curb and gutter, median barrier, 

pavement layers, cut and fill slopes, and ditches. 

Components are normally kept in a separate folder in the Template Library and are used to assemble complete 

templates. Drag and drop the components to the Current Template window to create a complete template. When 

connecting two components, the connecting point will change to a white colored plus sign prior to placing the 

component. This is the indication that the points coincide. When the components are connected together, using 

drag and drop from the Template Library folders, any coincident component points will use the point names of 

the previously placed component. Template point names can be edited anytime during the creation process. 

Components are normally created with point names that are not specific to being on the left or right side of the 

roadway. When they are used to create completed templates, prefixes and suffixes to the template points can be 

automatically added during component placement. Prefixes and suffixes are controlled using Tools > Options in 

the Create Template dialog and can be set and cleared in the Dynamic Settings dialog during placement using 

the Apply Affixes check box. 

MERGING COMPONENTS 

• Right-click Between the Components to Merge 

• Select the Merge Components Command 

When combining two components of a pavement section together, two separate components are produced with a 

vertical segment dividing them. To remove the vertical segment, position the cursor over the vertical segment 

and right-click. Then select Merge Components. 

EXERCISE OVERVIEW 

5.1 Creating a New Project Template Library 

5.2 Create Template Library Folders 

5.3 Using the Template Library Organizer 

5.4 Naming Project Templates 

5.5 Creating A Resurfacing Template 

5.6 Editing Templates 
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Exercise 5.1 Creating a New Project Template Library 

This exercise opens the proposed roadway design file, DSGNRD01.dgn, with GEOPAK using the FDOT 

Workspace and Project configuration. The Create Template dialog displays and a new Template Library file 

created for the project in the project symb folder. This new project Template Library is the container for all the 

components and templates used to develop the design model for the project design.  

1. (Optional) Extract the 22049555201(5).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22049555201\roadway\ folder in the 

FDOTSS4 Workspace in MicroStation. 

3. Use Corridor Modeling, Create Template tool. 

 

4. Open the Create Template dialog and select File > New > Template Library.  

 

5. Navigate to the Project roadway folder, C:\e\projects\22049555201\roadway\. 
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6. Enter the new Template Library Name, 22049555201. Click Save. 

 

7. Select File > Save again to verify, then close the Create Template dialog. Click Close. 
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Exercise 5.2 Create Template Library Folders 

• Components 

• Corridor Templates 

• End Conditions 

• Linear Templates 

• Surface Templates 

The Components, End Condition, Linear Templates, Surface Templates folders contain parts of the full 

Templates and is obtained from the FDOTSS4 Template Library.   

The Corridor Templates folder contains the constructed templates for the corridor. The Project Templates in the 

exercises to follow are named and saved in stages or phases in order to track the progress of the design. This 

method is also recommended to provide a backup and/or history for potential trouble shooting along the way. 

1. Use Corridor Modeling, Create Template tool. 

 

2. From the Create Template dialog, select File > Open and navigate to the 

FDOTSS4/GEOPAK/corridor directory and choose the EmptyProject.itl Template Library. 

3. From the Create Template dialog, select File > Save As to copy the blank Project Template 

Library over the 22049555201 .itl Template Library created earlier. This will save the next 

few steps. 
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➢ Optional Steps  

1. Create new folders in the Project Template Library.  

 

2. Create and re-name five folders. Select the Root folder and repeat steps to include all the 

following folders: 

o Components 

o Corridor Templates 

o End Conditions 

o Linear Templates 

o Surface Templates 

 

3. Select File > Save to save the project Template Library .itl file.  

 

  



TEMPLATE DESIGN - Using the Template Library Organizer ________________________________________________ Chapter 5 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  5-9 

Exercise 5.3 Using the Template Library Organizer 

This exercise uses the Create Template dialog to open the Template Library Organizer from the Tools menu 

option. Various components and templates from other Template Libraries and Roadway Designer files are 

obtained from using the Template Library Organizer. For the Chapter exercises to follow, the FDOTSS4 

Template Library contains a basic Typical Section and all of the components used for the project design. 

1. Use Create Template and select Tools > Template Library Organizer. 

 

2. From the Template Library Organizer dialog, click the Ellipses icon next to the OK button. 

The Open Template Library window displays. 

 

3. From Open Template Library, navigate to the c:\FDOTSS4\GEOPAK\corridor folder and 

select the FDOTSS4.itl Template Library file. Click Open. 
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4. The Template Library Organizer dialog displays with the .itl file listed in the right Available 

In: window pane. 

  

5. From the Template Library Organizer, navigate to the FDOT folder shown below. 

    

6. Select the PPM EXHIBIT TYP-5 to preview the template in the Preview window below the 

directory view. 
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7. Drag the Template from the right side to the left side onto the Components folder for the 

project. 

   

8. Collect the following items from the FDOTSS4 Template Library and drag them to the Project 

Folders Locations as shown below 

FDOTSS4 Template Location Project Folder Location 

Examples/Typical Sections(Variable) /4 Lane 

Divided Arterial (45 MPH or Less)  
PPM EXHIBIT TYP-5 to Components 

End Conditions/Parts Entire Parts folder to End Conditions 

Component/Pavement/Resurfacing Entire Resurfacing folder to Components 

Component/Curb & Gutter Curb Type E Inside to Linear Templates 

Linear Templates Common 
Outside Lane w/  Paved Shoulder to Linear 

Templates 

Linear Templates Common Outside Lane w/ Type F Curb  to Linear Templates 

Surface Templates Pavement Asphalt  to Surface Templates 

9. Click OK to return to the Create Template dialog and click Yes to the “Save data to file…  

The FDOT Standard Items are now saved in the Project Template Library. 
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Exercise 5.4 Naming Project Templates 

This exercise copies and renames the Typical Section obtained from the FDOTSS4 Template Library in the 

project Template Library template folder using the Create Template dialog. The Create Template dialog has 

functionality similar to Window Explorer to help manage templates for each project. 

Note A consistent project template naming convention is valuable as the design progresses. As more are added 
to the template design, create a backup copy and add a suffix to the name “_1, _2, _3, etc.  

1. In the Components folder, right click on the PPM EXHIBIT TYP - 5 Template, and select 

Copy. 

 

2. Right click on the Corridor Templates folder and select Paste. Right click on the copied 

EXHIBIT TYP – 5 Template and select Rename.  
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3. Change the Name of the Template to SR61.  Right click on the SR61 Template and select Set 

Active. A small red box will indicate the Active Template. 

 

4. Select File > Save to save the Project Template Library. 
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Exercise 5.5 Creating a Resurfacing Template 

This exercise creates a Resurfacing Template within the project Template Library. This exercise helps provide a 

basic understanding of the basic template creation methods from the FDOTSS4 Template library components 

types, connection points, constraints, targets, etc. 

1. Right click on the Corridor Templates folder and select New > Template. 

 

2. Right click on the New Template1 and select Rename. Change the Name to RRR98 and Select 

Enter to store the name. 

3. Right click again on the RRR98 and select Set Active. 

 

  



TEMPLATE DESIGN - Creating a Resurfacing Template ___________________________________________________ Chapter 5 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  5-15 

➢ Before Adding Components, Open Preference File to Add a Prefix to the Point Names. 

1. Select the Tools > Options from the Create Template dialog to launch the Template 

Options dialog. 

 

2. Click the Preferences button and then select the FDOT list item. Click Load and then Close 

the Preferences dialog. Click OK to close the Template Options dialog. 

 

3. Select the Tools > Dynamic Settings from the Create Template dialog. This provides a 

toolbox like dialog for placing components. 

Note The X and Y Step value 0.1000 functions similar to a grid lock in MicroStation when placing the 
components 
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a. Change the Point Style to Template Miscellaneous. 

b. Uncheck Apply Affixes. 

 

➢ Add Components 

1. Navigate to Components/Resurfacing/Overlay and select the Pvt Overlay Right Component. 

  

2. Drag the Component to the small magenta square in large View. 
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3. Repeat this step to place the Pvt Overlay Left Component on the small magenta square. 

  

4. Fit View by selecting the Fit icon below the Active Template window. 

 

5. Drag and drop the Resurfacing/Milling/ Pvt Milling Right Component and connect it to the 

bottom side of the Overlay Component in the Template. The cursor will turn white when it is 

lock on the location. 
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6. Repeat this step for the Left Milling Component. 

 

7. Drag and drop the Resurfacing/Overbuild/ Pvt Overbuild Right Component and connect it 

to the bottom side of the Overlay Component in the template. The cursor will turn white when 

it is lock on the location.  

 

8. Repeat this step for the Left Overbuild Component. 
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9. Check Apply Affixes on the Dynamic Settings dialog. 

 

10. Drag and drop the Linear Templates/Outside Lane w/ Paved Shoulder Component and 

connect it to the top side of the widening template.  While dragging Right click and turn On 

Mirror. 
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11. Modify the Widening lane Width and Slope,  

a. Edit the Point RT_PVT_EOP_OUT, double click on the Point to open the Point 

Properties dialog. 

b.  Change the Horizontal Constraint Value to 1 and Slope Constraint Value to -2%. 

  

12. Repeat for the Left Side Widening Pavement, LT_PVT_EOP_OUT, use Horizontal value -1, 

and Slope value 2.0%. 

➢ Add End Conditions to the SR61 and RRR98 templates 

1. Drag and drop the End Conditions/Parts 6:1 Cut and 6:1 FILL TO 5’ Components to both 

sides.  

2. Select File > Save to save the Template changes. 

 

Note The undo icon is also at the bottom of the view. 
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Exercise 5.6 Editing Templates 

1. On the Create Template dialog, check On the Display Point Names option. 

 

➢ Change End Condition Point Properties 

1. Double click on the RT 6:1 Cut Point to launch the Point Properties dialog. 

 

2. Check the End Condition is Infinite box and change Constraint 2, Horizontal Value, from 30 

to 5 feet.  Click Apply and then Close.  
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3. Repeat these changes for the remaining End Conditions; RT 6:1Fill, LT 6:1Cut, RT 6:1Fill. 

 Use -5 for left side points. To edit consecutive points, click the pick icon next to the point name and select 
the next point. 

 

4.  Select Fit View the Active Template and changes. 

 

5. Rich click on the each Fill components and choose edit properties. Change the Priority Value 

to 2  
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6. Turn OFF the Horizontal Feature Constraint on the middle point,  PVT _EOP_IN Point. 

 

7. Select File > Save to save the Template changes. 
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➢ Change the Overlay Depth Properties 

1. Change the bottom tab on the left side of the Create Template dialog to Active Template. 

 

2. Open the Parametric Constraints folder, double click on the OLAY_PvtThick Label and 

change the Default Value from -.25 to -2/12.  Click OK. 

 

3. Repeat these steps for the OLAY_PvtThickLt and OLAY_PvtThickRt Labels. 
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➢ Change the Milling Point Properties 

1. Zoom in the Active Template View to the Right Widening side. 

 

2. Right click on the RT_PVT_OLAY_OUT and select Edit Point. 
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a. Change the Constraint 1, Horizontal Value from 12 to 5 feet. 

b. Change Constraint 2, from Slope to Project to Surface.   

c. Set the Constraint 2 Value to Active. 

d. Click Apply and then Close.  
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e. Repeat these steps for the LT_PVT_OLAY_OUT, change the Horizontal Value from 

-12 to -7 and Slope to Project to Surface.  

  

3. Zoom out of the Active Template to view the results. 

 

4. Select File > Save to save the Template changes. 
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➢ Change the Widening Point Properties 

1. Double click on the RT_PVT_EOP_OUT to edit the Point Properties. 

 

2. Change the Constraint 1, Horizontal Value from 1 to.01 feet and Horizontal Feature 

Constraint Range from 50 to 100 feet.  Click Apply and then Close.  
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3. Repeat these steps for the LT_PVT_EOP_OUT, change the Horizontal Value from -1 to -.01 

and Horizontal Feature Constraint Range from -50 to -100 feet. Click Apply and then Close.  

  

4. Fit View the Active Template to view the results. 

 

5. Select File > Save to save the Template changes. 
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➢ Check the Milling Component Properties 

1. Double click on the bottom line of the RT_PvtOverlay to open the Component Selection 

dialog and select the RT_PvtMilling option to edit the Component Properties. 

 

2. Change the Overlay/Stripping Properties / Bottom option from Follow Surface to Follow 

Component.  Click Apply and then Close.  

Note This is the appropriate setting for constant depth milling to match existing pavement slope between two 
points. 
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3. Repeat these steps for the LT_PvtMilling Component, change the Overlay/Stripping 

Properties / Bottom option from Follow Surface to Follow Component.  Click Apply and 

then Close.  

   

4. Select File Save to save the Template changes. 
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➢ Insert a Milling Slope Break Template Point  

1. Right click on the RT_PvtOverlay Component and select Insert Point. 

 

2. Data point in the Active Template View to store a point. Right click and select Finish. 
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3. Double click on the new Point to edit the Point Properties. Change the Point Constraints as 

shown. 

 

4. Click Apply and then Close. 
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5. Repeat the steps above to insert Points on the bottom of the PvtOverlay, PvtMilling, and 

PvtOverbuild Components. 

 If insert point option is not available for the last component, use add point 

 

6. Set the Point Properties as shown. 

  

 When inserting the point on the PvtMilling and PvtOverbuild components, data point on the 
RT_ML_BREAK_BOT point to save from setting any other Point Properties edit steps.  
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7. Merge the three points into one final point. 

  

8. Select File > Save to save the Template changes and then close the Create Template dialog. 
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6 BASIC CORRIDORS MODELS 

CORRIDOR MODELING OVERVIEW 

As defined in the Bentley Civil Help:  

“The Corridor Modeling toolset is a group of highly interactive commands to create new design 
surfaces that represent a new roadway or other type of surface. Tools for creation, modification, 
management, and report functions are supported. 

Corridor Modeling tools aggregates a variety of civil data. The geometry is created with the 

Horizontal and Vertical Geometry tools, while the existing ground is defined by a MicroStation 

mesh or Civil Terrain Model. Plan view elements, such as edges of pavement, shoulders, curbs, 

etc. can be 2D or 3D. Superelevation information is defined within a design file using standards 

or imported data. Templates are utilized from one or more template libraries. 

Reference files can be used extensively with Corridor Modeling. On a simple project, the data 

may be all in one file; larger projects may have geometry in one file, plan view graphics in a 

second, terrain in another, superelevation in a fourth and the actual model in a fifth. All files 

can reference the others, to present a complete picture of the project.  

When working with Corridor Modeling, you can draw in 2D or 3D. When using 2D (such as for 

plan-view graphics), a 3D view is automatically created and maintained. For example, when a 

vertical geometry element is initially defined for a horizontal geometry element, the Default-3D 

model is created, if there isn’t one already. The 3D baseline (combination of horizontal and 

vertical element) is drawn into the 3D model. As template drops are added, and progressed, they 

are added to the 3D model automatically.  

When starting to create a corridor, basic information can be used. A single template can be 

used, along with preliminary geometry and a high level terrain model. As the design progresses, 

more detail can be added. Instead of a single template drop, perhaps more templates better 

define the roadway. Transitions can be added to smoothly move from one template to another. 

There may be multiple roadways all interconnected using the target aliasing tools. All the while, 

as changes are made, the corridor model is updating, so you see up-to-the minute results. Simple 

projects may not require all the tools, and a basic corridor model may be sufficient. But all the 

tools are available to handle basic to complex, small-scale to large-scale projects. 

The following are minimum requirements to use Corridor Modeling. 

• Civil horizontal element  

• Civil vertical element  

• Template stored in a template library 

A terrain model is not required for corridor modeling. If the template includes end conditions and no terrain 

model is defined, the software generates as much of the model as possible, but will not complete the end condition 

that ties to ground and no error message is given. 
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CORRIDOR MODELING PLANNING 

It is recommended to plan out the 3D modeling approach on a project.  Some have referred to this a Model 

Management Plan.  This plan will attempt to outline the following: 

• Determine how to break up the project into logical independent corridors 

• Determine which sections of the project are needed for detail modeling and surface modeling 

• Determine the files and filenames to be used for corridors and details.  

Note The project 3D Model may be in separate files or all combined into one file.: The FDOT file defined to be 
used for Corridor and Detail Models is MODLRDxx.  

Below is a sample diagram of a typical Model Management Plan: 

 

EXERCISE OVERVIEW 

6.1 Prepare to Create Corridor Model for SR61 

6.2 Create Corridor, SR61 

6.3 Variable Medians, SR61 Templates 

6.4 Add Corridor References, SR61 

6.5 Add Corridor Point Controls, SR61 

6.6 Add Corridor Key Stations, SR61 

6.7 Change Corridor Design Stage, SR61 

6.8 Review Corridor Objects, SR61 

6.9 Create RRR Corridor Model, BL98 

6.10 Create Template Drop, RRR98  

6.11 Add Corridor References, RRR98 

6.12 Template Point Control, RRR98 
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Exercise 6.1 Prepare to Create Corridor Model for SR61 

1. (Optional) Extract the 22049555201(6).zip file in the c:\e\projects folder. 

2. Use the create file tool to create the MODLRD01.dgn file to be used for corridor models. 

3. Open the MODLRD01.dgn or DSGNRD01.dgn file of the c:\e\projects\22049555201\roadway\ 

folder in the FDOTSS4 Workspace in MicroStation. 

4. If using the MODLRDO1 file, attach the terrain, 2D plan and survey files as references. 

5. Use the Terrain Model, Set Active Terrain Model tool.  

 

6. At the cursor prompt, select the Terrain Boundary green dashed line from the attached 

GDTMRD01 reference file. This will set the terrain model as Active. 

7. Move the cursor over the SR61 Centerline Feature and verify an Active Profile. 
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8. Use the Corridor Modeling, Create Template tool. 

 

 Use the F12 function key to access the Create Template Dialog. 

9. Verify that the correct Template Library is loaded Close the Create Template dialog. 

 

10. To set up the Views for viewing the 2D Plan and 3D Model simultaneously in the FDOTSS4 

Workspace, Select the F2 Function Key on the keyboard.  This will open an Isometric View of 

the project. 
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Exercise 6.2 Create Corridor, SR61 

1. Use the Corridor Modeling, Create Corridor tool. 

 

2. Enter the Corridor Name, SR61, in the Create Corridor dialog and then select the SR61 

Centerline in the Plan View.  

 

3. Reset to accept the Active Profile.  This profile resides with the SR61 Civil Feature Centerline.  
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4. Data point to accept the Name of the Corridor, SR61. The corridor is created AND the 

integrated Create Template Drop dialog launches.  

Note Once a Corridor is created, a shape boundary is placed in the Plan View representing its outline.  This 
shape is initially placed on the CorrHndlStg1_dp level.  It has several properties which can be seen by 
clicking on the shape and choosing first icon. One of the properties is the Design Stage.   

1   

5. Once the Create Template Drop dialog is opened, first select the corridor template to be 

placed on the corridor. Either use the icon on the dialog <OR> select ALT down arrow to 

pick a template. 
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6. Find the SR61 template in the Corridor Templates folder of the active Project Template 

Library. 

 

7. Data point to accept the Template and move to the next setting.  

8. Continue to define the Create Template Drop dialog information entering and accepting the 

following for the SR61 Corridor: 

a. Start – Use keypoint or intersect snap click to the ML line on 98, Station 700+23.62. 
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b. End - snap to the beginning of the milling, Station 715+73.20.  Complete dialog as 

shown below. 

 

9. Upon completion of the Corridor Processing bar in the lower right hand side of the 

MicroStation status bar, the 3D model will be displayed in View 2. 
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Note Once a Template Drop is created, a shape boundary is placed in the Plan View represent its outline.  This 
shape is initially placed on the TmpDrpHndlStg1_dp level.  It has several properties which can be seen by 
clicking on the shape and choosing first icon.  One of the properties is the Design Stage. 
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➢ Turn 3D Reference File Display Off in the Plan View 

At times the line work in the Plan View can become confusing with 3D lines over top of the 2D lines. This View 

can be simplified by turning the 3D Model Reference file display Off. 

1. Data Point somewhere in View 1 to make it active. 

2. On the MicroStation Level Display dialog, navigate to the Ref. DSGNRD01 Default-3D file 

or Ref. MODLRD01.DGN Default-3D file. 

 

3. Right click on the file and un-check the Display option. 
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Exercise 6.3 Variable Medians, SR61 Templates 

The FDOTSS4.itl file contains some PPM Exhibit Templates which are delivered with variable medians included. 

The median can vary with the following conditions or component sets: 

o Curb Median with or without Left Turns 

o Crossovers at Intersections 

o Traffic Separators with Left Turns 

To properly operate the median condition templates consider the following: 

• The various median component sets have a parent end condition search lines that targets plan features; e.g. 

CurbType E, Traffic Separator. 

• Each of the median components sets are displayed ONLY if the target is found. This is by the Parent/Child 

relationship of the Template components. 

• The LT and RT PGL Handles control the overall width of the median and can be modified to fit any project. 

• Many of the median components have Horizontal Feature Constraints (HFC) defined to locate the 2D civil 

features and the horizontal range will need to be modified to fit the project. 

 

➢ Add Parametric Constraint for Variable Median, SR61 Template  

The templates used have variable median conditions built within that needs to be set in place for the corridor.  

1. Use the Corridor Modeling, Create Parametric Constraint tool. 
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2. Identify the Corridor Boundary handle. Continue to define the Create Parametric 

Constraint dialog information. 

 

3. Enter and accept the following for the SR61 Corridor: 

Start Station  Alt for Begin 

Stop Station  Alt for End 

Constraint Label V_Offset 

Start Value   0.0 

Stop Value   0.0 

4. The variable median conditions are placed at the correct location vertically.  This will ensure 

the median is at the correct elevation for the next exercise. 
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Exercise 6.4 Add Corridor References, SR61 

Corridor References are related to the template points having a Horizontal Feature Constraint to control the 

location of the point on the corridor. They are 2D graphical Civil Features that need to be added to a corridor.  

For the SR61 corridor a selection of median Civil Features are used for template external references.   

 

1. The SR61 template is designed to target CurbGutterTypeE lines in the median.  Use the Set 

Feature Definition tool to change the two median CurbFace feature lines to CurbGutterTypeE 

features. 

 

2. Create a selection set of the following 12 features in the plan view: 

o 2 - PavementAsphalt(EOP) lines in the median 

o 4 - PavementAsphalt(EOP) taper lines in the median 

o 2 – CurbGutterTypeE lines in the median (step 1 above)  

o 2 – CurbGutterTypeE taper lines in the median   

o 4 - TrafficSeparatorTypeI(4 feet) lines in the median 

3. Use the Corridor Modeling, Add Corridor References tool. 

 

4. Identify the Corridor handle and then data point to add the selected lines as listed above to 

the corridor. 

5. Once the Reference Lines have been added, the Corridor will automatically process to include 

the new Horizontal Feature Constraints. 

  



Chapter 6 ____________________________________________ BASIC CORRIDORS MODELS - Add Corridor References, SR61 

6-14 ©2018 FDOT FDOT Roadway Design and 3D Modeling 

 Modeling the TrafSeparator level, do not add the Nose Radius Element to the Selection Set. This will be 
modeled in Chapter 9 with a 3D Civil Cell. 
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Exercise 6.5 Add Corridor Point Controls, SR61 

This exercise defines the LT and RT PGL to be a fixed distance from the centerline, 11 feet.   

 On projects where the PGL lines vary from parallel to the centerline, use the linear option and select the 
feature lines that represent the varying PGL’s. 

1. Use the Corridor Modeling, Create Point Control tool. 

 

2. Identify the Corridor Boundary handle. Continue to define the Create Point Control dialog 

information. 

  

3. Enter and accept the following for the SR61 Corridor: 

o Start Station  Alt for Begin   

o End Station  Alt for End   

o Control Description RT_PGL 

o Point    RT_PGL_HANDLE  

o Mode   Horizontal 

o Control Type  Linear Geometry 

o Start Value  11.00  

o End Value  11.00  

Note At the prompt to select an element, choose the SR61 centerline 
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4. Repeat the previous steps to add the Point Control for the LT_PGL.  

 

5. Enter and accept the following for the SR61 Corridor: 

o Start Station  Alt for Begin   

o End Station  Alt for End   

o Control Description LT_PGL 

o Point    LT_PGL_HANDLE  

o Mode   Horizontal 

o Control Type  Linear Geometry 

o Start Value  -11.00  

o End Value  -11.00  

Note At the prompt to select an element, choose the SR61 centerline 
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Exercise 6.6 Add Corridor Key Stations, SR61 

Create Key Station tool is useful to add stations that are not coincident with the template interval.  When the 

median conditions change abruptly, it is desirable to include the station for processing. 

1. Use the Corridor Modeling, Create Key Station tool. 

 

2. Identify the Corridor Boundary handle.  

3. Use AccuSnap to locate the Plan View CurbMedian / Traffic Separator division line. 
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4. Repeat these steps for both Traffic Separator locations in the Plan View. 
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Exercise 6.7 Change Corridor Design Stage, SR61 

The FDOTSS4 Workspace defines Corridor Stages to help with various tasks for Design and 3D Modeling. 

Depending on the Active Stage, processing the Corridor will take longer.   

1. Open the Project Explorer dialog, select the F11 Function Key. 

2. Select the Civil Standards tab and expand the Libraries option list. 

3. Locate the Corridor Design Stages under Project Settings > FDOT_CivilFeatures_RD. 

 

4. Select the Boundary of the Corridor and locate the Properties icon when the menu displays. 
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5. Select the Properties icon and change the Design Stage from 1 PRELIM to 2 DESIGN. 

 

6. The Corridor will re-process and the 3D Model will re-draw with a tighter interval.  
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Exercise 6.8 Review Corridor Objects, SR61 

The Corridor Objects dialog is a summary of all Corridor Modeling objects and provides an excellent method 

of managing data. 

1. Use the Corridor Modeling, Corridor Objects tool. 

 

2. Identify the Corridor Boundary handle to open the Corridor Objects dialog. 

  

➢ Additional Template Edits, SR61 

1. Change the sidewalk buffer from 3 feet to 0 feet on both roadways.  

2. Either change the sidewalk width to 6 feet or add the sidewalk back lines to the Corridor as 

References for the template HFC. 

3. Add End Conditions 2:1 Cut & Fill components to each side with Mirror and Affixes checked 

ON. 
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Exercise 6.9 Create RRR Corridor Model, BL98 

1. Continue in the DSGNRD01.dgn or MODLRD01.dgn file. 

2. Optional: Use the General Geometry, Set Active Terrain Model tool.  

 

Note This tool can also be found on the Terrain Model Workflow Task. 

3. At the cursor prompt, click on the Terrain boundary line from the attached GDTMRD02 

Reference file.  If the Terrain Model is Active, a message will display, Terrain Model Already 

Active. 
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4. Move the cursor over the BL98 centerline Feature and verify an Active Profile. 

 

5. To set up the Views for viewing the 2D Plan and 3D Model simultaneously in the FDOTSS4 

Workspace, select the F2 Function Key on the keyboard.  This will open an Isometric View 

of the project. 

 Use the Shift Key and Middle Button to rotate the 3D view. 
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6. Use the Corridor Modeling, Create Corridor tool.  

 

7. Enter the Corridor Name, RRR98, in the Create Corridor dialog and then select the BL98 

centerline in the Plan View.  

8. Reset to accept the Active Profile.  This profile resides with the BL98 Civil Feature Centerline.  

9. Data point to accept the Name of the Corridor, BL98.  The corridor is created AND the 

integrated Create Template Drop dialog launches.  

 

Note Once a Corridor is created, a shape boundary is placed in the Plan View representing its outline.  This 
shape is initially placed on the CorrHndlStg1_dp level.  It has several properties which can be seen by 
clicking on the shape and choosing first icon. One of the properties is the Design Stage.    
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Exercise 6.10 Create Template Drop, RRR98  

1. Once the Create Template Drop dialog displays, first select the corridor template to be 

placed on the corridor. Either use the icon on the dialog <OR> Select ALT down arrow to 

pick a template. 

 

2. Select the RRR98 template in the Corridor Templates folder. Click OK. 
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3. Data point to accept the Template and move to the next setting. Continue to define the Create 

Template Drop dialog information entering and accepting the following for the SR61 

Corridor: 

o Start Station  28+00 

o End Station  Alt for the end station  

o Drop Interval  10.0 

o Min. Tran. Before  0.0 

o Min. Tran. After   0.0 
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4. Upon completion of the Corridor processing bar in the lower right hand side of the 

MicroStation status bar, the 3D Model will be displayed in View 2. 

 

Note Once a Template Drop is created a shape boundary is placed in the Plan View represent its outline.  This 
shape is initially placed on the TmpDrpHndlStg1_dp level.  It has several properties which can be seen by 
clicking on the shape and choosing first icon.  One of the properties is the Design Stage. 
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Exercise 6.11 Add Corridor References, RRR98 

Corridor References are related to the template points having a Horizontal Feature Constraint to control the 

location of the point on the corridor. They are 2D graphical Civil Features that need to be added to a Corridor.  

For the RRR98 Corridor add the following Civil Feature References: 

• PavementMilling(ML) 

• Widening PavementAsphalt(EOPA) 

1. Select the lines as listed above to add to the Corridor.  

 Use the Selector Tools with in MicroStation to assist. 

 

2. Use the Corridor Modeling, Add Corridor Reference tool.  
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3. At the prompt, select the corridor handle or boundary, data point to accept the selected 

elements as corridor references. 

 

4. Once the Reference lines have been added, the Corridor will automatically process to include 

the new Horizontal Feature Constraints. 
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Exercise 6.12 Template Point Control, RRR98  

The template used has milling slope break points built within meant to follow normal slope breaks in the existing 

pavement. These lines add Point Controls for the Corridor.  

1. With View 1 active, turn Off all Levels in the TOPORD file and turn On the Pavemk_ep 

Level. 

 

2. Use References, Merge Into Master tool to copy the Pavemk_ep lines into the DSGNRD or 

MODLRD file. 
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3. Create a Selection Set of the middle Pavemk_ep lines. 

4. Use Horizontal Geometry, Set Feature Definition tool. 

 

5. Select the PavementCrown Feature Definition and pvtcrown Name. 

6. Data point to accept the Feature Definition to selected elements. 

 

7. Use the Corridor Modeling, Create Point Control tool. 
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8. Identify the Corridor Boundary handle. Continue to define the Create Point Control dialog 

information entering and accepting the following for the RRR98 Corridor: 

o Start Station  28+00 

o End Station  Alt for End  

o Control Description GradeBreak 

o Point   RT_ML_Break 

o Mode   Horizontal 

o Control Type  Feature Definition 

o Feature Definition Pavement Crown 

o Range   10 

o Priority   1 

o Horizontal Offset Start 0.0 

o Horizontal Offset Stop 0.0 
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➢ To validate the model verses the plan,  Complete the Following 

1. Open Project Explorer, Civil Standards, DSGNRD01.DGN or MODLRD01.DGN, Feature 

Definitions, Corridor Lines(3D) 

2. Select the PavementAsphalt_pm and then right click to select the properties 

3. In the Properties dialog, change the Linear Default Setting, Create Template Geometry setting 

to True 

 

4. Re-process the Corridors 

 

5. Verify that the construction lines in magenta, line up with the plan lines. 

6. Repeat the steps for the Milling_pm lines  
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7 OPEN CROSS SECTION VIEW 

INTRODUCTION  

This section will cover the Cross Section View tool. This is a single Cross Section View tool and is not for 

producing final plan cross sections to print or other production needs. Refer to the FDOT Plan Development 

Workflows training manual. 

The Cross Section View tool creates a single section plane through any displayed elements in the “default- 3D 

model” of the DGN file, thus having the ability to see a true slice or cross section through the model. The graphics 

can be created from a Roadway Corridor, Drainage Network, Bridge Structure, or any other 3D solid element in 

the design file or reference file.  

The cross section view created is dynamic and will change as the model elements in the design file or reference 

file changes. 

This Cross Section View tool will also display a location line in the plan view, profile view and 3D model view.  

This line is also tied to an element or alignment for specific location identification and navigation.  The Cross 

Section View tool is essential to evaluate the design and to make design decisions. 

EXERCISE OVERVIEW 

7.1 Opening a Cross Section View 

7.2 SR61 Corridor Cross Section View 

7.3 BL98 Alignment Cross Section View 

7.4 SR61/BL98 Turn Lane Cross Section View 

7.5 Create a 3D Drive-Through Animation 
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Exercise 7.1 Opening a Cross Section View 

This exercise teaches the user to open a View and set it to a Cross Section Model View.  

➢ Corridor Modeling Tool Used 

1. (Optional) Extract the 22049555201(7).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn OR MODLRD01.dgn file of the 

c:\e\projects\22049555201\roadway\ folder in the FDOTSS4 Workspace in MicroStation. 

 Check on the Reference file display for the TOPORD, and GDTMRD files 

3. Select the Function Key F2 to open View 2 the 3D Model. Click on the View 2 window to 

make it active.  

4. Use Reference Display to attach the GKLNRD Default-3D file. This is the file with the 

Existing Feature model elements. 
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5. Click in View 2 to make it Active. Use Level Display to toggle Off the DTM Level in the 

GKLNRD Reference file. 

 

6. Select the Function Key F4 to open Views 1-4.   

7. Use the MicroStation Select tool to select the SR61 centerline. Click the Open Profile Model 

icon on the Context Menu and select View 3 to place the Profile View of SR61.  
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Exercise 7.2 SR61 Corridor Cross Section View 

1. Use Corridor Modeling, Open CrossSection View tool.  

 

2. Select the Corridor: SR61 by the handle or near the boundary and click in View 4 to display 

the Corridor Cross Section.  

 

Note When used on a Corridor, the Cross Section View tool will determine the following from the corridor 
properties: 

o Left Offset 

o Right Offset 

o Interval 

o Start Station 
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3. For the SR61 Cross Section View 4: 

Note There is a known issue with SS4 Dynamic Cross Sections; the program will crash if you zoom and scroll 
at the same time when the cursor is over a yellow point.  To turn off the yellow points, go to the Project 
Explorer Civil Standard Tab and turn off the 3D Lines features.  

 

a. Notice many of the MicroStation Zoom, Pan, etc. commands will operate as normal.  

b. Use the Cross Section View Navigation tools to examine the Corridor Model. 

  

c. Select View Properties and change the Vertical Exaggeration to 10 and then click the 

View to see the changes. 
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d. Select the Station pull down menu and change to Station 715+00. 

 

4. Use Corridor Modeling, Locate Station Via Datapoint tool;  
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5. Select the Corridor boundary to see a dynamic locater line perpendicular to the Centerline. 

Data point at any station along the alignment and click in View 4 to see its Cross Section. 

  

 Another way to access the tool is to hold down a Right Click in the Cross View to select the Locate Station 
via Data Point  
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Exercise 7.3 BL98 Alignment Cross Section View 

1. Use Corridor Modeling, Open Cross Section View tool. 

 

2. Select the Alignment BL98 and enter the following:  

Left Offset  -75 

Right Offset  75 

Start Station  28+00  

Interval  20 
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3. Left click in View 4 to display the Corridor Cross Section.  

 

 Hold down a right click to Turn Off the Baseline cell level. 

4. Evaluate the RRR98 Model using the Cross Section tool. 

Note The Cross Section View tool works with Corridors, Civil Geometry, MicroStation Line or Line String 
Elements. 
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Exercise 7.4 SR61/BL98 Turn Lane Cross Section View 

1. Use Corridor Modeling, Open CrossSection View tool.  

 

2. Select the PavementAsphalt(EOPA)  line on the SW turning lane at the SR61 Intersection 

with BL98 and enter the following:  

o Left Offset  20  

o Right Offset 20 

o Start Station  0+00  

o Interval  10 
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3. Left click in View 4 to display the Corridor Cross Section.  

 

4. Evaluate the Model along the Curve Radii using the Cross Section tool. 

Note Since the intersection model is not yet built, there is no widening or shoulder drawing in the cross section 
around the radius. 
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Exercise 7.5 Create a 3D Drive-Through Animation 

Creating a drive through along the project requires a 3D view and a 3D path to follow. This exercise explains 

how to use the new Drive Through tool in SS4 along the proposed SR61 3D Model.  

   

➢ To Setup the Animation Drive Through  

1. Maximize View 2 Default-3D model to set it as the Active View. 

2. Turn OFF the ConstLines and XSMisc_px levels. 

3. Use Analysis & Reporting, 3D Drive Through tool. 

. 
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4. At the prompt, Select a 3D view, left click inside View 2. 

a. At the prompt, Select the center line of the road, pick the 3D line in the view shown 

below.  

  

b. On the 3D Drive Through dialog, change to the tab Camera/Target Controls and enter 

the values as shown below. 

  

c. Change the tab back to the General Controls and Select the play button.  

. 
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8 SUPERELEVATION 

OVERVIEW  

Superelevation rotates the pavement cross slopes through a curve so that vehicles can maintain stability and speed 

while on a turning roadway. Elevation banking is applied to help offset centrifugal force. Superelevation 

standards also define the transition length required to rotate from a normal crown to a fully banked curve and 

back again.  

Superelevation can be calculated in two ways:  

• Rules-based – using a set of preferences (SEP or SRL files) the station and associated cross slopes of the 

transitions are based on design speed, curvature, and other design parameters. As the design progresses and 

parameters change (i.e., design speed exceptions) superelevation can be reprocessed to the revised 

parameter(s).  

• Import – using a comma separate values (CSV) file to import the station and associated cross slope of each 

transition. In this option, the rules are not utilized; the data is simply applied to the superelevation lanes.  

The result of superelevation is a DGN file of graphic superelevation lanes with cross slope attributes. This file 

can be referenced to a corridor model and associated, so the superelevation transitions are incorporated into the 

corridor model. The superelevation data can be in its own DGN file, or can be drawn into any of the other project 

DGN files with geometry, corridor, etc.  

EXERCISE DESCRIPTION 

In this workshop, the SR61 Centerline has a single curve to define superelevation. Once the required 

superelevation is determined from a predefined FDOT rule file, it will be assign to the SR61 corridor the results 

will be reviewed in the Cross Section View.  Also, the results will be reviewed in the table editor and generate 

reports will be generated as other methods to review data.  

As an alternative to calculating supers with rules, we’ll also import a dataset from a FDOT Curve Table (csv file 

generated from Excel).  

The general workflow for superelevation is listed below.  

• Create RDXSRD File to draw superelevation lane shapes 

• Reference the ALGNRD File 

• Create Superelevation Sections 

• Create Superelevation Lanes 

• Calculate Superelevation Based on FDOT Tables 

• Project Explorer Edits, Graphical Edits 

• Assign Superelevation to Corridor, Associate Points 

• Special Template Point, Superelevation Flag Box 

• Template Inside Lane Vector Offset Constraint 

• Superelevation Diagram and Reports 
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EXERCISE OVERVIEW 

8.1 Create Superelevation Model 

8.2 Create Superelevation Sections 

8.3 Create Superelevation Lanes 

8.4 Calculate Superelevation 

8.5 Graphical Edits 

8.6 Project Explorer Edits 

8.7 Superelevation Reports and Diagram Editing  

8.8 Assign Superelevation to Corridor  

 

Exercise 8.1 Create Superelevation Model  

1. (Optional) Extract the 22049555201(8).zip file in the c:\e\projects folder. 

2. Open the DSGNRD01.dgn file of the c:\e\projects\22049555201\roadway\ folder in the 

FDOTSS4 Workspace in MicroStation. 

3. From the FDOTSS4 Menu, select Actions > Create/Edit File. 
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a. From the Create File/Project dialog, locate the ROADWAY CROSS SECTIONS 

from the Roadway Design Files File Group and click Create.  

 

b. Click Open File, and set the Set/Update Plot Scale dialog displays. 

 

c. Click OK on the Set/Update Plot Scale dialog. Click OK on the CreateFile/Project 

dialog. 
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4. Locate the View Group toggle on the bottom left of the MicroStation window and change the 

View Group/Model to Xsshrd Views. 

 

5. On the MicroStation References tool, attach the DSGNRD01 file. 

   

Note The Superelevation tools utilize the active MicroStation symbology.   

6. Window into the Proposed Roadway in the DSGNRD01 Reference file.  

7. Set the MicroStation active Level to ConstLines and select File > Save Settings (Ctrl +F).  
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Exercise 8.2 Create Superelevation Sections  

1. Use Corridor Modeling, Create Superelevation Sections tool. 

 

2. On the Create Superelevation Sections dialog, enter as shown below: 

o Name   SR61 

o Start Station   Alt to lock to Begin 

o End Station   Alt to lock to End 

o Minimum Tangent  0  

l  
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3. The Superelevation Sections are drawn and the Create Superelevation Lanes dialog is 

launched. 

 

Note Use the Function Key F5 to dim the references 
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Exercise 8.3 Create Superelevation Lanes 

1. Use the Corridor Modeling, Create Superelevation Lanes tool. 

 

2. Define each of the Super Elevation Lanes as shown below, following the prompt to enter and 

data point to accept data: 

 

Name Left1 Left2 Right1 Right2 

Type Primary Primary Primary Primary 

Side Left Left Right Right 

Inside Edge Offset 11 35 11 35 

Width 24 16 24 16 

Normal Cross Slope -2.00% -3.00% -2.00% -3.00% 
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3. The Superelevation Lanes are drawn and the Calculate Superelevation Lanes dialog is 

launched. 

 

 

  



SUPERELEVATION - Calculate Superelevation __________________________________________________________ Chapter 8 

FDOT Roadway Design and 3D Modeling ©2018 FDOT  8-9 

Exercise 8.4 Calculate Superelevation  

1. Use the Corridor Modeling, Calculate Superelevation tool.  

 

2. On the Calculate Superelevation dialog: 

   

3. Select the Browse button and navigate to select the FDOT_Urban_e.sep file from the 

\FDOTSS4\GEOPAK\e_tables\ directory.  
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4. Enter the necessary dialog information as shown at the prompt and data point to accept data: 

e Selection  5% e max 

L Selection  2&4lane 

Design Speed  50 

Transition ID  Linear 

Number of Lanes  4 

Facility    Divided 

Open Editor  Yes, check 

 

5. The Superelevation Lanes are now applied with Superelevation and the Superelevation 

Editor dialog is launched.  

 

6. Review the data and Close the Superelevation Editor dialog. 
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7. Open the Civil Message Center to review the Superelevation Notes. 
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Exercise 8.5 Graphical Edits 

➢ Superelevation Sections 

1. Use the MicroStation Element Selection tool and select the Superelevation Section. The 

graphic handlers now display. 

2. Change the Begin Station to 70000. 

   

➢ Superelevation Lanes 

1. Using the MicroStation Element Selection tool, select the Left2 lane of the Superelevation 

Lanes. The graphic handlers now display. 

2. Change the Left2 Lane width to 4 feet, repeat for the Right2 Lane. 
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Exercise 8.6 Project Explorer Edits 

1. Open the Project Explorer, Select F11 and select the Civil Model tab. If this tab is not shown 

click on the small arrow in the top right corner of the dialog.  

 

2. Expand the RDXSRD01.dgn data tree and navigate to Superelevation > SR61-1 > 

Superelevation Objects > Left 1.  Right click and select Properties. 
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3. In the Element Information dialog, review the Superelevation Lane Properties. 

4. Change the Left1 Lane width to 29 feet, repeat this for the Right1 Lane Width. 

  

  

2

9 2

9 
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Note For this project template, there is no slope break or outside lane so Left2 and Right2 will be remove from 
the Superelevation design. 

 

➢ Delete Lane Shapes for this project template  

1. In the Project Explorer dialog, right click on the Left2 Lane and select Delete. Repeat for 

Right2 Lane. 

 

2. Close the Project Explorer dialog. 
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Exercise 8.7 Superelevation Reports and Diagram Editing 

➢ Create a Superelevation Report 

1. Use the Corridor Modeling, Superelevation Report tool. 

 

2. Select the SR61 Superelevation Section and right click to accept. 
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3. In the Civil Report Browser, Change the report format stylesheet to SuperelevationToCSV.xsl 

 

4. In the Civil Report Browser, select File > Save As. 

5. Change the path folder to C:\e\projects\22049555201\Roadway and the File Name to 

SR61_SE use the Save as type Text File (*.txt). 

 

6. Choose Save and Exit the Civil Report browser. 
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7. This file can be used to edit and re-import superelevation values for the corridor.  

 

8. To use the modified CSV values, first delete all the entries in the Superelevation Editor 

diagram then using this tool,  

9. Locate the csv file in the Roadway directory and import the Superelevation.   
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Exercise 8.8 Assign Superelevation to Corridor 

1. Return to the Default Model of the DSGNRD01 or MODLRD01 file. 

 

2. Attach the Superelevation Design from the RDXSRD01-Xsshrd Model as a Reference file. 

 

➢ Check the Active Template for Superelevation Flags  

1. Use Corridor Modeling, Create Template tool.  

a. Set active the SR61 Template. 

b. Open each of the 4 Pavement Edge Points Properties, and check ON the 

Superelevation Flag option. 
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2. Use Corridor Modeling, Synchronize Template tool. 

 

3. Select the SR61 Template Drop Handle, the Corridor will begin to Re-Process. 

 

4. Use Corridor Modeling, Assign Superelevation to Corridor tool. 
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a. Select the Reference Superelevation Section boundary.  

b. Select the Corridor Boundary for SR61. 

c. The Associate Superelevation dialog displays. Review the Pivot Point and 

Superelevation Point assignment and then click OK. 

 

5. The Corridor will begin to process and display the new model.  

 

6. Select the Function Key F4 to open 4 Views.  Use the Open CrossSection tool to display and 

review the Superelevation on the Corridor. 
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7. Follow the cursor prompts to display the cross section in View 4. 

 

 Use the Locate Station via Data point tool to navigate to the curve area of the alignment with 
superelevation.  
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9 DETAIL MODELING 

 

SR61 CORRIDOR DESIGN DETAILS EXERCISES 

• Intersection Design 

o Build Intersection Terrain at BL98 

o Including TS Nose and Turn Island 

OTHER DESIGN DETAILS 

• Build Intersection Terrain at School Entrance  

• Transition Template for the End of the Project 

• Build Intersections for Friendship Road 

• Add 3D Urban Driveway 

• Add 3D Sidewalk Ramps 

• Add 3D Rural Turn Out  

• Superelevation Vector Offsets for the Median Widening and Curb Gutter Points 

• Superelevation Vector Offsets for the Traffic Separator Widening 
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INTERSECTION DESIGN 

The intersection can be built in parts as shown in the diagram: 

 

The following exercises provide instructions on how to model these with Civil Tools other than the Normal 

Corridor Templates. The steps to design the SR61 intersection have been detailed in the Chapter, Exercises 9.1 

through 9.12.  Once completed follow the same methodology to add further design details 9.13 and 9.14. 

EXERCISE OVERVIEW 

9.1 Plan to Build Intersection Terrain at BL98 

9.2 Add a Component Switch to the RRR98 Template 

9.3 Constructing Vertical Profiles from 3D Model Elements 

9.4 Construct 3D Radius Lines 

9.5 Construct 3D Intersection Limit Lines 

9.6 Build the Intersection Terrain from 3D Elements 

9.7 Create an Intersection Pavement Surface  

9.8 Traffic Separator Nose 

9.9 SR61 Corridor Clipping References 

9.10 Model Curb and Sidewalk around Radii 

9.11 Right Turn Island 

9.12 RRR98 Corridor-Build Intersection Terrain at School Entrance (On Your Own) 

9.13 SR61 Corridor-Build Intersection Terrain at Friendly Road (On Your Own) 
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Exercise 9.1 Plan to Build Intersection Terrain at BL98 

 

The general methodology for building intersection design come from the concept of creating new 3D model 

boundary lines from profiles on the corridor surfaces and 3D lines.  Transition profiles are easily produced with 

the civil tools for the radii.   

These are the general steps to follow: 

1. Develop a seam line between corridors through the intersection,  

2. Create a switch or trigger line on the crossing corridor templates, 

3. Remove outside corridor component elements through the limits of the intersection,  

4. Construct 2D elements around the perimeter of the intersection, 

5. Develop/design the profiles for each of the perimeter line, 

6. Build an intersection terrain boundary using the 3D perimeter elements, 

7. Add break lines if necessary to the intersection terrain, 

8. Add surface templates to the intersection terrain, 

9. Use linear templates along the perimeter edge lines to help transition corridors, 

10. Use corridor clipping tool to clean overlaps between corridor and linear templates.  

 

(Optional) Extract the 22049555201(9).zip file in the c:\e\projects folder. 

Open the DSGNRD01 file and zoom into the Intersection of SR61 and BL98. 

<OR>  Create a MODLRD02.dgn file and create the intersection details in this file. Refer to 

Chapter 6 Corridor Modeling Planning.  
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➢ Turn OFF the Automatic Corridor processing of SR61. 

1. Select the SR61 Corridor handle to display the Context Menu and select Lock - Deactivate 

Rule. 

 

2. Select the Function Key F2 to open the Plan and Model Views together. Zoom into the 

Intersection in both Views 1 and 2.  
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Exercise 9.2 Add a Component Switch to the RRR98 Template 

This exercise adds a Component Switch to the RRR98 template to be used across the limits of the intersection. 

This switch is implemented using a Parametric Constraint on the BL98 corridor to turn off all the outside 

components for the corridor through the intersection.  

1. Use Corridor Modeling, Create Template tool. 

 

2. Set Active the RRR98 template. 

 

3. Using the Template Library Organizer, locate the SWITCHES template in the FDOTSS4.itl 

file 
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4. Drag the SWITCHES template to the project Components folder 

 

5. Choose OK and choose Yes to Save the data to the project template library, 22049555201.itl. 

 

6. With the RRR98 template active, drag the SWITCHES template onto the center of the RRR98 

template 

 

Note The switch template consists of two simple components left and right of the centerline. A label has been 
assign to the horizontal constraint value.  Also, display rules have been created for when the value is 
1,2,3,4, or 5.  By assigning one of the rules to a component, the display of that component and all related 
components can be controlled based on the value of the switch.  
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➢ Create a Parent /Child relationship of all the Left side components. 

1. Open the Component Properties dialog for the Left Cut Component. 

a. Set the Parent Component by using the “pick icon”  , select the LT_PvtOut. 

Note Use the wheel to zoom into the Left Widening LT_PvtOut component or select it from the list 

 

b. Choose Apply and Close the Component Properties dialog.  

c. Repeat this procedure for the Left Fill, and Left Shoulder components.  The Unpaved 

Shoulder and Base components should already have a parent relationship which can be 

used.  

2. Use the Active Template Tab to view the Component Relationships to the LT_PvtOut. 
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3. In the Active Template Component List,  Right click on the LT_PvtOut Component and 

uncheck the Display option,  

4. All of the left side components should turn off,   Right click on the LT_PvtOut Component 

and toggle the Display back on.  

5. In the Active Template Component List, Right click on the LT_PvtOut Component and 

choose Edit. 

6. From the Component Properties dialog, Select Edit on the Display Rules: field 

 

a. Select the Template Display Rule LT_SWITCH1 rule from the list  

b. Build the Conditional Expression NOT LT_SWITCH1 by clicking the NOT button 

and then Selected Rule button 

 

c. Choose OK, then Apply, then Close to save the display rule to the component.  

Note Adding the rule NOT SWITCH1 is  telling the template left side “Not To Display If The Horizontal Distance 
Of The Switch Is The Value 1” 

7. Choose Close and Yes to save change to exit the Create Template dialog.  
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➢ To update the Corridor with the Template changes. 

1. Use Corridor Modeling: Synchronize Template tool; 

 

2. At the prompt, select the BL98 Template boundary. The corridor will re-process with the 

updated RRR98 template.  

➢ To implement the Switch, Add the Parametric Constraint 

1. Use Corridor Modeling, Create Parametric Constraint; 
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a. At the prompt, select the BL98 Corridor boundary.  

b. Snap to the SW Radius for the Start Station. 

c. Snap to the NW Radius for the End Station. 

d. Pick the LT_SWITCH Constraint Label from the list. 

e. Enter 1 for the Start Value. 

f. Enter 1 for the Stop Value. 

 

g. The corridor will re-process with the updated RRR98 Template.  

2. The left outside components of the BL98 corridor are now turned off though the limits of the 

intersection.  
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Exercise 9.3 Constructing Vertical Profiles from 3D Model Elements 

This exercise calculates a Curb Profile between the two EOP Lines, from which it is constructed, in order to 

construct the Intersections Corners.  However, first it’s necessary to add the Model Line Profiles back onto the 

2D elements.  

 FDOTSS4 – with the MR2 release, we have implement 2D Lines from the 3D model.  
In Project Explorer change the PavmentAsphalt_pm feature property to True as 
shown below. Then re-process each corridor to see the resulting construction lines.  
These lines have profiles and can be used in lieu of the steps outlined in the exercise.  

 

1. Use the Vertical Geometry, Project Profile by 3D Element tool. 

 

2. At the prompt select plan Line PavementAsphalt(EOPA).  
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3. From the Model, select the PavtAsphalt_pm Line representing the outside RRR98 EOP in the 

Model. 

  

  

4. Repeat for all 4 lines shown below. 
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Exercise 9.4 Construct 3D Radius Lines 

1. First: Use the Horizontal Geometry Simple Arc tool to create new Construction Line Blue 

Dash features between the two PavementAsphalt EOP edges on both corners. Use 110’ and 

60. 

Note   Note that these will be used to help create automatic profiles for the 3D lines on the Radii.  

 

2. Use Vertical Geometry, Quick Profile Transition tool. 
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3. Accept the Parabolic Quick Transition Method, enter SW_EOP-Pr and select the 

construction line Radius Line create from above. A 3D element should display.  

 

4. Open the Profile View for the SW EOP Curve Radius. 
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5. Repeat the same steps above to create a Profile for the NW_EOP-Pr Line. 
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6. (Alternative to using the Parabolic Option) Follow the next steps.   

a. Open the Profile Model of the Radius Element. 

b. Use Vertical Geometry, Profile Intersection Point tool. 

 

c. Select the NW PavementAsphalt(EOPA) Radius Line as the Element to Show 

Intersections. 

 

d. Select the Right SR61 EOP and Right Turn Lane PavementAsphalt(EOPA) Lines 

respectfully.  
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e. Two white location points will display on the Profile View.  

 

f. Use Vertical Geometry, Profile Line between Points tool and snap to the two 

Intersection Points on the NW Profile View.  

g. Select the new Profile Line. Select the Set Active Profile from the Context Menu 

and the 3D Line will display. 
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Exercise 9.5 Construct 3D Intersection Limit Lines 

1. Use Horizontal Geometry, Line between Points tool.  

a. Use the Feature Definition ConstLinesGreenDash. 

b. Construct a line perpendicular to the Traffic Separator lines and ends at the Radius 

EOP across both Roadways left and right. 

 

2. Use the Vertical Geometry, Open Profile Model and select the newly constructed line. 
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3. On the Profile window, hold down the last icon until a drop down menu displays. 

a. Select the Quick Profile from Surface command. 

 

b. At the prompt, first select the LT_PvtOut Surface in the 3D Model. 

 

c. Then select the LT_PvtWideneIn Surface.  
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d. Continue to add the TSWidenIn Surface. 

 

e. Data point to accept. 

 

4. On the Profile window, hold down the last icon until a drop down menu displays. 

a. Select the Profile Complex By Elements command. 
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b. At the prompt, select the first segment and data point to accept Profile. 

 

5. Use Vertical Geometry, Set Active Profile. 

 

6. Repeat these steps for the other Intersection Limit line. 
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7. Construct an element across the Right Turn Lane from the EOP to the ML line at the Radius 

Point on the NW corner of the Intersection. 

a. Use Vertical Geometry, Profile from Surface tool and select the Right Turn Pavement 

Component. 

b. Use Vertical Geometry, Set Active Profile. 

 

8. Repeat these steps to create the 3D line on the opposite side. 
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➢ Add Profile to Traffic Separator Lines in Plan 

1. Open the profile view for the Traffic Separator line 

2. From the profile view, select the Vertical Geometry, Quick Profile from Surface tool. 

 

3. At the cursor prompt, select the pavement surface, TSWidenT1Opt1In, in the 3D model, view 

2. 

  

4. Repeat this for the opposite Traffic Separator element.  

5. Construct lines using Horizontal Geometry, Single Offset Partial on either side of the Traffic 

Separator. Use .08 feet Offset, 1 inch.  

a. Start the line at the end of the Traffic Separator and Stop at the Intersection Limit 

Construction line.  
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b. Repeat this for both sides. 

 

6. Use Vertical Geometry, Project Slope from Element tool. 

 

a. Project a Profile on the lines from the Traffic Separator Profile. Use 0% Slope. 

b. Select the line and select Set Active Profile from the Context Menu. 
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7. Delete the Traffic Separator Nose Radius Line.  It will be created later with a Civil Cell. 

Note It may need to be dropped from the Left Turn with TS Civil Cell. 

8. Construct a Line across the Traffic Separator Offset Ends. 

9. Create a Profile from the elements that intersect.  Set the Profile as active. 

  

10. Create a 3D Line across the Intersection from Radius to Radius. This will close the Intersection 

boundary. 

11. Construct the Line across the Intersection. 

 Use Single Offset Partial for the Horizontal, and Profile from Element for the Vertical. 
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Exercise 9.6 Build the Intersection Terrain from 3D Elements 

1. Use Terrain Model, Create from Elements tool. 

  

2. Select the 3D Model View to set active and using the Project Explorer, Civil Standards: 

Turn OFF the Corridor Components and Corridor Lines(3D) 
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3. Select the boundary elements for the intersection. 

  

4. Data point to accept.  
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Exercise 9.7 Create an Intersection Pavement Surface  

1. Use 3D Geometry, Apply Surface Template. 

2. Select a Pavement Surface Template from the Template Library and select the Intersection 

Terrain to create pavement.  
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Exercise 9.8 Traffic Separator Nose 

1. In Project Explorer change the Traffic Separator_pm feature property Linear Feature 

Properties to True as shown in Exercise 9.3. Then re-process each corridor to see the resulting 

construction lines.  These lines have profiles and can be used for the steps outlined in this 

exercise. 

2. To add the Traffic Separator Nose use the Civil Cell Place Civil Cell Tool. 

 

3. Select the TSNose Civil Cell. 
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4. Select the Right Side of the Traffic Separator_pm in the Plan View, then select the Left Side 

of the Traffic Separato_pm.  These magenta line have profiles attached either from the model.  

5. While hovering over each of the Reference lines, change the Reference Line direction 

arrow(triangle) on both elements until it fits on the lines. 

6. Data point to accept. 
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Exercise 9.9 SR61 Corridor Clipping References 

1. Use Corridor Modeling, Add Clipping Reference tool. 

 

2. At the prompt, select the SR61 Corridor handle. 
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3. Select the Intersection Terrain Boundary. 

 

4. Reset and the SR61 Corridor begins re-processing. 

 

5. Repeat to add the Intersection as a clipping reference for RRR98 Corridor.  

Note Later the shoulders and sidewalks will be clipped with the Linear Templates added around the radii.  
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Exercise 9.10 Model Curb and Sidewalk Around Radii 

1. Use the Corridor Modeling, Create Template tool. 

 

2. Open the SR61 Template Library. 

 

3. Navigate to the Linear Templates folder. 

  

4. Double click on the Outside Lane w/ Type F Cub Template to make active. 
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5. Make the following edits: 

a. Delete the Pavement and Base. 

b. Change the Template Origin to the Curb PVT_EOP_OUT Point. 

c. Change the Utility Strip Horizontal Value to Zero. 

d. Change the Back of Sidewalk to 6 feet. 

e. Add the 6:1 Fill and Cut End Conditions, set the End Points to Infinite. 

 

6. Close the Create Template dialog and click Yes to Save Changes. 

7. Use 3D Geometry, Apply Linear Template tool. 
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a. At the prompt select the SW_EOP Construction Radius Line in the Plan View. 

 

b. Select Alt down arrow to select the Template, Outside Type F Curb.  Data Point to 

accept the Template. 

 

c. Select Alt to lock the Start Station and data point to accept. 

d.  Select Alt to lock the End Station and data point to accept. 
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e. Data point to accept the Reflect Orientation. 

f. Data point to accept the Exterior Corner Sweep Angle. 

 

8. Repeat the steps above for the NW EOP Construction Radius Plan Element. 

 

 To turn off the Blue triangles, toggle off the DTM and DTM Triangles. 
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9. Use Corridor Modeling, Add Clipping Reference tool. 

 

a. At the prompt, select the SR61 Corridor handle. 
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b. Select the 2 Linear Template Boundaries as Clipping References. 

c. Data point to accept the Corridor clipping. 
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Exercise 9.11 Right Turn Island 

1. For this exercise, an Island Curb will need to be retrieved from the FDOTSS4.itl file.   

a. Use the Create Template, Template Library Organizer to add the Curb Type E 

Inside to the project .itl file. 

 

2. Use Vertical Geometry, Open Profile Model tool. 
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a. Select the Turn Island shape and select View 3. 

 First toggle off the PavtAsphalt(EOP) level  

b. In the Profile Model View 3, select the Quick Profile from Surface command. 

 

c. At the prompt, select the Intersection Terrain Surface DTMPrInt in the 3D Model 

View 2. 

Note It may be necessary to tab over the surface features in intersection in order to select the terrain element.  

1 
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d. Data point to accept. A new Profile will display. 

 

e. Select the Profile and select Create Best Fit Profile. 
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f. Enter the Best fit Parameters as shown. 

 

g. Create the Best Fit Profile, select the new Profile and select Set As Active. 

h. The Island Boundary is created in the 3D Model. 
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3. Use 3D Geometry, Apply Linear Template tool. 

 

a. At the prompt select the Island Line in the Plan View. 

 

b. Select Alt down arrow to select the Template, Curb Type E.  Data point to accept the 

Template. 
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c. Select Alt to lock the Start Station and data point to accept. 

d.  Select Alt to lock the End Station and data point to accept. 

e. Data point to accept the Reflect Orientation. 

f. Data point to accept the Exterior Corner Sweep Angle. 

 

g. To create the sod within the Traffic Island, Use Terrain Model, Create from Elements 

tool. 
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h. Create a Terrain from the 3D Top Back Curb line.   

 

4. To change the Terrain Triangles display, 

a. Select the new Terrain DTMPr_Island and open the properties, Element Information 

dialog.  

b. Change the level for the Calculated Features Display Triangles to ShldUnpaved_px 

and change the class from construction to primary. 
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5. Use the Terrain Model, Create Clipped Terrain Model tool 

 

a. Select the Intersection terrain and then select the island boundary and choose Internal  
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Exercise 9.12 RRR98 Corridor-Build Intersection Terrain at School Entrance (On Your 

Own) 

1. Create a shape boundary of the perimeter of the School Driveway pavement to be resurfaced. 

2. Use the Create Clipped Terrain Model tool to model the existing pavement. 

3. Add a surface template to the Terrain in step 2. 

4. Use the RT_Switch parametric constraint along the RRR98 corridor to remove the overlap 

components between radius points. 

5. Add Key Station to near the radius points to create complete components 

6. Use Linear Template around the Radii to construct the curb, sidewalk, shoulder, etc.  

a. Set the Template Origin and Pavement Point as shown 

 

b. Add the PavementMilling(ML) lines a reference to the linear templates to complete the 

widening. 
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Exercise 9.13 SR61 Corridor-Build Intersection Terrain at Friendship Road (On Your Own) 

1. Drop the Complex Chain that makes up the EOP Lines and Radius. 

2. Create a Corridor Model of the Friendship Road.   

3. Edit the Template Drop and delete all Components outside of widening. 

4. Project Profile to Element on the Curve EOP lines <OR> Quick Profile from Surface. 

5. Construct a Profile from the Projected Surface Lines for the Curve Radii. 

6. Use Linear Template around the Radii. 

7. Create a Terrain from the 3D elements. 

 For the Traffic Separator to Pavement Crown Cross over median, set the LT_XOVER_CTL, 
RT_XOVER_CTL, and PVT_CROWN Properties as shown: 
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10 CREATING 3D DELIVERABLE FILES  

INTRODUCTION 

This chapter will provide detailed instructions for producing the specific output files used by contractors for 

Automated Machine Guidance (AMG).  Specifically: 

• Controlling Geometry Files 

• 2D CADD files 

• Proposed 3D Breakline CADD files 

• Existing, Proposed and Subgrade/Earthwork surface XML files 

3D DELIVERABLES SUPPORTING AMG for 3D PROJECTS 
(Store in project folder:  3DDeliverables) 

File Name Description 

Design Alignments and Profiles 

AMG-ALGN##.xml 
All Alignments and Profiles exported from the \Roadway\ALGNRD, PROF or 

model files and \Roadway\DSGNRD or CORRRD files in LandXML format. 

2D Proposed Planimetrics Design 

AMG-2DSGN##.dwg/dgn 
2D proposed Roadway design exported from the \Roadway\DSGNRD file.  

(Production of this file for construction is at the designer’s discretion.) 

AMG-2DRPR##.dwg/dgn 
2D proposed Drainage design exported from the \Roadway\DRPRRD file. 

(Production of this file for construction is at the designer’s discretion.) 

AMG-2PDPL##.dwg/dgn 
2D proposed Pond design exported from the \Roadway\PDPLRD file. 

(Production of this file for construction is at the designer’s discretion.) 

2D Existing Survey  (Note: These are being considered to merge into a single survey Planimetrics file) 

AMG-2TOPO##.dwg/dgn 
2D proposed existing Topography exported from the \Survey\TOPORD file. 

(Production of this file for construction is at the designer’s discretion.) 

AMG-2DREX##.dwg/dgn 
2D proposed existing Drainage exported from the \Survey\DREXRD file. 

(Production of this file for construction is at the designer’s discretion.) 

AMG-2UTEX##.dwg/dgn 
2D proposed existing Utilities exported from the \Survey\UTEXRD file. 

(Production of this file for construction is at the designer’s discretion.) 

3D Existing Survey Surfaces 

AMG-3SURFACEEX##.xml 

3D existing terrain surface to be exported from the \Survey\GDTMRD file as 

LandXML format. 

(Production of this file for construction is at the designer’s discretion.  This file 

will be produced if the 3D Existing Surface dwg/dgn file(s) are not produced.) 

3D Proposed Surfaces 

AMG-3SURFACEPR##.xml 
3D proposed finished (top) surface to be exported as LandXML format from the 

\Roadway\MODLRD file.  

AMG-3SURFACEEW##.xml 

3D proposed finished (bottom) surface to be exported as LandXML format from 

the \Roadway\MODLRD file. This file will be used to generate surface to 

surface earthwork volumes. 

3D Proposed Break Lines 

AMG-3DSGN##.dwg/dgn 

3D proposed Roadway design exported from the \Roadway\DSGNRD file. 

(Production of this file for construction is at the designer’s discretion.  This file 

will be produced if the 3D Proposed Surface(s) LandXML file(s) is not 

produced. Geometric elements should be in vector.) 



Chapter  10 _________________________________ CREATING 3D DELIVERABLE FILES - Creating Alignment XML File for AMG 

10-2 ©2018 FDOT FDOT Roadway Design and 3D Modeling 

EXERCISE OVERVIEW 

10.1 Creating Alignment XML File for AMG 

10.2 Creating 2D Proposed Lines File for AMG 

10.3 Creating Existing Surface File for AMG 

10.4 Creating 3D Breaklines and Proposed Surface Files for AMG 

10.5 Creating 3D Breaklines and Proposed Subgrade/Earthwork Files for AMG  

10.6  Use LandXML Visualizer to Validate Land XML File 

 

Exercise 10.1 Creating Alignment XML File for AMG 

You can export Alignments and Profiles directly from the elements in the DGN file. 

1. Open the DSGNRDxx.dgn. 

2. Select and hover over an Alignment.  Select Horizontal Geometry Report from the Context 

Menu. 

 

3. In the Bentley Civil Report Browser select the Civil Geometry > 

AlignmentsToLandXML.xsl report. 
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4. Select File > Save As  

a. Navigate to the 3DDeliverables directory. If it doesn’t exist, use create new folder.  

 

b. Enter the File name: AMG-ALGNSR61.xml 

c. Select Text File (.txt) as the Save as type.  

d. Click Save.   

5. Repeat for the AMG-ALGNBL98.xml 

  

Note This will save both the Horizontal and Vertical (Profile) Geometry. 
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Exercise 10.2 Creating 2D Proposed Lines File for AMG  

Use the MicroStation Save As command to save copies of the Proposed Design files into the 3DDeliverables 

directory with AMG-2 names in DGN and DWG formats. 

For example: AMG-2DSGNRDxx.DGN, AMG-2DSGNRDxx.DWG. 

➢ Simplify MicroStation Elements 

1. Open the DSGNRDxx.dgn. 

2. Select the Plan View to make active. Select Function Key CTRL F1 to open a Plan View.  

3. In the View Attributes, turn Off Construction elements<OR> Select Function Key F7. 

4. Turn Off reference file display 

5. Turn Off levels for Baseline, CLConstr., and Scratch 

6. Place a Fence around all Elements in the design file. 

7. Enter ff= ..\3DDeliverables\AMG-2DSGNRD01.  

<Or> use the Copy Fence Contents dialog. 

 

8. Data point to accept. 

9. Verify the file is in the 3DDeliverables directory. 
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➢ Save as DWG(Optional) 

1. Open the .\3DDeliverables\AMG-2DSGNRD01 design file. 

2. Select File > Save As from the MicroStation menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog 

4. Verify or Enter the File Name, AMG-2DSGNRDxx and click Save. 

5. Select the Units Survey Feet and click OK. 

 

Note The file will open in DWG Work Mode, see the blue cross hairs icon in the bottom right of the MicroStation 
window  
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Exercise 10.3 Creating Existing Surface File for AMG  

1. Open the DSGNRD01.dgn file. Display 2D and 3D Views and Select Function Key F2. 

2. Turn ON the Reference file display for GDTMRD02 or SURVRD01. 

3. Select and hover over the Existing Surface and then select Export Terrain Model > 

LandXML. 

 

4. Select the Terrain. 

5. Select the Export Format: LandXML 

6. Enter the Project Name: AMG-3SURFACEEX01  

7. Enter the Project Description: Existing Surface 

8. Select the Export Options: Export Both 

 

9. Save the AMG-3SURFACEEX01.xml file to the 3DDeleverables directory. 
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Exercise 10.4 Creating 3D Breaklines and Proposed Surface Files for AMG  

This exercise outlines the steps to create the proposed surface of the project for use by contractors for automated 

machine guidance as follows:  

Prepare the View for Exporting 

Exporting 3D Break Lines 

Creating Proposed Surface Files for AMG 

Delete extraneous triangles 

➢ Prepare View for Exporting 

1. Open the DSGNRDxx.dgn or MODLRDxx file.  To Display 2D and 3D Views, select Function 

Key F2. 

2. Turn OFF the Reference File display for: 

o GKLNRD01.DGN 

o GDTMRD02.DGN or SURVRD01.DGN 

 

3. Set the Corridor Design Stage to Final. 

 

4. Maximize the View 2 – Default-3D. 

5. Change the View Rotation to a Top view 
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6. Open Project Explorer Use the Function Key F11 . Navigate to Civil Standards > Active file 

>Feature Definitions.  Uncheck Corridor Components folder to turn OFF Mesh Solid 

elements. 

7. Use Project Explorer Civil Standards > Active file >Feature Definitions.  Uncheck Plan(2D) 

folder to turn OFF Lines created from Active Profiles 

  

8. Use the Function Key F7 to turn OFF all Construction elements in the 3D View.  
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9. In Project Explorer Civil Standards > Active file >Feature Definitions.  Open the Corridor 

Lines(3D) folder to uncheck any proposed sub-surface features and other non-proposed 

surface features.  

i.e.  Bottom_pm,  

Subgrade_pm 

CurbBase_pm,  

PavementBase_pm,  

ShoulderBase,  

TemplateMisc_pm,  

TemplateNullPoint_pm.  

  

10. Use Level Display dialog to turn off the default level in the Default 3D view 

Note Use Level Display dialog to turn off remaining levels to use for the 3D Proposed breakline surface.  i.e. 
Default level, Scratch_dp, Miscellaneous, ConstLines, etc 

➢ Exporting 3D Break Lines. 

1. Place a Fence around all the Elements in the default-3D View.  
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2. Enter ff= ..\3DDeliverables\AMG-3DSGNRD01. Or use the copy fence contents dialog. 

 

3. Data point to accept and verify the file is in the 3DDeliverables directory. 

➢ Save as DWG(Optional) 

1. Open the 3DDeliverables\AMG-3DSGNRD01 design file. 

2. Select File > Save As from the MicroStation Menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog 

4. Verify or Enter the File Name, AMG-3DSGNRD01 and click Save. 

5. Select the Units Survey Feet and click OK. 

 

Note The file will open in DWG Work Mode, see the blue cross hairs icon in the bottom right of the MicroStation 
window. Open the dwg file and trim extraneous elements as necessary 
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➢ Creating Proposed Surface Files for AMG  

1. In FDOTSS4, Select File >Open to the AMG-3DSGN01.DGN file. Click Open File and click 

OK. 

2. Create a Selection Set of all Elements. 

3. Use Civil Tools, Terrain Model, Create From Elements tool. 

 

4. Define the following in the Create Terrain Model dialog: 

o Feature Type:   Break Line 

o Edge Method:   None 

o Feature Definition:  DTMProposed 

o Name:   AMG-3SURFACEPR01 

 

5. Data point through prompts to accept settings. A Surface is created.  Use Function Key F2 to 

turn ON/OFF the construction elements 
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6. Notice the External Triangles must be trimmed. 

 

7. Turn Off the Level DTM_px  . 

8. Create a Selection Set of all the Cut_pm and Fill_pm Lines defining the slope construction 

limits. 

9. Use Civil Tools, Terrain Model, Change Feature Type tool. 

 

10. Set the Feature Type to Boundary. 

11. When prompted left click twice to change all the selected lines to boundary elements for the 

External Limits of the Surface. 

12. Turn ON the DTM_px level to see the results. 
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➢ To delete extraneous triangles 

1. Select and hover over the Surface Terrain edge and then select Rules>Remove Rule.  

Note This will break the relationship to the 3D elements! 

 

2. Use Civil Tools, Terrain Model, Edit Terrain Model tool 

 

3. From the tool settings menu, select Delete Triangle By Line 
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4. Draw a line (two left clicks) from outside the terrain across the erroneous triangle, then repeat 

as necessary.  
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➢ Save Terrain to Land XML file 

1. Select and hover over the Surface and then select Export Terrain Model > LandXML. 

 

2. Select the Terrain. 

3. Select the Export Format: LandXML 

4. Enter the Project Name: AMG-3SURFACEPR01.xml  

5. Enter the Project Description: Proposed Surface 

6. Select the Export Options: Export Both 

 

7. Save the file to the 3DDeleverables directory. 
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Exercise 10.5 Creating 3D Breaklines and Proposed Subgrade/Earthwork Files for AMG  

This exercise outlines the steps to create the proposed surface of the project for use by contractors for automated 

machine guidance as follows:  

Prepare the Templates for Subgrade Point definitions and Alternate Surfaces 

Prepare the View for Exporting 

Exporting 3D Break Lines 

Creating Proposed Surface Files for AMG 

Delete extraneous triangles 

The 3D proposed finished subgrade surface to be exported as LandXML format from the \Roadway\MODLRD 

file. This file can be used to generate surface to surface earthwork volumes 

The subgrade surface can be created from the 3D feature lines provided that they have been defined properly in 

the point definitions on all project corridor, linear and surface templates. 
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➢ Prepare the Templates for Subgrade Point definitions and Alternate Surfaces 

In the Create Template dialog, edit each of the points defining the finished subgrade. Set the Feature 

Definition and Alternate Surface fields to SubGrade_pm and SUBGRADE, respectfully.    

When creating surface terrains from 3D lines, there are two important TIN principles for consideration:  

a. Vertical Faces – all lines must have different xy values.  They cannot be stacked 

in the z plane. Therefore, set the horizontal offset value no less than .01 feet on vertical 

component points in the project templates 

b. Caves/Cliffs –  all lines must continue in the same direction.  The TIN triangles 

will not reverse direction across a surface. Therefore, consider which points to use 

for the subgrade surface. I.E. base, base extensions, wall footers, etc.  Additional 

template points may be needed to intercept the top surface in these areas. As a rule, it 

is better to include the base, base extensions, wall footers, etc for excavation and not 

to include base, base extensions, wall footers, etc for embankment.  

Note These template accommodations are necessary to consider for ALL Corridor, Linear and Surface 
Templates used on the project. 

  

The following images are examples of the point properties dialog, highlighted Subgrade_pm Point Feature 

Definition, and the highlighted SUBGRADE Alternate surface.  In this example the base extension is not 

included in the subgrade surface definition.  
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➢ Prepare the View for Exporting 

1. Open the DSGNRDxx.dgn or MODLRDxx file.  To Display 2D and 3D Views, select Function 

Key F2. 

2. Turn OFF the Reference File display for: 

GKLNRD01.DGN 

GDTMRD02.DGN or SURVRD01.DGN 

 

3. Set the Corridor Design Stage to Final for all the corridors and linear templates. 

 

4. Open both the Project Explorer and Element Properties Dialogs, Navigate to the Civil 

Model>Active Design file > Terrain Models. 

5. For EACH Terrain Model Surface Templates, Set the Create Linear Features option to True.  
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6. Maximize the View 2 – Default-3D. 

7. Change the View Rotation to a Top view 

 

8. In Project Explorer > Civil Standards > Active file >Feature Definitions.  Uncheck Corridor 

Components folder to turn OFF Mesh Solid elements. 

9. Use Project Explorer Civil Standards > Active file >Feature Definitions.  Uncheck Plan(2D) 

folder to turn OFF Lines created from Active Profiles 

  

10. Use the Function Key F7 to turn OFF all Construction elements in the 3D model view.  
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11. In Project Explorer Civil Standards > Active file >Feature Definitions.  Open the Corridor 

Lines(3D) folder to check only-proposed subgrade surface features.  

i.e.  Cut_pm,  

Fill_pm,  

MedianCrown_pm,  

ShoulderUnpavBreak_pm,  

Subgrade_pm,  

  

12. Use Level Display dialog to turn off the default level in the Default 3D view 

Note Use Level Display dialog to turn off remaining levels to use for the 3D Proposed Subgrade breakline 
surface.  i.e. Default level, Scratch_dp, Miscellaneous, ConstLines, etc. 
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➢ Exporting 3D Break Lines. 

1. Place a Fence around all the Elements in the default-3D View.  

 

2. Enter ff=..\3DDeliverables\ AMG-3DSGNRDEW01.dgn.  

3. Or use the copy fence contents dialog. 

 

4. Data point to accept. 

5. Verify the file is in the 3DDeliverables directory. 
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➢ Save as DWG(Optional) 

1. Open the 3DDeliverables\ AMG-3DSGNRDEW01.dgn design file. 

2. Select File > Save As from the MicroStation Menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog 

4. Verify or Enter the File Name, AMG-3DSGNRDEW01 and click Save. 

5. Select the Units Survey Feet and click OK. 

 

Note The file will open in DWG Work Mode, see the blue cross hairs icon in the bottom right of the MicroStation 
window. Open the dwg file and trim extraneous elements as necessary 
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➢ Creating Proposed Subgrade Surface Files for AMG  

1. In FDOTSS4, Select File >Open to the AMG-3DSGNEW01.DGN file. Click Open File and 

click OK. 

2. Create a Selection Set of all Elements. 

3. Use Civil Tools, Terrain Model, Create From Elements tool. 

 

4. Define the following in the Create Terrain Model dialog: 

o Feature Type:   Break Line 

o Edge Method:   None 

o Feature Definition:  DTMProposed 

o Name:   AMG-3SURFACEEW01 
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5. Data point through prompts to accept settings. A Surface is created.  Use Function Key F2 to 

turn ON/OFF the construction elements 

6. Notice the External Triangles must be trimmed. 

 

7. Turn Off the Level DTM_px  . 
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8. Use Civil Tools, Terrain Model, Change Feature Type tool. 

 

9. Set the Feature Type to Boundary. 

10. Select each of all the Cut_pm and Fill_pm Lines individually defining the slope construction 

limits. Right click to finish when all the selected lines to boundary elements for the External 

Limits of the Surface. 

Note A Selection Set for Cut/Fill Lines does not produce the desired results for the creation of the Subgrade 
surface Terrain 

11. Turn ON the DTM_px level to see the results. 
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➢ Save Terrain to Land XML file 

1. Select and hover over the Surface and then select Export Terrain Model > LandXML. 

 

2. Select the Terrain. 

3. Select the Export Format: LandXML 

4. Enter the Project Name: AMG-3SURFACEEW01.xml  

5. Enter the Project Description: Proposed Surface 

6. Select the Export Options: Export Both 

 

7. Save the file to the 3DDeleverables directory. 
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Exercise 10.6 Use Land XML Visualizer to Validate Land XML File 

1. From the desktop locate and open the FDOTSS4 Product Folder 

  

2. Open the Land XML Visualizer tool 

3. On the Land XML Visualizer tool, select File Open. Choose the AMG-

3SURFACEPR01.xml file 
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4. Change the Plan View Setting to Default, No Fill, No Vectors and No shading as shown 

below.  Also, right click on the Pnts definition and choose Hide 
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