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Advanced 3D Modeling 
Description 

This is a 2-day training course to include fundamentals of 3D Modeling. Participants will continue to learn the 

Bentley OpenRoads Designer Connect Edition tools for design and modeling within the FDOTCONNECT 

workspace.  Several advanced concepts and technologies will be introduced including:  

• Rule Based Superelevation Design Parameters 

• Associating Template Points to Superelevation Lanes 

• Constructing 3D Elements 

• Building Intersection Terrains from 3D Elements 

• Appling a Surface Depth to Terrain Elements 

• Placing 3D Civil Cells 

• Configuring Advanced 2D and 3D Civil Cells 

• Corridor and Terrain Model Clipping 

•  Applying Linear Templates to 3D Elements 

• Building DTM, XML Files for Construction Deliverables 

Objectives 

• Create a Superelevation Shape Model. 

• Create Superelevation Sections and Lanes. 

• Calculate and Assign Superelevation to a Corridor. 

• Create an Intersection Terrain Model from 3D Elements. 

• Create a Traffic Separator Nose Model on the Corridor Model. 

• Create an Island Model on an Intersection. 

• Apply Linear Corridors along 3D Elements. 

• Create 3D Driveway on a Corridor Model. 

• Create 3D Sidewalk Ramps on Intersection Model. 

• Prepare the Files Necessary for Construction Deliverables. 

Audience 

• FDOT Roadway Designers and Engineers 

Prerequisites 

Participants need to have a basic understanding of Computer Aided Drafting and Design (CADD) using 

MicroStation, a basic understanding of OpenRoads Designer Connect Edition concepts and a solid understanding 

of the engineering necessary to design a Roadway. 

In addition to the above, the participant is required to complete:  

FDOT Roadway Design and 3D Modeling - Basic Training. 

Duration: 16 Hours   

Professional Credit Hours:  16 PDHs 

Note PDH Credit will only be available with Instructor lead or Computer Based Training (CBT) thru Learning 

Curve.  
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INTRODUCTION 

This course was developed to introduce OpenRoads Designer CONNECT Edition - OpenRoads Technology tools 

for design and modeling on Florida Department of Transportation (FDOT) projects.  The curriculum was 

developed within the FDOTCONNECT Workspace to provide sample exercises for most of the new Civil Tools 

on a sample project data set. 

COURSE OBJECTIVES 

Participants of this course will be introduced to the newest OpenRoads Technology and a Workflow for 

designing two dimensional (2D) Plans, Profiles, Cross Sections and three dimensional (3D) Models for 

Construction Deliverables.  At successful completion they will have learned how to: 

• Create a Terrain Element from the existing surface to be used as a reference for the project. 

• Develop Existing Feature Terrain Surfaces to be shown on cross sections and used in earthwork calculations. 

• Use Civil Geometry Elements in the design file to calculate and define a proposed centerline of construction 

and while using the built in Design Standards Criteria checking. 

• Use Civil Geometry Elements in the design file to define the roadway features of the proposed design. 

• Apply Civil Cells delivered within the FDOTCONNECT Civil Cell DGN library. 

• Use Civil Geometry Elements in the design file to define the vertical profiles of a proposed centerline. 

• Use the Standard Components and Templates within the FDOTCONNECT Template library. 

• Create a 3D Model of the existing and proposed Roadways. 

• Reference 2D Civil Geometry Elements to a Corridor Model by adding the elements for use as design model 

control lines. 

• Apply varying Typical Section conditions along the project, including: variable medians, special ditches, 

handrail checks, gravity wall placement, slope conditions, left and right turns, etc. 

• Define the Superelevation Standards along a corridor. 

• View Dynamic Cross Sections for review, updates, and design checks along the project before cross sections 

are created for printing. 

• Create and display 3D Models for better designing and visualization. 

• Use the Milling Overbuild and Overlay Components on a project corridor. 

• Apply Corridor Modeling Techniques used for developing driveways and intersection, etc. 
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EXPECTATIONS – WHAT THIS COURSE PROVIDES 

This course provides a standard workflow for designing a project with Bentley Systems OpenRoads Designer 

CONNECT Edition - OpenRoads Technology within the FDOTCONNECT Workspace. Although the majority 

of tools are used throughout, this course does not provide a description of every Bentley Systems OpenRoads 

Designer CONNECT Edition - OpenRoads Technology Civil Tool.  Integrated help for each of the tools can 

be found by selecting FILE then going to the backstage and selecting Help to bring up Bentley’s ONLINE HELP 

or from the Ribbon pick the HELP icon.   

 

FILE>HELP 
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DOCUMENT STYLE 

Style conventions used throughout the course guide are shown in the following table. 

Item Convention Example 

Menu names 

and 

commands 

Bold N 

(Names separated 

with > symbol) 

• File > Open 

• File > ComSelect > Design 

Dialog box 

Actions 
Bold 

 

• Click the Apply button. 

• Click the Graphic Select button to the right 
of the Horizontal Alignment Include box. 

• In the Segment Type list, click Lines. 

Dialog box 

Field Names 
Italic • Key in Hemfield Road in the Alignment 

Name field. 

• Click the Graphic Select button to the right 
of the Horizontal Alignment Include field. 

• In the Segment Type list, click Lines. 

Key-ins Bold • Key in Hemfield Road in the Alignment 
Name field. 

File Names Italic • Open the file  ALGNRD01.dgn in the 
C:\WorkSets\FDOT\22049555201\Roadway. 

File Paths Non italic 

 

• Open the file  _Blank.dgn in the 
C:\WorkSets\FDOT\22049555201 

New Terms 

or Emphasis 
Italic 

 

• The Template Library contains templates, 
which represent typical sections of the 
proposed roadway. 

 

We would like to introduce the user to a new workflow terminology using the Ribbon if you see a direction like this: 

OPENROADS MODELING>GEOMETRY>HORIZONTAL>Lines>Line From Element>Simple Line From 

Element 

This means we are in the WorkFlow of OpenRoads Modeling which has a Tab named Geometry, and has tools 

that are located in the Horizontal Group. Now that we are in the right workflow, Tab and Group we may need 

to click on a tool that has more than one option. 
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FILE TYPES 

The Bentley Systems OpenRoads Technology road design process uses a single source file type, the DGN file.  

All pertinent design data is stored in the design file. This information can be viewed through the Project Explorer 

and reported on in the Civil Report Browser. 

Below is a brief description of some file types which can be imported or exported (i/o) with OpenRoads 
Technology. 

File Type Description: 

• Surface.tin  (i/o) - A binary file, also known as a GEOPAK digital terrain model (DTM),that stores features 

made up of random points, break lines, and boundary data along with triangulated surface model. The features 

and the triangles together represent an existing ground surface. 

• Surface.xml (i/o) – A text based file, LandXML format, which stores civil data such as surfaces, breaklines, 

or horizontal and vertical alignments 

• Surface.dat (i) - A binary (or ASCII) file containing string and point information that is used for digital terrain 

model construction. 

• Surface.dtm (i/o) – A binary file, also known as a Roadway Designer digital terrain model that stores features 

made up of components, break lines, and boundary data along with triangulated surface model. The features 

and the triangles together represent either existing ground surface or the proposed roadway corridor model. 

• Template Library.itl (i) - Stores templates and template components. Different components can be assembled 

to build templates, which define the typical sections of a roadway. Only one Template Library file may be 

open for editing at a given time. 

LEARNING RESOURCES 

There are several resources available for learning about the various Bentley Systems OpenRoads Designer 

CONNECT Edition OpenRoads Technology tools. Among them are: 

• Bentley Communities:  

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/33435/openr

oads-designer 

http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-technotes-

faqs.aspx 

• Bentley Learn: 

Bentley Institute site is for registered user and may require a Select Server site license to participate:  

https://learn.bentley.com 

• Bentley Product OpenRoads: 

Videos are available on a variety of topics: https://www.Bentley.com 

• YouTube: 

Bentley OpenRoads Videos are available on a variety of topics: http://www.youtube.com/user/BentleyCivil 

• YouTube Search - Google:  

Bentley OpenRoads returns several sites with videos for learning how to apply the technology on project 

specific situations. 

• Production Support Office | CADD (CADD) Website:  http://www.fdot.gov/cadd/ 

Webinar training recordings are available on many of the subjects covered in this manual:  

http://www.fdot.gov/cadd/main/FDOTCaddTraining.shtm 

https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/33435/openroads-designer
https://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/33435/openroads-designer
http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-technotes-faqs.aspx
http://communities.bentley.com/products/road___site_design/w/road_and_site_design__wiki/7021.openroads-support-clips-technotes-faqs.aspx
https://learn.bentley.com/
http://www.bentley.com/
http://www.youtube.com/user/BentleyCivil
http://www.fdot.gov/cadd/
http://www.fdot.gov/cadd/main/FDOTCaddTraining.shtm
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http://www.fdot.gov/cadd/downloads/webinars/Posted.shtm#loadSection 

https://www.youtube.com/channel/UCqbY8kqZuXp1pyYV6lIQw_A 

COURSE SUPPORTING FILES 

The exercises for each chapter are independent of one another and can be used without having to complete the 

exercises in previous modules. The exercise files are organized into separate completed Selected zip files for each 

chapter.  All files used in this course are located also at this link: 

https://www.fdot.gov/cadd/downloads/documentation/fdotconnecttraining/fdotord/fdotconnect-roadway-

design-3d-modeling 

INTRODUCING A NEW WORKSPACE 

FDOTCONNECT PREDEFINED SETTINGS 

 

DESIGN FILE SETTINGS: 

   

http://www.fdot.gov/cadd/downloads/webinars/Posted.shtm#loadSection
https://www.youtube.com/channel/UCqbY8kqZuXp1pyYV6lIQw_A
https://www.fdot.gov/cadd/downloads/documentation/fdotconnecttraining/fdotord/fdotconnect-roadway-design-3d-modeling
https://www.fdot.gov/cadd/downloads/documentation/fdotconnecttraining/fdotord/fdotconnect-roadway-design-3d-modeling
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FDOTCONNECT WORKSPACE PREFERENCES: 
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FDOTCONNECT FUNCTION KEYS  

FDOTCONNECT Function Key Assignments 

F1 Opens the OpenRoads Designer OnLine Help. Ctrl+F1 Closes all Views except View 1 

F2 Open View 1 (2D Plan) and View 2 (3D Isometric) and fits both views. 

F3 Opens View 3 (2D Plan), closes all View 4, and arranges all Views. 

F4 Open View 1 (2D Plan) , View 2 (3D Isometric), View 1 (2D Plan), View 1 (2D Plan) & 

Fits All views 

F5 Toggles Dim References ON/OFF 

F6 Resets out of any ongoing commands. 

F7 Toggles the Construction view attribute ON/OFF. 

F8 Toggles between MicroStation AccuDraw and Civil AccuDraw. 

F9 Toggles (opens or closes) the Reference dialog. 

F10 Toggles (opens or closes) the Level Display dialog. 

F11 Toggles (opens or closes) the Project Explorer dialog. 

F12 Opens the Create Template dialog. 
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• Function Key F1 – Civil Help 

 

  

• Function Key F2 – Open and Fits Two Views Setup; View 1- 2D Plan, View 2-Isometric. 
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• Function Key F3 – Opens View 3; Closes View 4 and Arranges Views. 

 

• Function Key F4 – Opens and fits Four View Setup; View 1- 2D Plan, View 2-Isometric, View 3,4 - custom 
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• Function Key F5 – Toggle Dim References. 

  

• Function Key F6 – Resets Out of Any Ongoing Commands. 

 

• Function Key F7 – Toggles On/Off Construction View Attributes. 
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• Function Key F8 – Toggles Between MicroStation AccuDraw and Civil AccuDraw. 

  

• Function Key F9 – Toggles Reference Dialog Open\Close. 

 

• Function Key F10 – Toggles Level Display Dialog Open\Close. 
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• Function Key F11 Toggles Project Explorer Dialog Open/Close. 

  

• Function Key F12 Corridor Modeling, Opens Create Template Dialog. 
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FDOTCONNECT USER CONFIGURATION VARIABLES 

  

FDOTCONNECT DESIGN AND 3D MODELING OVERVIEW 
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GENERAL WORKFLOW AND CHAPTER OUTLINE 

1. Existing Terrain and Existing Features 

2. Design Centerlines Alignments  

3. Prepare 2D Plan Layout 

4. Design Profiles 

5. Define Project Templates 

6. Create 3D Design Model and add 2D References 

7. Create Cross Section View 

8. Define Superelevation and Assign to the Corridor Model 

9. Detail Modeling for Intersections, Median Traffic Separator Nose, Side Roads, 

Driveways, Curbs Ramps, etc. 

10. Prepare Construction Deliverables 

RECOMMENDED MICROSTATION SETTINGS 

Various tools and settings will be used throughout the workshop. Therefore, for quick accessibility, several of 

the dialogs are better docked on the sides the MicroStation view. 

GETTING STARTED 

LAUNCHING FDOTCONNECT FOR OPENROADS DESIGNER 

FDOT Connect can be launched from the FDOT – Roadway and FDOT – ROW icons located in the 

FDOTConnect folder on your desktop.  The first time it is launched, it is important to select the FDOT 

workspace from the workspace dropdown. 

1. Find the FDOT Connect launch icons on your desktop or locate the “FDOTConnect” folder on 
your desktop.  

  

2. Launch FDOTConnect for OpenRoads Designer by double-clicking one of the FDOT icons. 

Note that your FDOTConnect launch icons will vary depending on which Bentley Connect 

Edition platforms you have installed. FDOTConnect will create an icon for OpenRoads 

Designer, an icon for Microstation Connect Edition (MSCE), and an icon for OpenBridge 

Modeler (OBM) depending on which of these applications is present on your machine during 

installation of the Workstation or Client. (This release of FDOT Connect is the “Alpha test” 

version for OpenBridge Modeler).  
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1. In the Workspace/Workset select screen of OpenRoads Designer, select the Workspace 

selection drop-down menu by clicking on “No Workspace.” 

 

2. Select “FDOT” from the drop-down menu to select the FDOTConnect workspace. 

   

3. From here, you can now create a new WorkSet, this is done by selecting the drop-down menu, 

being sure to select the FDOT’s “0_WORKSET_TEMPLATE” as the workset template.  
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4. Click “OK” after filling in the Create Workset dialog. 

 

5. After creating a new project using the FDOT Workset Template, you can create new files using 

the FDOT Create File tool.  This tool is launched from within the FDOTConnect workspace, 

so you must first open a file.  The FDOT Workset template includes a blank starting file from 

which to launch the Create File tool. 

6. From the OpenRoads Designer file open dialog, select “Browse” to browse the contents of 

your new workset. 

 

7. Locate “_Blankfile.dgn” at the root of your workset folder structure. Select this file and then 

select “OPEN” to open it. 
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8. When the FDOTConnect Workspace opens, you can locate the FDOT ribbon by selecting the 

“OpenRoads Modeling” workflow from the menu at the top left of the screen. The FDOT tab 

is located at the far right of this ribbon.  Select “Create File” to launch the Create File tool for 

creating FDOT project files.  
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MENU DOCKING 

  

1. Verify that the Civil Message Center tool is already docked on the bottom; if not, select it from 

the General Geometry Task group, dock and unpin. 

   

2. Verify that the Project Explorer is docked on the left side; if not, from the Ribbon select the 

Home tab then in the group named primary click on the explorer icon…Or use the F11 function 

key to toggle ON/OFF the dialog. 

   



INTRODUCTION _______________________________ Recommended MicroStation SettingsRecommended MicroStation Settings 

FDOT Roadway Design 3D Modeling  ©2021 FDOT  19 

3. Verify that the Level Display is docked on the right side; if not, from the FDOT-Function Keys 

press F10, dock and unpin. 

 

4. Verify that the Element Information is docked on the right side; if not, this can be brought up 

by selecting Ctrl+I , dock and unpin. 

  

• Many of the dialog settings are stored in user preferences defined in xml data files located in the users data 
folders i.e. C:\Users\rd964vd\AppData\Local\Bentley\OpenRoadsDesigner\10.0.0\prefs. 
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1 TEMPLATE DESIGN 

OVERVIEW 

The Create Template command generates the transverse geometry that is central to roadway design. A template 

comprises a series of points and components that represent break line features that are processed using Corridor 

Modeling commands. Roadway features that have been processed are saved to the design surface. Templates are 

stored in a template library (*.itl). 

TEMPLATE BASICS 

• The FDOTCONNECT Workspace provides an extensive Template Library. 

• FDOTCONNECT Templates closely follow CADD Manual, FDM and FDOT Design Standards and should 

be used to start a project. 

• FDOTCONNECT Templates are designed from the FDM typical sections of the proposed roadway. 

• FDOTCONNECT Templates are stored in the CIVIL FDOT ORD.itl. 

• The CIVIL FDOT ORD.itl Templates have Features, Point Names, Component Names, Parametric 

Constraints and Display Rules which follow a standard naming convention. 

• A project specific Template Library is created and CIVIL FDOT ORD.itl file templates are copied to that 

library and are modified to meet the specific needs of the project. 

• New and modified templates should adhere to the template standards of the CIVIL FDOT ORD.itl file. 

• When applied to a Corridor, templates are written to the design file and can be edited within the file. 

• Once templates are in a design file, they can be copied to another Project Template Library or design file. 

APPLYING TEMPLATES 

• Templates create a model of the proposed roadway. 

• Template points generate longitudinal break line features in the model. 

• Templates are used to create a proposed model of the roadway. 

• Templates are assigned to specific stations along an alignment at a specific interval, which are called template 

drops. 

• When a corridor is processed, the points of the template drops are connected to form a model of the roadway. 

• The connected template points also form longitudinal break line of the surface model. 

• The model can be exported into a traditional surface Terrain model. 
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CREATE TEMPLATE DIALOG 

The Create Template dialog is accessed from the Corridor Modeling, Create Template tool. To create or edit a 

Template Library, click the Open Create Template icon on the Corridor Modeling dialog. This displays the 

Create Template dialog. 

The Create Template dialog is the primary place where templates are created and edited. This is also where 

templates are copied from a standard Template Library to a project Template Library using Tools > Template 

Library Organizer. 

• User Definable Folder Structure 

• Create Templates, Components and End Conditions 

• Right-click Functions 

• Copy and Paste, and Drag and Drop 

• Red-colored Box Indicates Current Template 

• Drag and Drop Components to Current Template Window 

On the left side of the dialog, you will find the Template Library area, which contains a Windows-like folder 

structure. The root folder is the name and location of the Template Library that is currently open. Only one 

Template Library may be open at a time. 

To navigate the folder structure, double-click the folders you want to open or close. Inside any folder you can 

create and organize your templates and subfolders. The organization of the folder structure is user definable. The 

folder structure also supports common Windows functions, such as drag and drop, cut and paste, etc. 

Most commonly used commands can be accessed by right clicking on the folders and templates. If you double 

click a template, it becomes the Current Template and is signified by a red box around the Template icon. The 

Current Template is also identified in the Current Template area next to the Template Library area. To assemble 

or edit a template, it must be the Current Template. 

CURRENT TEMPLATE WINDOW 

• Templates Assembled and Edited 

• Right-click To Create Components 

• Double-click To Edit Points and Components 

• View Commands Bottom of Window 

In the center of the Create Template dialog is the main graph for creating templates. The graph is called the 

Current Template window. The Current Template window uses its own graphics engine and is not a MicroStation 

View. The scale of the graph is dynamic and changes as you zoom in and out. 

The center point of the Current Template window is marked by the dynamic origin, which is a magenta-colored 

box. The dynamic origin is used as a reference point and can be moved to any location in the graph. 

At the bottom of the graph there are numerous view commands, which are similar to MicroStation View 

commands. There are two buttons that look like the MicroStation View Previous and View Next commands, 

however, they are used to undo and redo template creation operations. 

If your mouse has a scroll wheel, it can be used to pan and zoom. The CTRL-Z keyboard hot key will undo your 

last edit or creation.  In the graph area you can right-click to access commands and you can double-click elements 

in the graph for editing purposes. 
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TEMPLATE PREVIEW WINDOW 

• Previews Templates and Components 

• Works on Non-current Templates 

• Placement Point Location Denoted by a Cyan-colored Box 

• Click Point to Move Placement Point Location 

• Drag and Drop from Preview Area to Current Template Window 

Under the Template Library area is the Preview area.  When you highlight (single click) a template, the template 

is displayed in the Preview area. 

You can use the Preview to assemble templates from their parts or components. This is accomplished using drag 

and drop functions. The cyan-colored box in the Preview represents the insertion point for any drag and drop 

operation. You can change the insertion point location by clicking the desired insertion point on the preview. 

DYNAMIC SETTINGS 

• Tools > Dynamic Settings Command 

• Precision Input Template Points 

• XY = Absolute Coordinates 

• HS = Horizontal Delta Distance and Slope from Last Point Placed 

• DL = Enter Delta Coordinates from Last Point Placed 

The Dynamic Settings dialog is used for precision input of the template components and to assign point names 

and styles when creating components. It also serves as a compass for the location of your cursor with respect to 

the dynamic origin. The dynamic origin can be moved using Set Dynamic Origin, located at the bottom of the 

Dynamic Settings dialog. 

The Dynamic Settings dialog is accessed by selecting the menu option Tools > Dynamic Settings or using the 

View Control icons located below the Current Template window. 

The Key-in pull-down specifies the type of key-in to be performed: 

XY = key-in absolute coordinates 

DL = key-in delta coordinates from last point placed (defaults to the dynamic origin if it is the first point 

of a component) 

HS = key-in horizontal delta distance and slope from last point placed 

VS = key-in vertical delta distance and slope from last point placed 

OL = key-in delta coordinates from dynamic origin 

OS = key-in horizontal delta distance and slope from dynamic origin 
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COMPONENTS 

• Components are Parts of the Template 

• Curb and Gutter, Median Barrier, Pavement Layers, Cut and Fill, etc. 

• Simply Drag and Drop Components Together to Create a Complete Template 

• When Two Points Coincide, Heavy White Plus Sign Appears 

• Existing Connection Point Name Override Dropped Point Name 

Components are logical parts of a template. Portions of the template that are separated into components are 

normally based on tabulation considerations. Examples of components include curb and gutter, median barrier, 

pavement layers, cut and fill slopes, and ditches. 

Components are normally kept in a separate folder in the Template Library and are used to assemble complete 

templates. Drag and drop the components to the Current Template window to create a complete template. When 

connecting two components, the connecting point will change to a white colored plus sign prior to placing the 

component. This is the indication that the points coincide. When the components are connected together, using 

drag and drop from the Template Library folders, any coincident component points will use the point names of 

the previously placed component. Template point names can be edited anytime during the creation process. 

Components are normally created with point names that are not specific to being on the left or right side of the 

roadway. When they are used to create completed templates, prefixes and suffixes to the template points can be 

automatically added during component placement. Prefixes and suffixes are controlled using Tools > Options in 

the Create Template dialog and can be set and cleared in the Dynamic Settings dialog during placement using 

the Apply Affixes check box. 

MERGING COMPONENTS 

• Right-click Between the Components to Merge 

• Select the Merge Components Command 

When combining two components of a pavement section together, two separate components are produced with a 

vertical segment dividing them. To remove the vertical segment, position the cursor over the vertical segment 

and right-click. Then select Merge Components. 

EXERCISE OVERVIEW 

Exercise 1.1 Create Template ................................................................................................................................ 1-5 
Exercise 1.2 Creating a Blank Template Library (optional) .................................................................................... 1-5 
Exercise 1.3 Create Default Template Library ....................................................................................................... 1-7 
Exercise 1.4 Using the Template Library Organizer ............................................................................................... 1-8 
Exercise 1.5 Naming Project Templates .............................................................................................................. 1-11 
Exercise 1.6 Creating a Resurfacing Template ..................................................................................................... 1-13 
Exercise 1.7 Editing Templates ............................................................................................................................ 1-20 
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Exercise 1.1 Create Template 

This exercise opens the proposed roadway 3D Model file, MODLRDMainline61.dgn, with Open Roads 

Technology and using the FDOTConnect Workspace and WorkSet configuration. The Create Template dialog 

displays and a new Template Library file created for the workset in the workset roadway folder. This new project 

Template Library is the container for all the components and templates used to develop the design model for the 

project design. 

1. Open the _BlankFile.dgn file of the c:\<Workset Folder>\FDOT\22049555201_CE\ folder in 

the FDOTConnect - Roadway Workspace in OpenRoads Designer. 

2. Go to the FDOT ribbon and Choose “Create File.” 

3. Create a new MODLRDMainline61.dgn file. Select Wakulla County. Choose Create/Open 

File. 

4. Navigate to the Corridors Tab of the Ribbon (in the OpenRoads Modeling workflow), then 

using the Create Group select the Create Template icon to launch the Create Template tool. 

 

• Hint: Use the F12 function key to access the Create Template Dialog. 

Exercise 1.2 Creating a Blank Template Library (optional) 

1. From the Create Template dialog select File > New > 

Template Library. 

 

 
 

2. Navigate to the Workset roadway folder, C:\<workset>\FDOT\22049555201_CE\roadway\. 
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3. Enter the new Template Library Name, 22049555201. Click Save. 

 

4. Create new folders in the Project Template Library. 

 

5. Create and re-name five folders. Select the Root folder and repeat steps to include all the 

following folders: 

o Components Training 

o Corridor Templates Training 

o End Conditions Training 

o Linear Templates Training 

o Surface Templates Training 

 

6. Select File > Save to save the project Template 

Library .itl file. 
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Exercise 1.3 Create Default Template Library 

• Components 

• Corridor Templates 

• End Conditions 

• Linear Templates 

• Surface Templates 

The Components, End Condition, Linear Templates, Surface Templates folders contain parts of the full 

Templates and is obtained from the FDOTConnect Template Library.  

The Corridor Templates folder contains the constructed templates for the corridor. The Project Templates in the 

exercises to follow are named and saved in stages or phases in order to track the progress of the design. This 

method is also recommended to provide a backup and/or history for potential trouble shooting along the way. 

1. From the Create Template dialog, select File > Open and navigate to the FDOTConnect 

Workspace folders 

FDOTConnect\Organization-Civil\FDOT\Template Library directory and choose the 

EmptyProject.itl Template Library. 

2. From the Create Template dialog, select File > Save As. If Exercise 1.2 was performed, 

overwrite the blank 22049555201.itl Template Library created earlier. 
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Exercise 1.4 Using the Template Library Organizer 

This exercise uses the Create Template dialog to open the Template Library Organizer from the Tools menu 

option. Various components and templates from other Template Libraries and Roadway Designer files are 

obtained from using the Template Library Organizer. For the Chapter exercises to follow, the CIVIL FDOT 

ORD Template Library contains a basic Typical Section and all of the components used for the project design. 

1. Use Create Template and select Tools > Template Library Organizer. 

 

2. From the Template Library Organizer dialog, click the Ellipses icon next to the OK button. 

The Open Template Library window displays. 

 

3. From Open Template Library, navigate to the CIVIL FDOT ORD.itl 

This is located in the FDOTConnect workspace in the following folder location 

C:\FDOTConnect\Organization-Civil\FDOT\Template Libraryfolder CIVIL FDOT ORD.itl . 

Click Open. 
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4. The Template Library Organizer dialog displays with the .itl file listed in the right Available 

In: window pane. 

 

5. From the Template Library Organizer, navigate to the Examples (For Training) folder. Open 

the folder by double clicking on it, select the SR61 inside median curb template. 

   

6. By selecting the template a preview will show in the  Preview window below the directory 

view. 
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7. Drag the Template from the right side to the left side onto the Examples (For Training) 

Corridor Templates folder for the project. 

  

8. Collect the following items from the CIVIL FDOT ORD Template Library and drag them to 

the Project Folders Locations as shown below. 

CIVIL FDOT ORD Template Location Project Folder Location 

Examples (For Training)/ Design and 3D 

Modeling Course Guide Templates 

Entire folder to Examples (For Training)/Design and 

3D Modeling Course Guide Templates 

End Conditions/Parts Entire Parts folder to End Conditions 

Component/Pavement/Resurfacing (Milling, 

Overbuild and Overlay) 

Entire Resurfacing (Milling, Overbuild and 

Overlay) folder to Components 

Component/Curb & Gutter Curb Type E Inside to Linear Templates Common 

Linear Templates Common 
Outside Lane w/ Paved Shoulder to Linear 

Templates Common 

Linear Templates Common 
Outside Lane w/ Type F Curb to Linear Templates 

Common 

Surface Templates Pavement Asphalt to Surface Templates 

If template exists still add it and see that it will increment the template that you are adding (the 

program will add a 1 to the end of the template added.) 

9. Click OK to return to the Create Template dialog and click Yes to the “Save data to file” 

The FDOT Standard Items are now saved in the Project Template Library. 
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Exercise 1.5 Naming Project Templates 

This exercise copies and renames the Typical Section obtained from the CIVIL FDOT ORD.itl Template Library 

in the project Template Library template folder using the Create Template dialog. The Create Template dialog 

has functionality similar to Window Explorer to help manage templates for each project. 

Note A consistent project template naming convention is valuable as the design progresses. As more are added 
to the template design, create a backup copy and add a suffix to the name “_1, _2, _3, etc. 

1. In the Typical Sections (FDM) folder, right click on the FDM EXHIBIT –306-05 Template 

and select Copy. 

 

2. Right click on the Corridor Templates folder and select Paste. Right click on the copied FDM 

EXHIBIT 306-5 Template and select Rename. 
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3. Change the Name of the Template to SR61_Training.  Right click on the SR61 Template and 

select Set Active. A small red box will indicate the Active Template. 

 

4. Select File > Save to save the Project Template Library. 
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Exercise 1.6 Creating a Resurfacing Template 

This exercise creates a Resurfacing Template within the project Template Library. This exercise helps provide a 

basic understanding of the basic template creation methods from the CIVIL FDOT ORD Template library 

components types, connection points, constraints, targets, etc. 

1. Right click on the Corridor Templates folder and select New > Template. 

 

2. Right click on the New Template1 and select Rename. Change the Name to RRR98_Training 

and Select Enter to store the name. 

3. Right click again on the RRR98_Training and select Set Active. 
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➢ Before Adding Components, Open Preference File to Add a Prefix to the Point Names. 

1. Select the Tools > Options from the Create Template dialog to launch the Template 

Options dialog. 

 

2. Click the Preferences button and then select the FDOT list item. Click Load and then Close 

the Preferences dialog. Click OK to close the Template Options dialog. 

 

3. Select the Tools > Dynamic Settings from the Create Template dialog. This provides a 

toolbox like dialog for placing components. 

Note The X and Y Step value 0.1000 functions similar to a grid lock in MicroStation when placing the 
components. 

 

a. Change the Point Style to Template Miscellaneous. 
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b. Uncheck Apply Affixes. 

 

➢ Add Components 

1. Navigate to Components/Resurfacing (Milling, Overbuild and Overlay)/Overlay and select the 

Pvt Overlay Right Component. 

 

2. Using the Preview window drag the Component to the small magenta square in large View. 

 

3. Repeat this step to place the Pvt Overlay Left Component on the small magenta square. 
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4. Fit View by selecting the Fit icon below the Active Template window. 

 

5. Drag and drop the Resurfacing/Milling/ Pvt Milling Right Component and connect it to the 

bottom side of the Overlay Component in the Template. The cursor will turn white when it is 

lock on the location. 
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6. Repeat this step for the Left Milling Component. 

 

7. Drag and drop the Resurfacing/Overbuild/ Pvt Overbuild Right Component and connect it 

to the bottom side of the Overlay Component in the template. The cursor will turn white when 

it is lock on the location. 

 

8. Repeat this step for the Left Overbuild Component. 
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9. Check Apply Affixes on the Dynamic Settings dialog. 

 

10. Drag and drop the Linear Templates Common/Outside Lane w/ Paved Shoulder 

Component and connect it to the top side of the milling template.  While dragging Right click 

and turn On Mirror. 
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11. Modify the Widening lane Width and Slope, 

a. Edit the Point RT_PVT_EOP_OUT, double click on the Point to open the Point 

Properties dialog. 

b.  Change the Horizontal Constraint Value to 1 and Slope Constraint Value to -2%. 

 

12. Repeat for the Left Side Widening Pavement, LT_PVT_EOP_OUT, use Horizontal value -1, 

and Slope value 2.0%. 

➢ Add End Conditions to the SR61 and RRR98 templates 

1. Drag and drop the End Conditions/Parts 6:1 Cut and 6:1 FILL TO 5’ Components to both 

sides. 

2. Select File > Save to save the Template changes. 

 

Note The undo icon is also at the bottom of the view. 
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Exercise 1.7 Editing Templates 

1. On the Create Template dialog, check On the Display Point Names option. 

 

➢ Change End Condition Point Properties 

1. Double click on the RT 6:1 Cut Point to launch the Point Properties dialog. 

 

2. Check the End Condition is Infinite box and change Constraint 2, Horizontal Value, from 30 

to 5 feet.  Click Apply and then Close. 
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3. Repeat these changes for the remaining End Conditions; RT 6:1Fill, LT 6:1Cut, RT 6:1Fill. 

• Use -5 for left side points. To edit consecutive points, click the pick icon next to the point name and select the 
next point. 

 

4.  Select Fit View the Active Template and changes. 

 

5. Rich click on the each Fill components and choose edit properties. Change the Priority Value 

to 2. 

 

  



Chapter 1 _______________________________________________________________ TEMPLATE DESIGN - Editing Templates 

1-22 ©2021 FDOT  FDOT Roadway Design 3D Modeling 

6. Turn OFF the Horizontal Feature Constraint on the middle point, PVT _EOP_IN Point. 

 

7. Select File > Save to save the Template changes. 

➢ Change the Overlay Depth Properties 

1. Change the bottom tab on the left side of the Create Template dialog to Active Template. 
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2. Open the Parametric Constraints folder, double click on the OLAY_PvtThick Label and 

change the Default Value from -.25 to -2/12.  Click OK. 

 

3. Repeat these steps for the OLAY_PvtThickLt and OLAY_PvtThickRt Labels. 

➢ Change the Milling Point Properties 

1. Zoom in the Active Template View to the Right Widening side. 
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2. Right click on the RT_PVT_OLAY_OUT and select Edit Point. 

 

a. Change the Constraint 1, Horizontal Value from 12 to 5 feet. 

b. Change Constraint 2, from Slope to Project to Surface.  

c. Set the Constraint 2 Value to Active. 

d. Click Apply and then Close. 
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e. Repeat these steps for the LT_PVT_OLAY_OUT, change the Horizontal Value from 

-12 to -7 and Slope to Project to Surface. 

 

3. Zoom out of the Active Template to view the results. 

 

4. Select File > Save to save the Template changes. 
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➢ Change the Widening Point Properties 

1. Double click on the RT_PVT_EOP_OUT to edit the Point Properties. 

 

2. Change the Constraint 1, Horizontal Value from 1 to.01 feet and Horizontal Feature 

Constraint Range from 50 to 100 feet.  Click Apply and then Close. 
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3. Repeat these steps for the LT_PVT_EOP_OUT, change the Horizontal Value from -1 to -.01 

and Horizontal Feature Constraint Range from -50 to -100 feet. Click Apply and then Close. 

  

4. Fit View the Active Template to view the results. 

 

5. Select File > Save to save the Template changes. 
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➢ Check the Milling Component Properties 

1. Double click on the bottom line of the RT_PvtOverlay to open the Component Selection 

dialog and select the RT_PvtMilling option to edit the Component Properties. 

 

2. Change the Overlay/Stripping Properties / Bottom option from Follow Surface to Follow 

Component.  Click Apply and then Close. 

Note This is the appropriate setting for constant depth milling to match existing pavement slope between two 
points. 
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3. Repeat these steps for the LT_PvtMilling Component, change the Overlay/Stripping 

Properties / Bottom option from Follow Surface to Follow Component.  Click Apply and 

then Close. 

  

4. Select File Save to save the Template changes. 
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➢ Insert a Milling Slope Break Template Point 

1. Right click on the RT_PvtOverlay Component and select Insert Point. 

 

2. Data point in the Active Template View to store a point. Right click and select Finish. 
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3. Double click on the new Point to edit the Point Properties. Change the Point Constraints as 

shown. 

 

4. Click Apply and then Close. 

 

  



Chapter 1 _______________________________________________________________ TEMPLATE DESIGN - Editing Templates 

1-32 ©2021 FDOT  FDOT Roadway Design 3D Modeling 

5. Repeat the steps above to insert Points on the bottom of the PvtOverlay, PvtMilling, and 

PvtOverbuild Components. 

• If insert point option is not available for the last component, use add point. 

 

6. Set the Point Properties as shown. 

  

• When inserting the point on the PvtMilling and PvtOverbuild components, data point on the 
RT_ML_BREAK_BOT point to save from setting any other Point Properties edit steps. 
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7. Merge the three points into one final point. 

 

8. Select File > Save to save the Template changes and then close the Create Template dialog. 
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Exercise 1.8 Add a Component Switch to the RRR98 Template 

(optional) 

This exercise adds a Component Switch to the RRR98 template to be used across the limits of the intersection. 

This switch is implemented using a Parametric Constraint on the BL98 corridor to turn off all the outside 

components for the corridor through the intersection, in Chapter 4. 

1. Use the Corridor Modeling, Template >Create Template tool. 

 

2. Set Active the RRR98 template. 

 

3. Using the Template Library Organizer, locate the SWITCHES template in the Civil 

FDOT ORD.itl file. 
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4. Drag the SWITCHES template to the project Components folder. 

 

5. Choose OK and choose Yes to Save the data to the project template library, 22049555201.itl. 

6. With the RRR98 template active, drag the SWITCHES template onto the center of the RRR98 

template. 

 

Note The switch template consists of two simple components left and right of the centerline. A label has been 
assigned to the horizontal constraint value.  Also, display rules have been created for when the value is 
1,2,3,4, or 5.  By assigning one of the rules to a component, the display of that component and all related 
components can be controlled based on the value of the switch. 
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➢ Create a Parent /Child relationship of all the Left side components. 

1. Open the Component Properties dialog for the Left Cut Component. 

a. Set the Parent Component by using the “pick icon”  , select the LT_PvtOut. 

Note Use the wheel to zoom into the Left Widening LT_PvtOut component or select it from the list. 

 

b. Choose Apply and Close the Component Properties dialog. 

c. Repeat this procedure for the Left Fill, and Left Shoulder components.  The Unpaved 

Shoulder and Base components should already have a parent relationship which can be 

used. 

2. Use the Active Template Tab to view the Component Relationships to the LT_PvtOut. 
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3. In the Active Template Component List, right click on the LT_PvtOut Component and 

uncheck the Display option, 

4. All of the left side components should turn off, right click on the LT_PvtOut Component 

and toggle the Display back on. 

5. In the Active Template Component List, right click on the LT_PvtOut Component and 

choose Edit. 

6. From the Component Properties dialog, Select Edit on the Display Rules: field 

 

a. Select the Template Display Rule LT_SWITCH1 rule from the list. 

 

b. Build the Conditional Expression NOT LT_SWITCH1 by clicking the NOT button 

and then Selected Rule button. 

 

c. Choose OK, then Apply, then Close to save the display rule to the component. 

Note Adding the rule NOT SWITCH1 is  telling the template left side “Not To Display If The Horizontal Distance 
Of The Switch Is The Value 1” 

7. Choose Close and Yes to save change to exit the Create Template dialog. 
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2 BASIC CORRIDORS MODELS 

CORRIDOR MODELING OVERVIEW 

As defined in the Bentley Civil Help: 

“The Corridor Modeling toolset is a group of highly interactive commands to create new design 
surfaces that represent a new roadway or other type of surface. Tools for creation, modification, 
management, and report functions are supported. 

Corridor Modeling tools aggregates a variety of civil data. The geometry is created with the 

Horizontal and Vertical Geometry tools, while the existing ground is defined by a MicroStation 

mesh or Civil Terrain Model. Plan view elements, such as edges of pavement, shoulders, curbs, 

etc. can be 2D or 3D. Superelevation information is defined within a design file using standards 

or imported data. Templates are utilized from one or more template libraries. 

Reference files can be used extensively with Corridor Modeling. On a simple project, the data 

may be all in one file; larger projects may have geometry in one file, plan view graphics in a 

second, terrain in another, superelevation in a fourth and the actual model in a fifth. All files 

can reference the others, to present a complete picture of the project. 

When working with Corridor Modeling, you can draw in 2D or 3D. When using 2D (such as for 

plan-view graphics), a 3D view is automatically created and maintained. For example, when a 

vertical geometry element is initially defined for a horizontal geometry element, the Default-3D 

model is created, if there isn’t one already. The 3D baseline (combination of horizontal and 

vertical element) is drawn into the 3D model. As template drops are added, and progressed, they 

are added to the 3D model automatically. 

When starting to create a corridor, basic information can be used. A single template can be 

used, along with preliminary geometry and a high level terrain model. As the design progresses, 

more detail can be added. Instead of a single template drop, perhaps more templates better 

define the roadway. Transitions can be added to smoothly move from one template to another. 

There may be multiple roadways all interconnected using the target aliasing tools. All the while, 

as changes are made, the corridor model is updating, so you see up-to-the minute results. Simple 

projects may not require all the tools, and a basic corridor model may be sufficient. But all the 

tools are available to handle basic to complex, small-scale to large-scale projects. 

The following are minimum requirements to use Corridor Modeling. 

• Civil horizontal element 

• Civil vertical element 

• Template stored in a template library 

A terrain model is not required for corridor modeling. If the template includes end conditions and no terrain 

model is defined, the software generates as much of the model as possible but will not complete the end condition 

that ties to ground and no error message is given. 

Corridor models are built at an interval, which determines the level of detail of the model. OpenRoads essentially 

takes the typical section stored in the template and places it every 25’ (or whatever the interval is set to) along 

the alignment in order to build the 3D model. The FDOT CADD manual section 8.4.7 sets forth the maximum 

required intervals for a corridor, depending on the Context Classification of the roadway. Corridors can certainly 

be built at a more frequent interval, but this is at the expense of more computing power (RAM, disk space, and 

CPU). To optimize the model, the interval spacing should only be made tighter than the maximum when needed. 
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For this project, the Context Classification is C3C. An excerpt from the table in the CADD manual is shown 

below, showing the corridor interval requirement for C3C. The interval can be set to the tangent requirement as 

long as the design stage used decreases the interval spacing on curves. 

Maximum Corridor Frequency Interval Spacing (Feet) 

Context Classification Tangent Curve Intersection 

C3C 20 10 5 

CORRIDOR MODELING PLANNING 

It is recommended to plan out the 3D modeling approach on a project. Some have referred to this a Model 

Management Plan. This plan will attempt to outline the following: 

• Determine how to break up the project into logical independent corridors. 

• Determine which sections of the project are needed for detail modeling and surface modeling. 

• Determine the files and filenames to be used for corridors and details. 

Note The project 3D Model may be in separate files or all combined into one file.: The FDOT file defined to be 
used for Corridor and Detail Models is MODLRD(xx)## with an optional descriptor in the parentheses. 

Below is the  Model Management Plan for this project dataset. In this chapter we will be creating the three 

proposed model files. 
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Exercise 2.1 Prepare to Create Corridor Model for SR61 

1. Open the MODLRDMainline61.dgn file of the c:\<Workset Folder>\FDOT\22049555201_CE\ folder in the 

FDOTConnect - Roadway Workspace in OpenRoads Designer. 

2. Reference the GDTMRD01, ALGNRD01 and DSGNRD01 files. 

3. Use the Terrain tab, Set Active tool. 

 

4. At the cursor prompt, select the Terrain Boundary green dashed line from the attached SURVRD01 

reference file. This will set the terrain model as Active. 

5. Move the cursor over the SR61 

Centerline Feature and verify an 

Active Profile. 

 

 

 

 

 

 

 

6. To set up the Views for 

viewing the 2D Plan 

and 3D Model 

simultaneously in the 

FDOTCONNECT 

Workspace, Select the 

F2 Function Key on the 

keyboard. This will 

open an Isometric View 

of the project. 

 

 

 

7. Save Settings. 
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Exercise 2.2 Create Corridor, SR61 

1. Use the 

Corridors, New 

Corridor tool. 

 

 
 
 
 

2. Select the 

SR61 

Centerline 

in the Plan 

View when 

the “Locate 

Corridor 

Baseline” 

prompt 

comes up. 

3. Reset to 

accept the 

Active 

Profile. 

This profile 

resides with 

the SR61 

Civil 

Feature 

Centerline. 

4. Enter the 

Corridor 

Name, 

SR61, in 

the Create 
Corridor 
dialog. 

 



BASIC CORRIDORS MODELS - Create Corridor, SR61 ____________________________________________________ Chapter 2 

FDOT Roadway Design 3D Modeling ©2021 FDOT  2-3 

5. Data point to 

accept the 

Name of the 

Corridor, 

SR61. The 

corridor is 

created AND 

the integrated 

Create 
Template 
Drop dialog 

launches. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note Once a Corridor is created, a shape boundary is placed in the Plan View representing its outline. This 
shape is initially placed on the CorrHndlStg1_dp level. It has several properties which can be seen by 
clicking on the shape and choosing first icon. One of the properties is the Feature Definition (Design Stage). 

6. Once the Create Template Drop dialog is opened, first select the corridor template to be placed on the 

corridor. Either use the icon on the dialog <OR> select ALT down arrow to pick a template. 
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7. Find the SR61 inside TS template in the Corridor Templates folder of the active Project Template Library. 

Select it and click “OK.” 

Note OpenRoads appears to have an issue applying superelevation properly when a template has multiple end 
condition search functions, so we have split the corridor into three template drops, one for the two traffic 
separator sections and one for the median section. 

 

Note Verify that the correct .itl Template Library is loaded at the top left of the Pick Template dialog. If it is not, 
the correct template can be loaded by opening the Create Template dialog and opening a different .itl file 
prior to using the tool. Refer to the previous chapter. 

8. Data point to accept the Template and move to the next setting. 

9. Continue to define the Create Template Drop dialog information entering and accepting the following for 

the SR61 Corridor: 

a. Start – Use keypoint or intersect snap click to the traffic separator nose near the intersection with 

US 98, Station 700+71.00 as shown below. 
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b. End – snap to the end of the traffic separator at Station 703+71.00 as shown below. 

c. Set the Drop Interval to 20. 

 

10. Repeat Steps 6-8, selecting the SR61 inside median curb in the Pick Template dialog. 

a. Snap the start station to the end of the previously inserted template at the beginning of the curbed 

median section, Sta. 703+71.00. 

b. Snap the end station to the end of the curbed median section, Sta. 711+88.90. 

c. Ensure the drop interval is set the same as above. 

11. Repeat Steps 6-8 to insert another template drop for the next traffic separator section. 

a. Snap the start station to the end of the previously inserted template at the end of the curbed median 

section, Sta. 711+88.90. 

b. Snap the end station to the beginning of the radius return for the side street shortly after the end of 

the traffic separator, Sta. 714+23.96. 

c. Ensure the drop interval is set the same as above. 
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12. Upon completion of the 

Corridor Processing bar in 

the lower right hand side of 

the OpenRoads status bar, 

the 3D model will be 

displayed in View 2. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note Once a Template Drop is 
created, a shape boundary is placed 
in the Plan View represent its outline. 
This shape is initially placed on the 
TmpDrpHndlStg1_dp level. It has 
several properties which can be seen 
by clicking on the shape and choosing 
first icon. Properties include the 
Template Drop Interval and the 
Template Name. 
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➢ Turn 3D Reference File Display Off in the Plan View 

At times the line work in the Plan View can become confusing with 3D lines over top of the 2D lines. This View 

can be simplified by turning the 3D Model Reference file display Off. 

1. Data Point somewhere in View 1 to make it active. 

2. On the OpenRoads Level Display dialog, navigate to the Ref. MODLRDMainline61.DGN Default-3D 

file. 

3. Right click on the file and un-check the Display option. 
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Exercise 2.3 Add Corridor References, SR61 

Corridor References are related to the template points having a Horizontal Feature Constraint to control the 

location of the point on the corridor. They are 2D graphical Civil Features that need to be added to a corridor. 

For the SR61 corridor a selection of median Civil Features are used for template external references. 

1. The SR61 template is designed to target Curb Gutter Type E lines in the median. Hover the cursor over one 

of the median lines to verify that it has the Feature Definition of Curb Gutter Type E. 

 

1. Create a selection set of the following 12 features in the plan view: 

o 2 – Pavement Asphalt EOPA lines in the median 

o 4 – Pavement Asphalt EOPA taper lines in the median 

o 4 – Pavement Asphalt EOPA lines on the outside edge of pavement 

o 2 – Curb Gutter Type E lines in the median 

o 2 – Curb Gutter Type E taper lines in the median 

o 4 – TS Conc Type I 4 ft Wide lines in the median 

• Modeling the TrafSeparator level, do not add the Nose Radius Element to the Selection Set. This will be 
modeled in Chapter 9 with a 3D Civil Cell. 

2. Use the Corridors, Add Corridor References tool. 

 

3. Identify the Corridor handle and then data point to add the selected lines as listed above to the corridor. 
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4. Once the Reference Lines have been added, the Corridor will automatically process to include the new 

Horizontal Feature Constraints. The median features will come in several feet above the pavement, as 

intended on the template. This will be resolved in the next exercise. 
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Exercise 2.4 Change Corridor Feature Definition, SR61 

The FDOTConnect Workspace includes several Corridor Feature Definitions to help with various tasks for 

Design and 3D Modeling. Depending on the active Feature Definition, processing the Corridor will take longer. 

To optimize model performance, it is recommended that designers wait to change the Feature Definition until 

later in the design process, as each definition is set up with multipliers that decrease the corridor interval spacing. 

For example, the Design stage might be utilized for a 60% submittal, while the Final stage might be utilized for 

the 90% and final submittals. 

1. Open the Explorer pane from the Home tab or with the F11 Function Key. 

 

2. Select to expand the OpenRoads Standards section and expand the Standards option list. 

3. Expand Corridor under Libraries > Feature Definitions > Feature Definition 

(FDOT_Stanrdards_Features.dgnlib (Default)). These Feature Definitions are set up for various Design 

Stages. 

 

4. Select the Handle of the SR 61 Corridor and locate the Properties icon when the menu displays. 
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5. Select the Properties icon and change the Feature Defintion from 1 PRELIM to 3 FINAL. 

 

6. The Corridor will re-process and the 3D 

Model will re-draw with a tighter interval. 

Notice that the outside corridors remain 

unchanged. 
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Exercise 2.5 Add Key Stations, SR61 

Create Key Station tool is useful to add stations that are not coincident with the template interval. When the 

median conditions change abruptly, it is desirable to include the station for processing. Otherwise the model may 

have holes or overlaps, which is not desirable when it is used to generate 3D Deliverables for Automated Machine 

Guidance. 

1. Use the Corridors, Edits>Create Key Station tool. 

 

2. Identify the Corridor Boundary handle of the SR61 Corridor. 

3. Use AccuSnap to locate the Plan View CurbMedian / Traffic Separator division line. Snap to a point on 

this line. 

 

4. Repeat these steps for both Traffic Separator locations in the Plan View. 
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5. Add Key Stations at other transition areas, including where the left turn lane transition begins. If snapping 

directly on the transition point does not work, sometimes a key station is needed immediately before and/or 

after the transition point in order to minimize the size of the hole. 

6. (Optional) Rotate the 3D View to a Top-down orientation, as it is sometimes easier to see where to snap to 

in the 3D view. 
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Exercise 2.6 Review Corridor Objects, SR61 

The Corridor Objects dialog is a summary of all Corridor Modeling objects and provides an excellent method 

of managing data. 

1. Use the Corridors, Corridor Objects tool. 

 

2. Identify the Corridor Boundary handle to open the Corridor Objects dialog. 

 

3. Review the various objects on the corridor. If too many key stations were added in the previous step, they 

can be deleted or modified in this dialog.  
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Exercise 2.7 Parametric Constraints, SR61 

The FDOTConnect.itl file contains some FPM Exhibit Templates which are delivered with variable medians 

included. The median can vary with the following conditions or component sets: 

o Curb Median with or without Left Turns 

o Crossovers at Intersections 

o Traffic Separators with Left Turns 

To properly operate the median condition templates, consider the following: 

• The various median component sets have a parent end condition search lines that targets plan features; e.g. 

Curb Gutter Type E, Pavement Asphalt EOPA. 

• Each of the median components sets are displayed ONLY if the target is found. This is by the Parent/Child 

relationship of the Template components. 

• The LT and RT PGL Handles, or the LT and RT PGL in points, control the overall width of the median and 

can be modified to fit any project. 

• Many of the median components have Horizontal Feature Constraints (HFC) defined to locate the 2D civil 

features and the horizontal range will need to be modified to fit the project. 

➢ Add Parametric Constraint for Variable Median, SR61 Template 

The templates used have variable median conditions built within that needs to be set in place for the corridor. 

1. Use the Corridors, Edits>Create Parametric Constraint tool. 

 

2. Identify the Corridor Boundary handle. Continue to define the Create Parametric Constraint dialog 

information. 
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3. Enter and accept the following for the SR61 Corridor: 

• Start Station  Alt for Begin 

• Stop Station  Alt for End 

• Constraint Label  V_Offset 

• Start Value   0.0 

• Stop Value   0.0 

 

1. The variable median conditions are placed at the correct location 

vertically. This will ensure the median is at the correct elevation for the next exercise. 

Exercise 2.8 Prepare to create Corridor Model, SR 61 End Conditions 

1. Go to the FDOT ribbon and Choose “Create File.” 

2. Create a new MODLRDDetail61.dgn file. Select Wakulla County. Choose Create/Open File. 

3. Reference the MODLRDMainline61 file. Set Live Nesting Depth to 1. 

4. Use the Terrain tab, Set Active tool. 

 

5. At the cursor prompt, select the Terrain Boundary green dashed line from the attached SURVRD01 

reference file. This will set the terrain model as Active. 

6. Move the cursor over the SR61 Centerline Feature and verify an Active Profile. 

 

7. To set up the Views for viewing the 2D Plan and 3D Model simultaneously in the FDOTConnect Workspace, 

Select the F2 Function Key on the keyboard. This will open an Isometric View of the project. 

8. Save Settings. 
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Exercise 2.9 Create Corridor, SR 61 End Conditions 

Splitting the template allows more flexibility when adding driveways and side streets, as the end condition 

(outside) template can change at those locations without affecting the mainline. The template for the previous 

exercise only extended to the edge of pavement and did not include curb. In this exercise we will add the curb 

and the end conditions. 

1. Use the Corridors, New Corridor tool. 

2. Select the SR61 Centerline in the Plan View when the “Locate Corridor Baseline” prompt comes up. 

3. Reset to accept the Active Profile. This profile resides with the SR61 Civil Feature Centerline. 

4. Enter the Corridor Name, SR61 R, in the Create Corridor dialog. 

5. OpenRoads will continue on to the Create Template Drop command. Either use the icon on the dialog 

<OR> select ALT down arrow to pick a template. 

 

6. Pick the SR61 R template in the Corridor Templates folder of the active Project Template Library. 

7. Continue to define the Create Template Drop dialog information entering and accepting the following for 

the SR61 Corridor: 

a. Start – Snap to the beginning of the curb radius return on the right side of SR 61 at the T intersection, 

Station 700+40.00. 

b. End – Snap to the 

beginning of the 

curb radius return 

on the right side of 

SR 61 at the 

intersection, 

Station 713+68.58, 

as shown on the 

right. 

c. Set the Drop 

Interval to 20 and 

accept the 

remaining prompts. 
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8. Repeat Steps 1-7 for the left side. 

a. Name the Corridor SR 61 L and pick the SR 61 L Template. 

 

b. Select the start and end points of the template drop based on the curb radius return points on the left 

side of the roadway. The stationing is listed below: 

o Start – Station 701+34.00 

o End – Station 714+29.06 

9. The corridor models will display in the 3D 

View but will be on top of the previously 

placed pavement model. This will be 

addressed in the next Exercise. 
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Exercise 2.10 Add Corridor Point Control, SR 61 End Conditions 

1. Use the Corridors, Edits>Create Point Control tool. 

 

2. Identify the Corridor Boundary handle for the SR 61 R corridor. 
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3. For the Start 

station, snap to 

the end of the 

radius return at 

Station 

701+00.00. 

4. Continue to 

define the 

Create Point 
Control dialog 

information. Enter and accept the following for the SR61 R Corridor: 

o End Station Lock to End 

o Control Description EOP 

o Point  RT__PVT_EOP_OUT 

o Mode Both 

o Control Type Corridor Feature 

Note Do not select either the Point or the Reference Feature 
with the drop-down menu as ORD currently appears to 
have a defect where that will cause the point control to 
not display correctly. They must be selected in the 3D 
view. 

5. For the Corridor, select a handle on SR 61 corridor 

developed for the inside (from MODLRDMainline61.dgn). 

6. For the Reference Feature, select the 

RT__PVT_EOP_OUT line on the SR 61 corridor (inside) 

in the 3D view, as shown on the right.  

7. Accept the defaults for the remaining items. The 3D view 

will update to move the curb and sidewalk to match the 

edge of pavement of the SR 61 corridor model. 

 

8. Repeat Steps 1 through 7 to set a point control for the SR 61 L 

corridor, with the following differences in the dialog: 

o Start Station: 701+34.00 

o Control Description: EOP 

o Point: LT_PVT_EOP_OUT 

9. For the Reference Feature: select the LT__PVT_EOP_OUT 

line on the SR 61 corridor (inside) in the 3D view, as shown on 

the right. 

10. Repeat Step 6 to complete 

the point control. The model should 

look as shown on the left in the 3D 

view. 
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Exercise 2.11 Change Corridor Feature Definition, SR61 End 

Conditions 

1. Open the Explorer pane from the Home tab or with the F11 Function Key. 

 

2. Expand the OpenRoads Model section of the Explorer window. 

3. Expand MODLRDDetail61.dgn (Default). 

4. Expand 1 PRELIM under Corridors. 

5. Right click on SR61 L and select “Properties.” 

6. Hold down Shift or Ctrl and select SR61 R. The Properties window 

changes to show both Corridors selected. 

7. Change the Feature Definition from 1 PRELIM to 3 FINAL as 

shown below. The 3D models for the outside corridors should 

redraw with a tighter interval. 
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Exercise 2.12 Prepare to Create Corridor Model, US98 

1. Go to the FDOT ribbon and Choose “Create File.” 

2. Create a new MODLRDUS98.dgn file. Select Wakulla County. Choose Create/Open File. 

3. Reference the SURVRD01, ALGNRD01, and DSGNRD01 files. 

4. Use the 

Terrain tab, 

Set Active 

tool. 

 
 
 

5. At the cursor prompt, select the Terrain Boundary green dashed line from the attached SURVRD01 

reference file. This will set the terrain model as Active. 

6. Move the cursor over the US98 Baseline Feature and verify an Active Profile. 

7. To set up the Views for viewing the 2D Plan and 3D Model simultaneously in the FDOTConnect Workspace, 

Select the F2 Function Key on the keyboard. This will open an Isometric View of the project. 

8. Open the Level Display Browser. 

9. With the 3D view active, turn off all levels in the SURVRD01.dgn reference, then turn on the DTM_ex 

level. 

10. In the 2D view, right click and select Turn Level Off By Element to turn off the following levels in the 

SURVRD01.dgn reference by selecting the relevant elements: 

o All existing utility levels 

o Survey control points 

11. Turn off all DTM levels in the SURVRD01.dgn reference except DTM_ex. 

12. Save Settings. 

Exercise 2.13 Create Corridor, US98 

13. Use the Corridors, New Corridor tool. 

14. Select the US98 Baseline in the Plan View when the “Locate Corridor Baseline” prompt comes up. 

15. Reset to accept the Active Profile. This profile resides with the US98 Civil Feature Baseline. 

16. Enter the Corridor Name, RRR98, in the Create Corridor dialog. 

17. OpenRoads will continue on to the Create Template Drop command. Either use the icon on the dialog 

<OR> select ALT down arrow to pick a template. 

18. Pick the RRR98 cross slope correction L control template in the Corridor Templates folder of the active 

Project Template Library. 

19. Snap the start and end stations to the milling limits shown in the DSGNRD01.dgn file. 

20. Set the Drop Interval to 20 and accept the remaining prompts. 
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Exercise 2.14 Add Corridor References, US98 

1. Create a selection set of the following lines from the DSGNRD01.dgn file: 

o All Milling lines 

o All Paved Shoulder lines 

o All Edge of Pavement lines 

a. Open Level Display Manager. 

b. Turn off all levels but the Corridor handles in this file, and all but the needed levels in the 

DSGNRD01.dgn file. 

c. Use the box selection tool to select everything shown. 

d. Use the “-“ selection tool to remove the corridor handles from the selection set. 

Note “Select all on level by element” does not work with references in ORD. 

2. Use the Corridors, Add Corridor References tool. 

 

3. Data point to add selection set as a corridor reference. 

Exercise 2.15 Additional Template Edits, SR61 (on your own) 

1. Add the sidewalk front and back lines as corridor references to the respective outside corridors. 

2. Change the sidewalk buffer from 3 feet to 0 feet on both roadways. 

3. Add the outside Edge of Pavement lines as a corridor reference line to the SR61 mainline corridor. 
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3 SUPERELEVATION 

OVERVIEW 

Superelevation rotates the pavement cross slopes through a curve so that vehicles can maintain stability and speed 

while on a turning roadway. Elevation banking is applied to help offset centrifugal force. Superelevation 

standards also define the transition length required to rotate from a normal crown to a fully banked curve and 

back again. 

Superelevation can be calculated in two ways: 

• Rules-based – using a set of preferences the station and associated cross slopes of the transitions are based 

on design speed, curvature, and other design parameters. As the design progresses and parameters change 

(i.e., design speed exceptions) superelevation can be reprocessed to the revised parameter(s). 

• Import – using a comma separate values (CSV) file to import the station and associated cross slope of each 

transition. In this option, the rules are not utilized; the data is simply applied to the superelevation lanes. 

The result of superelevation is a DGN file of graphic superelevation lanes with cross slope attributes. This file 

can be referenced to a corridor model and associated, so the superelevation transitions are incorporated into the 

corridor model. The superelevation data should be stored in the ALGNRD DGN file, in the Superelevation model. 

DATA NEEDED FOR SUPERELEVATION 

The following should be determined before beginning the superelevation process on any project since OpenRoads 

will need the data input. For this training dataset, the correct inputs will be provided. 

 
 

 

 

 

 

 

Superelevation
eMax

Low Speed 
(5%)

High Speed 
(10%)

Shared Use 
Path (2%)

Design Speed 
(mph)

18 - 70

Lanes
/Direction

1-2

3

4

Pivot Method

Crown

Edge

Divided Inside

Centerline

Superelevation 
Width

Edge-to-Edge

Divided/
Undivided
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EXERCISE OVERVIEW - SUPERELEVATION 

In these exercises, the SR61 Centerline has a single curve to define superelevation. Once the required 

superelevation is determined from a predefined FDOT rule file, it will be assigned to the SR61 corridor. The 

results will be reviewed in the Cross Section View and in the table editor. Reports will be generated as other 

methods to review data. 

As an alternative to calculating supers with rules, we’ll also import a dataset from a FDOT Curve Table (csv file 

generated from Excel). 

The general workflow for superelevation is listed below. 

• Set up Superelevation Flags in Template Library 

• Create Superelevation Sections and Lanes 

• Calculate Superelevation Based on FDOT Tables 

• Project Explorer Edits, Graphical Edits 

• Superelevation Diagram and Reports 

• Reference the Superelevation model of the ALGNRD File to the MODLRD file 

• Assign Superelevation to Corridor, Associate Points 

• Review superelevation in Cross Section View 

 

Exercise 3.1 Verify Template Superelevation Flags ............................................................................................... 3-3 
Exercise 3.2 Prepare Alignment File for Superelevation ........................................................................................ 3-4 
Exercise 3.3 Calculate Superelevation from Corridor ............................................................................................ 3-5 
Exercise 3.4 Create Superelevation Sections (optional) ........................................................................................ 3-6 
Exercise 3.5 Create Superelevation Lanes (optional) ............................................................................................ 3-7 
Exercise 3.6 Graphical Edits ................................................................................................................................... 3-8 
Exercise 3.7 Add Superelevation Lane for Curb ..................................................................................................... 3-9 
Exercise 3.8 Superelevation Editor ...................................................................................................................... 3-10 
Exercise 3.9 Project Explorer Edits ...................................................................................................................... 3-11 
Exercise 3.10 Calculate Superelevation ............................................................................................................... 3-12 
Exercise 3.11 Superelevation Reports ................................................................................................................. 3-13 
Exercise 3.12 Editing Superelevation .csv Report ................................................................................................ 3-16 
Exercise 3.13 Import Superelevation from .csv file ............................................................................................. 3-17 
Exercise 3.14 Superelevation Diagram ................................................................................................................ 3-17 
Exercise 3.15 Attach Superelevation to Model File ............................................................................................. 3-18 
Exercise 3.16 Set up Cross Section View ............................................................................................................. 3-19 
Exercise 3.17 Assign Superelevation to Corridor ................................................................................................. 3-22 
Exercise 3.18 Review Superelevation Point Controls .......................................................................................... 3-23 
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Exercise 3.1 Verify Template Superelevation Flags 

1. Open the ALGRD01.dgn file in the c:\<Workset Folder>\FDOT\22049555201_CE\ folder in the 

FDOTConnect - Roadway Workspace in OpenRoads Designer. 

2. Use the Corridors, Create Template tool.  

3. Set active the SR61 inside TS Template.  

4. Switch to Active Template view and select the Superelevation Points folder to highlight the points in the 

template that will be affected by superelevation. Verify that all four Pavement Edge Points and the CL_ 

null Point are highlighted. 

5. Open any of the points Properties and verify the Superelevation Flag option is checked ON. 

 

6. Repeat Steps 3-5 for the SR61 Inside median curb Template. 

7. Close the Create Template dialog. 

Note Any changes needed to the points or Superelevation Flags must be saved to the .itl file and synchronized 
with the template in the appropriate MODLRD file. 
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Exercise 3.2 Prepare Alignment File for Superelevation 

1. Locate the View Group toggle on the bottom left of the MicroStation window and change the 

View Group/Model to Superelevation Views. 

 

2. On the MicroStation References tool, attach the Default models of the DSGNRD01, 

MODLRDMainline61, and ALGNRD01 files. 
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Exercise 3.3 Calculate Superelevation from Corridor 

1. Use Corridors, Create Superelevation Sections tool. 

 

2. Enter Name: SR61 and data point. 

3. Select the CL_SR61 corridor. 

Note Selecting the CL_SR61 centerline also works, but selecting a corridor automates much of the remaining 
process, and eliminates the need for exercises 3.4 and 3.5. 

4. Select the FDOT_Superelevation.xml rules file. 

5. Set all values as shown before accepting the Minimum Tangent Length value. 

 

6. Enter 80 for the EdgeWidth Runtime Variable. 

Note The EdgeWidth Runtime Variable is the width used 
to determine the superelevation transition and varies 
depending on the type of roadway being 
superelevated. For any Low Speed roadways or High 
Speed undivided roadways, this width (“W” in the 
Standard Plans) will be left pavement edge to right 
pavement edge including any median, since the 
median width is included. For High Speed divided 
roadways, this width (W) will be the outside 
pavement edge to inside pavement edge of one side. 

The section is drawn and the superelevation lanes automatically placed with the calculations. 

7. Skip to Exercise 3.6. 
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Exercise 3.4 Create Superelevation Sections (optional) 

Note Only needed if selecting the centerline instead of the corridor. 

1. On the Create Superelevation Sections dialog, enter remaining values as shown below: 

o Start Station   Alt to lock to Begin 

o End Station   Alt to lock to End 

o Minimum Tangent  0 

o Lane Creation Method Template 

o Feature: 

o Feature Definition Superelevation 

o Name   SE 

 

2. The Superelevation Sections are drawn and the Create Superelevation Lanes dialog is 

launched. 

 

Note Use the Function Key F5 to dim the references. 
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Exercise 3.5 Create Superelevation Lanes (optional) 

Note Only needed if selecting the centerline instead of the corridor in Exercise 3.3. 

3. (Optional, only needed if canceling out of previous command.) Use the Corridors, Create 

Superelevation Lanes by Road Template tool. 

Select the Superelevation Section and reset to complete. 

1. Select the SR61 Inside Median Curb Template as shown and click “OK” and accept. 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. The Superelevation Lanes are drawn. 
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Exercise 3.6 Graphical Edits 

➢ Superelevation Sections 

1. Use the MicroStation Element Selection tool and select the Superelevation Section. The 

graphic handlers now display. 

Note Press the Tab key if necessary to select the superelevation section instead of referenced linework. 

 

2. Zoom in on the end of the Superelevation Section, select the End Station manipulator, and drag 

to extend the Superelevation Section to near Station 717+00. The Section as well as the lanes 

will extend, and the calculation will update as shown below. 
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Exercise 3.7 Add Superelevation Lane for Curb 

Note Curb slope needs to follow the high side of the roadway superelevation per Standard Plans 000-511. This 
can be accomplished through a point control, or it can be done with superelevation.  

1. Use the Corridors, Create Superelevation Lanes Tool. 

 

2. Select the Superelevation corridor and input the following values in the dialog: 

Name  Gutter 

Type  Primary 

Side of Centerline Left 

Inside Edge Offset 40.00 

Width  1.50 

Normal Cross Slope 9.375% 

 

 

Note Normal Cross Slope should be calculated from the Standard Plans for the Edge of Pavement to Flowline 
based on curb type used. Curb and Gutter Type F is 9.375%. 
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Exercise 3.8 Superelevation Editor 

1. Select Corridors, Superelevation Editor. 

 
2. The Superelevation Editor opens. Note that the right side does not transition back correctly, 

because the end transition was initially cut off before the end of the superelevation section. 

3. Hold down the Shift key and select the last row. Click the Red X to delete all superelevation 

rows. 

4. Close the Superelevation Editor. 
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Exercise 3.9 Project Explorer Edits 

1. Open Explorer, Select F11 and select the OpenRoads Model tab. 

2. Expand the ALGNRD01.dgn (SUPERELEVATION) data tree and navigate to Superelevation 

> SR61-1 > Superelevation Objects > Gutter.  Right click and select Properties. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

  

  

 

3. In the Properties dialog, review the 

Superelevation Lane Properties. 

4. Change the Gutter Lane Normal 

Cross Slope to -9.375%. 
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Exercise 3.10 Calculate Superelevation 

1. Use the Corridors, Calculate Superelevation tool. 

2. Select the Superelevation section. 

3. Select the Superelevation rule file FDOT_Superelevation.xml. 

4. Enter the necessary dialog information as shown at the prompt and data point to accept data: 

e Selection  emax 5% Low Speed 

L Selection  FDOT Low Speed 

Design Speed  45 

Pivot Method  Inside Edge 

Open Editor  No, unchecked 

 

5. Enter 80 for the EdgeWidth Runtime 

Variable. 

 

 

6. The Superelevation Lanes are now applied 

with Superelevation. 

• Bentley OpenRoads Connect Edition computes superelevation differently for each lane, using 
the offset to determine a different radius. As such, the only accurate calculations according to 
the FDOT method will be the center lanes, which both have the same calculated superelevation. 
Some edits in Excel will be required to copy the transitions and e rates from the center lane to 
the other lanes.  
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Exercise 3.11 Superelevation Reports 

➢ Create a Superelevation Report 

1. Use the Corridors, Superelevation Report tool. 

 

2. Select the SR61-1 Superelevation Section and right click to accept. The Report Browser 

opens. 
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3. To adjust the formatting of the 

reports, go to Tools, Format 

Options. Set the Format Options 

as shown below: 

Slope Precision 0.123 

Slope Format 50% 

Alternate Slope 0.10 

(10%) 

Linear Precision 0.1234 

Station Precision 0.12 

Station Format ss+ss.ss 

 

 

4. In the Civil Report Browser, change the report format stylesheet to 

SuperelevationCalculation.xsl Scroll through the report and note the different radius 

measurements used for each lane. This will need to be corrected to meet FDOT criteria. 
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Note Calculations can be confirmed using this report as well, if needed to verify which lane uses the correct 
radius, a current OpenRoads defect. 

5. In the Civil Report Browser, change the report format stylesheet to 

FDOT_SuperelevationToCSV.xsl. Verify that Station and precision are showing properly. 

Note Cross Slope in this table uses the linear precision, as it cannot have a % symbol when importing back in 
to the editor. 

Note Any modified values of curve length (the last column), will not export properly due to OpenRoads 
limitations. The default value is exported in the FDOT_SuperelevationToCSV report. 

6. In the Civil Report Browser, select File > Save As. 

7. Change the path folder to C:\<Workset Folder>\FDOT\22049555201_CE\Roadway and the 

File Name to SR61_SE.csv use the Save as type Text File (*.txt). 

 

 

 

8. Choose Save and Exit the Civil Report browser. 
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Exercise 3.12 Editing Superelevation .csv Report 

1. Open the .csv file in Excel to make edits. 

2. Copy all values (columns B-G) from the CL null - LT_PGL lane to the LT_PGL – 

LT_PVT_EOP_OUT lane. 
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3. Modify Gutter Lane values to match the table below. This can be done with a combination of 

copy and paste as well as adding new rows. 

              Gutter 700+71.00 -0.9375 RS NC L 75 

              Gutter 703+82.70 -0.9375 RS NC L 75 

              Gutter 703+92.70 0 RS LC L 75 

              Gutter 706+80.70 0.024 RS FS L 75 

              Gutter 712+23.70 0.024 RS FS L 75 

              Gutter 715+11.70 0 RS LC L 75 

              Gutter 715+21.70 -0.9375 RS NC L 75 

              Gutter 718+18.47 -0.9375 RS NC L 75 

Note Station for the second and second-to-last NC (Normal Crown) can vary as desired to adjust the distance 
the gutter transitions from full depth to match the lane at the Level Crown station. 

4. Verify that all values appear correct, and close and save the .csv file. 

Exercise 3.13 Import Superelevation from .csv file 

1. Repeat Exercise 

3.8, steps 1-3 to 

clear out the 

calculated 

superelevation. 

Leave the 

Superelevation 

Editor open. 

2. Select “Import 

Superelevation 

Transitions.” 

3. Locate the csv 

file in the 

Roadway 

directory and import the Superelevation.  

 

Exercise 3.14 Superelevation Diagram 

1. Select Corridors, Open Superelevation View. 

 

2. Select the Superelevation Section. 

3. Open View 2 and select in the window. The Superelevation Diagram is placed in this view. 
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4. Save Settings. 

Exercise 3.15 Attach Superelevation to Model File 

1. Open the MODLRDMainline61 file. Make sure the 2D view is active. 

2. Attach the Superelevation Model from the ALGNRD01-file as a Reference file. 
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Exercise 3.16 Set up Cross Section View 

➢ Open a Cross Section View 

1. Right click and hold in one of the views and select View Control > 3 Views Plan/XS/3D. 

 

2. Select OK to create a dynamic cross section view. 

 

 

 

 

3. Select the SR61 mainline corridor and click in View 7   

The cross section view should open in this view. 

Note For this and some other tools, you will need to select the short corridor handle that recurs along the length 
of the corridor. The long template drop handles at the beginning and end of each template drop is not valid 
for this tool. 
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➢ Add Dimension Lines 

4. Use the Corridors, Dynamic Sections > Place Horizontal Temporary Dimension tool. 

  

5. Select View 7 and dimension each Superelevation lane as shown below (Left Lane, Left 

Median, Right Median, Right Lane), making sure to select the blue diamond centerline point 

for the two median lanes. 

 

Note Make sure to select the point on top of the friction course on both sides. Zoom in as needed to see better. 
Ctrl+zoom with the mouse wheel will add vertical exaggeration if needed. 

6. Adjust zoom as desired. 
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➢ Change Station 

7. Select View 7 View Properties > Center on Current Offsets 

as shown below. 

8. Right click and hold in View 7 and select Locate Station Via 

Datapoint as shown on the right. 

9. Select View 1. 

10. Select a station in the Superelevated area near the 

Superelevation Transition as shown below. 

Note The cross slope is still 2% since the Superelevation has not yet 
been assigned. 
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Exercise 3.17 Assign Superelevation to Corridor 

1. Use Corridors, Calculate > Assign to Corridor tool. 

 

a. Select the Superelevation section and reset to accept. 

b. Select the SR61 corridor. 

c. Verify that the Superelevation and Pivot Points are correct. For the Gutter Lane, 

choose any point for Superelevation and Pivot Point. 

 

Note Since the curve is to the right and we rotate about the inside edge, the Pivot Point should be the Template 
Point on the right while the Superelevation Point should be the Template Point on the left. 

d. Click OK on the Associate Superelevation Dialog, and then click OK on the error 

regarding Recursive Superelevation. 

Note This error occurs because the Gutter Lane is not actually in the mainline template, and would not occur if 
we had the gutter in the same template as the mainline. Superelevation will not process correctly due to 
this error, but it is easy to resolve by manually deleting the extra point control, though. 

2. The Corridor will begin to process and display the new model. 
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Exercise 3.18 Review Superelevation Point Controls 

1. Use the Corridors, Corridor Objects tool. 

 

2. Identify the Corridor Boundary handle to open the Corridor Objects dialog. 

3. Select Point Control, and find the Superelevation control labeled SR61-1:Gutter. Select it. 

4. Click the red X to delete. The superelevation reprocesses. 

5.  Close the Corridor Objects dialog. 

6. Verify in the cross section view that the superelevation has been applied correctly. Move to 

the previous or next cross section using the arrows as shown below, or use the Locate Station 

Via Datapoint tool. 
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Exercise 3.19 Assign Gutter Superelevation, SR61 L 

➢ Turn on Display of Superelevation model 

1. Open the MODLRDDetail61.dgn file. 

2. Open the References dialog. 

3. Set the 2D view active. 

4. Use Show Hierarchy, select MODLRDMainline61.dgn. 

 

5. Turn on display of the ALGNRD01.dgn file, SUPERELEVATION model. 

➢ Set up Cross Section View 

6. Right click and hold in one of the views and select 

View Control > 3 Views Plan/XS/3D. 

7. Select OK to create a dynamic cross section view. 

 

 

 

 

8. Select the SR61 L corridor and click in View 7. The 

cross section view should open in this view. 
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➢ Assign Superelevation to Corridor 

9. Use Corridors, Calculate > Assign to Corridor tool. 

 

a. Select the Superelevation section and reset to accept. 

b. Select the SR61 L corridor. 

c. Verify that the Superelevation and Pivot Points are correct for the Gutter Lane. For 

the remaining lanes, choose any point for Superelevation and Pivot Point. 

d. Set Priority for Gutter to 1 and the others consecutively as shown. 

 

Note Since the curve is to the right and we rotate about the inside edge, the Pivot Point should be the Template 
Point on the right while the Superelevation Point should be the Template Point on the left. 

e. Click OK on the Associate Superelevation Dialog. 

10. The Corridor will begin to process and display the new model. 
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➢ Review Superelevation Point Controls 

11. Use the Corridors, Corridor Objects tool. 

 

12. Identify the Corridor Boundary handle to open the Corridor Objects dialog. 

13. Select Point Control, and find the Superelevation control labeled SR61-1:Gutter. Select all 

the other Superelevation Point Controls. 

 

14. Click the red X to delete. The superelevation reprocesses. 

15.  Close the Corridor Objects dialog. 

16. Verify in the cross section view that the superelevation has been applied correctly, and that the 

gutter follows the outside lane slope when it reaches a positive superelevation. Move to the 

previous or next cross section using the arrows as shown below, or use the Locate Station Via 

Datapoint tool. 

17. Turn off display of the ALGNRD01.dgn file, SUPERELEVATION model and close the 

Reference dialog. 

18. Save Settings. 
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4 DETAIL MODELING 

 

SR61 CORRIDOR DESIGN DETAILS EXERCISES 

• Curb Radii 

o Add profiles for Edge of Pavement 

o Add Point Control for End Conditions  

• Intersection Design 

o Build Intersection Terrain at SR 61 and US 98 

o Including TS Nose and Turn Island 

OTHER DESIGN DETAILS 

• Build Intersection Terrain at School Entrance 

• Transition Template for the End of the Project 

• Build Intersections for Friendship Road 

• Add 3D Urban Driveway 

• Add 3D Sidewalk Ramps 

• Add 3D Rural Turn Out 

• Superelevation Vector Offsets for the Median Widening and Curb Gutter Points 

• Superelevation Vector Offsets for the Traffic Separator Widening 
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INTERSECTION DESIGN 

The intersection can be built in parts as shown in the diagram: 

 

The following exercises provide instructions on how to model these with Civil Tools other than the Normal 

Corridor Templates. The steps to design the SR61 intersection have been detailed in the exercises in this chapter.  

Once completed follow the same methodology to add further design details for the remainder of the project. 

PLAN TO BUILD INTERSECTION TERRAIN AT BL98 

 

The general methodology for building intersection design come from the concept of creating new 3D model 

boundary lines from profiles on the corridor surfaces and 3D lines.  Transition profiles are easily produced with 

the civil tools for the radii.  

These are the general steps to follow: 

1. Develop a seam line between corridors through the intersection. 

2. Create a switch or trigger line on the crossing corridor templates. 

3. Remove outside corridor component elements through the limits of the intersection. 

4. Construct 2D elements around the perimeter of the intersection. 

5. Develop/design the profiles for each of the perimeter line. 
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6. Build an intersection terrain boundary using the 3D perimeter elements. 

7. Add break lines to the intersection terrain. 

8. Add surface templates to the intersection terrain. 

9. Use linear templates along the perimeter edge lines to help transition corridors. 

10. Use corridor clipping tool to clean overlaps between corridor and linear templates. 

EXERCISE OVERVIEW 

Exercise 4.1 Create Template Geometry, RRR98 ................................................................................................... 4-1 
Exercise 4.2 Create Template Geometry, SR61 ..................................................................................................... 4-2 
Exercise 4.3 Construct 3D Radius Lines ................................................................................................................. 4-3 
Exercise 4.4 Construct 3D Intersection Limit Lines ................................................................................................ 4-8 
Exercise 4.5 Add Parametric Constraint to RRR98 Template ............................................................................... 4-14 
Exercise 4.6 Model Curb and Sidewalk Around Radii .......................................................................................... 4-15 
Exercise 4.7 Build the Intersection Terrain from 3D Elements ............................................................................ 4-17 
Exercise 4.8 Clip Terrain for Right Turn Island ..................................................................................................... 4-19 
Exercise 4.9 Create an Intersection Pavement Surface ....................................................................................... 4-22 
Exercise 4.10 Traffic Separator Nose ................................................................................................................... 4-24 
Exercise 4.11 Right Turn Island ............................................................................................................................ 4-25 
Exercise 4.12 RRR98 Corridor-Build Intersection Terrain at School Entrance (On Your Own)............................. 4-27 
Exercise 4.13 SR61 Corridor-Build Intersection Terrain at Friendship Road (On Your Own) ............................... 4-28 
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Exercise 4.1 Create Template Geometry, RRR98 

This exercise turns on the profiles needed to build profiles tied to the corridor model. We have implemented 2D 

Lines from the 3D model. In Explorer change the PavementAsphalt_pm feature property to True as shown below. 

Then re-process each corridor to see the resulting construction lines.  These lines have profiles and can be used 

in lieu of the steps outlined in the exercise. 

1. Open the MODLRDUS98.dgn file. 

2. Go to Explorer, right click on Feature Definitions > Linear > 

Roadway Design > Template Points > PavementAsphalt_pm and 

select Properties as shown on the left. 

3. Change Create Template Geometry to “True” as shown 

below. 

 

 

 

 

 

 

 

 

 

 

 

 

4. Reprocess the corridor. Note the additional purple lines that show up in the 2D view. 

5. Add Key Stations at the radius return points on either side of the SR61 intersection. 
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Exercise 4.2 Create Template Geometry, SR61 

This exercise turns on the profiles needed to build profiles tied to the corridor model. We have implemented 2D 

Lines from the 3D model. In Explorer change the PavementAsphalt_pm feature property to True as shown below. 

Then re-process each corridor to see the resulting construction lines.  These lines have profiles and can be used 

in lieu of the steps outlined in the exercise. 

1. Open the MODLRDMainline61.dgn file. 

2. Go to Explorer, right click on Feature Definitions > Linear > 

Roadway Design > Template Points > PavementAsphalt_pm and 

select Properties as shown on the left. 

3. Change Create Template Geometry to “True” as shown 

below. 

 

 

 

 

 

 

 

 

 

 

 

4. Reprocess the corridor. Note the additional purple lines that show up in the 2D view. 
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Exercise 4.3 Construct 3D Radius Lines 

1. Open the MODLRDDetail61.dgn file and zoom in to the intersection of SR61 and US 98. 

2. From Geometry, Horizontal, Arcs > Arc Between Elements, use the Simple Arc tool to create 

new PavementAsphaltEOPA features between the two PavementAsphaltEOPA edges on 

both corners. 

 

3. Use 110’ and 60’ for the radii to match the radius returns in the design file, as show below. 

 



Chapter 4 _______________________________________________________________ DETAIL MODELING - Exercise Overview 

4-4 ©2021 FDOT FDOT Roadway Design 3D Modeling 

Note   These will be used to help create automatic profiles for the 3D lines on the Radii. 

4. Open a Profile Model for the 60’ radius on the right side. 

5. Use Geometry, Profile Creation > Project Profile Range to Element tool. 

 

6. Select the PavementAshpalt_pm line to project as shown below. 

 

7. Select the Pavement Asphalt EOPA arc plan element to project onto. 
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8. Set the range to match the length of the overlap of the two arcs, 0+00.00 to 0+69.11. 

9. Repeat the command to project the PavementAsphalt_pm from the edge of the SR61 corridor 

onto the other end of the same arc. Snap from the beginning of the line, 0+67.23 to the end of 

the arc where it intersects the line, 0+94.25. 

10. In the profile view, Vertical Geometry Tools, select Profile Reverse Transition. 

 

11. Select the two projected profiles as the two elements, and set back and ahead offsets to 0. Set 

the Start Point such that it creates a low point in the vicinity of Station 0+68. 
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12. Snap the end point to the end of the profile as shown below. 

 

13. Set Trim/Extend option to Both. 

14. Remove the rule from the transition projected from the US98 corridor. 

 

Note We will be removing the portion of the RRR98 corridor that the profile is built from later, so removing the 
rule here first will allow this change without breaking the profile for the radius return. 

15. Use the Drawing, Modify, Trim to Element tool to trim the projected profile to the reverse 

transition. 

16. Use the Geometry, Vertical, Complex Geometry > Profile Complex By Elements command 

to complex the pieces into one profile. 
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17. Select the new Profile Line. Select the Set Active Profile from the Context Menu and the 

3D Line will display. 

 

18. Repeat steps 4-17 for the 110’ radius on the other side of the intersection.  
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Exercise 4.4 Construct 3D Intersection Limit Lines 

1. Use Geometry, Horizontal, Complex Geometry > Complex By PI tool. 

 

a. Use the Feature Definition PavtSlopeBreak. 

b. Construct a complex line first along the left side of the mainline corridor from the EOP 

radius return to the beginning of the corridor (trace the PavementAshpalt_pm feature 

lines), then perpendicular to the Traffic Separator lines across the end of the corridor 

to the right side of the SR61 mainline corridor, then trace the PavementAsphalt_pm 

feature line to the EOP radius return point on the right side. In the picture below the 

first two segments of the complex element are highlighted in green, while the third is 

in progress near the snap point. 

• Turn off Level Display of the corridor elements from the mainline corridor, CorrPointControl_dp and 
TmpDrpHndlStg3_dp to make it easier to select the correct lines. Also, turn off display of DSGNRD01.dgn 
if necessary. 
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2. Use the Geometry, Vertical, Open Profile Model tool and select the newly constructed 

Complex line. 

 

3. Use the Geometry, Profile Creation > Project Profile Range to Element tool. 
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4. Select the PavementAsphalt_pm feature line on the left side and project it onto the 

ConstLines Green Dash complex element. Start the range at the EOP radius return and end 

at the beginning of the feature line and mainline corridor. 

 

5. Repeat Steps 3-4 for the right side PavementAsphalt_pm feature line, starting the range at the 

beginning of the feature line/corridor and ending at the radius return. 

6. Use Geometry, Profile Creation > Profile Intersection Point tool to add intersection points 

for the 4 PavementAsphalt_pm feature lines around the traffic separator. 
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7. Use the Geometry, Vertical, Complex Geometry > Profile Complex By PI command. 

 

8. Start on the left and snap to all the lines and points shown in the profile. 

 

9. Use Geometry, Set Active Profile to set the newly created profile as active. 
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10. Repeat these steps to draw a complex element with a profile on the US 98 side of the 

intersection area. Use Project Profile Range to Element where lines with profiles overlap the 

lines, and Profile Intersection Point where lines cross or end. See image below for reference. 
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11. To create a profile for sections with neither an intersection nor overlapping profile from a 

template, use the Geometry, Vertical, Element Profiles, Profile by 3D Element tool. Select 

the element in this file to profile in the 2D view, and select the 3D element from the corridor 

model in the 3D view (ie LT_FC_IN on the RRR98 profile). 
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Exercise 4.5 Add Parametric Constraint to RRR98 Template 

1. Open the MODLRDUS98.dgn file. 

2. Use the Corridors, Edits>Create Parametric Constraint tool. 

 

a. At the prompt, select the BL98 Corridor 

boundary. 

b. Snap to the SW Radius for the Start Station. 

c. Snap to the NW Radius for the End Station. 

d. Pick the LT_SWITCH Constraint Label 

from the list. 

e. Enter 1 for the Start Value. 

f. Enter 1 for the Stop Value. 

g. The corridor will re-process with the updated RRR98 Template. 

3. The left outside components of the BL98 corridor are now turned off though the limits of the 

intersection. 
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➢ Turn OFF the Automatic Corridor processing of US98. 

4. Select the US98 Corridor handle to display the Context Menu and select Lock - Deactivate 

Rule. 

 

 

Exercise 4.6 Model Curb and Sidewalk Around Radii 

1. Use the Corridors, Edits>Create Point Control tool. 

2. Identify the Corridor Boundary handle for the SR 61 R corridor. Continue to define the 

Create Point Control dialog information. 

 

a. Lock to Start. 

b. Snap End station to the end of the radius return, where the other point control begins. 

c. Set Control Description to US98. 



Chapter 4 _______________________________________________________________ DETAIL MODELING - Exercise Overview 

4-16 ©2021 FDOT FDOT Roadway Design 3D Modeling 

d. Select the RT_PVT_EOP_OUT in the 3D View. 

e. Set Mode to Both. 

f. Set Control Type to Linear Geometry. 

g. Select the Pavement Asphalt EOPA radius return with the active profile. 

h. Set Use as Secondary Alignment. 

Note Corridor intervals are normally drawn perpendicular to the alignment the corridor follows. Since the corridor 
was drawn along the roadway centerline, the sidewalk and curb intervals would not normally be 
perpendicular to the radius return pavement edge as it needs to be. Use as Secondary Alignment 
instructs the template drop to place the interval perpendicular to the element being used for a point control. 

i. Accept remaining values as shown above. 

1. Repeat the steps above for the SR 61 L Corridor. 
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Exercise 4.7 Build the Intersection Terrain from 3D Elements 

1. Use Terrain, Create, From Elements tool. 

 

2. Select the boundary elements for the intersection. 

 

3. Set the Feature Definition to DtmClipping. 

4. Data point to accept. Press F7 to turn on Constructions in the 3D view if necessary to see the 

newly created terrain model.  
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5. Verify that the boundary is correct by turning off reference displays and Mesh items in 

Explorer >OpenRoads Standards. 

➢ Add a breakline in the vicinity of the SR61 centerline connecting the traffic separator to 

US 98. 

6. Construct a line using the horizontal geometry tools with an appropriate feature definition, 

such as PavtCrown. Use the vertical geometry tools, such as Profile Intersection Point, to 

create a profile for the horizontal line and set it active. 

7. Use the Terrain, Feature Management > Add Features tool. 

 

8. Select the newly created terrain model. 

9. Set Feature Type to Break Line and select a break line with an active profile. 

 

• To turn off the Blue triangles, toggle off Construction elements. 

10. Adjust stroking definition of the breakline in the Properties dialog to fine tune the surface as 

desired. 

  



DETAIL MODELING - Clip Terrain for Right Turn Island ____________________________________________________ Chapter 4 

FDOT Roadway Design 3D Modeling ©2021 FDOT  4-19 

Exercise 4.8 Clip Terrain for Right Turn Island 

1. Create a selection set of EOP lines for the Right Turn Island and copy from the 

DSGNRD01.dgn reference into the MODLRDDetail61file. 

2. Use Geometry, Complex Geometry > Complex by Element tool to complex all lines 

together into one complex element using the PavementAsphaltEOPA feature definition. 

Note The Automatic method is easier, but either way works. If using the Manual method, click on the first half of 
each line to ensure that the Complex Geometry elements are all going in the same direction. Note the 
arrow on the end of each element that appears as you select it, indicating direction. 

3. Open a Profile model for the complex element. 

4. Use the Geometry, Profile Creation > Quick Profile from Surface tool and select the 

intersection terrain and the complex element in the plan view. 

 

5. Set the newly created profile as active. 
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6. <Optional> Select the Profile and select Create Best Fit Profile. 

 

a. Enter the Best fit Parameters as shown. 

 

b. Create the Best Fit Profile, select the new Profile and select Set As Active. 

c. The Island Boundary is created in the 3D Model. 
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➢ Clip Terrain 

1. Use the Terrain, Additional Methods > Create Clipped Terrain Model tool. 

 

a. Select the intersection terrain in the 3D view. 

b. Select the right turn island complex element and 

reset. 

c. Set Clipping Method to Internal. 

d. Name the terrain Intersection Clip. 

e. Accept settings as shown on the right. 

f. Clipped terrain will overlap with existing terrain but triangles should indicate that the 

new one stops at the right turn island. 
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Exercise 4.9 Create an Intersection Pavement Surface 

1. Use Model Detailing, Apply Surface Template. 

 

a. Select Pavement Asphalt Surface Template from the Template Library.  

b. Select the Intersection Clip terrain to create pavement.  

• Hint: Select one of the triangles in the 3D view that does not go through the right turn island. 

c. Set Feature Definition to Enable Linear Features. 

 

Note Using Enable Linear Features creates break lines that can be used to create the top and bottom surfaces 
in Chapter 5. 
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2. Turn off Construction lines to see the surface template without the terrain overlap. 
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Exercise 4.10 Traffic Separator Nose 

1. To add the Traffic Separator 

Nose use the Model Detailing, 

Place Civil Cell Tool. 

 
2. Select the TSNose Civil Cell. 

 

3. Select the PavementAsphalt_pm line on the Right Side of the Traffic Separator in the Plan 

View, then select the line on the Left Side of the Traffic Separator. 

4. While hovering 

over each of the 

Reference lines, 

change the 

Reference Line 

direction 

arrow(triangle) 

on both elements 

until it fits on the 

lines. 

5. Data point to 

accept.  
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Exercise 4.11 Right Turn Island 

1. Use Model Detailing, Apply Linear Template tool. 

 

a. At the prompt select the 

Island Line in the Plan View. 

 

 

 

 

 

 
 
 
 

b. Select Alt down arrow to select the Template, Components>Curb & Gutter>Curb 

Type E Inside.  Data point to accept the Template. 

 

c. Select Alt to lock the Start Station and data point to accept. 

d.  Select Alt to lock the End Station and data point to accept. 



Chapter 4 _______________________________________________________________ DETAIL MODELING - Exercise Overview 

4-26 ©2021 FDOT FDOT Roadway Design 3D Modeling 

e. Data point to accept the Reflect Orientation on the inside of the island. 

f. Data point to accept the Exterior Corner Sweep Angle. 

 

2. Create Template Geometry for the back of curb line. 

a. Go to Explorer, right click on Feature 

Definitions > Linear > Roadway Design > 

Template Points > Curb_pm and select 

Properties. 

b. Change Create Template Geometry to 

“True” as shown on the right. 

c. Reprocess the linear template. 

3. To create the sod within the Traffic Island, 

create a Terrain from the 3D Top Back 

Curb line.  

a. Use Terrain, Create, From 

Elements tool. 

b. Set Feature Definition to 

DtmProposedSlopes.  
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Exercise 4.12 RRR98 Corridor-Build Intersection Terrain at School 

Entrance (On Your Own) 

1. Create a shape boundary of the perimeter of the School Driveway pavement to be resurfaced. 

2. Use the Create Clipped Terrain Model tool to model the existing pavement. 

3. Add a surface template to the Terrain in step 2. 

4. Use the RT_Switch parametric constraint along the RRR98 corridor to remove the overlap 

components between radius points. 

5. Add Key Station to near the radius points to create complete components. 

6. Use Linear Template around the Radii to construct the curb, sidewalk, shoulder, etc. 

a. Set the Template Origin and Pavement Point as shown. 

 

b. Add the PavementMilling(ML) lines as a reference to the linear templates to complete 

the widening. 
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Exercise 4.13 SR61 Corridor-Build Intersection Terrain at Friendship 

Road (On Your Own) 

1. Drop the Complex Chain that makes up the EOP Lines and Radius. 

2. Create a Corridor Model of the Friendship Road.  

3. Edit the Template Drop and delete all Components outside of widening. 

4. Project Profile to Element on the Curve EOP lines <OR> Quick Profile from Surface. 

5. Construct a Profile from the Projected Surface Lines for the Curve Radii. 

6. Use Linear Template around the Radii. 

7. Create a Terrain from the 3D elements. 

• For the Traffic Separator to Pavement Crown Cross over median, set the LT_XOVER_CTL, 
RT_XOVER_CTL, and PVT_CROWN Properties as shown: 
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5 CREATING 3D DELIVERABLE FILES 

INTRODUCTION 

This chapter will provide detailed instructions for producing the specific output files used by contractors for 

Automated Machine Guidance (AMG).  Specifically: 

• Controlling Geometry Files 

• 2D CADD files 

• Proposed 3D Breakline CADD files 

• Existing, Proposed and Subgrade/Earthwork surface XML files 

 

Chapter 8 of the CADD manual for FDOTConnect outlines the required 3D Deliverables. The table is also shown 

below. 

3D DELIVERABLES SUPPORTING AMG for 3D PROJECTS 

(Store in project folder: 3DDeliverables) 

Category File Name Description 

Design Alignments and 

Profiles 
AMG-ALGN##.xml 

All Alignments and Profiles exported from the \Roadway\ALGNRD, PROF or model files and 

\Roadway\DSGNRD or CORRRD files in LandXML format. 

2D Proposed 

Planimetrics Design 
AMG-2DSGN##.dwg/dgn 

2D proposed Roadway design exported from the \Roadway\DSGNRD file.  (Production of this 

file for construction is at the designer’s discretion.) 

 AMG-2DRPR##.dwg/dgn 
2D proposed Drainage design exported from the \Drainage\DRPRRD file. (Production of this 

file for construction is at the designer’s discretion.) 

 AMG-2PDPL##.dwg/dgn 
2D proposed Pond design exported from the \Drainage\PDPLRD file.  

(Production of this file for construction is at the designer’s discretion.) 

3D Existing Survey   

Note: Single survey 

Planimetrics file. 

AMG-3SURFACEEX##.xml 

3D existing terrain surface to be exported from the \Survey\GDTMRD file as LandXML 

format. 

(Production of this file for construction is at the designer’s discretion.  This file will be 

produced if the 3D Existing Surface dwg/dgn file(s) are not produced.) 

AMG-3SURVRD##.dwg/dgn 3D existing Topography, Drainage, and Utilities from the \Survey\SURVRD file 

3D Proposed Surfaces  AMG-3SURFACEPR##.xml 
3D proposed finished (top) surface to be exported as LandXML format from the 

\Roadway\MODLRD file.  

 AMG-3SURFACEEW##.xml 

3D proposed finished (bottom) surface to be exported as LandXML format from the 

\Roadway\MODLRD file. This file will be used to generate surface to surface earthwork 

volumes. 

3D Proposed Break Lines AMG-3DSGN##.dwg/dgn 3D proposed Roadway break lines exported from the 3D model. 

3D Proposed Model 

AMG-MODLRD0#.ifc/imodel 
Master roadway 3D model file, exported to the available BIM format based on platform, 

Industry Foundation Classes format (.ifc) preferred but imodel acceptable for Bentley projects. 

AMG-DRPRRD0#.ifc/imodel 
Master drainage 3D model file, exported to the available BIM format based on platform, .ifc 

preferred but.imodel acceptable for Bentley projects. 

AMG-

B#MODLBR0#.ifc/imodel 

Master bridge 3D model, exported to the available BIM format based on platform, .ifc 

preferred but imodel acceptable for Bentley projects. One file per bridge. 
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EXERCISE OVERVIEW 

Exercise 5.1 Creating Alignment XML File for AMG ......................................................................................... 5-2 
Exercise 5.2 Creating 2D Proposed Planimetrics File for AMG ...................................................................... 5-3 
Exercise 5.3 Create Master Model File............................................................................................................... 5-5 
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Exercise 5.5 Creating 3D Existing Surface File for AMG ......................................................................................... 5-7 
Exercise 5.6 Creating 3D Proposed Top Breaklines Files for AMG ......................................................................... 5-8 
Exercise 5.7 Creating 3D Proposed Surface Files for AMG .................................................................................. 5-12 
Exercise 5.8 Creating 3D Subgrade/Earthwork Breaklines for AMG .................................................................... 5-15 
Exercise 5.9 Creating 3D Proposed Subgrade/Earthwork Surface Files for AMG ................................................ 5-21 
Exercise 5.11 Use Land XML Visualizer to Validate Land XML File ...................................................................... 5-24 

 

Exercise 5.1 Creating Alignment XML File for AMG 

You can export Alignments and Profiles directly from the elements in the DGN file. 

1. Open the ALGNRDD01.dgn 

file. 

2. Switch to the Default Model 

view. 

3. Use the Geometry, General 

Tools, Import/Export > 

Export Geometry tool. 

4. Set Export type to LandXML. 

5. Select the CL_SR61 centerline alignment. 

6. Set the Version to 1.2 and check the box or select Yes to export Only 

Active Profiles. 

7. The Export to LandXML dialog opens. 

a. Navigate to the 3DDeliverables directory. 

b. Enter the File name: AMG-ALGNSR61.xml 

c. Ensure that 

LandXML File 

(.xml) is the Save 

as type. 

d. Click Save.  

8. Repeat steps 3-7 for the 

US98 Baseline to create 

AMG-ALGNBL98.xml. 

Note This will save both the 
Horizontal and Vertical 
(Profile) Geometry.  
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Exercise 5.2 Creating 2D Proposed Planimetrics File for AMG 

Use the MicroStation Save As command to save copies of the Proposed Design files into the 3DDeliverables 

directory with AMG-2 names in DGN and DWG formats. 

For example: AMG-2DSGNRDxx.DGN, AMG-2DSGNRDxx.DWG. 

➢ Simplify MicroStation Elements 

1. Open the DSGNRD01.dgn file. 

2. Select the Plan View to make active. Select Function Key CTRL F1 to open a Plan View. 

3. In the View Attributes, turn Off Construction elements<OR> Select Function Key F7. 

4. Turn Off reference file display. 

5. Turn Off levels for Baseline, CLConstr., and Scratch. 

6. Place a Fence around all the Elements. 

 

7. Save the fence contents to a file, in 3DDeliverables\AMG-2DSGNRD01.dgn. 

 

8. If converting to DWG (next page), check the 

Switch to generated file box. 

 

 

9. Data point to accept and verify the file is in the 3DDeliverables directory. 
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➢ Save as DWG(Optional) 

1. If not already open, open the .\3DDeliverables\AMG-2DSGNRD01 design file. 

2. Select File >Save As from the MicroStation menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog. 

4. Verify or Enter the File Name, AMG-2DSGNRD01 and click Save. 

5. Select the Units Survey Feet and click OK. 

  

Note The file will open in DWG Work Mode, see the blue cross hairs icon in the bottom right of the MicroStation 
window. 
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Exercise 5.3 Create Master Model File 

1. If not already done, set the Corridor Feature Definition to Final for all the corridors and linear templates. 

2. Go to the FDOT ribbon and Choose “Create File.” 

3. Create a new MODLRDMaster01.dgn file. Select Wakulla County. Choose Create/Open File. 

4. Reference the MODLRDDetail61, MODLRDMainline61, MODLRDUS98, 

MODLRD_EXISTING_FEATURES01, MODLRD_EXISTING_DRAINAGE01, 

MODLRD_EXISTING_UTILITIES01, RWDTRD01, PDPLRD01, GDTMRD01, SURVRD01, ALGNRD01, 

and DSGNRD01 files. 

5. Use the 

Terrain tab, 

Set Active 

tool. 

 
 
 

6. At the cursor prompt, select the Terrain Boundary green dashed line from the attached SURVRD01 

reference file. This will set the terrain model as Active. 

7. Display 2D and 3D Views and Select Function Key F2. 

8. Save Settings. 
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Exercise 5.4 Export iModel 

1. Go to File > Publish iModel as shown on the right. 

2. Check the box to Create a Single Package. 

3. In the Package name field, input AMG-

MODLRD01.i.dgn. Click the 3 dots beside the 

Package name and navigate to the 3DDeliverables 

folder. 

4. Review remaining settings and select Publish. 
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Exercise 5.5 Creating 3D Existing Surface File for AMG 

1. Turn ON the Reference file display for GDTMRD02 or SURVRD01. 

2. Select and hover over the Existing Surface and then select Export Terrain Model LandXML. 

 

3. Select the Terrain. 

4. Select the Export Format: LandXML 

5. Enter the Project Name: AMG-3SURFACEEX01 

6. Enter the Project Description: Existing Surface 

7. Select the Export Options: Export Both 

 

8. Save the AMG-3SURFACEEX01.xml file to the 3DDeleverables directory. 

  



Chapter 5 ______________________ CREATING 3D DELIVERABLE FILES - Creating 3D Proposed Top Breaklines Files for AMG 

5-8 ©2021 FDOT FDOT Roadway Design 3D Modeling 

Exercise 5.6 Creating 3D Proposed Top Breaklines Files for AMG 

This exercise outlines the steps to create the proposed surface of the project for use by contractors for automated 

machine guidance as follows: 

Prepare the View for Exporting 

Exporting 3D Break Lines 

Creating Proposed Surface Files for AMG 

Delete extraneous triangles 

➢ Prepare View for Exporting 

1. In the 3D view, turn OFF the Reference File display for: 

o MODLRD_Existing_Features01.dgn 

o MODLRD_Existing_Drainage01.dgn 

o MODLRD_Existing_Utilities01.dgn 

o RWDTRD01.dgn 

o GDTMRD01.dgn 

o SURVRD01.dgn 

o ALGNRD01.dgn 

o PDPLRD01.dgn 

2. Maximize the View 2 – Default-3D. 

3. Change the View Rotation to a 

Top view as shown on the right. 

4. Use the Function Key F7 to 

turn OFF all Construction 

elements in the 3D View. 

5. Open Level Display. Ensure the 

3D View is active. 
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6. Hold down Shift and select the MODLRDMainline61.dgn, MODLRDDetail61.dgn, and 

MODLRDUS98.DGN reference files. Turn off the following levels in the Default 3D View: 

a. any proposed sub-surface features and other non-

proposed surface features. 

i.e.  Bottom_pm, 

Subgrade_pm 

CurbBase_pm, 

PavtBase_pm, 

ShldrBase_pm, 

TemplateMisc_pm, 

TemplateNullPoint_pm. 

 

b. Any used _px levels (meshes). 

c. Remaining levels not needed for the 3D Proposed 

breakline surface.  i.e. Default level, Scratch_dp, 

Miscellaneous, ConstLines, and any levels not ending in 

_pm.  
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➢ Exporting 3D Break Lines. 

1. Place a Fence around all the Elements in the default-3D View. 

 

2. Save the fence contents to a file, in 3DDeliverables\AMG-3DSGNRD01.dgn. 

 

3. If converting to DWG (below), check the 

Switch to generated file box. 

4. Data point to accept and verify the file is in the 

3DDeliverables directory. 

➢ Save as DWG(Optional) 

1. If not already open, open the 3DDeliverables\AMG-3DSGNRD01 design file. 

2. Select File > Save As from the MicroStation Menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog. 

4. Verify or Enter the File Name, AMG-3DSGNRD01.dwg and click Save. 
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5. Select the Units Survey Feet and click OK. 

  

Note The file will open in DWG Work Mode, see the blue cross hairs icon 
in the bottom right of the MicroStation window.  

6. Trim extraneous elements as necessary. Save changes to the .dwg file, then “Save As” to 

overwrite the .dgn file. 
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Exercise 5.7 Creating 3D Proposed Surface Files for AMG 

1. In FDOTCONNECT, Select File >Open to the AMG-3DSGN01.DGN file. Click Open File 

and click OK. 

2. Create a Selection Set of all Elements. 

3. Use Terrain, Create, From Elements tool. 

 
4. Define the following in the Create Terrain Model dialog: 

o Feature Type:   Break Line 

o Edge Method:   None 

o Feature Definition:  DTMProposed 

o Name:   AMG-3SURFACEPR01 

 
5. Data point through prompts to accept settings. A Surface is 

created.  Use Function Key F2 to turn ON/OFF the 

construction elements. 

 

 

6. Notice the External Triangles must be trimmed. 

7. Turn Off the Level DTM_px  . 

8. Create a Selection Set of all the Cut_pm and Fill_pm 

Lines defining the slope construction limits. 

9. Use Terrain, Edit, Feature Management > Change 

Feature Type tool. 

 

 

 

 
 
 

10. Set the Feature Type to Boundary. 

11. When prompted left click twice to change all the selected lines to boundary elements for the 

External Limits of the Surface. 

12. Turn ON the DTM_px level to see the results. 
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➢ To delete extraneous triangles 

1. Select and hover over the Surface Terrain edge 

and then select Rules>Remove Rule. 

Note This will break the relationship to the 3D 
elements! Alternatively, build a 3D boundary 
connecting the gaps in the Cut_PM and Fill_PM 
lines and add the feature to the surface as a 
boundary, or use them to clip the terraian.  

2. Use Terrain, Edit Model tool. 

 

3. From the tool settings menu, select Delete Triangle By 

Line. 

 

4. Draw a line (two left clicks) from 

outside the terrain across the erroneous 

triangle, then repeat as necessary. 
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➢ Save Terrain to Land XML file 

1. Select and hover over the Surface and then select Export Terrain Model > LandXML. 

 

2. Select the Terrain. 

3. Select the Export Format: LandXML 

4. Enter the Project Name: AMG-3SURFACEPR01 

5. Enter the Project Description: Proposed Surface 

6. Select the Export Options: Export Both 

 

7. Save the file to the 3DDeleverables directory with the filename AMG-3SURFACEPR01.xml. 
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Exercise 5.8 Creating 3D Subgrade/Earthwork Breaklines for AMG 

This exercise outlines the steps to create the proposed surface of the project for use by contractors for automated 

machine guidance as follows: 

Prepare the Templates for Subgrade Point definitions and Alternate Surfaces 

Prepare the View for Exporting 

Exporting 3D Break Lines 

Creating Proposed Surface Files for AMG 

Delete extraneous triangles 

The 3D proposed finished subgrade surface to be exported as LandXML format from the \Roadway\MODLRD 

file. This file can be used to generate surface to surface earthwork volumes 

The subgrade surface can be created from the 3D feature lines provided that they have been defined properly in 

the point definitions on all project corridor, linear and surface templates. 

➢ Prepare the Templates for Subgrade Point definitions and Alternate Surfaces 

In the Create Template dialog, edit each of the points defining the finished subgrade. Set the Feature 

Definition and Alternate Surface fields to SubGrade_pm and SUBGRADE, respectfully.   

When creating surface terrains from 3D lines, there are two important TIN principles for consideration: 

a. Vertical Faces – all lines must have different xy values.  They cannot be stacked 

in the z plane. Therefore, set the horizontal offset value no less than .01 feet on vertical 

component points in the project templates 

b. Caves/Cliffs – all lines must continue in the same direction.  The TIN triangles 

will not reverse direction across a surface. Therefore, consider which points to use 

for the subgrade surface. I.E. base, base extensions, wall footers, etc.  Additional 

template points may be needed to intercept the top surface in these areas. As a rule, it 

is better to include the base, base extensions, wall footers, etc for excavation and not 

to include base, base extensions, wall footers, etc for embankment. 

Note These template accommodations are necessary to consider for ALL Corridor, Linear and Surface 
Templates used on the project. 

 



Chapter 5 _____________________ CREATING 3D DELIVERABLE FILES - Creating 3D Subgrade/Earthwork Breaklines for AMG 

5-16 ©2021 FDOT FDOT Roadway Design 3D Modeling 

The following images are examples of the point 

properties dialog, highlighted Subgrade_pm 

Point Feature Definition, and the highlighted 

SUBGRADE Alternate surface.  In this example 

the base extension is not included in the subgrade 

surface definition. 
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➢ Prepare the View for Exporting 

1. Open the MODLRDMaster01 file.  To Display 2D and 3D Views, select Function Key F2. 

2. Turn OFF the Reference File display for: 

o MODLRD_Existing_Features01.dgn 

o MODLRD_Existing_Drainage01.dgn 

o MODLRD_Existing_Utilities01.dgn 

o RWDTRD01.dgn 

o GDTMRD01.dgn 

o SURVRD01.dgn 

o ALGNRD01.dgn 

o PDPLRD01.dgn 

 

3. Maximize the View 2 – Default-3D. 

4. Change the View Rotation to a Top view. 

5. Use the Function Key F7 to turn OFF all 

Construction elements in the 3D View. 
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6. Open Level Display. Ensure the 3D View is active. 

7. Turn off display of Default level and PavementAsphalt_pm. 

8. Hold down Shift or Ctrl and select the 

MODLRDMainline61.dgn, MODLRDDetail61.dgn, and 

MODLRDUS98.DGN reference files.  

a. Turn on only proposed subgrade feature levels: 

i.e.  Cut_pm, 

Fill_pm, 

MedianCrown_pm, 

ShoulderUnpavBreak_pm, 

Subgrade_pm, 

 

b. Turn off any used _px levels (meshes) 

c. Turn off remaining levels not needed for the 3D 

Proposed breakline surface.  i.e. Default level, 

Scratch_dp, Miscellaneous, ConstLines, and any 

levels not ending in _pm. 
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➢ Exporting 3D Break Lines. 

1. Place a Fence around all the Elements in the default-3D View. 

 

2. Save the fence contents to a file, in 3DDeliverables\AMG-3DSGNRDEW01.dgn. 

 

3. If converting to DWG (next page), check the 

Switch to generated file box. 

4. Data point to accept and verify the file is in the 

3DDeliverables directory. 
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➢ Save as DWG(Optional) 

1. Open the 3DDeliverables\ AMG-3DSGNRDEW01.dgn design file. 

2. Select File > Save As from the MicroStation Menu. 

3. Select Autodesk(R) DWG as the Save as type. 

Note There is no need to set Options on the Save As dialog. 

4. Verify or Enter the File Name, AMG-3DSGNRDEW01 and click Save. 

5. Select the Units Survey Feet and click OK. 

  

Note The file will open in DWG Work Mode, see the blue cross hairs icon 
in the bottom right of the MicroStation window.  

6. Trim extraneous elements as necessary. Save changes to the .dwg file, then “Save As” to 

overwrite the .dgn file. 
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Exercise 5.9 Creating 3D Proposed Subgrade/Earthwork Surface Files 

for AMG 

1. In FDOTCONNECT, Select File >Open to the AMG-3DSGNRDEW01.DGN file. Click Open 

File and click OK. 

2. Create a Selection Set of all Elements. 

3. Use Terrain, Create, From Elements tool. 

 

4. Define the following in the Create Terrain Model dialog: 

o Feature Type:   Break Line 

o Edge Method:   None 

o Feature Definition:  DTMProposed 

o Name:   AMG-3SURFACEEW01 

 

 

 

 

 

 

 

5. Data point through prompts to accept 

settings. A Surface is created.  Use Function Key F2 

to turn ON/OFF the construction elements. 

6. Notice the External Triangles must be 

trimmed. 

7. Turn Off the Level DTM_px. 

8. Use Terrain, Feature Management, Change 

Feature Type tool. 
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9. Set the Feature Type to Boundary. 

10. Select each of all the Cut_pm and Fill_pm Lines individually defining the slope construction 

limits. Right click to finish when all the selected lines to boundary elements for the External 

Limits of the Surface. 

Note A Selection Set for Cut/Fill Lines does not produce the desired results for the creation of the Subgrade 
surface Terrain. 

11. Turn ON the DTM_px level to see the results. 
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➢ Save Terrain to Land XML file 

1. Select and hover over the Surface and then select Export Terrain Model > LandXML. 

 

2. Select the Terrain. 

3. Select the Export Format: LandXML 

4. Enter the Project Name: AMG-3SURFACEEW01.xml 

5. Enter the Project Description: Proposed Bottom Surface 

6. Select the Export Options: Export Both 

 

7. Save the file to the 3DDeleverables directory with filename AMG-3SURFACEEW01.xml. 
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Exercise 5.10 Use Land XML Visualizer to Validate Land XML File 

1. From the desktop locate and open the FDOTCONNECT Product Folder. 

 

2. Open the Land XML Visualizer tool. 

3. On the LandXML Visualizer tool, select File Open. Choose the AMG-

3SURFACEPR01.xml file. 
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4. Change the Plan View Setting to Default, No Fill, No Vectors and No shading as shown 

below.  Also, right click on the Pnts definition and choose Hide. 
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6 EARTHWORK 

INTRODUCTION 

In OpenRoads Designer, quantities are generally calculated from the 3D model. While most of the effort is 

covered in other training documents, there are some steps of earthwork calculation that tie in closely with the 

modeling process and will be covered in this chapter. Historically, earthwork quantities in roadway design have 

been calculated using the average end area method, calculating the volume as a prism with the ends being two 

cross sections. This has certain limitations to accuracy, particularly depending on the cross section interval. It 

assumes no changes happen between the cross sections. If the roadway is a bit asymmetrical about the centerline 

on a curve or the earthwork changes significantly between cross sections, the accuracy drops quickly. In contrast, 

with triangulated terrain models and modern computing power, it is easy to calculate the volume using the 

surface-to-surface comparison method. This calculates the actual volume between two surfaces by using all the 

points of each of the terrains, in a compute intensive method that would be impossibly time consuming to 

duplicate by hand.  Sometimes the surface-to-surface comparison method is also used to create a third surface 

that is the difference between the other two surfaces. In this comparison surface, any elevation values less than 

zero would be cut while positive values would be fill. 

Figure 1. Average End Area.1 

The above figures illustrate the key differences in the volume calculations between average end area and surface-

to-surface methods. Both are essentially calculating volumes of prisms, but the surface-to-surface prisms are 

enclosed by triangles based on the survey points and the triangles generated from the corridor components. The 

factors affecting volume accuracy are the detail level of the survey Digital Terrain Model and the interval spacing 

of the corridor model or the stroking definition of lines used for linear templates or surfaces. We can calculate 

much more accurate volumes from the 3D model by simply decreasing the interval spacing (i.e., on curves) and/or 

adding key stations in more complex areas such as intersections with radius returns in a way that seeks to 

maximize the tradeoff of performance vs accuracy. This is reflected in the requirements of the CADD manual 

table discussed in Chapter 2. 

The average end area earthwork volumes can be calculated manually by scaling from plans, calculating the areas 

of cut and fill shapes in one cross section, then performing the same calculation on the next cross section and 

 
1 josebchl, “Average End Areas Method Example,” Batista Land Surveyor, October 9, 2016, 

http://batistalandsurveyor.com/math/average-end-areas-method-example/. 
2 Jian-chuan Cheng and Long-jian Jiang, “Accuracy Comparison of Roadway Earthwork Computation between 

3D and 2D Methods,” Procedia - Social and Behavioral Sciences, Intelligent and Integrated Sustainable 

Multimodal Transportation Systems Proceedings from the 13th COTA International Conference of 

Transportation Professionals (CICTP2013), 96 (November 6, 2013): 1277–85, 

https://doi.org/10.1016/j.sbspro.2013.08.145. 

Figure 2. Surface-to-surface comparison.2 
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summing them up. The surface-to-surface comparison method, by contrast, is too computationally intensive to 

calculate by hand. 

For engineers wanting to independently verify the quantity calculations, there are still a few options. One would 

be to import the surfaces into construction software such as Trimble and run the surface-to-surface comparison 

method in the other piece of software. This allows a different algorithm to independently check the calculations 

performed by OpenRoads Designer. Another might be to have OpenRoads calculate the volumes using the 

average end area as well, while recognizing that this figure will always differ to some degree due to its lower 

accuracy. 

For the FDOT workflow we need to create the cut and fill volumes in the model files, and we cannot perform a 

surface to surface volume comparison until the proposed bottom surface is created. This chapter will focus on 

those two steps. Both are using the same approach to calculate the volumes, but one creates 3D shapes from the 

corridors and detail modeling, and the other calculates directly from two Digital Terrain Models. 

EXERCISE OVERVIEW 

For any projects with multiple alignments, the cut/fill 3D shapes need to be created in separate files for each 

alignment. This allows our quantity calculations to be tied to an alignment. Any file that is referenced in is 

included in the earthwork volume calculation, even if the display is off. Consequently, for these projects, care 

needs to be taken to not even clip one corridor to a corridor on another alignment. In the case of this dataset, 

earthwork volumes for each alignment will be created in the MODLRDMainline61.dgn and MODLRDUS98.dgn 

files respectively. MODLRDMainline61.dgn will need to reference MODLRDDetail61.dgn, but it does not need 

to reference MODLRDUS98.dgn, even though the detail file references it out of necessity. For intersections 

between different alignments, having a separate file for detail modeling may be the best model management plan. 

Exercise 6.1 Create Cut and Fill Volumes ............................................................................................................... 6-2 
Exercise 6.2 Analyze Volume ................................................................................................................................. 6-4 

 

Exercise 6.1 Create Cut and Fill Volumes 

➢ Prepare File for Cut and Fill Volumes 

1. Open the c:\<Workset Folder>\FDOT\22049555201_CE\roadway\MODLRDMainline61.dgn file in the 

FDOTConnect - Roadway Workspace in OpenRoads Designer. 

1. With the 2D view active, attach the MODLRDDetail61.dgn file. 

2. If not already open, open a 2D and a 3D view. 
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➢ Create Cut and Fill Volumes, SR61 

3. Use the Home > Civil Analysis > Create Cut Fill Volumes command. 

 

4. Accept the default options in the dialog. 

 

 

 

 

5. To see the cut and Fill Volumes, turn on Constructions in the 3D view. 

 

Note Cut Volumes are in red and Fill Volumes are in blue. There should be two components, even if the cut and 
fill areas are not contiguous. These components do not show up in the OpenRoads Model, but can be 
toggled on and off in the OpenRoads Standards under Feature Definitions > Mesh > Volumes. 

➢ Create Cut and Fill Volumes, US98 

6. Open the c:\<Workset Folder>\FDOT\22049555201_CE\roadway\MODLRDUS98.dgn file in the 

FDOTConnect - Roadway Workspace in OpenRoads Designer. 

7. Repeat Steps 3-6 to create Cut and Fill Volumes for the US98 corridor. 

Note Ensure that the neither the MODLRDMainline61 nor the MODLRDDetail61 files are attached. 
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Exercise 6.2 Analyze Volume 

1. Open the MODLRDMaster01.dgn file. 

2. Make the 2D View active. 

3. Attach the AMG-3DSGN01.dgn and the AMG-3DSGNRDEW01.dgn files as references. Turn off display of 

all but DTM levels. 

4. Use the Home, Model Analysis and Reporting, Civil Analysis > Analyze Volume tool. 

 

5. Use the Terrain Model to Terrain Model Volume Method. 

6. Set Existing Ground as the From Terrain Model as shown below. 

 

7. Set To Terrain Model to the proposed subgrade surface AMG-3SURFACEEW01. 

8. <Optional> Check the box to Save Result to insert the calculated volume as a text object in the dgn file. 

9. Accept settings and view the volumes in the Civil Message Center.  

Note Volumes calculated are in the file units, so should be cubic feet, not cubic yards. 

10. If Save Result was checked, insert the volume at desired location in the 2D View.
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7 VISUALIZATION 

INTRODUCTION 

This section will cover several options for visualizing the model. These will help reviews performed in the CAD 

software, in LumenRT on a computer, or in LumenRT using a VR headset such as Oculus Rift. 

EXERCISE OVERVIEW 

Exercise 7.1 Visualize Existing Ground ................................................................................................................... 7-1 
Exercise 7.2 Create a 3D Drive-Through Animation............................................................................................... 7-4 
Exercise 7.3 Export to LumenRT ............................................................................................................................ 7-5 

 

Exercise 7.1 Visualize Existing Ground 

➢ Clip the Existing Ground Terrain 

1. Open the MODLRDMaster01.dgn file. 

2. In the 3D view, turn Constructions on in order to see the terrains used to create surface 

templates. 

3. Use the Terrain, Additional Methods > Create Clipped Terrain Model tool. 

a. Select the Existing Ground for the Reference Terrain Model. 

b. Select all the corridor handles: 

• SR 61 L 

• SR 61 R 

• SR 61 Inside 

• US 98 

c. Select the DtmPr 

Terrain.  

d. Accept clipping 

features. 

e. Set Feature Definition 

to DCDrape. The 

triangles of the 

Existing Ground 

should now display 

without overlapping 

the proposed model. 
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➢ Drape Aerials on Existing Ground 

1. Ensure that the 3D View is active. 

2. Use the Home, Attach Tools > Raster Manger tool. 

 

3. Attach the 3 5136:-0#.sid files in C:\Workset\FDOT\22049555201_CE\ Roadway\aerials\sid 

4. Set Draping to Yes as shown below and click “Attach.” 
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5. The existing ground will display on the terrain with the DCDrape Feature Definition. 

 

6. Use Terrain, Geometry, Feature Management > Add Features to add the lines used to create 

the intersection surface in Chapter 4 to the new DCDrape terrain. 

 

7. Set Feature Type to Hole. 

Note Often the Hole Feature Type works, although because the profiles of those lines are not on the existing 
ground, it likely will not. Drape Void will work better as it essentially drapes the profiles to the existing 
ground before using them to clip the surface. 

8. Use Terrain, Geometry, Feature Management > Change Feature Type to change the feature 

type of the lines to Drape Void until they are successfully removed from the terrain. 

• Hint: turn off display of reference file levels except for the Pavt Break and EOP from MODLRDDetail61.dgn 
in order to make it easier to select the lines for both these steps. 

9. If needed, edit the model to manually delete triangles overlapping with the proposed model. 
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Exercise 7.2 Create a 3D Drive-Through Animation 

Creating a drive through along the 

project requires a 3D view and a 3D 

path to follow. This exercise explains 

how to use the Drive Through tool in 

FDOTConnect along the proposed 

SR61 3D Model.  

➢ To Setup the Animation 

Drive Through 

 

1. Open the MODLRDMaster01.dgn file. 

2. Maximize View 2 Default-3D model to set it as the Active View. 

3. Turn OFF the ConstLines and XSMisc_px levels. 

4. Use Corridors, 3D Drive Through tool. 

5. At the prompt, Select a 

3D view, left click 

inside View 2. 

a. At the prompt, 

Select the 

center line of 

the road, pick 

the 3D line in 

the view shown 

on the right. 

 

 
 

b. On the 3D Drive Through dialog, change to the tab 

Camera/Target Controls and enter the values as shown 

on the left. 

 

 

 

c. Change the tab back to the General 

Controls and Select the play button as 

shown on the right.  
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Exercise 7.3 Export to LumenRT 

Note Ensure the system meets LumenRT requirements. CADD or District training laptops may not be able to 
process and may crash. 

1. Make the 3D View active. 

2. Change the Active Workflow to 

Visualization. 

 

 

 

3. Turn off Existing Ground lines: 

a. Turn off display of GDTMRDO1.dgn. 

b. Turn off all levels in MODLRDMaster01.dgn except for DTM_ex and 

DTMTriangles_ep. 

4. Use the Home, LumenRT tool. 

 

5. LumenRT will open and the export will process. 
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