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FDOTConnectXX.XX 
OpenRoads Designer 

Comprehensive Template Design 

Description 

This is a 1-day training course to learn the fundamentals of Template Design. Participants will learn 
basic and advanced knowledge of the Create Template dialog within Bentley OpenRoads Designer 
Connect Edition environment for design and modeling within the FDOTConnectXX.XX workspace.  Most all 

of the Create Template dialog capabilities are included as follows: 

•    Template Library Basics •    Point and Component Properties 

•    Creating New Libraries, Folders and  Templates •    Constraint Types/ Labels 

•    Current Template Window •    Horizontal Feature Constraints 

•    Template Preview Window •    End Conditions/ Targets/ Priorities 

•    Current/Active Template Tab •    Display Rules 

•    Dynamic Settings •    Testing Window 

•    Create /Modify/ Delete Components, Points, etc. •    Point Name and Component Name Overrides 

Objectives 

• Create a New Project Template Library and Project Folders. 

• Use Template Library Organizer to build Project Templates.  

• Build a Resurfacing Template from Basic Components. 

• Learn to Use the Variable Median FDM Templates. 

• Configure Templates for Superelevation. 

• Add and Test End Conditions. 

• Build a Special Condition Component Sets for Displaying Walls, Guard Rails, Sidewalks, etc.  

• Build a Special Condition Component Sets for Displaying Special Ditches with Variable Width and 

Constant Slopes. 

• Adding Special Condition Component Sets to a Template. 

• Practice Building Project Templates from Sample Project Typical Sections 

Audience 

• FDOT Roadway Designers and Engineers  

Prerequisites 

Participants have a basic understanding of Computer Aided Drafting and Design (CADD) using MicroStation, a 

basic understanding of OpenRoads Technoloyconcepts and a solid understanding of the engineering necessary to 

design a Roadway. In OpenRoads Designer there is no longer any GEOPAK Functionality. 

 

Duration: 8 Hours    

 

Professional Credit Hours:  8 PDHs 

 

 

 





TABLE OF CONTENTS 

 

Comprehensive Template Design – Exercises 

FDOTCONNECTXX.XX ............................................................................................................................................. 1 

STATE OF FLORIDA ................................................................................................................................................. 1 

DEPARTMENT OF TRANSPORTATION ..................................................................................................................... 1 

1 GETTING STARTED ....................................................................................................................................... 1-1 

INTRODUCTION .......................................................................................................................................................... 1-1 
Best Practices ..................................................................................................................................................... 1-1 

CREATE TEMPLATE DIALOG ........................................................................................................................................... 1-1 
Current Template Window................................................................................................................................. 1-2 
Template Preview Window ................................................................................................................................ 1-3 

SETTING PREFERENCES ................................................................................................................................................. 1-3 
Template Options .............................................................................................................................................. 1-4 

TEMPLATE LIBRARY ..................................................................................................................................................... 1-5 
Workset ITL ........................................................................................................................................................ 1-6 
Template Library Organizer ............................................................................................................................... 1-7 

EXERCISES OVERVIEW .................................................................................................................................................. 1-8 
Exercise 1.1 Creating a New Project Template Library .......................................................................................... 1-8 
Exercise 1.2 Create Template Library Folders...................................................................................................... 1-10 
Exercise 1.3 Using the Template Library Organizer ............................................................................................. 1-12 

2 BUILD A STATIC TEMPLATE .......................................................................................................................... 2-1 

TERMS ...................................................................................................................................................................... 2-1 
TEMPLATE COMPONENTS ............................................................................................................................................. 2-1 
POINT PROPERTIES ...................................................................................................................................................... 2-2 

Point Naming is Important ................................................................................................................................ 2-4 
Component Naming ........................................................................................................................................... 2-5 
Point Feature Definitions ................................................................................................................................... 2-6 

CONSTRAINTS ON POINTS ............................................................................................................................................. 2-7 
Point Constraints Example ................................................................................................................................. 2-8 
Constraint Types ................................................................................................................................................ 2-8 
Display Constraints ............................................................................................................................................ 2-9 

TEMPLATE OPTIONS .................................................................................................................................................. 2-10 
DYNAMIC SETTINGS................................................................................................................................................... 2-10 
CONSTRUCTION OF TEMPLATES ................................................................................................................................... 2-11 

Building a Template from Components ........................................................................................................... 2-12 
Merging Points................................................................................................................................................. 2-13 
Testing Components ........................................................................................................................................ 2-14 
Inserting Components ...................................................................................................................................... 2-15 

EXERCISES ............................................................................................................................................................... 2-16 
Exercise 2.1 Creating a Static Template ............................................................................................................... 2-16 
Exercise 2.2 Configure Template to Match Existing Pavement Slopes ................................................................ 2-23 
Exercise 2.3 Configure Widening to Match Existing Pavement Slopes ................................................................ 2-25 
Exercise 2.4 Creating a Corridor .......................................................................................................................... 2-31 

3 ADDING END CONDITIONS .......................................................................................................................... 3-1 

END CONDITION PROPERTIES ........................................................................................................................................ 3-1 
TESTING END CONDITIONS ........................................................................................................................................... 3-2 
EXERCISES ................................................................................................................................................................. 3-3 

Exercise 3.1 Add End Conditions ........................................................................................................................... 3-4 
Exercise 3.2 Test End Conditions ........................................................................................................................... 3-9 
Exercise 3.3 Synchronized Template Changes in the Corridor............................................................................. 3-10 

4 HORIZONTAL FEATURE CONSTRAINTS ......................................................................................................... 4-1 

HIERARCHY OF CONSTRAINTS ........................................................................................................................................ 4-1 



 

 

HORIZONTAL FEATURE CONSTRAINT ............................................................................................................................... 4-1 
EXERCISES ................................................................................................................................................................. 4-3 

Exercise 4.1 Horizontal Feature Constraints .......................................................................................................... 4-4 
Exercise 4.2 Adding Corridor References............................................................................................................... 4-7 
Exercise 4.3 Set Corridor Design Stage .................................................................................................................. 4-9 
Exercise 4.4 Search Range ................................................................................................................................... 4-13 
Exercise 4.5 Troubleshooting Ranges .................................................................................................................. 4-14 
Exercise 4.6 Synchronize Template Changes with the Corridor .......................................................................... 4-16 

5 SWITCHES.................................................................................................................................................... 5-1 

INTRODUCTION .......................................................................................................................................................... 5-1 
PARENT \ CHILD RELATIONSHIPS .................................................................................................................................... 5-1 
ACTIVE TEMPLATE VIEW .............................................................................................................................................. 5-2 
ORGANIZING \ STACKING CONDITIONS ............................................................................................................................ 5-3 
SWITCHES ................................................................................................................................................................. 5-4 
DISPLAY RULES ........................................................................................................................................................... 5-5 

Creating Display Rules ....................................................................................................................................... 5-6 
DEFINING PARAMETRIC CONSTRAINTS (LABELS) ................................................................................................................ 5-7 

Parametric Constraints ...................................................................................................................................... 5-7 
Applying Parametric Constraints ....................................................................................................................... 5-8 

EXERCISES ................................................................................................................................................................. 5-8 
Exercise 5.1 Setting Preferences (Optional) .......................................................................................................... 5-9 
Exercise 5.2 Parent \ Child Relationships ............................................................................................................ 5-11 
Exercise 5.3 Add Switches and Display Rules....................................................................................................... 5-16 
Exercise 5.4 Apply Parametric Constraints .......................................................................................................... 5-22 

6 TRIGGER LINES ............................................................................................................................................ 6-1 

INTRODUCTION .......................................................................................................................................................... 6-1 
Creating Trigger Lines ........................................................................................................................................ 6-2 

EXERCISES ................................................................................................................................................................. 6-2 
Exercise 6.1 Setting Preferences (Optional) .......................................................................................................... 6-3 
Exercise 6.2 Stacking Conditions ........................................................................................................................... 6-4 
Exercise 6.3 Type F Curb & Gutter Condition ........................................................................................................ 6-6 
Exercise 6.4 Constraining Conditions Together ..................................................................................................... 6-9 
Exercise 6.5 Defining Parent \ Child Relationships .............................................................................................. 6-12 
Exercise 6.6 Testing Relationships ....................................................................................................................... 6-16 
Exercise 6.7 Configuring Trigger Line Component ............................................................................................... 6-17 
Exercise 6.8 Display Rule ..................................................................................................................................... 6-18 
Exercise 6.9 Adding Corridor References............................................................................................................. 6-19 
Exercise 6.10 Fixing Vertical Offset with Parametric Constraints ........................................................................ 6-21 

 

 

 



 

Comprehensive Template Design  ©2018 FDOT  1-1 

1 GETTING STARTED 

INTRODUCTION 

Best Practices 

1. Using the already created itl add any folders that are missing 

2. Use TLO to copy FDOT Templates. 

3. Organized Templates by corridor. 

4. Version the Templates or organize by Template Drop Stations. 

5. Use Apply Affixes when building new Templates (tools options). 

6. One green point per Template (as a rule). 

7. Remove Point Name Overrides, except on common tie down points (All white text). 

8. Remove Component Name Overrides, except on common tie down components. 

9. Use the same label on common Constraints. 

CREATE TEMPLATE DIALOG 
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• User Definable Folders 

• Create Templates, Components and End Conditions  

• Right-click Functions  

• Copy and Paste, and Drag and Drop  

• Red-colored Box Indicates Current Template  

• Drag and Drop Components to Current Template Window  

On the left side of the dialog, you will find the Template Library area, which contains a Windows-like folder 

structure. The root folder is the name and location of the Template Library that is currently open. Only one 

Template Library may be open at a time.  

To navigate the folder structure, double-click the folders you want to open or close. Inside any folder you can 

create and organize your templates and subfolders. The organization of the folder structure is user definable. The 

folder structure also supports common Windows functions, such as drag and drop, cut and paste, etc.  

Most commonly-used commands can be accessed by right clicking on the folders and templates. If you double 

click a template, it becomes the Current Template and is signified by a red box around the Template icon. The 

Current Template is also identified in the Current Template  

Current Template Window 

• Templates Assembled and Edited  

• Right-click to Create Components  

• Double-click to Edit Points and Components  

• View Commands Bottom of Window  

In the center of the Create Template dialog is the main graph for creating templates. The graph is called the 

Current Template window. The Current Template window uses its own graphics engine and is not a MicroStation 

View.  

The scale of the graph is dynamic and changes as you zoom in and out. The center point of the Current Template 

window is marked by the dynamic origin, which is a magenta-colored box. The dynamic origin is used as a 

reference point and can be moved to any location in the graph.  

At the bottom of the graph there are numerous view commands, which are similar to MicroStation View 

commands. There are two buttons that look like the MicroStation View Previous and View Next commands, 

however, they are used to undo and redo template creation operations. If your mouse has a scroll wheel, it can be 

used to pan and zoom. The CTRL-Z keyboard hotkey will undo your last edit or creation.  

In the graph area you can right-click to access commands and you can double-click elements in the graph for 

editing purposes.  
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Template Preview Window 

Under the Template Library area is the Preview area. When you highlight (single click) a template, the template 

is displayed in the Preview area.   The Template Preview window previews Templates and Components:  

• Works on Non-current Templates  

• Placement Point Location Denoted by a Cyan-colored Box  

• Click Point to Move Placement Point Location  

• Drag and Drop from Preview Area to Current Template Window  

You can use the Preview to assemble templates from their parts or components. This is accomplished using drag 

and drop functions. The cyan-colored box in the Preview represents the insertion point for any drag and drop 

operation. You can change the insertion point location by clicking the desired insertion point on the preview.  

SETTING PREFERENCES 

 

 

FDOT provides a collection of preferences definitions that should be applied before creating templates. 

1. From the Create Template dialog select Tools > Options. 

2. On the Template Options dialog click the Preferences button.   

3. On the Preferences dialog select FDOT and click Load (or double-click FDOT). 
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Template Options 

Specifies naming and step options for the current template. 

 

• Naming Options  

o Component Seed Name - From Feature Definition - indicates, when selected, the component 

name is derived from the style specified when the component is created.  

o Component Seed Name - Specify - indicates, when selected, the component name is specified 

in the field.  

o Points Seed Name - allows you to specify the seed name for point in the current template. Since 

point names must be unique, the seed name is appended with a different number each time a 

point is created.  

o Apply Affixes - Left Prefix/Suffix - specifies which prefix/suffix should be added to a point or 

component when the value is on the left of 0.0 (absolute).  

o Apply Affixes - Right Prefix/Suffix - specifies which prefix/suffix should be added to a point or 

component when the value is on the right of 0.0 (absolute).  

• Step Options - specifies precision step input for components and points. These values can also be accessed 

from the Dynamic Settings dialog.  

o Step Options - X Step - specifies the step increment for the X distance from the dynamic origin. 

If this value is non-zero, then the cursor moves to the horizontal increments of the specified 

value as measured from the dynamic origin.  

o Step Options - Y Step - specifies the step increment for the Y distance from the dynamic origin. 

If this value is non-zero, then the cursor moves to the vertical increments of the specified value 

as measured from the dynamic origin.  

o Step Options - Slope - specifies the step increment for slope from the dynamic origin. If this 

value is not 0, then the cursor moves to the slope increments of the dynamic origin. Slope is 

applicable only when the dynamic settings are in horizontal/slope mode.  

• Preferences - opens the Preferences dialog.  

  

mk:@MSITStore:C:/Program%20Files%20(x86)/Bentley/MicroStation%20V8i%20(SELECTseries)/Documentation/Civil_Tools_SS4.chm::/GUID-BBD374B2-4CAC-DAB2-9E1F-C18312EB7631.html
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TEMPLATE LIBRARY 

FDOT provides a customized Template Library named: CIVIL FDOT ORD.ITL, located in the 

\FDOTConnectXX.XX\Organization-Civil\FDOT\Template Library directory.  It contains a collection of 

Components and Templates that were developed from the FDOT Design Standards and FDM.  These templates 

can be copied into a project specific ITL and customized to meet the needs and unique conditions of each project. 

 

The FDOTCONNECTXX.XX workspace includes configuration variables that will make  a project specific .itl 

file when a file is created in the Roadway folder of the project. The .itl that is created will have only some of the 

componets that you will need make CIVIL FDOT ORD.ITL the default template library unless a project specific 

ITL is found.  If an ITL file name matches the project name then it will be defined as the default ITL. 

The Components contained in the FDOT template library were developed using the criteria defined in the FDOT 

Design Standards. 

The Templates delivered in the “Typical Sections (FDM)” folder of the ITL are static templates matching each 

Typical Sections defined in the Florida Design Manual (FDM).  
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Workset ITL 

The CIVIL FDOT ORD.ITL file is normally located on the server where users have limited access. To customize 

the template library for a specific project it will be important to create a project ITL file and import the needed 

components and templates from the CIVIL FDOT ORD.ITL file. The project ITL file can then be selected in the 

Corridor Modeler preferences to associate it with a specific project.  

 A Workset specific ITL will be created once a design file is created using the Create File tool. This ITL file 

will have folder structure and some common templates that can be used to design a project. 

 

Note A ITL file will be created automatically in the Roadway Folder when you first create a file.  The user then 
will use the Template Library Organizer to build the itl.. 

o . 
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Template Library Organizer 

After creating and opening the project specific template library you can import Templates and Components using 

the Template Library Organizer.  On the Create Template dialog select Tools > Template Library Organizer. 

The Template Library Organizer moves (drag and drop) templates from one template library to another. To copy 

or move a template or an entire folder, press and hold the left mouse button down over a template or folder, then 

drag the selected item to its new location either in the other library or the same library.  

The default process is to copy the item. To move the item, hold down the shift key while releasing the left mouse 

button. The selected folder or template can also be deleted by pressing the delete key. 
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EXERCISES OVERVIEW 

To prepare your computer for the next set of exercises: 

a) Delete the following file 22049555201_CE.itl from the location 

C:\WorkSets\FDOT\22049555201_CE\Roadway Folder.   

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  

c) Extract the CT22049555201_Chapter1.zip file in the C:\WorkSets\FDOT\ folder. 

Exercise 1.1 Creating a New Project Template Library 

In this exercise students will create a project specific template library. This new project Template Library is the 

container for all the components and templates used to develop the model for the project. 

1. Open the MODLRD_TemplateDesign01.dgn file from the current workset that was delivered.  

C:\WorkSets\FDOT\22049555201_CE\Roadway\  

2. On the OpenRoads Modeling workflow select the Corridor Tab on the Ribbon, Create Template tool. 

 

3. Open the Create Template dialog and select File > New > Template Library.  
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4. Navigate to the Workset rRoadway folder, C:\WorkSets\FDOT\22049555201_CE\Roadway\ and enter 

the new Template Library Name, Training. Press Save. 

 

5. Select File > Save again to verify, then close the Create Template dialog. Press Close. 
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Exercise 1.2 Create Template Library Folders 

• Components 

• Corridor Templates 

• End Conditions 

• Linear Templates 

• Surface Templates 

The Components, End Condition, Linear Templates, Surface Templates folders contain parts of the full 

Templates and is obtained from the FDOTCONNECTXX.XX Template Library.   

The Corridor Templates folder contains the constructed templates for the corridor. The Project Templates in the 

exercises to follow are named and saved in stages or phases in order to track the progress of the design. This 

method is also recommended to provide a backup and/or history for potential trouble shooting along the way. 

1. Use Corridor Modeling, Create Template tool.This can be found on the Corridors Tab 

 

2. Create new folders in the Project Template Library by selection File > New > Folder from the menu or 

by right clicking on the root folder in the Create Template dialog and selecting New > Folder from the 

context menu. 

 

 

 

 

 

3. Create and re-name five folders. Select the Root folder and repeat steps to include all the following 

folders: 

o Components 

o Corridor Templates 

o End Conditions 

o Linear Templates 
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o urface Templates 

 

4. Select File > Save to save 

the project Template Library .itl 

file.  
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Exercise 1.3 Using the Template Library Organizer 

Typically the components and templates needed for your project can be copied from other Template Libraries 

and design files using the Template Library Organizer.  This exercise uses the Template Library Organizer 
to copy the components need for this workshop into your project ITL file. 

 

 

 

Note If a new template is created as in this exercise a new setting preferences needs to be defined. 

1. Use Create Template and select Tools > Template Library Organizer. 

 

2. From the Template Library Organizer dialog, press the Ellipses icon next to the OK button. The Open 
Template Library window displays. 

 

3. From Open Template Library, navigate to the Template Library folder within the 

FDOTConnectXX.xx workspace 

C:\FDOTConnect10.10\Organization-Civil\FDOT\Template Library 

folder and select the CIVIL FDOT ORD.itl Template Library file. Press Open. 
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4. The Template Library Organizer dialog displays with the .itl file listed in the right Available In: 

window pane. 

  

5. From the Template Library Organizer, navigate to the Components\Curb & Gutter folder shown 

below.    

6. Select Curb Type F to preview the template in the Preview window below the directory view. 
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7. Drag the Curb Type F component from the right side to the left side and drop it onto the Components 

folder for the project. 

   
 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. Collect the following items from the CIVIL FDOT ORD Template Library and drag them to the Project 

Folders Locations as shown below 

CIVIL FDOT ORD Template 

Location 
Project Folder Location 

Components/Curb & Gutter Curb Type F to Components 

Components/Ditches Common Ditch Left to Components 

Components Entire Null folder to Components 

Components Entire Pavement folder to Components 

Components/Shoulder Shoulder Pavement Left to Components 

Components/Shoulder Shoulder Pavement Right to Components 

Components/Utility Strip Utility Strip Left to Components 

End Conditions Entire Parts folder to End Conditions 
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End Conditions Cut & Fill to End Conditions 

End Conditions Standard Search Line (Trigger) to End Conditions 

9. Press OK to return to the Create Template dialog and press Yes to the “Save data to file…   

 The FDOT Standard Items are now saved in the Project Template Library. 

10. Close MicroStation so the FDOT workspace will recognize the new Project ITL file. 
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2 BUILD A STATIC TEMPLATE 

TERMS 

Component - a set of points that define an open or closed shape. 

 

Template - a collection of points and components. 

 

Template Library - Templates are stored in a Template Library (*.itl). 

TEMPLATE COMPONENTS 

A component is a set of points that define an open or closed shape. Each component, whether open or closed, can 

represent a different material or area of interest. Components are named and have an assigned feature style.  

Components can be modified as desired. There is no limit to the number of points or components in a Template. 

When Templates are paired with horizontal and vertical alignments and superelevation, they define the surface 

of a corridor. Templates are flexible design components that allow you to model simple constructs, such as ditches 

and sidewalks, to the more complex multi-lane highways with superelevated curves and variable side slopes. 

There are 5 types of components created in Corridor Modeling: Simple, Constrained, Unconstrained, Null Point, 

End Condition, and Overlay/Stripping. 

• Simple Component - typically represents a section of pavement. It’s a closed parallelogram (4 constrained 

points) that is defined by the slope and thickness.  

• Constrained Component - consists of points that are all restricted to the movement of the first point. A 

constrained point is typically used to manage the behavior of other points in the template. When a point 

(parent) is moved, any constrained point (child) also moves. This restriction only affects the offset and 

elevation (x,y) of the restrained point and, the relationship is unidirectional (movement of child point does 

not move the parent point).  

• Unconstrained Component – an open or closed-shaped with no movement restrictions.  

• Null Point Component - a template point that is purposely not related to any particular component. It’s most 

often used as a reference for controlling other points.  

• End Condition Component - a special open-shaped component that targets a surface, a feature of a surface, 

an elevation, or an alignment (it replaces the former Cut/Fill, Material, and Decision tables). The integrity of 

end conditions can now be routinely tested while the roadway template is being created. 

• Overlay/Stripping Component - used to handle all milling/stripping operations and can be used to handle 

leveling (overlay) operations. 
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POINT PROPERTIES 

 

Point Properties specifies properties associated with roadway template points:  

• Name - displays the point name. The drop down list includes items from the Point Name List.  

• Use Feature Name Override - displays the name of the feature that will be created in the surface to 

correspond to the point. This field is optional. If it is blank, then the point name will be used as the feature 

name.  

Note While the Point name must be unique to the template, the Feature Name does not have to be. However, 
if the same feature name exists on more than one point for the solution at a given station, undesirable 
results will occur.  

The option is intended, primarily, for end condition components, to create connectivity from one station 
to the next when the template end conditions change. For example, if you want all surface tie-in points 
to belong to one feature, then set the feature name of all the ending end condition points on each side 
of the template to the same name (i.e. all Cut and Fill end points on the right would be given the feature 
name Tie_R and all the ones on the left would be given the feature name Tie_L).  

• Feature Definition - displays the feature style of the point. If no style is specified, then it comes from the 

first component of which the point is a member.  

• Alternate Surface - allows you to specify the name of an alternate surface for a point. You may choose 

multiple alternate surface names. Select from the list of available surfaces in the active template.  

o End Condition Properties - allows you to specify additional properties when a point is part of 

an end condition.  

o Check for Interception - specifies the preceding segment will be checked for interception of 

the target when the end-conditions are solved. If it is turned off, then the segment will be ignored 

when checking for interceptions.  

o Place Point at Interception - specifies that when an interception is found along the preceding 

line segment, the line segment will be drawn to the interception. Otherwise, if the interception 

is found, the line segment will be drawn to its maximum width.  
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o End Condition is Infinite - specifies the last segment will be considered to be of infinite length 

when attempting to intercept the target. This option is applicable only to the last point on the 

end condition.  

o Do Not Construct - specifies the point will be solved like all other points in the end-condition, 

but the point will be skipped when drawing the component segments.  

• Member Of - indicates in which components the point is included.  

• Constraints - allows you to review/edit the constraints on a point.  

o Type - specifies the constraint type: None, Horizontal, Vertical, Slope, Vector-Offset, Project 

to Surface, Project to Design, Horizontal Maximum, Horizontal Minimum, Vertical Maximum, 

Vertical Minimum, Angle Distance.  

o Parent 1 - specifies the constraint parent point.  

o Parent 2 - displays the second parent point, only when applicable. Applicable to Horizontal 

and Vertical Maximum and Minimum constraints and Vector Offset Constraints.  

o Rollover Values (check box and button) - displays only for a slope constraint. These values 

are displayed in the Parent 2 field since the rollover reference point is the second parent point 

for the slope constraint. Selecting the checkbox activates the Rollover Values button. Selecting 

the button displays the Rollover Point Properties dialog.  

o Value - specifies the horizontal offset for horizontal type constraints. Negative values are to the 

left; positive values are to the right.  

✓ For Vertical type constraints, this is the vertical offset. Negative values are down; 

positive values are up.  

✓ For the Slope constraint, the value is the slope. Negative Values indicate a slope that 

goes from upper left to lower right; positive values indicate a slope from the lower 

right to upper left.  

✓ For the Vector Offset constraint, a negative value is an offset to the left of the vector 

going from the first parent to the second parent; positive values are to the right of the 

vector.  

✓ For the Project to Surface constraint, the value is the name of the surface (Note that a 

blank name will translate to the active surface).  

✓ For the Project to Design constraint, the value is the maximum distance to attempt to 

project to. Negative values imply the projection is to the left; positive values project 

to the right.  

✓ For variable constraints, the value is the difference between two points.  

o Label - displays the optional label for the constraint. Constraints that are labeled can have their 

value changed during design processing. The same label name can be assigned to more than 

one constraint and more than one point.  

o Project to Surface - allows you to limit the projection of a point to the surface: Any Direction 

(no restrictions), Down (point projects down from its original location only), Left (point 

projects to the left from its original location only), Right (point project to the right from it 

original location only), and Up (point projects up from its original location only). The Up and 

Down options are ignored when the other Constraint is Vertical. Similarly, the Left and Right 

options are ignored when the other Contraint is Horizontal.  

o Style Constraint - specifies, when selected, that the style contraint on a point overrides the 

point contraints if a feature or alignment with a matching style is found within a specified 

horizontal range. Activates the Style field which allows you to identify the style.  

o Style Constraint (Type) - allows you to select the constraint type: Horizontal, Vertical, or 

Both.  

o Range - specifies the maximum horizontal distance to search from the point's current location 

to any feature or alignment with the specified style. Only the active surface and active geometry 

project is searched. Negative values cause the search to be to the left; positive values to the 

right. A value of zero causes the search to find the closest instance of the style.  

• Apply - saves changes to the current point.  
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Point Naming is Important 

The Point Name is very important. There’s no standard naming convention for the points but they should be 

named so that each point in a template has a unique name and is easily identifiable by it’s name alone. Consistency 

in point naming is important too. If multiple templates will be applied to a corridor the names of common points 

in the templates should match. 

For example: If you have two templates for a given corridor and on the first template you name the point 

representing the outside edge of pavement on the left roadway LT_PVT_EOP_OUT then you will need to name 

the point the same thing on the second template as well. The will allow the corridor to transition smoothly from 

one template to the next.   

Note Point Name overrides are sometimes necessary when using trigger sets or for template transitions but 
should only be used when necessary. 
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Component Naming 

Individual Component Names also appear in the ensuing model. These components are used for volume 

calculations, so standard naming conventions should be applied to ensure consistent results.  When transitioning 

between two templates (going from a two-lane to a four-lane roadway, for example), the corridor attempts to 

connect component points of the same name to model the transition. 

 

• Consistency is important 

• Component naming is recommended to be consistent with the material type. 

o Used for identifying components 

o Template Transition 
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Point Feature Definitions 

Feature Definitions define the symbology of the point and how it should be displayed in the various views. 

• Points in a template should always have a _pm Feature Definition. 

• _pm indicates that the element is shown in a Proposed Model view. 

• Bottom_pm should be used for points below the finished grade so they can be easily turned off when 

producing 3D Deliverables or creating a finished grade surface. 

 

FDOT’s Feature naming convention mirrors its level naming convention where the name is followed by an 

underscore and then two characters which represent the state .of the element and the view it is displayed in. Since 

the elements in the template will be drawn into the 3D model and then cut into cross sections the features used 

will have a _pm (pointsl) or _px (components) suffix. 

The format of the Feature Name is: feature_sv (max. 18  

Where: (object = element type)_ (s = state)(v = view)  

(S)tate Designations 

p (proposed)  

d (drafting element)  

e (existing 

m (model) 

(V)iew Designations 

p (plan) 

r (profile) 

x (cross section) 

Note Features with no suffix are assumed to be proposed plan elements. 
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CONSTRAINTS ON POINTS 

Point constraints are used to manage the behavior of points in a template. If a point is moved in a template, either 

by the user editing the template or by the application of a horizontal or vertical control during design processing, 

all the points related to the point being moved behave in a rational and predictable manner. 

• A point can have, at most, 2 constraints on it. It is then “fully constrained”. 

• A point with only one constraint is “partially constrained” 

• A point with no constraints is “unconstrained” and the point is shown as a green plus sign 

Note A rule of thumb is to have only one green point per template and all other points are red.  

Point constraints are two-dimensional and one-way. Two-dimensional means that the constraints can only affect 

the points offset and elevation (x and y coordinates in the cross section view). One-way means there is a child-

parent relationship between points. In other words, if point B is constrained by point A, point A is said to be the 

parent of point B and moving point A will affect point B, but you cannot move point B to affect point A. The 

example below shows a sample of this where the light blue arrow indicates a parent/child relationship from point 

A to point B. 

 

• Point Constraints provide structure to the points making up each component. 

• A Constraints basically defines where a point is located, relative to another “Parent” point.  

• Constraints can have different parents. 
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Point Constraints Example 

 

Constraint Types 

There are a variety of constraint types that can be applied to a point’s properties. By applying two of these 

constraints to a point structure defining the points relationship to others is established. 

Corridor Modeling provides a variety of constraint types for roadway template design (Horizontal, Horizontal 

Maximum, Horizontal Minimum, Vertical, Vertical Maximum, Vertical Minimum, Slope, Vector Offset, Project 

to Surface, Project to Design, Angle Distance) as described as defined below: 

• Horizontal  - The child point remains at the given horizontal distance from the parent point. 

• Horizontal Maximum - The child point has two parent points and remains at the given horizontal distance 

from the parent point that is farthest to the right (has the maximum horizontal or X value). 

• Horizontal Minimum - The child point has two parent points and remains at the given horizontal distance 

from the parent point that is farthest to the left (has the minimum horizontal or X value). 

• Vertical - The child point remains at the given vertical distance from the parent point. 

• Vertical Maximum - The child point has two parent points remains at the given vertical distance from the 

parent point that is highest (has the maximum vertical or Y value). 

• Vertical Minimum - The child point has two parent points and remains at the given vertical distance from 

the parent point that is lowest (has the minimum vertical or Y value). 

• Slope - The child point will maintain the given slope from the parent point. Slope constraints can, 

additionally, have rollover values assigned to them. Rollover values are used to set the slope constraint based 

on a high side slope difference and a low side slope difference, and a reference point which defines the 

controlling slope to the parent point. Slope constraints are absolute. Slopes going from lower-left to upper-

right are positive regardless of whether the child point is to the left or right of the parent. 

• Vector Offset - The child point has two parent points and will be projected onto the vector defined by the 

two parents. If the offset is not zero, then the child point will maintain a perpendicular offset from the parent 

vector at the specified offset value. Negative values indicate an offset to the left of the vector defined by the 

parent points. Positive values indicate an offset to the right. 

• Project to Surface - This constraint must be used in conjunction with one of the previously define 

constraints. The other constraint will define the projection direction. The child point will then be projected 

to the surface with the name or parametric label given when the design is processed. If the surface does not 

exist, or no solution is found, then the point will remain where it is placed in the template. 
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• Project to Design - This constraint is similar to the Project to Surface, except that the point is projected to 

the design surface of the template. A projection value is given to indicate whether the projection is to be to 

the left or to the right. The point must also be constrained by one of the previous constraints, excluding the 

Project to Surface, so that a direction for the projection may be determined. A negative value limits the 

projection to the left of 0; a positive value limits the projection to the right. A value of 0 will seek to the left 

and to the right of 0 to project the point. If no solution is found, then the point will remain where it is placed 

in the template. 

• Angle Distance - This constraint takes two parent points, a distance, and an angle. The selected point is then 

fully constrained to the location defined by the first parent, and the angle from the first parent relative to the 

vector defined by the two parent points. This constraint creates a rigid-body rotation. When selected, no other 

constraints types are available. 

Display Constraints 

Switching the Display mode from Components to Constraints will provide a graphical representation of the 

relationships of the points making up the template. 

 

• Components/Constraints - Determines the display mode of the template. If the display components field is 

set, then the components is displayed. If the display constraints field is set, then the point constraints is 

displayed. Points are always displayed. 

• Display Point Names - Specifies point names are displayed (in white), when this option is checked. If the 

point has a Feature Name Override (applied on the Point Properties dialog), it is displayed in red. 

• Display All Components - Specifies all components that are hidden because of their display rules are 

displayed with dashed lines, when this option is checked. For more specific details on defining display rules, 

see the Display Rule help topic. 
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TEMPLATE OPTIONS 

There are some options you will find helpful when working in the Create Template dialog.  

➢ To select the FDOT defined Preferences: 

1. Select Tools > Options from the menu in the Create 
Templates dialog. 

2. Click the Preferences button. 

3. On the Preferences dialog select FDOT then click 

Load and OK. 

4. Click OK to accept the options and Close the dialog. 

 

 

DYNAMIC SETTINGS 

• Tools > Dynamic Settings Command  

• Precision Input Template Points  

• XY= Absolute Coordinates  

• HS= Horizontal Delta Distance and Slope from Last Point Placed  

• DL= Key-in Delta Coordinates from Last Point Placed  

 

The Dynamic Settings dialog is used for precision input of the template components and to assign point names 

and styles when creating components. It also serves as a compass for the location of your cursor with respect to 

the dynamic origin. The dynamic origin can be moved using Set Dynamic Origin, located at the bottom of the 

Dynamic Settings dialog.  

 

The Dynamic Settings dialog is accessed by selecting the menu option Tools > Dynamic Settings or using the 

View Control icons located below the Current Template window.   

The Key-in pull-down specifies the type of key-in to be performed: 

XY = key-in absolute coordinates  

DL = key-in delta coordinates from last point placed (defaults to the dynamic origin if it is the first point of 

a component)  

HS = key-in horizontal delta distance and slope from last point placed  

VS = key-in vertical delta distance and slope from last point placed  

OL = key-in delta coordinates from dynamic origin  

OS = key-in horizontal delta distance and slope from dynamic origin  
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CONSTRUCTION OF TEMPLATES 

   

  

• Components - Building Blocks of Templates 

o Pavement 

o Curbs & Sidewalks 

o Tie Down & End Conditions 

• Allows Drag & Drop 

• Mirror/Reflect and Affixes 

o Components 

o Points (Including Overides) 

o CDR’s 

• Allows for One Component 

The Apply Affixes option can automatically insert a prefix or suffix to point names and components indicating 

the side of the road they were applied to. This is powerful because it allows a single component to be used on 

both sides of the road when used with the Mirror and Reflect placement options. More commonly, you can also 

select the Apply Affixes option on the dynamic settings dialog.  

Note Thought needs to be given as to when this option should be selected. If you select it when creating a 
template and then also have it selected when applying the template you will have nested Affixes. 
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Building a Template from Components 

Drag components from Template Library folders or the Preview Window into the editing window. 
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Merging Points 

Merges overlapping points into a single point. This command is available only if there is more than one point 

under the cursor. You are prompted to select the point to be deleted. Reset to exit the command.  

Points will be merged automatically if a new component is attached directly to an existing component. 

 

Note If the point remains green, you deleted the wrong one. 
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Testing Components 

To test simple components, right-click on the points and select “Move Point” to see how the point constraints 

will react when points start dynamically moving. 

You can test constraints in components by moving points to see results. 
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Inserting Components 

To insert a component between other components in a template you will need to Unmerge the components. 

• Right-click on the component and select Unmerge Component points. 

• Points in the component will be renamed, inserting “Copy of” before the name. This breaks 

other components constraints to the points allowing you to move the component. 

• You can then insert the new component and rename the points of the unmerged components 

before attaching it to the inserted component(s). 

• Previous constraints and attachments will have to be recreated and points should be merged 

after moving components into place. 
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EXERCISES 

OPTIONAL: To prepare your computer for the next set of exercises: 

a) Delete the C:\WorkSets\FDOT\22049555201_CE\ folder.  

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  

c) Extract the CT22049555201_CE_Chapter2.zip file in the C:\WorkSets\FDOT\ folder. 

Exercise 2.1 Creating a Static Template 

In this exercise students will create the backbone of a resurfacing template with widening and new shoulders.  

Note Steps 1-7 (loading Create Template preferences) are only needed if MicroStation was closed and 
restarted.  

1. Open the MODLRD01.dgnMODLRD_TemplateDesign01.dgn file from the current 

worksetC:\WorkSets\FDOT\22049555201_CE\Roadway\  

2. Use the F12 key to launch the Create Template dialog.  

If the ITL is named properly the Project ITL file should already be loaded. 

 

Note The FDOTConnectXX.XX workspace provides some predefined preferences that are useful when 
working with templates. These preferences should be loaded for each new MicroStation session.  

3. Select Tools > Options from the menu. 

4. On the Template Options dialog press the Preferences button. 
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5. On the Preferences dialog, select FDOT from the list and press Load. 

Note You can also double-click FDOT to load the preferences. 

 

6. Press the Close button to return to the Template Options dialog.  

Notice that Left and Right Prefixes have been defined and the Step Options have been set to a 

tenth. The step options allow the components being dragged into the active template to snap 

onto the grid at one tenth of a foot intervals.  

 

7. Press OK to close the Template Options dialog. 

8. Back on the Create Template dialog, double-click on the root folder to expand it and view the contents. 
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9. Right-click on the Corridor Templates folder and select New > Template from the context menu. 

 

10. When prompted, enter the new template name: US98. 

 

11. Select Tools > Dynamic Settings from the menu.  

12. On the Dynamic Settings dialog, key-in CL in the Point Name field and select TemplateMisc_pm 

from the Point Style drop down. 

 

Note Null Point defines default properties for the creation of points.  
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13. Right-click in the working area and select Add New Component > Null Point from the context menu. 

 

14. Place the point above the magenta square at approximately 0’ horizontal and 4’ vertically.  

Note The magenta square indicates the template origin. 

 

15. On the Dynamic Settings dialog, Uncheck the Apply Affixes check box so the prefixes will not be 

applied to point names and components when the next component is placed. 
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16. Navigate to the Components\Pavement\Resurfacing\Overlay folder and select the Pvt Overlay Left 

component. 

 

17. Drag the Pvt Overlay Left component into the working area and place it just below the CL point. 

 

18. Next select the Pvt Overlay Right component and snap it onto the green point of the component placed 

in the previous step.  
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When the green point turns wpresse you can drop the drag and the components will be joined. 

If the point is not wpresse when the component is released the points and components will not 

be merged together. 

 

Note There should only be one green point per template so PAV_EOP_IN should be constrained to the CL 
point. 

19. Right-click on the PVT_EOP_IN point and select Add Constraint > Full from the context menu and 

then select on the CL point to define the point to constrain it to. 
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20. When prompted enter a Horizontal Offset of zero and a Vertical Offset of -1 then press OK. 

 

21. Navigate to the Components\Pavement\Resurfacing (Milling, Overbuild and Overlay) Milling 

folder and select the Pvt Milling Left component. 

22. Drag and drop the Pvt Milling Left component onto the bottom of the left overlay component. 

 

23. Drag and drop the Pvt Milling Right component onto the bottom of the right overlay component. 
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Exercise 2.2 Configure Template to Match Existing Pavement Slopes 

To configure this template match the existing pavement slopes the points on the top of the overlay components 

will need to be modified to target the surface. 

1. Double-click on the point named PVT_EOP_IN to open its properties dialog. 

 

2. Change Constraint 2 Type to Project to Surface 

3. Press Apply and then Close to return to the Create Template dialog. 

 

4. Repeat steps 1-3 for LT_PVT_OLAY_OUT and RT_PVT_OLAY_OUT. 

5. On the Dynamic Settings dialog, Check the Apply Affixes box again to turn the point name prefixes 

back on. 

6. Navigate to the Components\Pavement\Milling folder and select the Travel Lane Left component. 
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7. Drag and drop the Travel Lane Left component onto the top left point of the overlay. Right-click while 

dragging and select Mirror to attach the component to both sides at the same time. 

Note Ctrl + M will also toggle the Mirror function on and off during the drag and drop function. 
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Exercise 2.3 Configure Widening to Match Existing Pavement Slopes 

To make the widening follow the same slope as the existing pavement a Vector-Offset constraint must be applied. 

1. Double-click on the LT_PVT_EOP_OUT point to edit its properties. 

2. Change the Constraint 2 Type to a Vector-Offset 

Parent 1 : PVT_EOP_IN 

Parent 2 : LT_PVT_OLAY_OUT 

 

3. Press Apply and Close to return to the Create Template dialog. 

4. Repeat steps 1-3 for the widening on the right side of the template. 

5. To test the new constraints right-click on the top inside widening point and select Test Point Controls 

> Test Vertical Point Control from the context menu. 

 

6. Move the inside point up and down. This should cause the outside point to move as well to maintain the 

same slope as the resurfacing. 
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7. Right-click to get out of the testing mode. 

8. From the Components\Shoulder folder drag and drop the Shoulder Pavement Left component 

attaching it to the top left point on the widening component. Toggle Off the Mirror option using Ctrl + 

F while dragging. 

 

9. From the Components\Shoulder folder drag and drop the Shoulder Pavement Right component 

attaching it to the top right point on the widening component.  

10. Uncheck Display Point Names to make the template more visible. 
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11. Navigate to the Components\Pavement\Base Extension folder and select the Pavement Base 

Extension Inside Right 

 

Note The component for the base extension is not the same depth as the pavement base so some 
adjustments will need to be made. 

 

12. Right–click on the bottom inside point of the base extension component and select Delete Both 

Constraints from the context menu. 
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13. Right–click on the bottom outside point side point of the base extension component and select Delete 

Both Constraints from the context menu. 

14. Right–click on the bottom inside point of the base extension component and select Move Points from 

the context menu. 

 

15. Snap the point onto the bottom. 
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16. Right click on the point that was just moved and select Merge Points from the context menu. 

  

17. When prompted, select LT_PVT_BASE_BOT_OUT1. This will delete one of the points sharing the 

same location combining that part of the components. 

Note If the remaining point is green then you deleted the wrong one. 

 

18. Double-click on the bottom outside point of the base extension component to edit its properties. 
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19. Edit the points properties as shown below: 

 

 

Note The Vector-Offset constraint will force the bottom of the base extension to maintain the same slope as 
the base even if the slope changes for superelevation. 

20. Repeate steps 11-19 on the right side of the template to apply a base extension. 

21. Once both sides are complete Save the template by selecting File > Save from the menu on the Create 
Template dialog and then Close the Create Template dialog. 
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Exercise 2.4 Creating a Corridor 

In this exercise students will create a corridor using the newly constructed template. To create a corridor you will 

need an alignment, a profile, and a surface. MODLRD01.dgnMODLRD_TEMPLATEDESIGN01.DGN contains 

the elements necessary but the active surface and profile must be defined. 

1. Begin by selecting the green terrain boundary element and then placing the cursor over the boundary 

to get the context menu. Select the second icon, Set as Active Terrain Model. 

 

2. Open a profile view for the baseline of US 98 by selecting the baseline and then placing the cursor over 

the baseline to get the context menu. Select the second icon, Open Profile Model. 

  

3. When prompted on the cursor to select or open a view, select View 3 from the View Toggles toolbar. 

 

4. Then select View 3 to display the existing profile. 
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5. Select the existing profile and then hover the cursor over the profile to get the context menu. Select the 

second icon, Set as Active Profile. 

 

Note With the active profile and active terrain model defined a corridor can be easily created. 

6. From the Ribbon and the Create Group select the New Corridor tool OPENROADS 

MODELING>CORRIDORS>CREATE>New Corridor > Create Corridor. 

 

7. When prompted, select the base line of US 98. 

 

8. Next you will be prompted for a profile. Reset (right-click) to use the active profile for the baseline. 

 

9. Next you will be prompted to name the corridor. Just Data Point (left-click) to accept the default name 

which matches the alignment name. 
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10. Next you will be prompted for the Start Station for the corridor. Make sure “Lock to Start” is NOT 

selected on the Create Template Drop dialog and then snap to the beginning of one of the proposed 

edge of pavement lines and Data Point. 

 

 

11. Next you will be prompted for the End Station. Make sure Lock to End is NOT selected on the Create 
Template Drop dialog and then snap to the end of one of the proposed edge of pavement lines and Data 

Point. 

 

12. When prompted for the drop interval key-in 10, press Enter to lock the value, and then Data Point to 

accept. 
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13. Accept the default value of Zero for Minimum Transition Before Drop by using the Data Point to 

accept. 

 

14. Accept the default value of Zero for Minimum Transition After Drop by using the Data Point to accept. 

 

15. Enter an optional description or leave it blank and Data Point to accept completing the corridor creation 

process. 
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3 ADDING END CONDITIONS 

 

END CONDITION PROPERTIES 

End Conditions are different than simple, constrained, unconstrained, null point, and overlay/stripping 

components because they have the ability to target a surface or element with specific Features.  End Condition 

Properties specify properties only visible for End Condition components.  

 

• Target Type - specifies the type of target the End Condition is seeking. Targets include:  

o Surface - Seeks a surface  

o Elevation - Seeks a particular elevation  

o Feature XY - Seeks the horizontal location of a feature of a particular surface.  

o Feature Elevation - Seeks the vertical location of a feature of a particular surface.  

o Feature XYZ - Seeks the location of a feature of a particular surface. Overrides the slope 

constraint of the End Condition segment to seek the feature.  

o Alignment XY - Seeks the horizontal location of a particular alignment.  

o Alignment Elevation - Seeks the vertical location of a particular vertical alignment or, in the 

absence of a vertical alignment, uses horizontal geometry elevation.  

o Alignment XYZ - Seeks the location of a particular alignment. Overrides the slope constraint of 

the End Condition segment to seek the feature.  
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• Surface/Feature/Alignment - specifies the surface associated with the target type. Depending on the target 

type, Surface, Alignment, or Surface and Feature options are available that allow you to set the target 

information. If the target type is Elevation, then no field is displayed here.  

Note If the target type is Surface or one of the Feature target types, and you do not specify a surface name; 
then, the surface during the Roadway Designer session will be the active surface. See the Roadway 
Designer command for more information on Target Aliases.  

• Priority - specifies the order in which  End Conditions are attempted in seeking a solution. Where more than 

one End Condition starts at the same point, this value determines the order in which End Conditions are 

attempted to find a solution. Lower numbers are attempted first.  

• Benching Checkbox - indicates, when On, the set of segments of the End Condition are repeated until a 

solution is found.  

• Benching Count - indicates the maximum number of times that benching should occur. If this value is 0, 

then the repeat count is unlimited, and the benching End Condition must find its target for it to be valid. If 

any other number is entered, then if the benching is repeated for the specified count and if the target is not 

reached, the benching End Condition will still be considered successful if an End Condition attached to the 

end of the benching End Condition is successful.  

• From Datum - indicates, when On, the benching will use a Datum Elevation and Step Elevation to set the 

benching rather than using the End Condition segments as they are defined.  

• Datum Elevation - specifies the elevation that represents the basis for the Step Elevation. Datum + Current 

Bench Elevation = n * Step Elevation.  

• Step Elevation - specifies the increment for benching when a datum is being used. Each bench elevation is 

always located at the end of the first segment (or the second point) of the benching End Condition.  

• Horizontal Offset - specifies a horizontal offset from the target. This option only applies if the target is a 

horizontal target or has a horizontal aspect.  

• Vertical Offset - specifies a vertical offset from the target. Applies only if the target is a vertical target or 

has a vertical aspect. For an elevation target, specify the elevation here.  

• Rounding Length - specifies the length used to round the End Condition. When this value is something other 

than 0.0, 4 additional points are added to the end of the End Condition using a parabolic formula to smooth 

out the transition of the intersection of the End Condition with the surface. This rounding effect is only 

applied when the target is a surface or an elevation. Any other End Conditions attached to the end of this one 

is attached to the end of the rounded section.  

TESTING END CONDITIONS 

End Conditions solutions and overly/stripping components can be tested to see how they react to the surface or 

other features and tests component display rule true or false flags from the Test End Conditions dialog. 
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• <View Window> - displays the current template. Non-solved end conditions, and their child components, 

are displayed in dashed lines. Normal components and solved end conditions are displayed as solid lines. The 

display has all the standard windowing commands and scrollbars. 

• Close - dismisses the dialog. 

• Failure Report - activates the Results dialog. When you fail to get a solution on one or both sides, the results 

show which components failed and which end condition start points were not solved. 

• Check Priorities - tests the template for priority conflicts. When conflicts exist, a message is displayed 

indicating there are end conditions that start from the same points and have the same priorities. The End 

Condition Priority Conflicts dialog is displayed. If no conflicts exist, a message box indicating no conflicts 

is displayed. 

• Check Duplicates - checks for duplicate feature and component names for the given solution. If duplicate 

feature or component names are found, the Duplicate Feature Name List dialog is displayed. If no duplicates 

are found, a message to this effect is displayed. 

• Help - displays help. 

• Available Targets - lists all of the targets applicable to the current template. You can select the desired target 

and draw it in the display. 

• Use Surface Slope - specifies the slope of the surface that is being placed. This is useful in certain instances 

where an end condition intersects a surface more than once, such as a ditch profile. 

• Draw - draws the selected target. Surfaces and elevations are drawn as horizontal lines. Features and 

alignments are drawn as + marks. As you draw a target, the display dynamically updates to show the 

solution(s). 

• Reset - clears all the drawn targets. 

• Display Rules - list the display rules for the current template. Left-click over a value to toggle between True 

and False. Press the Reset button to restore the original Display Rules values. 

EXERCISES 

OPTIONAL: To prepare your computer for the next set of exercises: 

a) Delete the C:\WorkSets\FDOT\22049555201_CE\ folder.  

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  

c) Extract the CT22049555201_CE_Chapter3.zip file in the C:\WorkSets\FDOT\ folder. 

  

mk:@MSITStore:c:/progra~2/common~1/bentle~1/roadwa~1/0811~1.07/1033/geopak_corridormodeling.chm::/Create_Template/end_condition_priority_conflicts.htm
mk:@MSITStore:c:/progra~2/common~1/bentle~1/roadwa~1/0811~1.07/1033/geopak_corridormodeling.chm::/Create_Template/end_condition_priority_conflicts.htm
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Exercise 3.1 Add End Conditions 

In this exercise End Condition components will be added to the template so cut and fill lines will tie the proposed 

template to the existing ground. 

Note Steps 1-7 (loading Create Template preferences) are only needed if MicroStation was closed and 
restarted. 

1. Open the MODLRD_TemplateDesign01.dgnMODLRD_TemplateDesign01.dgn file from the current 

workset. 

2. Use the F12 key to launch the Create Template dialog. If the ITL is named properly the Project ITL 

file should already be loaded. 

 

Note The FDOT workspace provides some predefined preferences that are useful when working with 
templates. These preferences should be loaded for each new MicroStation session.  

3. Select Tools > Options from the menu. 

4. On the Template Options dialog press the Preferences button. 
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5. On the Preferences dialog, select FDOT from the list and press Load. 

Note You can also double-click FDOT to load the preferences. 

 

6. Press the Close button to return to the Template Options dialog.  

Note Notice that Left and Right Prefixes have been defined and the Step Options have been set to a tenth. 
The step options allow the components being dragged into the active template to snap onto the grid at 
one tenth of a foot intervals.  

 

7. Press OK to close the Template Options dialog. 

Note Before making major edits, it is recommended to make a copy in case you want to go back to a previous 
state. 
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8. From the Create Template dialog, navigate to the Corridor Templates folder and double-click on the 

US98 template to make it active. 

9. Right-click on the US98 template and select Copy from the context menu. 

  

10. Right-click on the Corridor Templates folder and select Paste from the context menu. A copy of the 

template will be made with a “1” appended to the name. 
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11. Toggle On the Dynamic Settings dialog box using the icon in the view controls. 

 

12. Uncheck the Display Point Names box. 

13. Navigate to the End Conditions > Parts folder, then drag and drop the 6:1 FILL TO 5’ component on 

the unpaved shoulder on the right side of the template. 
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14. Drag and drop the 6:1CUT component on the same unpaved shoulder on the right side of the template. 

 

15. Double-click on the right fill line just placed to review the Component Properties. 

Name:   Begins with RT_ 

Name Override:  Begins with RT_ 

Target Type:  Terrain Model 

Terrain Model:  <Active> 

Priority:  1 

16. Press Close to return to the Create Template dialog. 

17. Double-click on the right cut line to review the Component Properties. Change the Priority to 2 and 

press Apply. 

 

Name:   Begins with RT_ 

Name Override:  Begins with RT_ 

Target Type:  Terrain Model 

Terrain Model:  <Active> 

Priority:  2 

18. Press Close to return to the Create Template dialog. 
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Exercise 3.2 Test End Conditions 

The Create Template dialog provides a tool to test End Conditions before applying them to a corridor to make 

sure you get the expected results.  

1. From the  Create Template dialog click the Test button. 

2. On the Test End Conditions dialog, select <Active>-Terrain Model from the Available Targets list 

and move the cursor above and below the template to see how the End Conditions react. 

 

3. Press Close to return to the Create Template dialog. 

4. Navigate to the Components\Ditches folder, then drag and drop the Common Ditch Left component 

on the left shoulder component. 

 

5.  Select File > Save from the Create Template dialog. 

6. Press the Close button to return to MicroStation. 
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Exercise 3.3 Synchronized Template Changes in the Corridor 

To see the changes in the model the changes to the template will need to be synchronized in the corridor. 

1.  From the Corridors Tab then the Miscellaneous Group select the Synchronize Template Tool. 

OPENROADS MODELING>CORRIDORS>MISCELLANEOUS>Synchronize Template 

 

2. When prompted on the cursor to Locate Template Drop, select the corridor boundary. 

 

3. The corridor will process and you can evaluate the changes to the model. 
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4 HORIZONTAL FEATURE CONSTRAINTS 

HIERARCHY OF CONSTRAINTS 

A points location can be overridden in various ways to produce variable results from a single template. From 

lowest priority to highest: 

• Point Constraints – Each point can have up to two constraints that define its location in relation to other 

points.  

• Horizontal Feature Constraint – Each point can have a single Horizontal Feature Constraint that will allow 

a point to override the location defined by the Point Constraints. 

• Parametric Constraints – Can be created to override Point Constraints within a defined station range. This 

will override Point Constraints and Horizontal Feature Constraints. 

• Point Controls – A point control can be applied to any point on a template and forces the point to follow a 

particular geometric element in the file. This will override Parametric Constraints, Point Constraints and 

Horizontal Feature Constraints. 

• Superelevation – A specialized point control that is created and applied using the superelevation tools. This 

will override all other constraints and controls. 

HORIZONTAL FEATURE CONSTRAINT 

Horizontal Feature Constraints provide the ability to override a points location when an element with the assigned 

Feature is found within the search Range, the maximum horizontal distance to search from the point's current 

location.  The search distances in the Range field are based on the offset defined in the template, not where the 

parent point may be when applied to a corridor.  Only elements that have been added to the corridor as “External 

References” are searched.  

Note Regarding search range, negative values will search left.  Positive values to the right.  A value of zero 
causes the search to find the closest instance of the Feature. 
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➢ How to make a milling component follow a milling limits line is: 

1. Draw the milling limit lines in the plan view using the Feature “Pavement Milling ML”. 

2. Create a template assigning the Feature “Pavement Milling ML” as a Horizontal Feature Constraint on 

the outside points of the overlay component. 

3. Create a corridor using template 

 

 

 

 

 

 

4. Add milling limit lines in the plan view as Corridor References using the “Add Corridor Reference” 

from the Corridors Tab from the Miscellaneous Group the Corridor References Tool 

selection.OPENROADS MODELING>CORRIDORS>MISCELLANEOUS>Corridor Reference>Add 

Corridor Reference 

 

Horizontal Feature Constraints are the most common way to make a point follow a plan element like an edge of 

pavement as its horizontal location from the centerline varies.   

 

In the example above the horizontal constraint (Constraint 1) defines the width of the pavement but with the 

Horizontal Feature Constraint defined it will follow the EOP line as it transitions. 

1. Apply “Feature” to the plan element defining its symbology.  

2. Edit the template point you want to follow the plan element and select the Horizontal Feature Constraint 

to match the Feature applied to the plan element. 

3. In the point properties define the Range or distance you expect the template to encounter the plan 

element. 

4.  When the corridor is created the plan element will need to be added as a Corridor Reference in order for 

the template to see it. 

The Range defines the distance from the points location it will search for a line with the Feature “Pavement 

Asphalt EOPA”. If found the constraints will be overridden to that elements horizontal offset. 
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The Range or search distance begins from the points horizontal location in the template. The template will search 

from that location the distance defined in the Range property. Positive distances to the right and negative distances 

are to the left. This creates an envelope in which an element with the defined feature can be found. This keeps 

the system from finding like elements on the other side of the road. 

 

The animation in this slide shows what happens to the edge of pavement when it is located within the search 

Range and how it defaults back to the defined point constraints when the edge of pavement falls outside the 

search Range. 

EXERCISES 

OPTIONAL: To prepare your computer for the next set of exercises: 

a) Delete the C:\WorkSets\FDOT\22049555201_CE\ folder.  

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  

c) Extract the CT22049555201_CE_Chapter4.zip file in the C:\WorkSets\FDOT\ folder. 
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Exercise 4.1 Horizontal Feature Constraints 

In this exercise Horizontal Feature Constraints will be applied to the corridor making it more flexible. Horizontal 

Feature Constraints are the first level of point overrides and provides the template with the flexibility to follow 

an edge of pavement of milling limits line. 

Note Steps 1-7 (loading Create Template preferences) are only needed if MicroStation was closed and 
restarted. 

1. Open the MODLRD_TemplateDesign01.dgnMODLRD_TemplateDesign01.dgn file from the current 

workset of 22049555201_CE.  

2. Use the F12 key to launch the Create Template dialog. If the ITL is named properly the Project ITL 

file should already be loaded. 

 

Note The FDOTConnectXX.XX workspace provides some predefined preferences that are useful when 
working with templates. These preferences should be loaded for each new MicroStation session.  

3. Select Tools > Options from the menu. 

4. On the Template Options dialog press the Preferences button. 
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5. On the Preferences dialog, select FDOT from the list and press Load. 

Note You can also double-click FDOT to load the preferences. 

 

6. Press the Close button to return to the Template Options dialog.  

Note Notice that Left and Right Prefixes have been defined and the Step Options have been set to a tenth. 
The step options allow the components being dragged into the active template to snap onto the grid at 
one tenth of a foot intervals.  

 

7. Press OK to close the Template Options dialog. 
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8. Navigate to the Corridor Templates folder and double-click on the US98 template to make it active. 

9. Double-click on the LT_PVT_OLAY_OUT point to review its properties. 

Note Notice the default Horizontal value for this point is -12 but a Horizontal Feature Constraint is applied with 
the Feature Pavement Milling ML and a Range of -50’  

 

10. Close the Point Properties and Create Template dialogs. 
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Exercise 4.2 Adding Corridor References 

In order for a corridor to apply Horizontal Feature Constraints the horizontal geometry must be added to the 

corridor as external references. Without this the Horizontal Feature Constraints are ignored and the components 

are drawn at the horizontal Value. 

1. From the Ribbon selectAdd Corridor Reference OPENROADS 

MODELING>CORRIDORS>MISCELLANEOUS>CORRIDOR REFERENCES>Add Corridor 

Reference 

 

2. When prompted, left click on the corridor boundary to locate it. 

 

3. Next you will be prompted to “Locate First Reference”. Begin left-clicking all of the Milling Limits 

lines within the range of the corridor.  

4. When all of the Milling Limits lines are selected right-click (Reset) to complete the process.  

 

Note The corridor will reprocess and the shape of the model will begin to change. 
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5. Select F6 to get out of the command and start the element selection tool. 

6. Make a MicroStation selection set of all the edge of pavement lines within the range of the corridor. 

7. From the Ribbon select Add Corridor Reference  

OPENROADS MODELING>CORRIDORS>MISCELLANEOUS>CORRIDOR REFERENCES>Add 

Corridor Reference 

8.  

9. When prompted, left-click on the corridor boundary to locate it. 

 

10. When prompted Data Point (left-click) to apply selected elements as corridor references.  
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Note The corridor will process and the model will further change shapes. 

Exercise 4.3 Set Corridor Design Stage 

This is a small corridor and changes in the horizontal geometry are occurring over short distances. To better see 

how the Feature Constraints are being applied the corridor Design Stage can be modified. 

1. Select one of the corridor handles sticking out from the boundary and then hover over it to get the 

context menu. Select the first icon on the menu, Properties. 

 

2. Using the drop-down arrow, change the Design Stage to “3 FINAL”. 

 

Note The corridor will reprocess again, providing further detail. 
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3. With the overlay component selected in the model you can see where the milling lines are now being 

located by the template in most locations.  
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4. With the widening components selected you can identify locations at the beginning and ending of the 

corridor where the edges of pavement are not being located correctly. 
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Exercise 4.4 Search Range 

Ranges are a common issue when using Horizontal Feature Constraints. Since the beginning the search range is 

based on the points location in the template instead of the its relative position to other points when applied to the 

corridor.  

 

1. Start the Measure Distance command from the Ribbon The measure Distacne Tool can be found on 

the Drawing Tab and measure Group 

OPENROADS MODELING>DRAWING>MEASURE>Measure Distance 

 

 

2. On the Measure Distance dialog select the Perpendicular Method.  
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Exercise 4.5 Troubleshooting Ranges 

Use the Measure Distance tool to identify the narrowest distance from the baseline to the milling limits and from 

the baseline to the proposed edge of pavement for the widening.  

 

Note When working with multilane facilities, divide highways, interchanges, or the likes you will also want to 
identify the widest point for each search so you can limit the search range and not accidently locate a 
matching feature from another lane.  

1. Select F12 to open the Create Template dialog. 

2. Double-click on the left milling limits point (LT_PVT_OLAY_OUT) to edit its properties. 

3. Change the value for the Horizontal constraint to be -6, then press Apply and Close. 

  

4. Double-click on the left outside widening point (LT_PVT_EOP_OUT) to edit its properties. 

5. Change the value for the Horizontal constraint to be -.1, then press Apply and Close. 
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6. Repeat Steps 2-5 for the right side of the template. 

7. Select File > Save from the Create Template dialog. 

8. Press the Close button to return to MicroStation. 
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Exercise 4.6 Synchronize Template Changes with the Corridor 

To see the changes in the model the changes to the template will need to be synchronized in the corridor. 

1.  From the Ribbon select the Synchronize Template Tool. This can be found on the Corridors Tab then 

the Miscellaneous Group.  OPENROADS 

MODELING>CORRIDORS>MISCELLANEOUS>Synchronize Template 

 

 

2. When prompted on the cursor to Locate Template Drop, select the corridor boundary. 

 

Note The corridor will process and you can evaluate the changes to the model. 
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5 SWITCHES 

INTRODUCTION 

In this exercise Switches will be used to turn off the display of components through areas like intersections or 

drives where detail modeling techniques will be used.  Turning of the display of components in these areas is far 

more efficient when processing a corridor than clipping references. 

PARENT \ CHILD RELATIONSHIPS 

 

Defining a Parent\Child relationship between related components makes it much easier to manage their display 

in variable conditions. 

• End Conditions, Switches, and Display Rules effect the parent effect children. 

• Deleting a parent component deletes all children. 

• Component Relationships can be viewed as a hierarchical tree using the Active Template tab on the 

Create Template dialog. 

• Relationships can be created by dragging and dropping on the Active Template tab. 

A well structured template will have parent\child relationships defined between components that go together. For 

example:  the base component is a child of the pavement component. This becomes more important as variable 

conditions and display rules are added to the template. When properly structured you can apply the display rule 

to the parent component only instead of modifying each subcomponent individually.  
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ACTIVE TEMPLATE VIEW 

 

The Active Template view allows you to see and modify properties for all parts of the active template. 

• Points - List of all points. Highlights the selected point in the template. 

• Components – List of Components in hierarchical tree. 

• End Condition Branches – List of end conditions in hierarchical tree. 

• Display Rules – List of all Display Rules . Highlights the selected Display Rules in the 

template. 

• Parametric Constraints – List of all Labels defined in the active template. 

• Alternate Surfaces –  List of all Alternate Surfaces and their components. 

• Point Feature Definitions – List of Points categorized by Feature. 

• Component Feature Definitions - List of Components categorized by Feature. 



SWITCHES - Synchronize Template Changes with the Corridor ______________________________________________ Chapter 5 

Comprehensive Template Design ©2018 FDOT 5-3 

ORGANIZING \ STACKING CONDITIONS 

 

• Instead of stacking the End Conditions on top of each other, they can be offset. 

• All End Conditions can be attached using Horizontal and Vertical Constraints 

•  Parametric Constraints can be used to override the Horizontal and Vertical Constraints to zero 

values when applied to the corridor. 

As more conditional components are added to make the template more dynamic, it gets very busy and hard to 

manage if all the components are on top of each other. We recommend placing the conditional trigger set above 

or below the connection point and then use parametric constraints to move the trigger sets into place when applied 

to a corridor. 
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SWITCHES 

     

Switches are often used to switch the display of components On or Off.  If a component or template has a point 

with the word 'SWITCH' in the point name, then the 'SWITCH' Points Horizontal value can be modified to 

change the components that are displayed. 

Switches are basically a series of if statements with a display rule added to each. Typically the ‘if statement’ 

measures the distance between two points and assigns a display rule to activate when the distance equals a specific 

number. This way each possibility can only occur in one condition. 

✓ If the distance between LT_Switch and LT_Switch1 is 1’ display a Type F Curb and Gutter 

✓ If the distance between LT_Switch and LT_Switch1 is 2’ display a Type E Curb and Gutter 

✓ If the distance between LT_Switch and LT_Switch1 is 3’ display a Drop Curb 

Display Rules are applied to each of the possible conditions so as the distance changes one condition is turned 

Off and another is turned On. 
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DISPLAY RULES 

 

 

A Display Rule is a condition statement that can be assigned to a component. Once assigned, the component can 

only be displayed when the conditional statement is true.  Each interval is evaluated by the Display Rule and the 

components and all the children are affected. 

Note Display rules are not applied in transitions. Transitions see only what is displayed at the beginning and 
end of the transition at the time the transition is created, and use that information to create the transition. 
Only components that are displayed are included in the transition.  
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Creating Display Rules 

To create a Display Rule click the Edit button on the parent Component Properties dialog.  This opens the 

Component Display Conditional Expressions dialog that allows you to build a Conditional Expression by 

evaluating and selecting from a list of previously created Display Rules.  

If there are no Display Rules listed yet, <OR> if the Display Rule needed does not appear in the list, click the 

Add button on the bottom of the dialog.  This opens the Display Rule dialog that allows you to enter a name and 

a description to create a new Display Rule.  

• Name - displays the rule name. In edit mode, this field is read only. However, you can rename the 

rule from the Create Template > Active Template tab.  

Note Display Rules can not contain a left or right parenthesis, "(" or ")", or any of the following phrases in the 
rule name: AND, OR, NOT.  

• Description - specifies a description for the display rule.  

• Type - displays the rule type.  

Then you can choose from a list of Display Rule Types and define the properties associated with the Type. 

• Horizontal  -specifies the difference between the x values of the point (pt1.x - pt2.x).  

• Absolute Horizontal - specifies ABS ( pt1.x - pt2.x ).  

• Vertical - specifies pt1.y - pt2.y.  

• Absolute Vertical - specifies ABS ( pt1.y - pt2.y ).  

• Slope - specifies the slope from pt1 to pt2.  

• Absolute Slope - specifies the absolute value of the slope from pt1 to pt2.  

• Component is Displayed - list existing components. The rule is evaluated to True if the indicated 

component is displayed.  

• Between (1st point) - specifies the first point for the conditional test. Does not apply for type 

Component is Displayed type.  

• And (2nd point) - specifies the second point for the conditional test. Does not apply for type 

Component is Displayed.  

• (Expression) - specifies the conditional expression (<, <=, =, >=, >).  

• (Value field) - specifies the value that the expression is evaluated against.  
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DEFINING PARAMETRIC CONSTRAINTS (LABELS) 

 

Parametric Constraints use the Label property defined on a points constraints to override the defined value over 

a specified station range.  Labels for common constraints should be the same. 

✓ Pavement Depth 

✓ Lane Width 

✓ Switches 

Parametric Constraints 

Parametric Constraints allows you to reset the values for all points using the selected label at once.  

For example, Pavement Thickness could be defined on the inside and outside of every pavement component ion 

the template. For a six lane section with cross overs Pavement Thickness could be defined 14 times or more in a 

single template. If the pavement design changes you can quickly reset all of those values at once without having 

to edit each point’s properties to redefine the vertical constraint. 

➢ To edit Parametric Constraints on the Create Template dialog: 

1. Select the “Active Template” tab. 

2. Expand the Parametric Constraints folder 

3. Double-click the Label name 

4. Enter a value in the “Edit Default Parametric Value” dialog  

5. Click OK. 
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Applying Parametric Constraints 

Parametric constraints can also be used to change one or more labeled constraint values of a template while the 

template is being processed through the corridor.. Click Tools > Parametric Constraints. This allows you to use 

only one template to handle a number of different conditions. The process involves two steps.  

1. Add labels to the constraints that are to be controlled. This is done in the Create Template command.  

2. Specify the new constraint value(s) and the station range over which they will be applied on the corridor. 

This is most commonly used to change pavement thickness over a specified range.  

All constraints can contain parametric labels.  

For example, if the milling depth changes in the middle of the project you don’t need to do multiple template 

drops. You can do a single template drop and add a Parametric Constraint each time the milling thickness changes. 

➢ To apply a parametric Constraint to a corridor  

1. Select Create Parametric Constraint, this tool can be found on the Corridor Tab, Edits Group the Edits Drop 

down  

OPENROADS MODELING>CORRIDORS>EDITS>EDITS>Create Parametric Constraint 

  

 

2. After selecting the corridor you will be prompted for: 

o Start station 

o Stop station 

o Constraint Label 

o Start Value 

o End Value 

EXERCISES 

OPTIONAL: To prepare your computer for the next set of exercises: 

a) Delete the C:\WorkSets\FDOT\22049555201_CE\ folder.  

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  
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c) Extract the CT22049555201_CE_Chapter5.zip file in the C:\WorkSets\FDOT\ folder. 

Exercise 5.1 Setting Preferences (Optional) 

Note Steps 1-7 (loading Create Template preferences) are only needed if MicroStation was closed and 
restarted. 

1. Open the MODLRD_TemplateDesign01.dgnMODLRD_TemplateDesign01.dgn file of the current 

workset C:\WorkSets\FDOT\22049555201_CE\Roadway folder 

2. Use the F12 key to launch the Create Template dialog. If the ITL is named properly the Project ITL 

file should already be loaded. 

 

Note The FDOTConnectXX.XX workspace provides some predefined preferences that are useful when 
working with templates. These preferences should be loaded for each new MicroStation session.  

3. Select Tools > Options from the menu. 

4. On the Template Options dialog press the Preferences button. 
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5. On the Preferences dialog, select FDOT from the list and press Load. 

Note You can also double-click FDOT to load the preferences. 

 

6. Press the Close button to return to the Template Options dialog.  

Note Notice that Left and Right Prefixes have been defined and the Step Options have been set to a tenth. 
The step options allow the components being dragged into the active template to snap onto the grid at 
one tenth of a foot intervals.  

 

7. Press OK to close the Template Options dialog 
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Exercise 5.2 Parent \ Child Relationships 

It is best to create parent \ child relationships between components so Display Rules can be applied to a single 

component instead of all components outside that location. 

Note Before making major edits, it is recommended to make a copy in case you want to go back to a previous 
state. 

1. Navigate to the Corridor Templates folder and double-click on the US98 template to active. 

2. Right-click on the US98 template and select Copy from the Context menu. 

  

3. Right-click on the Corridor Templates folder and select Paste from the Context menu. A copy of the 

template will be made with a ‘1’ appended to the name. 
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4. Double-click on the ditch component. 

 

5. The Component Selection dialog opens indicating there are multiple components at that location. 

Select the top component. 

 

6. To assign a Parent Component select a component name from the drop-down list or select the parent 

dynamically. Select the dynamic selection tool and then select the unpaved shoulder component. 
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7. After selecting the unpaved shoulder press Apply and Close to return to the Create Template dialog. 

8. Double-click on the ditch component again; this time selecting the bottom component when prompted. 

9. Make the unpaved shoulder the parent component of the second ditch component by repeating steps 3 

and 4. 

10. Check the Display All Components option in the Create Template Display settings. 

 

11. Double-click on the V ditch component. 

12. Make the unpaved shoulder the parent component of the V ditch component by repeating steps 3 and 

4. 

13. Uncheck the Display All Components option in the Create Template Display settings. 

14. Zoom in to the area where paved shoulder component attaches to the widening component. 

15. Double-click on the paved shoulder component and use the dynamic selection tool to select the 

widening component (LT_Pvt) as the Parent Component. 
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16. Press Apply and Close to return to the Create Template dialog. 

17. Double-click on the base extension for the left side and use the Parent Component drop-down list to 

select LT_Pvt. 

 

18. Press Apply and Close to return to the Create Template dialog. 

19. Double-click on the left pavement base component and use the Parent Component drop-down list to 

select LT_Pvt. 



SWITCHES - Parent \ Child Relationships _______________________________________________________________ Chapter 5 

Comprehensive Template Design ©2018 FDOT 5-15 

 

20. Press Apply and Close to return to the Create Template dialog. 
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Exercise 5.3 Add Switches and Display Rules 

The CIVIL FDOT ORD.ITL provides a prebuilt “Switches” component that contains the controlling points and 

related display rules for 5 conditions on each side of the template. 

Note When making major edits it is recommended to make a copy in case you want to go back. 

1. Navigate to the Corridor Templates folder and double-click on the US98 template to active. 

2. Right-click on the US98 template and select Copy from the context menu. 

  

3. Right-click on the Corridor Templates folder and select Paste from the context menu. A copy of the 

template will be made with a ‘2’ appended to the name. 
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4. Open the Dynamic Settings dialog if necessary (Tools > Dynamic Settings) and ensure the Apply 

Affixes box is unchecked. 

 

5. Navigate to the Components\Null folder and select the SWITCHES component. 

6. Drag it onto the active template and drop it onto the green CL point. 

 

7. Double-click on the widening component to edit its properties. 

 

8. On the Component Properties dialog, press the Display Rules Edit button. 
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9. On the Component Display Conditional Expression dialog select the rule in the list then press the 

NOT button and the Selected Rule button. 

 

10. This builds the statement “NOT LT_SWITCH1”. Press OK to apply this Display Rule. 
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Note Back on the Component Properties dialog you will see that the Display Rules field has been populated. 

11. Press Apply and then Close to return to the Create Template dialog. 

 

12. Double-click on the inside point of the left switch component (LT_SWITCH1). 
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13. Set the Horizontal Value to 1 and press Apply. Notice how everything to the left of the resurfacing is 

turned Off. 

 

Note Take note that a Label named LT_SWITCH has been applied to the Horizontal constraint. This Label 
can be used to change the Horizontal Value through user defined station ranges by applying Parametric 
Constraints to the corridor. 

14. Set the Horizontal Value back to 1.5 then press Apply and Close. 

15. On the Create Template dialog select File > Save from the menu and then Close to return to 

MicroStation. 
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Exercise 5.4 Apply Parametric Constraints 

Parametric Constraints can be applied to a corridor to override the value of point constraints if a label has been 

defined in the point properties. This exercise will use this functionality to turn off the display of components 

through the intersection. 

1. To Sychronize Template use the tool that can be found on Corridors Tab of r\the Ribbon on the 

Miscellaneous Group then Synchronize Template  OPENROADS 

MODELING>CORRIDORS>MISCELLANEOUS>Synchronize Template 

 

2. From the Ribbon on the Corridor Tab then the Edit Group, select the Edits Drop down to select the 

Create Parametric Constraint tool OPENROADS MODELING>EDIT>EDIT>Create Parametric 

Constraint 

 

3. Ensure that the start and end values are not locked in on the Create Parametric Constraint dialog and 

select the corridor boundary to Locate Corridor as prompted on cursor. 

 

4. When prompted for the Start Station use AccuSnap to snap to the first return of the SR 61 intersection 

and then Data Point (left-click) to Accept. 
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5. When prompted for the End Station use AccuSnap to snap to the opposite return of the SR 61 

intersection and then Data Point (left-click) to Accept. 

 

6. When prompted for the Constraint Label choose LT_SWITCH from the drop-down on the Create 
Parametric Constraint dialog  

<OR> use the up and down arrows on the key board to select LT_SWITCH from the cursor and then 

Data Point (left-click) to Accept. 
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7. When prompted for the Start Value key in 1 and press Enter then Data Point (left-click) to Accept. 

 

8. When prompted for the Stop Value key in 1 and press Enter then Data Point (left-click) to Accept. 

 

Note Notice how, using the Parametric Constraint to make the statement in display rule true, turns off the 
components through the station range defined. 
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9. Press F6 on the key board to get out of the current command and return to Element Selection. 

10. Select one of the returns and change the radius to see how that effects the model. By snapping to the 

returns for start and stop locations the model will automatically heal itself if changes to geometry are 

made. 

11. Use Ctrl+Z to Undo the change to the return. 
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6 TRIGGER LINES 

INTRODUCTION 

 

• Make Trigger Line the Parent of related components.  

• An End Condition (Trigger Line) is configured to search for a specific Target. 

• When Target is located, all related components of a Trigger Line will display, but not displayed 

if Target is not found. 

• Exclude Trigger Lines from triangulation. 

“Trigger Line” is a term for the use of End Conditions as display controls. Trigger Lines are used to make a 

template dynamic by including multiple possibilities in a single template.  This reduces the number of template 

drops required along a corridor and is especially useful in urban areas where conditions change frequently. 

Trigger Lines are End Condition components used to search for “Corridor References” with a specific Feature.  

End Conditions are only displayed when the defined condition is true.  All child components of an End Condition 

are displayed when the End Condition is True. 
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Creating Trigger Lines 

   

 

To create a Trigger Line you can right-click in the editor and select “Add New Component > End Condition” and 

draw a line horizontally from where you want to begin the search to a point in the direction of the search. You 

could then set the Target Type to “Feature Definition Horizontal”  and the choose the desired target Feature 

Definition. 

➢ To Use the Predefined Standard Search Line (Trigger) 

A default Trigger Line is provided in the CIVIL FDOT ORD.ITL file.  It is named “Standard Search Line 

(Trigger)” and can be found in the End Conditions folder.: 

1. Drag the Standard Search Line (Trigger) component into your template. 

2. Set the Target Feature in the trigger line properties. 

3. Edit the component to be controlled by the trigger line and make the trigger line the parent component.  

EXERCISES 

In this exercise Trigger Lines are used to change from a paved shoulder to a curbed section through the turn lane. 

OPTIONAL: To prepare your computer for the next set of exercises: 

a) Delete the C:\WorkSets\FDOT\22049555201_CE\ folder.  

b) Open the ComprehensiveTemplateDesign folder on the desktop and expand the DataSets folder.  

c) Extract the CT22049555201_CE_Chapter6.zip file in the C:\WorkSets\FDOT\ folder. 

d) Note the paved shoulder on US 98 has been changed to Type F Curb and Gutter along the right turn lane. 
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Exercise 6.1 Setting Preferences (Optional) 

Note Steps 1-7 (loading Create Template preferences) are only needed if MicroStation was closed and 
restarted. 

1. Open the MODLRD_TemplateDesign01.dgnMODLRD_TemplateDesign01.dgn file of the current 

workset. C:\WorkSets\FDOT\22049555201\Roadway\ folder  

2. Use the F12 key to launch the Create Template dialog. If the ITL is named properly the Project ITL 

file should already be loaded. 

 

Note The FDOTConnectXX.XX workspace provides some predefined preferences that are useful when 
working with templates. These preferences should be loaded for each new MicroStation session.  

3. Select Tools > Options from the menu. 

4. On the Template Options dialog press the Preferences 

button. 

5. On the Preferences dialog, select FDOT from the list and 

press Load. 

Note You can also double-click FDOT to load the 
preferences. 

 

6. Press the Close button to return to the Template 
Options dialog.  

Note Notice that Left and Right Prefixes have been defined 
and the Step Options have been set to a tenth. The 
step options allow the components being dragged into 
the active template to snap onto the grid at one tenth 
of a foot intervals.  

 

7. Press OK to close the Template Options dialog 
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Exercise 6.2 Stacking Conditions 

To make for easy maintenance of the template it is a best practice to stack variable conditions above or below the 

connection point instead of putting multiple components on top of each other. This exercise will be adding a 

second condition that can be triggered on as needed. 

1. Use F12 to open the Create Template dialog. 

2. Navigate to the Corridor Templates folder and double-click on the US98 template to make it active. 

3. Right-click on the US98 template and select Copy from the context menu. 

 

4. Right-click on the Corridor Templates folder and select Paste from the context menu. A copy of the 

template will be made with a 3 appended to the name. 
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Exercise 6.3 Type F Curb & Gutter Condition 

The right turn lane has Type F Curb and Gutter instead of paved shoulders so another condition needs to be 

accounted for in the template. 

1.  Navigate to the Components\Curb & Gutter folder and select the Curb Type F component. 

2. While dragging the Curb Type F into the template press Ctrl+R on the keyboard to Reflect the 

component and then drop it a couple feet below the paved should component. 

  

3. Navigate to the Components\Utility Stripe folder and select the Utility Strip Left component. 

4. While dragging the Utility Strip into the template press Ctrl+R on the keyboard to toggle Off Reflect 

and then drop it on the back of curb. 

 

5. Navigate to the End Conditions\Parts folder and select the 6:1 Fill TO 5’ component. 

6. While dragging the 6:1 Fill TO 5’ into the template press Ctrl+R on the keyboard to toggle On 

Reflect and then drop it on the utility strip component. 
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7. Navigate to the End Conditions\Parts folder and select the 6:1 CUT component. 

8. While dragging the 6:1 CUT into the template press Ctrl+R on the keyboard to toggle On Reflect and 

then drop it on the utility strip component. 

 

9. Navigate to the End Conditions folder and select the Standard Search Line (Trigger) component. 

10. Drag the Standard Search Line (Trigger) and drop it just above the Type F Curb component. 
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Exercise 6.4 Constraining Conditions Together 

Now that the additional components have be placed, point constraints must be defined tying the new components 

to the original template. This way each of the conditions will be constrained to the proper location. 

1. Right-click on the green point on the trigger line and select Add Constraint > Full Constraint from 

the context menu then select the green point on the Curb Type F component. 

 

2. Set the Horizontal Offset value to Zero and the Vertical Offset Value to 2.0 and press OK. 
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3. Right-click on the green point on the curb and select Add Constraint > Full Constraint from the 

context menu then select the top outside point of the widening component where the curb should be 

placed when displayed. 

 

4. Set the Horizontal Offset value to Zero and the Vertical Offset value to -4.5 and press OK. 
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5. Double-click on the LT_CURB_TP and add the Label _V_Offset to the Vertical constraint.  This 

will allow you to override the Vertical Value with a Parametric Constraint Value of zero in the 

corridor making all of the components move to their correct location. 

 

6. Press Apply and then Close to return to the Create Template dialog. 
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Exercise 6.5 Defining Parent \ Child Relationships 

Now that the points are properly constrained, parent\child relationships must be defined. This will make for easier 

management of the template because display rules only need to be applied to the upper most relationship in the 

hierarchy. 

1. Select the Active Template tab and expand the Components folder. 

 

2. Left-click on the LT_1:6 CUT component and select Edit from the context menu. 
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3. On the Component Properties dialog, notice that Parent Component is undefined. Press Close to 

return to the Create Template dialog. 

 

4. Select the LT_1:6 CUT component. 

5. Drag and drop LT_1:6 CUT on the LT_UtilityStrip component. 

 

6. Left-click on the LT_1:6 CUT component and select Edit from the context menu. 
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7. On the Component Properties dialog, notice that Parent Component is now LT_UtilityStrip. Press 

Close to return to the Create Template dialog. 

 

8. Drag and drop LT_1:6 FILL on the LT_UtilityStrip component. 
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9. Drag and drop LT_UtilityStrip on the LT_Curb Type F component. 

 

10. Drag and drop LT_Curb Type F on the LT_SEARCH_ component. 

 

 



Chapter 6 _______________________________________________________________ TRIGGER LINES - Testing Relationships 

6-16 ©2018 FDOT  Comprehensive Template Design 

Exercise 6.6 Testing Relationships 

Now everything should be constrained as shown below. To test the relationships the display of the LT_SEARCH_ 

component can be toggled Off. If properly configured, the new curb and everything connected to it will disappear. 

1. Right-click on LT_SEARCH_ and toggle Off Displayed to see what all turns off. 

 

Note You can see how turning off the “Trigger Line” (LT_SEARCH_) turns off all related components. 

2. Right-click on LT_SEARCH_ and toggle On Displayed. 
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Exercise 6.7 Configuring Trigger Line Component 

Now that the relationships are defined, the trigger line needs to be configured to search for a specific Feature or 

Element. 

1. Double-click on the trigger line (LT_SEARCH_)  

2. Ensure Target Type is Feature Definition Horizontal and select CurbGutterTypeF from the Feature 

Definition drop-down list. 

 

3. Press Apply and Close on the Component Properties dialog to return to the Create Template 

dialog. 
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Exercise 6.8 Display Rule 

With the trigger line configured to turn on when a line with the Feature CurbGutterTypeF is found, the paved 

shoulder needs to be updated to turn off when the curb turns on. This will be handled by creating a Display Rule 

on the paved shoulder that checks for the trigger line.  

1. Double-click on the shoulder pavement component. 

2. On the Component Properties dialog press the Edit button. 

 

3. Select the SEARCH_ Display Rule, press NOT and then press Selected Rule. 

4. When the Conditional Expression reads NOT SEARCH_ press OK to return to the Component 
Properties dialog. 

 

5. Back on the Component Properties dialog, you will see that the Display Rules field has been 

populated. Press Apply and then Close to return to the Create Template dialog. 

 

6. Select File > Save from the menu and Close the Create Template dialog. 
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Exercise 6.9 Adding Corridor References 

To see the changes the template must be synchronized and a corridor reference must be added so the trigger line 

can see the curb and gutter. 

1. From the Ribbon select the Synchronize Template Tool from the Corridor Tab Miscellaneous Group 

select the Synchronize Template. OPENROADS MODELING>MISCELLANEOUS>Synchronize 

Template  

 

2. When prompted on the cursor to Locate Template Drop, select the corridor boundary. 

 

3. Press F6 on the keyboard to get out of the current command and start the Element Selection tool. 

4. Select a corridor handle sticking out from the boundary and then hover the mouse over it to get the 

context menu. 

5. Select the 5th icon on the context menu to open the dropdown and select Add Corridor Reference. 

 

6. When prompted, select both of the curb lines on the right turn lane. 
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7. When both are selected, Reset (right-click) to complete the process.  
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Exercise 6.10 Fixing Vertical Offset with Parametric Constraints 

The corridor will reprocess showing the Curb section. The Vertical Offset from the template will remain until a 

Parametric Constraint is applied. 

1. Select a corridor handle sticking out from the boundary and then hover the mouse over it to get the 

context menu. 

 

2. Select the 6th icon on the context menu to open the dropdown and select Create Parametric Constraint. 

 

3. When prompted for the Start Station, press the Alt key on the keyboard to lock the station to the 

beginning of the corridor. 
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4. Data Point (left-click) to accept the Start Station. 

 

5. When prompted for the End Station, press the Alt key on the keyboard to lock the station to the end of 

the corridor. 

 

6. Data Point (left-click) to accept the End Station. 
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7. When prompted for the Constraint Label choose _V_Offset from the drop-down on the Create 
Parametric Constraint dialog  

<OR> use the up and down arrows on the key board to select _V_Offset from the cursor and then Data 

Point (left-click) to Accept. 

 

8. When prompted for the Start Value key in Zero and press Enter then Data Point (left-click) to Accept. 
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9. When prompted for the Stop Value key in Zero and press Enter then Data Point (left-click) to Accept. 

 

Note The corridor will reprocess attaching the curb to the pavement. 

 

10. Click on the title bar of View 2 to give it focus and then press F7 to turn Off construction elements. 
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