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FDOTConnect 

for 

OpenRoads Designer 
 

Automated Quantities Workflow 

 Description 

This training course details the Florida Department of Transportation (FDOT) Quantity Workflow developed for 

the Summary of Quantity Tables required for the Estimated Quantities Report. The participants will learn the use 

of FDOT and OpenRoads Designer tools required in the workflow. This includes tools used to assign pay item 

information to 2D and 3D design elements, calculate quantities, and export quantity tables. This course also covers 

the Designer Interface Quantity Builder, used to generate an XML file compatible for upload to Designer Interface 

for AASHTOWare Project Preconstruction. 

This course includes, but is not limited to the following:  

• Item Types 

• Asset Manager 

• Pay Items and Quantities 

• Quantity Takeoff Manager 

• Generating Summary Tables 

• Summary Reports Builder  

• Estimated Quantities Report 

• Exporting Data to Designer Interface 

Objectives 

Students will learn how to use FDOTConnect’s Quantity Takeoff Manager, Summary Reports Builder, and the 

Designer Interface Quantities Builder tools to draw, calculate, and document design quantities. 

Audience 

FDOT Designers and Engineers 

Prerequisites 

The following course is required: 

FDOT Roadway Design and 3D Modeling – Basic 2D Rule Based Design Training 

Participants need to have a basic understanding of Computer Aided Drafting and Design (CADD) using 

MicroStation, a basic understanding of OpenRoads Designer concepts and a solid understanding of the 

engineering necessary to design a Roadway. 

 

Duration: 8 Hours   

Professional Credit Hours: 8 PDHs 

 

Note  PDH Credit will only be available with Instructor lead or Computer Based Training (CBT) thru Learning 

Curve. 
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1 INTRODUCTION 

OBJECTIVES 

Review the workflow and components of computing quantities. 

• Define the Workflow for Project Quantities and Recommended Tools 

• Requirements of Florida Department of Transportation (FDOT) 

DOCUMENT STYLE  

The following table shows the style conventions used throughout the course guide. 

Item Convention Example 

Menu Names and 

Commands 
Bold, names separated 

with > symbol 
 File > Open 

 File > Compress > Design 

Dialog Box 

Actions 
Bold 

 

 Click the Apply button. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include box. 

 In the Segment Type list, click Lines. 

Dialog Box Field 

Names 
Italic  Key in Hemfield Road in the Alignment Name field. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include field. 

 In the Segment Type list, click Lines. 

Key-ins Bold  Key in Hemfield Road in the Alignment Name field. 

File Names Italic  Open the file QTDSRD01.dgn in the 

C:\Worksets\FDOT\22049555201_CE\Calculations 

directory. 

File Paths Non-italic 

 

 Open the file QTDSRD01.dgn in the 

C:\Worksets\FDOT\22049555201_CE\Calculations 

directory. 

New Terms or 

Emphasis 
Italic 

 
 The Template Library contains templates, which 

represent typical sections of the proposed roadway. 
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AUTOMATED QUANTITIES WORKFLOW 

Shown in the figure below, is a workflow that represents the process of creating and providing pay item quantities 

for FDOT projects. Bentley OpenRoads applications include an element property called an Item Type which can 

be used to define meta-data as a property of drawing and/or model elements. The FDOTConnectXX.XX 

Workspace uses these Item Types to assign pay item information to those elements. Once the elements are drawn 

and pay items assigned to the Item Types, the Quantity Takeoff Manager (QTM) tool can then be used to compute 

quantities and export them to Excel Summary of Quantities Tables. For Tables which do not have Item Types or 

automated Tables defined for the quantities, QTM will also create a blank Excel Summary of Quantities Table 

that may be completed by the designer. 

When all project Summary Tables are complete, the quantity information is then processed into PDF and XML 

format.  The Summary Reports Builder tool converts the data from the Excel Summary of Quantities Tables into 

the Estimated Quantities Report which is then submitted with the project.  The Designer Interface Quantities 

Builder tool converts the same data from the Excel Tables into an XML file which may be used to upload the 

quantity data through Designer Interface into AASHTOWare Project Preconstruction. 

 

The Quantity Takeoff Manager, Summary Reports Builder, Designer Interface Quantities Builder, and all 

associated resource files were developed by the Production Support CADD Office for use with Bentley 

OpenRoads applications. Additional automation and process enhancements are expected, and the workflows 

documented herein are subject to change. 

This document will focus mostly on the workflow for Roadway quantities.  Other disciplines, such as Drainage 

and Traffic Plans, will have similar processes that will be detailed further in their respective Training Guides. 

FDOT STANDARDS 

FDOT provides several resources to instruct and aid designers in processing pay item quantities. The Estimates 

Office publishes the Basis of Estimates Manual, the governing document that specifies how to compute each pay 

item. The Estimates Office also provides a Master Pay Item list containing every pay item available for use in 

Florida. The Production Support CADD Office provides resources and tools to simplify the process of generating 

quantities. Item Types for pay items are delivered in the FDOTConnectXX.XX workspace and are defined in dgn 

libraries for Roadway and Drainage features, in application resources for the Traffic Plans tools, and may be 

applied through a template formatted for use with Bentley’s Asset Manager tool or directly from the Item Types 

tools.  

FDOT recommends the use of Civil Features for all linear feature drafting and 3D Modeling to ensure that each 

element is on the correct symbology and that the correct quantity Item Types are applied. The Roadway and 

Drainage features and Traffic Plans tools are pre-set to comply with drafting standards specified by the CADD 

Manual. The Item Types are used by Quantity Takeoff Manager which is configured to compute quantities based 

on the computation methods defined in the Basis of Estimates Manual. 
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FDOT STANDARD FILES 

Quantity information is stored in CADD files designated with one of three standard FDOT File Names, located 

in the appropriate discipline directory: 

• DSGN** – for Linear/Each Features (where ** indicates the 2-letter characters for the discipline) 

• MODLRD – for 3D modeled Linear/Area/Tonnage/Cubic Yard Features 

• QTDSRD – for 2D Area/Tonnage/Cubic Yard Features that are not modeled and quantity references 

 

The FDOT tool Create File available from the FDOT Ribbon creates these files. 
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2 ITEM TYPES 

OBJECTIVES 

• Introduce Item Types and Item Type Tools 

• Explore the Item Types Dialog 

• Set Item Types on Drawing Elements 

ITEM TYPE BASICS 

Much like AdHoc values in previous versions, Item Types in ORD are tags of meta information attached to a 

MicroStation element. For the Automated Quantities workflow, we will use the Item Types to apply pay item 

quantity information. 

The Item Types tool group is in the OpenRoads Modeling Workflow > Utilities tab, and may also be found in the 

Drawing Workflow > Attach tab or Drawing Workflow > Content tab. 

 

Item Types that are defined in dgn libraries or are active in the current dgn file may be accessed through the Item 

Types dialog. To open the Item Types dialog, click on the dialog fly-out button in the bottom right corner of the 

tool group. 

 

If there are active Item Types in the file, the Library Resource (book icon) should display with a green 

checkmark, and the tool tip will indicate that “Local resource, matches library”. 
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If the Item Types in the file have been changed, or the dgn library has changed or been updated, the Library 

Resource will display with a blue triangle, and the tool tip will indicate “Local resource, differs from library”. 

 

To update the Item Types in the active file, select/highlight the Library Resource, and two tools that were 

previously grey will now be active.  You can choose to Show Differences, or Update from Library. 

 

Note Since FDOT Quantities tools are dependent on multiple resource files that define the tables and 
computation methods for the pay items, Item Type creation for quantities is not recommended at this 
time. 

 

ITEM TYPES TOOLS 

Item Types can be managed through the Item Types tools. They can be added or deleted, Pick Lists may be edited, 

and Item Types may be imported or exported to Excel files. 

When an element is either not placed with a Civil Feature, or if it needs an additional Roadway or Drainage Item 

Type added, the Item Types > Attach Item tool may be used. 
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If an Item Type needs to be removed from a given element, the Detach Item tool may be used to remove any 

individual Item Type or all Item Types from an element.  Only the items checked will be removed, any items that 

remain unchecked will remain attached to the element. 

 

    

Pick Lists may be managed through the Pick List tool and Item Types may be imported or exported to an Excel 

file if necessary. Editing Pick Lists or creating Item Types for FDOT quantities is only recommended in certain 

limited circumstances, since the quantity tools rely on computation values and report styles from 

FDOTConnectXX.XX resource files that must also have definitions for any pay items referenced in the Item 

Types. 

  

Additional information on these tools may be found through Bentley’s Connect Advisor or Bentley Learn, or 

contact the Production Support CADD office for assistance. 

ITEM TYPES FOR QUANTITIES  

FDOTConnectXX.XX utilizes Item Types to assign data to elements that identify quantity pay item information 

to be used to compute and generate Summary Tables. Each Item Type consists of multiple fields called Property 

Definitions. Item Type Property Definitions will vary depending on the requirements of the pay item(s) and/or 

Summary Table they are designed for. 

 

Item Types for Roadway and Drainage may have one or more Property Definitions that require selections from 

a Pick List to select a property that is pre-defined in resource files delivered with the FDOTConnectXX.XX 

tools.  When the Property Definition is selected from a Pick List, the value may then be used in conjunction 

with lookup table resource files or defined expressions to populate other properties. If a Property Definition is 

grey, it is set by other property values and may not be directly edited. When viewing Item Types of elements in 

a referenced file, all properties will be grey and cannot be edited. 

Other Property Definitions may be completed by typing values directly in the Property Definition field. These 

may be required to complete computations or to include information in the Summary Table. The 

“ConstructionRemarks” Property Definition should always be left blank by the designer and is intended only for 

As-Built remarks. 

Item Type Name 

Property Definition Names Pick List Selector 

Property Definitions 
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Any drawing element may have as many Item Types as necessary to define all pay items associated with that 

element.  However, each Item Type must have a unique name. An element cannot have the same Item Type 

applied more than one time. 

ITEM TYPES AND FEATURES 

Civil Features are recommended for all linear feature drafting and 3D Modeling to ensure that each element is on 

the correct symbology and that the correct quantity Item Types are applied. The Roadway and Drainage Features 

are pre-set to comply with drafting standards specified by the CADD Manual. Currently, Features only support 

one Item Type per Feature. If additional Item Types are needed to fully define all pay items associated with an 

element, they must be applied manually with the Item Types tools or Asset Manager. 

Most Item Types that are assigned with Features will need Property Definitions set in the Item Type Properties. 

This can be done on individual elements, or with a selection set of elements having the same Item Type. Creating 

selection sets can be simplified by using the Level Display or Explorer settings to adjust the view. For example, 

in a 3D model view, using Explorer > OpenRoads Standards, in the active file, to uncheck all the feature 

definitions except Curb, or using Level Display, to turn off all Used levels except CandG_px, as shown below 

turns off the display of all elements except the Curb elements. This can be used to adjust the display for 

visualization and selection of any group of linear or 3D elements. 
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When the view is adjusted to easily create a selection set of all like-type elements, the Item Type should display 

in the Properties  dialog. If all elements in the selection set do not have the Item Type, it will not display in 

the properties. 

Select the correct Type from the picklist to correspond to the design intent of the element. Once the Type is 

selected, the Property Definition for PayItemNumber and any other fields dependent on the Type selection will 

be populated from the resource files.  Design Notes may also be added by typing in the Property Definition field. 

  

Exercise 2.1 Setting Item Type Properties on 3D Meshes 

This exercise examines the mesh properties of 3D elements in model files and uses the Properties dialog to select 

and set the Item Type Property Definitions to match the design intent and set the appropriate pay item. 

1. Open the MODLRDMainline61.dgn file in the C:\Worksets\FDOT\22049555201_CE\Roadway\ directory 

folder. 

2. Long right-click in the current view to display the context menu. Select View Control > 2 Views Plan/3D. 

Adjust the window sizes and zoom as necessary to best display both views. 

3. On the ribbon Home tab, in the Primary tool group, select Explorer, then Properties. You may dock these 

dialogs, if desired. 

     

4. In the Explorer dialog, select the Open Roads Standards tab, then expand selections for Standards > 

MODLRDMainline61.dgn (Default) > Feature Definitions and uncheck all items. This should turn off the 

display for all elements that have Features assigned. 
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5. In the Explorer dialog, under Feature Definitions, expand selections for Mesh > XS, then select the 

checkbox for curb. This should display only the curb mesh elements in the View 2, Default-3D view.  

 

6. Activate (click in) the 3D view, then open the References dialog and turn off the display of all reference 

files so only the 3D meshes in the active file are visible in the 3D view. 

7. Select any curb mesh in the 3D view, then examine the properties displayed in the Properties dialog. Notice 

the Item Type property entry for CurbAndGutter. 
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8. Click in the field for the Item Type Property Definition “Type” and examine the pick list. 

 

9. If the pick list selection group is blank, open the Item Types dialog and verify that the “resource matches 

library” as shown in the Item Type Basics section of this chapter. 

10. In the 3D view, create a selection set of the curb meshes. The properties should display 2 elements with a 

Type E curb Feature. Select “Type E” from the pick list for the Type property definition. This sets the 

property definition of the Item Type for both elements in the selection set. Notice that when the property 

definition Type is set, the PayItemNumber and Width property definitions are populated with the correct 

pay item number and the design width of the curb type selected. These property definitions are populated 

from a separate resource file and cannot be modified in the Item Type. 

    

11. Clear the selection set, uncheck the Explorer Feature Definition for Curb, and check the Feature Definition 

for PavementAsphaltFC. This should adjust the display in the 3D view to only the show the Friction Course 

Pavement mesh elements. (CurbBase is skipped, because payment for curb base is included in the cost of 

curb and it does not need a pay item assigned.) 
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12. Create a selection set of all the mesh elements displayed in the 3D view and review the properties to verify 

that all elements in the selection set are Friction Course Pavement, and that the ACFrictionCourse Item 

Type is present. 

13. In the Item Type property definition for “Type” select the pick list entry for Traffic B FC-9.5 pg 76-22. 

This sets the Item Type for all elements in the selection set. Verify that the pay item number is populated. 

Notice that there is a property definition for “Lift”. This property definition is only needed when the Item 

Type is applied to a 2D element and a numerical thickness value in decimal inches is required to compute 

the quantity. When applied to a 3D mesh, the 3D volume is used to compute the quantity and the Lift value 

is ignored.  Even though it won’t affect the calculation here, to ensure that the Item Type properties match 

the 3D mesh design, enter 0.75. 

Note The property definition name was changed from “Thickness” to “Lift” in FDOTConnect 

10.09.01.01 due to a conflict with Bentley element property names. Previous versions may not 

compute quantities correctly for 2D elements requiring a “Thickness” value. 

 

14. Repeat the above steps to set the Item Type property definitions on the Features as follows: 

PavementAsphaltSC – Traffic B pg 76-22; Lift 2.25 

PavementBase – Optional Base Group 6 

Slopes – Performance Turf Sod 

Traffic Separator – Type I 4’ Wide Opt 1 

Note Traffic Separator that is placed with a corridor template displays as a single element, even 

though it stops and restarts along the corridor. The quantities tools will report the true 

quantity/length of the segments but will only give a single line item with the begin station of 

the first segment and end station of the last segment. This may be corrected in future versions 

of ORD, but in the current release, to report separate quantities for each segment requires 

creating separate template drops for each segment. 

15. In the Explorer dialog, under Feature Definitions, uncheck the Mesh > XS and then expand selections for 

Mesh > Volumes, uncheck Volume, then select the checkbox for Volumes_Cut. This should display only 

the excavation cut volumes mesh elements in the View 2, Default-3D view. (If the meshes do not display, 

make sure the view attributes for constructions are turned on in the 3D view, as earthwork meshes are on a 

construction level.) 

  

16. Create a selection set of the Volumes_Cut meshes, then set the EarthworkCut Item Type to “Regular 

Excavation”. 

17. Repeat the process for Volumes_Fill and set the EarthworkFill Item Type to “Embankment”. 

18. Turn on all features for Mesh > Volumes and Mesh > XS. Save settings. 
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Exercise 2.2 Setting Item Type Properties on 2D Elements placed with Features 

This exercise will use the Geometry > Offsets and Tapers tool with the Guardrail Feature active to place a segment 

of Guardrail in the DSGNRD file, then utilize the Properties and Item Types tools to set the Property Definitions 

for the primary Item Type and place a secondary Item Type for a Pipe Rail on the same element. 

1. Open the DSGNRD01.dgn file in the C:\Worksets\FDOT\22049555201_CE\Roadway\ directory folder. 

2. Zoom in to the upper left quadrant of the intersection. 

 

3. On the OpenRoads Modeling > Geometry tab, locate the Horizontal tool group and use the Offsets and 

Tapers tool set to Single Offset Entire Element. 

4. In the dialog, set the Offset to 2.00 and set the Feature Definition to Linear > Roadway Design > 

Plan/Profile 2D Lines > Guardrail > WBeam General TL 3 Left. Notice when this Feature is selected, the 

Item Type for Guardrail appears in the dialog. 

5. Set the Guardrail Item Type – Type property definition to W-Beam General TL-3. If the pick list selection 

group is blank, open the Item Types dialog from the Utilities tab to refresh the resource file. The 

PayItemNumber property definition will not populate until the element is placed. 
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6. Locate the edge of pavement EOPA arc and select it to offset. Drag the cursor to the outside of the 

pavement and data point/left click to accept each of the settings. 

7. Repeat the process with the EOPA line to the left of the intersection along the US98 corridor as shown 

below. 

 

8. Create a selection set of the two segments of guardrail line and examine the properties. 

 

9. With the selection set still active, on the OpenRoads Modeling > Utilities > Item Types tool group, select 

Attach Item. 
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10. In the Attach Item dialog, In the Item Types section, select Roadway Quantities > PipeRail and data 

point/left click in the default view to accept and set the Item Type. 

 

11. Select the two guardrail lines again and examine the properties to verify that both Item Types are attached. 
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ASSET MANAGER 

Because FDOT’s Summary of Quantities Reports must include location information in addition to pay items, the 

FDOTConnectXX.XX quantities workflow utilizes Bentley’s Asset Manager (technology preview) tools and 

resources to assign item project-specific Item Types. These Item Types are attached to elements to identify the 

alignment that should be used to provide station and offset location values for each element to be quantified. 

When a new project is created with FDOTConnectXX.XX, an Asset Manager template is copied to the project’s 

Symbology folder.  This file is named FDOTProject.xlsm. If the file is not found, it may be copied from the 

FDOTConnectXX.XX\Organization-Civil\FDOT\Asset Manager folder to the project Symbology folder. 

This file may be edited to add the alignment names for the project in the _Pick List Definitions worksheet tab. 

Each alignment name should be added to the Alignment row and the name should match the alignment Feature 

name exactly. When the Alignment Item Type is placed with Asset Manager, this defines the contents of the Pick 

List selection. 

For projects which have multiple funding sources (also known as sequencing), the sequenced Financial Project 

numbers may also be defined in this file and the FPID Item Type applied with Asset Manager. When FPID Item 

Types are attached, the quantity tools are designed to create separate summary tables for each FPID specified as 

directed in the Basis of Estimates Manual, Chapter 8.  If there is no sequencing on a project, the FPID Item Type 

is not used. 

 

The Asset Manager tool may be found in the Utilities > Item Types tool group. 

 

In the Asset Manager Dialog, select the Open Asset Definitions File button and navigate to the project Symbology 

> FDOTProject.xlsm file and click Open. The left pane should populate with FDOTProject and have selections 

for Alignment and FPID. Check the applicable box(es) under FDOTProject, then in the Elements section click 

the option for Selection Set, and finally set the Assignment Mode to Add.  
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This may be used to apply and set the values for the Alignment and/or FPID Item Types to any or all quantity 

elements in a file at one time. Create a selection set of the quantity elements in the design file, then click Add 

Assets and close Asset Manager. While the selection set is still active, view the properties  of the selection 

set. In the Alignment Item Type, click in the property definition field for Alignment and set the desired value 

from the pick list. Follow the same process for FPID if a sequence FPID is needed. 

 

Note For elements placed with the Traffic Tools, that already have an Alignment Property Definition 

in the Item Type, DO NOT apply the Alignment Item Type with Asset Manager.  This creates 

a conflict and will keep the location data from appearing in the Summary Table. 
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Exercise 2.3 Placing and Setting the Alignment Item Type with Asset Manager 

This exercise will use the FDOTProject.xlsm file to define the alignment names to match the alignment Feature 

names for use with Asset Manager. Then Asset Manager will be used to apply the Alignment Item Type to a 

selection set of quantity elements. Finally, the same selection set may be used to set the Item Type Property 

Definition through the Properties dialog. 

1. Open the Excel file FDOTProject.xlsm in the C:\Worksets\FDOT\22049555201_CE\Symbology directory 

folder. 

2. In the _Pick List Definitions worksheet tab, add the values for the project’s alignments as shown below. 

These values must exactly match the Feature names of the alignments in the project. 

 

3. Once the values have been added, Save and Close the file. 

4. Continuing in the DSGNRD01.dgn file (C:\Worksets\FDOT\22049555201_CE\Roadway\), on the Utilities 

> Item Types tool group, select Asset Manager. 

 

5. In the Asset Manager dialog, select Open Asset Definitions File and navigate to the FDOTProject.xlsx file 

in the project Symbology folder, and click Open. 
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6. Adjust the settings in the Asset Manager dialog as shown below. 

 

7. In the DSGNRD01.dgn View 1, create a selection set of the two guardrail lines created in the previous 

exercise. 

8. Once the selection set is created, in the Asset Manager Dialog, Click Add Assets. 

9. Examine the properties of the selection set. There should be an additional Item Type for Alignment. The 

properties groups in this dialog can be collapsed or expanded  and you can drag any of the Item Types or 

property groups up or down in the Properties dialog to adjust the list view. 
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10. Clear the selection set. 

11. Select the arc segment of the guardrail and set the Alignment property definition to CL_SR61. 

 

12. Select the line segment of the guardrail and set the Alignment property definition to US98. 

 

13. Open the MODLRDMainLine61.dgn file in the C:\Worksets\FDOT\22049555201_CE\Roadway\ directory 

folder from Exercise 2.1. 

14. In the Explorer dialog, select the Open Roads Standards tab, then expand selections for Standards > 

MODLRDMainLine61.dgn (Default) > Feature Definitions and uncheck all items. This should turn off the 

display for all elements that have Features assigned. 

15. In the Explorer dialog, under Feature Definitions, expand selections for Mesh, then select the checkboxes 

for all Features that were set in the previous Exercise (Volumes and XS). This should display all of the 

mesh elements in the View 2, Default-3D view that have pay items assigned in their Item Types. 

16. Create a selection set of all the mesh elements displayed in the 3D view. 

17. Open the Asset Manager dialog and verify that the FDOTProject definitions file is still attached and the 

settings are correct. Click Add Assets to add the Alignment Item Type to all elements in the selection set. 

18. With the selection set still active, in the Properties dialog, set the Alignment Item Type to CL_SR61. 
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ITEM TYPES FOR 2D SHAPES 

When there are area or volume quantities that need to be defined, calculated, and reported and they are not 

included in the 3D model, we can still compute those areas from 2D shapes. The QTDSRD is the file used to 

create the shapes required to calculate 2D area/volume quantities. FDOT recommends the use of models within 

this file instead of creating a separate DGN file for each pay item and its shapes. Each model is named using the 

pay item number, BOE 10-digit format or with the use of dashes. Each model should have the Alignment, Design, 

and Survey files referenced. These references assist with the creation of the shapes needed as well as to provide 

helpful information for Construction personnel who need to access this file. Do not create shapes for all the 2D 

area/volume quantities in one model. This makes it difficult for Construction to locate the shapes they need to 

verify. 

 To save time, set up the default model with the desired references, and then copy this model to create the 
additional models needed for the pay item shapes. 

Exercise 2.4 Placing and Setting Item Types on 2D Shapes 

This exercise will create a new QTDSRD file and apply pay item and Alignment Item Types to area shapes. 

1. Continuing from the previous exercise, in the OpenRoads Modeling > FDOT > Actions tool group, select 

Create File and select the QTDSRD file with the settings shown below. Click Create - Open File. 
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2. In the Default model of the QTDSRD01.dgn file, in the OpenRoads Modeling > Home > Primary tool 

group, open the Attach Tools > References dialog. 

3. From the References dialog, select Attach Reference. From the …\22049555201_CE\Roadway\ directory 

folder, attach the ALGNRD01 and DSGNRD01 files, and from the …\22049555201_CE\Survey\ directory 

folder, attach the SURVRD01 file as shown below. 

 

4. In the view tools, select Fit View, then in the Quick Access toolbar, select Save Settings (or press Ctrl-F). 

 

 

5. In the OpenRoads Modeling > Home > Primary tool group, open the Models dialog, then select the Default 

Model and select Copy. 

 

 

6. Change the Name to “0110 [space][space] 4 [space] 10” (to match the BOE format) and set the Description 

to “Removal of Existing Concrete” as shown below. Click OK. 
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7. In the 0110  4 10 model, zoom to the intersection of the old and new SR61 roads. 

 

8. On the right side of the roadway, locate the existing planters referenced from the Survey file. For the 

purposes of this exercise, we will assume that the planters are concrete that needs to be removed for the 

new roadway. Create a selection set of the 6 rectangular planter shapes and copy them into the active file. 

(Long right click for the context menu and select Copy or locate the Copy tool in the OpenRoads Modeling 

> Drawing > Manipulate tool group.) 

9. Once the shapes are copied, turn off the Reference displays of the DSGNRD and SURVRD files. 

 

10. In the OpenRoads Modeling > Drawing > Groups tool group, select Create Region. 
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11. In the Drawing > Attributes tool group, set the Level to ConcreteRemoval. 

 

12. Set the Create Region tool to Fill, with a Fill Type of Opaque and do not check Keep Original. This will 

remove the copied shape/level and replace it with the new shape on the ConcreteRemoval level. 

 

13. Data point/left click twice inside each of the 6 planter shapes to create the new concrete shapes. 

14. Create a selection set of the 6 concrete shapes. In the OpenRoads Modeling > Utilities > Item Types tool 

group, select Attach Item. 

15. In the Attach Item dialog, select the Item Types: Roadway Quantities > ClearingGrubbingRemoval, then 

left click twice in the drawing to accept the selection. 

 

16. With the selection set still active, in the Properties dialog, select the Type property definition for Removal 

of Existing Concrete. 

Note Since the Summary of Clearing and Grubbing and Removal Items is not currently automated 

due to the presence of dual units of measure (LS/AC), this Item Type will not compute. Until 

the automation is added, adding another Item Type with similar units of measure to create a 

temporary summary table will help generate the data needed to complete the Summary of 

Clearing and Grubbing and Removal Items. This will be covered further in later exercises. 

17. Keeping the same selection set active, change the Item Type in the Attach Item dialog to DitchPavement 

(be sure to uncheck ClearingGrubbingRemoval) and left click twice in the drawing to accept the selection. 

18. In the properties dialog, in the DitchPavement Item Type, set the Type property definition to 

ConcDitchReinforced3in. Type in the DesignNotes property definition field “0110  4 10”. This will assist 

in identifying the Removal Concrete in the temporary summary table. 



ITEM TYPES - Item Types for 2D Shapes  Chapter 2 

FDOTConnectXX.XX Automated Quantities ©2021 FDOT  2-21 

19. Open Asset Manager, attach the Alignment Item Type to the selection set, and set the property definition to 

CL_SR61 as shown in the previous exercise. 

 

20. Save settings. 
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LOCATING AND TROUBLESHOOTING ITEM TYPES 

To ensure that all elements have the required Item Types, and that all Item Types are set with the correct pay item 

information, being able to locate and identify elements that need attention is important. As discussed in previous 

sections, using the Level Display and Explorer feature definitions display, along with the element properties are 

ways that allow us to isolate and examine elements. However, checking the properties on each individual element 

can be tedious and time consuming. 

If elements have been placed with features and already have Item Types attached, but not yet set, The Explorer > 

Items tab can be helpful to view and isolate groups of Item Types or individual Item Types. 

Note The Items tab in the Explorer window in OpenRoads Designer 10.8 versions is known to have 

issues with performance slow-downs of the software. This is usually resolved by selecting a 

different Explorer tab, then restarting the application. Use with caution. 

 

If you need to view a subset within an Item Type, the Advanced Search is a very helpful tool.  The launch icon 

for this tool is located at the end of the search bar in the Explorer dialog box. 

 

To create a search, select the Item Type in the Search For picklist, then set the parameters that will narrow the 

selection.  In the Where section, select the Item Type Property Definition from the picklist, then set the rule for 

what parts to include, then set the value to search for.  In the example below, the search is within Curb and 

Gutter to include only the elements where the Item Type’s pay item number is equal to 0520  1  7.  Be sure to 

click Add to Search so the parameters appear in the Search Summary window of the dialog.  Then select OK to 

complete the search.  The search results will appear at the bottom of the Item Types List in the Explorer > Items 

dialog. 
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If the Summary Table shows an element that is missing location data, or needs to be reviewed for accuracy, and 

the Element ID is known, the Select Element By ID tool is a quick way to locate any element. The tool may be 

found in the OpenRoads Modeling > FDOT > Actions > Misc. Tools > Select Element by ID. You must have 

focus in/activate the correct view for the element (2D or 3D), then select the tool, enter the Element ID# and 

click Find. The element will highlight, and the properties of the element will show in the Properties dialog.  

Once the element is located, be sure to close the Select Element by ID dialog to continue examining the 

element, or before starting any other command. 
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Exercise 2.5 Locating Item Types with Explorer and by Element ID 

This exercise will use the Explorer Items tab to select and isolate groups of Item Types. Then the Select Element 

by ID tool will be used to locate an element within the drawing and examine the properties and Item Types of 

that element. 

1. Open the MODLRDMainline61.dgn file in the C:\Worksets\FDOT\22049555201_CE\Roadway\ directory 

folder. 

2. Maximize the 3D view, Fit View and zoom to the corridor. 

3. In the Explorer dialog, select the Open Roads Standards tab, then expand selections for Standards > 

MODLRDMainLine61.dgn (Default) > Feature Definitions > Mesh and verify that all items are checked 

(displayed).  

4. In the Explorer dialog, select the Items tab, and examine the Item Type groups. Be aware that in ORD 10.8 

versions, this may slow down performance of the application. 

5. Click on any Item Type group. Review the properties. In the Properties dialog, click through any of the 

elements within the Item Type group and examine the property definitions of the Item Type. 

6. In the Explorer dialog, right-click any Item Type group, then select Isolate. Notice that the display turns off 

everything except the group selected. Right click again and select Clear Isolate to return the display to its 

previous state. 

7. Long right-click in the current view to display the context menu. Select View Control > 2 Views Plan/3D. 

Adjust the window sizes and zoom as necessary to best display both views. 

8. In the Default 2D view, open the References dialog and turn on the display for MODLRDMainline61.dgn 

Default 3D model. This should display the 3D shapes in the 2D view. 

9. In the OpenRoads Modeling > FDOT > Actions tool group use the pull-down to select Misc. Tools > Select 

Element by ID. 

 

10. Enter “5980” then click Find. Examine the highlighted mesh. 

11. Close the Select Element by ID dialog. 

12. In the Properties dialog, right-click on the ObjectSettingsRule element and select Isolate. 

13. Click on the highlighted pavement element in the 2D view and review the properties. 

14. Right-click on the LT_Pavement FC Outside element and select Clear Isolate. 
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3 SUMMARY TABLES 

OBJECTIVES 

• Set up the project reference QTDSRD file 

• Explore the Quantity Takeoff Manager 

• Create and examine the Summary of Quantities table Excel files 

QUANTITY REFERENCE FILE 

Since Item Types must be assigned to each element in its active file, we may have quantity information that is 

required for a single table in many different design files. For the FDOTConnectXX.XX quantities workflow, we 

will utilize the QTDSRD file to provide a design file in which to reference all the Roadway quantity data to a 

single location. Note, other design components (i.e. Drainage, Signing & Pavement Marking, etc.) may generate 

their quantities directly from their design files if all quantity information needed for the component Summary of 

Quantities table is located in or referenced to a single model. 

The combined reference model can be included in the same QTDSRD file as any 2D area/volume models, or it 

can be in a separate QTDSRD intended only for the quantity references. Whichever file is used, the combined 

reference model should be clearly labeled so it can easily be located by reviewers or Construction. 

Exercise 3.1 Creating the Reference QTDSRD 

This exercise will create a QTDSRD file that includes references of all 2D and 3D Roadway design files and 

models that contain quantity Item Types. 

1. Continuing from the previous exercise, in the OpenRoads Modeling > FDOT > Actions tool group, select 

Create File and select the QTDSRD file. Notice that the File Sequence # has incremented to 02. Verify that 

the output settings are correct, then click Create - Open File. 

2. In the OpenRoads Modeling > Home > Primary tool group, open the Attach Tools > References dialog. 

3. From the References dialog, select Attach Reference and attach the files as shown in the image below. 

Make sure to attach both 2D and 3D models of each of the MODLRD files and all pay item models of the 

QTDSRD01Complete.dgn. Notice that the GDTMRD file is in the project’s Survey folder. 

 

4. Locate the terrain outline, right click - hold for the context menu and select Set As Active Terrain Model. 

5. Right click and hold anywhere in the Default view for the context menu and select View Control > 2 Views 

Plan/3D, Fit View in the Default and 3D views, and save settings (Ctrl-F).  
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QUANTITY TAKEOFF MANAGER 

Quantity Takeoff Manager is a new application created by the FDOT Production Support CADD office for use 

with FDOTConnectXX.XX for OpenRoads Designer. This tool generates formatted Excel Summary Tables for 

all Summary of Quantities that may be included on a project. For select tables, it also harvests information from 

elements in CADD files including Item Types, Element Properties, and alignment location data, and computes 

and exports that data to Auto-Populated Summary Tables. 

The Alignment Options selector may be used to generate tables based on any individual alignment, or all 

alignments. Since Summary Tables should contain all the quantity data from all alignments on a project, it is 

recommended to leave the Alignment Options set to All. (FDOTConnect 10.08.01.00 and earlier versions may 

have slightly different options/button configurations.) 

 

The Summary Tables section contains a list of all Summary Tables that can be on a project. All project 

Summary Tables should be created using this tool. Dark/highlighted items indicate tables which may be auto-

populated from the design file element properties and Item Types. Non highlighted items are tables that, once 

created by the tool, must then be completed by the designer. 
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Summary Tables may be selected individually, all, none, or invert the current selection with the selection 

buttons, or multiple tables selected individually by holding the Ctrl key while selecting. 

The Output Options > File Output Location should default to the project Calculations folder. If it does not, or if 

sub-folders are used, the path may be redirected as needed using the browse button . All Summary Table 

Excel files from all project components should be stored in the Calculations folder. Sub-folders may be used if 

necessary, but all files required for the Estimated Quantities Report must be in the same folder. 

Since most quantities will be reported from reference files, the checkbox for Include External References should 

always be checked/selected. 

If Open Output File(s)is selected, each Excel file created will open a new instance of Excel. If a large number of 

tables are selected to compute at one time, it is not recommended to leave this option checked. 

The Compute button will generate the Summary Table for the selected items. The Create PDF button launches 

the Summary Reports Builder that creates the Estimated Quantities Report. This tool will be discussed further in 

the next chapter. The Close button will close the application. 

Exercise 3.2 Creating Summary Tables 

This exercise will create an auto-populated Summary of Pavement and a Summary of Clearing Grubbing and 

Removal Items template to be completed in the next exercise. 

1. Continuing from the previous Exercise, in the QTDSRD02.dgn file, make sure that the Default 2D model is 

active, then on the OpenRoads Modeling > FDOT tab, select the Quantities > Takeoff Manager tool. 

2. In the Takeoff Manager dialog, examine the Alignment Options to verify that the project’s alignments are 

included in the pull-down list. Leave the selection set to All. 

3. Click on the Summary Table Summary of Clearing Grubbing and Removal Items, then hold Ctrl and select 

Summary of Pavement. 

4. Verify that the File Output Location displays the path to the project’s Calculations folder and that Include 

External References and Open Output File(s) are checked. 
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5. Click Compute, then examine the Excel files.  Notice that the Summary of Clearing Grubbing and Removal 

Items has no project pay item data. Verify that the Summary of Pavement has the appropriate pay item 

data. 

 

 

6. Close both Excel files. 
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SUMMARY TABLES 

With the introduction of FDOTConnectXX.XX, the format of the Summary Tables has been modified from 

previous platforms. The Summary Tables are all generated from a single master template and follow a 

consistent format that always has Pay Item Definition information, followed by Quantity Values, Location 

Information, then Notes and Remarks. The format is not only important for consistency across Summary 

Tables, it is also critical for the generation of the Estimated Quantities Report. 

 

When Summary Tables are edited by the designer, there are some important rules to keep in mind to ensure that 

the Summary Table will be compatible with the Summary Reports Builder tool to create the Estimated Quantities 

Report: 

IMPORTANT RULES FOR SUMMARY TABLES 

1. Do not add, delete, move, or change any columns within the table. 

2. Do not leave any blank rows in the table. Each row must have a value in the Quantity “P” column or the 

Secondary Quantity “P” column, or the row will be considered the end of the file by Summary Reports 

Builder and any data below that row will be ignored. 

3. Fill in all 60 rows in the first worksheet/tab (Sheet1) before beginning another worksheet. 

4. If more than one worksheet is needed, copy the Sheet1 worksheet and rename it as Sheet2, Sheet3, etc. The 

worksheet names must follow the format (capital “S” and no space before the number). 

5. Supporting documentation may be kept in the same Excel file as long as a different worksheet/tab name is 

used. Any worksheet not named in “Sheet#” format will be ignored by the Summary Reports Builder and 

will not be included in the final Estimated Quantities Report. 

6. Changes in column widths, word wrapping, and text format in the Excel file will not be carried through to 

the Estimated Quantities Report. The data is read, processed, and reformatted into PDF form by the 

Summary Reports Builder. Because of this, word wrapping and page breaks may occur at different 

locations in the PDF than what is seen in the Excel file. 

7. Any data that is copied from another document should be pasted as “values” so that the formatting of the 

Summary Table is not altered. 

 

8. All quantity values should be entered with the correct rounded precision as defined in the BOE Chapter 2. 

Proposed quantities should be rounded to one additional significant digit, and Total quantities should be 

rounded to the precision shown in BOE 2.1.  

Note Using the Excel cell format to apply rounding will not carry through correctly to the PDF, as 

the Summary Reports Builder tool reads the cell values directly and does not honor the Excel 

cell rounding formats. 

9. Do not change the name of the Summary Table Excel file. The Summary Reports Builder will only include 

files with names exactly matching the definitions in the Quantity Takeoff Manager. The only exception is 

that a suffix may be added when a funding sequence FPID or Structure number is needed. 

(i.e. Summary of Structure Quantities - 123456.xlsx). 

10. Once a file has been edited, use caution not to create the same table with Quantity Takeoff Manager, or the 

file will be overwritten, and the data lost. If a new table must be created and the existing data preserved, 

make sure to save the existing file to a different location before creating the new file.  
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CREATING TABLES FOR NON-STANDARD PAY ITEMS 

While there are some Summary Tables that are not automated, there are instances where a pay item is not yet 

automated, or there is a project-specific pay item needed for an automated table that is not included in the 

FDOTConnectXX.XX resources. Since the FDOTConnectXX.XX resources should not be modified by designers, 

the CADD office has developed some suggested workflows to assist with populating Summary Tables that contain 

pay items that are not defined in the FDOTConnectXX.XX workspace. This workflow is not required, and 

quantities for these items may still be computed manually, if desired. Extra caution should be used when 

implementing these workflows to ensure that the quantities reported do not reflect the wrong pay item data. 

For any valid pay item (see the BOE) that is not currently defined in the FDOTConnectXX.XX workspace, follow 

the steps below: 

1. Create a model in the QTDSRD that will contain only elements for that pay item number. 

2. Reference in the alignment, topo, 2D design or 3D models, and any other file needed to define the shapes. 

3. Copy 2D linear elements, 3D meshes, or create area shapes in the QTDSRD model for the elements that 

belong to the non-defined pay item. 

4. Identify an Item Type that is defined in the FDOTConnectXX.XX workspace that has the same units of 

measure and computation method (or similar) to the non-defined pay item. 

5. Manually apply the selected Item Type to the elements in the QTDSRD model and type the correct pay 

item number into the Design Notes field of the Item Type. Be sure to also apply the alignment Item Type. 

6. Using Quantity Takeoff Manager, generate the table associated with the existing Item Type that was 

applied. Be sure not to overwrite another table. Consider changing the save path to a sub folder in the 

Calculations folder created specifically for this process. 

7. Change the file name to reflect the non-defined pay item description. This file is only a temporary step used 

to generate the data to be copied into the actual Summary of Quantities Table. 

8. If quantities were generated with a different but similar/compatible unit of measure, open the generated file 

and apply a conversion formula to the quantity values to convert to the correct units of measure. 

9. Using Quantity Takeoff Manager, create the appropriate Summary Table for the non-defined item (or open 

the table if it has already been generated with other auto-populated quantities). 

10. Type in the correct pay item number, description, and units then copy the quantity, location and element ID 

information and paste values-only into the table. 

Using this method allows the designer to automate the generation of the quantity, location, and element ID 

information for each design element, saving significant effort compared to identifying each element manually. 

For elements that may be defined in the FDOTConnectXX.XX workspace resource definitions but need multiple 

pay items and Item Types per element (usually for Traffic Plans), contact the CADD office for guidance on 

creating Item Types in the design file, or refer to the Traffic Plans training guide. 
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Exercise 3.3 Creating a Summary Table with Temporary Item Types 

This exercise will generate quantity data to be used in the Summary of Clearing Grubbing and Removal Items 

created in the last exercise. 

1. Continuing from the previous exercise, in the QTDSRD02.dgn file, launch Quantities > Takeoff Manager. 

2. Select Summary of Ditch Pavement, verify The Alignment Options and Output Options are correct and 

Open Output File(s) is checked, then click Compute. 

3. Examine the Summary of Ditch Pavement table. Notice that the values reflect the temporary Item Types 

with the Summary of Clearing Grubbing and Removal Items pay item information in the Design Notes 

column. Close the Excel file. 

 

4. In the OpenRoads Modeling > FDOT > Resources tool group, select Explore Directories > Current 

Workset. 

5. Navigate to the project’s Calculations folder and locate the Summary of Ditch Pavement.xlsx. 

6. Create a new folder in the Calculations folder named “Temp” and move the Summary of Ditch 

Pavement.xlsx file to the new folder. 

7. Rename the file from Summary of Ditch Pavement.xlsx to Summary of Clearing Grubbing and Removal 

Items Temp.xlsx. 

8. Open both the Calculations > Summary of Clearing Grubbing and Removal Items.xlsx and the Calculations 

> Temp > Summary of Clearing Grubbing and Removal Items Temp.xlsx. 

9. Since the units of measure for 0110  1  1 Clearing & Grubbing and 0110  2  2 Selective Clearing and 

Grubbing, areas with Trees to Remain are not SY the quantities will need to be adjusted. 

10. In row 4, column AQ of the Temp file, enter the formula =W4/4840. This converts the SY quantity to AC. 

 

11. Copy the row 4, column AQ cell, then highlight all the cells in column AQ that correspond to either pay 

item 0110  1  1 or 0110  2  2, then right-click and paste Formula. 

12. With the AQ column cells still highlighted, change the number settings from General to Number, and set 

the precision to 0.001. 
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13. In the Summary of Clearing Grubbing and Removal Items.xlsx, in cell B4, type in “0110  1  1”. Make sure 

to use the BOE format with two spaces before each 1 after 0110. This is critical for the Excel files to be 

compatible for upload to Designer Interface later. 

14. Next, on the same row in cell D4, type in “Clearing & Grubbing”, in cell H4, type in “LS”, in cell W4 and 

Y4, type in a value of “1”, and in cell AA4, type in “AC”. 

 

15. In the Temp Excel file, highlight and the values from column AQ which correspond to the 0110  1  1 pay 

item number and right-click and select Copy (or press Ctrl-C). 

16. Open a blank Notepad document and paste the values there, then copy again. This eliminates any of the 

trailing decimal place values. 

Note This extra step is necessary because, as stated above, using the Excel cell format to apply 

rounding will not carry through correctly to the PDF, since the Summary Reports Builder tool 

reads the cell values directly and does not honor cell rounding formats. Pasting values only 

within Excel retains the full length of decimal places from the original, so to avoid manually 

typing in all the data, using extra step of copying and pasting through the plain text format of 

Notepad clears the extra digits.  

17. In the Summary of Clearing Grubbing and Removal Items.xlsx, click in cell AB4, then right click and 

select Paste Values. This adds the computed and truncated AC values from the formula in the Temp file. 

18. In the Temp Excel file, highlight and copy the values from columns AG through AM for all rows which 

correspond to the 0110  1  1 pay item number. 

19. In the Summary of Clearing Grubbing and Removal Items.xlsx, right click in cell AG4, then select Paste 

Values. This places all the location data for all the selected rows/columns. 

20. In the Temp file in row 4, column AR, enter the formula =Y4/4840 to convert the total quantity. Change 

the number settings to Number and precision to 0.01. Type the rounded value in the Design Notes column 

with the text “Total AC”. (Or copy and paste through Notepad document to remove the trailing digits.) 

 

21. In the next row (do not leave a blank row), enter “0110  2  2”, “Selective Clearing and Grubbing, Areas 

with Trees to Remain”, and “AC” in columns B, D, and H, respectively. 

22. In the Temp file, highlight and copy the values from column AQ which correspond to the 0110  2  2 pay 

item number, following the same procedure as before, paste the values into the Notepad file to remove the 

trailing digits, then copy again. 

23. In the Summary of Clearing Grubbing and Removal Items.xlsx, click in next cell in column W, then right 

click and select Paste Values. This adds the computed and truncated AC values from the formula in the 

Temp file. 

24. In the Temp file in row 11, column AR, enter the formula =Y11/4840 (where 11 is the row number of the 

first row which corresponds to the 0110  2  2 pay item number). Change the number settings to Number and 

precision to 0.01. Copy and paste into the Notepad document or type the value directly in Step 26. 

25. In the Summary of Clearing Grubbing and Removal Items.xlsx, in the first row which corresponds to the 

0110  2  2 pay item number Column Y enter the value from Step 25. 
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26. In the Temp Excel file, highlight and copy the values from columns AG through AM for all rows which 

correspond to the 0110  2  2 pay item number. 

27. In the Summary of Clearing Grubbing and Removal Items.xlsx, right click in cell AG11, then select Paste 

Values. This places all the location data for all the selected rows/columns. 

28. In the next row (do not leave a blank row), enter “0110  4 10”, “Removal of Existing Concrete”, and “SY” 

in columns B, D, and H, respectively. 

29. In the Temp Excel file, highlight and copy the values from columns W through AM for all rows which 

correspond to the 0110  4 10 pay item number. 

30. In the Summary of Clearing Grubbing and Removal Items.xlsx, right click in next cell in column W, then 

select Paste Values. This places all the quantity and location data for all the selected rows/columns. 

 

31. Save and Close both Excel files. 
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4 ESTIMATED QUANTITIES REPORT 

OBJECTIVES 

• Examine the Summary Reports Builder Application 

• Set up the Estimated Quantities Report Signature Page 

• Create and examine the Estimated Quantities Report 

SUMMARY REPORT BUILDER 

The Summary Report Builder is a new application created by the FDOT Production Support CADD office for 

use with FDOTConnectXX.XX for OpenRoads Designer. This tool generates the Estimated Quantities Report 

from the Summary of Quantities Excel files generated for all project components by the Quantity Takeoff 

Manager. This application may be accessed either from the Create PDF button within Quantity Takeoff Manager,  

 

or from a standalone icon delivered in the desktop FDOTConnectXX.XX workspace folder. 

 

When accessed from within Quantity Takeoff Manager, the input and output directories are set by default to the 

Calculations and Estimates folders of the project, respectively. When opened from the Desktop folder icon, the 

folder paths to the project must be set to the correct project locations using the browse buttons . 

The Input Directory should be set to the Calculations folder, where all the Project Summary Table Excel files are 

to be kept. When this path is set, all Excel files in the folder with valid Summary Table names should be displayed 

in the Excel Summary Table Files window. 

The PDF Output Directory should always be the Project Estimates folder, where the Estimated Quantities Report 

should be kept. 

The Excel Summary Tables to be included in the PDF may be selected individually selecting the checkboxes, or 

by using the selection buttons in the bottom left corner of the dialog box. The checkbox for open output file may 

be selected to open the Estimated Quantities Report once its created. Once the selections are set, click Create to 

generate the Estimated Quantities Report. 
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ESTIMATED QUANTITIES REPORT SIGNATURE PAGE 

The Estimated Quantities Report requires a signature page that identifies the Project and Engineer of Record date 

as shown in FDM 902. The FDOTConnectXX.XX workspace delivers an Excel template for this page that must 

be completed outside of Quantity Takeoff Manager since it does not match the format of the Summary Tables. 

On new project the template should be in the Project Calculations folder. If the file does not appear, it may be 

copied from the FDOTConnectXX.XX\Organization-Civil\FDOT\Asset Manager folder to the Project 

Calculations folder. 

 

Any text shown in red italics indicates information to be completed by the designer with Project specific 

information. Once the data is completed, it should be changed to black vertical text to match the format of the 

other text.  The EOR Name and Date/Timestamp text may be deleted as this indicates the location where the 

digital signature should be placed. 

The seal graphic may be generated using the project Seals.cel file to print a .jpg image of the EOR’s seal that can 

be inserted into the table cell. 

Once the Excel EQRSignature.xlsx template is completed and saved, select File > Save as and change path to the 

Estimates folder and the file format to PDF 

 

If the file EQRSignature.pdf exists in the Estimates folder, the Summary Reports Builder will find it and include 

it as the first page and bookmark in the Estimated Quantities Report. If the file is not in the Estimates folder, or 

does not have the correct filename, the page will not be included. 

Exercise 4.1 Creating the Estimated Quantities Report Signature Page 

This exercise will generate the EOR Seal image from the Project Seals.cel, complete the EQRSignature.xlsx, 

and save the EQRSignature.pdf file in the Project Estimates folder. 

1. Open the Seals.cel file in the C:\Worksets\FDOT\22049555201_CE\Cell\ directory folder. Be sure to 

change the file format to .cel files. 
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2. Open the OpenRoads Modeling > Home > Primary tool group, open the Models dialog. 

 

3. Right-click on the PESeal model and select copy. 

 

4. In the Copy Model dialog, change the Name to EQRSignaturePESeal. 

5. Change the Model to the new EQRSignaturePESeal model and adjust the view. 

6. On the OpenRoads Modeling > Drawing Production > Text tool group, select Edit Text, then click 

SIGNATURE NAME. 

7. Change “SIGNATURE NAME” to “LUKE S. WALKER”. 

8. In the Text tool group, select Fill in Single Enter-Data Field, then click on the text 00000. Change the value 

to 99991 and click OK. 

    

9. On the OpenRoads Modeling > Drawing > Attributes tool group, set the level to “PlotBorder_dp”. 
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10. In the Placement tool group, select Place Block. 

 

11. Click once in the drawing view, then enter “:3”, press Enter, then enter “:3”. This should create a 3" by 3" 

square. 

12. On the Manipulate tool group, select Move, then using the Center snap, select the square and move it to the 

center of the center star of the seal. 

    

13. Change the background display of the file to white.  Select File > Settings > File > Color Table, then 

double click the “B” square in the lower right of the Color Table dialog. Select the list tab in the Modify 

Color dialog and select “White”.  Click OK in the Modify Color dialog, then click Attach in the Color 

Table dialog. Click the back arrow in the top left of the screen to return to the file. 

 

14. In the Selection tool group, select place fence, then snap to the corners of the plot border to create a fence. 

15. On the quick access toolbar, click Print (or select File > Print > Print). 

16. Set the Printer and Paper Size to jpeg.pltcfg. 

Note In FDOTConnect 10.08.01.00 and earlier, the delivered pltcfg file gives an error. If necessary, 

select the ellipsis  next to the Printer and Paper Size and navigate to the dataset 

C:\Worksets\FDOT\22049555201_CE\Symbology\ directory folder and select the jpeg.pltcfg.  

17. Set the Printer and Paper Size to MAX, Set the Area to Fence, then in the Scale/Size area set the Size to 3in 

as shown below. 
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18. Click Print to File. This should create an image PESeal.jpg file that is scaled to 3 inches square in the Cell 

directory folder. 

19. Open the EQRSignature.xlsx file in the C:\Worksets\FDOT\22049555201_CE\Calculations\ directory 

folder. If the template does not display as an 11x17 page, select File > Print and change the printer selected 

to a printer that supports 11x17 pages, such as Microsoft Print to PDF, then click the back arrow to return 

to the worksheet. 

20. Edit the template to add the Financial Project ID, Contract Number, Project Description and EOR 

information as shown below. Change the text font to black and non-italics. 

21. Delete the “Seal Graphic” text – this will be replaced with the image created in step 14. Delete the “EOR 

Name” and “Date/Timestamp” – this indicates the location that the EOR’s digital signature stamp will be 

located when the Estimated Quantities Report is signed and sealed. 

22. Click in the merged cell that was labeled “Seal Graphic”. Select Insert > Pictures > Insert Picture from This 

Device, then navigate to and select the PESeal.jpg created in step 18. This should insert the seal image in 

the proper location.  

23. Click on the image and examine the Picture Format > Size. If the Height and Width show as 3.13 inches, 

adjust the size to 3 inches to fit within the cell. (This happens due to a rounding/precision issue in printing.) 
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24. Select File > Save As. Click on the path and navigate to the project Estimates folder. 

 

25. Change the Save as type to PDF (*.pdf) then click Save. 
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Exercise 4.2 Creating the Estimated Quantities Report 

This exercise will generate and explore the Estimated Quantities Report. 

1. Open the QTDSRD02.dgn file in the C:\Worksets\FDOT\22049555201_CE\Roadway\ directory folder. 

2. In the OpenRoads Modeling > FDOT tab, open the Quantities > Takeoff Manager and click Create PDF. 

3. In the Summary Reports Builder dialog, review the Input and Output Directories and verify that they reflect 

the paths to the project’s Calculations and Estimates folders, respectively. 

4. Review the list of Excel Summary Table Files and verify all the Summary Table names match the Quantity 

Takeoff Manager Table names exactly, click Select All, check the box for Open Output File, then click 

Create. This process may take a minute. 

5. Examine the 22049555201_CE-ESTIMATES-QUANTITIES.pdf file. Test the bookmarks and verify that 

all Summary Tables have been included. 

  

6. Close the file. 
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5 DESIGNER INTERFACE QUANTITIES 
BUILDER 

OBJECTIVES 

• Examine the Designer Interface Quantities Builder Application 

• Review the workflow for uploading quantities to Designer Interface for AASHTOWare Project 

Preconstruction 

The workflow for uploading quantities to Designer Interface requires mainframe access and a RACF password. 

This chapter will cover the process but will not include exercises due to access restrictions. 

PROJECT HEADER EXPORT 

Before launching the Designer Interface Quantities Builder, the Project Header must be downloaded and saved 

to the Project’s lead discipline folder. The FDOTConnectXX.XX FDOT Ribbon tab > Resources > FDOT Links 

tool include a link to the Web Gate Portal website where Designer Interface may be accessed. 
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In Designer Interface, locate the Project in the Project List and select “Export Header”. The file may show at the 

bottom of the browser window and may be found in the Downloads folder on your computer. Locate the file and 

move it to the lead component discipline folder, usually Roadway. 
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DESIGNER INTERFACE QUANTITIES BUILDER 

The Designer Interface Quantities Builder is a new application created by the FDOT Production Support CADD 

office for use with FDOTConnectXX.XX for OpenRoads Designer in conjunction with Designer Interface for 

AASHTOWare Project Preconstruction. This tool generates an XML file from the same Summary of Quantities 

Excel files used to create the Estimated Quantities Report. This application may be accessed from the icon located 

in the FDOTConnectXX.XX Desktop folder. 

 

In the Designer Interface Quantities Builder application window, in the Header File Location, click Browse and 

locate the Project Header file downloaded from Designer Interface. 

Next, in the Summary Tables Location, click Browse and navigate to the Project Calculations folder. 

In the Excel Summary Table Files section, examine the Group Id section. Notice that each table shows with a 

default group Id. These each have a pick list of all the available Group Id codes that were included in the Project 

Header file. Verify that the correct Id is shown for each Summary Table. If the Id should be changed, select the 

correct Group Id from the list. See the Basis of Estimates, Chapter 9 for a list of allowed Group Id numbers by 

discipline. 

The Excel Summary Tables to be included in the XML may be selected individually selecting the checkboxes, or 

by using the selection buttons in the bottom left corner of the dialog box. 

The Output File Location should be directed to the lead component discipline folder and the file name should be 

changed to add “_out” to the filename (i.e. 0000000000000_out.xml). Click Create to save the XML file. 
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PROJECT QUANTITIES IMPORT 

Once the Output File is created, return to the Designer Interface page, and select “Import”. 

 

Click Select files and locate the [Project]_out.xml file. When the file appears in the window, then click Upload 

file. 

 

If there are no errors, the Project Load Log Message should display with a green highlighted title and successful 

messages. 
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If errors exist, a Data Validation Error page will display with a red highlighted title and list all errors in the XML 

file. All errors must be corrected or no data will be uploaded. 
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6 PLATFORM INDEPENDENT 
QUANTITIES 

OBJECTIVES 

• Examine and discuss the Quantities tools installed in the FDOTConnectXX.XX desktop folder. 

• Identify the location of Summary templates in the Workset template and project folder structure. 

• Examine Landscape and Structures Summary of Quantities Templates. 

BASIC FDOTCONNECT 

Occasionally, a project will have a component or discipline that does not require the full civil software to generate 

the CADD files required.  As long as the requirements of the FDOT, and especially the CADD Manual, are met 

and the files produced are compatible with the civil versions of the software, basic versions of MicroStation or 

AutoCAD may be used to produce the plans. 

In order to meet the requirements to generate and deliver quantities in an Estimated Quantities Report, consultants 

may still download and install the FDOT CADD software, even if the civil version of OpenRoads Designer is not 

present.  When FDOTConnectXX.XX is installed and OpenRoads civil software is not detected, the tools, 

applications and resources are still installed and available, but there will be no launch icons in the FDOTConnect 

desktop folder for the civil CADD software. (The red marked icons shown below will not be present.) 

 

The FDOT CADD Project folder structure and templates may be provided by the lead project designer. If not, 

refer to the CADD Essentials Workflow training guide for the steps to set up the project and create CADD files 

to meet the requirements of the CADD Manual. 

For the Quantities workflow, the applications that will be used are the Summary Reports Builder and the Designer 

Interface Quantities Builder (green circled icons shown above).  



Chapter 6 PLATFORM INDEPENDENT QUANTITIES - Generating Quantities 

6-2 ©2021 FDOT  FDOTConnectXX.XX Automated Quantities 

GENERATING QUANTITIES 

Once the component CADD files are created, the quantities must be computed, and the Summary Tables filled 

out manually.  Blank templates for all Summary Table Excel files should already be included in a sub-folder of 

the Calculations folder for new projects created with the FDOT Create Project application.  If the Blank Templates 

folder is not already included in the project Calculations folder, it can be copied there from the following location: 

FDOTConnectXX.XX\Workspaces\FDOT\WorkSets\0_WORKSET_TEMPLATE\Calculations\BlankTemplates 

 

Copy the templates needed for the project to the Calculations folder and edit them there to add the project’s 

quantity data.  Refer to the Summary Reports section of Chapter 3 in this document for rules and recommendations 

for completing the tables. 

All elements, lines, shapes, etc. created in MicroStation CE have an Element ID associated with them, and that 

information can be documented in the Summary tables when necessary.  One way to locate the Element ID is to 

use the Key-in tool and type “analyze element”, then in the Element Information dialog, Details tab, the Element 

ID is displayed. 
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Including the Element ID when possible, even in a manually generated table, allows reviewers to more easily 

locate and check the source of the quantity data. 

Completed Summary Excel files for all disciplines should be maintained in the project’s Calculations folder.  If 

a component of a project is completed by another firm or group, the Summary Table Excel files are delivered to 

the project lead and placed in the project’s Calculation folder for processing. 

SPECIAL CONSIDERATIONS FOR MANUAL SUMMARY REPORT TABLES 

There are a few instances where the workflow for manually generating a Summary Table differs from the 

Automated Quantities process.  For any unusual situation not covered here, contact the CADD Office for 

additional support. 

MULTIPLE FUNDING SOURCES 

In the Automated Quantities workflow, when there are multiple funding sources within a project, all quantity 

elements are tagged with an Item Type that identifies the FPID funding source for each element and the quantities 

are automatically placed in separate labeled Summary Table Excel files.  When quantities are generated manually 

for a project with multiple funding sources, the quantities must be sorted into separate Summary Tables for each 

FPID as required by the Basis of Estimates Manual. 

Each Summary Table Excel file must maintain the filename that matches the template provided.  When multiple 

files of the same name are created, each filename and table title must be appended with the FPID.  It is important 

to make sure that the filename matches the correct format, or it will not be compatible with the Summary Reports 

Builder to generate the Estimated Quantities Report.  This format requires the base template name followed by a 

space, dash, then another space, followed by the FPID and the file extension 

(i.e., Summary of Pavement - 22049555201.xlsx). 
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SUMMARY OF LANDSCAPE ITEMS AND PLANT SCHEDULE 

A special template for Summary of Landscape Items, which includes a linked worksheet for a Plant Schedule, 

has been included in the Calculations > Blank Templates folder.  The Sheet1 worksheet is formatted for the 

Summary of Landscape Items summary table and is compatible with the Summary Reports Builder and Designer 

Interface Quantities Builder.  The PlantShedule worksheet is formatted to be compatible with the Linked Data 

Manager tool and is linked to Sheet1 with formulas and will automatically include the appropriate data for that 

table.  This ensures a single source of data for both tables. 

If additional worksheets are needed, copy both the Sheet1 and PlantSchedule worksheets and rename them to 

Sheet2 and PlantSchedule2, respectively. The name format of the Sheet worksheets is critical to the compatibility 

with the Summary Reports Builder and Designer Interface Quantities Builder. In the copied PlantSchedule 

worksheet, edit the formulas to redirect to the corresponding Sheet# worksheet.  Repeat the process for any 

additional worksheets, maintaining the naming and numbering format.  If a separate Irrigation Schedule is needed, 

the PlantSchedule worksheet may be copied, renamed, and edited to change the table title and modify the links to 

only include the irrigation items from the Sheet# worksheets. 

When manually entering the data, be sure to follow the guidelines set forth in Chapter 3 of this document.  Be 

sure to enter pay item numbers in the BOE format and match the pay item descriptions in the BOE exactly. 

For secondary quantity item listings (plants or soil enhancement), the Label column should contain the 

corresponding designation or symbol indicated in the plans.  The Pay Item Description column should include 

the following information: 

Plants: Botanical Name / Common Name; Size; Spacing; Details 

Landscape Soil: Soil Enhancement; Removal Depth; Soil Added; Amendment Added; Scarification Depth; Unit 

In the past the Summary of Landscape Items quantities were generated by sheet.  All other quantities for the 

Estimated Quantities Report are summarized by-location.  The new workflow for landscape quantities allows the 

designer to designate locations as sheet numbers or by other parameters, depending on the needs of the project. 

To give quantities by sheet, the designer should identify the Site No. corresponding to the sheet numbers of the 

plans. If the designer chooses to designate site locations based on intersection, planting bed, etc. they may do so 

by assigning Site numbers to each location. With either option, the Site No. designations should be shown on the 

Project Layout sheet in the Landscape Plans.  The Location Description column may be used to further identify 

any location details to completely describe the location of the item(s) being quantified. 
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SUMMARY OF STRUCTURE QUANTITIES 

As with multiple funding sources, the Summary of Structure Quantities requires a separate Summary Table for 

each structure number.  Also, each Summary Table must include the structure number appended to the table title 

and filename. 

There are minor differences in the format of the table from previous versions of the Summary of Structure 

Quantities, though the same data is included.  Note that the Section column rows should not be merged.  The 

section should be listed on the first row of the quantities for that section and should not be repeated, much like 

pay items and descriptions.  Also there are columns provided for secondary quantities such as LS/SF as shown in 

the example below. 

 

CREATING THE ESTIMATED QUANTITIES REPORT 

The project Estimated Quantities Report (EQR) is generated by the project lead designer for the Engineer of 

Record.  Only when a project is completely produced outside of the OpenRoads Designer environment would the 

EQR need to be generated with the standalone tools.  However, a test PDF may be created to verify that all the 

data translates properly prior to forwarding the Excel file to the project lead. 

When using the Summary Reports Builder as a standalone tool, the only difference from the automated workflow 

is that the full path to the project Calculations and Estimates folders must be entered and/or browsed-to in the 

dialog.  The processes for creating the signature page and the Estimated Quantities Report are documented in 

Chapter 4 of this guide. 

 

UPLOADING QUANTITIES TO DESIGNER INTERFACE 

As with the Estimated Quantities Report, the upload of quantities to Designer Interface is managed by the project 

lead designer for the Engineer of Record.  It also requires mainframe permissions, so access is limited.  Since the 

Designer Interface Quantities Builder is a completely standalone application, the process is the same as shown in 

Chapter 5 of this guide.  Note that all quantities must be entered in the correct format as indicated in this training 

guide to achieve a successful upload of quantity data. 
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