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Description
This training course details the Florida Department of Transportation (FDOT) Quantity Workflow developed 
for the Summary of Quantity Tables required for the Estimated Quantities Report. The participants will 
learn the use of FDOT and OpenRoads Designer tools required in the workflow. This includes tools used to 
assign pay item information to 2D and 3D design elements, calculate quantities, and export quantity tables. 
This course also covers the Designer Interface Quantity Builder, used to generate an XML file compatible 
for upload to Designer Interface for AASHTOWare Project Preconstruction.
This course includes, but is not limited to the following: 

•	 Item Types
•	 Asset Manager
•	 Pay Items and Quantities
•	 Quantity Takeoff Manager
•	 Generating Summary Tables
•	 Summary Reports Builder 
•	 Estimated Quantities Report
•	 Exporting Data to Designer Interface

This training guide was developed with FDOTConnect10.12.  Any reference to FDOTConnect within this 
document should indicate either FDOTConnect10.12 or the currently supported FDOTConnect version

Objectives
Students will learn how to use FDOTConnect’s Quantity Takeoff Manager, Summary Reports Builder, and 
the Designer Interface Quantities Builder tools to draw, calculate, and document design quantities.

Audience
FDOT Designers and Engineers

Prerequisites
The following courses are required:

FDOT Roadway Design 3D Modeling and Roadway Design 2D Basics. Participants need to have a basic 
understanding of Computer Aided Drafting and Design (CADD) using MicroStation, a basic understanding 
of OpenRoads Designer concepts and a solid understanding of the engineering necessary to design a 
Roadway.
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1  INTRODUCTION

OBJECTIVES

Review the workflow and components of computing quantities.

•	 Define the Workflow for Project Quantities and Recommended Tools
•	 Requirements of Florida Department of Transportation (FDOT) 

DOCUMENT STYLE 
The following table shows the style conventions used throughout the course guide.

Item Convention Example

Menu names,  Commands, 
and Ribbon Navigation

Bold

(Names separated

with > symbol)

•	 General form is Workflow > Tab > Group > Tool

•	 File > Open

•	 File > Settings > User > Preferences

•	 OpenBridge Modeler > FDOT > Actions 
> Create File

Dialog actions Bold •	 Click the Apply button.

•	 Click the Graphic Select button to the right of 
the Horizontal Alignment Include box.

Dialog field names Italic •	 Key in Hemfield Road in the Alignment 
Name field.

•	 Click the Graphic Select button to the right of 
the Horizontal Alignment Include field.

Key-ins Bold •	 Key in Hemfield Road in the Alignment 
Name field.

File names Italic •	 Open the file Working Graphics.dgn in the
C:\Bentley Training\GEOPAK 101\Project Setup\
Practice\ folder.

File paths Not Italic or Bold •	 Open the file Working Graphics.dgn in the
C:\Bentley Training\GEOPAK 101\Project Setup\
Practice\ folder.
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AUTOMATED QUANTITIES WORKFLOW

Shown in the figure below, is a workflow that represents the process of creating and providing pay item 
quantities for FDOT projects. Bentley OpenRoads applications include an element property called an 
Item Type which can be used to define meta-data as a property of drawing and/or model elements. The 
FDOTConnect Workspace uses these Item Types to assign pay item information to those elements. Once 
the elements are drawn and pay items assigned to the Item Types, the Quantity Takeoff Manager (QTM) 
tool can then be used to compute quantities and export them to Excel Summary of Quantities Tables. For 
Tables which do not have Item Types or automated Tables defined for the quantities, QTM will also create 
a blank Excel Summary of Quantities Table that may be completed by the designer.

When all project Summary Tables are complete, the quantity information is then processed into PDF and 
XML format.  The Summary Reports Builder tool converts the data from the Excel Summary of Quantities 
Tables into the Estimated Quantities Report which is then submitted with the project.  The Designer Interface 
Quantities Builder tool converts the same data from the Excel Tables into an XML file which may be used to 
upload the quantity data through Designer Interface into AASHTOWare Project Preconstruction.

The Quantity Takeoff Manager, Summary Reports Builder, Designer Interface Quantities Builder, and all 
associated resource files were developed by the Production Support CADD Office for use with Bentley 
OpenRoads applications. Additional automation and process enhancements are expected, and the 
workflows documented herein are subject to change.

This document will focus mostly on the workflow for Roadway quantities.  Other disciplines, such as Drainage 
and Traffic Plans, will have similar processes that will be detailed further in their respective Training Guides.

 
FDOT STANDARDS
FDOT provides several resources to instruct and aid designers in processing pay item quantities. The 
Estimates Office publishes the Basis of Estimates Manual, the governing document that specifies how to 
compute each pay item. The Estimates Office also provides a Master Pay Item list containing every pay 
item available for use in Florida. The Production Support CADD Office provides resources and tools to 
simplify the process of generating quantities. Item Types for pay items are delivered in the FDOTConnect 
workspace and are defined in dgn libraries for Roadway and Drainage features, in application resources 
for the Traffic Plans tools, and may be applied through a template formatted for use with Bentley’s Asset 
Manager tool or directly from the Item Types tools. 

FDOT recommends the use of Civil Features for all linear feature drafting and 3D Modeling to ensure that 
each element is on the correct symbology and that the correct quantity Item Types are applied. The Roadway 
and Drainage features and Traffic Plans tools are pre-set to comply with drafting standards specified by 
the CADD Manual. The Item Types are used by Quantity Takeoff Manager which is configured to compute 
quantities based on the computation methods defined in the Basis of Estimates Manual.
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FDOT STANDARD FILES
Quantity information is stored in CADD files designated with one of three standard FDOT File Names, 
located in the appropriate discipline directory:

•	 DSGN** – for Linear/Each Features (where ** indicates the 2-letter characters for the discipline)

•	 MODLRD – for 3D modeled Linear/Area/Tonnage/Cubic Yard Features

•	 QTDSRD – for 2D Area/Tonnage/Cubic Yard Features that are not modeled and quantity references

The FDOT tool Create File available from the FDOT Ribbon creates these files. 
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2  ITEM TYPES

OBJECTIVES
•	 Introduce Item Types and Item Type Tools

•	 Explore the Item Types Dialog

•	 Set Item Types on Drawing Elements

ITEM TYPE BASICS
Much like AdHoc values in previous versions, Item Types in ORD are tags of meta information attached to 
a MicroStation element. For the Automated Quantities workflow, we will use the Item Types to apply pay 
item quantity information.

The Item Types tool group is in the OpenRoads Modeling Workflow > Utilities tab, and may also be found 
in the Drawing Workflow > Attach tab or Drawing Workflow > Content tab.

Item Types that are defined in dgn libraries or are active in the current dgn file may be accessed through 
the Item Types dialog. To open the Item Types dialog, click on the dialog fly-out button in the bottom right 
corner of the tool group.

If there are active Item Types in the file, the Library Resource (book icon) should display with a green 
checkmark, and the tool tip will indicate that “Local resource, matches library”.

If the Item Types in the file have been changed, or the dgn library has changed or been updated, the Library 
Resource will display with a blue triangle, and the tool tip will indicate “Local resource, differs from library”.
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To update the Item Types in the active file, select/highlight the Library Resource, and two tools that were 
previously grey will now be active.  You can choose to Show Differences, or Update from Library.

ITEM TYPES TOOLS
Item Types can be managed through the Item Types tools. They can be added or deleted, Pick Lists may 
be edited, and Item Types may be imported or exported to Excel files.

When an element is either not placed with a Civil Feature, or if it needs an additional Roadway or Drainage 
Item Type added, the Item Types > Attach Item tool may be used.

 
NOTE       In ORD 10.12, selecting property options or adding property values in the Attach Item 

dialog may cause the program to crash. To avoid this, attach the item, then set the Item 
Type properties in the Properties dialog.

If an Item Type needs to be removed from a given element, the Detach Item tool may be used to remove 
any individual Item Type or all Item Types from an element.  Only the items checked will be removed, any 
items that remain unchecked will remain attached to the element.
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Pick Lists may be created and managed through the Pick List tool and Item Types may be imported 
or exported to an Excel file if necessary. Editing Pick Lists or importing/exporting Item Types is only 
recommended in certain limited circumstances, since the automated quantity tools rely on specifically 
formatted FDOTConnect resource files.

 
Additional information on these tools may be found through Bentley’s Connect Advisor or Bentley Learn, or 
contact the Production Support CADD office for assistance.

ITEM TYPES FOR QUANTITIES 
FDOTConnect utilizes Item Types to assign data to elements that identify quantity pay item information 
to be used to compute and generate Summary Tables. Each Item Type consists of multiple fields called 
Property Definitions. Item Type Property Definitions will vary depending on the requirements of the pay 
item(s) and/or Summary Table they are designed for.

 

Item Types for Roadway and Drainage may have one or more Property Definitions that require selections 
from a Pick List to select a property that is pre-defined in resource files delivered with the FDOTConnect 
tools.  When the Property Definition is selected from a Pick List, the value may then be used in conjunction 
with lookup table resource files or defined expressions to populate other properties. If a Property Definition 
is grey, it is set by other property values and may not be directly edited. When viewing Item Types of 
elements in a referenced file, all properties will be grey and cannot be edited.

Other Property Definitions may be completed by typing values directly in the Property Definition field. 
These may be required to complete computations or to include information in the Summary Table. The 
ConstructionRemarks Property Definition should always be left blank by the designer and is intended only 
for As-Built remarks.

Any drawing element may have as many Item Types as necessary to define all pay items associated with 
that element.  However, each Item Type must have a unique name. An element cannot have the same 
Item Type applied more than one time. 
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CUSTOM ITEM TYPES FOR NON-STANDARD PAY ITEMS
Beginning with FDOTConnect10.12 automation for non-standard pay items is possible through the use of 
the new Summary Reports Manager and Pay Item Editor tools, which will be covered later in this guide.  
Since non-standard pay items are not included in the delivered Item Type resources, a Custom Item Type 
library template has been included along with the standard Item Types that is compatible with the FDOT 
automated quantities workflows. When needed, this library template should be copied and renamed based 
on the intended use, then edited to create project-specific Item Types.  Library and Item Type names should 
not include spaces or special characters, but may include “_” underscore characters.

Custom Item Types and Item Type Libraries are saved locally in the dgn in which they are created.  They 
are not saved to the FDOTConnect dgnlib resources.  Once created and saved in a local dgn, they may 
be imported into other dgn files, but use caution when importing item types between dgn files, as all item 
types within a dgn are brought through with an import operation and this may affect or overwrite other 
existing libraries.

NOTE  For advanced Item Type development not related to FDOT quantities, please  refer 
to the training and documentation provided by Bentley for OpenRoads Designer. 

Once the library is copied and renamed, the Item Type template can then be copied, renamed, and 
modified within the library to create new custom Item Types.  The template includes some of the basic 
properties commonly used in Item Types.  The PayItemNumber property is required for the quantities tools.  
Properties such as Lift, Width, and IsLumpSum are optional and depend on the requirements of the pay 
item, unit of measure, and Summary Table that the Item Type is intended for.  Item Type Property names 
must match the name format shown here or within other delivered quantity Item Types to be compatible 
with the quantities tools.
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For simplicity, and ease of troubleshooting, it is recommended to create individual Item Types for each 
non-standard pay item.  Custom Item Type names should reflect the name, or an abbreviated version of 
the name of the associated pay item.  Make sure to enter the pay item number in 10-digit BOE format in 
the Default Value property definition field of the PayItemNumber Item Type property.  Do not edit any other 
property definitions.

For pay items with dual units of measure that include LS (lump sum), the IsLumpSum Item Type property 
must be included, and the Default Value should be set to TRUE.

Changes must be saved, and the new custom Item Types may be attached to design elements, or appended 
to features within the local dgn.

DEFINING ITEM TYPES ASSIGNED FROM FEATURES
Civil Features are recommended for all linear feature drafting and 3D Modeling to ensure that each element 
is on the correct symbology and that the correct quantity Item Types are applied. The Roadway and Drainage 
Features are pre-set to comply with drafting standards specified by the CADD Manual. If additional Item 
Types are needed to fully define all pay items associated with an element, they may be applied manually 
with the Item Types tools or Asset Manager.

Most Item Types that are assigned with Features will need Property Definitions defined in the Item Type 
Properties. This can be done on individual elements, or with a selection set of elements having the 
same Item Type. 

Creating the selection set can be done in many different ways.  The Level Display or Explorer > 
OpenRoads Standards can be used to change the displayed elements to show only the elements having 
the same properties.
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The recommended method of selecting and working with Item Types is through the Explorer > Items in 
conjunction with the Properties Dialog.  If all the elements within the Item Type will not have the same 
definitions, the isolate option can be used to adjust the display to make it easier to create the selection set.

When the view is adjusted to easily create a selection set of all like-type elements, the Item Type should 
display in the Properties  dialog. If all elements in the selection set do not have the Item Type, it will not 
display in the properties.
 
Select the correct Type from the picklist to correspond to the design intent of the element. Once the Type is 
selected, the Property Definition for PayItemNumber and any other fields dependent on the Type selection 
will be populated from the resource files. Design Notes may also be added by typing in the Property 
Definition field.
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EXERCISE  2.1EXERCISE  2.1	   Setting Item Type Properties on 3D Meshes 

This exercise examines the mesh properties of 3D elements in model files and uses the Properties dialog 
to select and set the Item Type Property Definitions to match the design intent and set the appropriate 
pay item

1.	 From the desktop FDOTConnect folder, double-click on the FDOTConnect for OpenRoads Designer icon. 

2.	 Select the Custom Configuration option, set the Workspace to FDOT, and the WorkSet to 
22049555201.  Then click the Browse button and navigate to the project’s files.

3.	 Navigate to the C:\Worksets\FDOT\22049555201\Roadway\Training_Files\ Automated_Quantities\
Start\ directory folder.  Select all the files in this folder and right click and select copy. Navigate back 
to the C:\Worksets\FDOT\22049555201\Roadway folder, right click, select paste, and replace the 
current files. Then select and open the MODLRDDetail61.dgn file.

4.	 Long right-click in the current view to display the context menu. Select View Control > 2 Views 
Plan/3D. Adjust the window sizes and zoom as necessary to best display both views.



Automated Quantities 18

5.	 On the ribbon Home tab, in the Primary tool group, select Explorer, then Properties. You may dock 
these dialogs, if desired.

    
6.	 Click in the 3D view to make it the active view, then in the Explorer dialog, select the Items tab, then 

expand selections for CurbAndGutter.

7.	 Right-click the CurbAndGutter Item Type group and select Isolate.
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8.	 Select any curb mesh in the 3D view, then examine the properties displayed in the Properties 
dialog. Notice the Item Type property entry for CurbAndGutter. Some item types may already display 
CurbAndGutter properties that are assigned.  If, so, open the References dialog, and turn off the display 
of the MODLRDMainline61.dgn reference before step 10.

9.	 Click in the field for the Item Type Property DefinitionType and examine the drop-down pick list.  (If 
the pick list selection group is blank, open the Item Types dialog and verify that the “resource matches 
library” as shown in the Item Type Basics section of this chapter.)

10.	 In the 3D view, create a selection set of the curb meshes. The properties should display five elements 
with a Type F Feature. Click on the CurbTypeEIn element in the property list, then in the CurbAndGutter 
Item Type properties select Type E from the pick list for the Type property definition. This sets the 
property definition of the Item Type for that element in the selection set. Notice that when the property 
definition Type is set, the PayItemNumber and Width property definitions are populated with the 
correct pay item number and the design width of the curb type selected. These property definitions are 
populated from a separate resource file and cannot be modified in the Item Type.
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11.	Clear the selection set, then right-click on any Item Type or group in the Explorer and select 
Clear Isolate.

12.	 In the Explorer > Items dialog, select the ACFrictionCourse Item Type group, right-click, and select 
Isolate. Notice that there are no elements displayed.  Even though the Explorer recognizes and lists 
the item types that are included in the reference file, they cannot be modified from this file.  Select any 
Item Type in Explorer, right click and select Clear Isolate.

13.	Clear the selection set and select the Explorer > Items SuperpaveAsphalticConcrete Item Type group 
and examine the properties.  Notice in the Properties dialog that the only property shown is the Item 
Type, not the element properties.  The Item Type property definitions for all the elements with that Item 
Type may be applied by selecting it in this way, without using the Isolate option, if no additional QC 
check is needed and no additional modifications are needed to adjust the selection set of the elements 
included (i.e., all the elements within that Item Type are assigned the same Type/pay item number).

14.	 In the SuperpaveAsphalticConcrete Item Type property definition for Type select the pick list entry for 
Traffic B pg 76-22. This sets the Item Type for all elements in the selection set/Item Type group. Verify 
that the pay item number is populated. Notice that there is a property definition for Lift. This property 
definition is only needed when the Item Type is applied to a 2D element and a numerical thickness 
value in decimal inches is required to compute the quantity. When applied to a 3D mesh, the 3D volume 
is used to compute the quantity and the Lift value is ignored.  Even though it won’t affect the calculation 
here, to ensure that the Item Type properties match the 3D mesh design, enter 2.25 in the Lift property 
definition field.

NOTE    The property definition name was changed from “Thickness” to “Lift” in FDOTConnect 
10.09.01.01 due to a conflict with Bentley element property names. If the Item Type contains 
a property called “Thickness” and is opened in the current version of FDOTConnect, the 
Item Type library will need to be updated to match the delivered dgnlib.
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15.	Repeat the above steps to set the Item Type property definitions for Type as follows: 

EarthworkCut – Regular Excavation
EarthworkFill – Embankment

NOTE      If the earthwork meshes do not display, make sure the view attributes for constructions are 
turned on in the 3D view, as earthwork meshes are on a construction level.

PavementBase – Optional Base Group 6
PerformanceTurf – Performance Turf Sod
SidewalkDetectableWarnings – 4” Conc SW
TrafficSeparators  – Type I 4’ Wide Opt 1 

NOTE      Traffic Separator that is placed with a corridor template displays as a single element, 
even though it stops and restarts along the corridor. The quantities tools will report the 
true quantity/length of the segments but will only give a single line item with the begin 
station of the first segment and end station of the last segment. This may be corrected in 
future versions of ORD, but in the current release, to report separate quantities for each 
segment requires creating separate template drops for each segment. 

 
16.	 Right-click on any Item Type or group and Clear Isolate if needed. Save settings.
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EXERCISE  2.2    EXERCISE  2.2    Setting Item Type Properties on 2D Elements placed with Features
 
This exercise will use the Geometry > Offsets and Tapers tool with the Guardrail Feature active to place 
a segment of Guardrail in the DSGNRD file, then utilize the Properties and Item Types tools to set the 
Property Definitions for the primary Item Type and place a secondary Item Type for a Pipe Rail on the 
same element.

NOTE      This project location does not require guardrail. Guardrail placement is for training 
demonstration purposes only.

1.	 Navigate to the C:\Worksets\FDOT\22049555201\Roadway directory folder and locate the 
DSGNRD01.dgn. (This file should have been replaced in Step 3 of the previous exercise.).

2.	 Fit view then zoom in to the intersection.  Rotate the view and zoom to the upper left quadrant of the 
intersection as shown below.

3.	 On the OpenRoads Modeling > Geometry tab, locate the Horizontal tool group and use the Offsets 
and Tapers tool set to Single Offset Entire Element.

4.	 In the dialog, set the Offset to 2.00 and set the Feature Definition to Linear > Roadway Design > Plan/
Profile 2D Lines > Guardrail > WBeam General TL 3 Right. 

5.	 Locate the edge of pavement EOPA arc and select it to offset. Drag the cursor to the outside of the 
pavement and data point/left click to accept each of the settings.
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6.	 Repeat the process with the EOPA line to the left of the intersection along the US98 corridor as shown 
below. (You may need to change the feature to WBeam General TL 3 Left.  The guardrail side selected 
and the direction in which the reference line was placed affects which side of the line the posts are 
placed on.)

7.	 Create a selection set of the two segments of guardrail line and examine the properties. Set the 
Guardrail Type to W-Beam General TL-3.

8.	 With the selection set still active, on the OpenRoads Modeling > Utilities > Item Types tool group, 
select Attach Item.
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9.	 In the Attach Item dialog, In the Item Types section, select Roadway Quantities > PipeRail and data 
point/left click in the default view to accept and set the Item Type.

10.	 Select the two guardrail lines again and examine the properties to verify that both Item Types are attached.

 
 
 
 
 



Automated Quantities 25

ASSET MANAGER
Because FDOT’s Summary of Quantities Reports must include location information in addition to pay 
items, the FDOTConnect quantities workflow utilizes Bentley’s Asset Manager (technology preview) tools 
and resources to assign item project-specific Item Types. These Item Types are attached to elements to 
identify the alignment that should be used to provide station and offset location values for each element 
to be quantified.

When a new project is created with FDOTConnect , an Asset Manager template is copied to the project’s 
Symbology folder.  This file is named FDOTProject.xlsm. If the file is not found, it may be copied from the 
FDOTConnect10.12 \Organization-Civil\FDOT\Asset Manager folder to the project Symbology folder.

This file may be edited to add the alignment names for the project in the _Pick List Definitions worksheet 
tab. Each alignment name should be added to the Alignment row and the name should match the alignment 
Feature name exactly. When the Alignment Item Type is placed with Asset Manager, this defines the 
contents of the Pick List selection.

For projects which have multiple funding sources (also known as sequencing), the sequenced Financial 
Project numbers may also be defined in this file and the FPID Item Type applied with Asset Manager. 
When FPID Item Types are attached, the quantity tools are designed to create separate summary tables for 
each FPID specified as directed in the Basis of Estimates Manual, Chapter 8.  If there is no sequencing on 
a project, the FPID Item Type is not used.

Each row in the _Pick List Definitions worksheet defines a selection pick list for the associated Item 
Type. The values in the Alignment row do not correspond to the items in the FPID row. 

The Asset Manager tool may be found in the Utilities > Item Types tool group.
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In the Asset Manager Dialog, select the Open Asset Definitions File button and navigate to the project 
Symbology > FDOTProject.xlsm file and click Open. The left pane should populate with FDOTProject and 
have selections for Alignment and FPID. Check the applicable box(es) under FDOTProject, then in the 
Elements section click the option for Selection Set, and finally set the Assignment Mode to Add. 

This may be used to apply and set the values for the Alignment and/or FPID Item Types to any or all quantity 
elements in a file at one time. Create a selection set of the quantity elements in the design file, then click 
Add Assets and close Asset Manager. While the selection set is still active, view the Properties  of 
the selection set. In the Alignment Item Type, click in the property definition field for Alignment and set the 
desired value from the pick list. Follow the same process for FPID if a funding sequence FPID is needed.

NOTE    For elements placed with the Traffic Tools, that already have an Alignment Property Definition 
in the Item Type, DO NOT apply the Alignment Item Type with Asset Manager.  This creates 
a conflict and will keep the location data from appearing in the Summary Table.
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EXERCISE  2.3EXERCISE  2.3	Placing and Setting the Alignment Item Type with Asset Manager

This exercise will use the FDOTProject.xlsm file to define the alignment names to match the alignment 
Feature names for use with Asset Manager. Then Asset Manager will be used to apply the Alignment Item 
Type to a selection set of quantity elements. Finally, the same selection set may be used to set the Item 
Type Property Definition through the Properties dialog.

1.	 Navigate to the C:\Worksets\FDOT\22049555201\Symbology\Training_Files\Automated_Quantities_
Start\ directory folder and locate the FDOTProject.xlsm file.  Right click and select copy, then navigate 
to the C:\Worksets\FDOT\22049555201\Symbology folder, right click and select paste.  Then select 
and open the FDOTProject.xlsm file. 

2.	 In the _Pick List Definitions worksheet tab, add the values for the project’s alignments as shown below. 
These values must exactly match the Feature names of the alignments in the project.

3.	 Once the values have been added, Save and Close the file.

4.	 Continuing in the DSGNRD01.dgn file (C:\Worksets\FDOT\22049555201Roadway\), on the Utilities > 
Item Types tool group, select Asset Manager.

5.	 In the Asset Manager dialog, select Open Asset Definitions File and navigate to the FDOTProject.
xlsx file in the project Symbology folder, and click Open.
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6.	 Adjust the settings in the Asset Manager dialog as shown below.

7.	 In the DSGNRD01.dgn View 1, create a selection set of the two guardrail lines created in the 
previous exercise.

8.	 Once the selection set is created, in the Asset Manager Dialog, Click Add Assets.

9.	 Examine the properties of the selection set. There should be an additional Item Type for Alignment. The 
properties groups in this dialog can be collapsed or expanded  and you can drag any of the Item Types 
or property groups up or down in the Properties dialog to adjust the list view.
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10.	Clear the selection set.

11.	 Select the arc segment of the guardrail and set the Alignment property definition to CL_SR61.

12.	Select the line segment of the guardrail and set the Alignment property definition to US98.

13.	Open the MODLRDMainLine61.dgn file in the C:\Worksets\FDOT\22049555201\Roadway\ directory 
folder from Exercise 2.1.

14.	 In the Explorer dialog, with the 3D view active, select the Items tab, then hold the control key and 
select all the Item Type groups that were set in the previous Exercise. Right click and select Isolate. 
This should display all of the elements in the View 2, Default-3D view that have pay items assigned in 
their Item Types.

15.	Create a selection set of all the elements displayed in the 3D view.

16.	Open the Asset Manager dialog and verify that the FDOTProject definitions file is still attached and 
the settings are correct. Click Add Assets to add the Alignment Item Type to all elements in the 
selection set.

17.	With the selection set still active, in the Properties dialog, set the Alignment Item Type to CL_SR61.

 
 
ITEM TYPES FOR 2D SHAPES
When there are area or volume quantities that need to be defined, calculated, and reported and they are 
not included in the 3D model, we can still compute those areas from 2D shapes. The QTDSRD is the file 
used to create the shapes required to calculate 2D area/volume quantities. FDOT recommends the use of 
models within this file instead of creating a separate DGN file for each pay item and its shapes. Each model 
is named using the pay item number, BOE 10-digit format or with the use of dashes. Each model should 
have the Alignment, Design, and Survey files referenced. These references assist with the creation of the 
shapes needed as well as to provide helpful information for Construction personnel who need to access 
this file. Do not create shapes for all the 2D area/volume quantities in one model. This makes it difficult for 
Construction to locate the shapes they need to verify.

HINT     To save time, set up the default model with the desired references, and then copy this model 
to create the additional models needed for the pay item shapes.
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EXERCISE  2.4EXERCISE  2.4	   Placing and Setting Item Types on 2D Shapes

This exercise will create a new QTDSRD file and apply pay item and Alignment Item Types to area shapes.

1.	 Continuing from the previous exercise, in the OpenRoads Modeling > FDOT > Actions tool group, 
select Create File and select the QTDSRD file with the settings shown below, overwriting the File 
Sequence # with 01. Click Create - Open File and replace the existing QTDSRD01.dgn file.

2.	 In the Default model of the QTDSRD01.dgn file, in the OpenRoads Modeling > Home > Primary 
tool group, open the Attach Tools > References dialog.
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3.	 From the References dialog, select Attach Reference. From the …\22049555201\Roadway\ 
directory folder, attach the ALGNRD01 and DSGNRD01 files, and from the …\22049555201\Survey\ 
directory folder, attach the SURVRD01 file as shown below.

4.	 In the view tools, select Fit View, then in the Quick Access toolbar, select Save Settings (or press 
Ctrl-F).

5.	 In the OpenRoads Modeling > Home > Primary tool group, open the Models dialog, then select the 
Default Model and select Copy.

6.	 Change the Name to “0110 [space][space] 4 [space] 10” (to match the BOE format) and set the 
Description to “Removal of Existing Concrete” as shown below. Click OK.
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7.	 In the 0110  4 10 model, zoom to the intersection of the old and new SR61 roads.

8.	 On the right side of the roadway, locate the existing planters referenced from the Survey file. For the 
purposes of this exercise, we will assume that the planters are concrete that needs to be removed 
for the new roadway. Create a selection set of the 6 rectangular planter shapes and copy them into 
the active file. (Long right click for the context menu and select Copy or locate the Copy tool in the 
OpenRoads Modeling > Drawing > Manipulate tool group.)

9.	 Once the shapes are copied, turn off the Reference displays of the DSGNRD and SURVRD files.

10.	 In the OpenRoads Modeling > Drawing > Groups tool group, select Create Region.
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1.	 In the Drawing > Attributes tool group, set the Level to ConcreteRemoval.

2.	 Set the Create Region tool to Fill, with a Fill Type of Opaque and do not check Keep Original. This will 
remove the copied shape/level and replace it with the new shape on the ConcreteRemoval level.

3.	 Data point/left click twice inside each of the 6 planter shapes to create the new concrete shapes.

4.	 Create a selection set of the 6 concrete shapes. In the OpenRoads Modeling > Utilities > Item Types 
tool group, select Attach Item.

5.	 In the Attach Item dialog, select the Item Type Roadway Quantities > ClearingGrubbingRemoval, 
then left click twice in the drawing to accept the selection.

NOTE      In ORD 10.12, selecting property options or adding property values in the Attach Item 
dialog may cause the program to crash. To avoid this, attach the item, then set the Item 
Type properties in the Properties dialog.
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16.	Open Asset Manager, attach the Alignment Item Type to the selection set as shown in the previous 
exercise.  Using the Properties dialog, set the Item Type property definitions to Removal of Existing 
Concrete and CL_SR61 as shown below. 

17.	Save settings.
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LOCATING AND TROUBLESHOOTING ITEM TYPES
To ensure that all elements have the required Item Types, and that all Item Types are set with the correct pay 
item information, being able to locate and identify elements that need attention is important. As discussed in 
previous sections, using the Level Display and Explorer feature definitions display, along with the element 
properties are ways that allow us to isolate and examine elements. However, checking the properties on 
each individual element can be tedious and time consuming.

If elements have been placed with features and already have Item Types attached, but not yet set, The 
Explorer > Items tab can be helpful to view and isolate groups of Item Types or individual Item Types.

If you need to view a subset within an Item Type, the Advanced Search is a very helpful tool.  The launch 
icon for this tool is located at the end of the search bar in the Explorer dialog box.

To create a search, select the Item Type in the Search For picklist, then set the parameters that will narrow 
the selection.  In the Where section, select the Item Type Property Definition from the picklist, then set the 
rule for what parts to include, then set the value to search for.  In the example below, the search is within 
Curb and Gutter to include only the elements where the Item Type’s pay item number is equal to 0520  1  7.  
Be sure to click Add to Search so the parameters appear in the Search Summary window of the dialog.  
Then select OK to complete the search.  The search results will appear at the bottom of the Item Types List 
in the Explorer > Items dialog.



Automated Quantities 36

If the Summary Table shows an element that is missing location data, or needs to be reviewed for accuracy, 
and the Element ID is known, the Select Element by ID tool is a quick way to locate any element. The 
tool may be found in the OpenRoads Modeling > FDOT > Actions > Misc. Tools > Select Element by 
ID. You must have focus in/activate the correct view for the element (2D or 3D), then select the tool, enter 
the Element ID# and click Find. The element will highlight, and the properties of the element will show in 
the Properties dialog.  Once the element is located, be sure to close the Select Element by ID dialog to 
continue examining the element, or before starting any other command.

 

NOTE     If you have multiple files referenced, it is possible for the same element ID to exist in 
different files and this could cause the tool to find the wrong element or malfunction. 
If this occurs, you may need to re-try the search in each of the referenced files that the 
element might be in.

NOTE      The Select Element by ID tool may not display element properties in FDOTConnect 
10.12.01.00, but has been fixed in version 10.12.02.00 and newer.
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EXERCISE  2.5EXERCISE  2.5	Locating Item Types with Explorer and by Element ID

This exercise will use the Explorer Items tab to select and isolate groups of Item Types. Then the Select 
Element by ID tool will be used to locate an element within the drawing and examine the Properties and 
Item Types of that element.

1.	 Open the MODLRDMainline61.dgn file in the C:\Worksets\FDOT\22049555201\Roadway\ 
directory folder.

2.	 Maximize the 3D view, Fit View and zoom to the corridor.

3.	 In the Explorer dialog, select the Items tab, and examine the Item Type groups.

4.	 Click on any Item Type group. Review the properties. In the Properties dialog, click through any of the 
elements within the Item Type group and examine the property definitions of the Item Type.

5.	 In the Explorer dialog, right-click any Item Type group, then select Isolate. Notice that the display turns 
off everything except the group selected. Right click again and select Clear Isolate to return the display 
to its previous state.

7.	 In the Explorer dialog, locate the Advanced Search option and select it.  In the Advanced Search 
dialog, set the parameters as shown below, making sure to select Add to Search so the parameters 
show in the Search Summary, then click OK to perform the search.

6.	 Long right-click in the current view to display the context menu. Select View Control > 2 Views Plan/3D. 
Adjust the window sizes and zoom as necessary to best display both views.

7.	 In the Default 2D view, open the References dialog and turn on the display for MODLRDMainline61.dgn 
Default 3D model. This should display the 3D shapes in the 2D view.

8.	 In the OpenRoads Modeling > FDOT > Actions tool group use the pull-down to select Misc. Tools > 
Select Element by ID.

9.	 Enter “2022” then click Find. Examine the highlighted mesh.
10.	Close the Select Element by ID dialog.

11.	 In the Properties dialog, right-click on the ObjectSettingsRule element and select Isolate.

12.	Click on the highlighted pavement element in the 2D view and review the properties.

13.	Right-click on the LT_Pavement FC Outside element and select Clear Isolate.
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3  SUMMARY TABLES

OBJECTIVES
•	 Set up the project reference QTDSRD file
•	 Explore the Quantity Takeoff Manager
•	 Create and examine the Summary of Quantities table Excel files

QUANTITY REFERENCE FILE
Since Item Types must be assigned to each element in its active file, we may have quantity information that 
is required for a single table in many different design files. For the FDOTConnect quantities workflow, we 
will utilize the QTDSRD file to provide a design file in which to reference all the Roadway quantity data to 
a single location. Note, other design components (i.e., Drainage, Signing & Pavement Marking, etc.) may 
generate their quantities directly from their design files if all quantity information needed for the component 
Summary of Quantities table is located in or referenced to a single model.

The combined reference model can be included in the same QTDSRD file as any 2D area/volume models, 
or it can be in a separate QTDSRD intended only for the quantity references. Whichever file is used, the 
combined reference model should be clearly labeled so it can easily be located by reviewers or Construction.

EXERCISE  3.1EXERCISE  3.1	Creating the Reference QTDSRD

This exercise will create a QTDSRD file that includes references of all 2D and 3D Roadway design files and 
models that contain quantity Item Types.

1.	 Continuing from the previous exercise, in the OpenRoads Modeling > FDOT > Actions tool group, 
select Create Fileand select the QTDSRD file. Notice that the File Sequence # has incremented. Verify 
that the output settings are correct, then click Create - Open File. Set the File Sequence # to 02.

2.	 Navigate to the C:\Worksets\FDOT\22049555201\Roadway\Training_Files\ Automated_Quantities\
Complete\ directory folder.  Select the QTDSRD01.dgn, right click, and select copy. Navigate back 
to the C:\Worksets\FDOT\22049555201\Roadway folder, right click, select paste, and replace the 
current file. (This file contains additional quantity shape models to be used in this exercise.) 

3.	 In the OpenRoads Modeling > Home > Primary tool group, open the Attach Tools > References 
dialog.

4.	 From the References dialog, select Attach Reference and attach the files as shown in the image 
below. Make sure to attach both 2D and 3D models of each of the MODLRD files and all pay item 
models of and replace the existing QTDSRD02.dgn file. Notice that the GDTMRD file is in the project’s 
Survey folder.
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5.	 Locate the terrain outline, right click - hold for the context menu and select Set as Active Terrain Model.

6.	 Right click and hold anywhere in the Default view for the context menu and select View Control > 2 
Views Plan/3D, Fit View in the Default and 3D views, and save settings (Ctrl-F).

 
QUANTITY TAKEOFF MANAGER
Quantity Takeoff Manager is an application created by the FDOT Production Support CADD office for use 
with FDOTConnect for OpenRoads Designer. This tool generates formatted Excel Summary Tables for all 
Summary of Quantities that may be included on a project. For select tables, it also harvests information 
from elements in CADD files including Item Types, Element Properties, and alignment location data, and 
computes and exports that data to Auto-Populated Summary Tables.

The Alignment Options selector may be used to generate tables based on any individual alignment, or all 
alignments. Since Summary Tables should contain all the quantity data from all alignments on a project, it 
is recommended to leave the Alignment Options set to All.

The Summary Tables section contains a list of all Summary Tables that can be on a project. All project 
Summary Tables should be created using this tool. Dark/highlighted items indicate tables which may be 
auto-populated from the design file element properties and Item Types. Non highlighted items are tables 
that, once created by the tool, must then be completed by the designer.

Summary Tables may be selected individually, all, none, or invert the current selection with the selection 
buttons, or multiple tables selected individually by holding the Ctrl key while selecting.

The Output Options > File Output Location should default to the project Calculations folder. If it does not, 
or if sub-folders are used, the path may be redirected as needed using the browse button . 

All Summary Table Excel files from all project components should be stored in the Calculations folder. Sub-
folders may be used if necessary, but all files required for the Estimated Quantities Report must be in the 
same folder.
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Since most quantities will be reported from reference files, the checkbox for Include External References 
should always be checked/selected.

If Open Output File(s) is selected, each Excel file created will open a new instance of Excel. If a large 
number of tables are selected to compute at one time, it is not recommended to leave this option checked.

The Compute button will generate the Summary Table for the selected items. The Create PDF button 
launches the Summary Reports Builder that creates the Estimated Quantities Report. This tool will be 
discussed further in the next chapter. The Close button will close the application.

EXERCISE  3.2EXERCISE  3.2	Creating Summary Tables 

This exercise will create an auto-populated Summary of Pavement.

1.	 Continuing from the previous Exercise, in the QTDSRD02.dgn file, make sure that the Default 2D 
model is active, then on the OpenRoads Modeling > FDOT tab, select the Quantities > Takeoff 
Manager tool.

2.	 In the Takeoff Manager dialog, examine the Alignment Options to verify that the project’s alignments 
are included in the pull-down list. Leave the selection set to All.

3.	 Click on and highlight the Summary Table Summary of Pavement.

4.	 Verify that the File Output Location displays the path to the project’s Calculations folder and that Include 
External References and Open Output File(s) are checked.

5.	 Click Compute, then examine the Excel file.  Verify that the Summary of Pavement has the appropriate 
pay item data.

6.	 Close the Excel file.
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SUMMARY TABLES
With the introduction of FDOTConnect for OpenRoads Designer, the format of the Summary Tables has been 
modified from previous platforms. The Summary Tables are all generated from a single master template 
and follow a consistent format that always has Pay Item Definition information, followed by Quantity Values, 
Location Information, then Notes and Remarks. The format is not only important for consistency across 
Summary Tables, it is also critical for the generation of the Estimated Quantities Report.

When Summary Tables are edited by the designer, there are some important rules to keep in mind to 
ensure that the Summary Table will be compatible with the Summary Reports Builder tool to create the 
Estimated Quantities Report: 

IMPORTANT RULES FOR SUMMARY TABLES
1.	 Do not add, delete, move, or change any columns within the table.

2.	 Do not leave any blank rows in the table. Each row must have a value in the Quantity “P” column or the 
Secondary Quantity “P” column, or the row will be considered the end of the file by Summary Reports 
Builder and any data below that row will be ignored.

3.	 Supporting documentation may be kept in the same Excel file as long as a different worksheet/tab 
name is used. Any worksheet not named in “Sheet#” format will be ignored by the Summary Reports 
Builder and will not be included in the final Estimated Quantities Report.

4.	 Changes in column widths, word wrapping, and text format in the Excel file will not be carried through 
to the Estimated Quantities Report. The data is read, processed, and reformatted into PDF form by the 
Summary Reports Builder. Because of this, word wrapping and page breaks may occur at different 
locations in the PDF than what is seen in the Excel file.

5.	 Any data that is copied from another document should be pasted as “values” so that the formatting of 
the Summary Table is not altered.

6.	 All quantity values should be entered with the correct rounded precision as defined in the BOE Chapter 
2. Proposed quantities should be rounded to one additional significant digit, and Total quantities should 
be rounded to the precision shown in BOE 2.1. 

NOTE	 Using the Excel cell format to apply rounding will not carry through correctly to the 
PDF, as the Summary Reports Builder tool reads the cell values directly and does not 
honor the Excel cell rounding formats.

7.	 Do not change the name of the Summary Table Excel file. The Summary Reports Builder will only 
include files with names exactly matching the definitions in the Quantity Takeoff Manager. The only 
exception is that a suffix may be added when a funding sequence FPID or Structure number is needed.  
In that case, the original filename and table header may be appended with space dash space and either 
the FPID or structure number (i.e. Summary of Structure Quantities - 123456.xlsx).

8.	 Once a file has been edited, use caution not to create the same table with Quantity Takeoff Manager, 
or the file will be overwritten, and the data lost. If a new table must be created and the existing data 
preserved, make sure to save the existing file to a different location before creating the new file.
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QUANTITY TOOLS FOR NON-STANDARD PAY ITEMS
While there are some Summary Tables that are not automated, there are instances where a pay item is not 
yet automated, or there is a non-standard or project-specific pay item needed for an automated table that 
is not included in the FDOTConnect resources. Since the delivered FDOTConnect resources should not 
be modified by designers, the CADD office has developed some new tools and recommended workflows 
to assist with populating Summary Tables that contain pay items that are not defined in the delivered 
FDOTConnect workspace. Extra caution should be used when implementing these workflows to ensure 
that the pay items and quantities reported are valid and appropriate for the project.

For any valid, open pay item (see the BOE/DQE) that is not currently defined in the FDOTConnect 
workspace, follow the steps below:

1.	 Identify the elements that will represent the non-standard pay item.

2.	 Copy and rename the CustomItemTypes Item Type library as shown in Chapter 2.  Then copy and 
rename the FDOTItemTypeTemplate and define the pay item for each custom pay item Item Type 
needed on the project.

3.	 If the elements to be quantified are 3D meshes, apply the new custom Item Type to each mesh.  
Otherwise, create a model in the QTDSRD that will contain the 2D shape elements for that pay item 
number as shown in Exercise 2.4 and attach the new custom Item Type and alignment Item Type.

4.	 If the pay item number to be quantified was valid and open within the BOE/DQE prior to the most recent 
FDOTConnect release, use the Summary Reports Manager (see below) to add the pay item number to 
a local/project Summary Reports Definition for the Summary Table the pay item belongs to.  (Refer to 
the BOE/DQE “Plan Summary Box” section for applicable Table(s)).

5.	 If the pay item is new, or newly opened, since the most recent FDOTConnect release, in addition to 
adding the pay item to the project Summary Reports Definition as described above, use the Pay Item 
Editor to add a local/project compute method definition (see below).  This tool/step should ONLY be 
needed if the pay item was not active/open/valid at the time of the latest FDOTConnect release.

SUMMARY REPORTS MANAGER
When launched, the Summary Reports Manager displays the currently defined report definitions, including 
report names, Group Id, Pay Item numbers, and Report Columns.  In default mode (Admin is for FDOT 
use only), the only field that is able to be modified is the Pay Items group, and only new pay items can be 
added to the bottom of the list.  The summarized box may only be checked on for items such as reflective 
pavement markers or light poles that are allowed to be shown in the summary tables as a single line item 
with a summarized total.

Once pay items are added to the correct Summary Reports, selecting Save writes a supplemental report 
definition to the _Meta_Info folder in the active FDOT project folder structure.  The Quantity Takeoff 
Manager will then include this data with the FDOTConnect resources to add the defined pay items in the 
correct Summary Tables.

NOTE       Since the project specific resources are saved to the project’s _Meta_Info folder and must 
be read by the Quantity Takeoff Manager, if the Takeoff Manager’s Output File Location 
path does not automatically show up in green when the tool is launched, the tool cannot 
locate your project and will not be able to load the project specific resources.
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PAY ITEM EDITOR
The Pay Item Editor is used to assign a definition and computation formula to a new pay item number 
that is not already defined in the FDOTConnect resources. When in default mode (Admin is for FDOT use 
only), it writes a local project specific file that defines the pay item number, definition, and units of measure, 
which must match the BOE/DQE format exactly (except the Description may be in mixed case text).  The 
Group Id can remain 0200 – Roadway, then the compute methods for 2D (and 3D if required), must be 
assigned and can be selected from pre-defined options, or manually entered if the correct formatting 
syntax is used.

Once defined, click Add to add the new pay items to the Project Specific Pay Items list below. Selecting 
Save writes a supplemental Project Specific Pay Items file to the _meta_info folder in the active FDOT 
project folder structure.  The Quantity Takeoff Manager will then read this data in conjunction with the 
project specific Summary Reports Definitions and the FDOTConnect resources to compute the defined 
pay items quantities.
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EXERCISE  3.3EXERCISE  3.3	Working With Project Specific Pay Items (Optional)

This exercise will create a hypothetical Project Specific Item Type, Report Definition, and custom pay 
item definition.

1.	 Open the QTDSRD01.dgn created in Exercise 2.4 (C:\Worksets\FDOT\22049555201\Roadway\).

2.	 In the OpenRoads Modeling > Home > Primary tool group, open the Models dialog, then select the 
Default Model and select Copy.

3.	 Change the Name to “0123 [space] [space] 4 [space] 56” (to match the BOE format style) and set the 
Description to “CADD Quantities Training Example” as shown below. Click OK.

4.	 Adjust the display to turn off the Survey and Alignment reference displays and rotate the view to display 
the intersection as shown below.
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5.	 On the Drawing > Groups tool group, select the Create Region tool.  For this example, you can leave 
the level set to ConstLines, but when creating quantity shapes, be sure to set the level to an appropriate 
level symbology for the item being quantified before creating quantity shapes.

6.	 Click twice in the enclosed area defined by the PavtMilling lines as shown to create a shape to 
quantify.

7.	 On the Utilities Ribbon, in the Item Types Tool Group, locate the flyout arrow in the bottom right corner 
of the tool group and launch the Item Types dialog.

8.	 Locate the CustomItemTypes library, right-click, and select Copy, then right-click again and select 
Paste.

9.	 Right-click and rename the copy of the library to “QuantitiesTraining”.

10.	Click the arrow to expand the new library, then select, right-click, Copy the FDOTItemTypeTemplate, 
right-click again and select Paste.

11.	 Rename the Item Type template copy to “QuantityExample”.

12.	Expand the QuantityExample Item Type, select PayItemNumber, then fill in the Default Value Property 
Definition with 0123  4 56, being sure to use the correct spacing for the pay item format.
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13.	Click the Save button in the upper left corner of the Item Types dialog box and close the dialog.

14.	Select the new ConstLines shape in the 2D view, then select the Utilities > Attach Item dialog and 
navigate to and select the QuantitiesTraining > QuantityExample Item Type.

15.	Also expand the FDOTProject library and check the Alignment Item Type.

16.	Left-click/data point in the 2D view to accept and attach the item type to the shape.

17.	Open the Properties dialog box and examine the shape properties. Examine the Item Type properties 
and set the Alignment Item Type property to US98.
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18.	Select the FDOT Ribbon > Quantities > Quantities Tools > Summary Reports Manager.

19.	 In the Summary Reports Manager dialog, select the Summary of Driveway Base, then click in the 
next empty row of the Number field of the Pay Items column and type the 0123  4 56 pay item number 
and click Save.

20.	Click OK in the successful save dialog box.  This has saved the project specific report definition in the 
-Meta_Info folder of the active project. Close the Summary Reports Manager dialog.

21.	Select the FDOT Ribbon > Quantities > Quantities Tools > Pay Item Editor.

22.	Enter the the 0123  4 56 pay item in the Pay Item ID section, and CADD Quantities Training 
Example in the Pay Item Description section.  Select 0020 – Roadway in the Group Id picklist.

23.	Examine the options within the Unit of Measure picklist, and the Compute Method / Compute Method 
3D picklists for different units of measure.
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24.	Select the SY unit of measure.  Notice that the Compute Method, Compute Method 3D, and Compute 
Method Description all set to the default definitions for that unit of measure.  If other computation 
methods are defined, they will be available in their respective picklists.  (If the pre-defined formulas do 
not apply to the project specific pay item, please contact the CADD office for guidance on the formatting 
and syntax to create a new compute method.)

25.	Select Save, then Close the Pay Item Editor.

26.	Open the References dialog, and turn the alignment display on.

27.	Launch the Quantities > Takeoff Manager and select the Summary of Driveway Base, verify that 
the output location is correct and the Include External References and Open Output File(s) options 
are checked.

28.	Click Compute.

29.	Examine the Summary of Driveway Base Excel file that contains the newly created pay item 
definition and quantity.

30.	Close the Excel file.
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4  ESTIMATED QUANTITIES REPORT

OBJECTIVES
•	 Examine the Summary Reports Builder Application

•	 Set up the Estimated Quantities Report Signature Page

•	 Create and examine the Estimated Quantities Report

SUMMARY REPORT BUILDER
The Summary Report Builder is an application created by the FDOT Production Support CADD office 
for use with FDOTConnect for OpenRoads Designer. This tool generates the Estimated Quantities 
Report from the Summary of Quantities Excel files generated for all project components by the Quantity 
Takeoff Manager. This application may be accessed either from the Create PDF button within Quantity 
Takeoff Manager, or from a standalone icon delivered in the desktop FDOTConnect workspace folder.

When accessed from within Quantity Takeoff Manager, the input and output directories are set by default 
to the Calculations and Estimates folders of the project, respectively. When opened from the Desktop folder 
icon, the folder paths to the project must be set to the correct project locations using the browse buttons .

The Input Directory should be set to the Calculations folder, where all the Project Summary Table Excel files 
are to be kept. When this path is set, all Excel files in the folder with valid Summary Table names should be 
displayed in the Excel Summary Table Files window.

The PDF Output Directory should always be the Project Estimates folder, where the Estimated Quantities 
Report should be kept.
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The Excel Summary Tables to be included in the PDF may be selected individually selecting the checkboxes, 
or by using the selection buttons in the bottom left corner of the dialog box. The checkbox for open output 
file may be selected to open the Estimated Quantities Report once its created. Once the selections are set, 
click Create to generate the Estimated Quantities Report.

ESTIMATED QUANTITIES REPORT SIGNATURE PAGE
The Estimated Quantities Report requires a signature page that identifies the Project and Engineer of 
Record date as shown in FDM 902. The FDOTConnect workspace delivers an Excel template for this page 
that must be completed outside of Quantity Takeoff Manager since it does not match the format of the 
Summary Tables. On new project the template should be in the Project Calculations folder. If the file does 
not appear, it may be copied from the FDOTConnect \Organization-Civil\FDOT\Asset Manager folder to the 
Project Calculations folder.
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Any text shown in red italics indicates information to be completed by the designer with Project specific 
information. Once the data is completed, it should be changed to black vertical text to match the format 
of the other text.  The EOR Name and Date/Timestamp text may be deleted as this indicates the location 
where the digital signature should be placed.

The seal graphic may be generated using the project Seals.cel file to print a .jpg image of the EOR’s seal 
that can be inserted into the table cell.

Once the Excel EQRSignature.xlsx template is completed and saved, select File > Save As and change 
path to the Estimates folder and the file format to PDF

If the file EQRSignature.pdf exists in the Estimates folder, the Summary Reports Builder will find it and 
include it as the first page and bookmark in the Estimated Quantities Report. If the file is not in the Estimates 
folder, or does not have the correct filename, the page will not be included.

Whenever EQ Report revisions are required prior to letting of a project, you may add the revision block 
shown in FDM 132.4 to the EQRSignature files as shown below.  It will add a second page to the EQR-
Signature.pdf and the signature pages will be included in the EQ Report with the correct bookmarks, page 
numbers and date/timestamp.
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EXERCISE  4.1EXERCISE  4.1	Creating the Estimated Quantities Report Signature Page

This exercise will generate the EOR Seal image from the Project Seals.cel, complete the EQRSignature.
xlsx, and save the EQRSignature.pdf file in the Project Estimates folder.

1.	 Open the Seals.cel file in the C:\Worksets\FDOT\22049555201\Cell\ directory folder. Be sure to 
change the file format to .cel files.

2.	 Open the OpenRoads Modeling > Home > Primary tool group, open the Models dialog.

3.	 Right-click on the Thorp_PESeal model and select Copy.

4.	 In the Copy Model dialog, change the Name to Thorp_PESeal_EQR.

5.	 Change the Model to the new Thorp_PESeal_EQR model and adjust the view.   
6.	 On the OpenRoads Modeling > Drawing > Attributes tool group, set the level to PlotBorder_dp.
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7.	 In the Placement tool group, select Place Block.

8.	 In the Place Block dialog, leave the Method set to Orthogonal, and set Edge1 and Edge 2 to 0.25. Data 
point anywhere on the screen to place the 3” x 3” square.

9.	 On the Manipulate tool group, select Align Elements By Edge, then in the Align Edges dialog, set 
the Align method to Both Centers and select the center of the center star of the seal to move the plot 
border so it is centered around the seal.

   
10.	Change the background display of the file to white.  Select File > Settings > File > Color Table, then 

double click the “B” square in the lower right of the Color Table dialog. Select the list tab in the Modify 
Color dialog and select “White”.  Click OK in the Modify Color dialog, then click Attach in the Color 
Table dialog. Click the back arrow in the top left of the screen to return to the file.
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11.	 In the Selection tool group, select Place Fence, then snap to the corners of the plot border to create 
a fence.

12.	On the quick access toolbar, click Print (or select File > Print > Print).

13.	Set the Printer and Paper Size to jpeg.pltcfg.

14.	Set the Printer and Paper Size to MAX, Set the Area to Fence, then in the Scale/Size area set the 
Size to 3in as shown below.

15.	Click Print to File. This should create an image Thorp_PESeal_EQR.jpg file that is scaled to 3 inches 
square in the Cell directory folder.

16.	Open the EQRSignature.xlsx file in the C:\Worksets\FDOT\22049555201\Calculations\ directory folder. 
If the template does not display as an 11x17 page, select File > Print and change the printer selected to 
a printer that supports 11x17 pages, such as Microsoft Print to PDF, then click the back arrow to return 
to the worksheet.

17.	Edit the template to add the Financial Project ID, Contract Number, Project Description and EOR 
information as shown below. Change the text font to black and non-italics.

18.	Delete the “Seal Graphic” text – this will be replaced with the image created in step 14. Delete the “EOR 
Name” and “Date/Timestamp” – this indicates the location that the EOR’s digital signature stamp will be 
located when the Estimated Quantities Report is signed and sealed.
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19.	Click in the merged cell that was labeled “Seal Graphic”. Select Insert > Pictures > Place in Cell 
>This Device, then navigate to and select the Thorp_PESeal_EQR.jpg created in step 15. This should 
insert the seal image in the proper location and at the proper 3 inch square size. 

20.	Select File > Save As. Click on the path and navigate to the project Estimates folder.

21.	Change the Save as type to PDF (*.pdf) then click Save.
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EXERCISE  4.2EXERCISE  4.2	Creating the Estimated Quantities Report

This exercise will generate and explore the Estimated Quantities Report.

1.	 Open the QTDSRD02.dgn file in the C:\Worksets\FDOT\22049555201\Roadway\ directory folder.

2.	 In the OpenRoads Modeling > FDOT tab, open the Quantities > Takeoff Manager and click Create 
PDF.

3.	 In the Summary Reports Builder dialog, review the Input and Output Directories and verify that they 
reflect the paths to the project’s Calculations and Estimates folders, respectively.

4.	 Review the list of Excel Summary Table Files and verify all the Summary Table names match the 
Quantity Takeoff Manager Table names exactly, click Select All, check the box for Open Output File, 
then click Create. This process may take a minute.

5.	 Examine the 22049555201ESTIMATES-QUANTITIES.pdf file. Test the bookmarks and verify that all 
Summary Tables have been included.

 
6.	 Close the file.
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5    DESIGNER INTERFACE QUANTITIES BUILDER

OBJECTIVES
•	 Examine the Designer Interface Quantities Builder Application
•	 Review the workflow for uploading quantities to Designer Interface for AASHTOWare Project 

Preconstruction
The workflow for uploading quantities to Designer Interface requires mainframe access and a RACF 
password. This chapter will cover the process but will not include exercises due to access restrictions.

PROJECT HEADER EXPORT
Before launching the Designer Interface Quantities Builder, the Project Header must be downloaded and 
saved to the Project’s lead discipline folder. The FDOTConnect FDOT Ribbon tab > Resources > FDOT 
Links tool includes a link to the Web Gate Portal website where Designer Interface may be accessed.
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In Designer Interface, locate the Project in the Project List and select Export Header. The file will be saved 
to the Downloads folder on your computer. Locate the file and move it to the lead component discipline 
folder, usually Roadway.

 
DESIGNER INTERFACE QUANTITIES BUILDER
The Designer Interface Quantities Builder is an application created by the FDOT Production Support 
CADD office for use with FDOTConnect for OpenRoads Designer in conjunction with Designer Interface 
for AASHTOWare Project Preconstruction. This tool generates an XML file from the same Summary of 
Quantities Excel files used to create the Estimated Quantities Report. This application may be accessed 
from the icon located in the FDOTConnect Desktop folder.

In the Designer Interface Quantities Builder application window, in the Header File Location, click Browse 
and locate the Project Header file downloaded from Designer Interface.

Next, in the Summary Tables Location, click Browse and navigate to the Project Calculations folder.

In the Excel Summary Table Files section, examine the Group Id section. Notice that each table shows 
with a default group Id. These each have a pick list of all the available Group Id codes that were included 
in the Project Header file. Verify that the correct Id is shown for each Summary Table. If the Id should be 
changed, select the correct Group Id from the list. The Excel Summary Tables to be included in the XML 
may be selected individually selecting the checkboxes, or by using the selection buttons in the bottom left 
corner of the dialog box.
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The Output File Location should be directed to the lead component discipline folder and the file name 
should be changed to add “_out” to the filename (i.e. 0000000000000_out.xml). Click Create to save 
the XML file.

 
 
 
 
 
 
 
 
 



Automated Quantities 60

PROJECT QUANTITIES IMPORT
Once the Output File is created, return to the Designer Interface page, and select Import.

Click Select files and locate the [Project]_out.xml file. When the file appears in the window, then click 
Upload file.

If there are no errors, the Project Load Log Message should display with a green highlighted title and 
successful messages.
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If errors exist, a Data Validation Error page will display with a red highlighted title and list all errors in the 
XML file. All errors must be corrected or no data will be uploaded.
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6  PLATFORM INDEPENDENT QUANTITIES

OBJECTIVES
•	 Examine and discuss the Quantities tools installed in the FDOTConnect desktop folder.

•	 Identify the location of Summary templates in the Workset template and project folder structure.

•	 Examine Landscape and Structures Summary of Quantities Templates.

BASIC FDOTCONNECT
Occasionally, a project will have a component or discipline that does not require the full civil software to 
generate the CADD files required.  As long as the requirements of the FDOT, and especially the CADD 
Manual, are met and the files produced are compatible with the civil versions of the software, basic versions 
of MicroStation or AutoCAD may be used to produce the plans.

In order to meet the requirements to generate and deliver quantities in an Estimated Quantities Report, 
consultants may still download and install the FDOT CADD software, even if the civil version of OpenRoads 
Designer is not present.  When FDOTConnect is installed and OpenRoads civil software is not detected, 
the tools, applications and resources are still installed and available, but there will be no launch icons in the 
FDOTConnect desktop folder for the civil CADD software. (The red marked icons shown below will not be 
present.)

The FDOT CADD Project folder structure and templates may be provided by the lead project designer. If 
not, refer to the CADD Essentials Workflow training guide for the steps to set up the project and create 
CADD files to meet the requirements of the CADD Manual.

For the Quantities workflow, the applications that will be used are the Summary Reports Builder and the 
Designer Interface Quantities Builder (green circled icons shown above).
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GENERATING QUANTITIES
Once the component CADD files are created, the quantities must be computed, and the Summary Tables 
filled out manually.  Blank templates for all Summary Table Excel files should already be included in a sub-
folder of the Calculations folder for new projects created with the FDOT Create Project application.  If the 
Blank Templates folder is not already included in the project Calculations folder, it can be copied there from 
the following location:

C:\FDOTConnect10.12\Organization-Civil\FDOT\Data Templates\Calculations\BlankTemplates

Copy the templates needed for the project to the Calculations folder and edit them there to add the 
project’s quantity data.  Refer to the Summary Reports section of Chapter 3 in this document for rules and 
recommendations for completing the tables.

All elements, lines, shapes, etc. created in MicroStation CE have an Element ID associated with them, 
and that information can be documented in the Summary tables when necessary.  One way to locate the 
Element ID is to use the Key-in tool and type “analyze element”, then in the Element Information dialog, 
Details tab, the Element ID is displayed.
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Including the Element ID when possible, even in a manually generated table, allows reviewers to more 
easily locate and check the source of the quantity data.

Completed Summary Excel files for all disciplines should be maintained in the project’s Calculations 
folder.  If a component of a project is completed by another firm or group, the Summary Table Excel files 
are delivered to the project lead and placed in the project’s Calculation folder for processing.

SPECIAL CONSIDERATIONS FOR MANUAL SUMMARY 
REPORT TABLES
There are a few instances where the workflow for manually generating a Summary Table differs from the 
Automated Quantities process.  For any unusual situation not covered here, contact the CADD Office for 
additional support.

MULTIPLE FUNDING SOURCES
In the Automated Quantities workflow, when there are multiple funding sources within a project, all quantity 
elements are tagged with an Item Type that identifies the FPID funding source for each element and the 
quantities are automatically placed in separate labeled Summary Table Excel files.  When quantities are 
generated manually for a project with multiple funding sources, the quantities must be sorted into separate 
Summary Tables for each FPID as required by the Basis of Estimates Manual.

Each Summary Table Excel file must maintain the filename that matches the template provided.  When 
multiple files of the same name are created, each filename and table title must be appended with the FPID.  
It is important to make sure that the filename matches the correct format, or it will not be compatible with 
the Summary Reports Builder to generate the Estimated Quantities Report.  This format requires the base 
template name followed by a space, dash, then another space, followed by the FPID and the file extension 
(i.e., Summary of Pavement - 22049555201.xlsx).
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SUMMARY OF LANDSCAPE ITEMS AND PLANT SCHEDULE
A special template for Summary of Landscape Items, which includes a linked worksheet for a Plant Schedule, 
has been included in the Calculations > Blank Templates folder.  The Sheet1 worksheet is formatted for 
the Summary of Landscape Items summary table and is compatible with the Summary Reports Builder 
and Designer Interface Quantities Builder.  The PlantShedule worksheet is formatted to be compatible 
with the Linked Data Manager tool and is linked to Sheet1 with formulas and will automatically include the 
appropriate data for that table.  This ensures a single source of data for both tables.

If additional worksheets are needed, copy both the Sheet1 and PlantSchedule worksheets and rename 
them to Sheet2 and PlantSchedule2, respectively. The name format of the Sheet worksheets is critical 
to the compatibility with the Summary Reports Builder and Designer Interface Quantities Builder. In the 
copied PlantSchedule worksheet, edit the formulas to redirect to the corresponding Sheet# worksheet.  
Repeat the process for any additional worksheets, maintaining the naming and numbering format.  If a 
separate Irrigation Schedule is needed, the PlantSchedule worksheet may be copied, renamed, and edited 
to change the table title and modify the links to only include the irrigation items from the Sheet# worksheets.

When manually entering the data, be sure to follow the guidelines set forth in Chapter 3 of this 
document.  Be sure to enter pay item numbers in the BOE format and match the pay item descriptions 
in the BOE exactly.

For secondary quantity item listings (plants or soil enhancement), the Label column should contain the 
corresponding designation or symbol indicated in the plans.  The Pay Item Description column should 
include the following information:
Plants: Botanical Name / Common Name; Size; Spacing; Details

Landscape Soil: Soil Enhancement; Removal Depth; Soil Added; Amendment Added; Scarification 
Depth; Unit

In the past the Summary of Landscape Items quantities were generated by sheet.  All other quantities for 
the Estimated Quantities Report are summarized by-location.  The new workflow for landscape quantities 
allows the designer to designate locations as sheet numbers or by other parameters, depending on the 
needs of the project.

To give quantities by sheet, the designer should identify the Site No. corresponding to the sheet 
numbers of the plans. If the designer chooses to designate site locations based on intersection, planting 
bed, etc. they may do so by assigning Site numbers to each location. With either option, the Site No. 
designations should be shown on the Project Layout sheet in the Landscape Plans.  The Location 
Description column may be used to further identify any location details to completely describe the 
location of the item(s) being quantified.
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SUMMARY OF STRUCTURE QUANTITIES
As with multiple funding sources, the Summary of Structure Quantities requires a separate Summary Table 
for each structure number.  Also, each Summary Table must include the structure number appended to 
the table title and filename.  This process has been added to the quantities automation within OpenBridge 
Modeler when a 3D model is created, but must be completed manually when a bridge is detailed in 2D.

There are minor differences in the format of the table from previous versions of the Summary of Structure 
Quantities, though the same data is included.  Note that the Section column rows should not be merged.  
The section should be listed on the first row of the quantities for that section and should not be repeated, 
much like pay items and descriptions.  Also, there are columns provided for secondary quantities such as 
LS/SF as shown in the example below.
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CREATING THE ESTIMATED QUANTITIES REPORT
The project Estimated Quantities Report (EQR) is generated by the project lead designer for the Engineer 
of Record.  Only when a project is completely produced outside of the OpenRoads Designer environment 
would the EQR need to be generated with the standalone tools.  However, a test PDF may be created to 
verify that all the data translates properly prior to forwarding the Excel file to the project lead.

When using the Summary Reports Builder as a standalone tool, the only difference from the automated 
workflow is that the full path to the project Calculations and Estimates folders must be entered and/or 
browsed-to in the dialog.  The processes for creating the signature page and the Estimated Quantities 
Report are documented in Chapter 4 of this guide.

UPLOADING QUANTITIES TO DESIGNER INTERFACE
As with the Estimated Quantities Report, the upload of quantities to Designer Interface is managed by 
the project lead designer for the Engineer of Record.  It also requires mainframe permissions, so access 
is limited.  Since the Designer Interface Quantities Builder is a completely standalone application, the 
process is the same as shown in Chapter 5 of this guide.  Note that all quantities must be entered in the 
correct format as indicated in this training guide to achieve a successful upload of quantity data.
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