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FDOT Civil 3D Roadway Design & 3D Modeling 

Basic  

 

Description 

This 2-day course provides participants with advanced training on Civil 3D design workflow of creating a 

Corridor with the FDOT Subassemblies within depth focus on Regions and Targeting using the latest FDOT 

CADD Software suite release. 

 This course will demonstrate the workflows for base map compilation, displaying and editing roadway features 

in plan and profile views, and creating finished ground terrain models. Roadway alignments, profile views, and 

digital terrain models are utilized to display and edit the roadway parts during the design process.  

This course includes examples of intersection design, corridor modeling, traffic separator design, traffic island 

design , along with 3D visualization tools to enable the user to quickly recognize errors and confirm satisfaction 

of design intent. 

Objectives 

The student will have a basic understanding of …. 

• FDOT Civil 3D State Kit Tools 

• Corridor Creation 

• Alignments and Profiles 

• Surfaces 

• Annotation 

• Data Management Techniques Annotating Plans 

Audience 

This course is intended for roadway designers. 

Prerequisites 

Participants need to have a (basic) understanding of AutoCAD and AutoCAD Civil 3D. 

Duration: 16 Hours 

Professional Credit Hours: 16 PDHs 

 

Note PDH Credit will only be available with Instructor lead or Computer Based Training (CBT) thru Learning 
Curve. 
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1 GETTING STARTED 

DESCRIPTION 

This chapter provides the background information and context to help the user prepare to use this manual. 

OBJECTIVES 

This chapter is divided into two sections: 

• Introduction 

o Purpose 

o Terminology 

o Civil 3D Objects 

o About Civil 3D 

o About this Manual 

o Resources 

• Project Components 

o Civil 3D Drawings 

PREREQUISITES 

Basic understanding of AutoCAD and AutoCAD Civil 3D. 

INTRODUCTION 

PURPOSE 

This manual serves two primary functions. It is a training manual for instructor-led training, and a user's 

manual for roadway engineers, designers, and technicians. Lab exercises are provided at the end of the 

chapters, although the instructor-based classes may not use all the exercises or cover all the chapters. 

TERMINOLOGY 

Throughout this document the term “Department” refers to the Florida Department of Transportation. The 

Department’s standards for roadway design are provided in the Roadway Manual. Guidelines for roadway 

design are provided in the various roadway handbooks The Department’s Plans Preparation Manual and CADD 

Manual provide the standards for preparing the construction plan sets. Discussions about how to best use Civil 

3D to comply with the Department’s CADD standards and guidelines are included in this document where 

appropriate. 
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CIVIL 3D OBJECTS USED IN THE DATASETS FOR THIS MANUAL 

• Surface 

• Feature Line 

• Alignment 

• Profile 

• Profile View 

• Assembly 

• Sub-Assemblies 

• Corridor 

• Section Views 

Note Descriptions for each object can be found in the Civil 3D Online Help system: 

https://knowledge.autodesk.com/support/autocad-civil-3d 

ABOUT CIVIL 3D 

Civil 3D is a comprehensive application for designing a roadway design. Civil 3D includes a comprehensive set 

of tools for designing roadways in a dimensionally accurate 3D model. The FDOT Civil 3D State Kit contains 

custom assemblies and sub-assemblies used for roadway design. 

The assemblies and sub-assemblies objects can be edited graphically or numerically using a variety of 

convenient user interface features including interactive dialog boxes, cursor menus, tool tips, toolbars, ribbons, 

palettes, with most of these having context sensitive behaviors. Predefined styles compliant with FDOT 

standards are included with the FDOT Civil 3D State Kit. These styles control the graphical appearance of the 

assemblies and sub-assemblies, their labels and much more. 

Preset command behaviors simplify the use of commands so Civil 3D objects such as assemblies and sub-

assemblies are created and labeled simultaneously using the desired styles. Designs are produced with less 

effort and eliminate labeling errors.  

CIVIL 3D DRAWINGS 

Civil 3D Drawing Files are in a binary format with a .dwg file extension. They contain object tables and 

databases. When opened in an AutoCAD environment the drawing displays graphical and textual content. Civil 

3D objects are created and stored in this dwg file format along with native AutoCAD objects. 

RESOURCES  

• Roadway Design 

http://www.fdot.gov/roadway/Drainage/Manualsandhandbooks.shtm 

• CADD Manual 

http://www.fdot.gov/cadd/downloads/publications/publications.shtm 

• FDOT Civil 3D State Kit 

http://www.fdot.gov/cadd/downloads/software/software.shtm 

 

https://knowledge.autodesk.com/support/autocad-civil-3d
http://www.fdot.gov/roadway/Drainage/Manualsandhandbooks.shtm
http://www.fdot.gov/cadd/downloads/publications/publications.shtm
http://www.fdot.gov/cadd/downloads/software/software.shtm
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2 What is a Corridor? 

DESCRIPTION 

This chapter introduces you to Corridor Modeling using AutoCAD Civil 3D and the FDOT Civil 3D State Kit. 

In this chapter, you will learn about: 

• Corridors 

• Assembly  

• Sub Assemblies  

• Surfaces  

• Feature Lines  

• Alignments  

• Profiles  

CHAPTER SETUP 

There are no chapter datasets to restore for this chapter. 

Note Some of the content in this chapter is from the Civil 3D 2018 Help file and has been edited to follow the 
FDOT workflows.  

CORRIDOR MODELING OVERVIEW 

You can use AutoCAD Civil 3D corridor modeling to create 3D models of corridors, such as roads, highways, 

Intersections, and Roundabouts. 

A corridor model builds on and uses AutoCAD Civil 3D objects and data, including subassemblies, assemblies, 

surfaces, feature lines, alignments, and profiles. The corridor manages the data, tying various assemblies 

(applied for different ranges of stations) to the baselines and their finished grade profiles. 
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Corridors exist in a drawing as Objects. Corridor objects include corridor body geometry, longitudinal feature 

lines, embedded surfaces, rendering support, and slope hatching support. 

A corridor can define and display components, such as: 

• Feature lines connecting points along the point codes, which are defined in the subassemblies (used to 

create the assemblies). 

• Surfaces, using link codes and feature lines. 

A corridor object is created from a baseline (alignment or feature line) by placing 2D sections (assemblies) at 

incremental locations, and by creating matching slopes that reach a surface model at each incremental location. 

You can create corridors with multiple baselines, which enables you to create more complex designs, such as 

intersections. 

Note There is no limit to the number of alignments that can be used to define an AutoCAD Civil 3D corridor. 

Corridors are created from and based on existing AutoCAD Civil 3D objects, which include: 

• Horizontal Baselines (alignments or feature lines). Used by a corridor as its centerline. 

• Vertical Baselines (profiles or feature lines). Used to define surface elevations along the horizontal 

baseline. 

• Surfaces. Used to establish elevations along baselines (by way of profiles or feature lines) and as 

corridor targets. . 

• Subassemblies. A fundamental component of a corridor model. Subassemblies define the geometry of 

a corridor section (assembly). For example, a typical roadway may be composed of paved lanes (on 

either side of the centerline), a paved shoulder, a gutter and curb, and a roadside grading. These parts 

are defined independently as subassemblies. You can stack any type of subassembly to make up a 

typical assembly and apply the same assembly for a station range along a horizontal baseline. 

• Assemblies. Represent a typical section of a corridor. Assemblies comprise one or more subassemblies 

connected. 

• After you have created a corridor, you can extract data from it, including surfaces, feature lines (as 

polylines, alignments, profiles, and grading feature lines), and volume (quantity takeoff) data. 

Note There is no limit to the number of feature lines that can be created at a AutoCAD Civil 3D corridor station 
or range of stations. 

Corridors have their own display style and inherit styles from their components. 

Managing and Editing Corridors 

A corridor is defined by at least one baseline and an assembly that is applied for a range of stations on that 

baseline. In many cases, corridors will have different assemblies at different stations, depending on the existing 

ground and other design requirements. It may be necessary to build a corridor model that is controlled by 

multiple baselines. To add and edit this type of complexity, you can use the Parameters tab of the Corridor 

Properties dialog box, where you can modify the associated baselines and assemblies, change assembly 

frequency and range, and update targets. 

You can use the Corridor Properties dialog box to view and or change: 

A corridor’s information, such as name description, and object style, other parameters such as baselines, 

frequencies, and targets, code sets, corridor feature lines, surfaces, boundaries, and slope patterns. 
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Many corridor editing commands can also be accessed on the Corridor ribbon tab. 

To display the Corridor tab in the ribbon, do one of the following: 

• In the drawing window, click a corridor to select it. 

 

• In the ribbon, click the Modify Tab > Design Panel, then select Corridor. 
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• In Toolspace, on the Prospector tab, right-click a corridor and then click Select. 

 

Note  You cannot copy a corridor. 

 

 



What is a Corridor? _________________________________________________________________________________ Chapter 2 

FDOT Civil 3D Basic © 2019 FDOT  2-5 

WHAT IS A CORRIDOR? 

A corridor object is a flexible 3D (three-dimensional) model that combines the horizontal geometry of an 

alignment, the vertical geometry of a profile, and the cross-sectional geometry of an assembly. 

Corridors can be used to model many linear designs such as roads, highways, channels, railways, trenches, 

tunnels… 

In a transportation project the corridor is a critical element of the 3D model. Use Autodesk Civil 3D and the 

FDOT State Kit to create corridors that meet FDOT CADD standards.  

 

 

WHAT ARE THE COMPONENTS OF A CORRIDOR? 

Corridors contain Five components: Baseline, Assembly, Region, Frequency & Targets. 

• Baseline - First component for any Corridor.  Baseline or Alignment must contain the horizontal layout, 

and a profile providing the vertical layout.  
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• Assembly - Assemblies are required to generate the corridor by providing cross-sectional information to 

be applied a along some of all of the length of the baseline. Assemblies contain the subassemblies that 

are coded with marker points, links and shapes that generate roadways, curbs, sidewalks…  

 

• Region - When the geometry along a base line requires a new or single assembly, a new region is needed 

A start and end station is with no overlapping is required. 

 

• Frequency - Frequency refers to how often the assembly is applied to the corridor. You specify the 

frequency and placement settings for station along the corridor. The higher the frequency, the greater the 

detail. High frequency could also result in slow rebuild and over all slow drawing operation performance. 

 

• Targets - Targets are used to change the corridor geometric characteristics such as cross slope (elevation 

targets) and lane width (width targets). Width Targets can be Alignments, polylines, feature lines, or 

survey figures. Surface targets can be used for daylighting. Refer to each assembly help file for a detailed 

explanation for targeting options. 
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WHAT IS AN ASSEMBLY? 

Assembly objects contain and manage a collection of subassemblies that are used to form the basic structure of 

a 3D corridor model. An assembly is an AutoCAD Civil 3D drawing object that manages a collection of 

subassembly objects. Together, assemblies and subassemblies function as the basic building blocks of a 

roadway or other alignment-based design. An assembly object must be applied along an alignment to form a 

corridor, and it can reference one or more offsets. 

 

Adding one or more subassembly objects, such as travel lanes, curbs, and side slopes, to an assembly baseline 

creates an assembly object. This forms the design for a corridor section. The subassemblies are provided in a 

set of catalogs. 

Below is a Roadway assembly (left), with subassemblies shown in a tool palette (right): 

 

 

The following graphic shows a simple assembly object that represents one side (lane) of a two-lane road. 

Subassembly objects named BasicLane and BasicCurbAndGutter have been added to a baseline alignment, 

forming a single travel lane with a curb and gutter. 
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It is also possible to create more advanced assemblies referred to as conditional assemblies. A conditional 

assembly contains one or more conditional subassemblies, which apply subsequent subassemblies when 

specified conditions at a given station are met. 

The following components comprise an assembly object: 

• Insertion Point. This is the initial point in the drawing that is selected to create the assembly object. It 

corresponds to the centerline of the eventual corridor object. This is also known as the ground 

reference point and typically follows an alignment as well as a design profile (vertical alignment). 

• Baseline. The baseline of an assembly typically displays as a visual aid (marker) representing a 

vertical axis at the assembly baseline point. If you want to attach a subassembly to the baseline point, 

you can do so by selecting the baseline marker. This method of attaching subassemblies to an 

assembly is sometimes easier than selecting the baseline point, especially when there are already one 

or more subassemblies attached at that point. 

• Baseline Point. This is a point on the assembly typically representing the start point of the first 

subassembly that is attached to the assembly near the controlling alignment. By default, the baseline 

point coincides with the insertion point and therefore follows the centerline alignment and profile. If 

you want to begin sectional elements oriented away (horizontally and vertically) from the centerline, 

do so by moving this baseline point away from the assembly insertion point. 

• Offset Line. The offset line is a typically vertical line visually representing a vertical axis at the offset 

point. If you want to attach a subassembly at an offset point, you can do so by selecting the offset line 

marker instead of selecting the offset point. This method of attaching subassemblies to an assembly 

offset point is sometimes easier than selecting the offset point, especially when there are already one 

or more subassemblies attached at that point. 

• Offset Point. This is a point on the assembly representing the ground reference point along an offset 

alignment for the eventual corridor object. Subassemblies attached at this point follow an offset 

alignment and its designed profile. For example, in the case of a highway with service roads on one or 

both sides, the service road centerlines are represented by offset points. There is always just one 

baseline point on an assembly, and there can be zero or many offset points on an assembly. Offset 

points can be added to or deleted from an assembly at any time. 

To complete the definition of an assembly object, you typically add multiple subassembly objects, such as 

lanes, curbs, or ditches, along an alignment. Each subassembly can connect to the assembly baseline point, any 

assembly offset point, or to another subassembly already associated with the assembly. A subassembly can also 

be attached to these points with a relative offset and/or elevation from the point. 

Note There is no limit to the number of slope segments a user may define in an AutoCAD Civil 3D assembly. 

After creating assembly objects, you can proceed with other corridor modeling tasks, such as creating corridor 

objects, feature lines, and section views. 
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CREATING AN ASSEMBLY 

When you add a set of subassemblies sequentially to a baseline (for example, lane, curb, sideslope, then ditch), 

they are all added to the same subassembly group. The next time you select the assembly baseline, a new group 

is created, and the subsequent subassemblies added belong to the new subassembly group. 

1. Click Home tab > Create Design panel > Assembly drop-down Create Assembly 

 

2. In the Create Assembly dialog box: 

3. In the Name field, enter a name for the assembly. 

Note To name the assembly, select its default name and enter a new name, or you can use the Name 
Template. 

4. For Description, enter an optional description of the assembly. 

5. For Assembly Type, select the type of corridor in which the assembly will be used. 

6. For Assembly Style and Code Set Style, either accept the default style, select another style, or create 

a new style. 

     

7. Click OK. 
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8. To insert the assembly into the drawing, click a baseline location in the drawing. The assembly name 

is displayed under the Assemblies collection in the Prospector tree. A vertical line with a circular 

marker in the middle is inserted into the drawing. This is the assembly baseline location point, where 

you will attach one or more subassemblies. 

 

WHAT ARE SUBASSEMBLIES? 

A subassembly is a building block of a typical section, known as an assembly. Examples of subassemblies 

include lanes, curbs, sidewalks, railing, trenches, daylighting, and any other component required to complete a 

typical corridor section. 
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ADDING SUBASSEMBLIES TO AN ASSEMBLY MARKER 

You can add subassemblies to a drawing using the subassemblies provided through the AutoCAD Civil 3D tool 

palette or tool catalog or create your own custom subassemblies. 

To open the Tool Palette from the Home tab > Palettes panel click the Tool Palettes icon to open the Tool 

Palette. 

      

To select the FDOT Subassemblies Palette, right-click on the Tool Palette title bar, then select FDOT 

Subassemblies. 
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To reveal all the available tabs in the FDOT Subassemblies palette, right-click on the cascading tabs at the 

bottom of the Tool Palette. 

 

When using the preconfigured FDOT Civil 3D subassemblies, adding the subassembly to the drawing creates 

the subassembly object. 

If you want to draw a custom shape and use it as a subassembly, use the Create Subassembly from Polyline 

feature. From the Home Tab > Create Design Panel , select Create Design Panel name to expand more 

commands, then select Create Subassembly from Polyline icon. 

 

Another approach to creating customized subassemblies is using the Autodesk Subassembly Composer for 

AutoCAD Civil 3D. This method provides you with the ability to create custom subassemblies with simple or 

complex conditional behavior built in. 
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WHAT ARE THE ELEMENTS OF A SUBASSEMBLY? 

Subassemblies are composed of three elements:  Point, Links and Shapes. Each piece is used for different 

purposes at each stage of your design process. Below is a schematic showing the parts of a subassembly. 

 

POINTS:  

• Marker points are located at the endpoints of every link. 

• Used to “click” subassemblies together or “hook” to alignments and/or profiles known as targets. 

• Controls automatic labeling. 

• Coded points are used to connect the dots between each occurrence/frequency of the assembly. 

• Creates feature lines which can then be used almost anywhere.  

Points and point codes on the FDOT sidewalk subassembly are displayed below: 

 

LINK: 

• Linear components that usually represent the outer edges of an assembly. 

• Links have codes assigned to them that identify stratum materials and shapes. 

• You can add Custom Codes to some FDOT Subassemblies. 

• Controls automatic labeling. 

• Simplifies surface creation. Top and datum codes are used to build surfaces. 

Links and link codes on the FDOT sidewalk subassembly is displayed below: 
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SHAPE: 

• Shapes are the areas inside a closed formation of links. 

• Shapes are used for creating volumes or end-area material quantity calculations. 

Shape codes on the FDOT sidewalk subassembly is displayed below: 

 

TYPICAL SECTION DETAIL: 

The following graphic shows an example of a Typical Section of a road design used to create an Civil 3D 

Assembly which can be used in the building of a Corridor Model. 
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CORRIDOR FEATURE LINES. 

When a corridor is created feature lines are generated. Feature lines are drawn along the corridor, connecting 

points with identical codes in between assembly frequencies. 

Feature lines can represent back of curb, top of curb, edge of pavement, crowns. 

 

SPECIAL PURPOSE CORRIDORS FOR C3D 
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TYPICAL WORKFLOWS 

WORKFLOW: TO CREATE CORRIDORS 

This section provides the processes used to create corridors. 

• Create a corridor - Use the Create Corridor command. 

• Modify the corridor - Make any required customizations to settings or styles for the corridor. 

• Modify or override individual corridor stations - Override corridor and assembly parameters and apply 

the overrides to a station or range of stations. 

WORKFLOW: TO EDIT A CORRIDOR IN SECTION VIEW 

This section provides the process used to create and edit corridors in section view. 

• Create a corridor - Specify a baseline alignment and profile, but do not create regions or specify 

assemblies. 

• Open the section editor - Use the section editor to view cross sections of the corridor model while 

either creating or editing a corridor. 

• Specify other objects to display in the section editor - Specify which AutoCAD Civil 3D objects you 

want to represent in section. 

• Navigate to a station - Use the section editor tools to navigate to a corridor station. You can even view 

a section that is between corridor stations. 

• Create a corridor region - Drag and drop an assembly from the Prospector, a Tool Palette, or a 

catalog, and then specify the targets and station range for the region. 

• Change region assemblies as desired - Specify a new region assembly either from a list, or by 

dragging and dropping from Prospector, a Tool Palette, or a catalog. 

WORKFLOW: TO VISUALIZE CORRIDORS 

After you have created a corridor, create corridor surfaces and boundaries to help you visualize the corridor. 

• Create a corridor surface - When you create a corridor surface, it is added to the Surfaces collection. 

• Create corridor boundaries - Use corridor surface boundaries to prevent triangulation outside of the 

daylight lines of a corridor surface. 

• View corridor sections - You can use the View/Edit Corridor Section Tools to visually inspect how 

assemblies are applied at various stations. 

• Render a corridor boundary region - Render corridor data using the AutoCAD Render command. 

WORKFLOW: TO EXPORT CORRIDOR DATA 

After creating a corridor, you can export several types of data. 

• Export corridor feature lines - Export corridor feature lines as alignments, grading feature lines, profiles, 

or polylines. 

• Export corridor points as COGO points - Export all points from a selected corridor or constrain the 

selection based on station ranges or point code types. 

• Export corridor surfaces as disconnected surfaces - Exported surfaces are no longer part of the corridor. 

Note An exception: if you set pre-defined static alignments as offsets, it is expected that you will specify 
profiles too. No dynamic offset profiles will be created. Creating new corridor regions for the existing 
corridors in the intersection area, or creating new corridor objects in the intersection area 
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3 Basic Civil 3D Functions 

DESCRIPTION 

This chapter will cover basic Civil 3D functions covering the Toolspace, Workspaces, the Civil 3D Ribbon, 

FDOT Tab, Civil 3D Menus, the Panorama window, and Layout Toolbars. 

OBJECTIVES 

In this chapter, you will learn about: 

• Toolspace 

o Prospector Tab 

o Settings Tab 

o Survey Tab 

o Toolbox Tab 

• Workspaces 

• Civil 3D Ribbon 

• FDOT Tab 

• Civil 3D Menus 

• Panorama window  

• Layout Toolbars 

CHAPTER SETUP 

Run the Chapter 3 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects folder. 

Do not change the location in which the Practice Files are installed. Doing so can cause errors when 

completing the exercises in this training manual. 

Note Some of the content in this chapter is from the Civil 3D 2018 Help file and has been edited to follow the 
FDOT workflows.  
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CIVIL 3D TOOLSPACE 

In AutoCAD Civil 3D, design data is organized as object collections in the Toolspace window. In Toolspace, 

the Prospector tab displays the hierarchy of design objects, such as points, surfaces, and alignments.  

TOOLSPACE PROSPECTOR TAB 

 

You can use the Prospector tab to manage project and drawing objects. All of the objects in a drawing or 

project are arranged in a hierarchy.  

The Prospector Tab contains the following top-level collections, which can be viewed using the Master View: 

• Open Drawings 

• Data Shortcuts 

• Drawing Templates 

• Projects 

 The Projects collection in the Prospector Tab is not visible if you have not 
installed Autodesk Vault client and server applications. During a drawing 
session, the Projects collection lists the projects that are available after you 
have logged into an Autodesk Vault server and Vault database. 

Control the items displayed in the Prospector Tab by using the drop-down list at the top of the Prospector tab to 

control which items are displayed in the Prospector tab. 

 

• Master View - Displays all project and drawing items, including drawing templates. The name of the 

active drawing is highlighted. 

• Active Drawing View - Displays only items in the active drawing. If you switch to another drawing, 

the tab is updated to reflect the new drawing. 
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Standard context menu commands are available for many Prospector tab items and collections. To display the 

context menu, right-click a collection or item in the Prospector tab.  

 

The following commands are available on the Prospector context menu whenever they are applicable to the 

selected item(s): 

 

Note Some Prospector context menus do not include all the commands in the preceding table. Also, a 
Prospector context menu can contain additional commands that are related to the selected collection or 
item, including project management access control commands. 
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TOOLSPACE SETTINGS TAB 

You can use the Settings tab to manage styles for AutoCAD Civil 3D objects and to control settings for 

drawings and commands. Right-click collections and items to access commands. 

 

On this tab, styles are organized for different object types. Even in a blank drawing, most of these styles are 

present in a standard hierarchy. You can create and modify styles in a drawing, then save it as a template. 

Subsequent drawings based on the template will automatically have the same set of styles available. You can 

modify object, label, and table styles. You can also control settings for drawings and commands. 

Use the Active Drawing Settings View drop-down list at the top of the Settings Tab to control which items are 

displayed. 

 

Select one of the following tab views on the Settings tab: 

• Master View - Displays items for all open drawings. The name of the active drawing is shown in 

boldface. 

• Active Drawing Settings View - Displays only the items for the active drawing. 

• Active Drawing Labels Only View - Displays only label style collections and label styles items for the 

active drawing. 

• Labels Only View - Displays only label style collections and label style items for all drawings. 
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Use the Settings tab to manage Object, Label, and Table Styles and to control settings for Drawings and 

Commands.  The following graphic shows the top-level collections in the Settings tab: 

s  
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Use the Object collection in the Settings tab to access object styles, settings, and drawing-related 

information for a class of objects. Most of the object collections conform to a standard layout and use a 

standard context menu. The following graphic shows an example of a Settings tab Object collection: 

 

Right-click the Object collection to display a context menu with the following commands: 
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OBJECT STYLE COLLECTION (SETTINGS TAB) 

Use an Object’s Styles collection in the Settings tab to manage styles for a class of objects. 

The following graphic shows an example of a Settings tab object style collection: 

 

Right-click the Style Collection to display a standard context menu with the following commands: 

 

Right-click a Style Name to display a standard context menu with the following commands: 
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LABEL STYLES COLLECTIONS (SETTINGS TAB) 

Use the Label Styles collections in the Settings tab to create and manage label styles and expressions for a 

class of objects.  Click the +/- box to expand the collection and see the label styles for the object. Some 

objects have multiple levels of label styles. 

The following graphic shows an example of a label style collection: 

 

Right-click a label style name to display a context menu that contains the following commands: 
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TABLE STYLES COLLECTIONS (SETTINGS TAB) 

Use the Table Styles collections in the Settings tab to create and manage table styles for a class of objects.  

Click the +/- box to expand the collection and see the table styles for the object. Some objects have 

multiple levels of table styles. 

The following illustration shows an example of a Settings tab table style collection: 

 

Right-click a table styles collection to display a context menu with the following commands: 
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COMMANDS COLLECTIONS (SETTINGS TAB) 

Use the Commands collections in the Settings tab to control the settings for a specific command at the 

object (feature) level.  When you change settings using the Commands collections, the changes affect a 

single command only. 

The following graphic shows an example of a Settings tab commands collection: 

 

Right-click a command name and click Edit Command Settings to display the Edit Command Settings 

dialog box for the command. You can then change the settings. 
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GENERAL COLLECTION (SETTINGS TAB) 

Use the General collection to create multipurpose and label styles that can be used by more than one object 

type.  Pipes and Surface objects can share the Render styles in the General Multipurpose Styles collection, 

while Corridors and Grading share the other styles in this folder.  The General Label Styles are used by 

lines, curves, feature lines, and corridors. This collection also contains Note label styles, which are not 

specific to an object. 

The following graphic shows an illustration of the General collection: 

 

Right-click a style name to display a context menu that contains the following commands: 
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WORKING WITH WORKSPACES 

Workspaces are sets of user interface components, such as ribbon tabs and panels, toolbars, palettes, and menu 

bars, that are grouped and organized so that you can work in a custom, task-oriented drawing environment. 

When you select a workspace, only the user interface components specified in that workspace are displayed. 

You can still access other commands by entering their command names at the command line. 

AutoCAD Civil 3D 2018 comes with a default workspace for working with AutoCAD Civil 3D commands. 

You can use this workspace as-is or modify it according to your requirements. 

Workspaces in AutoCAD Civil 3D 2018 include: 

• Civil 3D: This workspace displays user interface components related to civil engineering design and 

survey features available in AutoCAD Civil 3D. 

• Drafting & Annotation: This workspace displays user interface components related to AutoCAD 

drafting and annotation features available in AutoCAD Civil 3D. 

• 3D Modeling: This workspace displays user interface components related to AutoCAD 3D modeling 

features available in AutoCAD Civil 3D. 

• Planning and Analysis: This workspace displays user interface components related to AutoCAD Map 

3D features available in AutoCAD Civil 3D. 

➢ To Change the Current Workspace 

You can switch to another workspace by using the Workspace drop-down menu in the Quick Access Toolbar.  

 

<OR> Use the Workspace Switching button, which is located in the application status bar. 
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CIVIL 3D RIBBON 

The AutoCAD Civil 3D ribbon is the primary user interface for accessing commands and features. Commands 

available from the ribbon are organized into tabs. Each tab is organized into a series of panels. The ribbon is 

typically turned on (displayed) by default and can be displayed or turned off by using the Ribbon and 

RibbonClose commands. 

There are two basic types of ribbon tabs: Static and Contextual. 

STATIC RIBBON TABS 

Static ribbon tabs are always displayed when the ribbon is turned on. 

 

CONTEXTUAL RIBBON TABS 

Contextual ribbon tabs are displayed automatically when you select an object or invoke an object-specific 

command. For example, when you select a pipe network object, the Pipe Network contextual tab is displayed. 

 

Contextual tabs contain commands that are related to the currently selected object. Most contextual tabs can be 

closed simply by deselecting the object. 

• Multiple Contextual Tab - When multiple types of objects are selected simultaneously, the Multiple 

contextual tab is displayed in the ribbon. For example, if you select both a pipe network object and an 

alignment object, the Multiple contextual tab is displayed. 

 

• Launch Pad Panel - AutoCAD Civil 3D contextual ribbons include a Launch Pad panel that provides 

access to commands that you might use next in your workflow. 

 

For example, when you select a surface object, the Surface contextual tab is displayed. The Launch Pad 

panel on the Surface contextual tab provides a variety of commands that you may want to use next. For 

example, you may want to create a Quick Profile, or Create a Profile from the selected Surface. 
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FDOT TAB 

The FDOT Ribbon Tab is part of the FDOT Civil 3D State Kit and is loaded when the FDOT2018.C3D desktop 

shortcut icon is used to start Civil 3D 2018.  The following graphic shows an illustration of FDOT2018.C3D 

desktop shortcut: 

 

The FDOT Ribbon Tab contains panels which contain tools for various FDOT Workflows: 

• Create File Panel 

• Tools Panel 

• Pay Item Tools Panel 

• Quantities Panel 

• Quality Control Panel 

• Reports Panel 

• GeoTech Panel 

• Help Panel 

 

 

The following FDOT Tab > Panels which display a black arrow next to the panel name display additional tools 

when the panel name is selected. 

• The following graphic shows an illustration of FDOT Tab > Pay Item Tools panel. 

 

• The following graphic shows an illustration of FDOT Tab > Quantities panel. 
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• The following graphic shows an illustration of FDOT Tab > Tools panel. 

 

• The following graphic shows an illustration of FDOT Tab > Quality Control panel 

 

AUTOCAD CIVIL 3D MENUS 

While the ribbon is the primary access point for AutoCAD Civil 3D commands, many commands are also 

available from the application menu and from context menus that are displayed when you right-click an object 

in Toolspace or in the drawing window. 

APPLICATION MENU 

The application menu provides access to file-related commands. For example, it provides commands that let 

you create, open, print, export, and publish a file. 
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Access the application menu by clicking the application menu icon at the top left of the application window . 

The application menu also provides a search tool which you can use to search for commands. Only those 

commands that are available in the current workspace are shown and searched. 

 

CONTEXT MENUS 

Context menus are available throughout AutoCAD Civil 3D. To display a 

context menu, right-click your pointing device on items in the Toolspace, 

Panorama, or other window, or on objects in the drawing area. 

The following graphic shows an illustration of a right-click in the Drawing 

Editor with nothing selected: 

 

 

 

The following graphic shows an illustration of a right-click in the Drawing 

Editor with a Surface object selected: 
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The following graphic shows an illustration of a right-click in the Drawing Editor with a Surface object 

selected: 

 

PANORAMA WINDOW 

Use the Panorama window to display data in a grid. 

The data views that are displayed in the Panorama window are referred to as vistas. The Panorama window can 

display many types of data, such as the Point Editor vista and the Alignment Entities vista. 

 

To conserve screen space if more than one vista is active, the Panorama window displays a tab for each one. 

Click the tab containing a vista’s name to bring it to the front of the window. 

You control the display of some vistas, such as the Point Editor vista. You activate them when you want, and 

they remain active until you dismiss them by clicking . Other vistas, such as the Alignment Entities vista, are 

controlled by a specific command. This type of vista can only be activated or closed when the command is 

running, and its display is controlled from the command toolbar. 

The active drawing controls the state of the Panorama window. When you switch between drawings, the 

Panorama window either becomes inactive or shows only the vistas associated with the active drawing. 

You can dock the Panorama window or use Auto-hide to reduce the amount of screen space it requires. 
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DISPLAYING THE PANORAMA WINDOW 

Display of the Panorama window is affected by several factors, such as the active drawing and the active vistas 

within that drawing. If the Panorama window is not visible, refer to the following table for possible reasons and 

actions you can take to display it: 

 

FEATURES OF THE TOOLSPACE AND PANORAMA WINDOWS 

The Toolspace and the Panorama windows share several features. 

 

• Tabs - The Toolspace window can display up to four tabs: Prospector, Settings, Survey, and Toolbox. 

The Panorama window displays named tabs if you have more than one vista active in the window. 

• Context Menus - Right-click in the Toolspace or the Panorama window to display a context menu of 

available commands. Right-click a single item, or select one or more items and right-click, to display a 

menu containing commands related to the item(s). If you right-click an area that contains no items or 

data, the menu contains commands related to the window. 
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• Auto-hide - This AutoCAD palette feature keeps the window active while maximizing the amount of 

available screen space. If Auto-hide is active for a window, the body of the window disappears when you 

move the cursor out of the window, leaving only the title bar visible. Move the cursor over the title bar to 

display the entire window again. The following illustration shows the Toolspace window both closed and 

open, with Auto-hide active: 

 

To activate Auto-hide for the Toolspace or the Panorama window, click on the title bar. To deactivate 

Auto-hide, click on the title bar. You can also right-click the title bar and use the context menu to control 

Auto-hide.  

 Auto-hide is not available when a window is docked. 

• Moving and Docking - The Toolspace and the Panorama windows, like all AutoCAD palettes, can be 

moved and resized, and either floated in the window or docked. A docked window shares one or more 

edges with adjacent windows and toolbars. If a shared edge is moved, the windows change shape to 

compensate. To undock and relocate a window, click and drag the control bars at the top or side of the 

window. To prevent a window from docking while you drag it, hold down Ctrl. 

Note You can quickly undock a window by double-clicking the window’s control bars. 

LAYOUT TOOLBARS 

Layout toolbars let you create and or edit AutoCAD Civil 3D objects. 

AutoCAD Civil 3D has the following layout toolbars: 

• Alignment Layout Toolbar 
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• Grading Creation Toolbar 

 

• Parcel Layout Toolbar 

 

• Pipe Network Layout Toolbar 

 

• Point Object Creation Toolbar 

 

• Profile Layout Toolbar 

 

The icons or commands available on an AutoCAD Civil 3D layout toolbar depend upon the toolbar in use. 

Most AutoCAD Civil 3D layout toolbars include the following three icons in the upper right corner: 

 

For information about the icons and commands that are available from a specific layout toolbar, click the Help 

button on the toolbar. 
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4 Creating the GTDMRD01 File 

DESCRIPTION 

In this chapter you will create the GDTMRD01 file used in the process of creating the SR61 Corridor model. 

Next you will be importing a LandXML file which contains a DTM surface created by the Survey department. 

Then Data Shortcuts of the DTM surface will be created. 

OBJECTIVES 

In this chapter, you will learn about: 

• FDOT Create File tool 

• Import LandXML file 

• Data Shortcuts 

o Set Working Folder 

o Set Data Shortcut Project Folder 

o Associate Project to Current Drawing 

o Creating Data References 

• Creating Data Shortcuts 

• Review Results 

CHAPTER SETUP 

Run the Chapter 4 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects folder. 

Do not change the location in which the Practice Files are installed. Doing so can cause errors when 

completing the exercises in this training manual. 
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Exercise 4.1 Set Data Shortcuts Paths 

In this exercise you will set up the Data Shortcuts paths. 

1. Start the FDOT Civil 3D State Kit by double clicking the _FDOT2018.C3D icon as shown below: 

 

2. Set Data Shortcuts Paths for the 22049555201 project. From TOOLSPACE > Prospector tab > Data 

Shortcuts, right click to display popup menu and select Set Working Folder. 

 

3. From the Browse For Folder dialog box, use the scroll bar to navigate and click on the C:\Civil 3D 2017 

Projects folder. Click OK to close the Browse For Folder dialog. 
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4. From TOOLSPACE > Prospector tab > Data Shortcuts, right click and select Set Data Shortcuts Project 

Folder.  

 

5. From the Set Data Shortcut Folder dialog box, select 22049555201 from the list. 

 

6. Click OK to close the Set Data Shortcut Folder dialog..  
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7. The Data Shortcuts are now set to reference the C:\Civil 3D 2017 \Projects\22049555201 folder. 

 

 

8. From the Status Bar at the bottom of the window toggle On Selection Cycling by clicking on the icon as 

shown below.  

Note Selection Cycling is not drawing specific but an option that you can toggle on or off at any time. If a new 
drawing is created or opened the Selection Cycling option will retain the previous toggle setting. 
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Exercise 4.2 Create a Digital Terrain Model - Tin Model - 3D file GDTMRD01 File 

In this exercise you will create the GDTMRD01 file  

1. From the FDOT Tab, select the Create Files panel 

 

2. Select the Create Files icon 

 

3. Make the project 22041255201 current. (Use Select Project Button) 

4. Select Control File: ROADWAY 

5. Select File Group: Survey Files (DWG) 

6. Select File Type: Digital Terrain Model - Tin Model - 3D(GDTMRD01) 

7. Set the GDTMRD01.dwg County to Wakulla 

8. Set the GDTMRD01.dwg Coordinate System to FL83-NF 

9. Click “Create-Open File” to create GDTMRD01.dwg file 

 

10. Click “Close” to close Create Files Tool 

11. Switch to the GDTMRD01.dwg file in the current session of Civil 3D 

12. Save the GDTMRD01.dwg file 
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Exercise 4.3 Associate Project to Current Drawing 

In this exercise you will associate the GDTMRD01 file to the current project. 

1. From the TOOLSPACE, Prospector tab, right-click on Data Shortcuts, then select Associate Project to 

Current Drawing. 

 

2. From the Associate Project to Current Drawing dialog, click OK 

 

3. Save the GDTMRD01.dwg file 
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Exercise 4.4 Import LandXML File 

In this exercise you will import an LandXML file. which contains a existing ground surface. 

1. From the Insert Tab > Import Panel 

 

2. Select the LandXML icon 

 

3. From the Import XML dialog, navigate to the C:\Civil 3D 2017 Projects\22049555201\Survey\XMLfolder, 

select the DTM Existing.XML file, Click Open, then Click OK to close the Import XML dialog. 

 

4. From the Import LandXML dialog Click OK to close the Import XML dialog. 
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5. From the Event Viewer, Clear All Events, then Close the Event Viewer. 

 

6. Perform a Zoom Extents to view results of the LandXML import. 

 

7. From the TOOLSPACE, Prospector tab, expand Surfaces collection. Right-Click on Existing GND, select 

Surface Properties... 
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8. Rename Existing GND Surface to DTM Existing. 

9. Set Surface style to Border-Existing [Green] 

 

1. Click Apply then click OK to close Surface Properties - DTM Existing dialog 

2. Review the results 

 

3. Save the GDTMRD01.dwg file 
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Exercise 4.5 Insert block Surface Boundary.dwg 

In this exercise you will insert a block which will be used to define a surface boundary. 

1. From the Insert Tab > Block Panel select the Insert command then select More options...  

 

 

2. From the Insert dialog Click Browse  
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3. Navagate to the C:\Civil 3D 2017 Projects\22049555201\Survey folder , select the Surface Boundary.dwg, 

then Click Open. 

 

4. From the Insert dialog uncheck Insertion point, Scale, Rotation, then select Explode, and Click OK to close 

the Insert dialog. 

 



Chapter 4 _________________________________________________________________________Creating the GTDMRD01 File 

4-12 © 2019 FDOT  FDOT Civil 3D Basic 

5. Perform a Zoom Window to review results of the block insertion. 

 

6. Save the GDTMRD01.dwg file 
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Exercise 4.6 Use Boundary Line work to create Surface Boundary: 

In this exercise you will use the boundary linework from the prior exercise to create a surface boundary. 

1. From the TOOLSPACE, Prospector tab, expand Surfaces collection. 

2. Expand  DTM Existing Surface, then expand Definition 

3. Right-click on Boundaries, select ADD 

 

4. From the Add Boundaries dialog, for Name use DTM Existing, for Type use Outer, select Non-destructive 

breakline, set Mid-ordinate distance to 0.10', and then Click OK. 
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5. Select the white polyline that was created when you inserted the Surface Boundary.dwg block. From the 

Selection dialog select Polyline. 

 

6. From the TOOLSPACE, Prospector tab, expand Surfaces collection. 

7. Expand  DTM Existing Surface, then expand Definition 

8. Select Boundaries, in Item preview review DTM Existing listing. 

 

9. Save the GDTMRD01.dwg file. 

  



Creating the GTDMRD01 File _________________________________________________________________________ Chapter 4 

FDOT Civil 3D Basic © 2019 FDOT  4-15 

Exercise 4.7 View Geolocation Maps for correct location: 

In this exercise you will use a Geolocation Map to verify the project location. 

1. From the Command line, type GEOMAP, select AERIAL option. 

 

2. From the Geolocation - Online Map Data dialog, Click Yes 

 

Note This exercise requires a A360 account. If you don't have an account you'll have to create one by clicking 
on CREATE ACCOUNT 

3. From the Sign in dialog, type in your Email , Click NEXT 
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4. Type in your Password, then Click SIGN-IN 

 

5. Review results: 

 

6. From the Command line, type GEOMAP, select OFF option. 
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7. Save the GDTMRD01.dwg file 
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Exercise 4.8 Create Surface Date Shortcuts: 

In this exercise you will create the GDTMRD01 file Data Shortcuts. 

1. From the TOOLSPACE, Prospector tab, right-click on Data Shortcuts, then select Create Data Shortcuts. 

 

2. From the Create Data Shortcuts dialog, select Surfaces, then Click OK. 
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3. From the TOOLSPACE, Prospector tab, Expand Data Shortcuts, then expand the Surfaces collection. 

4. Verify that the Surface DTM Existing is listed. 
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5. Perform a Zoom Window to display the DTM Existing Surface Boundary 

 

 

6. Save and Close the GDTMRD01.dwg file 
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5 Creating the ALGNRD01 File 

DESCRIPTION 

In this chapter you will open the ALGNRD01.dwg file already created to be used in the process of creating the 

SR61 Corridor model. Next you will import a LandXML file which contains a Alignment created by the Survey 

department. Then Data Shortcuts of the Alignment will be created. 

OBJECTIVES 

In this chapter, you will learn about: 

• Import LandXML file 

• Data Shortcuts 

• Set Working Folder 

• Set Data Shortcut Project Folder 

• Associate Project to Current Drawing 

• Creating Data References 

• Creating Data Shortcuts 

• Review Results 

CHAPTER SETUP 

Run the Chapter 5 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects folder. 

Do not change the location in which the Practice Files are installed. Doing so can cause errors when 

completing the exercises in this training manual. 
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Exercise 5.1 Set Data Shortcuts Paths 

In this exercise you will set up the Data Shortcuts paths. 

 

1. Start the FDOT Civil 3D State Kit by double clicking the _FDOT2018.C3D icon as shown below: 

 

2. Set Data Shortcuts Paths for the 22049555201 project 

3. From TOOLSPACE > Prospector tab > Data Shortcuts, right click to display popup menu and select Set 

Working Folder. 
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4. From the Browse For Folder dialog box, use the scroll bar to navigate and click on the C:\Civil 3D 2017 

Projects folder. Click OK to close the Browse For Folder dialog. 

 

5. From TOOLSPACE > Prospector tab > Data Shortcuts, right click and select Set Data Shortcuts Project 

Folder.  
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6. From the Set Data Shortcut Folder dialog box, select 

22049555201 from the list. 

7. Click OK to close the Set Data Shortcut Folder 

dialog..  

 

 

 

8. The Data Shortcuts are now set to reference the 

C:\Civil 3D 2017 \Projects\22049555201 folder. 

 

 

 

Exercise 5.2 TOGGLE SELECTION CYCLING ON: 

In this exercise you will Toggle Selection Cycling On. 

 

1. From the Status Bar at the bottom of the window toggle On Selection Cycling if not on by clicking on the 

icon as shown below. Selection Cycling is not drawing specific but an option that you can toggle on or off 

at any time. If a new drawing is created or opened the Selection Cycling option will retain the previous 

toggle setting. 
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Exercise 5.3 Open the ALGNRD01.DWG 

In this exercise you will open the ALGNRD01 file to verify the existing centerline alignments. 

 

1. Open the ALGNRD01.DWG. From the Select File dialog box, navigate to the C:\Civil 3D  2017 

Projects\22049555201\Roadway folder and select ALGNRD01.dwg Click Open to close the Select File 

dialog box.  
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2. Hover over both Alignments to view Alignment names. 
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3. From the TOOLSPACE, Prospector tab, expand Alignments collection, then expand Centerline Alignments   

 

4. Save the ALGNRD01.dwg file 
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Exercise 5.4 Associate Project to Current Drawing 

In this exercise you will associate the ALGNRD01 file to the current project. 

 

1. From the TOOLSPACE, Prospector tab, right-click on Data Shortcuts, then select Associate Project to 

Current Drawing. 

 

2. From the Associate Project to Current Drawing dialog, click OK. 
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Exercise 5.5 Import Alignment from ALGNRD-SR61 LandXML file 

In this exercise you will import an LandXML file. which contains the design alignment. 

 

1. From the Insert Tab> Import Panel 

 

2. Select the LandXML icon 

 

3. From the Import XML dialog, navagate to the C:\Civil 3D 2017 Projects\22049555201\Roadway\XML 

folder, select the ALGNRD-SR61.XML file, Click Open, then Click OK to close the Import XML dialog 
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4. From the Import LandXML dialog Click OK to close the Import XML dialog. 

 

5. From the Event Viewer, Clear All Events, then Close the Event Viewer. 

 

 

 

  



Creating the ALGNRD01 File _________________________________________________________________________ Chapter 4 

FDOT Civil 3D Basic © 2019 FDOT  5-11 

6. Perform a Zoom Window to display the results of the LandXML Import. Hover over the LandXML 

imported Alignment. 

 

7. From the Toolspace, Prospector tab, expand the Alignments collection, then expand Centerline Alignments, 

Verify that the Name is SR61  
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8. Right-click on SR61, then select Properties... 

 

9. From the Alignment Properties - SR61 dialog select the Station Control Tab, verify that the Start Station is 

698+53.79. Then Click OK to close the Alignment Properties - SR61 dialog. 
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10. Perform a Zoom Window to display the Alignments Ex-SR61, SR61, and US98.  

 

 

11. Save the ALGNRD01.dwg file 
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Exercise 5.6 Add Alignments to Data Shortcuts 

In this exercise you will create the ALGNRD01 file Data Shortcuts. 

 

1. From the TOOLSPACE, Prospector tab, right-click on Data Shortcuts, then select Create Data Shortcuts. 

 

2. From the Create Data Shortcuts dialog, select Alignments, then Click OK. 
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3. From the TOOLSPACE, Prospector tab, Expand Data Shortcuts, then expand the Alignments collection, 

then expand Centerline Alignments. 

4. Verify that the EX-SR61, SR61, and US98 Centerline Alignments are listed. 

 

5. Perform a Zoom Window to display the Alignments Ex-SR61, SR61, and US98.  

 

6. Save and Close the ALGNRD01.dwg file 
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6 Creating the MODLRD01-Existing 
Conditions Corridor 

DESCRIPTION 

In this Chapter you will create the MODLRD01- Existing Conditions.dwg file, Next, you'll follow the FDOT 

workflows to create the MODLRD01- Existing Conditions Corridor model for SR61, Then you'll create Sample 

lines and Section views for the MODLRD01- Existing Conditions Corridor model for SR61. 

OBJECTIVES 

In this chapter, you will learn about: 

• FDOT Existing Feature Assembly 

• Setup Data Shortcuts 

• Toggle Selection Cycling On 

• Create MODLRD01-Existing Corridor file 

• Associate Project to Current Drawing 

• Attach External Reference files 

• Create Data Shortcut References for Surfaces and Alignments  

• Create Existing Surface Profile 

• Create Assembly 

• Create Existing Conditions Corridor 

• Create Sample Lines 

• Create Cross Sections 

• Highlight Corridor Regions in Corridor Properties and see the Region highlighted in drawing editor 

• Review  

CHAPTER SETUP 

Run the Chapter 6 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects 

folder. 

Do not change the location in which the Practice Files are installed. Doing so can cause errors when 

completing the exercises in this training manual. 

 

Note Some of the content in this chapter is from the FDOT Subassemblies Help file. 
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OVERVIEW OF THE FDOT EXISTING FEATURES ASSEMBLY 

In this chapter you'll review the features of the FDOT Existing Features Assembly found in the FDOT 

Subassemblies tool palette > Assemblies Tab.  

 

1. From the Home Tab > Palettes Panel, select Tool Palettes.  

 

2. Right-click on the Tool Palette title bar, select FDOT Subassemblies, then select the Assemblies Tab. 

 

3. Right-click on the FDOT Existing Features assembly, then select Help... to open the FDOT Subassemblies 

help file. 
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4. Now you can review the features of the FDOT Existing Features Assembly from the FDOT Subassemblies 

Help file. 

 

FDOT EXISTING FEATURES ASSEMBLY 

 
This subassembly scans plan graphics for existing features symbology and draws the feature at each 

corridor station. This subassembly also may be used to draw Typical Right of Way Section features. 

 
ATTACHMENT 

This subassembly behaves different than most subassemblies, as it is not to be connected to other 

subassemblies. Rather, the subassembly creates points and links based off of symbology found in the 

targeted files. 

 
INPUT PARAMETERS 

Notes:  All dimensions are in feet unless otherwise noted. 
            For layer and entity parameters, separate each entry with a comma, enter "none" or leave 

entry blank for the layer specification to not process a specific feature. 

 

 

  



Chapter 5 _____________________________________________________ Creating the MODLRD01-Existing Conditions Corridor 

6-4 © 2019 FDOT FDOT Civil 3D Basic 
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TARGET PARAMETERS 

This section lists the parameters in this subassembly that can be mapped to one or more target 

objects, such as a surface, alignment, or profile object in a drawing. For more information, see 

Setting Targets in the AutoCAD Civil 3D User’s Guide Help. 
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OUTPUT PARAMETERS 

 

BEHAVIOR 

This subassembly searches a set width at each corridor station for intersecting plan graphics. It 

then draws existing features that connect to the defined surface. 

 
ASSUMPTIONS: 

 
PAVEMENT: 

There must an even number of pavement points found for subassembly to run. All processing 

stops if a least one matching pair of pavement points are not found. (If an odd number of points 

are encountered, an entry is created in the Civil3D event viewer labeling the station and number 

of points found).  

 
TRAFFIC SEPARATORS: 

Only appear between pavement structures.  

Traffic separator points appearing within a pavement structure are marked as errors.  

 
SHOULDER: 

Only one shoulder can exist left of left most pavement structure (if more than 1 is found, only the 

shoulder point closest to pavement is processed).  

Only one shoulder can exist right of right most pavement structure (if more than 1 is found, only 

the shoulder point closest to pavement is processed).  

A maximum of 2 shoulder points are processed between pavement structures. The left most 

shoulder point connecting to the leftmost pavement structure, the right most shoulder point 

connects to the rightmost pavement structure, all others marked as errors.  

Shoulder points connect to the closest pavement structure except if Shoulder note 3 above is 

encountered.  

Shoulder points existing within a pavement structure are marked as errors.  

 
GUARDRAIL: 

Guardrail points appearing within a pavement structure are marked as errors.  

Left, Right, and Double guardrail are delineated by a substring of the layer name by 

“LT_” : left  

“RT_”: right 

“DBL_”: double  
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BACK OF CURB: 

Connects to closet curb connector entity within search distance.  

Curb points existing within a pavement structure are marked as errors.  

 
SIDEWALK: 

Back of Sidewalk point first looks for closest Front of Sidewalk point within search distance 

(front of sidewalks points removed from further search effort at current station.  

Back of Sidewalk then looks for closest connector point with search distance and greater than 

minimum search distance.  

Remaining Front of Sidewalk points connect to remaining Front of Sidewalk points within search 

distance. 

 
 

LAYOUT MODE OPERATION 

In layout mode, this subassembly only draws a horizontal line  
 

POINT, LINK, AND SHAPE CODES 

The following lists the point, link, and shape codes for this subassembly that have codes assigned 

to them. Point, link, or shape codes for this subassembly that do not have codes assigned are not 

included in this list. 
 

This subassembly adds point and link codes as needed to represent sub-surface existing features. 

 

Point Code “Error” will be entered at existing feature points that fail connection criteria. 

 

The following link codes will be added when the appropriate criteria is met: 

ExistingPavement 

ExistingTrafficSeparator 

ExistingMiscPavement 

ExistingCurbAndGutter 

ExistingSidewalk 

ExistingShoulder 
 

CODING DIAGRAM 

No coding diagram for this subassembly. Coding is generated by existing features found. 
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Exercise 6.1 Set Data Shortcuts Paths 

In this exercise you will set up the Data Shortcuts paths. 

 

1. Start the FDOT Civil 3D State Kit by double clicking the _FDOT2018.C3D icon as shown below: 

 

2. Set Data Shortcuts Paths for the 22049555201 project 

3. From TOOLSPACE > Prospector tab > Data Shortcuts, right click to display popup menu and select Set 

Working Folder. 
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4. From the Browse For Folder dialog box, use the scroll bar to navigate and click on the C:\Civil 3D 2017 

Projects folder. Click OK to close the Browse For Folder dialog. 

 

5. From TOOLSPACE > Prospector tab > Data Shortcuts, right click and select Set Data Shortcuts Project 

Folder.  
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6. From the Set Data Shortcut Folder dialog box, select 

22049555201 from the list. 

7. Click OK to close the Set Data Shortcut Folder 

dialog..  

 

 

 

8. The Data Shortcuts are now set to reference the 

C:\Civil 3D 2017 \Projects\22049555201 folder. 

 

 

 

Exercise 6.2 TOGGLE SELECTION CYCLING ON: 

In this exercise you will Toggle the Selection Cycling on. 

 

1. From the Status Bar at the bottom of the window toggle On Selection Cycling if not on by clicking on the 

icon as shown below. Selection Cycling is not drawing specific but an option that you can toggle on or off 

at any time. If a new drawing is created or opened the Selection Cycling option will retain the previous 

toggle setting. 
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Exercise 6.3 Create MODLRD01-Existing Conditions file 

In this exercise you will create the MODLRD01-Existing Condition file 

 

1. From the FDOT Tab > Create File Panel select the Create Files icon 

2. Make the project 22041255201 current. (Use Select Project Button) 

3. Select Control File: ROADWAY 

4. Select File Group: Roadway Files (DWG) 

5. Select File Type: Proposed Design Model (MODLRD01) 

6. Set the MODLRD01.dwg County to Wakulla 

7. Set the MODLRD01.dwg Coordinate System to FL83-NF 

8. Click “Create - Open File” to create MODLRD01.dwg file 

9. Click “Close” to close Create Files Tool 
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10. Switch to the MODLRD01.dwg file in the current session of Civil 3D 

11. Using the Saveas command save the MODLRD01.dwg as MODLRD01-Existing Conditions.dwg . 

 

Exercise 6.4 Associate Project to Current Drawing 

In this exercise you will associate the MODLRD01-Existing Conditions file to the current project. 

1. From the TOOLSPACE, Prospector tab, right-click on Data Shortcuts, then select Associate Project to 

Current Drawing. 

 

2. From the Associate Project to Current Drawing dialog, click OK 

 

3. Save the MODLRD01-Existing Conditions.dwg file 

 



Creating the MODLRD01-Existing Conditions Corridor _____________________________________________________ Chapter 5 

FDOT Civil 3D Basic © 2019 FDOT  6-13 

Exercise 6.5 Attach External Reference file TOPORD01.dwg 

In this exercise you will attach an external reference file to the MODLRD01-Existing Conditions file. 

 

1. From the Home Tab > Layers Panel, set the current Layer to Xreference01_dp 

 

2. From the Insert Tab > Reference Panel, select Attach 

 

3. From the Select Reference dialog. navigate to the C:\Civil 3D 2017 Projects\22049555201\Survey folder, 

select the TOPORD01.dwg file, then Click Open. 
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4. From the Attach External Reference dialog, for Reference Type select Overlay, clear Scale, Insertion point, 

and Rotation boxes, then Click OK. 

 

5. Perform a Zoom Window to display the 22049555201 project location 

 

6. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.6 Create Data Shortcut Reference for DTM Existing Surface 

In this exercise you will create Data Shortcut references to the DTM Existing Surface. 

 

1. From the TOOLSPACE, Prospector tab, expand Data Shortcuts, then expand the Surfaces collection, right-

click on DTM Existing, then select Create Reference. 

 

2. From the Create Surface Reference dialog, use DTM Existing as Name, and set Style to Border-Existing 

[Green] select Surfaces, then Click OK. 

 

3. From the TOOLSPACE, Prospector tab, expand the Surfaces collection. 
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4. Verify that the Surface DTM Existing is listed. 

 

 

5. Perform a Zoom Window to display the 22049555201 project location displaying the DTM Existing 

surface. 

 

6. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.7 Create Data Shortcut Reference for EX-SR61, SR61 and US98 Alignments 

In this exercise you will create Data Shortcut references to for the EX-SR61, SR61 and US 98 Alignments. 

 

1. From the TOOLSPACE, Prospector tab, expand Data Shortcuts, expand the Alignments collection, then 

expand the Centerline Alignments, right-click on DTM Existing, then select Create Reference... 

 

2. rom the Create Alignment Reference dialog, use EX-SR61 as Name, set Alignment style to FDOT 

Existing, select Surfaces, set Alignment label set to Truncated Scale 1-40, and then Click OK. 

 



Chapter 5 _____________________________________________________ Creating the MODLRD01-Existing Conditions Corridor 

6-18 © 2019 FDOT FDOT Civil 3D Basic 

3. Repeat  Step 4 steps to Create References  for Centerline Alignments SR61 and US98. 

a) For Centerline Alignment SR61, set Alignment style to FDOT Proposed. 

b) For Centerline Alignment US98, set Alignment style to FDOT Existing. 

c) Use default settings for other values. 

 

 

4. From the TOOLSPACE, Prospector tab, expand the Alignment collection, then expand Centerline 

Alignments. 

5. Verify that Centerline Alignments EX-SR61, SR61 and US98 are listed. 
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6. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.8 Create Existing Surface Profile for SR61 Centerline Alignment 

In this exercise you will create the Existing Surface Profile for the SR61 Centerline Alignment.. 

 

1. From the Home Tab > Create Design Panel, select Profile, then select Create Surface Profile. 

 

 

2. From Create Profile from Surface dialog, for Alignment select SR61, for Surface select DTM Existing, 

Click Add>>, set Style to FDOT Existing, then Click Draw in profile view. 
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3. From the Create Profile View -General dialog, set Profile view style to FDOT 40 Horz x 4 Vert Scale 10x 

GRID ON, then Click on Next >. 

 

 

4. From the Create Profile View - Station Range dialog, Click on Next >. 
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5. From the Create Profile View - Profile View Height dialog, Click on Next >. 

 

 

6. From the Create Profile View - Profile Display Options dialog, set Style to FDOT Existing, then Click on 

Next >. 
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7. From the Create Profile View - Data Bands dialog, Click on Next >. 

 

 

8. From the Create Profile View - Profile Hatch Options dialog, Click on Create Profile View. 

 

 

9. Place Profile View to the right of the 22049555201 project location. 

 



Chapter 5 _____________________________________________________ Creating the MODLRD01-Existing Conditions Corridor 

6-24 © 2019 FDOT FDOT Civil 3D Basic 

10. Perform a Zoom Window to display the 22049555201 project location and the SR61 Profile View.   

 

 

11. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.9 Create Existing Condition Assembly 

In this exercise you will create the Existing Condition Assembly. 

 

1. From the Home Tab > Create Design Panel, select Assembly, then select Create Assembly. 

 

2. From the Create Assembly dialog, for Name: use Existing Conditions, set Assembly to Other, set Assembly 

style to FDOT, set Code set style to FDOT XSection Existing, then Click OK 

 

 

3. Place the Existing Conditions assembly marker to left of the SR61 Profile View 
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4. From the Home Tab > Palettes Panel, select Tool Palettes.  

 

5. Right-click on the Tool Palette title bar, select FDOT Subassemblies, then select the Assemblies Tab. 

 

6. Select the FDOT Existing Features assembly. 
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7. Review Parameters settingsof the FDOT Existing Features assembly in the Properties Palette. 
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8. Select the Existing Condition assembly marker to place FDOT Existing Features Assembly, then press 

Enter to end command. 

 

9. Close the FDOT Subassemblies Tool Palette. 

 

10. Perform a Zoom Window to display the 22049555201 project location and the SR61 Profile View. 

 

 

11. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.10 Create SR61 - Existing Conditions Corridor 

In this exercise you will create the SR61 - Existing Conditions Corridor. 

 

1. From the Home Tab > Create Design Panel, select Corridor, then select Corridor. 

 

 

 

2. From the Create Corridor dialog, use the following values: 

 Name: SR61 - Existing Conditions 

 Corridor style: FDOT 

 Baseline type: 

 Select Alignment and profile 

 Alignment: SR61 

 Profile: DTM Existing 

 Assembly: Existing Conditions 

 Target Surface: DTM Existing 

 Click on Set baseline region parameters 
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3. Click OK 
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4. From Baseline and Region Parameters - SR61 - Existing Conditions dialog, Set Start Station to 700+50, set 

End Station to 715+50 

 

5. Select Frequency icon, then set Frequency's to 50’, points values to No, then click OK 
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6. Select Target icon, set Existing surface to DTM Existing, then click OK. 

 

7. From Baseline and Region Parameters - SR61 - Existing Conditions dialog, click OK 

8. From Corridor Properties - Rebuild dialog, click Rebuild the Corridor 
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9. Review the events in the Event Viewer, clear events, then close the Event Viewer 

 

 

10. Perform a Zoom Window to display the 22049555201 project location and the SR61 Profile View. 

 

 

11. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.11 Create Sample Lines for SR61 Centerline Alignment 

In this exercise you will create the Sample Lines for the SR61 Centerline Alignment. 

 

1. From the Home Tab > Profile and Sections Panel, select Sample Lines, then press Enter. 

 

2. From the Select Alignment dialog, select SR61, then Click OK 

 

3. From the Create Sample Line Group dialog, for DTM Existing set Style to FDOT Existing, for SR61 - 

Existing Conditions set Style to FDOT XSection Existing, then click OK. 

 

  



Creating the MODLRD01-Existing Conditions Corridor _____________________________________________________ Chapter 5 

FDOT Civil 3D Basic © 2019 FDOT  6-35 

4. From the Sample Line Tools toolbar, select From corridor stations 

 

5. From the Create Sample Lines - From Corridor Stations dialog, set From alignment start to False then set 

Start Station to 700+50, set To alignment end to False then set End Station to 715+50, set Left Swath 

Width to 120', set Right Swath Width to 120', then click OK. 

 

6. Press Enter to end command. 

 

7. Perform a Zoom Window to display the 22049555201 project location and the SR61 Profile View. 
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8. Save the MODLRD01-Existing Conditions.dwg file 
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Exercise 6.12 Create Cross Sections Views for the SR61 Centerline Alignment 

In this exercise you will create Cross Section Views for the SR61 Centerline Alignment. 

 

1. From the Status bar, Set the Annotation scale of the current view to 1" = 40' 

 

2. From the Home Tab > Profile and Sections Panel, select Section Views, then select Create Multiple Views. 

 

3. From Create Multiple Section Views - General dialog, Set Station Range to User specified, set Start to 

700+50, set End to 715+50, set Section view style to FDOT 40 Horz x 10 Vert 4X GRID ON, then click 

Next > 
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4. From Create Multiple Section Views - Section Placement dialog, set the Template for cross section sheet to 

C:\FDOT2018.C3D\Data\Templates\Sheets\Roadway\SHXSC.dwt|40 Horiz x 10 Vert, select the box with 

the three dots referenced by the Red arrow. 

 

5. From the Select Layout as Sheet Template dialog, select the box with the three dots referenced by the Red 

arrow to select the Drawing template file name. 
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6. From the Select Layout as Sheet Template dialog, double-click on the Sheets folder. 

 

7. From the Select Layout as Sheet Template dialog, double-click on the Roadway folder. 
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8. From the Select Layout as Sheet Template dialog, select the SHXSC.dwt file, then Click Open. 

 

9. From the Select Layout as Sheet Template dialog, from the Select a layout to create new sheets list, select 

40 Horiz x 10 Vert, then Click OK. 
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10. From Create Multiple Section Views - Section Placement dialog, Click Next>. 

 

11. From Create Multiple Section Views - Offset Range dialog, click Next > 
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12. From Create Multiple Section Views - Elevation Range dialog, click Next > 

 

13. From Create Multiple Section Views - Section Display Options dialog, set the Style for DTM Existing to: 

FDOT Existing, Set the Style for SR61 - Existing Conditions to: FDOT XSection Existing, then click Next 

> 
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14. From Create Multiple Section Views - Data Bands dialog, Click Create Section Views. 

 

 

15. Place the Sections above the SR61 Profile View 
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16. Perform a Zoom Window, to review results at Station 709+00.00 

 

 

17. Perform a Zoom Window to display the 22049555201 project location, the SR61 Profile View, and the 

Section Views. 

 

 

18. Save and Close the MODLRD01-Existing Conditions.dwg file 

 

 

 



 

FDOT Civil 3D Basic © 2019 FDOT  7-1 

7 Create CORRIDOR MODEL 

DESCRIPTION 

In this Chapter you will create and edit a corridor model. The process is completed in three stages of increasing 

complexity. To prepare the objects controlling the horizontal and vertical position of the design you will offset 

alignments and their corresponding design profiles. You will create an assembly as required before creating the 

corridor model for the first pass.  You will edit the assembly and assign targets within a corridor region for the 

second and third passes. 

OBJECTIVES 

In this chapter you will: 

• Create an alignment using the alignment offset command.  

• Create an offset profile. 

• Create and edit an assembly. 

• Modify subassembly parameters. 

• Create and edit a corridor model. 

• Assign edge of pavement alignments as target geometry. 

• Review the results after each pass. 

CHAPTER SETUP 

Run the Chapter 7 - 22049555201.exe file and restore all files to the C:\Civil 3D 20XX Projects folder. 

Do not change the location in which the Practice Files are installed. Doing so can cause errors when 

completing the exercises in this training manual. 
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Exercise 7.1 Create MODLRD02.dwg 

In this exercise you will create the MODLRD02 file to be used to create a Corridor Model. 

 

1. From the Select File dialog box, navigate to the C:\Civil 3D 2017 Projects\22049555201\Roadway folder 

and select 7.1 – Corridor Model - Lanes - Start.dwg. Click Open.  

2. Right click the drawing tab and click Save As. From the Save Drawing As dialog box, navigate to the 

C:\Civil 3D  2017 Projects\22049555201\Roadway folder and type MODLRD02.dwg for the File name. 

Click Save. 

 

  

3. Associate MODLRD02.dwg File to the Project. From the TOOLSPACE > Prospector tab > Data Shortcuts 

[C:\Civil 3D  2017 Projects\22049555201], right-click and select Associate Project to Current Drawing. 

 

Exercise 7.2 Create offset alignments and offset profiles 

The MODLRD02.dwg contains an alignment and a profile for SR61. The typical section shows the PGL at the 

through lane which is offset from the centerline by 11 feet left and right. To model the through lanes of SR61 

create offset alignments and transfer the elevation of the PGL to the offset profile. 

 



Create CORRIDOR MODEL __________________________________________________________________________ Chapter-9 

FDOT Civil 3D Basic © 2019 FDOT  7-3 

➢ To create the PGL geometry and profile use the Create Offset Alignment command.  

1. Click the Create Offset Alignment command from the Home tab > Create Design panel on the ribbon. 
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2. Pick the SR61 alignment. In the Create Offset Alignment dialog set the Incremental offset on left: to 11.00' 

and set the Incremental offset on right: to 11.00'.  Continue by clicking the Create Offset Profile tab. 
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3. On the Create Offset Profile tab match the following settings. Create profile for offset alignment is 

checked. The Parent profile is set to SR61-PGL from the drop-down list. Superimpose onto profile view: is 

set to SR6127+88.00 from the drop down list.  The Cross slope from parent profile: is set to 0. The Profile 

style is set to FDOT PGL Right. Click OK. 
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4. The offset alignments are added to the model. In the Prospector the new alignments are found under the 

Offset Alignments collection with the following names. 

o SR61-Left-11.00 

o SR61-Right-11.00 

The profiles for each offset alignment have the following names. 

o SR61-Left-11.00 - -11.000 

o SR61-Right-11.00 - -11.000 

 

5. Right click on the offset profile SR61-Left-11.00 - -11.000 and select the Properties command. 
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6. In the Profile Properties dialog > Information tab set the Object style to FDOT PGL Left. Click the Offset 

Parameters tab. 

 

7. On the Offset Parameters tab you can add station and slope values to the Cross slope regions area. For this 

alignment the cross slope will remain at zero for the entire length in order to match the elevations at the 

PGL. Click OK. 
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8.  Left and right profiles are added to the SR61 collection of profiles as superimposed profiles. 

 

9. There are 4 different profile icons in the Prospector; Surface Profile, Superimposed Profile, Layout Profile, 

Offset Profile. 
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10. Superimposed profiles are added to the SR61 Profiles collection. Right click the SR61-Left-11.00 - 

…profile and click Properties. 

 

11. Click the Profile Data tab. Notice under the Data Source heading is the offset alignment, SR61-Left-11.00 - 

-11.000 the parent object of this profile. Superimposing the offset profiles is a convenient way to view the 

PGL and offset profiles in one profile view. Click OK. 
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12. Object names have a tendency to become verbose. Take a moment to cleanup the profile names in the 

Prospector replacing the existing names with those shown in red below. To edit a profile name right click 

on the profile name in the Prospector and click Properties. 

 

13. The end result from renaming the profiles is shown below. 

     

14. Save your file before continuing. 
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Exercise 7.3 Creating a Corridor Model - First Pass – Through Lane 

Witness the workflow of creating a corridor model starting with a simple through lane example. This 
example demonstrates the sequence of steps required to create a corridor model in a concise manner. As 
the corridor model becomes more complex and more subassemblies are added the behavior of each 
subassembly is revealed one at a time to build your knowledge incrementally. A corridor model requires 
three objects, an alignment, a profile, and an assembly. The Create Corridor command processes these 
three objects to produce a corridor model. 

1. Click the Create Assembly command on the Home tab > Create Design panel under the Assembly button. 

In the Name: field type SR61-Right. Click OK. 
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2. Pick the Center of the circle labeled Assemblies as shown below. 

 

3. The Assembly Marker is placed at the center of the circle.  The Assembly Marker represents the location 

that the Assembly is positioned horizontally along the alignment and vertically along the profile. The 

subassembly geometry extends perpendicular to the alignment. 
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4. Subassemblies are attached to an Assembly to represent a typical cross section of the components of a road 

design. Subassemblies are organized on Tool Palettes. In this example you pick the FDOT Lane 

subassembly and add it to the Assembly Marker. Click the Tool Palettes button on the Home tab > Palettes 

panel. The Tool Palettes are anchored on the right side of your screen. Click the Lanes - FDOT tab. 
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5. Click FDOT Lane on the Lanes – FDOT tab. The Properties Palette displays allowing you to edit the Lane 

Width parameter as well as other parameters.  Type 11.00 for the Lane Width and press Enter. 

 

6. Pick the Assembly Marker using the pickbox on your cursor. The Lane subassembly is attached to the 

SR61-Right assembly.  Press ESC to end the command. 
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7. Click the Corridor command under the Home tab > Create Design panel > Corridor button. 
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8. Enter the Name: SR61-Right. Select the SR61-Right-11.00 alignment. Select the SR61-Right-11-PGL 

profile. Select the SR61-Right assembly. Click OK. 
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9. The Baseline and Region Parameters dialog box organizes the display of the objects you selected to make 

the corridor.  The first row contains the Baseline information meaning, the alignment, the profile, and the 

Starting and Ending Stations. The second row represents the first Region.  The Region is nothing more than 

a station range between a starting and ending station typically representing something less than the full 

length of the Baseline alignment. There can be more than one Region under the Baseline.  Regions can not 

have overlapping station ranges. An explanation of Frequency and Targets will come later in this training 

guide. Click OK. Click Rebuild the corridor. 
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10. This drawing has named views. Pick the control in the canvas in the upper left corner labeled Top. Hover 

over Custom Model Views. Click Plan to restore the Plan view. 
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11. Zoom in to station 704. Hover the crosshairs over the corridor model to display the tooltip. The lines 

perpendicular to the alignment identified as Corridor - Link are also referred to as frequency lines.  The 

lines parallel with the alignment are corridor feature lines that connect the point codes from one station to 

the next. The Lane subassembly is applied to the SR61-Right baseline (alignment) at 25' intervals. In Plan 

view they look like lines. Notice the SR61 alignment labels have tick marks at 20' intervals. The Lane 

subassembly Lane Width parameter is set to 11' and applied to the right side of the baseline at a slope of -

2%.  
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12. Restore the SE Isometric view. Zoom to station 704. The blue and red geometry represents the pavement, 

base and subbase material of the Lane subassembly in a 3D view. This ladder-like geometry is a corridor 

model. Essentially, a corridor model is a typical cross section applied at intervals along an alignment at the 

elevation of the profile. Restore the Plan view. Save the drawing. 
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Exercise 7.4 Corridor Model – Second Pass – Curb, Sidewalk, and EOP Target 

Continuing with the SR61-Right corridor model add more subassemblies and assign a target to control the 

horizontal position of the outside Edge of Pavement. 

 

1. Restore the Assemblies view. Click the Curb tab on the Tool Palette. Click the Type F curb. Set the Side to 

Right in the Properties palette. Zoom into the SR61-Right assembly and pick the upper right circle on the 

Lane subassembly. Press ESC to end the command. 
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2. Click the Urban tab on the Tool Palette. Click the FDOT Sidwalk subassembly. Keep the default values in 

the Properties Palette. Pick the circle at the top back of curb on the Curb subassembly. Press ESC to end the 

command. 
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3. Throughout the design process you will make changes to the subassembly parameters. Refering back to the 

Typical Section you notice the parameters for the Sidewalk subassembly do not match. Grip the Sidewalk 

subassembly and make changes on the Properties Palette. 
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4. Assign a target parameter to the Lane Assembly to control the outside edge of pavement. Restore the Plan 

view and grip the corridor model. Click the Edit Targets command from the Modify Regions panel on the 

ribbon. Select a region to edit: appears as a command line prompt. Hover the cursor over the corridor to see 

the region perimeter highlighted in blue. Pick inside the region. 
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5. In the Target Mapping dialog click the cell in the Object Name column on Lane Width row. In the Set 

Width Or Offset Target dialog select Alignment - PavtAsphalt RT then click the Add button. Click OK. 

Click OK again to close the Target Mapping dialog. Press ESC to end the Edit Targets command. 
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6. The corridor is rebuilt. The Lane subassembly stretches to width of the Alignment – PavtAsphalt RT. The 

Curb and Sidewalk assemblies maintain their relative position to the outside of the Lane subassembly. 

Hover over each feature line to display the tooltip. 

 

7. Click the Save button. 

8. Restore the SE Isometric view. Zoom in to view the corridor model in 3D. 

 

9. The Lane subassembly now covers two through lanes and a bike lane.  The Curb and Sidewalk 

subassemblies are more recognizable in the 3D view. Restore the Plan view and click the Save command. 
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Exercise 7.5 Creating a Corridor Model – Third Pass – Median and Left Turn Lane 

Continue with the SR61-Right corridor model. Edit the Assembly to add a FDOT Lane subassembly to the left 

of the Assembly Marker. Add EOP Targets at Median and Left Turn Lanes.  

 

1. Restore the Assemblies view. Click the Lanes – FDOT tab on the Tool Palette. Click the FDOT Lane 

subassembly. In the Properties Palette set the side to Left.  

2. Set the slope to 2%. Set the width to 5'. The 5' width is arbitrary and for display purposes in the Assembly. 

The alignment targets will control the actual width of the Lane.  

3. Point codes are used to name corridor feature lines. The Pavement Inside Edge Point Code represents the 

side closest to the assembly marker. If this were a simple crowned road the assembly marker would 

represent the crown at the CL making it the inside edge of the lane. In this example the inside edge of the 

lane represents the PGL at the inside edge of the through lane on the Right side of SR61. Enter R_PGL for 

the Pavement Inside Edge Point Code. 
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4. In this example the Target Mapping uses alignments along the median and traffic separators. They 

collectively represent the R_Inside EOP at Median. Set the Pavement Outside Edge Code Point to 

R_Median. Pick the larger circle at SR61-Right Assembly Marker to place the subassembly. Press ESC to 

end the command. 
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5. Restore the Plan view. Grip the corridor model. Click the Edit Targets command.Click inside the blue 

highlighted area of the corridor model to select the Region in response to the command line prompt Select a 

region to edit:. In the Target Mapping dialog click the cell in the Object Name column on Lane Width row 

of the Left Assembly Group.  

  

 

6. In the Set Width Or Offset Target dialog click the Select from drawing button. 
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7. Zoom to an area near station 701 and pick the alignment on the right side of the traffic separator. Zoom to 

an area near station 711 and pick the alignment on the right side of the median. Zoom to an area near 

station 714 and pick the alignment on the right side of the traffic separator. Press Enter to return to the Set 

Width Or Offset Target dialog. 
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8. Click the Add button. The three alignments are added to the Selected entities to target: list. Resize the 

column widths to display the alignment names. Click OK. Click OK again to close the Target Mapping 

dialog. Press ESC to end the Edit Targets command. 
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9. Zoom to station 711. Notice the median alignment tapers toward the traffic separator to form a Left Turn 

Lane. Click the Save button. 

 

10. Restore the SE Isometric view.  Zoom to Station 711. The Lane subassembly on the left widens to form the 

left turn lane at the traffic separator.  Restore the Start view. 
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11. Expand the Corridors collection in the Prospector. Corridor related commands are available by right 

clicking on the corridor name SR61-Right.  Expand the Assemblies collection.  Notice how the 

subassemblies are organized by their position Right or Left of the Baseline (a.k.a. assembly marker) 

 

 

12. Save and Close MODLRD02.dwg  
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8 Corridor Surface 

DESCRIPTION 

You will create a surface from a corridor model in this chapter.  When you review the results, you will use the 

object viewer. 

OBJECTIVES 

In this Chapter you will: 

• Create a corridor surface using the commands in the corridor properties dialog. 

• Apply a surface boundary using the commands in the corridor properties dialog. 

• Review the surface in the Prospector. 

• Change the Surface Style in the Surface Properties dialog 

• Display the surface as triangles. 

• View the surface in the Object Viewer.  

• Change the Visual Style in the Object Viewer 

• Change the View Controls in the Object Viewer 

• Create 3D solids from the corridor model. 

CHAPTER SETUP 

Run the Chapter 8 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects folder.  

Do not change the location in which the Practice Files are installed. Doing so can cause errors when completing 

the exercises in this training manual. 
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Exercise 8.1 Create MODLRD03.dwg 

In this exercise you will create the MODLRD03 file to be used to create a Corridor Surface. 

 

1. From the Select File dialog box, navigate to the C:\Civil 3D 2017 Projects\22049555201\Roadway folder 

and select 8.1 - Creating a Corridor Surface.dwg. Click Open.  

2. Right click the drawing tab and click Save As. From the Save Drawing As dialog box, navigate to the 

C:\Civil 3D  2017 Projects\22049555201\Roadway folder and type MODLRD03.dwg for the File name. 

Click Save.  

3. Associate MODLRD03.dwg File to the Project. From the TOOLSPACE > Prospector tab > Data Shortcuts 

[C:\Civil 3D  2017 Projects\22049555201], right-click and select Associate Project to Current Drawing. 

 

 

Exercise 8.2 Corridor Model Properties 

In this exercise you will create a corridor surface using commands and settings available in the Corridor 

Properties dialog box. 

 

1. To create a corridor surface open the Corridor Properties dialog. On the Toolspace > Prospector tab expand 

the Corridors collection and right click SR61-Right. Click Properties. 

 

 

 

  



Corridor Surface ___________________________________________________________________________________ Chapter-9 

FDOT Civil 3D Basic © 2019 FDOT  8-3 

2. Click the Surfaces tab. Click the Create a corridor surface button on the far left. Edit the surface name to 

SR61-Right. Set the Surface Style to Contours Major 5' Minor 1'. With the Data type set to Links and the 

Specify code: set to Top click the + Add surface item button.  
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3. Click the Boundaries tab. Right click the SR61-Right and click Corridor extents as outer boundary. Click 

OK. Click Rebuild the corridor. 
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4. Review in Toolspace. Expand the Surfaces collection in the Prospector. Right click the surface SR61-Right. 

Click Surface Properties. On the Information tab notice the Surface Style is set to Contours Major 5' Minor 

1'. Click the Definition tab.  Notice the Operation type has one item: Surface From Corridor. 
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5. Review the SR61-Right surface as it is displayed in the drawing. Zoom to station 708. Hover over a 

contour. The tooltip identifies the object as a Corridor Surface. 
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Exercise 8.3 3D Display Techniques 

In this exercise you will see different ways to view the corridor surface in 3D. The first uses the Object Viewer 

to allow you to rotate the surface and apply display styles without affecting the display in the drawing editor.  

The second uses 3D solids generated from the corridor model. The third shows a slice through the corridor 

solids.  

 

1. Using the Object Viewer. Grip the surface by picking one of the contours. Click Surface Properties from 

the ribbon. On the Information tab set the surface style to Triangles Exag 3-1 Proposed. Click Apply. Click 

OK. 
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2. Click the Object Viewer command on the ribbon. Set the Visual Syles drop down list in the upper left 

corner to Shaded with edges. Set the View Control to SE Isometric. Use the Zoom Window button to zoom 

closer to the turn lane.  

 

 

 

 

  



Corridor Surface ___________________________________________________________________________________ Chapter-9 

FDOT Civil 3D Basic © 2019 FDOT  8-9 

3. Set the View Control to NW Isometric. Use the Zoom Window button to zoom closer to the turn lane. 

Notice the curb face is much more prominent when the surface style has a 3x vertical exaggeration applied.  

Close the Object Viewer by clicking the X in the upper right corner. 

 

 

4. Exporting Corridor Solids. Grip the surface by picking the edge of one of the blue triangles. Use the 

Surface Properties dialog to set the Surface Style to No Display.  Grip the corridor model. Click the Extract 

Corridor Solids from the Corridor Tools panel in the ribbon. Click the All Regions hyperlink on the 

command line. Use the default settings on all three panels in the Extract Corridor Solids dialog. Click 

Extract Solids. 
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5. Save the MODLRD03 drawing.  

6.  Set the View Controls to NW Isometric. Set the Visual Style Controls to Realistic. Zoom to the turn lane 

near station 712. Hover the cursor over the model to display the tooltip 3D Solid. 
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7. Viewing a section cut through corridor model solids. Set the View Controls to Plan.  Zoom to station 712. 

Set the Workspace to 3D Modeling.   

 

8. Click the Section Plane command from the Home tab > Section panel on the ribbon. Click the Draw section 

hyperlink on the command line. Turn off running object snaps. 
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9. Pick the start point near the station label 712. Pick the next point just beyond the sidewalk at station 712. 

Press Enter. Pick a location north of the section line to respond to the command line prompt, Specify point 

in direction of section view:. Hover over the section object to display the tooltip. 

 

10. Set the View Controls to SE Isometric. Zoom in to station 712. Set the Visual Style Controls to Conceptual. 

The corridor solids are cut away at the section object revealing the depth and underlying material specified 

in the subassemblies. 
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11. You may wish to create a live section to display a slice through the solids. The steps for creating a live 

section are not included in this manual. Set the Civil 3D Workspace current. Set the View Controls to Plan.  

Click Save. 
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FDOT Civil 3D Basic © 2019 FDOT  9-1 

9 Create SR61-Left Corridor 

DESCRIPTION 

In this chapter you will apply your skills learned in the previous chapter to create a corridor model on the left 

side of SR61. 

OBJECTIVES 

In this Chapter you will: 

• Copy an Assembly 

• Mirror subassemblies 

• Add a daylight subassembly 

• Create a corridor model 

• Assign targets to the corridor model 

CHAPTER SETUP 

Run the Chapter 9 - 22049555201.exe file and restore all files to the C:\Civil 3D  2017 Projects folder.     

Do not change the location in which the Practice Files are installed. Doing so can cause errors when completing 

the exercises in this training manual. 
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Exercise 9.1 Create MODLRD02.dwg 

In this exercise you will create the MODLRD02 file to be used to create a Corridor Surface. 

 

1. From the Select File dialog box, navigate to the C:\Civil 3D 2017 Projects\22049555201\Roadway folder 

and select 9.1 - Creating SR61-Left Corridor Model.dwg. Click Open.  

2. Right click the drawing tab and click Save As. From the Save Drawing As dialog box, navigate to the 

C:\Civil 3D  2017 Projects\22049555201\Roadway folder and type MODLRD02.dwg for the File name. 

Click Save.  

3. Associate MODLRD02.dwg File to the Project. From the TOOLSPACE > Prospector tab > Data Shortcuts 

[C:\Civil 3D  2017 Projects\22049555201], right-click and select Associate Project to Current Drawing. 

 

 

Exercise 9.2 Create SR61-Left Assembly 

 

In this exercise you will reuse the assembly for the right side of SR61 and configure it for use on the left side of 

SR61 

 

1. Copy SR61-Right Assembly and rename to SR61-Left. Restore the Assemblies view. Click the Copy 

command from the Home tab > Modify panel. Pick the SR61-Right assembly marker. Pick the bottom 

quadrant of the circle as the base point. Pick the top quadrant of the circle as the destination. Press Enter to 

end the copy command. 
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2. Rename the copied assembly to SR61-Left.  Grip the assembly marker and click Assembly Properties in the 

ribbon. Type SR61-Left in the Name field and click OK. 

 

 

3. Mirror SR61-Left Assembly. Zoom in closer to the SR61-Left assembly. Use a crossing window to select 

all the subassemblies on the right side of the assembly marker. Click Mirror on the Modify Subassembly 

panel on the ribbon. Pick the assembly marker in response to the command line prompt Select marker point 

within assembly for the mirrored subassemblies. Press Delete on the keyboard to erase the highlighted 

subassemblies on the right side of the assembly marker. Use the same technique to Mirror the shorter 

FDOT Lane subassembly to the right side of the assembly marker. 
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4. Edit the Point Codes changing the R_ prefix to L_.  Grip the Lane subassembly on the right side of the 

assembly marker. Open the Properties Palette. Rename the two point codes. 

o Pavement Inside Edge Point Code is L_PGL 

o Pavement Outside Edge Code Point is L_Median 
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5. Add Daylighting Subassembly. Click the Daylight – FDOT tab on the Tool Palette. Click FDOT Simple 

Daylight. Pick the outermost circle on the Sidewalk subassembly. Press ESC. Click Save. 
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Exercise 9.3 Create Corridor Model SR61-Left 

In this exercise you will create the SR61-Left corridor model which represents the left side of SR61. 

 

1. Click the Corridor command under the Home tab > Create Design panel > Corridor button. Type SR61-

Left in the Name field. Select SR61-Left-11.00 from the Alignment drop-down list. Select SR61-Left-PGL 

from the Profile drop-down list. Select SR61-Left from the Assembly list. Select DTM-Existing for the 

Target Surface.  Click OK. 
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2. Assign Targets. The Baseline and Region Parameters dialog opens after the Create Corridor dialog closes. 

Click Set all Targets. 

 

3. In the Target Mapping dialog click the cell in the Object Name column on Lane Width row in the 

Assembly Group Left (2). In the Set Width Or Offset Target dialog select Alignment - PavtAsphalt LT then 

click the Add button. This alignment represents the outside edge of pavement. Click OK.  
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4. In the Target Mapping dialog click the cell in the Object Name column on Lane Width row in the 

Assembly Group Right. In the Set Width Or Offset Target dialog hold down the Ctrl key while selecting 

Alignment - PavtAsphalt LT Inside, Alignment – Traffic Sep North LT, and Alignment Traffic Sep South 

LT. Click the Add button. These alignments represent the inside edges of pavement. Click OK 

 

5. Click OK again to close the Target Mapping dialog. Click OK to dismiss the Baseline and Region 

Parameters dialog. Click Rebuild the Corridor.  The Event viewer in the Panorama Palette shows errors at 

the beginning and ending alignment stations where there is no surface data to target for daylighting.  This 

problem will be addressed in the next Chapter. Close the Panorama Palette. Click Save. 
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6. Review the corridor models. Restore the Plan view in View Controls in the upper left of the canvas. The 

left and right sides of SR61 are corridor models.  The left side shows the daylighting outside of the 

sidewalk.   

 

7. Add the daylight subassembly to the SR61-Right assembly. Restore the Assemblies view in View Controls. 

Click the Daylight – FDOT tab on the Tool Palette. Click FDOT Simple Daylight. Pick the outermost circle 

on the Sidewalk subassembly on the SR61-Right Assembly. Press ESC. Click Save. 
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8. Assign the daylight target to the SR61-Right corridor model. Restore the Plan view in View Controls. 

Zoom in to station 712. Grip the SR61-Right corridor model. Click the Edit Targets command in the 

ribbon. Click inside the SR61-Right corridor model area to select the region. Set the Target Surface to 

DTM Existing. Click OK. Press ESC to end the Edit Targets command. The corridor is rebuilt and the 

daylight lines appear outside the Sidewalk on the SR61-Right corridor model. 
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9. Set the corridor region limits to the station range between intersections. Grip the SR61-Right corridor 

model. Zoom to the north end of SR61. Pick the diamond grip and drag it south to the traffic separator. Pick 

to reposition the grip to a point near the north traffic separator. Do the same for the SR61-Left corridor 

model region. The positions are not intended to be exact. If you prefer you may snap to a station label tick 

mark to place the grips. 
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10. Set the corridor region limits on the south side of SR61.  Zoom to the intersection of US98 and SR61. Pick 

the diamond grip on the SR61-Left corridor and drag it northwest. Snap to the alignment label tick at 

station 701..Do the same for the SR61-Right corridor region. You no longer get the error messages in the 

Event Viewer. Close the Panorama. Press ESC. 

 

11. Restore the Plan view  

 

12. Save the MODLRD02.dwg 
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10 Create SR61 Final Surface 

DESCRIPTION 

In this Chapter you will create a corridor surface on the left side of SR61 then combine the surfaces on the left 

and right sides of SR61 into a SR61 Final Surface. 

OBJECTIVES 

In this Chapter you will: 

• Create a corridor surface. 

• Paste SR61-Left surface to the Final Surface. 

• Review the SR61 Final surface results in the Object Viewer. 

CHAPTER SETUP 

Run the Chapter 10 - 22049555201.exe file and restore all files to the C:\Civil 3D 2017 Projects folder.     

Do not change the location in which the Practice Files are installed. Doing so can cause errors when completing 

the exercises in this training manual. 
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Exercise 10.1 Create MODLRD02.dwg 

In this exercise you will create the MODLRD02 file to be used to create Surfaces. 

 

1. From the Select File dialog box, navigate to the C:\Civil 3D 2017 Projects\22049555201\Roadway folder 

and select 10.1 - Creating SR61-Left Corridor Surface.dwg. Click Open.  

2. Right click the drawing tab and click Save As. From the Save Drawing As dialog box, navigate to the 

C:\Civil 3D  2017 Projects\22049555201\Roadway folder and type MODLRD02.dwg for the File name. 

Click Save. 

3. Associate MODLRD02.dwg File to the Project. From the TOOLSPACE > Prospector tab > Data Shortcuts 

[C:\Civil 3D  2017 Projects\22049555201], right-click and select Associate Project to Current Drawing. 

 

 

Exercise 10.2 Create SR61-Left Corridor Surface 

In this exercise you will use the SR61-Left Corridor Properties dialog to create a corridor surface. 

 

1. Expand the Corridors collection in the Prospector.  Right click on SR61-Left. Click Properties. 
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2. Click the Surfaces tab. Click the Create a corridor surface button. Edit the surface name to SR61-Left. 

Click + Add surface data.  Click the Boundaries tab. 

 

3. Add a surface boundary. Right click SR61-Left and click Corridor extents as outer boundary. Click OK. 

Click Rebuild the corridor. Click Save. 
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Exercise 10.3 Create a SR61 Final Surface 

In this exercise you will combine the DTM Existing, SR61-Left, and SR61-Right surfaces in a new surface 

called SR61 Final. 

 

1. Continue working in the MODLRD02.dwg In the Prospector right click the Surfaces collection. Click 

Create Surface. Type SR61 Final in the Name field. Click OK.  
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2. Expand the Surfaces collection. Expand the SR61 Final. Expand Definition. Right click Edits and click the 

Paste Surface command. 

 

3. Select all the surfaces in the list. Click OK. 
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4. Right click SR61 Final surface. Click Surface Properties. Click the Definition tab in the Surface Properties 

dialog. In the Operation Type area of the dialog you see the surface names added to the SR61 Final surface. 

The Paste Surface command will add each surface one at a time in the order they appear in the Operation 

Type list. The correct order is to have the existing surface added first. The Paste Surface command will use 

each surface boundary as a cutting object to remove data within the boundary and replace it with the data of 

the surface being added to the destination surface. 
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5. Review the SR61 Final surface. Click the Information tab in the Surface Properties dialog. Set the Surface 

Style to Triangles Exag 3-1 Proposed. Click Save. 

 

6. Pick a triangle edge to select the surface. Click the Object Viewer command on the General Tools panel in 

the ribbon. Select Shaded with edges from the Visual Styles drop-down list. Select NW Isometric from the 

View Control drop-down list. Click the Zoom Window button and zoom to the intersection at the North 

Traffic Separator. The DTM Existing surface forms the base. The SR61-Left and SR61-Right surfaces are 

pasted on top of the DTM Existing.  The voids at the traffic separators and median still have elevation data 

from the DTM Existing surface.  
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7. Click the Save Image button in the upper left of the Object Viewer. Save the file SR61 Final.png in the 

Roadway folder of the current project. Close the Object Viewer.  

 

8. Set the style of SR61 Final surface to Triangles 1-1 Proposed (Blue). Click the Surfaces collection in the 

Prospector to display the list of surfaces in the item view (the lower part of the Prospector). Click the 

surface style next to SR61 Final to open the Select Surface Style dialog. Select Triangles 1-1 Proposed 

(Blue) from the drop-down list. 
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9. Right click the SR61-Right corridor in the Prospector and click the Drive command. 

 

10. Zoom in to station 704. Pick the edge of pavement on the right side of the median. 
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11. Select EOP from the list in the Select a Feature Line dialog. Click OK. 

 

12. Click the Play/Pause button on the ribbon to start an animated drive sequence. Click the Close button on the 

right side of the ribbon. 

 

 

 

13. Set the style of SR61 Final surface to _No Display. Click the Surfaces collection in the Prospector to 

display the list of surfaces in the item view (the lower part of the Prospector). Click the surface style next to 

SR61 Final to open the Select Surface Style dialog. Select _No Display from the drop-down list. Click 

Save. 

 

14. Save and Close MODLRD02.dwg. 


