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FDOT Civil 3D Subassembly Composer 

 

Description 

This 1-day course provides participants with training on Civil 3D Subassembly Composer. To create and use a 

subassembly created with subassembly composer. 

Objectives 

The student will have a basic understanding of …. 

FDOT Civil 3D State Kit Tools 

Audience 

This course is intended for roadway designers. 

Prerequisites 

Participants need to have a (basic) understanding of AutoCAD and Civil 3D. 

Duration: 16 Hours 

Professional Credit Hours: 8 PDHs 

 

Note PDH Credit will only be available with Instructor lead or Computer Based Training (CBT) thru Learning Curve. 
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1 INTRODUCTION 

AUTODESK SUBASSEMBLY COMPOSER 

Autodesk Subassembly Composer for AutoCAD Civil 3D provides an interface for composing and modifying 

complex subassemblies, without the need for programming. It is available to be installed when installing 

AutoCAD Civil 3D. Without the need to be an expert in programming, users can create custom subassemblies to 

meet their specific needs that can be used again and again once they are imported in Civil 3D, making corridors 

have endless possibilities. In order to create subassemblies and as reviewed in this document, either Civil 3D or 

Subassembly composer are required.  

To use a subassembly created with subassembly composer, users must have Autodesk Subassembly Composer 

installed on their machines. The subassembly in composer is saved as a pkt file, whenever the file is opened in 

AutoCAD Civil 3D, the pkt is automatically converted to its latest version. 

Subassembly composer consists of five individual windows: Tool Box, Flowchart, Preview, Properties and 

Settings and Parameters. Each of these windows may be moved around independently using the docking controls 

. At any time, the default position can be regained by going to View> Restore Default Layout. 

 

The Toolbox window is the storage location for elements available for constructing the subassembly. This 

window will provide all elements used to build the flowchart. There are five sections: Geometry, Advanced 

Geometry, Auxiliary, Workflow and Miscellaneous. To use any of these elements, simply click on the desired 

element and drag and drop it over into the Flowchart panel. 

The Flowchart panel is used to build and organize the subassembly logic and elements. A flowchart could be a 

simple straight line of logic or it can be a complex tree of branching decisions either way always beginning at the 
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Start element. If there is a problem with the subassembly a small red circle with an exclamation point will be 

displayed in the upper right hand corner of this panel. 

The Preview panel  allows users to view your current geometry. There are two preview modes:  

• Roadway Model which shows the subassembly built using any target surfaces, target elevations, and/or 

target offsets; and  

•  Layout Mode which shows the subassembly built using only the input parameters (no targets).  

At the bottom of this panel are two checkboxes for Codes which are shown in brackets [] and Comments which 

are shown in parentheses (). If any Codes or Comments were entered in the properties for the points, links, or 

shapes then this information will be listed next to the applicable geometry. 

The Properties panel  is the input location of the parameters that define each geometry element. 

The Settings and Parameters panel  consists of five tabs that define the subassembly: Packet Settings, 

Input/Output parameters, Target parameters, Superelevation, and Event Viewer. 

Typical workflow 

The typical workflow for creating a subassembly is broken into six steps: 

1 Create a Project  

2 Specify subassembly parameters  

3 Add geometry elements  

4 Modify geometry elements  

5 Preview Geometry  

6 Save the project and import into AutoCAD Civil 3D. 
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2 FIXED SUBASSEBLIES 

FIXED GEOMETRY SUBASSEMBLY CREATION  

1 Open Autodesk Subassembly Composer from All programs > Autodesk  > Autodesk Subassembly 

Composer 2018 

 

2 Select File > Open the file 2.0 - Fixed - Start.pkt from the C:\Civil 3D 

2018\Projects\22049555201\Roadway folder 

3 Grab the Point from the Geometry Toolbox and drop it under the Start Icon on the Flowchart panel 

 

4 Notice and review the Properties panel  automatically updated upon the point creation: 

 

5 The Point is automatically assigned a Point Number, P1, the From Point is set to Origin. Notice and 

review the Preview panel  with the point created 
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6 Grab the Point from the Geometry toolbox and drop it under the point previously created, P1. Notice 

that the new point P2, is automatically assigned and a Link is automatically created: 

 

7 Under the Properties panel , under the Point Geometry Type, change the Type to Slope and Delta X. 

Under Point Geometry Properties, select From Point P1, Slope of -2% and Delta X, 10 

 

8 On the Preview panel , select the Fit to Screen button to visualize the Point and Link created based on 

the geometry parameters previously created: 
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9 Grab the Point from the Geometry toolbox and drop it under the point previously created, P2. Notice 

that the new point P3, is automatically assigned and a Link is automatically created: 

 

10 Under the Properties panel , verify that the Type under Point Geometry Type is set to Delta X and Delta 

Y. Under Point Geometry Properties, select From Point P2, type in 0 for Delta X and -1 for Delta Y: 

 

11 Select the Fit to Screen button. The Link and Point are created: 
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12 Grab the Point from the Geometry toolbox and drop it under the point previously created, P3. Notice 

that the new point P4, is automatically assigned and a Link is automatically created: 

   

13 Under the Properties panel , verify that the Type under Point Geometry Type is set to Delta X and Delta 

Y. Under Point Geometry Properties, select From Point P1, type in 0 for Delta X and -1 for Delta Y: 

 

14 The Preview panel  is automatically updated: 
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15 Grab the Link from the Geometry toolbox and drop it under the point previously created, P4. Notice 

that the new link, L4, is automatically assigned and a Link is automatically created: 

 

16 Under the Properties panel , change the Link Position. Select Start Point P3, and End Point, P4: 

 

17 The Preview panel  is updated: 
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Note The geometry so far is made out of Links and Points.  

18 In order to create a shape, grab the Shape from the Geometry toolbox and drop it under the link 

previously created, L4. Notice that the new shape, S1 is automatically created: 

 

19 Under the Properties panel , on the component, Links, select the green cube icon located on the right 

side: 

 

20 Place a data point anywhere on the rectangle made by points and links on the Preview panel . A new 

Shape, S1 is automatically created: 
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So far, the shape, links and points are static. They are defined by a geometry established under the Properties 

panel . 

Nothing, at this point, is targeting anything. We will make point P2 be defined by a slope and distance as defined 

previously or this point may also be targeting an offset alignment. 
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3 TARGETS 

TARGETS 

Targets are defined under the Settings and Parameters panel on the Target Parameters Tab and can be set to 

Surfaces, Elevations or Offsets. 

 

Continue working on the same file or open the file 3.0 - Targets - Start.pkt from the C:\Civil 3D 
2018 Projects\22049555201\Roadway folder 

1 Under the Settings and Parameters panel select the Target Parameters tab. 

2 Create an Offset target by selecting the italic Create Parameter line. Rename TargetParameter1 to 

OffsetAlignment, and set the Type to Offset. 

 

3 Leave the Preview Value at its default value. Notice also the change on the Preview panel . 

4 Click on the P2&L1 rectangle on the Flowchart panel: 
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5 On the Properties panel , change the Offset Target (overrides Delta X) to OffsetAlignment (This target 

was created previously and available for Selection): 

 

Note If the OffsetAlignment exists, it will overwrite the Delta X value. 

6 In order to test the behavior, notice the Preview panel  the arrow with the OffsetAlignment name. It 

depicts the target recently created and available for testing. The geometry is shrunk since the 

OffsetAlignment preview value is 0: 
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7 Select the OffsetAlignment arrow. It should turn yellow and drag it to the right. Release the selection.  

Notice that the Preview value under the Target Parameters changes and the shape geometry is updated:  

 

Note Point P2 is now being controlled by an Offset Alignment. 

8 Under the Settings and Parameters panel  select the Target Parameters tab. 

9 Create an Elevation target by selecting the italic Create Parameter line. Rename TargetParameter2 to 

Elevation, set the Type to Elevation and set the Preview Value to  -1 
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10 Select the P2&L1 rectangle from the Flowchart panel. Set the Offset Target to OffsetAlignment and 

set the Elevation Target to Elevation.  

 

11 On the Preview panel , select  and drag the OffsetAlignment and Elevation arrows and review the 

behavior of the shape and link: 

 

If these targets are defined in the Corridor in Civil 3D, the width and slope of the link will be controlled by an 

alignment and Elevation Targets. 
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4 Input / output parameters 

INPUT AND OUTPUT PARAMETERS 

Input and Output Parameters are values that can be defined once the assembly is imported into full blown Civil 

3D.  They are defined under Setting and Parameters window Input/Output tab on the bottom right window of 

Subassembly composer: 

 

If now, the width of the shape is to be controlled not by a target parameter, but by an input/output parameter, they 

must be defined on this window. 

Continue working on the same file or open the file 4.0 - Input Output - Start.pkt from the C:\Civil 
3D 2018 Projects\22049555201\Roadway folder 

1 Under the Setting and Parameters window select the Input/Output Parameters tab. 

2 Create an Width Input by selecting the italic Create parameter line. Rename Parameter2 to Width, set 

the Type to Double, set the Direction to Input, and set the Default Value to 12: 

 

3 Highlight the P2 & L1 rectangle from the Flowchart panel and under Point Geometry Properties, revert 

the Offset Target (overrides Delta X) to None, Elevation target to None, leave -2% for the Slope and 

write in width for Delta X: 
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Note Notice the Preview panel  automatically updated. 

4 Under the Settings and Parameters panel  select the Input/Output Parameters tab. 

5 Change the Default Value for the Width parameter to 5.00. The Preview panel  is automatically updated 

for the width.  

 

6 Select the italic Create parameter line under the Input/Output Parameters tab. Rename Parameter3 to 

Thickness, set the Type to Double, set the Direction to Input,  and set the Default Value to 1: 

 

7 Highlight the P3 & L2 rectangle from the Flowchart panel and under Point Geometry Properties, 

change the Delta Y from -1 and write in  –thickness: 
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8 Highlight the P4 & L3 rectangle from the Flowchart panel and under Point Geometry Properties, 

change the Delta Y from -1 to –thickness: 

 

9 On the lower right Input/Output Parameters window, change the Thickness parameter to 3: The 

Preview panel  automatically updates.  

 



Chapter 4 ____________________________________________________________________________ Input / output parameters 

4-4 ©2018 FDOT   FDOT Civil 3D Subassembly Composer 

 

10 Revert the value to 1: 
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5 CODES 

POINT, LINK AND SHAPE CODES 

Point, Link and Shape Codes can be assigned directly in Subassembly Composer by typing any name under the 

Point, Link or Shape Code. Code names must be in quotes. 

Continue working on the same file or open the file 5.0 - Codes - Start.pkt from the C:\Civil 3D 
2018 Projects\22049555201\Roadway folder 

1 Highlight the P2&L1 rectangle on the Flowchart panel. Under the Properties panel , type in “EOP” 

under Point Codes: 

 

2 In the Preview panel , toggle on the Codes box at the lower left corner of the window. Notice that P2 

has the EOP Point Code name displayed in brackets. 
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3 If multiple point codes are to be assigned to one point, names have to be separated by a comma. On the 

Properties panel  for point P2, under Point Codes, type in a coma next to “EOP” and type in “ETW”. 

Point P2 has two point codes assigned to it. Notice that P2 displays now both the EOP and ETW Point 

Code names in brackets. If not, in the Preview panel , toggle off then back on the Codes box at the 

lower left corner of the window. 

Note: To display both the EOP and ETW codes in the Preview panel you may have to roll your scroll 

wheel in or out on your mouse  to zoon in or out.  Hold your scroll wheel down on your mouse to pan 

around as well. 
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4 Scroll down on the Properties panel , and under Link, type in “Top” for the Codes: 

 

5 Select the L4 rectangle from the Flowchart panel and on the Properties panel , type in “Datum” under 

Link Codes: 

 

6 Select the S1 rectangle from the Flowchart panel and on the Properties panel , type in “Asphalt” under 

Shape Codes: 
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7 In the Preview panel  Point Codes for P2, L1, L4, and S1 are displayed in brackets. If not, in the Preview 

panel , toggle off then back on the Codes box at the lower left corner of the window. 
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6 CUT & FILL CONDITIONS 

CUT AND FILL CONDITIONS 

Cut and Fill conditions can be modeled in subassembly composer. In order to do so, a surface target must be 

defined under Target Parameters and an auxiliary point must be created from the last decision point with a zero 

Delta X from the last decision point and a Delta Y on the target surface. 

Conditions modeled are as follows for both Cut and Fill: 

 

 

 

Continue working on the same file or open the file 6.0 - Cut Fill - Start.pkt from the C:\Civil 
3D 2018 Projects\22049555201\Roadway folder 
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1 Under the Setting and Parameters window select the Target Parameters tab. 

2 On the Target Parameters window, select the italic Create Parameter line. Rename TargetParameter3 

to EG, change the Type to Surface and set Preview Value to -1. 

 

3 Drag an Auxiliary Point from the Auxiliary section on the Toolbox and drop it on the Flowchart panel: 

 

4 On the Properties panel , under Point Geometry Type, set Type to Delta X on Surface. Under Point 

Geometry Properties, select From Point P2 and Surface Target, EG:  

 

5 Select and drag the EG target surface on the Preview panel . The Auxiliary Point, AP1, is automatically 

updated: 
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6 Drag the Decision marker from the Workflow section under Toolbox and drop it on the Flowchart 

panel: 

 

7 On the Properties panel , under Condition, type in P2.Y > AP1.Y 

 

 

Note This condition rule will be true if point P2 is above the existing ground point, AP1 (Fill Condition) 

8 Drag a point from the Geometry section on the Toolbox and place it on the left side of the decision 

marker on the Flowchart panel: 
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9 On the Properties panel , under Point Geometry Type, select Type to Slope to Surface. Under Point 

Geometry Properties, select From Point to P2, type in a slope of -2:1. Select Surface Target to EG. 

Under Link turn on the Add Link to From Point box: 

 

10 The fill slope segment is placed when the condition value is true as seen in the Preview panel : 

 

11 Drag a Point from the Geometry section under Toolbox and place it on the Flowchart panel: 
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12 The point is automatically added to the previous point. Grab the arrow attached to the new point 

rectangle attached to the previous rectangle and attach it to the right side of the Decision symbol so that 

it is placed at the False condition: 

 

13 On the Properties panel , under Point Geometry Type select the Type to Slope and Delta X. Under 

Point Geometry Properties, select From Point to P2, type in a slope of -2:1 and type in 2 for Delta X. 

Under Link turn on the Add Link to From Point box: 

 

14 Drag a point from the Geometry section and drop it under the previously created point and link on the 

workflow window: 
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15 On the Properties panel , under Point Geometry Type, select the Type to be Delta X and Delta Y. Under 

Point Geometry Properties, select From Point to P6 and type in a Delta X of 3 and a Delta Y of 0. 

Under Link turn on the Add Link to From Point box: 

 

16 Drag a point from the Geometry section and drop it under the previously created point and link on the 

workflow window: 
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17 On the Properties panel , under Point Geometry Type, select the Type to be Slope to Surface. Under 

Point Geometry Properties, select From Point to P7, type in a slope of 2:1 and select the Surface Target 

to EG. Under Link turn on the Add Link to From Point box: 

 

18 In order to test the False condition, move the EG target surface on the Preview panel  to a cut condition 

and verify the behavior of the subassembly: 

 

19 In order to have all the Cut & Fill slopes for links and points open for prompting when placed in the 

drawing, they will be created as Input/Output parameters. 

20 Under the Setting and Parameters window select the Input/Output parameters tab. 

21 On the Input/Output parameters window, select the italic Create Parameter line. Rename Parameter4 

to CutSlope, change the Type to Slope, set the Direction to Input, and type in a Default Value of 2:1: 

 

22 On the Input/Output parameters window, select the italic Create Parameter line. Rename Parameter5 

to FillSlope, change the Type to Slope,  set the Direction to Input , and type in a Default Value of       -

2:1: 
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23 Highlight the P5 & L5 rectangle on the Flowchart panel. On the Properties panel , under Point 

Geometry Properties type in FillSlope for the Slope value: 

 

24 Highlight the P8& L8 rectangle on the Flowchart panel. On the Properties panel , under Point Geometry 

Properties type in CutSlope for the Slope value: 

 

25 Change the Cut and Fill Slope Default Values on the Input/Output Parameters window and review the 

automatic updates on the Preview panel . 

26 Highlight the P5 & L5 rectangle in the Flowchart panel. On the Properties panel , under Link assign 

“Top” under Codes to the current link: 

 

27 Repeat the same process of assigning the “Top” code to the L6, L7 and L8 links. 

28 Under the Setting and Parameters window select the Input/Output parameters tab. 

29 On the Input/Output Parameters window, set the Default Value on the Side parameter to Right. 

30 On the Input/Output Parameters window, set the Default Value on the CutSlope to 1:1 
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31 On the Input/Output Parameters window, set the Default Value on the FillSlope to -2:1 

 

32 Under the Setting and Parameters window select the Packet Settings tab. 

33 On the Packet Settings window and under Subassembly, type in SimpleLane (No spaces are accepted 

for names) for the Subassembly Name: 

 

34 Save the Packet file by selecting File at the top left corner of Subassembly Composer and then selecting 

Save As.  Name it SimpleLane.pkt and place it in C:\Civil 3D 2018 Projects\22049555201\Roadway 

folder: 

 

35 Close subassembly composer (File > Exit) 
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7 IMPORTING / Modeling PKT FILES 

IMPORTING AND MODELING WITH PACKET FILES. 

1 Open Civil 3D using the FDOT2018.C3D icon located on your desktop. 

 

2 Open the drawing 7.0 - Importing Modeling PKT - Start.dwg from the C:\Civil 3D 2018 

Projects\22049555201\Roadway folder 

3 The file contains an existing surface, a design horizontal alignment and a profile design. 

4 On the Home tab of the ribbon, under the Palettes section, select the Tool Palettes command: 

 

5 The current FDOT Subassemblies tool palette appears: 
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6 Right click on the gray right side area of the tool palette (Tool Palettes – FDOT Subassemblies) and 

select Civil Imperial Subassemblies: 

 

7 Select the Basic tab 

8 Right click on the gray right side area of the tool palette (Tool Palettes – Civil Imperial  Subassemblies) 

and select the Import Subassemblies option 
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9 On the Import Subassemblies dialog box, select the folder icon, then select the SimpleLane.pkt file 

from the C:\Civil 3D 2018 Projects\22049555201\Roadway folder which was created using 

Subassembly Composer. Select Import to: Tool Palette, Basic. The subassembly created in 

Subassembly Composer will be placed on the Basic tab on the current Tool Palette: 

 

10 Scroll down on the Basic tab subassemblies. The subassembly SimpleLane will be placed at the bottom 

of the list: 
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11 Restore custom model view: US98 SAC Assemblies using View Controls 

 

12 On the Ribbon Home tab, select Assembly, Create Assembly, name it SimpleLane and after selecting 

OK, place the Assembly marker in restored view US98 SAC Assemblies:  

    

13 Select the SimpleLane subassembly from Basic tab. Notice by scrolling down the Advanced properties 

that the side, Width, Thickness, Cut and Fill Slopes are ready to be overwritten by the user: 
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14 Change the Side to Right, and the Width to 12.00’. Verify that the CutSlope is 1:1 and that the FillSlope 

value is -2:1. Select the marker and place the subassembly: 

 

15 Change the Side to Left, identify the marker to complete the Assembly: 
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16 Select the Escape key to exit out of the Subassembly properties dialog box and Close the Tool Palettes 

containing all available subassemblies. 

17 Restore custom model view: US98 - 24+00 to 29+00 using View Controls 

 

18 On the Home tab of the ribbon, select Corridor > Create Corridor.  

 

19 On the Create Corridor dialog enter the following values: 

 Name: Corridor - US98 - 24+00 to 29+00 

 Corridor style: FDOT 

 Corridor layer: Corridor_dp 

 Baseline type: Alignment and Profile 

 Alignment: US98 

 Profile: US98 - 24+00 - 29+00 - PGL 

 Assembly: SimpleLane 

 Target Surface: DTM Existing 

  Turn on Set baseline and region parameters 
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20 Select OK to accept  the entered values. 

21 On the Create Corridor dialog box, change the Start Station to 24+00 and the End Station to 29+00, 

select the Set all Targets option and under Surfaces, select the DTM Existing target surface for both 

the right and left sides of the assembly. Notice the that the Width or Offset Targets and the Slope or 

Elevation Targets are available since these targets were defined and are now available from the 

Subassembly Composer SimpleLane assembly: 
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22 Select OK to dismiss the Target Mapping and select OK to run the Corridor. The corridor is modeled: 
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23 On the Toolspace, Prospector tab, expand the Corridors, select Corridor - US98 - 24+00 to 29+00, then 

right click and select Cross Section Editor... 

 

24 From the Ribbon > Section Editor tab > Station Selection panel, set Select a Station to Region Station 

 

25 Review the Sections by selecting the forward or backwards arrows at the Ribbon under Station 

Selection panel. The assembly behavior is exactly what was created in Subassembly Composer.  
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26 Select the Close X mark on the Ribbon to exit the Corridor Section Editor upon review completion. 

 

27 Restore custom model view: US98 - 24+00 to 29+00 using View Controls 

28 Save the drawing 7.0 - Importing Modeling PKT - Start.dwg to the C:\Civil 3D 2018 

Projects\22049555201\Roadway folder 

29 Close Civil 3D 2018 
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8 EDITING PKT FILES / MODEL UPDATE 

MAKING CHANGES TO PACKET FILE AND UPDATING THE MODEL 

Now that everything has been modeled, let us now suppose that a fill ditch must be added if the fill height is less 

than 3 feet: 

 

1 Open Autodesk Subassembly Composer from All programs > Autodesk  > Autodesk Subassembly 

Composer 2018 

 

2 Select File > Open and open the 8.0 - Editing PKT - Start.pkt file from the C:\Civil 3D 2018 

Projects\22049555201\Roadway folder. 

3 Scroll down on the Flowchart panel to the Decision symbol. The left side (True) currently holds the 

geometry for the fill situation. 

 

4 Delete the P5 & L5 rectangle by selecting it and pressing the delete key on the keyboard. 
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5 Select the decision symbol from the Workflow section on the Toolbox and place it on the left side: 

 

6 Select the line currently connecting the P8 & L8 rectangle to the decision symbol and move one of the 

ends so that it connects properly to the main decision symbol: 

 

7 If the workflow instructions do not fit, the lower right corner symbol of the drawing allows the window 

to be resized. 



EDITING PKT FILES / MODEL UPDATE ________________________________________________________________ Chapter 8 

FDOT Civil 3D Subassembly Composer ©2018 FDOT  8-3 

8 Click on the new Decision symbol and under the Properties panel , type under condition P2.Y – AP1.Y 

< 1  

9 This condition will test true if the fill height is less than 1 

     

        

10 Drag and drop a Point from the Geometry section of the Toolbox. On the Properties panel , under Point 

Geometry Type set Type to Slope and Delta X, under Point Geometry Properties, select From Point 

P2, type in a Slope of -50%, type in a Delta X of 2 and turn on under Link, Add Link to From Point: 

 

11 In order to test the behavior of the True condition, move the EG line  close to P2 on the Preview panel  

and verify that the segment is placed.  
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12 Drag and drop a Point from the Geometry section of the Toolbox and place it under the previously 

created point: 

 

13 On the Properties panel , under Point Geometry Type, set the Type to Delta X and Delta Y. under Point 

Geometry Properties, select From Point P9, type in a Delta X of 3, type in a Delta Y of 0, and turn on 

under Link, Add Link to From Point: 
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14 Verify the ditch on the Preview panel .  
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15 Drag and drop a Point from the Geometry section on the Toolbox under the point and link previously 

created. On the Properties panel , under Point Geometry Type, select Slope to Surface. Under Point 

Geometry Properties, select From Point P10 and type in CutSlope for Slope, set the Surface Target to 

EG, and turn on under Link, Add Link to From Point: 

 

16 Finally, a Point and Link must be added when the Fill height is greater than 3 feet.  Drag and drop a 

point next to the point and link previously created. 

 

17 Select the line currently connecting the P12 & L12 rectangle and add it to the decision symbol on its 

False Condition: 
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18 On the Properties panel , under Point Geometry Type, select Slope to Surface. Under Point Geometry 

Properties, select From Point P2, type in FillSlope for the Slope and set the Surface Target to EG, and 

turn on under Link, Add Link to From Point: 

19  Move down EG on the Preview panel  and to verify proper behavior. 

 

20 Highlight the new link L9 and under the Properties panel , type in under Link Codes “Top”. Repeat for 

the L10, L11 and L12 Link Codes. Verify Link Codes for L6, L7, and L8 are set to “Top”. 
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21 Under the Setting and Parameters window select the Packet Settings tab. 

22 On the Packet Settings window and under Subassembly, type in SimpleLaneDitchFill (No spaces are 

accepted for names) for the Subassembly Name: 

 

 

23 Save the Packet file by selecting File at the top left corner of Subassembly Composer and then selecting 

Save As.  Name it SimpleLaneDitchFill.pkt and place it in C:\Civil 3D 2018 

Projects\22049555201\Roadway folder: 
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24 Close Subassembly Composer (File > Exit) 

 

25 Open Civil 3D using the FDOT2018.C3D icon located on your desktop. 

 

26 Open the drawing 8.0 - Editing PKT - Start.dwg from the C:\Civil 3D 2018 

Projects\22049555201\Roadway folder 

27 Restore custom model view: US98 SAC Assemblies using View Controls 

 



Chapter 8 ________________________________________________________________ EDITING PKT FILES / MODEL UPDATE 

8-10 ©2018 FDOT   FDOT Civil 3D Subassembly Composer 

28 On the Ribbon Home tab, Create Design panel, select Assembly, Create Assembly, name it 

SimpleLaneFillDitch and select OK. Place the SimpleLaneFillDitch assembly marker under the 

SimpleLane assembly: 

   

29 On the Ribbon, select the Insert tab and select Import, select Import Subassemblies (another alternate 

method to importing the pkt file): 

 

30 Select the SimpleLaneDitchFill pkt file located under the working directory and select OK. The 

subassembly is ready for placement on the imported Tool Palette. 

 

31 The SimpleLaneDitchFill subassembly is displayed on the Tool Palette: 
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32 Select the SimpleLaneDitchFill subassembly from Basic tab. Notice by scrolling down the Advanced 

properties that the side, Width, Thickness, Cut and Fill Slopes are ready to be overwritten by the user: 

   

33 In the Properties Tool palette > Advanced Parameters , change the Side to Right, and set the Width to 

12.00’. Verify that the CutSlope is 1:1 and that the FillSlope value is -2:1. Select the 

SimpleLaneDitchFill marker on the Right Side and place the subassembly 

34 In the Properties Tool palette > Advanced Parameters , change the Side to Left, and the Width to 12.00’. 

Verify that the CutSlope is 1:1 and that the FillSlope value is -2:1. Select the SimpleLaneDitchFill 

marker on the Left Side and place the subassembly 
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35 Restore custom model view: US98 - 24+00 to 29+00 using View Controls 

36 Select the Corridor - US98 - 24+00 to 29+00 from the Prospector tab under Corridors, right click on it 

and select Rebuild Automatic. Right click on it again, and select Cross Section Editor... 

    

37 From the Ribbon > Section Editor tab > Station Selection panel, set Select a Station to Region Stations 
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38 From the Ribbon > Section Editor tab > Station Selection panel, select the forward arrow and move  to 

station 24+00 

 

 

39 From the Ribbon > Section Editor tab > Corridor Editor Tools panel, select Change Assembly 
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40 Select SimpleLaneFillDitch from list and select OK 

 

41 Upon selecting OK, notice how the Corridor gets automatically rebuilt and all sections are 

automatically updated: 

42 Select the Close X mark on the Ribbon to exit the Corridor Section Editor upon review completion. 

 

43 Restore custom model view US98 - 24+00 to 29+00 using View Controls 

44 Save the drawing 8.0 - Editing PKT - Start.dwg  to the C:\Civil 3D 2018 

Projects\22049555201\Roadway folder 

45 Close Civil 3D. 
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9 A p p e n d i x  A 

Class Name Function Name Description 

P1 (AP1) 
… 

P1000(AP1000) 

X X is relative to Origin Point of Subassembly 

Y Y is relative to Origin Point of Subassembly 

Offset Offset is relative to Baseline 

Elevation Elevation is relative to 0.0 height 

DistanceTo(point) Get the distance to another point 

SlopeTo(point) Get the slope to another point 

L1(AL1) 
… 

L1000(AL1000) 

Slope Link slope 

Length Absolute length, always be positive 

Xlength Length in horizontal direction, always be positive 

Ylength Length in vertical direction, always be positive 

StartPoint Get the start point of the link 

EndPoint Get the end point of the link 

MaxY Finds the max Y elevation from the points of the link 

MinY Finds the min Y elevation from the points of the link 

MaxInterceptY(slope) 
Lay a line at a slope on all the points on the link to 
determine the highest intercept at the start of the links.  

MinInterceptY(slope) 
Lay a line at a slope on all the points on the link to 
determine the lowest intercept at the start of the links.  

LinearRegressionSlope 
Do a linear regression on the points in the link to find the 
best fit slope between all of them.  

LinearRegressionInterceptY 
Find the Y value of the linear regression line (at the start 
point of the link).  

SE 

HasLeftLI Return true if has left lane inside SE 

HasLeftLO Return true if has left lane outside SE 

HasLeftSI Return true if has left shouder inside SE 

HasLeftSO Return true if has left shouder inside SE 

HasRightLI Return true if has right lane inside SE 

HasRightLO Return true if has right lane outside SE 

HasRightSI Return true if has right shouder inside SE 

HasRightSO Return true if has right shouder inside SE 

LeftLI Return left lane inside SE 

LeftLO Return left lane outside SE 

LeftSI Return left shouder inside SE 

LeftSO Return left shouder inside SE 

RightLI Return right lane inside SE 

RightLO Return right lane outside SE 

RightSI Return right shouder inside SE 

RightSO Return right shouder inside SE 

OffsetTarget 
isValid To judge if this target is assigned and it is valid to use 

Offset Get the offset value of the target 

ElevationTarget 
isValid To judge if this target is assigned and it is valid to use 

Elevation Get the elevation value of the target 

SurfaceTarget isValid To judge if this target is assigned and it is valid to use 

 


