
State of Florida 

Department of Transportation 
 

 

 

FDOT SS4 

Automated Quantities 
 

 

User Training Guide 

February 2019 

 

 

 

PRODUCTION SUPPORT / CADD OFFICE 

TALLAHASSEE, FLORIDA 

http://www.fdot.gov/cadd 

  

http://www.fdot.gov/cadd


  



FDOT SS4 Automated Quantities 
Description 

This training course details the Florida Department of Transportation (FDOT) Quantity Workflow developed for 

the Plan Summary Boxes required in FDOT Plan Sets. The participants will learn the use of FDOT and GEOPAK 

tools required in the workflow. This includes GEOPAK's Design & Computation (D&C) Manager and Quantity 

Manager, used to create quantity shapes, calculate quantities, export quantities and generate reports. This course 

also covers the FDOT Linked Data Manager (LDM), used to generate, link and place Plan Summary Boxes in the 

MicroStation design file. 

This course includes, but is not limited to the following:  

• D&C Manager 

• Drawing Shapes Representing Pavement and Sidewalk areas 

• Generating Quantities in D&C Manager 

• Linked Data Manager 

• Generating Plan Summary Boxes 

• Quantity Manager Basics 

• Pay Items and Quantities 

• Quantity Manager Reports 

• Exporting Data to Designer Interface 

• Generating Summary of Pay Items Sheet 

Objectives 

Students will learn how to use GEOPAK’s Design & Computation Manager, Quantity Manager, and the FDOT 

Linked Data Manager tools to draw, calculate, and document design quantities. 

Audience 

FDOT Designers and Engineers 

Prerequisites 

The following course is required: 

FDOT Roadway Design and 3D Modeling – Basic 2D Rule Based Design Training 

Participants need to have a basic understanding of Computer Aided Drafting and Design (CADD) using 

MicroStation, a basic understanding of GEOPAK concepts and a solid understanding of the engineering necessary 

to design a Roadway. 

  



 

[PAGE INTENTIONALLY LEFT BLANK.] 

 



Table of Contents 

FDOT SS4 Automated Quantities ©2019 FDOT i 

1 INTRODUCTION ........................................................................................................................................... 1-1 

OBJECTIVES ............................................................................................................................................................... 1-1 
DOCUMENT STYLE ...................................................................................................................................................... 1-1 
AUTOMATED QUANTITIES WORKFLOW ........................................................................................................................... 1-2 
FDOT STANDARDS ..................................................................................................................................................... 1-2 
FDOT STANDARD FILES ............................................................................................................................................... 1-3 

Setting Up the QTDSRD file ................................................................................................................................ 1-4 
Exercise 1.1 Create and Set Up the QTDSRD File ................................................................................................... 1-5 

2 D&C MANAGER ........................................................................................................................................... 2-1 

OBJECTIVES ............................................................................................................................................................... 2-1 
D&C MANAGER DIALOG BASICS ................................................................................................................................... 2-1 
MENU ITEMS ............................................................................................................................................................. 2-2 
TOOL BAR ................................................................................................................................................................. 2-2 
EXPLORING FDOT’S .DDB FILE ..................................................................................................................................... 2-5 

Exercise 2.1 Identify an Existing Element .............................................................................................................. 2-6 
Exercise 2.2 Create a Collection Set and Add to Favorites .................................................................................... 2-9 

3 CIVIL FEATURES AND ADHOC ATTRIBUTES MANAGER ................................................................................. 3-1 

OBJECTIVES ............................................................................................................................................................... 3-1 
CIVIL FEATURES .......................................................................................................................................................... 3-1 

Exercise 3.1 Draw Guardrail with Civil Tools.......................................................................................................... 3-1 
ADHOC ATTRIBUTES .................................................................................................................................................... 3-4 

Adhoc Attribute Manager .................................................................................................................................. 3-5 
Exercise 3.2 Tagging Adhoc Attributes .................................................................................................................. 3-6 

4 CALCULATING QUANTITIES ......................................................................................................................... 4-1 

OBJECTIVES ............................................................................................................................................................... 4-1 
CALCULATING QUANTITIES WITH D&C MANAGER ............................................................................................................ 4-1 

Settings to Consider ........................................................................................................................................... 4-1 
Design Settings ................................................................................................................................................................. 4-2 
Compute Settings ............................................................................................................................................................. 4-2 

Compute Mode .................................................................................................................................................. 4-3 
Selecting Database Items to Compute .............................................................................................................................. 4-4 
Computation Results ........................................................................................................................................................ 4-5 

Exercise 4.1 Calculating Linear Foot Quantities with D&C Manager ..................................................................... 4-5 
CREATING SHAPES ...................................................................................................................................................... 4-8 

Exercise 4.2 Calculating Area Quantities with D&C Manager ................................................................................ 4-9 
Exercise 4.3 Modifying Adhocs with D&C Manager for Quantity Calculations .................................................... 4-14 

Preferences Mode ............................................................................................................................................ 4-19 
Exercise 4.4 Add an Item to the D&C Manager ................................................................................................... 4-21 

Label Shapes with Area ID ............................................................................................................................... 4-23 
Exercise 4.5 Label Areas ...................................................................................................................................... 4-24 

5 QUANTITY MANAGER ................................................................................................................................. 5-1 

OBJECTIVES ............................................................................................................................................................... 5-1 
QUANTITY MANAGER OVERVIEW .................................................................................................................................. 5-1 
ACCESS QUANTITY MANAGER ....................................................................................................................................... 5-1 
QUANTITY MANAGER DIALOG ....................................................................................................................................... 5-2 

Project Properties .............................................................................................................................................. 5-3 
Defining Project Properties............................................................................................................................................... 5-3 

Preferences ........................................................................................................................................................ 5-5 
Interface Details ................................................................................................................................................. 5-7 

Pay Item Pane ................................................................................................................................................................... 5-7 



 

ii ©2019 FDOT FDOT SS4 Automated Quantities 

Quantity Pane ................................................................................................................................................................... 5-7 
Element Pane .................................................................................................................................................................... 5-7 

RIGHT-CLICK MENUS .................................................................................................................................................... 5-8 
INSERT OPTIONS ......................................................................................................................................................... 5-9 

Insert Category .................................................................................................................................................. 5-9 
Insert Pay Item ................................................................................................................................................. 5-10 
Insert Quantity ................................................................................................................................................. 5-11 

Exercise 5.1 Navigating Quantity Manager .......................................................................................................... 5-13 
Exercise 5.2 Creating a Category ......................................................................................................................... 5-16 
Exercise 5.3 Importing Pay Items......................................................................................................................... 5-16 
Exercise 5.4 Creating Quantities .......................................................................................................................... 5-20 

REPORTS ................................................................................................................................................................. 5-24 
Exercise 5.5 Creating CSV Reports ....................................................................................................................... 5-24 

6 PLAN SUMMARY BOXES & LDM .................................................................................................................. 6-1 

OBJECTIVES ............................................................................................................................................................... 6-1 
PLAN SUMMARY BOXES ............................................................................................................................................... 6-1 
LDM BASICS ............................................................................................................................................................. 6-3 

Create Summary Boxes From Quantity Manager .............................................................................................. 6-4 
Exercise 6.1 Create New Summary Boxes from Quantities ................................................................................... 6-5 

Create Summary Boxes From FDOT Templates ............................................................................................... 6-10 
Exercise 6.2 Create New Summary Boxes from Template ................................................................................... 6-11 
Exercise 6.3 Create Summary Box with LDM and CSV files ................................................................................. 6-14 

HELPFUL INFORMATION ............................................................................................................................................. 6-19 

7 SUMMARY OF PAY ITEMS WORKFLOW ....................................................................................................... 7-1 

OBJECTIVES ............................................................................................................................................................... 7-1 
SUMMARY OF PAY ITEMS WORKFLOW ............................................................................................................................ 7-1 
EXPORT .................................................................................................................................................................... 7-1 

Accessing Export ................................................................................................................................................ 7-1 
Exporting Data to XML File ................................................................................................................................ 7-3 

IMPORT QUANTITIES IN DESIGNER INTERFACE .................................................................................................................. 7-6 
GENERATE REPORTS .................................................................................................................................................... 7-8 

Access AASHTOWare Project Webgate Reporting ............................................................................................. 7-8 
Generate Summary of Pay Items Report ........................................................................................................... 7-9 
Create the Summary of Pay Items Sheet ......................................................................................................... 7-11 

 



  

FDOT SS4 Automated Quantities ©2019 FDOT 1-1 

1 INTRODUCTION 

OBJECTIVES 

Review the workflow and components of computing quantities. 

• Define the Workflow for Project Quantities and Recommended Tools 

• Requirements of Florida Department of Transportation (FDOT) 

DOCUMENT STYLE  

The following table shows the style conventions used throughout the course guide. 

Item Convention Example 

Menu Names and 

Commands 
Bold, names separated 

with > symbol 
 File > Open 

 File > Compress > Design 

Dialog Box 

Actions 
Bold 

 

 Click the Apply button. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include box. 

 In the Segment Type list, click Lines. 

Dialog Box Field 

Names 
Italic  Key in Hemfield Road in the Alignment Name field. 

 Click the Graphic Select button to the right of the 

Horizontal Alignment Include field. 

 In the Segment Type list, click Lines. 

Key-ins Bold  Key in Hemfield Road in the Alignment Name field. 

File Names Italic  Open the file Working Graphics.dgn in the C:\Bentley 

Training\GEOPAK 101\Project Setup\Practice\ 

directory. 

File Paths Non-italic 

 
 Open the file Working Graphics.dgn in the C:\Bentley 

Training\GEOPAK 101\Project Setup\Practice\ 

directory. 

New Terms or 

Emphasis 
Italic 

 
 The Template Library contains templates, which 

represent typical sections of the proposed roadway. 
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AUTOMATED QUANTITIES WORKFLOW 

Shown in the figure below, is a workflow that represents the process of creating and providing pay item quantities 

for FDOT projects. GEOPAK supplies a tool called the Design & Computation Manager (D&C Manager) that is 

both a design tool and a quantity calculator. The FDOT Workspace is set up to use the D&C Manager items to 

set the Civil Features for linear design elements. Once the elements are drawn and the quantities computed, the 

data is transferred into Quantity Manager for review and/or modification. Linked Data Manager (LDM), delivered 

in the FDOT CADD Software, uses the Quantity Manager database to automate summary boxes in Excel and link 

them to the MicroStation DGN file.  

For those summary boxes which are not automated, CSV reports can be generated from Quantity Manager to help 

speed up the process of populating the summary box Excel templates from LDM. Quantities not automatically 

computed with D&C Manager are entered manually into Quantity Manger and the summary box template is 

populated manually. Finally, reports are generated to export all the quantities in the database to Designer Interface. 

 

FDOT STANDARDS 

FDOT provides several resources to instruct and aid designers in computing pay item quantities. The Estimates 

Office publishes the Basis of Estimates Manual, the governing document that specifies how to compute each pay 

item. The Estimates Office also provides a Master Pay Item list containing every pay item available for use in 

Florida. The Production Support CADD Office provides tools to simplify the process of generating quantities. 

The D&C Manager database (FDOT*.ddb) and several Quantity Manager report styles are delivered with the 

FDOT CADD Software. The FDOT D&C Manager database is pre-set to comply with both drafting standards 

specified by the CADD Manual and the Pay Item Computation Methods supplied by the Basis of Estimates 

Manual. 

FDOT recommends the use of Civil Features for all linear feature drafting to ensure that each element is on the 

correct symbology and that quantities may be automatically calculated. FDOT also recommends the use of the 

D&C Manager for all quantity shape drafting for the same reasons. The FDOT*.ddb database that is supplied by 

FDOT includes most of the items that will be used on a FDOT project. 
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FDOT STANDARD FILES 

Quantity information is stored in CADD files designated with one of two standard FDOT File Names, located in 

the appropriate discipline directory: 

• DSGN** – for Linear/Each Features (where ** indicates the 2-letter characters for the discipline) 

• QTDSRD – for Area/Tonnage/Cubic Yard Features 

 

The FDOT tool Create File available from the FDOT Menu creates these files. 
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SETTING UP THE QTDSRD FILE 

The QTDSRD is the file used to create the shapes required to calculate area quantities. FDOT recommends the 

use of models within this file instead of creating a separate DGN file for each pay item and its shapes. Each model 

is named using the pay item number, TRNS*port format or with the use of dashes. Each model should have the 

Alignment, Design, and TOPO files referenced. These references assist with the creation of the shapes needed as 

well as to provide helpful information for Construction personnel who need to access this file. 

 To save time, set up the default model with the desired references, and then copy this 
model to create the additional models needed for the pay item shapes. 

Note Do NOT create shapes for all the area quantities in one model. This makes it difficult for Construction to 
locate the shapes they need to verify. If the intent is to be able to calculate all the quantities at one time, 
create the separate models breaking the shapes down by pay item and then reference these models to 
a single composite model. 
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Exercise 1.1 Create and Set Up the QTDSRD File 

This exercise uses the Create File tool to create the QTDSRD file. Once created, the user attaches the references 

to the Default model and copies it to create new models for each pay item number needed to create shapes for 

generating quantities. 

 Open the MicroStation design file DSGNRD01.dgn using the FDOTSS4 icon in the FDOTSS4 folder 

located on the desktop. 

 On the FDOT Menu, select Actions > Create File to open the Create File tool. 

 

 In the Create File dialog, click on Select Project to set the project directory. 

 

 Browse to the project directory, C:\e\projects\22049555201\. Click Select Folder. 

 In the Create File dialog, complete selection of the Discipline and File Group as shown below using the 

drop-down options. 
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 Scroll down under File Type, select Quantity Computation Shapes-Calculations and verify the Output 

settings. Set County as shown and click Create - Open File. The application creates the QTDSRD01.dgn 

file and stores it in the Output Folder selected. 

 

 Once the new file opens, the Set Plot Scale dialog displays. Click OK and then click Close on the Create 

File dialog to close it. 

 On the MicroStation menu select File > References to open the References dialog. 
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 Attach the files ...\roadway\ALGNRD01.dgn model ALGNRD_50, ...\roadway\DSGNRD01.dgn model 

Default, and...\survey\TOPORD01.dgn model Default. (FDOT recommends turning OFF any undesired 

levels, such as Text, Construction Lines, etc. Fit the View and Save Settings.) 

 

 On the MicroStation menu select File > Models to open the Models dialog. 

 

 Select the Copy a Model icon. Fill out the Copy Model dialog as shown below and click OK. 

 

 Select the Copy a Model icon. Fill out the Copy Model dialog as shown below and click OK. 

 

 Close MicroStation. 
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2 D&C MANAGER 

OBJECTIVES 

• Introduce the D&C Manager and Tools 

• Explore Identify Item, Display Item 

• Set Item Tools in Plans Production 

D&C MANAGER DIALOG BASICS 

To access D&C Manager, from the Road toolbox, click the Design & Computation Manager icon.  

<OR>  

From the MicroStation menu, select GEOPAK > ROAD > Design & Computation Manager.  

<OR>  

From the FDOT Plans Development > Quantities Tasks menu, select the D&C Manager icon. 

 

D&C Manager uses a hierarchical database (the .ddb file) which stores information concerning functional 

classification and display preferences for each feature and item used in a MicroStation file. FDOT uses this 

database to set the Civil Features that control the symbology of elements in the different design Views.  

The Production Support CADD Office is responsible for the development of the FDOT standard GEOPAK D&C 

Manager database. It complies with the CADD Standards as defined in the CADD Manual. This database may 

need modification for project-specific items or for compliance with District standards. If the user customizes the 

database, the user saves this customized database into the project directory under the symb directory. Saving the 

database to the project directory is important because this ensures delivery of the modified database with the 

project. Saving this file to the project directory ensures that the same pay items are available later in the life of 

the project that are applicable at the time of letting. 
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MENU ITEMS 

The D&C Manager dialog has five menus. 

File This menu creates a new .ddb file, displays an existing .ddb file, saves a .ddb file, 

save as, merges .ddb files, compresses .ddb files, uses a password for a .ddb file, and 

exits D&C Manager. 

Edit This menu performs multiple edit functions to the .ddb file: Undo or Redo database 

changes and Copy, Move, Rename, and Delete database Items and Categories. There 

are also options to Find an item or Category, Identify a database Item, Create a New 

Category or New Item, as well as Modify Item and Review Item. 

Settings This menu has six items pertaining to setting default options in D&C Manager and 

MicroStation, and the methods of computing quantities. 

Favorites This menu allows for storing, recalling and managing frequently used items. 

Help This menu displays the Bentley help files for the D&C Manager. Use this 

documentation for information not covered by this manual. The exercises in this 

manual define critical settings required for the FDOT Workflow. 

TOOL BAR 

D&C Manager has a toolbar for quick access to different modes. 

 

 
 

• Switch to Toolbox Mode - D&C Manager is set up to work in two different modes, dialog 

box or toolbox. This icon displays the toolbox mode. This toolbox is resizable and 

dockable. To change the display back to the dialog box, click the Switch to Dialog Mode 

icon, the last icon on the right. The Place Influence check box is at the left end of the 

toolbox. 

 

  

Identify Item - This tool sets the D&C Manager item to match an existing MicroStation 

element previously drawn by the D&C Manager. If the Identified element does not match 

an item in the opened database, a message appears in the status bar saying: No matching 

database item. 

  

• Display - The Display icon filters the MicroStation elements in the design file to control the 

display of specific features. This icon expands D&C Manager to show a collection bin. 

This collection bin is for selecting multiple items at one time. This icon also displays a 

second toolbox with four icons as seen in the image below. From left to right the icons are 

Normal Display, Highlight Selection, Hide Selection and Display Only Selection. 
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• Design - The Design icon is used to draw MicroStation elements in the design file with the 

defined symbology by use of Draw Plan and Profile or in conjunction with MicroStation 

element placement commands with Place Influence activated. 

 

 
 

• Set - The Set icon sets the symbology of previously drawn MicroStation graphic elements 

in accordance with the parameters of a selected item in the database. This tool applies D&C 

Manager attributes to an element or selection set of elements drawn without using the 

Design mode of D&C Manager, or fixes items originally drawn with the wrong symbology. 

The Set icon also appends, replaces or deletes Adhoc Attributes. 

 

 
 

• Compute - The Compute icon tabulates quantities of items placed as Pay Items using the 

Design or Set mode. If drafting elements using the MicroStation tools, quantities do not 

compute unless an attribute is applied using the Set tool. This tool also expands D&C 

Manager to show the collection bin, allowing for processing multiple pay items at one time. 

A second toolbox also displays as seen in the figure below.  

 

 
 

• Shape - The Shape icon uses Plan View MicroStation graphics to place shapes required for 

quantities. This tool displays a second dialog box as shown in the following figure. 
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• Pavement Marking - This mode dynamically provides additional options for placing 

pavement striping and markings. This tool adds four additional tools to D&C Manager as 

shown in the following figure. The four Pavement Marking tools from left to right are:  

Striping, Separation, Chevron Diverge, Chevron Merge 

 

Note The FDOT Traffic Plans Course covers the Pavement Marking tools and this 
manual will not be detailing these tools. 

  

• Preference - This icon expands the toolbar to include four additional icons to configure 

D&C Manager. These same tools are also accessible through the Edit menu and Right-click 

options. 
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EXPLORING FDOT’S .DDB FILE 

FDOT delivers a database file in the FDOTSS4 directory located at GEOPAK\databases\fdotss4.ddb. FDOT 

specifically set up this database to create elements with the correct level symbology according to FDOT CADD 

Standards. The .ddb file is set up with discipline directories called Categories. Inside each Category are Items. 

Categories The basic component of the hierarchical tree is the Category, represented by a folder   

icon. The FDOT database is set up with categories representing the different disciplines. The 

following figure shows the Categories with a description relative to their discipline. These 

Categories are composed of Subcategories and/or Items. 

 

Items The other database component is the Item that correlates to the definition of the elements or 

feature. This can be a Drafting Item, a Compute Item, a Default Item or a Pavement Item. 

(FDOT does not use Pavement Items and they are not discussed here). Items contain specific 

functions related to defined element symbology or quantity calculations. 

➢ Opening a Category reveals Items as shown below: 

 
Default The Default Items set element symbology for drawing 

elements and search parameters. 

 
Drafting 

Standards 

The Drafting Standards Items set element symbology for the 

placement of coordinate geometry elements, i.e., points, 

curves, parcels, chains, and profiles. 

 

 

Compute 

Parameters 

The Compute Parameters Items set element symbology and 

parameters associated with computation procedures, i.e., unit 

of measure, rounding factors, pay item, etc. 
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Exercise 2.1 Identify an Existing Element 

This exercise uses the ID tool to set the D&C Manager to match the item used to draw an existing element in the 

design file. It is designed to explore the FDOTSS4.ddb file to get familiar with its contents.  

 Open the MicroStation file C:\e\Projects\2204955201\roadway\DSGNRD01.dgn. 

 Zoom the MicroStation View to the new intersection near the beginning of the project. 

 

 From the FDOT Plans Development > Quantities Tasks menu select Open D&C Manager. 
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 From D&C Manager click the Identify Item icon. 

 

 In the design file, select the Face of Curb on the intersection return in the Northeast quadrant of the 

intersection. The Face of Curb highlights. 
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 Place a Data Point in the design file to accept the command. The Concrete Curb & Gutter, 

Type F Item highlights in D&C Manager. This indicates that D&C Manager found a match to the selected 

element and has set this as the Active Item. From this point, the user can implement any other tool from the 

D&C Manager using this Item. 

 

 With the Concrete Curb & Gutter, Type F selected, click on the Display icon. 

 

 On the display settings toolbox, select Highlight Selection. Note all the face of curb elements matching the 

settings for the Concrete Curb & Gutter, Type F highlight. 
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Exercise 2.2 Create a Collection Set and Add to Favorites 

In this exercise, you will create a collection set of commonly used items in the D&C Manger and then save as a 

Favorite to recall later. 

 Continuing in the D&C Manager, go to File > Save As > New File. Save the database as 22049555201.ddb 

in the project symb directory. 

 Open the saved database by selecting File > Open C:\e\Projects\2204955201\symb\22049555201.ddb 

 Highlight the Concrete Curb & Gutter, Type F item, right-click and select Add to Favorites. 

 

 Navigate to the following items in the D&C Manager, right-click and Add to Favorites. 

• EOPA – Edge of Asphalt Pavement 

• BSW – Back of Sidewalk 

• FSW – Front of Sidewalk 

• 0520  5 11 – Traffic Separator Concrete – Type I, 4’ wide 

• Guardrail, Roadway TL-3 (Left) 

• Guardrail, Roadway TL-3 (Right) 

 From the D&C Manager dialog, go to the Menu option: Favorites and select the Concrete Curb & 

Gutter, Type F item from the list on the bottom. The active item changes to the Type F curb. 
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 Select Favorites > Organize Favorites. The My Favorites dialog opens. On this dialog, modify the order 

of the list by selecting the Up or Down button on the bottom and deleting undesired items. 

 

 On My Favorites dialog, select Save As. Save the file as drafting.col in the symb folder of the project 

directory. Recall this file at any time by using the Open option. You may create collections for drafting 

items, calculation/quantity items, groups for specific design areas like drainage, traffic control, S&PM, 

utilities, erosion control, etc. 

 



 

FDOT SS4 Automated Quantities ©2019 FDOT  3-1 

3 CIVIL FEATURES AND ADHOC 
ATTRIBUTES MANAGER 

OBJECTIVES 

• Introduce Civil Features 

• Introduce the Adhoc Attributes Manager 

CIVIL FEATURES 

Civil Features define the symbology of elements much like using Place Influence with D&C Manager. The 

difference is only the Civil tools use the Feature definitions. Each design Feature has only one definition. Within 

this definition, symbology is set up for each design View. The tools use the correct symbology for the elements 

drawn based on the type of model or design View (Plan, Cross Section, Profile, or 3D). FDOT has set up the 

Feature tables using Native Style. Native Style looks in the .ddb file for the symbology settings, including the 

GEOPAK attribute tag and any adhocs defined in the .ddb file. 

Exercise 3.1 Draw Guardrail with Civil Tools 

In this exercise, the students use the back of sidewalk and paved shoulder lines to draw in guardrail using Civil 

tools and Features.  

 Open the MicroStation file C:\e\Projects\2204955201\roadway\DSGNRD01.dgn. 

Note If continuing from previous exercise, make sure to close D&C Manager before continuing. 

 Zoom into the NW corner of the new intersection. 

 On the Civil Tools > Horizontal Geometry Tasks menu, select the Single Offset Entire Element tool. 
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 Set the Feature. From the Feature Definition drop down arrow, navigate to Plan (2D) > Guardrail   and 

select the Feature GuardrailLT_TL2. Accept the default Name set. 

 

 Follow the prompts on the cursor to Copy Parallel the Paved Shoulder line 5 feet for the Guardrail line. 

 Select the Paved Shoulder line. 

 

 Enter -5 and press Enter <OR> Data Point in the file to accept. 
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  Leave Mirror unchecked to the default of No and press Enter <OR> Data Point in the file to accept. 

 

 Repeat to draw in Guardrail as shown. Use an Offset value of 2 feet behind the sidewalk. 

 Use the MicroStation modify tool Trim to Intersection to connect the segments together. 

 

Note The process tags the elements created with the DDB Feature attributes. To verify the attributes tagged, 
open the Application Attribute Viewer by going to GEOPAK > ROAD > Element Attributes. 
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ADHOC ATTRIBUTES 

Adhoc Attributes are tags that apply to graphic elements to provide more information. Adhoc Attributes are 

comprised of three types of information that require mandatory definitions: Name, Type, and Value. 

Name An identifying term used when GEOPAK is searching for a specific Adhoc Attribute. 

Type Identifies the nature of the information, and has several different setting options. The options 

for Type are Numeric, String, Unit, Quantity, and Remarks. 

Value The actual information to be used by GEOPAK, and is determined by the Type. For example, 

if the Type is Numeric then the Value must be a number. 

FDOT has set up Adhoc Attributes for many of the Items in the D&C Manager. The functionality of these Adhocs 

range from setting variables used in the calculation of quantities to adding notes for later retrieval. It is important 

to note that in many cases specific projects may require modification of these Adhoc values. The creation process 

of design elements using the Civil Tools and Features will assign the default. FDOT recommends the review of 

these elements to ensure the correct values are set on the elements. 

Note Place these adhocs on the elements BEFORE exporting the quantities to Quantity Manager. 

Name Type 
Default 

Value 
Description 

DESIGN NOTES STRING  Used in automation; Provide extra detail or formula used 

to derive quantity 

SortBy STRING  

Extra control for sorting quantities into the summary 

boxes. Can be alpha or numeric. LDM will sort by the 

value set with this adhoc first and then sort by station. 

SYSTEM CBW STRING  

Permanent crash cushion details – see Standard Plans 

Index 544-001 and associated Standard Plans Instructions 

for more information. Used in automation to fill out the 

summary box information. 

SYSTEM GUARDRAIL STRING  

DESIGN SPEED STRING  

CRASH TEST LEVEL STRING  

HAZARD WIDTH STRING  

LENGTH RESTRICTION STRING  

TTC PHASE STRING  

Temporary crash cushion details. Used in automation to 

fill out the summary box information. 

WORK ZONE SPEED STRING  

CRASH TEST LEVEL STRING  

HAZARD WIDTH STRING  

LENGTH RESTRICTION STRING  

OFFSET STRING  

LOC DESCRIPTION STRING  
Used in automation; gives extra description for the 

location of the quantity shapes in the pavement summary 

box, i.e. shoulder, median, side road name, etc. 

STA CL DRIVEWAY STRING  
Used in automation when pavement or 6” sidewalk area is 

documented in a summary for driveways. 

PAVEMENT TYPE STRING ROADWAY 

Used to sort the quantities in a database into either the 

Summary of Pavement or the Summary of Permanent 

Driveways. 

FUNCTION STRING 
UNDER 

GUARDRAIL 

Used in automation to determine documentation on which 

column the quantity needs in the Summary of 

Miscellaneous Asphalt. 
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Name Type 
Default 

Value 
Description 

SW TYPE STRING SIDEWALK 

Used to sort the quantities in a database into either the 

Summary of Sidewalk or the Summary of Permanent 

Driveways. 

HELP REMARKS VARIES 

Extra guidance provided to help determine the value of 

another adhoc. These adhocs do not pull over into 

Quantity Manager. 

VARIOUS ITEMS*** UNIT/QTY VARIES Sets pay item quantities 

DAYS NUMERIC VARIES Used in formula to calculate pay item. 

LIFT NUMERIC 1 Used in formula to calculate pay item. 

THICKNESS NUMERIC VARIES Used in formula to calculate pay item. 

SLOPE NUMERIC 0 Used in formula to calculate pay item. 

ADHOC ATTRIBUTE MANAGER 

Adhoc Attribute Manager is the tool used for tagging, reviewing, and manipulating Adhoc Attributes. Access 

this tool from the MicroStation Menu selecting GEOPAK > ROAD > GEOPAK 3pc Adhoc Attributes. 

Or by selecting the Open Adhoc Manager button  on the FDOT Plans Development > Quantities Tasks 

menu.  

 

The Adhoc Attribute Manager has four icons on the tool bar for viewing and tagging elements with Adhoc 

Attributes. From left to right these icons are:  Attribute Display Filter, Identify Element, Set Attribute, and 

Adhoc Scooper. The two icons on the right side of the dialog are Create New Row and Delete Row. 

Click F1 with the toolbox active to see the GEOPAK Help files for more detailed information. 
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Exercise 3.2 Tagging Adhoc Attributes  

In this exercise, the value for the Design Notes adhoc will be set using the 3PC Adhoc Attribute Manager. 

 Continuing in the DSGNRD01.dgn file, from the FDOT Plans Development > Quantities Tasks menu, 

select the Open Adhoc Manager button . Adhoc Attribute Manager displays. 

 

 Select File > Preferences. 

 

 On the Preferences dialog, select Replace from the drop-down menu for the Set Mode. 

 

 Click on the X to close the dialog. 

 Click the Identify Element icon, and then select the Guardrail drawn in Exercise 3.1. Click anywhere in 

the drawing to accept the selection. The dialog populates with the Adhocs attached to the selected element. 
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 Select the Value field for Design Notes and type in notes as shown. This text will be included later in the 

quantity summary box. 

 

 Create a Selection Set of the guardrail elements. 

 Click the Set Attribute icon. An Alert displays. 

 

 From Alert, click Yes. 

 

 With the Selection Set still active, select the Identify Element icon. The Adhocs for all the elements in the 

selection are now available in the Adhoc Attribute Manager in read-only mode. Use the arrows to scroll 

through the elements. Selecting the Identify Element icon again will empty the Selection Set. 

 

 Close Adhoc Attribute Manager. 

  



Chapter3 CIVIL FEATURES AND ADHOC ATTRIBUTES MANAGER - Tagging Adhoc Attributes 

3-8 ©2019 FDOT  FDOT SS4 Automated Quantities 

[THIS PAGE INTENTIONALLY LEFT BLANK] 

 



 

FDOT SS4 Automated Quantities ©2019 FDOT  4-1 

4 CALCULATING QUANTITIES 

OBJECTIVES 

• Understand D&C Manager Compute Settings 

• Understand and Draw Quantity Shapes  

• Calculate Area and Linear Quantities with the D&C Manager 

• Label Shapes with Area ID 

CALCULATING QUANTITIES WITH D&C MANAGER 

Once all design elements and quantity shapes are completed, calculating quantities with D&C Manager is a simple 

process with four parts: 

• Settings to Consider 

• Selecting Database Items to Compute 

• Calculating Quantities  

• Exporting Quantities  

SETTINGS TO CONSIDER 

The D&C Manager has many Settings options to consider. For many of these, the Production Support CADD 

Office recommends the Default Settings. 
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DESIGN SETTINGS 

Within the Design Settings options, there are settings for Element Connectivity. These options set the 

tolerances used by GEOPAK during different operations. 

 

• Maximum Gap Tolerance – The application uses this to 

determine whether two elements are connected. FDOT 

recommends Maximum Gap Tolerance be set no higher 

than 0.2. 

• Deduction Tolerance – The application uses this in the 

Compute Mode, the deduction tolerance sets the distance 

used to search for other elements used to subtract a given 

value from the total quantity. FDOT uses deductions for 

inlets in the calculation of curb and gutter. Increase the 

value when drawing curb through inlet cells. The suggested 

value is 3.0. 

 

COMPUTE SETTINGS 

Compute Settings control how D&C Manager processes information gathered when exporting quantities. 

Review Compute Settings before every session of computing quantities, with careful thought about the 

desired final product. As a rule, some settings are always the same. The DBMS Properties is always set to 

Microsoft Access (.mdb) as the Driver. Having these options set ensures that the quantity database matches 

the graphical elements of the .dgn file and that all available information carries over to Quantity Manager. 

Compute Settings apply during the Compute Mode to help ensure accurate quantity generation. This manual 

will focus on the DBMS Properties. 

 

• Driver – FDOT recommends using Microsoft Access 

(.mdb), which does not require a User Name and 

Password. 

• Purge Quantities – Scans the design file for elements 

previously quantified and purges the quantity database 

of any elements not found in the file. This is not 

automatic by default. Use this option only if ALL the 

quantities in the database are contained in the Active 

Model, otherwise the process will delete the other 

quantities. 

 

 

 

 

 

Note With the recommended workflow, FDOT does NOT recommend the use of the Purge Quantities for 
Deleted DGN Elements option. 
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COMPUTE MODE 

The Compute mode tabulates quantities of items placed as Pay Items by the D&C Manger. This option uses the 

Collection Set option to allow processing of multiple pay items at one time.  

  

• Job – The COGO job**.gpk database for the project used for chain information. 

• Extents – The Extents determines which elements are included in the set. If selecting the Range 

check box, the element must exist within the extents and range (distance left and right of the 

baseline) for the element computed. 

 

Active Design File All elements in the active Design file that match the selected items. 

View Computes items that display in MicroStation View One. 

Fence Computes items within a MicroStation fence. 

Boundary Element Uses a MicroStation shape to define the boundary of computable 

elements. The Fence mode affects the computation of elements 

within the boundary. 

Station Range Computes items using a Baseline Reference (chain or dgn). The 

Begin and End station limits the extent of the computations. 

Sheet Range Uses the clip borders created with the Plan & Profile Sheet 

Composition tool to define the area of computation. 

Selection Set Computes those items that are in a previously created selection set 

that meets the definition of the compute items. 

Boundary 

Selection Set 

Computes items that are within a boundary element that is in a 

selection set that meets the definition of the selected elements. 
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• Baseline Reference – The Baseline Reference section defines the reference element for quantities. 

 

Chain This uses a previously stored COGO chain. 

DGN This uses a graphic element. The stationing based on the length of the element 

starting at 0. 

None No reference is required, and the Baseline Reference is blank. This option limits 

the type of output available, as computations will not have station/offset values. 

Note FDOT recommends using the Chain option. This option gathers the station/offset information of the 
elements when calculating. This information is required for the Plan Summary Boxes and automation 
with Linked Data Manager (LDM). 

SELECTING DATABASE ITEMS TO COMPUTE 

Before computation, the collection set of the Items and/or Categories calculated is set from the D&C Manager 

database: single Items, multiple Items, multiple Categories, Favorites Collection, or any combination of 

Items, Categories and Favorite Collections. A collection set is not required when computing quantities for a 

single Item or Category. 

➢ To Select Only One Item 

1. In D&C Manager, select the Item for computation. 

➢ To Select Multiple Items 

1. In D&C Manager, select an Item for computation. 

2. Right-click the selected Item. A menu displays. 

3. From the menu, click Add to Collection. The Item displays in the collection box at the bottom of 

D&C Manager. 

Note The collection box appears when D&C Manager is in Compute Mode. 

4. Repeat steps 1 through 3 to add Multiple Items to the collection box. 

➢ To Select Categories 

1. In D&C Manager, select the desired Category for computation. 

2. For multiple categories, right-click the Category. A menu displays. 

3. From the menu, click Add to Collection. The Category places in the collection box at the bottom 

of D&C Manager. 

4. Repeat steps 1 through 3 to add Multiple Categories to the collection box. 

Note When selecting Categories, all Items in the Categories present in the DGN file will compute. 

➢ To Select a Favorites Collection 

1. Right-click in the collection box and select Open a Collection. 

2. Select the desired collection file and click Open. 

3. Repeat steps 1 and 2 to add multiple collections. 
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COMPUTATION RESULTS 

After defining the settings, clicking on Compute Quantities opens the Computation Results dialog. 

  

Computation Results displays a table of all computed Items processed during computation. From here, the 

user can review the results and export quantity computations to a variety of formats. The box to the right of 

the Export Format is for supplying a file name for the report or quantities database. The computation can 

Create or Append the report or quantity database by making the selection to the right of the file name box. 

The Run box identifies the session when the quantities compute. Groupings is used to identify the 

TRNS*PORT Grouping in Quantity Manager. The Display button highlights any item selected in the Table 

View in the design file. 

➢ To Sort Items in the Table 

1. In the table, click the column header. All Items will sort by that column. 

➢ To Exclude Individual Items 

1. Clear the check box in the Export column for any individual items excluded. 

FDOT recommends using the Export Format option DBMS to export quantities to Quantity Manager. From 

Quantity Manager, reports can be generated to help fill out non-automated summary boxes as well as generate 

the xml file that can be used to upload the pay items and quantities to AASHTOWare Project Preconstruction 

(formerly known as Trns*port). Linked Data Manager (LDM) uses the Quantity Manager database to 

automate summary boxes. 

Exercise 4.1 Calculating Linear Foot Quantities with D&C Manager 

This exercise calculates and exports linear foot quantities to a Quantity Manager database using the D&C 

Manager.  

 Open the design file DSGNRD01.dgn. 

 In the D&C Manager, navigate to Roadway Design > Plan Features > Curb & Gutter, Curb, Gutter and 

select the Curb & Gutter, Curb Gutter category. 
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 Select the Compute Mode. 

 

 Set the Plan Quantity Computation dialog as shown and click Compute Quantities. 

 

 On the Computation Results dialog, set the Export Format to DBMS, type in the project number for the file 

name with the Mode set to Create, and for Groupings type in 0200.  Click Export. 

 

Note It is very important to change the Groupings value before exporting. The default value, Design Estimate, 
will result in errors when importing quantities through Designer Interface. 

 Close the Computation Results dialog. 
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 In the D&C Manager, navigate to and select the Guardrail category. 

 

 On the Plan Quantity Computation dialog, change the Chain to BL98 and then click Compute Quantities. 

 

 On the Computation Results dialog, change the Export option to Append and click Export. 

 

 Change the D&C Manager back to the Design Mode. 
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CREATING SHAPES 

Shape creation is generally not done during the design process. As such, quantity shapes for these areas need to 

be created. The quantity shape file (qtdsrd01AQT.dgn) provided with this course already has most of the needed 

shapes built. This course focuses on creating shapes near the existing intersection. It is important to remember 

that the methods of computation shown in this manual may not be complete, and the designer should consult the 

appropriate governing documents for calculation procedures. 

With the introduction of Open Roads Civil Tools, the Production Support CADD Office recommends using the 

MicroStation Create Region tool to create quantity shapes. The Shape Mode of the D&C Manager is accessible; 

however, this tool does not function properly with some civil elements, especially Civil Cells. When creating 

quantity shapes with the Create Region tool, it is very important to turn OFF the Associative Region Boundary 

option. If it is on, D&C Manager will NOT recognize the elements for computations. 

 

Although it is possible for quantity shapes to span the entire length of the project, FDOT recommends that they 

be broken into intervals. The designer can choose to break the shapes at intersections, or at a set distance. 

Note For area shapes with “holes”, the Locate Interior Shapes option is not recommended, as the 
stationing is not exported properly to Quantity Manager for Grouped Holes. Creating two or more 
shapes may be necessary to quantify the area. 
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Exercise 4.2 Calculating Area Quantities with D&C Manager 

This exercise creates, calculates and exports quantity shapes to a Quantity Manager database using the D&C 

Manager. 

 Open the design file QTDSRD01.dgn, Model 0334 1 52 from Exercise 1.1. 

 Rotate the view and zoom to the beginning of the new construction. 

 

 On the MicroStation menu select File > References to open the References dialog and turn off the display 

for the ALGNRD01.dgn and TOPORD01.dgn reference files. 
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 On the MicroStation menu select Settings > Levels > Display (or click the Level Display button) to open 

the Level Display dialog and select the DSGNRD01.dgn, Default attachment. Right-click in the Level 

Name area and select All Off then select the level names to turn back On as shown below. 

      

 From the FDOT Plans Development > Quantities Tasks menu, select the Open D&C Manager icon. 
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 Navigate to Roadway Design > Quantity Features > Asphaltic Concrete > Superpave Asphaltic Conc and 

select 0334  1 52. 

 

 Using the MicroStation Place Line command, draw in lines to segment the new construction area into 

smaller areas for reporting purposes.  

 

Note Make sure to trim the elements to intersection ensuring the elements do not cross or overlap each other.  

 The D&C Manager should still be open. Make sure the Adhoc Attributes dialog displays. If it does not, 

toggle On the Place Influence and Adhoc Attributes in the Place Influence dialog box. 
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 In the Adhoc Attributes dialog box, add the Value, SR61, for the Adhoc LOCDESCRIPTION. 

 

 Open the MicroStation tool Create Region.  

 

 Define the settings in the dialog as shown. 

 DO NOT check ON the Associative Region Boundary option; otherwise, the 
D&C Manager will not recognize the shape when calculating. 

 

Note Using a Fill Type is optional. 

 Data Point inside of one of the mainline areas to flood the area and create the quantity shape. Continue 

selecting areas to create shapes for the remaining mainline areas. 
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 Change the D&C Manager Mode to Compute. 

 

 Set up the Plan Quantity Computation dialog as shown above and click on Compute Quantities. The 

shapes along the mainline highlight and the Computation Results dialog displays. 

 On the Computation Results dialog, make sure to set the Groupings to 0200 as shown below and then click 

Export. Close the dialog when export is complete. 
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Exercise 4.3 Modifying Adhocs with D&C Manager for Quantity Calculations 

This exercise modifies the Lift Adhoc value on the Asphalt Shapes. LDM automation uses these Adhocs to sort 

the quantities in the Quantity Manager database into the correct summary box. 

 Open the MicroStation design file, QTDSRD01.dgn, Model 0334  1 52. 

 Turn Off the display for all the Reference files. 

 In the D&C Manager, navigate to Roadway Design > Quantity Features > Asphaltic Concrete > Superpave 

Asphaltic Conc and select 0334  1 52. 

 

 You can select the id button, then click one shape to go directly to the correct item. 

 Select the Set icon. 

 

 Toggle On the Adhoc Attributes option and set the Attach Mode to Replace. 
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 Select all the Shapes in the file with the Element Selection tool by clicking out to the upper left of the 

shapes and dragging the mouse to encompass all the shapes.  

 

Note Take care when setting Adhoc values to Selection Sets. Make sure NOT to overwrite other Adhoc values 
that may be different on individual elements. 

 In the Adhoc Attributes dialog, set the Lift Adhoc Value to 2.5. 

 

 In the Set dialog, click the Set button. 

 

 Change the D&C Manager Mode to Compute. 
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 Modify the Settings as shown and click Compute Quantities. 

 

Note In the previous exercise, the user exported a quantity for the same pay item to the database. Re-exporting 
the quantity will NOT overwrite what is already in the database. Delete the quantity from Quantity 
Manager before exporting the new quantity. The next steps will define the basics for doing this. The 
next chapter covers the Quantity Manager. 

 From the FDOT Plans Development > Quantities Tasks menu select Open Quantity Manager. 

 < OR > 

In the MicroStation View, right-click and hold for the context menu, then select Quantity Manager. 

   

 On the Quantity Manager dialog, click on Open Project. 
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 On the Connect To Database dialog, click on the icon to Select Database Filename. 

 

 Navigate to C:\e\projects\22049555201\roadway\ and select the 22049555201.mdb file. 

Click Open. 

 On the Connect To Database dialog, click Connect. 

 

 Navigate to the asphalt quantity under Roadway Design > Quantity Features > Asphaltic Concrete > 

Superpave Asphaltic Conc. 
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 Right-click on the Pay Item 0334  1 52 and select Delete. 

 

 On the Delete Payitem? Alert dialog, click Yes to delete the selected Pay Item. 

 

 Close Quantity Manager. 

 In MicroStation, on the Computation Results dialog, use the same settings shown to Export the Asphalt 

Quantities. 
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PREFERENCES MODE 

Use the Preferences Mode of the D&C Manager to create, review, and modify items.  

 

There are times when items needed are not included in the D&C Manager database. For example, a pay item is 

needed or an item to count elements in a design file. In these situations, toggle on the icon for Preferences. This 

is an administrative mode to make it easier to modify items in the database. With Preferences Mode active, double 

clicking on a database item opens the Item Modify dialog box.  

 

• Item ID - Name of the database item. For Compute Parameter items, it is important to name the item 

using the Project Preconstruction formatting. 

• Type - Four types are supported: Default, Drafting Standards, Compute Parameters, and Pavement 

Design. 

 

Default Identifies element symbology for drawing elements and search 

parameters. 

Drafting Standards Defines element symbology for the placement of coordinate 

geometry elements, i.e. points, lines, curves, parcels, chains, and 

profiles. 

Compute Parameters Identifies parameters associated with calculating quantities, i.e. 

unit of measure, rounding factors, pay item, formulas. 

Pavement Design FDOT does not use this classification and this manual will not 

cover. 
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• Description - Description of the item. 

• Placement - Sets the symbology for elements drawn or set using this item. 

• Attribute - When toggled ON, adds a special adhoc to the element used to make the element unique 

for identification purposes.  

• Class - Primary or Construction. 

• Cell Name - Sets the cell name. 

• Scale - Sets how the scale of the cell is determined when placing. 

• Supplemental Search Criteria - Defines additional symbology parameters to identify elements for 

the item. 

• Key-In Commands - MicroStation key-in commands executed when double clicking on an item 

when in the different modes. 

• Adhoc Attributes - When toggled ON, assigns adhoc attributes to elements with Place Influence or 

using the Set command. 

 

• Compute Parameters - When setting Classification to Compute Parameters, toggled ON. Defines 

how to calculate the item, and sets the Units and Rounding. 
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Exercise 4.4 Add an Item to the D&C Manager 

This exercise adds an item to the D&C Manager database for pay item 520-1-11, variable height Type F Curb & 

Gutter. Since we are creating an item to calculate curb and gutter, we going to copy a similar item and then modify 

the new item to suit the needs for the new pay item required. 

 Continuing with the D&C Manager in the saved project database 22049555201.ddb, navigate to the item 

520-1-10 Curb & Gutter, Type F. 

 Select the Preferences Mode. 

 

 Right-click and select Copy. 

 

 On the Copy to… dialog box, scroll down to and select the 0520 1 10 item and select OK. When copying 

or moving items or categories, the item places below the item or category selected. 
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 Double-click on the new item 0520 1 101 to open Item Modify. 

 

 On the Item Modify dialog, edit the Item ID, Description and Attribute values as shown below.  

 

 Click OK. The item is now ready to use to draw/set elements and calculate the quantity. 

 Select File > Save to save the modified database to the project symb directory so that the changes will be 

delivered with the project. 
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LABEL SHAPES WITH AREA ID 

When designing an FDOT project, labeling the areas used to generate quantities is REQUIRED. The delivery to 

Construction includes the QTDSRD file as part of the backup information for the quantities. FDOT delivers the 

Label Shapes with ID VBA application on the FDOT Menu to automate labeling: It is also included on the FDOT 

Plans Development > Quantities Tasks menu. 

     

 

This tool can label all the shapes in a model at one time by creating a selection set of all the elements in the file 

and then clicking Label Shapes. FDOT recommends creating the labels at a larger scale than for normal drawings. 

These labels are not printed. The intent of these labels is to help downstream location of specific shapes. 

  



Chapter 4 CALCULATING QUANTITIES - Label Areas 

4-24 ©2019 FDOT  FDOT SS4 Automated Quantities 

Exercise 4.5 Label Areas 

This exercise creates the Area ID Label on the quantity shapes using the Label Shapes with ID tool. 

 On the FDOT Plans Development > Quantities Tasks menu select Label Shapes with ID. 

 

 Set up the Label Shapes with ID dialog as shown below.  

 

Note This tool works with Annotation Scale. If the text comes in too small with the above setting, go to the 
Settings > Drawing Scale dialog and adjust the Annotation Scale for the model. 

 Using the Element Selection tool, select ALL the Shapes in the Model. 

 Click Label Shapes. 

 Select CTL-B on the keyboard to open View Attributes. Toggle OFF the Fill option.  

 Save Settings with CTL-F on the keyboard. 

 Review the results. 
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5 QUANTITY MANAGER 

OBJECTIVES 

• Detail the Functions of Quantity Manager 

• Open a Quantity Database in Quantity Manager 

• Detail the Quantity Manager Window 

• Navigate Through Quantity Manager 

• Generate Quantity Reports 

QUANTITY MANAGER OVERVIEW 

Quantity Manager is the GEOPAK tool used to store, organize, and manipulate quantities generated by the D&C 

Manager. Pay items and quantities can also be stored in the database manually. It is not the intent of this chapter 

is to provide full training on all the functions within Quantity Manager. For more in depth information, see the 

Bentley Help files. 

ACCESS QUANTITY MANAGER 

To access Quantity Manager, from the Road toolbox, pull down the options under the D&C Manager icon and 

click the Quantity Manager icon. 

 

<OR>  

From the MicroStation menu, select GEOPAK > ROAD > Quantity Manager.  

<OR>  

From the FDOT Plans Development > Quantities Tasks menu, select the Quantity Manager icon.  

<OR>  

From MicroStation, right-click and hold for the context menu, select Quantity Manager. 

Note The right-click menu options change with the type of active file open. 
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QUANTITY MANAGER DIALOG 

Quantity Manager has three parts, as shown in the following figure: Menu bar, Tool Bar and Window Area. The 

Window area has three panes: Pay Item, Quantity, and Element. 

 

➢ Opening a Project 

1. From the MicroStation Menu, select GEOPAK > ROAD > Quantity Manager. 

2. From the Quantity Manager Menu, select Project > Open. Connect to Database dialog displays. 

 

3. In the File box, enter the path to 22049555201AQT.mdb 

<OR> click the Browse icon  and navigate to the file. 

4. Leave the User Name and Password boxes blank. 

Note For this course will use the pre-existing 22049555201AQT.mdb file. 

5. Click the Connect button. The database displays. 
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PROJECT PROPERTIES 

Once a project displays in Quantity Manager, the Project Properties need to be set. There are two methods for 

setting the project properties. The preferred method is using the Designer Interface, unless the user does not have 

a TRNS*PORT login. 

DEFINING PROJECT PROPERTIES 

➢ To Define Project Properties from within Quantity Manager, if no TRNS*PORT login. 

1. From the Quantity Manager menu, select 

Project > Properties. Project Properties 

displays. 

2. In the Project Number box, enter the 

Project FIN Number. 

3. In the Description box, enter the Project 

description. 

4. In the Unit System box, select English. 

5. In the Spec Year box, enter the 

Specification Year. 

Note  The Spec Year definition must match the Pay 
Item aecXML file exactly. 

 

➢ To Define Project Properties using Designer Interface, if Login Exists. 

If user has a login to access Designer Interface, this is the preferred method for populating the Project 

Properties. 

Note For illustration purposes in this course, the CADD office test project in Designer Interface will be used. 

1. Once logged into Designer Interface, use “Export Header” to create an .XML file to import into 

Quantity Manager. This file contains the Quantity Manager Project Properties. 
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2. Select Save As to save the file to your project discipline directory. By default, the filename of this 

file becomes [FPID#].xml. 

Note The bar and save options shown are in Internet Explorer. Other internet browsers may save the file 
directly to the downloads folder. If this happens, simply copy the file from the downloads folder to the 
project discipline directory. 

3. In Quantity Manager, open the same Project as selected in Designer Interface. 

4. From the Quantity Manager menu, select Project > Properties.  

5. From Project Properties, select Project > Import aecXML Infrastructure V33 Project. 

 

6. Select the Location and File Name of the XML file exported from Designer Interface. 

7. Click OPEN. The Project Properties populates in Quantity Manager. 

8. Select the TRNS*port Groupings tab. 

 

9. Select the TRNS*PORT Groupings applicable to your Project. The Default checks all ON. 

10. Select Import. Project Properties closes. 

11. Select the drop-down list for TRNS*PORT Groupings. 

 

Note Notice the creation of the Groupings. See the Basis of Estimates Manual, Chapter 9 for the Grouping 
definitions. 
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PREFERENCES 

The preferences are set to enable Adhoc Attribute editing, define the aecXML Import Documents file locations, 

and set the Display Accuracy of Distance Decimal, Station Decimal, and Station Format. 

➢ To Define Project Preferences 

1. From the Quantity Manager menu, select Project > Preferences. Project Preferences displays. 

 

2. Check On the Enable Adhoc Attribute Editing. 

3. Download the FDOT pay item list from FDOT’s FTP site into the Project Symb directory. There is 

a link on the FDOT Menu under Actions > AASHTOWare Project Preconstruction 

(TRNS*port) > AECITEM.xml Download. Login as “guest”. 
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4. Select the Expand button at the far-right side of the aecitem.xml file link, then select Download 

and save the file to the Project Symb directory. 

 

Note FDOT updates the FTP site each morning around 5 am and recommends downloading periodically to 
ensure the latest pay item list. 

5. In the Project Preferences dialog Pay Item box, enter the path to AECITEM.xml, located in the 

Project Symb directory. 

<OR> click the Browse icon  and navigate to the file. 

6. In the Payer box, leave blank. 

7. Click the OK button. The information saves and Project Preferences closes. 
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INTERFACE DETAILS 

The main body of Quantity Manager comprises three panes: Pay Item, Quantity, and Element. 

 

PAY ITEM PANE 

The Pay Item Pane is located on the left side of Quantity Manager in Normal View and is the top pane when 

tiled horizontally. Two tabs control the display type for the Pay Item pane:  

• Payitem Tree – This tab displays the contents in a hierarchical structure easily navigated in the same 

manner as D&C Manager.  

• Payitem Table – This tab displays the database Pay Items in a table format that contains additional 

information about Pay Items and is useful for selecting multiple items. 

QUANTITY PANE 

The Quantity Pane displays only quantity information under the current Phase selected on the tool bar about 

the specifically selected Pay Item or Category. The information is customizable by selecting which columns 

to display and sorts by clicking on any of the column headers. 

ELEMENT PANE 

The Element Pane displays information specific to the selected Quantity. Each tab displays different 

attributes. The Elements tab shows all the elements that make up the selected Quantity. Adhoc Attributes tab 

displays any Adhoc related to the Quantity. Funding Participation, Funding Rules, and Payer Participation 

tab displays information related to funding sources. 
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RIGHT-CLICK MENUS 

Select an item or category and right-click in the Pay Item Pane or Quantity Pane to display a popup menu with a 

list of shortcuts to tools related to the View Pane. 
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INSERT OPTIONS 

Quantity Manager has an option for manually adding Quantities. The Insert menu has the options to add 

Categories, Pay Items, and Quantities <OR> access by right-clicking in the Pay Item Pane of the dialog. The 

options will vary when accessing through the right-click menus. 

INSERT CATEGORY 

A Category is comparable to a folder in a directory structure. When exporting quantities from D&C Manager, the 

Categories from the D&C Manager export along with the quantities. Manually create Categories above, below, 

or as subcategories to the selected Category. 

➢ To Create a New Category: 

1. Select an existing Category in the Pay Item Pane. 

2. Right-click and select the option to Insert Above, Below or Subcategory. 

 

3. On the New Category Properties dialog, enter the new Category Name. 

4. Click OK. 
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INSERT PAY ITEM 

In Quantity Manager, the Pay Item is a special “file” that contains the quantity information. Add Pay Items Above 

or Below a selected Pay Item. Highlighting a Category and selecting the option to Insert Pay Item ensures the 

new Pay Item adds to the selected Category. 

➢ To Create a New Pay Item: 

1. Select an existing Pay Item or Category. 

2. Right-click and select the option to Insert Pay Item. 

 

3. Complete the New Pay Item Properties dialog. 

 The aecitem.xml file is accessible through Quantity Manager by clicking on the 
Browse icon next to the Pay Item Name, then the Pay Item Number may be selected from the list. 

4. Click OK. 
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INSERT QUANTITY 

Manually add Quantities to the database by right-clicking on a Pay Item in the Pay Item pane of the dialog. These 

can be new quantities not calculated by the D&C Manger or could include a contingent quantity added after the 

project quantities have been calculated. 

➢ To create a new quantity: 

1. Select the desired Pay item to add a new Quantity. 

2. Right-click and select Insert Quantity. 

3. Fill out the New Quantities Properties dialog box. There are three tabs for entering information. 

a. General Tab – Enter quantity information. 

 

b. Location Tab – Enter Baseline and Station/Offset Information 

 

Note If either the station or offset information is not given, LDM will not include the quantity during automation. 
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c. Adhoc Attributes Tab - Add Adhocs - they must match D&C Manager for LDM to use during 

automation. 

 

  



QUANTITY MANAGER - Navigating Quantity Manager   Chapter 5 

FDOT SS4 Automated Quantities ©2019 FDOT  5-13 

Exercise 5.1 Navigating Quantity Manager 

This exercise will explore Quantity Manager to get familiar with how it is set up and displays the contents of the 

database. 

 From the MicroStation Menu, select Applications > GEOPAK Road > Quantity Manager. 

 From the Quantity Manager Menu, select Project > Open. Connect to Database dialog displays. 

 

 In the File box, enter the path to 22049555201AQT.mdb <OR> click the Browse icon  and navigate to 

the file. 

 Leave the User Name and Password boxes blank. 

 Click the Connect button. The database displays. 

 From Quantity Manager, select the Pay Item Tree tab. 

 Navigate through the database and select Pay Item 0285706. 
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 In the Quantity Pane, right-click on a column header. Quantity Table displays. 

 

 Clear the Remarks, Description, and Extended Description check boxes. 

 Close Quantity Table dialog. 

 From Quantity Manager, select the first item in the Quantity Pane. 
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 In the Elements Pane, select the Elements tab and review the components of the selected quantity. 

 

 In the Payitem Pane, select the Payitem Tree tab and navigate the database to Item 0334 1 52 (Superpave 

Asphaltic Concrete, Traffic B, PG 76-22). 

 Select one of the Quantities that appears in the Quantity Table. 

 In the Element Pane, select the Adhoc Attributes tab. The Adhoc tags display for this element. 
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Exercise 5.2 Creating a Category 

This exercise creates a new Category for manually added Pay Items. 

 From Quantity Manager, select the Payitem Tree tab and then select the Roadway Design Category. 

 

 From the Quantity Manager menu, select Insert > Category > Subcategory. New Category Properties 

displays. 

  From New Category Properties, enter Manual Pay Items in the Category Name box. 

 

 Click the OK button to create the new Category. 

Exercise 5.3 Importing Pay Items 

This exercise sets the preferences to find the aecitem.xml file and imports Pay Items to the database. 

 From Quantity Manager, select Project > Preferences. 

 On the Project Preferences dialog, check On the Enable Adhoc Attribute Editing. 

 Click on the Browse icon  next to the Payitem box, browse to the Project Symb directory, and select 

the aecitem.xml file.  

 Set the Display Accuracy settings as desired and click OK. 

 



QUANTITY MANAGER - Importing Pay Items   Chapter 5 

FDOT SS4 Automated Quantities ©2019 FDOT  5-17 

 From Quantity Manager, Set the TRNS*PORT Groupings to 0200, select the Payitem Tree tab and then 

select the Manual Pay Items Category. 

 Right-click and select Insert Payitem… from the popup menu. New Payitem Properties dialog displays. 

(This option allows for adding the pay item as well as the quantity.) 

 

 Click on the Browse Master Payitem Document icon. 

        

 In the Select Payitem dialog, clear the Description Filter box and then enter M. All Payitems with 

Descriptions beginning with the letter M display. 

 

 In the table, select 0101 1 Mobilization and click the Import button.  
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 The Mobilization Payitem information populates on the New Payitem Properties dialog. 

 

 Toggle ON the option for the Rounded Value and type in a value of 1. 

 

 Click OK to add the pay item and quantity to Quantity Manager. 

 Select the Manual Pay Items Category. 

 Right-click and select Import Payitems (aecxml Infrastructure v33) from the popup menu. Select 

Payitems dialog displays. (This option allows for the insertion of pay items only.) 
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 On the Select Payitems dialog, clear the Description Filter box and then enter M. All Payitems with 

Descriptions beginning with the letter M display. 

 

 In the table, select 0102 1 Maintenance of Traffic. 

 Click the Import button. The Maintenance of Traffic Payitem adds to Quantity Manager. 

 Repeat steps 15 through 17 to import Payitem 0102 61 Business Sign using B in the Description Filter. 

 Close Select Payitems. 
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Exercise 5.4 Creating Quantities 

This exercise adds quantities to Pay Items included in the database. 

 In the Payitem Tree tab, select Manual Pay Item 0102 1 Maintenance of Traffic. 

 Right click and select Insert Quantity. 

 

 From New Quantity Properties, General tab: 

 In the Measurement Value box, enter 60. This value is the number of days for the project. 

 In the Computed Quantity box, enter 1. This Pay Item is an example of a Hybrid Lump Sum Quantity. 
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 Select the Location tab. 

 In the Baseline Chain box, select SR61 (JOB00.GPK). The Minimum and Maximum Station will 

populate from the chain automatically. 

 

 Click the Create icon. The Quantity adds to Quantity Manager. 

 Close the New Quantity Properties dialog box. 

 In the Payitem Tree tab, select Pay Item 0102 61 Business Sign. 

 

 Right click and select Insert Quantity. 

 From New Quantity Properties, select the General tab. 

 In the Measurement Value box, enter 1. 

 Select the Location tab. 

 In the Baseline Chain box, select SR61 (JOB00.GPK). 

 Under Minimum Station, enter 706+00 in the Station box and enter 100 in the Offset box. 

 Under Maximum Station, enter 706+00 in the Station box and enter 100 in the Offset box. 

 Click the Create icon. The Quantity adds to Quantity Manager. 

 Under Minimum Station, enter 782+00 in the Station box and enter -100 in the Offset box. 

 Under Maximum Station, enter 782+00 in the Station box and enter -100 in the Offset box. 

 Click the Create icon. The Quantity adds to Quantity Manager. 

 Under Minimum Station, enter 791+00 in the Station box and enter 100 in the Offset box. 

 Under Maximum Station, enter 791+00 in the Station box and enter 100 in the Offset box. 

 Click the Create icon. The Quantity adds to Quantity Manager. 
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 Close New Quantity Properties. 

 In the Payitem Tree tab, select Pay Item 0334  1 52 Superpave Asphaltic Concrete, Traffic B, 

PG 76-22. 

 

 Right click and select Insert Quantity. From New Quantity Properties, select the General tab. Fill out as 

shown below. 

 

 Select the Location tab. Fill out as shown below. 
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 Select the Adhoc Attributes tab. Click on the New Phase button to add a new adhoc attribute. 

 

 Add the Adhoc names, types, and values as shown below: 

 

Note The Adhoc Names and Types MUST match the Adhocs of the item in D&C Manager for LDM automation 
to include the manually created quantity item in the Summary box. 

 Click Create to add the quantity. 

 Close the New Quantity Properties dialog box. 

 Click on the new item in the Quantity Pane. In the Element Pane, select the Adhoc Attributes tab. Review 

the Adhoc values. 
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REPORTS 

Quantity Manager has the option to create Reports in PDF or CSV formats. For non-automated Plan Summary 

Boxes, use the CSV Reports to generate the data needed to fill out the summary box Excel templates. 

Exercise 5.5 Creating CSV Reports 

This exercise generates an Area Report for Clearing and Grubbing and the Removal of Existing Concrete 

quantities used to fill out the Summary of Clearing and Grubbing and Removal Items. 

 Continuing in the 22049555201AQT.mdb file, navigate to Roadway Design > Quantity Features > Pavt 

Removal Clearing & Grubbing and select the Pay Item 0110  1  1 Clearing & Grubbing and verify that 

the Trns*port Groupings is set to 0200. 

 

 Select Item 0110 1 1 and then select Tools > Reports > Create. 

 

 On the Create Report dialog, set the Report Style to FDOT Form 700-050-01 Area Computations 

(CSV). 
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 In the Report File Name, click the Select Report Filename icon. 

 

Note The creation process saves the CSV to the GEOPAK working directory when not defining the full path 
for the Report File Name. 

 Navigate to the project calculations folder, enter 0110_1_1.csv as the file name and then click Open. 

 

 In the Create Report dialog, click Create. 

 

 Excel opens the CSV spreadsheet. View the exported data. Close Excel. 

 Repeat steps 2 – 5 for Pay Item 0110  2  2 Selective Clearing and Grubbing, Areas with Trees to Remain 

and Pay Item 0110  4 10 Removal of Existing Concrete. 

 Close Quantity Manager. 
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6 PLAN SUMMARY BOXES & LDM 

OBJECTIVES 

• Define Plan Summary Boxes and workflow requirements. 

• Introduce Linked Data Manager (LDM). 

• Create Plan Summary Boxes using LDM and reports. 

PLAN SUMMARY BOXES 

FDOT requires that all quantities are documented in Plan Summary Boxes located on the Summary of Quantity 

sheets. Computation Books are no longer required. Do NOT mix and match the old summary boxes with the new 

ones in the same plan set. The FDOT Design Manual (FDM) and the Structures Design Manual along with the 

CADD Manual and the Basis of Estimates post documentation to define the following. 

➢ Plan Set Location 

• Roadway – Summary of Quantities sheets are to be placed after the numbered Plan Sheets. 

• Structures – Directly after the Index/Key Sheet (or after the Summary of Pay Items if the Structures 

Plans are stand-alone with no Roadway component.) 

➢ File Name 

• Roadway – SUMQRD 

• Structures – B#SumofQuantities* 

➢ Sheet Prefix  

FDOT uses Sheet Prefixes to keep separate for re-numbering. 

• Roadway – SQ- 

• Structures – BQ#- 

Note Each Bridge will have a separate Summary of Structure Quantities sheet(s) numbered as:  BQ#-#. 
 
For Example, if there are general bridge Pay Items (Mobilization MOT, etc.), the sheet will be the first 
Summary of Structure Quantities sheet numbered BQ-1. The Summary of Structure Quantities for Bridge 
1 will follow with sheet numbers BQ1-1, BQ1-2, etc.; followed by Bridge 2 with sheet numbers BQ2-1, 
BQ2-2, etc. 
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➢ Formatting 

FDOT controls Summary Box formatting through Excel spreadsheet files. 

• FDOT-delivered Summary Box templates for use with LDM in both automated and manual formats: 

o    Barrier Walls o    Pedestrian Longitudinal Channeling Devices 

o    Curb and Traffic Separators o    Permanent Crash Cushions 

o    Ditch Pavement o    Permanent Crash Cushions 2019 

o    Driveways o    Railing 

o    Edgedrain o    Sidewalk 

o    Erosion Control o    Temporary Crash Cushions 

o    Fencing o    Temporary Driveways 

o    French Drain o    Trench Drain 

o    Guardrail o    Turf and Prepared Soil 

o    Mailboxes o    Turnouts 

o    Miscellaneous Asphalt o    Underdrain 

o    Pavement o    Utility Adjustments 

• FDOT-delivered Summary Box templates for use with LDM in manual format only: 

o    Box Culverts o    Pedestrian Special Detours 

o    Clearing and Grubbing and Removal Items o    Side Drain and Mitered End Sections 

o    Earthwork o    Side Drains and Mitered End Section with Flowlines 

o    General Items o    Structures Quantities 

o    Geotechnical Items o    Temporary Traffic Control Plan Items 

o    Litter Removal and Mowing o    Temporary Highway Lighting 

o    Lump Sum Items o    Temporary Signalization and Detection 

o    Miscellaneous Drainage o    Traffic Monitoring Site Items 

o    Monitor Existing Structures 
 

Keep all summary box Excel files and any other quantity related files (PDF or output from other programs) 

in a directory named “calculations” under the root Project Directory. (Roadway and Structures subdirectories 

within the calculations folder may be used to help organize this directory. This is optional.) 

➢ Summary Box Exceptions 

• Component sets of plans currently using Tabulation of Quantities sheets will continue to do so with 

NO change in their workflow. 

• Summary of Drainage Structures Sheets will not change. Do NOT add Pay Items to these sheets. 
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LDM BASICS 

Access LDM through the FDOT Menu to create a link between the Summary Excel spreadsheet file and the 

MicroStation design (DGN) file for easy placement and updating of Summary Boxes. The LDM link provides 

easy access to the Excel spreadsheet for modification and update with a simple right-click on the link. 

Access LDM from the FDOT Menu by selecting Actions > Linked Data Manager. <OR> 

From the FDOT Plans Development > Quantities Tasks menu, select the Linked Data Manager icon.  

 

 

Note For more in-depth information on the features of this tool, refer to the LDM Help file or Posted Webinars. 
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CREATE SUMMARY BOXES FROM QUANTITY MANAGER 

LDM provides an automated option (Create New from Quantities) to create FDOT Summary Boxes that only 

need to be run once to generate an Excel file from Quantity Manager with all worksheets created and contained 

in a single file. 

1. Select Create New Link 

 

2. For the Source File, select Create New from Quantities. 

3. Select the Quantity Manager Database. 

4. Select Report Description/File Name for the desired Summary to create and click OK. 

 

5. Save the file in the project calculations folder. 

6. Place the Summary Box in MicroStation. 
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Exercise 6.1 Create New Summary Boxes from Quantities 

 Open the MicroStation file QTDSRD01.dgn. 

 On the FDOT Menu, select Actions > Create Files. 

 

 Confirm that the Project, Discipline, and File Group are as shown below, scroll down the File Type list, 

select SUMQRD Summary of Quantities Sheets.  Set county as shown and click Create – Open File. 

 

 Upon opening, click OK on the Set Plot Scale dialog, and then Close on the Create File dialog to close it. 

 From the FDOT Plans Development > Quantities Tasks menu, select the Linked Data Manager icon to 

open LDM. 
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 From LDM, select the Create new link button. 

 

 On the Link Information dialog, select the Create New from Quantities button. 

 

 From the Quantity Manager Summary Reports dialog, select the Quantity Manager Database. Click the 

Browse icon  and select the database file 22049555201AQT.mdb. 

 Check On the option to Force all text imported from database to be UPPER CASE. 

 Select the Summary of Pavement report from the list and click OK. 
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 Save the Summary_of_Pavement.xlsx Excel file to the project calculations folder. 

 On the Link Information dialog, the Source Path populates. Complete the dialog as shown below and click 

OK. 

 

 Data Point in the design file to place the Summary Box sheets. Notice that the Summary Box does not fit 

on the Plan sheet and the Pay Item description wraps on the line. 

    

 Right-click on one of the new links in the LDM dialog for the Summary of Pavement and select Open 

Source. Excel opens. 
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 Holding down the shift key in Excel, select Worksheets Box1 and then Box3 to select all the Summary Box 

worksheets. 

 Select the columns Length (I) and Width (J); right-click and select the popup menu option Hide to remove 

the columns selected from the display. Hide the Location Description column (F) as well. 

 

Note Delete or hide unused columns in a summary box from the worksheet. The only exceptions are the 
F quantity columns and the Construction Remarks column – DO NOT delete or hide these columns. 

 Right click on the Pay Item Description column (B) and select Column Width…change the column width 

to 95. Click OK. 

 

Note To correct the word wrap, the text may be broken up and placed in different rows instead of modifying 
the column width. Use spaces to create an indent on the second row of the description. Be sure to 
ungroup the worksheets before modifying individual cells or text. 
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 Right-click on the Worksheet tabs and select Ungroup Sheets. Save the file. 

 

 In MicroStation, use the shift key to select all the links to the Summary of Pavement Summary Box, 

right-click and select Update Now. 

 

  



Chapter 6 PLAN SUMMARY BOXES & LDM - Create New Summary Boxes from Quantities 

6-10 ©2019 FDOT  FDOT SS4 Automated Quantities 

CREATE SUMMARY BOXES FROM FDOT TEMPLATES 

LDM provides an option (Create New from Template) to create FDOT Summary Boxes using the FDOT templates 

provided in the FDOT CADD software. Access all the FDOT Summary Box templates in the Computation 

Summary Boxes group from the drop down. 

 

 For the Summary of Structure Quantities in the Structures workspace, place the Plan 
Sheet border at a scale of 12. Do NOT turn on the Use Drawing Scale option when creating a link.  
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Exercise 6.2 Create New Summary Boxes from Template 

This exercise creates the Summary Boxes from FDOT Templates and links to MicroStation using LDM. 

 From the FDOT Menu, select Actions > Sheets > Plan Sheet. 

 Data point in the design file to place the border. Place the cell using a scale of 1:1. 

 From LDM, click the Create Link button. Link Information dialog displays. 

 

 On the Link Information dialog, select Create New from Template. The Select FDOT Template dialog 

displays. 

 

 From the Select FDOT Template drop down, select Computation Summary Boxes. 
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 Select the Summary of Lump Sum Items and click OK. 

 On the Save As dialog, navigate to the 22049555201/calculations folder and click Save. 

 The Source Path populates on the Link Information dialog. Complete the dialog with the information 

shown below and click OK. 

 

 The Summary Box attaches to the cursor. Data point inside the Plan Sheet border to place the Summary 

Box. The link displays in the LDM dialog box. 
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 Right-click on the link in LDM and select the popup menu option Open Source. The 

Summary_of_Lump_Sum_Items.xlsx opens in Excel. 

 

 Complete the Summary Box with Mobilization pay item information as shown below. Save and Close the 

Excel file. 

 

Note If the Pay Item No. auto-corrects/drops the leading zero, you can set the Excel Number format to Text. 

 In MicroStation, right-click on the link in LDM. Select the option to Update Now. The Summary Box 

updates with the new information. 
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Exercise 6.3 Create Summary Box with LDM and CSV files 

This exercise creates a summary box using a LDM template and CSV files generated from Quantity Manager. 

 Continuing in the file SUMQRD01.dgn, place (or copy) a plan sheet border in the file. 

 From LDM, click the Create new link button. Link Information dialog displays. 

 

 On the Link Information dialog, select Create New from Template. The Select FDOT Template dialog 

displays. 

 

 From the Select FDOT Template drop down, select Computation Summary Boxes. 
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 Select the Summary of Clearing and Grubbing and Removal Items and click OK. 

 On the Save As dialog, navigate to the 22049555201/calculations folder and click Save. 

 The Source Path populates on the Link Information dialog. Complete the dialog with the information 

shown below and click OK. 

 

 The Summary Box attaches to the cursor. Data point inside the Plan Sheet border to place the Summary 

Box. The link displays in the LDM dialog box. 
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 Right-click on the link in LDM and select the popup menu option Open Source. The 

Summary_of_CG_and_Removal_Items.xlsx opens in Excel. 

 

 In Excel, select the Length and Width columns. Right-click and select Hide. 

 Open the file 0110_1_1.csv created in Exercise 5.5. 

 Copy the pay item number, pay item description, and units from the CSV and paste VALUES into the first 

row ONLY for the pay item in the Summary_of_CG_and_Removal_Items.xlsx. 

Note Since Clearing & Grubbing has primary units of LS and secondary Units of AC, the CSV file shows the 
units as AC. Be sure to enter the correct Units (LS) in the Units column of the Summary Box and enter 
the AC Area values in the Secondary Units column. 
 
Also, FDOT requires summary box data to be UPPERCASE. If the pay item description is copied from 
the CSV, it will need to be edited to change it to uppercase text. 

 

 Select the values in the CSV for the Begin Station, to, End Station. Right-click and select copy. 
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 In Summary_of_CG_and_Removal_Items.xlsx click in the cell C5 and select the option to Paste Values. 

 

 Continue copying and pasting the required values from the CSV file into the summary box template as 

shown below. Place a value of 1 in the total column since this is a LS pay item. 

 

Note If desired, use a formula in the Design Notes column totaling the number of acres for the Clearing & 
Grubbing. Ex. =SUM(K5:K14)&" TOTAL AC" 

 Open the file 0110_2_2.csv. 

 Type or copy in the Pay Item Number, Pay Item Description, and Units for 0110  2  2, Selective Clearing 

and Grubbing, Areas with Trees to Remain. 

 Copy and paste the required information from the CSV file into the summary box template. Place the area 

quantities in the Quantity (P) column. 

 In the total column, on the first row for the pay item include the formula for the total SY for the pay item. 

=SUM(L15:L24) 
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 Repeat steps 16-19 for 0110_4.csv. 

Note Due to the differences in precision required for the different units of measurement, the cell format number 
of decimal places in the Summary Box will need to be adjusted to the appropriate number of decimal 
places as indicated in the BOE, Chapter 2. 

 

 Delete or Hide rows 31 – 54. 

 Save the file Summary_of_Removal_Items.xlsx. 

 In MicroStation, select the link in LDM. Right-click and select Update Now. 

 Review the results in MicroStation. 

Note If word wrapping occurs, Open Source, adjust column widths, save and Update Now until the text fits in 
the column and Summary Box fits within the sheet border. If necessary, the Pay Item Description can be 
split into two lines. 
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HELPFUL INFORMATION 

❖ MicroStation commands will modify the elements drawn by LDM.  

o This is a ONE-WAY process. Make changes within LDM to the Source Excel File and then use the 

Update Now (right-click) option in LDM to update the design file. Changes made with MicroStation 

tools CANNOT update automatically to the Source Excel File within LDM. 

o Move Summary Boxes or Text linked in with LDM with MicroStation commands and LDM WILL 

remember the data and location. 

❖ Control formatting for FDOT Summary Boxes through the Excel Template Files created and delivered in the 

FDOT CADD software, NOT within MicroStation. Use LDM to access those Excel Template Files to 

populate and make modifications. 

o Within the FDOT Summary Box Excel templates, columns and rows may be adjusted or hidden 

with changes reflected in MicroStation when updating links. 

o Within the FDOT Summary Box Excel templates, delete any column when not used. 

EXCEPTION: DO NOT delete the “Construction Remarks” or “F” columns. 

o DO NOT add columns for additional information, i.e. Sheet Number. The Summary Box format is 

defined in the BOE and should not be modified. Contact Kandi Daffin or Melissa Hollis if there is 

justification for modifications to the forms. 

o Most of the FDOT Summary Box Excel templates have been set up to fit on a Plan sheet. 

DO NOT add rows. Copy the Worksheet as needed to create additional Summary Box Worksheets. 

❖ FDOT requires only one Source Excel File for each Summary Box type in FDOT Plans. 

❖ Use Quantity Manager CSV Reports to help populate the Summary Boxes not automated. 

Be sure to Paste using Values only to preserve the cell formatting in Excel. 

❖ Expect to encounter Word wrapping when placing the Summary Box in MicroStation even though the text 

displays on a single line in Excel. This is due in part because of a variable for a buffer in LDM that keeps the 

text from overlapping the column lines when placed in MicroStation. Make additional adjustments to the 

column widths in Excel as needed. 

❖ As shown in the example shown below, the Pay Item No, Description, Unit and Quantity Total is shown only 

on the first line for each Pay Item. 

 

❖ Place all Summary Boxes with quantities on the designated Summary of Quantities sheets, not scattered 

within other areas of the Plans, i.e. Traffic Control Plan items, Earthwork, Bridge sheets, etc. 

o Place Summary Boxes in the Summary of Quantities sheets as close as possible to numerical order. 

See Chapter 8 of the Basis of Estimates Manual posted on the Estimates website. 

❖ If backup information for the quantity is in the GEOPAK GPK file, FDOT requires NO Printout. 

❖ (Optional) Include Formulas in the Summary Boxes in the Design Notes column, if desired. 

o Formulas or Notes can be stored in the Back Up spreadsheet available in each of the Summary Box 

Excel files. 
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7 SUMMARY OF PAY ITEMS WORKFLOW 

OBJECTIVES 

• Review the workflow for generating the Summary of Pay Items for Plans 

• Export data from Quantity Manager 

• Import to Designer Interface 

• Generate Summary of Pay Items report from AASHTOWare Project Webgate Reporting 

• Create Summary of Pay Items sheets using FDOT TRNS*port tool 

SUMMARY OF PAY ITEMS WORKFLOW 

The Summary of Pay Items sheet is a required sheet in the plans. It contains the output from AASHTOWare 

Project Preconstruction (PrP) of all the pay items and quantities loaded for the project.  

To get the quantity information to PrP, an XML file generated from the Quantity Manager Export function imports 

the quantities to Designer Interface. The Designer Interface is a user-friendly interface to PrP. Additional 

quantities can be manually added, modified and deleted using Designer Interface.  

Once the quantities are loaded, access AASHTOWare Project Webgate Reporting to generate the Summary of 

Pay Items Report. This report for CADD is an XML file used by the FDOT TRNS*port tool to create Summary 

of Pay Item sheets. 

EXPORT 

Quantity Manager includes a utility that facilitates exporting various database information. The format of this 

information is in .XML format that Designer Interface can import.  

ACCESSING EXPORT 

From the Quantity Manager menu, select Project > Export > Export. Export dialog displays. 
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Active Trns*port Groupings Only a single Trns*port Grouping may be exported at one time. If All 

Trns*port Groupings are selected, the Export icon is disabled. 

Export Style • Pay item (Bentley QM XML) 

• Pay item + Funding (Bentley QM XML) 

• Pay item + Quantity (Bentley QM XML 2) 

• Pay item + Quantity (Bentley QM XML)  

• Pay item + Quantity + Element (Bentley QM XML) 

• Pay item + Quantity + Element Sorted (Bentley QM XML)  

• Pay item + Quantity Sorted (Bentley QM XML)  

• aecXML 

• aecXML + Funding (This is the option used for FDOT projects.) 

Rename Trns*port 

Groupings As 

This option renames the XML tag “costType”. For FDOT projects, 

toggle this option on and set to DesignEstimate. It does not change the 

Trns*port Grouping (GroupId tag) value set for the quantity. 

Document Type aecXML Infrastructure v33 is the standard schema used for creating 

custom reports.  

Document File Name The file name including directory path to which the report will export. If 

the directory path is not defined, the file will be saved to the working 

directory. 

Export Only Selected 

Quantities 

Option to export only selected pay items/quantities into the report. 

Only the items displayed in the Quantity Manager Pay Item Quantity pane export. The Quantity Manager Export 

XML file is used for the Designer Interface “import” option which will add/update the Pay Items, their Quantities 

and add Project Categories into AASHTOWare Project Preconstruction. 
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EXPORTING DATA TO XML FILE 

➢ To export quantity data from Quantity Manager. 

1. Set the Trns*port Groupings to the desired group. 

2. In the Quantity Manager Pay Item Table pane, select the root folder and expand all the categories. 

Use CTL+A to select all the pay items. Only the Pay Items included in the active Trns*port 

Grouping will be exported. 

 

3. From the Quantity Manager menu, select Project > Export >Export. Export displays. 

4. In the Export Style box, select aecXML + Funding. 

5. Check On the Rename Trns*port Groupings As box and enter DesignEstimate. 

6. In the Document File Name, enter quantity.xml. 

 

7. Click the Export button. 

8. An Information dialog displays. This is normal and not an error. Click OK. Another Information 

dialog then displays with the export completed successfully message. Click OK. 
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9. Navigate to the Quantity.xml file just created and review. 

 

Note The rounding for the pay items are to 1 decimal place farther than the unit requirements in the BOE. (See 
Chapter 2 of the BOE.) FDOT has developed the XML Quantity Rounder tool to round the values 
in the xml exported by Quantity Manager to the correct decimal place for importing in Designer 
Interface. Incorrect accuracy generates errors when importing. 

10. Close the XML file. 

11. On the FDOT Plans Development > Quantities Tasks menu, select Quantity Rounder. 
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12. On the XML Quantity Rounder tool, click on Process XML File. 

 

13. Navigate to the quantity.xml file and select Open. 

14. An Information alert pops up when the process is finished. Click OK. 

15. Click on Finished – Exit Application to close XML Quantity Rounder tool. 

16. Open the new file, quantity_rounded.xml, and review. 
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IMPORT QUANTITIES IN DESIGNER INTERFACE  

This process imports the XML file saved from the Quantity Manager Export function and processed through the 

XML Quantity Rounder. The XML file should contain the Project Pay Items, Quantities and the Project 

Categories to which the Pay Items apply.  

Note Update/Import will only occur if no errors exist in the XML file. 

➢ To Import Quantities in Designer Interface 

1. Select appropriate Project Number from Designer Interface for the same Project you performed 

the Quantity Manager Export function. 

2. Click the IMPORT link. 

 

3. Click the Select files… icon to browse to and select the quantity_rounded.xml file saved from the 

XML Quantity Rounder tool. 

 

4. Click the UPLOAD file button to process the XML file. 

5. Other updates may be required using Designer Interface once the Pay Items and Quantities import 

(i.e. mark item non-participating, structure info …) 
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6. If errors exist, a Data Validation Error page will show (red highlighted title below) listing all errors 

in the XML file. It is required to correct all errors in Quantity Manager, re-export, re-process and 

then re-import into Designer Interface before applying any updates/additions to the Designer 

Interface database. There are Error Number links to Help Messages to assist in error corrections. 

 

Note If there is a Trns*port Grouping in Quantity Manager for DesignEstimate, this will cause the error 
shown above. This Trns*port Grouping must be deleted from Quantity Manager before exporting the 
quantities. Go to the Pay Item Table view of the Pay Item pane. Select the Trns*port Grouping 
DesignEstimate. You must correct any quantities that are associated with this grouping before it can be 
deleted. Highlight the pay items (one at a time) and then select all the quantities in the Quantities pane. 
Right-click, select edit, and correct the Trns*port Grouping value. Repeat this process for all the pay items 
with quantities under DesignEstimate. Once they are all corrected, go to the menu Edit > Trns*port 
Groupings. Select DesignEstimate from the list and select Delete. Re-export the XML file, process the 
Quantity Rounder tool and import the new file into Designer Interface. 

7. If no errors exist, you will get a Project Load Log Message page (green highlighted title below), 

listing all updates or inserts performed in Designer Interface for the project. 
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GENERATE REPORTS 

Once the pay items and quantities are loaded, either through the import process or manually in Designer Interface, 

the next step is to run the Project Edit and Summary of Pay Items reports from AASHTOWare Project Webgate 

Reporting. 

ACCESS AASHTOWARE PROJECT WEBGATE REPORTING 

Access the AASHTOWare Project Webgate Reporting through the Web Gate site which is opened from the FDOT 

Menu option: Actions > AASHTOWare Project Preconstruction (TRNS*port) > Web Gate Website <OR> 

from the Open Web Gate icon on the FDOT Plans Development > Quantities Tasks menu. 

 

 

On the Web Gate page, select the link AASHTOWare Project Webgate Reporting Login. 

Note To login, an FDOT RACF User ID is required. 
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GENERATE SUMMARY OF PAY ITEMS REPORT 

Many reports are available within Webgate Reporting. There are two reports important for designer to run for this 

process: 

❖ Project Edit Report, found under Designers, Estimators, and Reviewers, identifies any errors with the pay 

items loaded on the project. It also identifies pay items that require extra documentation such as a Technical 

Special Provision (TSP). 

 

❖ Summary of Pay Items, found under General Reports, is used by CADD to generate the Summary of Pay 

Items sheet. 
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➢ Generate the Summary of Pay Items Report 

1. Select the Project from the drop-down list. 

2. Click on the Auto-Generate Proposal Sections. (This process regenerates the section and line 

numbers for the proposal. It corrects any errors that may result from adding/updating/deleting any 

pay items or quantities for the project.) 

3. Select the Report Type CADD File to generate the XML file needed in the CADD Software. 

 

4. Click Submit. 

5. When the option pops up at the bottom of the page, click on the drop-down and select Save As. 

(This may take some time depending on the size of the project and the internet connection speed.) 

 

6. Save the XML file to the project directory. 

7. Logout of the AASHTOWare Project Webgate Reporting site. 
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CREATE THE SUMMARY OF PAY ITEMS SHEET 

FDOT has an application, FDOT TRNS*port, that will import the data from the Summary of Pay Items Report 

XML file to create the Summary of Pay Items sheet(s) that are required with the lead component of the project. 

To access the FDOT TRNS*port tool, on the FDOT Menu select Actions > AASHTOWare Project 

Preconstruction (TRNS*port) > FDOT TRNS*port <OR> click on the Import Pay Item Summaries icon on 

the FDOT Plans Development > Quantities Tasks menu. 
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➢ Create the Summary of Pay Items Sheet 

1. On the FDOT Menu, select Actions > Create File to open the Create File tool. 

2. In the ROADWAY > Roadway Files file group, select the Summary of Pay Items Sheets. Verify 

the Project and Output settings are correct, then click Create-Open File. 

 

3. Set the Plot Scale to 1.0 on the Set/Update Plot Scale dialog box. 

 

4. Click Close to close Create File dialog box. 

5. Open the FDOT TRNS*port tool (Import Pay Item Summaries). 
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6. Click Browse to select the report XML file generated from the Webgate Reporting site. 

7. Toggle On Label Sheet. 

8. Complete the information. (By default, the fields - Sheet Title: Summary of Pay Items, and 

Number: 2, are populated.) 

 

9. Click Load Summary of Pay Items. 

Note If the Load Summary of Pay Items button does not appear on the dialog box, click on the bottom right 
corner of the dialog to re-size it. 

10. Finished loading Pay Items displays. Click OK. 

 

11. Fit view in the MicroStation CESSRD01.dgn file to view the Summary of Pay Items tables. 

12. Save settings. Close MicroStation. 
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